Little Navmap User Manual
Little Navmap is a free open source flight planner, navigation tool, moving map, airport search and
airport information system for Flight Simulator X, Flight Simulator - Steam Edition, Prepar3D v2 to
v5, Microsoft Flight Simulator 2020 and X-Plane 11.
More about my projects at www.littlenavmap.org [https://www.littlenavmap.org]. Support forum at
AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/].
You can get the latest version of this manual in different formats from here: User Manuals
[https://albar965.github.io/manuals.html]

Do not use this program for real world navigation.
This user manual is for Little Navmap versions 2.6.
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3. Installation
Little Navmap for Windows is a 32-bit application and was tested with Windows 7, Windows 8,
Windows 10 (32-bit and 64-bit).
macOS is supported up from macOS Sierra 10.12 inclusive.
The Linux version was built on Ubuntu but should work on other distributions as well.
The macOS and Linux versions are both 64-bit.
Each version of Little Navmap and the other programs come with a plain text file CHANGELOG.txt which
has important notes and describes the changes between versions.
3.1. Updating
Delete all installed files of a previous Little Navmap version before installing a new version or install
into a new folder. All files from the previous ZIP archive can be deleted since settings are stored in
separate directories (except Creating Map Themes).
Warning
In any case do not merge the installation directories since old files can cause trouble.
There is no need to delete the old settings directory. The program is written in a way that it can
work with old setting files and adapts these if needed. In some cases settings are reset to default
once an updated version is installed.
3.2. Windows
The installation of Little Navmap does not change or create any registry entries in Windows and
involves a simple copy of files therefore an installer or setup program is not required.
Warning
Do not extract the archive into the directory c:\Program Files\ or c:\Program Files (x86)\ since this
requires administrative privileges. Windows keeps control of these directories, therefore other
problems might occur like replaced or deleted files.
There is usually no need to run Little Navmap as administrator. Adapt folder permissions if you
have to export flight plans to protected places.
Extract the Zip archive into a directory like c:\Users\YOURNAME\Documents\Little Navmap or
c:\Users\YOURNAME\Programs\Little Navmap. Then start the program by double-clicking littlenavmap.exe.
The extension .exe might be hidden in Windows Explorer depending on settings. In that case look
for a file littlenavmap having a light blue globe icon.
You can install the Visual C++ Runtime Installer (All-In-One) v56
[https://www.majorgeeks.com/files/details/visual_c_runtime_installer.html] package from MajorGeeks.Com but this is
only needed if you get errors when starting Little Navmap.
3.2.1. SimConnect
Little Navmap comes with a SimConnect library version 10.0.61259.0 (FSX SP2 / no Acceleration)
and does not require a separate installation of SimConnect.
The included SimConnect library is compatible with all FSX and P3D versions as well as Microsoft
Flight Simulator 2020.
3.2.2. Unblock Application
Depending on system and anti-virus settings it might be needed to unblock the executable files.
This applies to Little Navmap (littlenavmap.exe), Little Navconnect (littleconnect.exe) and the Little
Xpconnect plugin (win.xpl).

You can do this in the Windows explorer by selecting properties and checking Unblock file. Detailed
instruction can be found here, for example: How to Unblock a File in Windows 10
[https://mywindowshub.com/how-to-unblock-a-file-in-windows-10/].
3.2.3. Improve Start-up Time
Anti-virus programs can significantly slow down the startup and execution of the program in
Windows.
Therefore, it is recommended to exclude the following directories from scanning:
Disk cache for map tiles: C:\Users\YOURUSERNAME\AppData\Local\.marble\data
Scenery library and userpoint
databasesC:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_db
These directories do not contain executable files and are accessed frequently by Little Navmap.
3.3. macOS
Extract the ZIP file and copy the Little Navmap application to the directory Applications or any other
directory.
Note
The menu entry which is referenced as Tools -> Options in this manual for Windows and Linux can
be found in the application menu at Little Navmap -> Preferences on macOS.
3.3.1. First Start on macOS
Note on first start on macOS: When starting the application you will get a message Little Navmap is
from an unidentified developer. Are you sure you want to open it?.
The procedure may be slightly different depending on whether you’re using Big Sur or Catalina.
1. Right or Ctrl-Click in the Finder on Little Navmap and select Open.
2. You will see a dialog Little Navmap cannot be opened because it is from an unidentified developer.
Click Ok.
3. Go to System Preferences -> Security and Privacy. You will see a message mentioning Little
Navmap. Click Open Anyway.
4. Next a dialog Are you sure you want to open it? pops up. Click Open.
3.3.2. Clearing the Quarantine Flag for Little Xpconnect on macOS
You have to remove the quarantine flag from the plugin after downloading and extracting it.
Otherwise X-Plane will silently not load the plugin.
The procedure may be slightly different depending on whether you’re using Big Sur or Catalina.
1. Copy the whole plugin folder Little Xpconnect into the folder plugins in Resources in the X-Plane
installation. The complete path should look like .../X-Plane 11/Resources/plugins/Little
Xpconnect.
2. Right or Ctrl-Click in the Finder on the included script Prepare Little Xpconnect.command in the
folder .../plugins/Little Xpconnect and select Open With and Terminal.
3. You will see a dialog Prepare Little Xpconnect.command cannot be opened because it is from an
unidentified developer. Click Ok.
4. Go to System Preferences -> Security and Privacy. You will see a message mentioning the script
Prepare Little Xpconnect.command. Click Open Anyway.
5. Next a dialog Are you sure you want to open it? pops up. Click Open.
The script shows a few explantions and asks for your password which allows it to run a command
as an administrator. You can look at the script which is a text file to see what commands are
executed.
The Little Xpconnect installation was successful if you can see it in the X-Plane plugin manager.
You have to repeat this procedure each time you update Little Xpconnect.

3.4. Linux
Extract the archive to any place and run the executable file littlenavmap to start the program from a
terminal:
./littlenavmap

Most file managers will start the program if double-clicked.
A desktop file Little Navmap.desktop is included. You have to adjust the paths to use it. You must use
absolute paths in the desktop file.
If the program does not start run the command:
ldd littlenavmap

and send me the output. This shows which shared libraries might be missing.
3.5. X-Plane Plugin
Little Navmap can only connect to X-Plane using the Little Xpconnect X-Plane plugin which has to
be installed as well.
The Little Xpconnect plugin is included in the Little Navmap archive but can also be downloaded
separately.
The plugin is 64-bit only and is available for Windows, macOS and Linux.
Delete any old Little Xpconnect installations in the plugins directory before copying the new
version. Do not merge new and old installations.
Copy the whole plugin directory Little Xpconnect into the directory plugins in the directory Resources
in the X-Plane installation. The complete path should look like:
.../X-Plane 11/Resources/plugins/Little Xpconnect

The installation was successful if Little Xpconnect shows up in the plugin manager.
Note that Little Xpconnect does not add menu items in the X-Plane Plugins menu.
When connecting with Little Navmap select the tab X-Plane in the connection dialog. See also Flight
Simulator Connection.
3.6. Additional Programs
The Little Navmap Zip archive contains two additional folders:
Little Navconnect:

A complete copy of the program allowing remote flight simulator connections for
FSX, P3D, MSFS and X-Plane.
Little Xpconnect:

This is the 64-bit plugin that is needed for Little Navmap or Little Navconnect to
connect to X-Plane.
3.7. Multiple Installations
Do not run more than one Little Navmap instances using the same settings folder in parallel. This
can result in crashes when accessing the databases. Running several instances is prevented by the
program on Windows but not on Linux and macOS.
You can instruct Little Navmap to create and use a different settings folder by passing the
parameter --settings-directory to the executable when starting up. This is supported for all
operating systems.
This parameter instructs the program to use the given directory instead of ABarthel and allows to
have two instances of Little Navmap running with their own settings and databases.
Note that this does not override the full path and spaces are replaced with underscores.
Example:

How to use C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel-XP as a settings folder on Windows:
1. Right click on the littlenavmap.exe file (extension might be hidden in Windows explorer) and
select Create Shortcut.
2. Right click on the newly created shortcut and edit the shortcut properties.
3. Append --settings-directory ABarthel-XP to the path in the settings field separated by a space
before --settings-directory.
4. Click Ok.

Contents of the link properties dialog for the example above. Extended target folder input field to have the whole path visible.

4. Quick Overview

A quick overview of Little Navmap showing the most important functions.

The most important context menus which are can be used to build a flight plan, navigate the map or show information. Image based on
Little Navmap 2.4.5.

Where to get help and more information. Tooltips, status bar and help buttons marked red. Image based on Little Navmap 2.4.5.

5. Start
This page opens automatically in your browser after updating or first installation of Little Navmap.
This is a part of the Little Navmap online manual.
It gives valuable links and information for first time users and provides a list of first steps. The next
chapter Introduction explains more details for all these. See also Installation.
Tip
Explore the chapters on the left side of this page or use the search function on the top left.
5.1. First Steps
Little Navmap shows various dialogs on first start to give hints for better usage. You can dismiss
these dialogs for future starts by pressing Do not show again but keep at least the message in mind.
1. You have to load the scenery library first to see the airports of your simulator. Go to main
menu Scenery Library and select Load Scenery Library. Select your simulator and click Load.
Also have a look at Scenery Library Menu, Load Scenery Library and Navigation Databases
about the different scenery library modes which can be selected in the menu.
2. Build a flight plan. Right click into the map on an airport and select departure ( Set as
Departure), destination ( Set as Destination) and intermediate waypoints ( Add Position to
Flight Plan and Append Position to Flight Plan) from the context menu.
3. Save the flight plan into Little Navmap’s own format LNMPLN by clicking Save Flight Plan.
This file format is only for Little Navmap and allows to keep all flight plan features like
remarks, user defined approaches and more. Do not try to load it into simulators or other
tools.
4. Configure the flight plan export in menu File -> Multiexport Flight Plan Options. Select
desired formats by clicking one or more checkboxes on the left and adapt the paths and
filenames for export. See Flight Plan Multiexport.
5. Select File -> Multiexport Flight Plan to export your flight plan for simulator, tools or aircraft.
6. Connect Little Navmap to your flight simulator. Go to main menu Tools -> Flight Simulator
Connection, choose your simulator and click Connect. See Connecting to a Flight Simulator for
more information.
7. You probably see a few warning messages in Little Navmap about missing aircraft
performance information. Ignore these for now.
See in the menu Help -> Tutorials if you’re new to Little Navmap.
See here Tutorial - Creating an Aircraft Performance Profile for an tutorial which shows how to
create your own aircarft performance files or download one here: Little Navmap Downloads Aircraft Performance [https://www.littlenavmap.org/downloads/Aircraft%20Performance/].
See Network Setup on information how to set up a remote/networked connection.
5.2. Useful Links
Little Navmap Downloads - Aircraft Performance and more [https://www.littlenavmap.org/downloads/].
Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html].
New Maps for Little Navmap at Avsim [https://www.avsim.com/forums/topic/548994-new-maps-for-lnm/].
More about my projects at www.littlenavmap.org [https://www.littlenavmap.org].
Support forum at AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-supportforum/].
The sources of this manual are available on Github [https://github.com/albar965/littlenavmap-manual].

6. Introduction
This chapter gives a brief overview of the most important topics with links to the more detailed
chapters.
Little Navmap shows several dialogs and a web page on first startup to give hints about usage and
other useful information. Once read you can disable these dialogs by clicking on Do not show this
dialog again.
6.1. Creating Recommended Directories for Files
The program suggests to create a recommended directory structure on startup. You can choose to
ignore this and save your Little Navmap files in arbitrary places. The program does not require a
fixed directory structure for its files.
See Directories for more information.
6.2. Loading the Scenery Database
Little Navmap will copy and prepare the included Navigraph database on the first startup.
Load Scenery Library will be shown once the preparation is finished. From there you can select all
recognized Flight Simulators and load their scenery libraries into the database of Little Navmap.
An Empty Database indication is shown in the statusbar if you skip this step. You will not be able to
build flight plans for your simulator.
Note that you have to reload the database to see changes when adding add-on airports.
Note
X-Plane cannot be always recognized automatically. You might have to set the path in the dialog
Load Scenery Library before you can load the database.
One database is kept for each simulator and can be changed on the fly in Scenery Library Menu.
You can load the scenery library database later by going to the menu item Load Scenery Library in
the menu Scenery Library.
Scenery library databases may need to be updated when you install a new version of Little
Navmap. A question dialog will pop up prompting you to erase the now incompatible database. You
can reload the scenery in Load Scenery Library after erasing the databases.
Note
Selecting the right scenery library for the simulator while flying is crucial since the selection also
affects other functions of Little Navmap. The selected scenery library defines which weather files
are read, for example.
6.3. Connecting to a Simulator
Once you close the Load Scenery Library the dialog Connecting to a Flight Simulator will be shown
to connect to a running flight simulator.
See Connecting to a Flight Simulator for the next step to use Little Navmap as a moving map. The
included Little Xpconnect plugin has to be installed for X-Plane.
6.4. Recommended things to do after Installing
The elevation data which is used by default is limited and has a lot of problems. Therefore, I
recommend to download and use the offline GLOBE elevation data. See Install GLOBE
elevation data for more information.
Have a look at Tutorials if you use the program the first time.
See Install Navigraph Updates [https://albar965.github.io/littlenavmap_navigraph.html] on my home page
for information how to update Little Navmap’s navigation data.

6.5. How to run a Network Setup
The remote computer does not need a simulator installation and there is no need to share the
scenery library of the simulator.
See Network Setup on information how to set up a remote/networked connection.
6.6. User Interface
6.6.1. Dock Windows and Tabs
See the chapters Dock Windows and Tabs for more information on these elements.
6.6.2. Context Menus
Context menus are an important element to build flight plans or get information and can be found
in the following places:
Map display window: Context Menu Map
Flight plan table: Context Menu Flight Plan
Airport, navaid and other search result tables: Context Menu Search
Procedure search tree: Context Menu Procedures
Elevation Profile: Context Menu Elevation Profile
Multiexport Flight Plan Options: Flight Plan Multiexport.
The context menus provide functionality to get more information about an object at the clicked
position or to build or edit a flight plan.
6.6.3. Tooltip Help, Help Buttons and Help Menu
The help menu of Little Navmap contains links to the online help, an included offline help PDF
document, online tutorials and the map legend.
The program uses tooltips to provide help or to display more information on buttons and other
controls. Tooltips are small labels which pop up if you hover the mouse above a control like a
button or text edit field.
A more detailed description is also shown on the left side of the statusbar if you hover the mouse
over a menu item.

Almost all dialogs and dock windows have buttons which are labeled Help or use the icon
Clicking these will open the corresponding sections of the online manual.

.

6.6.4. Window Title
The main window title shows the application name and version.
Furthermore, it indicates the currently selected simulator database (FSX, FSXSE, P3DV2, P3DV3, P3DV4,
P3DV5, MSFS or XP11), the flight plan file name, the aircraft performance file name with trailing * for
both if either has changed.
The AIRAC cycle is shown as a four digit number after the simulator and Navigraph database
indication if available and if a database is selected.
The AIRAC cycle is only shown for X-Plane and the Navigraph database. Other simulators do not
provide cycle information in their scenery libraries.
A N will be appended if the Navigraph database is used. Otherwise (N) is used. Example below for
Prepar3D:
P3DV5 / (N):

All features on the map and all information in dialogs and windows come from
the flight simulator database. Navdata might be limited depending on simulator.
P3DV5 / N: Airports and ILS are shown and used from the flight simulator database. Navaids,
airways and procedures are used from the Navigraph database.
(P3DV5) / N: All data is used from the Navigraph database. No aprons, no taxiways and no
parking positions are available for airports.
See Scenery Library Menu, Load Scenery Library and Navigation Databases for more information.

Examples: Little Navmap 2.6.8 - XP11 2001 / N 2011 LOAG_LOWW.lnmpln * - PA30 Twin Comanche.lnmperf
Version 2.6.8, X-Plane selected with AIRAC cycle 2001, Navigraph database in use with AIRAC cycle
2011, flight plan LOAG_LOWW.lnmpln changed and performance profile PA30 Twin Comanche.lnmperf
unchanged.
Little Navmap 2.6.4.beta - (XP11) / N 2012 IFR Frankfurt Am Main (EDDF) to Fiumicino (LIRF).lnmpln - PA30
Twin Comanche.lnmperf *

Version 2.6.4.beta (a test version), X-Plane not selected - using Navigraph only, Navigraph
database in use with AIRAC cycle 2012, flight plan unchanged and performance profile PA30 Twin
Comanche.lnmperf changed.
Little Navmap 2.6.5.rc1 - XP11 2012 / (N) - *

Version 2.6.5.rc1 (a release candidate), X-Plane selected, not using Navigraph, no flight plan
loaded and new and empty default performance profile loaded.
6.6.5. Information and Simulator Aircraft Text
You can change the text size permanently in the options dialog for these windows. See options
dialog on page Display and Text.
This page also allows to change the font for the whole program interface.
Tip
A quick way to change the text size is to use the mouse wheel and Ctrl key. This setting won’t be
saved across sessions, though.
6.6.6. Error Messages
Little Navmap shows error messages with white text on red background for problems with the
aircraft performance, top of descent/climb calculation or other issues.
Tooltips on these error messages give more help in most cases. Click these messages or hover the
mouse cursor above to see more information.
6.6.7. Activating and raising Windows and Tabs
Little Navmap opens and raises dock windows and tabs for certain actions like File -> New Flight
Plan or Aircraft -> Open Aircraft Performance ... to avoid confusion for new users. This behavior can
be disabled in the options dialog on tab User Interface by disabling the option Raise related windows on
actions.
6.6.8. Copy and Paste
Almost all dialogs, text labels and all information windows in Little Navmap allow to copy and paste
the formatted text to the clipboard.
You can select the text using the mouse and then either use Ctrl+C or the context menu to copy it
to the clipboard.
The table views for the flight plan or airport/navaid search results allow copying of the results in
CSV format to the clipboard which can be pasted into a spreadsheet program like LibreOffice Calc
[https://www.libreoffice.org] or Microsoft Excel.
6.6.9. Translation and Locale
Little Navmap is currently available in several languages, although not all translations are
complete.
Your system language is used if supported. Otherwise Little Navmap falls back to English. The
language for the user interface can be change in Options on page User Interface.
I will happily support anybody who would like to translate the user interface or manual into another
language. Language packages can be added to a Little Navmap installation later once they are

available. See Translating [https://github.com/albar965/littlenavmap/wiki/Translating] in the GitHub Little Navmap
wiki for more information.
Despite using the English language in the user interface the locale settings of the operating system
will be used. So, e.g. on a German version of Windows you will see comma as a decimal separator
instead of the English dot.
The language and locale settings can be forced to English in the dialog Options on the page User
Interface.
6.6.10. Map Legend
The legend explains all the map icons and the Flight Plan Elevation Profile icons. It is available in
Legend.
6.6.11. Rating
Airports get a zero to five star rating depending on facilities. Airports that have no rating will be
displayed using a gray symbol below all other airports on the map (Empty Airport). This behavior can
be switched off in the Options dialog on the page Map.
This helps to avoid airports with no scenery elements.
The criteria below are used to calculate the rating. Each item gives one star:
1.
2.
3.
4.
5.

Add-on (or 3D for X-Plane)
Parking positions (ramp or gate)
Taxiways
Aprons
Tower building (only if at least one of the other conditions is met).

All airports that are not located in the default Scenery directory of FSX/P3D or are located in the
Custom Scenery directory of X-Plane are considered add-on airports which raises the rating by one
star.
Airports having the 3D label in X-Plane are 3D airports which raises the rating by one star too.
Star airports in Microsoft Flight Simulator 2020 will always get a five star rating.
Add-on airports are highlighted on the map with a yellow ring which can be disabled in the options
dialog on page Map Display.
Using emphasized (bold and underlined) text highlights add-on airports in the search result table,
flight plan table, information windows and map tooltips.
6.7. Navdata Updates
Little Navmap comes with a ready to use navigation database courtesy of Navigraph
[https://www.navigraph.com] which includes airspaces, SIDs, STARs and more. The database can be
updated by using Navigraph’s FMS Data Manager.
See the chapter Navigation Databases for more information.
Warning
In any case close Little Navmap when updating, copying or replacing scenery databases. Little
Navmap might crash or show wrong data otherwise.
6.7.1. FSX, Prepar3D and Microsoft Flight Simulator 2020
Little Navmap is compatible with navdata updates from fsAerodata [https://www.fsaerodata.com], the
FSX/P3D Navaids update [http://www.aero.sors.fr/navaids3.html] and the Navigraph beta update for Microsoft
Flight Simulator 2020 (support forum: Beta Testing for Microsoft Flight Simulator 2020
[https://forum.navigraph.com/viewforum.php?f=14]).
6.7.2. X-Plane
Little Navmap will use navdata updates that are installed in the directory Custom Data.

Older updates installed in the GPS directories are not used.
User-defined data from the files user_fix.dat and user_nav.dat is read and merged into the database if
found.
Note that neither ARINC nor the FAACIFP files are supported.

7. Dock Windows
The user interface of Little Navmap consists of a main window and several dock windows which can
be detached from the main window or arranged within the main window.
The docked windows can be moved around in their docked position and can be detached from the
main window by simply dragging them outside of the main window (click the title bar to drag), by
double-clicking their title bar or by clicking on the window symbol on the top right.
Double click on the docked window’s title bar or click on the window symbol again to move the
windows back into their docked position in the main window.
All docked windows, except the map window, can be closed if they are not needed. You can also
drop docked windows on each other to create a tabbed view. The tabs will appear at the bottom of
the dock stack in this case.
Note that dock windows open automatically when selecting functions like Show Information or clicking
on the user aircraft, for example.
You can save and load dock window layouts in the Window menu. See also Window Layout for details.
More dock window related settings like auto activation on mouse overr can be found in the options
on page User Interface.
Tip
Hold Ctrl while clicking on the window title bar to prevent a window from going back into the
docked state in the main window and keep it floating.
You can also deselect Window -> Allow Window docking in the main menu to prevent the dock
windows from snapping back into the main window.
Toolbars are also movable by clicking on the left handle and can also be closed or detached from
the main window similar to the dock windows. Toolbars can also be opened and closed in the main
menu Window.

Cursor above the toolbar handle that has to be clicked to move or to undock the toolbar.

Note
Use the Window menu in the in the main menu to save, load or restore closed windows, toolbars
and tabs.
The Window -> Reset Window Layout menu item in the main menu can be used to reset the state and
positions of all dock windows and toolbars back to their default. This also resets the tab visibility
and order back to default.

Title bar of a dock window marked red.

Moving a dock window around. The blue background opens to indicate a space in the main window where the dock can be dropped in.

Dock window in floating state detached from main window.

Dropping a dock window on another to create a stack.

A stack of two dock windows. The tab bar is marked red at the bottom of the stacked dock windows.

Note
You must click on the title bar of a window to remove it from the stack, not on the tab bar.

8. Tabs
The dock windows Flight Planning, Information, Simulator Aircraft and Search have tab bars that allow
to close, open and move tabs.
Tooltips give more information about the function of a tab.
Note that you cannot move a tab to another window.
The Window -> Reset Window Layout menu item in the main menu also resets the tab visibility and
order to default.
8.1. Context Menu Tabbar
The context menu above the tab bar (right click on one of the tabs) and the tab button
the following menu items:
Open All:

have

Opens all tabs. All closed tabs are opened again and added to the right side of the

tab bar.

Close all Except Current:

All tabs are closed except the currently active.
Opens all closed tabs again and restores the default order.
Lock Tab Layout: Hides the close buttons to avoid accidental closing. Moving by click and drag
as well as closing by double click are disabled. A locked tab bar also occupies less space. You
can still close and open tabs using the context menu or menu button.
Close Tab: Only visible in the context menu. Closes the tab below the click spot.
One menu item for each tab: Toggles tab visibility. A tab is always opened to the right of the
current one.
Reset Tab Layout:

8.2. Mouse actions
Click and drag a tab to move it.
Double click a tab to close it.
Right click a tab to open the context menu.
Use the mouse wheel above a tab bar to cycle between tabs.
8.3. Stacked Dock Window Tabs
Tabs at the bottom of a window appear when you drop dock windows on each other. Grab a window
title bar to move a window out of the stacked display. You can also change the order of these tabs
by dragging them around.
See Dock Windows for more information about stacked dock windows.

Drop down button menus and context menus on tab bars marked red.

9. Menus and Toolbars
This chapter describes all the menu items of Little Navmap. You will find most of this functionality
on the toolbars as well which are not be described separately. Keyboard shortcuts can be seen on
the menu items. See Keyboard Shortcuts.

Menu and toolbars docked in default positions.

9.1. Tear off Dropdown Menus
Toolbar buttons and the drop down menu button the Flight Plan Route Description allow to tear of
the menu by clicking on the dashed line on top of it.
This will move the menu into a separate window and allows to quickly change several options at
once.
The state of the tear off menus is not saved.

The drop down menu button for the userpoint categories for map display and how the menu can be teared off into its own window.

9.2. File Menu

9.2.1.

New Flight Plan

Erases the current flight plan and shows the flight plan table.
You have to use Context Menu Search, Context Menu Map or Flight Plan Route Description dialog to
create a new flight plan.

9.2.2.

Open Flight Plan

Opens a flight plan with one of the following formats:
LNMPLN. This is the default format of Little Navmap which supports all flight plan features
like remarks. See Little Navmap LNMPLN Format for information about this format.
PLN: FSX, FS9, FSC or MSFS.
FLP
FMS: X-Plane FMS 11 or FMS 3
FlightGear FGFP
Garmin FPL

The type of file is determined by content and not file extension. See Flight Plan Formats for more
information.
An opened flight plan file will be reloaded on start up (reload and centering can be switched off in
the Options dialog on Startup and Update and User Interface).
You can also drag and drop files from a file manager like Windows Explorer or macOS Finder into
the Little Navmap main window to load them. Single flight plans and all allowed formats for loading
as well as aircraft performance files are accepted.
Note
Keep in mind that most flight plan formats are limited and not all information is provided or can
be loaded from a file. For example, cruise altitude might not be loaded from X-Plane FMS in
some cases, airways and departure parking spots cannot restored for several formats, transitions
cannot be loaded from MSFS PLN and more.

Warning
Always save a copy of the flight plan in LNMPLN format to be able to reload all information.
Exporting to and reading from other formats like X-Plane FMS might result in information loss.

9.2.3.

Append Flight Plan

Adds departure, destination and all waypoints to the current flight plan.
Using Append Flight Plan allows to load or merge complete flight plans or flight plan snippets into a
new plan. All waypoints are added at the end of the current flight plan. Then you can use the Delete
selected Legs and Move selected Legs up/down context menu items to arrange the waypoints and airports
as required. See Context Menu Flight Plan.
All current arrival procedures will be removed when appending a flight plan. The new flight plan will
use arrival and approach procedures from the loaded plan, if any are present.
The appended legs are selected after loading the flight plan.
9.2.4. Recent Flight Plans
Shows all recently loaded flight plans for quick access. You can clear the list by selecting Clear Menu.

9.2.5.

Save Flight Plan

Saves the flight plan into the current LNMPLN file. This format allows to store all flight plan
attributes of Little Navmap.
Little Navmap opens the Save as dialog (see below Save Flight Plan as LNMPLN) if departure,
destination or any other value used in the flight plan name has changed. This helps to avoid
overwriting LNMPLN files with wrong plans after reversing direction, for example.
You can disable this behavior in the options dialog on page Flight Plan by unchecking Avoid
overwriting Flight Plan with not matching departure and destination.

9.2.6.

Save Flight Plan as LNMPLN

Saves the flight plan to a LNMPLN file. This format allows to save all flight plan attributes of Little
Navmap.
See Little Navmap LNMPLN Format for information about this format.
changes the current file name in Little Navmap which means that all further
saves will go into the new LNMPLN file.
Save Flight Plan as PLN

Little Navmap proposes a new file name based on the pattern set in options on page Flight Plan.
Tip
You can save the flight plan files in any place. I recommend a directory in Documents like
Documents\Little Navmap\Flight Plans.
You can also use the folder which is suggested by the Directories dialog.

Warning
Always save a copy of the flight plan in the default LNMPLN format to be able to reload all
information. Writing to and reading from other formats like X-Plane FMS might result in
information loss. See Flight Plan Formats for more information.

9.2.7.

Reset all for a new Flight

Opens a dialog which allows to reset functions in Little Navmap for a new flight. See Reset all for a
new Flight for more information.

9.2.8.

Export Flight Plan as MSFS 2020 PLN

Saves a flight plan for Microsoft Flight Simulator 2020.
Little Navmap can read and write this format.
This does not change the current file name and type. Further saves will still use the same LNMPLN
file name and format as before.
See also Flight Plan Formats.

9.2.9.

Export Flight Plan as P3D or FSX PLN

Saves a flight plan for FSX or Prepar3D.
Little Navmap can read and write this format.
This does not change the current file name and type. Further saves will still use the same LNMPLN
file name and format as before.
See also Flight Plan Formats.

9.2.10.

Export Flight Plan as X-Plane FMS 11

Saves the flight plan using the new X-Plane FMS 11 format.
Little Navmap can read and write this format.
See Flight Plan Formats for more information on limitations.
This does not change the current file name and type. Further saves will still use the same file name
and format as before.
Store FMS files into the Output/FMS plans directory inside the X-Plane directory if you would like to
use the flight plan in the X-Plane GPS, the G1000 or the FMS.

9.2.11.

Export Flight Plan as FlightGear FGFP

Flightplan format which can be loaded into the RouteManager of the free flight simulator FlightGear
[http://www.flightgear.org].
Little Navmap can read and write this format.
A deactivateable warning dialog will be shown when saving.
See Flight Plan Formats for more information on limitations.
This does not change the current file name and type. Further saves will still use the same file name
and format as before.
You can save the files into any directory and load it within FlightGear.
9.2.12. Show Flight Plan in SkyVector
Opens the default web browser and shows the current flight plan in SkyVector [https://skyvector.com].
Procedures are not shown.
Note that the flight plan will not be displayed if a small airport is unknown to SkyVector.
Example: ESMS NEXI2B NILEN L617 ULMUG M609 TUTBI Z101 GUBAV STM7C ENBO

[https://skyvector.com/?fpl=ESMS%20NILEN%20L617%20ULMUG%20M609%20TUTBI%20Z101%20GUBAV%20ENBO].

missing SID and STAR in SkyVector.

Note

9.2.13. Export Flight Plan to Other Formats
9.2.13.1. Export Flight Plan as HTML Page

Saves the flight plan table as shown to HTML file which can be viewed in a web browser. Icons are
embedded in the page.
The exported file will reflect changes of the flight plan table view like column order. Columns which
are hidden or shrinked to minimum width are excluded.
9.2.13.2. Export Flight Plan as GPX

Exports the current flight plan into a GPS Exchange Format file which can be read by Google Earth
and most other GIS applications.
The flight plan is exported as a route and the flown aircraft trail as a track including simulator time
and altitude.
The route has departure and destination elevation and cruise altitude set for all waypoints.
Waypoints of all procedures are included in the exported file. Note that the waypoints will not allow
to reproduce all parts of a procedure like holds or procedure turns.
Note
Do not forget to clear the aircraft trail ( Delete Aircraft Trail or Reset all for a new Flight) before a
flight to avoid old trail segments in the exported GPX file. Or, disable the reloading of the trail in
the options dialog on Startup and Update.
9.2.13.3. Export Flight Plan as vPilot VFP

Export the flight plan for the VATSIM vPilot [https://www.vatsim.net/pilots/download-required-software] online
network client.
Flight Plan Online Network Export will appear before where you can add all needed information.
9.2.13.4. Export Flight Plan as IvAp FPL
9.2.13.5. Export Flight Plan as X-IvAp FPL

Export flight plan format for IVAO online network clients IvAp or X-IvAp
[https://www.ivao.aero/softdev/ivap.asp].
Flight Plan Online Network Export will appear before where you can add all needed information.
9.2.14. Export Options

Sub-menu with several actions that affect export to most flight plan formats. This does not affect
the saving of fliight plans to LNMPLN.
Warning
Note that saving flight plans with one or more of these methods has limitations:
Several approach leg types like holds, turns and procedure turns cannot be displayed
properly by using just waypoints or coordinates.
Speed and altitude limitations are not included in the exported legs.

9.2.14.1. Export Waypoints for Approaches
9.2.14.2. Export Waypoints for SID and STAR

Save procedure waypoints instead of procedure information if checked. This affects all flight plan
export formats except the native LNMPLN format.
Use this if your simulator, GPS or FMC does not support loading or display of approach procedures,
SID or STAR.
Procedure information is replaced with respective waypoints that allow to display procedures in
limited GPS or FMS units.
9.2.14.3. Export Waypoints for Airways

Enabling this function will omit all airway information in the exported flight plan formats. A chain of
waypoints will be exported instead of waypoint/airway/waypoint triplets.

9.2.15.

Multiexport Flight Plan

Exports all selected flight plan formats at once. You have to configure paths and select formats for
exporting before by selecting Multiexport Flight Plan Options below.
Disabled if no flight plan format is selected for export.
See Flight Plan Multiexport for details.

9.2.16.

Multiexport Flight Plan Options

Opens a dialog which allows to configure paths and select formats for flight plan exports with the
Multiexport Flight Plan function above
See Flight Plan Multiexport for details.

9.2.17.

Add Google Earth KML

Allows addition of one or more Google Earth KML or KMZ files to the map display. All added KML or
KMZ files will be reloaded on start up. Reload and centering can be switched off in the Options dialog
on Startup and Update and User Interface.
Due to the variety of KML files it is not guaranteed that all files will show up properly on the map.

9.2.18.

Clear Google Earth KML from Map

Removes all loaded KML files from the map.

9.2.19.

Save Map as Image

Saves the current map view as an image file. Allowed formats are JPEG, PNG and BMP. The image
does not include the map overlays.

Map Image Export will show up before saving which allows to select the image size.

9.2.20.

Save Map as Image for AviTab

Saves the current map view as an image file for AviTab [https://github.com/fpw/avitab]. Allowed formats
are JPEG and PNG.
Map Image Export will show up before saving which allows to select the image size.
The saved file is accompanied by a calibration file in JSON-Format [https://en.wikipedia.org/wiki/JSON]. It
has the same name as the image with an additional .json extension.
The files have to be saved to .../X-Plane 11/Resources/plugins/AviTab/MapTiles/Mercator.
See here in the AviTab documentation for more information how to load the map image: Map App Mercator [https://github.com/fpw/avitab/wiki/Map-App#mercator].
9.2.21. Copy Map Image to Clipboard
Copies the current map image to the clipboard. The image does not include the map overlays.
Map Image Export will show up before copying the image which allows to select the image size.

9.2.22.

Print Map

Allows to print the current map view. See Print Map for more information.

9.2.23.

Print Flight Plan

Opens a print dialog that allows you to select flight plan related information to be printed. See Print
Flight Plan for more information.

9.2.24.

Quit

Exits the application. Will ask for confirmation if there are unsaved files.
9.3. Flight Plan Menu
9.3.1. Flight Plan
Opens and raises the flight planning dock window and flight plan tab. Also activates the flight plan
table for quick navigation. Same as Window -> Shortcuts -> Flight Plan or pressing F7.
See Window for a full list or shortcuts.
9.3.2. Fuel Report
Opens and raises the flight planning dock window and Fuel Report tab. Same as Window -> Shortcuts > Fuel Report or pressing F8.
See Window for a full list or shortcuts.

9.3.3.

Undo/Redo

Allows undo and redo of all flight plan changes. The last action is shown in the menu item like Add
Waypoint, for example.

9.3.4.

Select a Start Position for Departure

A parking spot (gate, ramp or fuel box), runway or helipad can be selected as a start position at
the departure airport. A parking position can also be selected in the map context menu item Set as

Departure when right-clicking on a parking position. If no position is selected the longest primary
runway end is selected automatically as start.

The start position selection dialog for EDDN.

9.3.5.

Edit Flight Plan on Map

Toggles the flight plan drag and drop edit mode on the map. See Map Flight Plan Editing.

9.3.6.

New Flight Plan from Route Description

Opens a dialog with the ATS route description of the current flight plan that also allows to modify
the current flight plan or enter a new one.
Flight Plan Route Description gives more information about this topic.

9.3.7.

Copy Flight Plan Route to Clipboard

Copies the route description of the current flight plan to the clipboard using the current settings
from Flight Plan Route Description.

9.3.8.

Calculate Direct

Deletes all intermediate waypoints and connects departure and destination using a great circle line.
This function does not delete procedures from the current flight plan but will rather connect
procedure exit and entry directly, if any.
Tip
You can calculate a flight plan between any kind of waypoints, even user-defined waypoints
(right-click on the map and select Add Position to Flight Plan to create one). This allows the
creation of snippets that can be merged into flight plans.

9.3.9.

Reverse Flight Plan

Swaps departure and destination and reverses order of all intermediate waypoints. A default
runway is assigned for the new departure start position.
Procedures are removed by this function.
This function also removes all airway references since the result would not be valid due to one-way
restrictions.

9.3.10.

Calculate Flight Plan

Opens the flight plan calculation dock window which allows to automatically generate a flight plan
by various criteria.
The altitude from the current flight plan is transferred to the calculation window.
See chapter Flight Plan Route Calculation for more information.

9.3.11.

Adjust Flight Plan Altitude

Changes the flight plan altitude according to a simplified East/West rule and the current route type
(IFR or VFR). Rounds the altitude up to the nearest even 1,000 ft (or meter) for westerly flight
plans or odd 1,000 ft (or meter) for easterly flight plans. Adds 500 ft for VFR flight plans.
The rule can be changed in the options on Flight Plan.
9.3.12. Download Tracks on Startup
Downloads tracks immediately and instructs Little Navmap download tracks on startup.
See Tracks for more information.

9.3.13.

Download Tracks

Downloads Oceanic or other tracks which are NAT, PACOTS and AUSOTS.
Tracks are shown on the map and a message is shown in the statusbar once the download is
finished.
Tracks are removed when closing the program. Use the function Download Tracks on Startup above to
always have tracks available.
See Tracks for more information.
9.3.14. Delete Tracks
Remove downloaded Oceanic and other tracks from the track database.
9.3.15. Track Sources
9.3.15.1. NAT
9.3.15.2. PACOTS
9.3.15.3. AUSOTS

Allows to select the track systems to download. You have to start the download again to see the
changes.
See Tracks for more information.
9.4. Map Menu

9.4.1.

Goto Home

Goes to the home area that was set using Set Home View in the sub-menu More in the map context
menu. It will show the map using the saved position and zoom distance. The center of the home
area is highlighted by a

symbol.

Note that the symbol is only an indicator for the home view center position and does not have any
context menu or mouse actions attached.
The symbol cannot be hidden. Set it at a remote position if you like to hide it.

9.4.2.

Go to Center for Distance Search

Go to the center point used for distance searches. See Set Center for Distance Search.The center
for the distance search is highlighted by a

symbol.

The center symbol cannot be hidden. Set it at a remote position if you like to hide it.

9.4.3.

Center Flight Plan

Centers the whole flight plan on the map.

9.4.4.

Remove all Highlights and Selections

Deselect all entries in the flight plan table, all search result tables and remove all highlight marks
from the map. Use this to get a clean view of the map while flying.

9.4.5.

Remove all Ranges, Measurements, Patterns and Holdings

Removes all user features which are range rings, navaid range rings, measurement lines, airport
traffic patterns and holdings from the map. This cannot be undone.
A warning dialog is shown before removing all user features.

9.4.6.

Center Aircraft

Zooms to the user aircraft if directly connected to a flight simulator or remotely connected using
Little Navconnect and keeps the aircraft centered on the map.
Default is to keep the user aircraft and the next flight plan waypoint visible on the map. The mode
falls back to simple aircraft centering if no flight plan is loaded or no active leg is present.
You can zoom and move the map around and after a timeout the aircraft and next waypoint are
centered again.
You can change the behavior on Simulator Aircraft tab in dialog Options.

9.4.7.

Delete Aircraft Trail

The aircraft trail is saved and will be reloaded on program startup.
This menu item removes the user aircraft trail from both the map and the elevation profile.
The trail can be exported together with the flight plan into a GPX file by using Export Flight Plan as
GPX.
The aircraft trail is also attached to logbook entries as flown trail and can be saved there.
Note

Always reset your trail before doing a flight to have the correct trail in the logbook entry. The
best way to do this is Reset all for a new Flight.

9.4.8.

Map Position Back/Forward

Jumps forward or backward in the map position history. The complete history is saved and restored
when starting Little Navmap.
9.5. View Menu

9.5.1.

Reset Display Settings

Resets all map display settings which can be changed in the menu View back to default.
9.5.2. Details

9.5.2.1.

More Details

9.5.2.2.

Default Details

9.5.2.3.

Less Details

Increases or decreases the detail level for the map. More details means more airports, more
navaids, more text information and bigger icons.
Warning
Map information will be truncated if too much detail is chosen. A red warning message Too many
objects will be shown in the statusbar if this is the case.
The detail level is shown in the statusbar. Range is -5 for least detail to +5 for most detail.
Tip
You can also quickly change the detail level with the mouse wheel using Ctrl+Wheel.
9.5.3. Airports

9.5.3.1.

Force Show Addon Airports

Add-on airports are always shown independently of the other airport map settings and zoom level if
this option is selected.
Enabling this function allows to see even small add-on airstrips in continental zoom levels, for
example.
Add-on airports are highlighted with a yellow ring which is independent of this function. You can
disable the yellow ring in the options dialog on page Map Display by unchecking Highlight add-on
airports.
Example: Force Show Addon Airports on a higher zoom level:

Off: Only large add-on airports are shown on the map with a yellow highlight.

On: All large add-on airports and additionally small add-on airstrips are shown on the map with a yellow highlight.

9.5.3.2.

Show Airports with hard Runways

Show airports that have at least one runway with a hard surface.

9.5.3.3.

Show Airports with soft Runways

Show airports that have only soft surfaced runways or only water runways. This type of airport
might be hidden on the map depending on zoom distance.

9.5.3.4.

Show empty Airports

Show empty airports. This button or menu item might not be visible depending on settings in the
Options dialog on Map. The status of this button is combined with the other airport buttons. This
means, for example: You have to enable soft surfaced airport display and empty airports to see
empty airports having only soft runways.
An empty airport is defined as one which has neither parking nor taxiways nor aprons and is not an
add-on. These airports are treated differently in Little Navmap. Empty airports are drawn gray and
behind all other airports on the map.
This function helps the user to avoid airports that have no scenery elements.

Airports having only water runways are excluded from this definition to avoid unintentional hiding.
X-Plane and 3D airports
The function can be extended to X-Plane airports which are not marked as 3D. This can be done by
checking Consider all X-Plane airports not being 3D empty in the Options dialog on Map. All airports not
being marked as 3D will be shown in gray on the map and can be hidden like described above if
enabled.
An airport is considered 3D if its source file contains 3D in the gui_label.
The definition of 3D is arbitrary, though. A 3D airport may contain just a single object, such as a light
pole or a traffic cone or it may be a fully constructed major airport.
9.5.4. Navaids

9.5.4.1.

Show VOR Stations

9.5.4.2.

Show NDB Stations

9.5.4.3.

Show Waypoints

9.5.4.4.

Show ILS Feathers

9.5.4.5.

Show Victor Airways

9.5.4.6.

Show Jet Airways

Show or hide these facilities or navaids on the map. Navaids might be hidden on the map
depending on zoom distance.

9.5.4.7.

Show Tracks

Show or hide Oceanic or other tracks which are NAT, PACOTS and AUSOTS.
This function is disabled if no tracks are downloaded.
See Tracks for more information.
9.5.5. Airspaces
This sub-menu and toolbar allow the selection of individual airspace categories.
Airspace data sources can be selected in menu Scenery Library -> Airspace Libraries.
Note that airspaces are hidden at lower zoom levels to avoid overlaying with the airport diagram.
You can tear off the drop down menus from the toolbar by clicking on the dashed line on top of the
menu.

Airspace selection toolbar with all drop down menus.

9.5.5.1.

Show Airspaces

Allows to enable or disable the display of all airspaces with one click. Use the menu items below
this one or the toolbar buttons to display or hide the various airspace types.
The airspaces toolbar contains buttons each having a drop down menu that allows to configure the
airspace display like showing or hiding certain airspace types. Each drop down menu also has All
and None entries to select or deselect all types in the menu.

9.5.5.2.

ICAO Airspaces

Allows selection of Class A to Class E airspaces.

9.5.5.3.

FIR Airspaces

Allows selection of the Class F and Class G airspaces or flight information regions.

9.5.5.4.

Restricted Airspaces

Show or hide MOA (military operations area), restricted, prohibited and danger airspaces.

9.5.5.5.

Special Airspaces

Show or hide warning, alert and training airspaces.

9.5.5.6.

Other Airspaces

Show or hide center, tower, mode C and other airspaces.

9.5.5.7.

Airspace Altitude Limitations

Allows filtering of the airspace display by altitude. Either below or above 10,000 ft or 18,000 ft or
only airspaces intersecting with the flight plan altitude.

9.5.6. User Features

9.5.6.1.

Range Rings

9.5.6.2.

Measurement Lines

9.5.6.3.

Traffic Patterns

9.5.6.4.

Holdings

Hides or shows the respective user features.
Note that the menu item to add an user feature is disabled if the respective user feature is hidden
on the map. The menu item is suffixed with the text hidden on map if this is the case.
9.5.7. Userpoints
Allows to hide or show user-defined waypoints by type.
The menu item Unknown Types shows or hides all types which do not belong to a known type.

The type Unknown

shows or hides all userpoints which are exactly of type Unknown.

You can tear off the drop down menu from the toolbar by clicking on the dashed line on top of it.
See Userpoints for more information on user-defined waypoints.

9.5.8.

Show Flight Plan

Show or hide the flight plan. The flight plan is shown independently of the zoom distance.
Note that the flight plan is also hidden in the elevation profile if you switch it off here.

9.5.9.

Show Top of Climb and Top of Descent

Hides the climb and descent slopes as well as the top of climb and top of descent indicators when
disabled. This affects the map and elevation profile display but not the altitude calculation in the
fuel report or elevation profile.

9.5.10.

Show Missed Approaches

Show or hide the missed approaches of the current flight plan. This does not affect the preview in
the search tab Procedures.
Note
This function changes the active flight plan leg sequencing: Sequencing the active leg will stop if
the destination is reached and missed approaches are not displayed. Otherwise sequencing will
continue with the missed approach and the simulator aircraft progress will show the remaining
distance to the end of the missed approach instead.

9.5.11.

Show Aircraft

Shows the user aircraft and keeps it centered on the map if connected to the simulator. The user
aircraft is always shown independently of the zoom distance.

The icon color and shape indicates the aircraft type and whether the aircraft is on ground (gray
border on ground).

User aircraft in flight.
A click on the user aircraft shows more information in the Simulator Aircraft dock window.
More options to change the map behavior while flying can be found here Simulator Aircraft.

9.5.12.

Show Aircraft Trail

Show the user aircraft trail. The trail is always shown independently of the zoom distance. It is
saved and will be reloaded on program startup.
The trail can be deleted manually by selecting Map -> Delete Aircraft Trail in the main menu.
The length of the trail is limited for performance reasons. If it exceeds the maximum length, the
trail is truncated and the oldest segments are lost.
The trail can be exported together with the flight plan into a GPX file by using Export Flight Plan as
GPX.

9.5.13.

Show Compass Rose

Show a compass rose on the map which indicates true north and magnetic north. Aircraft heading
and aircraft trail are shown if connected to a simulator.
The rose is centered around the user aircraft if connected to a simulator. Otherwise it is centered
on the map view.
See Compass Rose for details.

9.5.14.

Attach Compass Rose to Aircraft

The compass rose is centered in the current view if not connected to a simulator.
Once connected, the compass rose will be attached to the user aircraft and follow its position.
This can be disabled with this menu item which detaches the rose from the user aircraft and keeps
it centered on the screen.

9.5.15.

Show AI and Multiplayer Aircraft or Ships

Shows AI and multiplayer aircraft or ships on the map. Multiplayer vehicles can be displayed from
e.g. FSCloud, VATSIM or Steam sessions.
The icon color and shape indicates the aircraft type and whether the aircraft is on ground (gray
border).

AI or multiplayer aircraft from the simulator.
This includes aircraft that are injected by the various online network clients. A click on the AI
aircraft or ship shows more information in the Simulator Aircraft dock window in the tab AI /
Multiplayer.

Multiplayer aircraft/client from an online network. See Online Networks. A click on the online
aircraft shows information in the Information dock window in the separate tab Online Clients.
Note that, in X-Plane, ship traffic is not available and AI aircraft information is limited.

The displayed vehicles are limited by the used multiplayer system if Little Navmap is not connected
to an online network like VATSIM or IVAO. Multiplayer aircraft will disappear depending on distance
to user aircraft. For AI in FSX or P3D this is currently about 100 NM or around 200 km.
Smaller ships are only generated by the simulator within a small radius around the user aircraft.
Little Navmap limits the display of AI vehicles depending on size. Zoom close to see small aircraft
or boats.
On the lowest zoom distance all aircraft and ships are drawn to scale on the map.
Aircraft labels are forced to show independently of zoom level for the next five AI/multiplayer
aircraft closest to the user that are within 20 NM distance and 5,000 ft elevation.
All aircraft icons can be customized: User, AI and Multiplayer Aircraft Icons.

9.5.16.

Show Map Grid

Show a latitude/longitude grid as well as the meridian [https://en.wikipedia.org/wiki/Prime_meridian] and
antimeridian [https://en.wikipedia.org/wiki/180th_meridian] (near the date line) on the map.
A 30, 5 or 1 degree grid is shown depending on zoom factor.

9.5.17.

Show Country and City Names

Show country, city and other points of interest. Availability of these options depends on the
selected map theme. See Theme.

9.5.18.

Show Hillshading

Show hill shading on the map. Availability of these options depends on the selected map theme.
See Theme.

9.5.19.

Show Minimum Altitude

Toggles the display of minimum off-route altitude grid on the map.
The minimum off-route altitude grid provides an obstacle clearance altitude within an one degree
grid. The altitudes clear all terrain and obstructions by 1,000 ft in areas where the highest
elevations are 5,000 ft MSL or lower. Where the highest elevations are above 5,000 ft MSL or
higher terrain is cleared by 2,000 ft.
The large number is 1,000 ft and small number 100 ft minimum altitude.

MORA grid: 3,300, 4,400, 6,000, 9,900 and 10,500 ft.

9.5.20.

Show Airport Weather

Shows icons for airport weather where a weather station is available. Select source for display with
Airport Weather Source below.
See Airport Weather for an explanation of the symbols and Airport Weather for more information.
9.5.21. Wind levels
Enables or disables wind aloft display for different layers as well as at flight plan waypoints. Select
wind data source for display with Wind source below.

See Winds Aloft for an explanation of the wind symbols and Winds Aloft for more information.

9.5.22.

Show Sun Shading

Enables the display of sun shading on the globe. This works in both projections Mercator and
Spherical.
You can change the time source with the Sun Shading Time menu below. The shadow darkness can be
changed in the dialog Options on Map Display 2.
See Sun Shading for more information.
9.5.23. Sun Shading Time
You can choose between three time sources for the sun shadow.
9.5.23.1. Simulator

Uses the time of the connected flight simulator and falls back to real time if not connected. Updates
the shadow if the simulator time changes.
9.5.23.2. Real UTC Time

Use real time.
9.5.23.3. User defined Time

Allows to use the user defined time as set by using Set User defined Time below.
9.5.23.4. Set User defined Time

Opens a dialog to set an user defined time in UTC as a source for the sun shading.
See Set User defined Time for more information.
9.5.24. Projection
9.5.24.1. Mercator

A flat projection that gives the most fluid movement and the sharpest map when using picture tile
based online maps themes like OpenStreetMap or OpenTopoMap.
9.5.24.2. Spherical

Shows earth as a globe which is the most natural projection. Movement can stutter slightly when
using the picture tile based online maps themes like OpenStreetMap or OpenTopoMap. Use the
Simple, Plain or Atlas map themes to prevent this.
Online maps can appear slightly blurred when using this projection. This is a result from converting
the flat image tiles to the spherical display.

Spherical map projection with Simple offline map theme selected.

9.5.25. Theme
Allows to change the map theme which defines the look and feel of the background map.
Custom map themes are prefixed with a * in the drop down box in the toolbar and with the word
Custom in the menu.
Tip
Also check out the Little Navmap Support Forum at AVSIM [https://www.avsim.com/forums/forum/780-littlenavmap-little-navconnect-little-logbook-support-forum/], Little Navmap Downloads - Map Themes
[https://www.littlenavmap.org/downloads/Map%20Themes/] and LittleNavmapOFMTheme
[https://github.com/AmbitiousPilots/LittleNavmapOFMTheme] for more map themes.

Note
Please note that all the online maps are delivered from free services therefore fast download
speeds and high availability cannot be guaranteed.
In any case it is easy to deliver and install a new online map source without creating a new Little
Navmap release. See Creating Map Themes for more information.
9.5.25.1. OpenStreetMap

This is an online raster (i.e. based on images) map that includes a hill shading option. Note that the
OpenStreetMap hill shading does not cover the whole globe.

View at an Italian airport using OpenStreetMap theme and hill shading.
9.5.25.2. OpenTopoMap

An online raster map that mimics a topographic map. Includes integrated hill shading and elevation
contour lines at lower zoom distances.
The tiles for this map are provided by OpenTopoMap [https://www.opentopomap.org].

View at the eastern Alps using OpenTopoMap theme. A flight plan is shown north of the Alps.
9.5.25.3. Stamen Terrain

A terrain map featuring integrated hill shading and natural vegetation colors. The hill shading is
available worldwide.
Map tiles by Stamen Design [https://stamen.com], under CC BY 3.0 [https://creativecommons.org/licenses/by/3.0].
Data by OpenStreetMap [https://www.openstreetmap.org], under ODbL [https://www.openstreetmap.org/copyright].

View showing Stamen Terrain theme.
9.5.25.4. CARTO Light

A very bright map called Positron which allows to concentrate on the aviation features on the map
display. The map includes the same hill shading option as the OpenStreetMap.
Map tiles and style by CARTO [https://carto.com/]. Data by OpenStreetMap [https://www.openstreetmap.org],
under ODbL [https://www.openstreetmap.org/copyright].
9.5.25.5. CARTO Dark

A dark map called Dark Matter. The map includes the same hill shading option as the
OpenStreetMap.
Map tiles and style by CARTO [https://carto.com/]. Data by OpenStreetMap [https://www.openstreetmap.org],
under ODbL [https://www.openstreetmap.org/copyright].
9.5.25.6. Simple (Offline)

This is a political map using colored country polygons. Boundaries and water bodies are depicted
coarse. The map included in Little Navmap has an option to display city and country names.
9.5.25.7. Plain (Offline)

A very simple map. The map is included in Little Navmap and has an option to display city and
country names. Boundaries and water bodies are depicted coarse.
9.5.25.8. Atlas (Offline)

A very simple map including coarse hill shading and land colors. The map is included in Little
Navmap and has an option to display city and country names. Boundaries and water bodies are
depicted coarse.
9.6. Weather Menu
9.6.1. Airport Weather Source
Selects the source for the airport weather symbol display on the map. See also Airport Weather
and Weather.
The following options are available:
9.6.1.1. Disabled

Disables the weather source which also disables all file accesses. The menu item Show Airport
Weather and the toolbar button will disabled if this is selected.

9.6.1.2. Flight Simulator

FSX, Prepar3D or X-Plane. Display for FSX/Prepar3D and on remote connections is slower and
might cause stutters when scrolling.
Display for X-Plane remote connections is not supported except by sharing the X-Plane METAR.rwx
weather file on the network.
9.6.1.3. Active Sky

Use Active Sky as source for weather display.
9.6.1.4. NOAA

Most up-to-date option for weather (National Oceanic and Atmospheric Administration
[https://www.noaa.gov/]).
9.6.1.5. VATSIM

Same as NOAA but weather information might be older than NOAA. Use this for online flying in the
VATSIM network.
9.6.1.6. IVAO

Same as NOAA weather but information might be older. Use this for online flying in the IVAO
network.
9.6.2. Wind source
Choose the source for winds aloft forecast data here. This will affect the calculation of top of
descent, top of climb and fuel planning. See also Winds Aloft and Weather.
A manual wind setting for cruise altitude can also be used. See Buttons.
The selected wind source is shown in the tab Fuel Report in the Average wind line as well as in all
tooltips on wind barbs.
9.6.2.1. Manual Wind

This is the same function as the Manual Wind button in the Fuel Report tab.
This menu item overrides the wind source and allows to set the average wind direction and speed
manually. Two input fields are shown in the Fuel Report tab if this is checked.
9.6.2.2. Disabled

No wind will be downloaded and processed.
9.6.2.3. Flight Simulator (X-Plane only)

Uses the global_winds.grib file which is downloaded and used by X-Plane. This file uses only two wind
layers and is therefore less accurate than the NOAA option.
9.6.2.4. NOAA

Downloads weather files from National Oceanic and Atmospheric Administration [https://www.noaa.gov/].
This is the most accurate option since it downloads data for several wind layers.
9.7. Userpoint Menu
See Userpoints for more information on user-defined waypoints.
9.7.1. Userpoint Search
Raise the dock window Search and the tab Userpoints where you can edit, add delete and search
user-defined waypoints.
9.7.2. Import CSV
Import a CSV file that is compatible with the widely used format from Plan-G and adds all the
content to the database.

Note that the CSV format is the only format which allows to write and read all supported data
fields.
See CSV Data Format for a more detailed description.
9.7.3. Import X-Plane user_fix.dat
Import user-defined waypoints from the file user_fix.dat. The file does not exist by default in XPlane and has to be created either manually or by exporting from Little Navmap.
The default location is XPLANE/Custom Data/user_fix.dat.

The imported userpoints are of type Waypoint
bulk edit functionality.

which can be changed after import using the

The format is described by Laminar Research here: XP-FIX1101-Spec.pdf [https://developer.x-plane.com/wpcontent/uploads/2016/10/XP-FIX1101-Spec.pdf].
See X-Plane user_fix.dat Data Format for more information.
9.7.4. Import Garmin GTN
Reads user-defined waypoints from the Garmin user.wpt file. Refer to the manual of the Garmin unit
you are using for more information about format and file location.

The imported userpoints are of type Waypoint
bulk edit functionality.

which can be changed after import using the

See Garmin user.wpt Data Format for more information.
9.7.5. Export CSV
Create or append user-defined waypoints to a CSV file. A dialog asks if only selected userpoints
should be exported, if the userpoints should be appended to an already present file or if a header
should be added.
Note that the exported file contains extra columns compared to the Plan-G format. The description
field supports more than one line of text and special characters. Therefore, not all programs might
be able to import this file. If needed, adapt the file in Microsoft Excel or LibreOffice Calc.

Userpoint export dialog with tooltip help on first option.

9.7.6. Export X-Plane user_fix.dat
Only selected userpoints or all can be exported. The exported data can optionally be appended to
an already present file.
Not all data fields can be exported to this format. The ident field is required for export.
Also, you have to make sure that the user waypoint ident is unique within the user_fix.dat.
See X-Plane user_fix.dat Data Format for more information about limitations.

9.7.7. Export Garmin GTN
Only selected userpoints or all can be exported. The exported data can optionally be appended to
an already present file.
Not all data fields can be exported to this format. The ident field is required for export. Some fields
like the name are adapted to limitations.
See X-Plane user_fix.dat Data Format for more information about limitations.
9.7.8. Export XML for FSX/P3D BGL Compiler
This export options creates an XML file which can be compiled into an BGL file containing
waypoints.
The region and ident fields are required for this export option.
See the Prepar3D SDK documentation for information on how to compile the BGL and how to add
this to the simulator.
9.7.9. Clear database
Remove all user-defined waypoints from the database.
A CSV backup file named little_navmap_userdata_backup.csv is created in the settings directory
C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel before deleting all user-defined waypoints.
Little Navmap also creates a full database backup on every start. See Userpoints.

9.8. Logbook Menu
9.8.1. Logbook Search
Raise the dock window Search and the tab Logbook where you can edit, add delete and search logbook
entries.
See Logbook for more information.
9.8.2. Show Statistics
Shows the logbook statistics dialog. See Logbook Statistics.
9.8.3. Import CSV
Import logbook entries from a CSV file. The entries are added to the logbook database.
9.8.4. Export CSV
Allows to export the full logbook or the selected entries to a CSV (comma separated value) text file
which can be loaded in LibreOffice Calc or Microsoft Excel. See Import and Export.
9.8.5. Import X-Plane Logbook
Import the X-Plane logbook file .../X-Plane 11/Output/logbooks/X-Plane Pilot.txt into the Little Navmap
logbook database. Note that the X-Plane logbook format is limited and does not provide enough
information to fill all Little Navmap logbook fields.
See X-Plane Import.
9.8.6. Convert Log Entries from Userpoints
Automatically converts all legacy log entries that were collected as userpoints and copies them to
the new logbook.
See Conversion for details.
9.8.7. Create Logbook entries
Little Navmap creates logbook entries for each flight automatically if this menu item is checked. A
logbook entry containing only departure is created on takeoff and finalized with destination and
more information on landing.
Note
Always reset your trail before doing a flight to have the correct trail in the logbook entry. The
best way to do this is Reset all for a new Flight.
See also Logbook.
9.9. Aircraft Menu
This menu contains functionality for aircraft performance profiles which allow fuel planning and
traveling time estimation.
See Aircraft Performance and Aircraft Performance Edit for more information.

9.9.1.

New Aircraft Performance

Creates a new performance profile with default values, shows the fuel report and opens the edit
dialog. A profile with 3 NM per 1,000 ft for descent and climb rules and no fuel consumption is
default. Red warning messages will be shown since the profile is not complete.

9.9.2.

Open Aircraft Performance

Loads a LNMPERF aircraft performance profile and shows the fuel report. You can also load a profile
by dragging the file from a file manager like Windows Explorer into the main window of Little
Navmap.

9.9.3.

Save Aircraft Performance

Saves the current profile. Opens a file dialog if not saved before.

9.9.4.

Save Aircraft Performance as

Allows to save the current profile using a new filename.
9.9.5. Recent Performance Files
Shows all recently loaded aircraft performance files for quick access. You can clear the list by
selecting the sub-menu item Clear Menu.

9.9.6.

Edit Aircraft Performance

Opens Aircraft Performance Edit for the current performance profile.

9.9.7.

Open Aircraft Performance and Merge

Opens a file loading dialog and subsequently Aircraft Performance Merge which allows to merge or
copy data from the opened file to the current aircraft performance.

9.9.8.

Merge collected Aircraft Performance

Opens Aircraft Performance Merge which allows to merge or copy data from the collected aircraft
performance to the currently loaded aircraft performance.
See also Aircraft Performance Collection.

9.9.9.

Restart Aircraft Performance Collection

Resets all collected values for aircraft performance to zero and starts the performance collection
over.
See also Aircraft Performance Collection.
9.10. Scenery Library Menu
9.10.1. Flight Simulators
One menu item is created for each flight simulator installation or database found. These menu
items allow switching of databases on the fly.
The menu shows the simulator name as a disabled menu item if only one flight simulator was
found.
The loaded AIRAC cycle is shown only for X-Plane and Navigraph data since the information is not
available for FSX, P3D and MSFS.
Note
You have to set the base path to the X-Plane directory in the Load Scenery Library Dialog first to
enable the X-Plane menu item.

This menu is synchronized with simulator selection in Load Scenery Library. Once a database is
successfully loaded, the display, flight plan and search will switch over to the newly loaded
simulator data.
Note
Note that Little Navmap does not keep you from using a X-Plane scenery database while being
connected to FSX/Prepar3D or vice versa, for example. You will get unwanted effects like wrong
weather information if using such a setup.
Parking positions in flight plans might change when switching between scenery library databases.
This can happen if airports have parking positions with different names or missing parking
positions.
The program might change a loaded flight plan if you switch between different databases. This can
happen if a departure position is set in the plan which does not exist in the other database. Click
New Flight Plan before switching to avoid this.
9.10.2. Navigraph
This sub-menu also shows the AIRAC cycle if a Navigraph database is found in the database
directory.
See the chapter Navigation Databases for more information about scenery databases and the three
different display modes below.
Note that airspaces are not affected by this selection. See Airspace Libraries below.
9.10.2.1. Use Navigraph for all Features

Completely ignores the simulator database and takes all information from the Navigraph database.
Warning
Airport information is limited in this mode. This means that aprons, taxiways, parking positions,
runway surface information and other information is not available. Also, smaller airports might
be missing. Runway layout might not match the runway layout in the simulator if you use stock
or older airport scenery.
9.10.2.2. Use Navigraph for Navaids and Procedures

This mode blends navaids and more from the Navigraph database with the simulator database. This
affects the map display, all information and all search windows.
This is the default and recommended mode for all simulators.
9.10.2.3. Do not use Navigraph Database

Ignores the Navigraph database and shows only information read from the simulator scenery.
Warning
Navdata read from FSX, P3D or MSFS has limitations. The airway network might not be correct
and procedures can have errors.
9.10.3. Airspace Libraries
Enables or disables various airspace databases for display.
9.10.3.1. Simulator

Toggles display of simulator airspaces. These also change when changing the simulator database in
the Scenery Library menu.
See also X-Plane Airspaces and FSX, Prepar3D and MSFS Airspaces.
9.10.3.2. Navigraph

Shows the airspaces from the included or updated Navigraph database. This is independent of the
selected simulator.
9.10.3.3. User

Selects user airspaces for display. This source is independent of the selected simulator.
See also User Airspaces and Load User Airspaces.
9.10.3.4. Online

Selects the online centers for display. Only enabled if connected to an online service like VATSIM or
IVAO.

9.10.4.

Load User Airspaces

A directory selection dialog will show up when running this function the first time. Select a directory
containing OpenAir airspace files with file ending .txt. All files in the directory will be read
recursively into the user airspace database.
See also User Airspaces.

9.10.5.

Load Scenery Library

Open the Load Scenery Library dialog. See Load Scenery Library for more information.
9.11. Tools Menu

9.11.1.

Flight Simulator Connection

Opens the Connect dialog allowing Little Navmap to connect directly to a flight simulator, the Little
Xpconnect X-Plane plugin, or remotely using the Little Navconnect agent. See Connecting to a
Flight Simulator for more information.
9.11.2. Run Webserver
Starts the internal web server of Little Navmap. Access the web page using the menu item Open
Webserver Page in Browser below.
See Web Server for detailed information and Web Server for configuration options.
9.11.3. Open Webserver Page in Browser
Only enabled if the web server is running. Opens the web server page in your default browser. The
default address is like http://YOUR_COMPUTER_NAME:8965 or http://localhost:8965.
This function might not work depending on your network setup. Enter the computer name as above
manually in your browser if this is the case.
9.11.4. Reset all Settings and Restart
This will reset all options, window layout, dialog layout, aircraft trail, map position history and file
histories back to default values and restart Little Navmap after showing a warning dialog.
User features like range rings, traffic patterns, holds as well as scenery, logbook and userpoint
databases are not affected.
A backup copy of the settings file little_navmap.ini is created in the configuration directory. See
Configuration.
Use this function instead of deleting the settings directory if you see crashes or other issues with
the program.
9.11.5. Reset all Messages

Re-enable all dialogs that were disabled by selecting Do not show this dialog again or similar
messages.
9.11.6. Save Options and State
Saves all options, dialog settings, tab arrangements and the window layout. This is normally only
done when exiting Little Navmap.
9.11.7. Files and Directories
9.11.7.1. Open Log File

Shows the log file abarthel-little_navmap.log in the default text editor. This can be used to track down
errors or crashes.
See also Logs for details.
Note
Immediately save this log to another file if you’d like to report problems with Little Navmap. The
log file might be overwritten if you continue your flight. See How to report a Bug for more
information about reporting bugs.
9.11.7.2. Open Configuration File

Shows the main little_navmap.ini configuration file in the default text editor.
See also Configuration for details about the files used.
Warning
There is usually no need to edit this file directly. Editing this file the wrong way might crash Little
Navmap.
9.11.7.3. Show Database Files

Open Little Navmap’s database directory in a file manager. See Running without Flight Simulator
Installation for more information on copying database files between different computers.
See also Databases for details about the different databases.

9.11.8.

Options

Opens the dialog Options which allows to change the user interface, map display, weather and
more.
Note
The menu entry which is referenced as Tools -> Options in this manual for Windows and Linux can
be found in the application menu at Little Navmap -> Preferences on macOS.
9.12. Window Menu
9.12.1. Shortcuts
A list of menu items that open and raise the respective dock window and tab. See Window for a full
list.
Some shortcuts also activate search fields or tables like the airport ICAO search when using Airport
Search or pressing F4. This allows to quickly look for an airport or other feature by just pressing a
function key.
9.12.2. Map Overlays

Show or hide floating map overlays, like the overview on the top left or the compass on the top
right corner of the map window.
You can also right click on a map overlay to hide it from the context menu.
9.12.3. Style
Allows to switch the style of the graphical user interface on the fly. A restart is not needed.
The user interface styles contain a Night mode that can be used for flights in a dark environment.
You can also dim the map and elevation profile display for this style in the dialog Options on Map
Display 2 (Map Dimming in Night Style at the bottom of the dialog).
The colors for the styles Fusion and Night can be changed by editing configuration files. See
Customizing General for more information.
The available styles depend on the operating system except for Fusion and Night which are always
available.
9.12.4. Open Window Layout
Opens a LNMLAYOUT file and applies the changes like visibility, position and floating status directly
to the dock windows. Size and position of the main window is also restored.
Full screen and normal layouts are both loaded from this file.
See Window Layout for more information.
9.12.5. Save Window Layout as
Saves visibility, position and floating status of all dock windows as well as the size and position of
the main window to a LNMLAYOUT file.
Note that the layout for the fullscreen and normal view are save together in this file.
See Window Layout for more information.
9.12.6. Recent Window Layouts
List of recently saved or loaded window layout files. Select one to load and apply the layout.
9.12.7. Reset Window Layout
Reset the main window layout back to default. This involves visibility, position and state of all dock
windows as well as the toolbars. All tabs and the statusbar are reset to default as well.
This function can be helpful if a dock window gets lost on multi monitor setups.
Note that the dock windows Search and Simulator Aircraft are stacked in the default layout. You can
access both using the tabs at the lower right position of the main window.
See Window Layout for more information on window layouts.

9.12.8.

Fullscreen Map

Maximizes the map window and hides all dock windows as well as the toolbars.
See Fullscreen for more information on fullscreen mode.
9.12.9. Keep in Foreground
Forces the main window of Little Navmap to remain in foreground of all other applications.
9.12.10. Show all floating Windows
Raises all undocked (i.e. floating) windows before the main window. This can be helpful if a window
got lost. See Dock Windows for more information about floating dock windows.

9.12.11. Allow Window docking
This is enabled per default. Disable this if you do not want floating (i.e. undocked) dock windows to
snap back into the main window while moving them around.
See also Dock Windows.
9.12.12. Allow Window moving
Enabled per default. Disable this to avoid moving dock windows around when accidentally clicking
and dragging the title bar. This usually messes up the window layout. Disabling this function still
allows to move floating (i.e. undocked) windows around.
You can still resize the docked windows at the border between them and you can still turn a docked
window into a floating window by double clicking on the title bar.
See also Dock Windows.

9.12.13.

Search

9.12.14.

Flight Planning

9.12.15.

Flight Plan Calculation

9.12.16.

Information

9.12.17.

Flight Plan Elevation Profile

9.12.18.

Simulator Aircraft

9.12.19.

Legend

Open or close these dock windows. The map dock window cannot be closed. The whole dock
window stack is closed if a dock window is part of a stack. See Dock Windows for more information
about stacked dock windows.
Note that the Flight Plan Calculation window cannot be docked and remains in floating state. The
altitude from the current flight plan is not copied to the calculation window when using this
function.
9.12.20. File Toolbar
9.12.21. Map Toolbar
9.12.22. Map Options Toolbar
9.12.23. Map Projection and Theme Toolbar
9.12.24. Flight Plan Toolbar
9.12.25. Map Airspaces Toolbar
9.12.26. Dock Window Toolbar
9.12.27. Tools Toolbar
9.12.28. Statusbar
Show or hide these toolbars and/or the statusbar.

You can also hide toolbars in the context menu that appears when right clicking on them.
9.13. Help Menu

9.13.1.

Contents (Online)

Show the online user manual in the default web browser. The English user manual is shown if it is
not available in your language.
You can install additional language packs for Little Navmap which can include a translated manual.

9.13.2.

Tutorials (Online)

Shows the online tutorials in the default web browser.

9.13.3.

Frequently asked Questions (Online)

Shows the frequently asked questions in the web browser.

9.13.4.

Contents (Offline, PDF)

Show the included PDF user manual in the default PDF viewer.
You can install additional language packs for Little Navmap which can include a translated PDF
manual.

9.13.5.

NavMap Legend

Show the navigation related map legend in the Legend dock window. You can also access the legend
here: Legend.

9.13.6.

Map Legend for current Map Theme

Show the map theme dependent base legend in the Legend dock window. Note that the legend is not
available for all map themes.

9.13.7.

About Little Navmap

Show version and revision number for Little Navmap, also contains links to the database directory,
configuration file, log file and the author’s e-mail address.

9.13.8.

About Marble

Display information about the Marble widget [https://marble.kde.org] that is used to download and show
the maps.

9.13.9.

About Qt

Display information about the Qt application framework [https://www.qt.io] that is used by Little
Navmap.

9.13.10.

Donate for this Program

Opens the donation web page in your default browser.

If you would like to show your appreciation you can donate using PayPal.
Donations are purely optional but greatly appreciated.

[https://albar965.github.io/donate.html]

9.13.11.

Check for Updates

Allows to manually check for updates. This will also show updates that were recently ignored by
pressing the Ignore this Update on the notification dialog.
See Checking for Updates for more information.

10. Statusbar
The statusbar at the bottom of the main window shows various indications (from left to right):
Messages, last action or quick help explaining a menu item or toolbar button. When inactive
the field shows the number of messages, if any. Messages cover background tasks like
weather updates or the simulator connection state. Messages are shown in the tooltip when
clicking into the field or hovering the mouse above. A maximum of ten messages is shown.
Connection status for a local or remote connection. The tooltip provides more detail about
the status, like the host name for remote connections as well as the connection status for
online networks.
Connecting...: The program is trying to establish a connection which was initiated
either manually or automatically.
Connected: A connection was established.
Disconnected: The simulator or Little Navconnect exited.
Indicator that shows airport types, airspaces, navaids or AI vehicles currently visible on the
map. The tooltip gives more details.
A red warning message Too many objects is be shown if too many objects are displayed
on the map due to too high a detail level. The map display might be incomplete if this
happens.
A red Database empty message will be shown if the currently selected database has no
content and needs to be loaded. See Load Scenery Library for more information how
to load the scenery library for a simulator.
Map detail level. Range is -5 for least detail to +5 for most detail. See Details.
Online map download progress indicator. This shows the state of the current map download.
The text is prefixed with a red Offline. indication if offline mode is enabled.
Done: All map data loaded successfully.
Loading: Map data is missing in the cache and was requested. Now waiting for reply.
Updating: Map data is already loaded but expired after two weeks. Waiting for new
data after requesting an update.
Incomplete: Download failed.
Zoom distance (viewpoint distance to earth surface) in NM or kilometers.
Cursor position on map as latitude and longitude depending on selected unit in the dialog
Options on page Units.
Ground elevation below the cursor after a short delay if the GLOBE
[https://ngdc.noaa.gov/mgg/topo/globe.html] offline elevation data is selected.
Magnetic declination at the cursor position in degrees West or East.
Current date of month and Zulu/UTC time hours:minutes:seconds. This is the real world time
and not the simulator time. The tooltip gives more date and time information.

Status bar with messages in tooltip about the last weather updates, the connection status Connecting (FSX/P3D/MSFS) and a tooltip that
indicates what is currently shown on the map. The map detail level is unchanged and the map coordinates at the cursor position are
shown on the bottom right. Altitude at cursor is not shown since offline elevation data is not installed. The online map download progress
indicator shows Done indicating all map tiles were downloaded. Zoom distance is 1.8 NM.

11. Directories
Little Navmap suggests to create a recommended directory structure on startup. This is purely
optional. You can choose to ignore this and save your Little Navmap files in arbitrary places. The
program does not require a fixed directory structure for its files.
All default directories are adjusted if you allow Little Navmap to create the directory structure. This
means that file dialogs will initially point to the right place when saving files.
The following folders are suggested to be created:
Flight Plans:

For flight plans in Little Navmap’s own format LNMPLN. See Flight Plan
Multiexport for exporting flight plans to other formats usable by simulators, aircraft or tools.
See also Little Navmap LNMPLN Format for information about this format.
Aircraft Performance: Directory for aircraft performance files LNMPERF. See Aircraft
Performance for more information.
Window Layouts: For saved window layouts LNMLAYOUT. See Window Layout or Dock Windows.
Airports: A place to store PDF, text, image or other files that are linked in the airport
information. Chapter Files gives more information about this feature.
User Airspaces: User defined airspaces in OpenAir format. See Load Scenery Library.
GLOBE Elevation Data: A place for the GLOBE data used by the flight plan elevation profile. Look
at chapter See Install GLOBE elevation data for installation instructions.
Note
The directory names depend on the chosen user interface language. This dialog might pop up
again if you change the language. Ignore it in this case.
See options on page User Interface for information how to change the program language.

12. Map Display
Little Navmap uses two layers to display the map:
1. Background which is defined by offline or online maps like the OpenStreetMap
[https://www.openstreetmap.org]. You can change the background by selecting another Theme. The
background maps cannot be modified or configured since they are fetched from third party
online services. Little Navmap downloads pre-rendered image tiles from these services to
draw the background map.
2. The foreground layer which is drawn by Little Navmap and can be customized in the options
dialog on the map pages. It consists of airports, navaids, airways, airspaces, measurement
lines, range rings, holds, traffic patterns and all moving objects like AI and the user aircraft.
See Legend for details about the various symbols shown by the map.
12.1. Moving
Use click and drag to move the map and the mouse wheel to zoom in or out. Use Shift+Wheel to
zoom in small steps and Ctrl+Wheel to increase or decrease map details.
You can also use the overlay buttons on the right side of the map to move around.
Alternatively use the keyboard to move around the map:
Cursor keys: Scroll the map
+ and -: Zoom in and out
* and /: Zoom in and out in small steps
Alt+Left and Alt+Right: Go forward or backward in the map position history
Ctrl++ and Ctrl+-: Increase or decrease details
Ctrl+Home: Go to home position
Ctrl+End: Go to center for distance search
Note
Do not forget to activate the map window by clicking into it or pressing F2 before using keys for
movement.
12.2. Mouse Clicks
A single click shows details about all map objects nearby the clicked position in the Information dock
window. Windows and tabs are raised depending on clicked objects.
The procedure search window can be raised optionally if clicking an airport. This can be enabled in
the options dialog on page Map. Check Show procedures on airport click to enable this function.
A single click on an user aircraft, AI aircraft or multiplayer aircraft shows details in the Simulator
Aircraft dock window.
A double-click zooms in showing either the airport diagram or the navaid closely and also shows
details in the Information dock window. The same applies for all AI or multiplayer aircraft or ships.
The double-click and single-click functionality does not work for flight plan waypoints or airports if
the flight plan edit mode is enabled. The edit mode can be disabled using the toolbar or Flight Plan
-> Edit Flight Plan on Map in the main menu. See also Map Flight Plan Editing.
The mouse click sensitivity can be adjusted in the Options dialog on the page Map Navigation.
Note
The center of the airport symbol is the hotspot for right or left click actions as well as for tooltip
display. This is also the case if the whole airport diagram is visible.
The same applies to all navaids as well as airport parking spots where the center is the hotspot
for clicks.

12.3. Mouse Click Hotspots
Map marks like range rings or measurement lines have hotspots to indicate that a modifier-click
like Ctrl+Click can remove them or an action is available in the context menu. The same applies to
the flight plan drag and drop editing mode.
The mouse cursor changes into a hand

to indicate a click spot.

Click spots are:
Center of range rings (small circle).
End of a measurement line (cross).
Runway threshold point (small circle) for airport traffic patterns.
Holding fix (small triangle) of a holding.
12.4. Mouse Clicks and Modifiers
You can use the keyboard and mouse click to get quick access to the following functions:
Shift+Click:

Adds or removes range rings or navaid range rings.
and Alt+Click: Starts great circle line measurement or deletes a measurement line.
Ctrl+Shift+Click: Add or edit an userpoint.
Ctrl+Alt+Click: Inserts an airport, a navaid, an userpoint or a position into the nearest flight
plan leg.
Shift+Alt+Click: Appends an airport, a navaid, an userpoint or a position to the flight plan.
Ctrl+Click

Clicking again on the hotspot removes the marks, measurement lines or flight plan waypoints.
12.5. Aircraft
The user aircraft and AI or multiplayer aircraft or ships will be shown on the map if the program is
connected to a flight simulator. Color indicates user or AI or multiplayer vehicle and the symbol
shape indicates if the aircraft is an piston/turboprop, jet, helicopter or a ship. The symbol outline
changes to gray if an aircraft is on ground.
Little Navmap limits the display of AI vehicles depending on size. Zoom close to see small aircraft
or boats
AI and multiplayer aircraft on ground are shown only on small zoom distances to avoid cluttered
airports. This means that an AI aircraft can disappear from the map when landing on an airport.
Tip
On the lowest zoom distance all aircraft are drawn to scale as are the parking spots which means
you can easily check if your aircraft fits on an apron, parking spot or taxiway.
A yellow wind arrow and labels for the situation around the user aircraft can be displayed on the
top center of the map. The displayed labels for aircraft can be configured in the dialog Options on
Map Display 2. No labels are shown for ship traffic.
See Aircraft and Ships for details about the aircraft type.
12.6. Tooltips
Hovering the mouse over the map will show tooltips for all map objects including airports, VOR,
NDB, airways, parking, fuel box, towers, aircraft and ships. The tooltip is truncated and shows a
message More ... if it gets too long. In that case reduce details or zoom in closer.
The sensitivity for the tooltip display can be adjusted in the Options dialog on Map Navigation.

Tooltip with information for an airport and a VOR.

Tooltip with information about airspaces.

12.7. Highlights

Airports, navaids or other features that are selected in the flight plan table or in a search result
table are highlighted on the map with a green/black or a yellow/black ring respectively.
Waypoints that are selected in the procedure preview are highlighted with a blue/black ring.
These highlight circles provide all functionality of visible map objects, even if the objects are not
shown at the current zoom distance (ring is empty). This allows double-click for zoom in, singleclick for information dock window and all context menu entries.
You can use Map -> Remove all Highlights and Selections to remove all highlights from the map.
12.8. Flight Plan
You can enable or disable the display of the flight plan as well as missed approaches in the menu
and toolbar.
All features which are part of the flight plan are forced to be shown even if they are disabled in the
menu. This means that destination, departure and alternate airport symbols as well as diagrams
are shown even if airport display is disabled. The same applies to all navaids and approach ILS.
Tip
Hide all map features to get a clean view on flight plan related airports and navaids only.
12.9. Airport Diagram
The display will change from a single icon to an airport diagram if you zoom in deep enough to an
airport. The diagram shows all taxiways, parking positions, gates, runways and more.
The airport diagram provides more information through tooltips for parking and tower positions. A
right-click on a parking position opens the context menu and allows to select the start position for
flight plan departure.
See Airport Diagram for details about the airport diagram.
Note
Airspaces are hidden if the airport diagram is shown.

Tip
You can adjust the visibility of airport elements like runways or aprons for diagram in the options
dialog on page Map Display 2 in the tree on the right side.
Use this is you’d like to rely on the airport diagrams of the OpenStreetMap background map, for
example.

High level view of the airport diagram of EDDH.

Detailed view of the airport diagram. Shows blue gates on the right and green general aviation ramp parking spots on the left. Long
displaced threshold of runway 33 is visible. Dashed yellow lines indicate taxi paths.

12.10. Context Menu Map
The map context menu can be activated using right-click or the menu key. Menu items are enabled
or disabled depending on selected object and some menu items contain the name of the selected

map object for clarification.
Mouse click modifiers like Ctrl+Click are shown as a hint on the right side of the context menu.
Little Navmap automatically inserts a sub-menu replacing the menu item if more than one
appropriate map object was found below the cursor. This helps to select the right airport from a
dense map which displays many airports in one spot, for example.
Some menus add an additional item Position to the sub-menu which inserts a plain position instead
of a navaid or an airport.
Menu items are disabled if their function does not apply to the clicked map object. Hints showing
the reason are appended to the menu text like (has not procedure) for an airport.

The various sub-menus of the map context menu.

12.10.1.

Show Information

Show detailed information in the Information dock window for the nearest airport, airway, airspace,
navaid or aircraft which name is shown in the menu item.
If you like to see information on all objects nearby a click position do a single left click into the
map.
See Information for details.

12.10.2.

Show Procedures

Open the procedure search tab of the search dock window and display all procedures for the
airport.
The menu item text varies depending if the airport is a part of the flight plan.

See Search Procedures for more information.

12.10.3.

Create Approach

Opens a dialog which allows to create a simple user defined final approach.
The text of this menu item varies depending if the airport is already the destination in the flight
plan or not.
See User Defined Approach for more information.

12.10.4.

Measure Distance from here

Display distances from the selected origin as you move the mouse over the map. Left-click on the
map to end measuring and keep the measurement line. All measurement lines are saved and will
be restored on next start up.
You can use the keyboard, mouse wheel or the map overlays to scroll and zoom while dragging a
line.
Right-click, press the escape key or click outside of the map window to cancel the measurement
line editing.
Measurement lines use nautical miles, kilometers or statue miles as unit. Feet or meter will be
added as unit if the lines are short enough. This allows to measure e.g. takeoff distance for
crossing takeoffs.
A great circle gives the shortest distance from point to point on earth but does not use a constant
course. For that reason the measurement line will show two course values. One for the start and
one for the end position.
Course is always indicated in degrees true which is indicated by the suffix °T. Additional information
like ident or frequency will be added to the line if the measurement starts at a navaid or an airport.
The width of distance measurement lines can be changed in the dialog Options on page Map Display.
The labels can be changed in the tree view on the right side of the page Map Display 2.
See Highlights and User Features for details on measurement lines.
Note that the menu item is disabled if measurement lines are hidden on the map (menu View ->
User Features). The menu item is suffixed with the text hidden on map if this is the case.

12.10.5.

Remove Distance measurement

Remove the selected line. This menu item is active if you right-click on the end point of a distance
measurement line (small cross).

12.10.6.

Add Range Rings

Show multiple red range rings around the clicked position. The number and distance of the range
rings can be changed in the Options dialog on page Map. A label indicates the radius of each ring.
The width of all range ring lines can be changed in the dialog Options on Map Display 2.
Note that the menu item is disabled if range rings are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

12.10.7.

Add Navaid Range Ring

Show a ring around the clicked radio navaid (VOR or NDB) indicating the navaid’s range. A label
shows ident and frequency and the ring color indicates the navaid type.

Note that the menu item is disabled if range rings are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

12.10.8.

Remove Range Ring

Remove the selected rings from the map. This menu item is active if you right-click on the center
point of a range ring (small circle).

12.10.9.

Add Traffic Pattern

This menu item is enabled if clicked on an airport. Shows a dialog that allows to customize and
display an airport traffic pattern on the map.
See Traffic Patterns.
Note that the menu item is disabled if traffic patterns are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

12.10.10.

Remove Traffic Pattern

Enabled if clicked on the airport traffic pattern hotspot (white filled circle at runway threshold)
which is indicated by a hand cursor. Removes the traffic pattern from the map.
See Traffic Patterns.

12.10.11.

Add Holding

Display a holding pattern at any position on the map. The hold may also be attached to navaids.
Opens a dialog for customization if selected.
See chapter Holdings for more information.
Note that the menu item is disabled if holdings are hidden on the map (menu View -> User Features).
The menu item is suffixed with the text hidden on map if this is the case.

12.10.12.

Remove Holding

Enabled if clicked on the hotspot (holding fix, white filled triangle) which is indicated by a hand
cursor. Removes the holding from the map.
See chapter Holdings for more information.

12.10.13.

Set as Departure

This is active if the click is at an airport, an airport parking position or a fuel box. It will either
replace the current flight plan departure or add a new departure if the flight plan is empty.
The default runway will be used as starting position if the clicked object is an airport. The airport
and parking position will replace both the current departure and start position if a parking position
is clicked within an airport diagram.

12.10.14.

Set as Destination

This menu item is active if the click is at an airport. It will either replace the flight plan destination
or add the airport if the flight plan is empty.

12.10.15.

Set as Alternate

This menu item is active clicked at an airport. Selecting this item adds the airport as an alternate to
the current flight plan.
More than one alternate can be added to the flight plan. Legs to the alternate airports originate all
from the destination.
Disabled if airport is already departure, destination or alternate.
Note that you have to activate an alternate leg manually if you would like to fly it (see Activate
Flight Plan Leg).

12.10.16.

Add Position to Flight Plan

Insert the clicked object into the nearest flight plan leg. The object will be added before departure
or after destination if the clicked position is near the flight plan end points.
The text Position in the menu is replaced with an object name if an airport, navaid or userpoint is at
the clicked position.
An user-defined flight plan position is added to the plan if no airport or navaid is near the clicked
point.
An userpoint is converted to an user-defined flight plan position if added to the plan.
You cannot edit flight plan legs that are a part of a procedure or between procedures.
Tip
All information from a userpoint like remarks, ident, region and name are copied to the flight
plan position if you right click on a userpoint and select Add Position to Flight Plan or Append
Position to Flight Plan.

12.10.17.

Append Position to Flight Plan

Same as Add Position to Flight Plan but will always append the selected object or position after the
destination or last waypoint of the flight plan.
This will remove STAR and approach procedures from the current flight plan, if any.

12.10.18.

Delete from Flight Plan

Delete the selected airport, navaid or user flight plan position from the plan. This can be departure,
destination, alternate airport or an intermediate waypoint.
Deleting a waypoint of a procedure removes the whole procedure.

12.10.19.

Edit Flight Plan Position or Edit Flight Plan Position Remarks

Change the ident, name, remarks or position of an user-defined flight plan waypoint. See Edit
Flight Plan Position.
Also allows to add a remark to any flight plan waypoint which is not an alternate and not a part of a
procedure. See Edit Flight Plan Remarks.
You can edit the coordinates directly instead of dragging the flight plan position (Map Flight Plan
Editing).
See Coordinate Formats for a list of formats that are recognized by the edit dialog.

12.10.20.

Userpoint

12.10.20.1.

Add Userpoint

Add an user-defined waypoint to the userpoints. Some fields of the userpoint dialog are populated
automatically depending on the selected map object.
Coordinates are always filled-in. If the selected object is an airport or navaid, an userpoint of type
Airport or Waypoint respectively is created and the fields Ident, Region, Name and Altitude are filledin.
If the selected position is empty map space, an userpoint of type Bookmark is created at this position.
Altitude is filled-in if GLOBE offline elevation data is installed. See Install GLOBE elevation data.
See Add Userpoints for more information.

12.10.20.2.

Edit Userpoint

Open the edit dialog for an userpoint. Only enabled if the selected object is an userpoint. See Edit
Userpoints.

12.10.20.3.

Move Userpoint

Move the userpoint to a new position on the map. Only enabled if the selected object is an
userpoint.
Left-click to place the userpoint at the new position. Right-click or press the escape key to cancel
the operation and return the userpoint to its former position.

12.10.20.4.

Delete Userpoint

Remove the user-defined waypoint from the userdata after confirmation. Only enabled if the
selected object is an userpoint.

12.10.21.

Edit Log Entry

Active when clicked on the blue great circle line, the blue flight plan preview or an airport of a
logbook entry highlight.
Allows to edit the respective logbook entry. See Edit Logbook Entry.

12.10.22.

Fullscreen Map

Same as Fullscreen Map. Only visible in fullscreen mode.
12.10.23. More

12.10.23.1.

Show in Search

Show the nearest airport, navaid, userpoint, online client or online center in the search dialog. The
current search parameters are reset in the respective tab.

12.10.23.2.

Copy to Clipboard

Copies the coordinates at the clicked position into the clipboard.
The coordinate format depends on the selection in Options on page Units.

12.10.23.3.

Set Center for Distance Search

Set the center point for the distance search function. See Distance search. The center for the
distance search is highlighted by a

symbol.

The symbol cannot be hidden. Set it at a remote position if you like to hide it.
Note that the symbol is only an indicator for the search center position and does not have a context
menu or a mouse action attached.

12.10.23.4.

Set Home View

Set the currently visible map view as your home view. The center of the home area is highlighted
by a

symbol.

You can jump to the home view by using main menu Map -> Goto Home.
The symbol cannot be hidden. Set it at a remote position if you like to hide it.
Note that the symbol is only an indicator for the home view center position and does not have a
context menu or a mouse action attached.

13. Legend
By default, all speeds are given in knots, distances in nautical miles, altitudes and elevations in
feet. The units can be set to imperial or metric in the dialog Options on Units.
Colors, size and text labels of some map elements can be changed in the dialog Options on Map
Display. This legend shows the default values.
Heading and course are suffixed with °T for true course or °M for magnetic course.
13.1. Mouse Clicks
The display of a map feature class will be enabled if you use on of these mouse clicks. A Shift+Click
will enable display of range rings, for example. A second Shift+Click into the center (active point)
will remove the range rings.
You can enable or disable visibility in menu View -> User Features or the toolbar.
A click in the map on the active spot of a feature like a range ring removes it. The cursor changes
to a hand symbol to indicate an active spot which allows to remove a feature by click or
remove/edit it in the context menu.
Mouse

Description

Single Click

Show information about all features around the
cursor position.

Double Click

Zooms to the clicked feature and shows
information.

Shift+Click

Add or remove range rings or navaid range
rings.

Alt+Click

Start great circle line measurement or delete
measurement line.

Ctrl+Shift+Click

Add or edit an userpoint.

Ctrl+Alt+Click

Insert airport, navaid, userpoint or position
into the nearest flight plan leg.

Shift+Alt+Click

Append airport, navaid, userpoint or position to
flight plan.

Wheel

Zoom in or out.

Shift+Wheel

Zoom in or out in small steps.

Ctrl+Wheel

Increase or decrease map details.

13.2. Key Commands
You have to activate the map window (i.e. click into it or press the key F2) before you can use the
keyboard shortcuts.
Key

Description

Key

Description

Cursor keys

Scroll the map.

+

and -

Zoom in and out.

*

and /

Zoom in and out in small steps.

Alt+Left

Ctrl++

and Alt+Right

and Ctrl+-

Go forward or backward in the map position
history.
Increase or decrease details.

Ctrl+Home

Go to home position.

Ctrl+End

Go to center for distance search.

13.3. Highlights and User Features
Symbol

Description

Center of the home position.

Center point that will be used for distance
searches.
Shows map center. Useful for Click and Center
navigation mode. Also shows map navigation
click/touch areas if enabled.
Flight plan with distance, direction and
magnetic course at each leg. Displayed values
can be changed in dialog Options on tab Map
Display 2. °M and °T indicate magnetic or true
course, respectively.

Flight plan procedure leg with the same
information as above.

Active flight plan leg

Wind direction and speed at flight plan
waypoint. See chapter Winds Aloft below for
details about wind barbs.

Symbol

Description

Flight plan departure position on airport. Either
parking, fuel box, helipad, water or runway.

Top of climb point with distance from
departure. Can be disabled in menu View ->
Show Top of Climb and Top of Descent

Top of descent point with distance to
destination. Can be disabled in menu View ->
Show Top of Climb and Top of Descent
Range rings labeled with distance. The number
and distance of the range rings can be changed
in the Options dialog on page Map.

VOR or NDB range rings labeled with ident and
frequency. Color indicates Navaid type.

Great circle distance and course measurement
line indicating length and true heading at start
and destination. The two heading values will be
equal for small distances. For shorter distances
length is also shown in feet or meter. The width
of distance measurement lines can be changed
in the dialog Options on page Map Display 2.
The labels can be changed in the tree view on
the right side of the same page.
Measurement lines starting from an airport or
navaid have the same color and additional
ident and frequency labels. Course will
consider magnetic variation of a navaid.

A highlighted airport or navaid selected in the
search result table.

A highlighted airport or navaid selected in the
flight plan table.

Highlighted positions of a procedure leg in the
preview. Small circle show from and large
circle to position.
Thin circle shows the recommended or related
navaid of a procedure leg. This can be a
VORDME for a DME arc approach leg for
example.

Symbol

Description

This shows the related position on the flight
plan when hovering the mouse above the
elevation profile.

13.4. Logbook Preview
Direct connection between departure and destination as well as flight plan preview and flown trail is
shown for selected logbook entries. Any of the above can be disabled in the logbook search context
menu.
Airports and great circle path between
departure and destination for a logbook entry
selected in the search result table. Label shows
departure, destination and great circle distance
between airports.
Flight plan preview as stored with the logbook
entry. Waypoint names and flying direction
indicated by arrows. Note that complex
procedures are not visible.

Flown user aircraft trail stored with the logbook
entry.

13.5. Compass Rose
Line thickness can be changed in dialog Options on the tab Map Display 2.
The colors for flight plan leg course and heading indicator depend on settings for active flight plan
leg which can be changed in the dialog Options on tab Map.
Symbol

Description

True north.

Magnetic north.

Distance circles and marks from user aircraft if
connected.

Solid line shows aircraft track in degrees
magnetic if connected.

Dashed line shows aircraft heading if
connected.

Magenta line segment shows the course to
next waypoint of the active flight plan leg.
Hidden if no flight plan loaded.
Heading indicator. Shows the heading that has
to be flown towards the next waypoint of the
active flight plan leg considering cross wind.
Hidden if no flight plan loaded.

13.6. Aircraft and Ships
Symbol

Description
Current user vehicle if connected to the
flight simulator. Labels vary and can be
customized in Options on the page Map
Display. The user aircraft depends on
selected aircraft (jet, piston/turboprop or
helicopter).

User aircraft on ground or ship.

Aircraft carrier and frigate (X-Plane only)

Needle showing the current ground track
of the aircraft. Aircraft nose shows
heading.

User aircraft trail if connected to the flight
simulator.

Wind around the user aircraft with
direction in degrees magnetic and speed.

AI or multiplayer aircraft. Labels vary and
can be customized in Options on the tab
Map Display. The symbol depends on
aircraft type (jet, piston/turboprop,
helicopter or ship).
Online network aircraft/client. Labels vary
and can be customized as above.
13.7. Airports
Airports having control towers are shown in dark blue others in magenta. Add-on airport names
and idents are shown italic and underlined throughout the whole program. Airports that are part of
the flight plan have a light yellow text background.
The symbol is shown smaller if an airport has no runways. This is the case for some add-on airports
that use another techniques like photo scenery to display runways.
Symbol

Description
Airports with hard surface runways longer than
8,000 ft or 2,400 m. All runways longer than
4,000 ft or about 1,200 m are shown. Only for
lower zoom distances.
Airports with hard surface runways. White line
shows heading of longest runway.

Symbol

Description
Airports with soft surface runways.
Empty airports shown in gray. No taxiways, no
parking spots and no aprons.
Seaplane base having only water runways.

Military airport.

Heliport having only helipads and no runways.

Abandoned airport. All runways are closed.

Airports that have fuel available.

Add-on airports are always highlighted
independent of Force Show Addon Airports or
not. You can disable this in the options dialog
on page Map Display by unchecking Highlight
add-on airports.

Weather at airport. See chapter Airport
Weather below.

Airport label showing name, ident, ATIS
frequency, elevation, lighted runways (L) and
length of longest runway. The text labels for an
airport can be changed in the dialog Options on
the tab Map Display.

Airport runway overview shown before the full
airport diagram when zooming in.

13.8. Navaids
Navaids that are part of the flight plan have a light yellow text background.
Symbol

Description

Symbol

Description

VOR DME including ident, type (High, Low or
Terminal) and frequency. Compass rose shows
magnetic variation on lower zoom distances.
Small blue rectangle at high zoom levels.

VOR including ident, type and frequency. Tiny
blue rectangle at high zoom levels.

DME including ident, type and frequency. Small
blue rectangle at high zoom levels.

TACAN including ident, type (High, Low or
Terminal) and channel. Compass rose shows
magnetic variation on lower zoom distances.
Small blue rectangle at high zoom levels.

VORTAC including ident, type (High, Low or
Terminal) and frequency. Compass rose shows
magnetic variation on lower zoom distances.
Small blue rectangle at high zoom levels.

NDB including ident, type (HH, H, MH or CL compass locator) and frequency. Small dark
red circle at high zoom levels.
Waypoint with name. Small magenta triangle
at high zoom levels.

User-defined waypoint with name.

Invalid airport, waypoint, VOR or NDB that is
part of the flight plan but could not be found in
the Scenery Database.
Marker with type and heading indicated by lens
shape.
Jet airway with label showing name, type (Jet
or Both), minimum and maximum altitude.
Text depends on zoom distance. A preceding
arrow will show the allowed direction if the
airway is one-way.

Symbol

Description
Victor airway with label showing name, type
(Victor or Both), minimum and maximum
altitude. Text depends on zoom distance. A
preceding arrow will show the allowed direction
if the airway is one-way.
Eastbound PACOTS track with flying direction,
name 2 and type. Tracks having no east/west
direction are shown in gray color.

Westbound PACOTS track with flying direction,
name H and type.

ILS with glideslope and markers. Label shows
ident, frequency, magnetic heading, glideslope
pitch and DME indication if available.
Localizer. Label shows ident, frequency,
magnetic heading and DME indication if
available.
13.9. Procedures
See chapter Procedures for more detailed information on all the legs.
Symbol

Description

SID, STAR, approach or transition leg for flight
plan and in preview with distance, direction
and magnetic course at each leg.

Missed approach leg for flight plan and
preview.

Dotted line indicates circle-to-land or straightin part of a procedure leading to a runway end.
Here part of flight plan.

Vector leg indicating course to an initial fix.
Here part of flight plan.

Manual leg. Fly according to ATC instructions.
Here shown as preview.

Symbol

Description

Leg to alternate destination.

Gray yellow filled circle indicates a procedure
point which is not a navaid but defined by
course and/or distance from a navaid, an
altitude restriction or manual termination.
A black circle indicates an overfly waypoint.
Can be a procedure point or a navaid.

The Maltese cross highlights the final approach
fix or the final approach course fix.

Prefix GS is not an altitude restriction but an
indicator for the ILS glideslope altitude. Can
mean at or at or above.

Fly a heading, track or a hold until manually
terminated by ATC.

Intercept the next approach leg at a course of
about 45 degrees.

Procedure leg that is terminated when reaching
the given altitude.

A fix defined by a course or heading and
distance to a navaid.

Turn to intercept a radio navaid radial.

This fix is defined by a heading or track which
is terminated by reaching a DME distance.

Intercept a course to the next fix at an angle of
about 45 degrees.
13.10. Airport Diagram
Runway, taxiway, helipad and apron colors indicate surface type. White is used for an unknown or
invalid surface type given by an add-on developer.

Symbol

Description
Runway with length, width, light
indicator (L) and surface type.

Runway end with ident and magnetic
heading.

Displaced threshold. Do not use for
landing.

Overrun area. Do not use for taxi,
takeoff or landing.

Blast pad. Do not use for taxi, takeoff or
landing.

Taxiway with name and center line.

Closed taxiway.

Semi transparent dotted aprons and
taxiways indicate that no surface is
drawn. It might use a photo texture or
simply the default background.
Tower. Red if a tower frequency is
available. Otherwise just view position.

Fuel

GA ramp with parking number and
heading tick mark.

Symbol

Description
Gate with number and heading tick
mark. Second ring indicates availability
of jetway.

Cargo ramp

Military combat parking or cargo ramp.

Helipads. Red text indicates medical
helipad. Color indicates surface.

13.11. Elevation Profile
The colors and symbols of the elevation profile follow the style of the main map as set in the
options dialog on tab Map Display. Colors, patterns and symbols for airports, navaids, procedures,
active and passed flight plan legs are the same. The profile display also follows other map settings
like visibility of flight plan line, aircraft and aircraft trail.
Symbol

Description

Ground with departure elevation on the left
and destination airport elevation on the right.

Flight plan altitude.

Top of climb with distance from departure.

Top of descent with distance to destination.

At altitude restriction of a procedure with
waypoint name.

Symbol

Description

At or above altitude restriction of a procedure.

At or below altitude restriction of a procedure.

At or above and at or below (between) altitude
restriction of a procedure.

Minimum safe altitude for flight plan. This is
elevation plus 1,000 ft rounded up to the next
500 ft. The 1,000 ft buffer can be changed in
the dialog Options on the tab Flight Plan
Minimum safe altitude for a flight plan
segment. The same rules apply as to the
minimum safe altitude for flight plan.

User aircraft if connected to the simulator.
Labels show actual altitude and climb/sink
rate.
User aircraft trail if connected to the flight
simulator.
ILS slope. Label shows ident, frequency,
magnetic heading, glideslope pitch and DME
indication if available. Only shown if an
approach is selected and runway end has an
ILS. Opening angle has no relation to actual
slope precision.
Visual Approach Slope Indicator. Label shows
slope pitch and VASI type. Only shown if an
approach is selected and runway end has a
VASI. Opening angle has no relation to actual
slope precision.
13.12. Airport Traffic Pattern
Color and indicators depend on user choice in Traffic Patterns dialog.
Symbol

Description

Symbol

Description

Downwind leg of airport traffic pattern with
altitude and magnetic course.

Final leg of airport traffic pattern with runway
and magnetic course.

Arrow and dashed line shows path for pattern
entry.
Dashed line and arrows show path for pattern
exit.
White circle is active point at the runway
threshold of the pattern. Mouse cursor changes
above and allows to remove the pattern in the
context menu.
13.13. Holding
Color depends on user choice in holding dialog.
Symbol

Description
Holding fix, magnetic and true inbound course,
time for straight leg and navaid ident (LBU).
Ident is only shown if holding is attached to
navaid. True course display depends on
options.
Magnetic and true outbound course, speed and
altitude as given in the dialog. True course
display depends on options.
Active point and holding fix. Mouse cursor
changes above and allows to remove the
holding in the context menu.

13.14. MORA Grid
The minimum off-route altitude grid provides an obstacle clearance altitude within an one degree
grid. The altitudes clear all terrain and obstructions by 1,000 ft in areas where the highest
elevations are 5,000 ft MSL or lower. Where the highest elevations are above 5,000 ft MSL terrain
is cleared by 2,000 ft.
Symbol

Description

MORA grid. Large number is 1,000 ft and small
number 100 ft. Example here: 3,300, 4,400,
6,000, 9,900 and 10,500 ft.

13.15. Airport Weather
13.15.1. Flight Rules
Symbol Color

Description

VFR. Visual flight rules.

MVFR. Marginal VFR. Visibility equal or below 5
statue miles or lowest ceiling at or below 3,000
ft.
IFR. Instrument flight rules. Visibility below 3
statue miles or lowest ceiling below 1,000 ft.
LIFR. Limited IFR. Visibility below 1 statue
miles or lowest ceiling below 500 ft.
13.15.2. Cloud Cover
Symbol

Description

No clouds.

Few

Scattered

Broken
ceiling

Overcast

13.15.3. Wind
Symbol

Description

No pointer indicates wind below 2 knots.

Pointer without wind barb shows wind below 5
knots from north-west.

Short barb is 5 knots wind.

Symbol

Description

Long barb is 10 knots wind.

50 knots wind.

Example: 25 knots.

Example: 65 knots.

Example: 15 knots steady wind (black) gusting
to 30 knots (red).

13.16. Winds Aloft
Symbol

Description
No pointer indicates wind below 2
knots.

Below 5 knots from west.

Example: 25 knots.

14.

Traffic Patterns

Little Navmap can display an airport traffic patterns for guidance on the map.
Right click on an airport in the map, flight plan table or airport search result table and select Add
Airport Traffic Pattern.
This will show a dialog where you can select a runway and customize the pattern.
Note that the menu item is disabled if traffic patterns are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.
Little Navmap shows a tooltip with information about the traffic pattern when hovering the mouse
above the hotspot (white filled circle) at runway threshold.
14.1. Create Traffic Pattern
Dialog input and selection fields:
Dialog header: Shows airport name and its ICAO ident as well as field elevation.
Runways: List of available runways for the airport. Shows runway name, length, width,
magnetic heading, surface and lighting status.
Turn direction: Select to choose between left or right turn pattern. This is automatically
updated when selecting a runway from FSX or P3D.
Base 45° after threshold: Calculates the final leg length automatically when checked.
Base leg to runway threshold: Length of the final leg. Measured from turn to final to the runway
threshold.
Downwind to runway: Parallel distance from downwind leg to runway.
Pattern altitude: Pattern altitude above airport elevation. This is automatically updated when
selecting a runway from FSX or P3D.
Entry and exit indicators: Shows dashed lines and arrows giving hints for entry and exit
points.
Line Color: Color of the pattern lines and labels.
Traffic patterns can be removed by either selecting Map -> Remove all Ranges, Measurements and Patterns
or by right click on the hotspot (circle) at the runway threshold.
A click on OK or a double click into the list Runways closes the dialog and creates the traffic pattern.
See Traffic Patterns for details about the displayed numbers in the pattern.

Traffic pattern dialog for EDFE runway 08 at 1,000 ft above airport elevation.

Traffic Pattern for the settings in the dialog above. Downwind leg shows pattern altitude above MSL and course and final leg shows runway
name and course. White filled circle is the hotspot that can be right clicked to remove the pattern in the context menu.

15.

Holdings

Little Navmap can display a holding pattern at any place or navaid on the map.
Holdings can be placed at any map position. Attaching a holding to a navaid will use the magnetic
declination of the navaid and show its ident in the holding label.
Right click in the map, flight plan table, airport, navaid or userpoint search result table and select
Add Holding.
This will show a dialog where you can select a runway and customize the holding.
Note that the menu item is disabled if holdings are hidden on the map (menu View -> User Features).
The menu item is suffixed with the text hidden on map if this is the case.
Little Navmap shows a tooltip with information about the holding when hovering the mouse above
the hotspot (white filled triangle) at the holding fix.
15.1. Create Holding
Dialog input and selection fields:
Dialog header: Shows navaid name and ICAO ident or coordinates if holding is not attached
to a navaid.
Turn direction: Select to choose between left or right turn.
Course: Course of the inbound (towards fix) leg of holding in magnetic degree.
Speed: Intended holding speed. Used together with time to calculate holding size.
Time: Time of the straight legs in the holding. Used together with speed to calculate holding
size.
Label Straight section length: Calculated length of the straight inbound and outbound
sections.
Label Total time to complete: Total time to complete one holding.
Altitude label: Altitude to display at the holding.
Line Color: Color of the holding lines and labels.
Holdings can be removed by either selecting Map -> Remove all Ranges, Measurements and Patterns or by
right click on the hotspot (triangle) at the holding fix.
See Holding for details about the displayed numbers in the pattern.

Holding dialog for VORDME RID.

Holding at VORDME RID. Inbound label shows inbound magnetic course, holding time and navaid ident. Outbound track has outbound
magnetic course, speed and altitude as label. While filled triangle is the hotspot and holding fix.

16.

Compass Rose

The compass rose indicates true north, magnetic north, aircraft heading and aircraft track.
User aircraft heading, track, distance rings and markers are shown if Little Navmap is connected to
a simulator. The rose is centered around the user aircraft if connected.
The compass rose is kept centered in the current view if not connected to a simulator. Magnetic
declination is based on the declination in the center.
Once connected, the compass rose will be attached to the user aircraft and follow its position. This
can be disabled in menu View -> Attach Compass Rose to Aircraft.
The size is adapted to the map view size but not larger than 1,000 NM and not smaller than 4 NM.
Line thickness and other display options can be changed in dialog Options on page Map Display 2.
The colors for flight plan leg course and heading indicator depend on settings for active flight plan
leg which can be changed in the dialog Options on page Map Display.
16.1. Indicators

True north.

Magnetic north.

Distance circles and marks from user aircraft if
connected.

Solid line shows aircraft track in degrees
magnetic if connected.

Dashed line shows aircraft heading if
connected.

Magenta line segment shows the course to
next waypoint of the active flight plan leg.
Hidden if no flight plan loaded.
Heading indicator. Shows the heading that has
to be flown towards the next waypoint of the
active flight plan leg considering cross wind.
Hidden if no flight plan loaded.
16.2. Examples

Compass rose without simulator connection. Distance rings disabled.

Compass rose centered around user aircraft. No flight plan loaded. Therefore, heading and next waypoint indicators hidden.

17.

Sun Shading

Little Navmap allows to display the sun shadow on the globe. This works in both projections
Mercator and Spherical.
Enable the shadow in the menu View -> Show Sun Shading.
You can change the time source for the sun shading in View -> Sun Shading Time.
The shadow darkness can be changed in the dialog Options on page Map Display 2, Sun shading
Darkness at the bottom of the dialog.

Sun shading on the northern hemisphere.

17.1. Time Sources
You can choose between three time source for the sun shading. Time is not fixed and will advance
for all sources or updated from simulator time.
Simulator:

Uses the time of the connected flight simulator. Falls back to real time if not
connected to a simulator. Automatically updates the shadow if the simulator time changes.
Real UTC Time: Always use real time.
User defined Time: Allows to use the user defined time as changed by Set User defined Time
below.
17.2. Set User defined Time
The menu View -> Sun Shading Time -> Set User defined Time opens a dialog to set an user defined time
in UTC as a source for the sun shading.
Tip
You can move the dialog away from the map window and see the results immediately by clicking
the button Apply.

Note
Do not forget to click on a date when changing months or years. Otherwise the old date will be
used.

Note that the user defined time is reset to current real time when restarting Little Navmap.

Date and time for sun shading on November 8 at 10:42 pm Zulu Time.

18. Map Image Export
This dialog appears when saving the map view to an image file, for AviTab or copying it to the
clipboard.
Dialog input and selection fields:
Resolution:

Select the desired resolution here. The following options are available:
Export the map view as shown. The current pixel size of this image is
shown in the list entry.
Custom Resolution: Use the pixel size from the input fields Width and Height.
720p, 1280 x 720, 16:9,
1080p, 1920 x 1080, 16:9,
1440p, 2560 x 1440, 16:9,
2160p, 3840 x 2160, 16:9 and
4320p, 7680 x 4320, 16:9: Pre-defined typical image and monitor resolutions.
Width and Height: Use this to define the pixel size for the image if Custom Resolution is selected.
Zoom out to avoid blurred map: Checking this option helps to get a sharp background image for
online maps (e.g. from OpenStreetMap). This works best with the map projection Mercator.
As a result the map might be zoomed out farther than expected in some cases.
Current Map View:

Note
All options except Current Map View will change visible details. Navaids might appear which are not
shown in the map on screen, for example.

Dialog shown after choosing Save Map as Image ....

19.

Elevation Profile

This dock window shows the ground elevation, flight plan with cruise, climb, descent legs and
altitude restrictions together with all flight plan waypoints. It is only available when a valid flight
plan is loaded. The user aircraft will be shown if Little Navmap is connected to the simulator.
Note
The elevation display covers only the flight plan and will not change the depiction if you get off
the flight plan with your simulator aircraft. You need a valid flight plan (i.e. a departure and
destination airport) and a valid aircraft performance file to see the elevation profile.
The elevation profile also does not cover missed approaches and legs to alternate airports. Create a
new flight plan from the destination to the alternate airport if you wish to use the elevation profile.
Movement of the aircraft and the trail in the elevation profile is tied to the active flight plan leg and
will not be correct if flying away from the active leg.
19.1. Top Label
Following information is shown in the top label if connected to a flight simulator with a valid flight
plan:
Distance from user aircraft to flight plan destination
Distance from user aircraft to the top of descent
Example: To Destination: 1,213 nm, to Top of Descent: 1,109 nm.
The label is hidden if not connected to a simulator.
19.2. Tooltip Label
Additional information is shown in a tooltip label at the right or left side in the window if the mouse
is hovered over the diagram. The corresponding position is highlighted on the map with a
black/cyan circle. The label changes the side depending on mouse position.
The label shows the following information for the mouse position:
Distance from departure and to destination plus calculated altitude and next waypoint.
Course for the flight plan leg at the cursor position.
Heading for this flight plan leg at the position. This is calculated based on wind conditions.
Ground altitude and calculated altitude above ground.
Safe altitude of the flight plan leg at the cursor position (orange line).
Wind direction and speed as well as head- (▼) or tailwind (▲) component.

Information for position between waypoints GIGIR and OBITI. Indicating a headwind of 28 kts at this position. User aircraft still climbing.
Note the image showing German number format with dot as thousands separator.

19.3. Bottom Label
This is only shown if the profile could not be built due to errors in the flight plan or aircraft
performance.
The error messages are the same as in Error Display in the flight planning window.
Hover the mouse over the label or click it for more information about the error.
19.4. Zoom Sliders

The right side of the elevation profile contains the zoom sliders. The following controls are
available:

Splitter: You can resize the right part of the elevation profile window using this splitter
button. The part containing the sliders will be collapsed if you drag it to the far right. You
can open the collapsed part again by dragging the splitter to the left.
Expand to Window:

Resets the view back to 100 percent showing the whole flight plan.

Zoom Vertically: Move the slider up to zoom in vertically. Maximum zoom results in 500 ft
height for the whole profile window.
Zoom Horizontally: Move the slider up to zoom in horizontally. Maximum zoom results in
about 4 NM distance for the whole profile window.

19.5. Mouse Movement
Hover: The corresponding position within the flight plan is highlighted on the map with a
black/cyan circle.
Wheel: Zoom in and out horizontally.
Shift+Wheel: Zoom in and out vertically.
Left Click and drag: Move map up, down, left or right.
Left Double Click: Zoom to position on main map.
Right Click: Show context menu.
19.6. Keyboard Movement
Click on the elevation profile window to activate it before using the keyboard.
Cursor keys: Move map up, down, left or right.
+ and -: Also on numpad. Zoom in and out horizontally.
* and /: Also on numpad. Zoom in and out vertically.
0 or Ins : Reset view to 100 percent and show the whole flight plan.
Home and End: Jump to departure or destination.
PageUp and PageDown: Move forward or backward one page.
19.7. Context Menu Elevation Profile

19.7.1.

Show Position on Map

Zooms to the corresponding position on the map. This is the same as double clicking into the
elevation profile.

19.7.2.

Expand to Window

Resets the view back to 100 percent showing the whole flight plan.

19.7.3.

Center Aircraft

If this option is selected, the aircraft remains centered on the left of the altitude profile during
flight.
The aircraft will be kept on the upper part of the window if the aircraft is descending and on the
lower part if climbing.
See also for more information on jump back in the options dialog on Simulator Aircraft.

19.7.4.

Delete Aircraft Trail

The aircraft trail is saved and will be reloaded on program startup.

This menu item removes the user aircraft trail from the elevation profile only. It does not remove
the trail from the map. Use this if the trail appears in the wrong place or shape after creating of
modifying a flight plan.
The trail in the elevation profile is of no relevance for the GPX file export.

19.7.5.

Show VASI

Shows a VASI slope if an approach procedure with a runway (not circle-to-land) is selected in the
flight plan and if the runway has a VASI.
The slope is drawn with the correct angle to be usable as an approach guide. The vertical opening
angle is only meant for depiction and has no relation to the real VASI accuracy.

Display of VASI slope at destination airport. Slope is 3 degrees and VASI type is PAPI4. Final approach fix is marked with a Maltese cross.

19.7.6.

Show ILS

Shows an ILS glideslope if an approach with a runway is selected in the flight plan and if the
runway has an ILS.
The slope is drawn with the correct angle to be usable as an approach guide. The vertical opening
angle is only meant for depiction and has no relation to the real ILS accuracy.
A label on top shows name, frequency, heading, glideslope angle and DME indicator if available

Display of ILS at destination airport. Final approach fix is marked with a Maltese cross.

19.7.7.

Show Top of Climb and Top of Descent

Hides the climb and descent slopes as well as the top of climb and top of descent indicators when
disabled. This affects the map and elevation profile display but not the altitude calculation in the
fuel report or elevation profile.
This is the same function as Show Top of Climb and Top of Descent in the menu View.
19.7.8. Follow on Map
The map view will be centered - not zoomed in - on the position below the cursor if hovering above
the elevation profile when this option is selected.
19.7.9. Show Tooltip
Hides the mouse hover tooltip Tooltip Label if unchecked.

19.7.10. Show Zoom Sliders
Show or hide the zoom sliders and buttons at the right side of the elevation profile. You can still
zoom using the mouse or the keyboard.
19.7.11. Show Labels
Show or hide the altitude labels at the right side of the elevation profile.
19.7.12. Show Scrollbars
Show or hide the scroll bars at the bottom and the right side of the elevation profile. You can still
use the mouse or keyboard to navigate.
19.8. Profile Display
The colors, symbols and font of the elevation profile follow the style of the main map as set in the
options dialog. Colors, patterns and symbols for airports, navaids, procedures, active and passed
flight plan legs are the same. The profile display also follows other map settings like visibility of
flight plan line, aircraft and aircraft trail.
Aircraft heading will turn if a backward movement relative to the active flight plan leg is detected.
For more information see the Elevation Profile.
The elevation profile uses actual altitude for display of restrictions, slope and cruise.
The aircraft icon is shown using indicated altitude to ensure matching to cruise altitude line at the
higher flight levels.
You might see vertical aircraft movement of the aircraft symbol and jumps in the trail when
adjusting barometric pressure in the simulator altimeter.
Note
Note that the profile display depends on the correct sequencing of the active flight plan leg
(magenta line). The aircraft will be displayed in the wrong position and the aircraft trail will be
erratic if the active leg is not correct or manually changed.
The aircraft trail will be displayed incorrectly in the elevation profile if the flight plan is changed
(i.e. the flight plan length or geometry changes). You can delete the profile aircraft trail in
context menu Delete Aircraft Trail while keeping the trail on the map.

Flight plan elevation profile with line indicating the mouse hovering position. Orange lines show minimum safe altitude for flight plan
segments. Red line shows overall minimum safe altitude. Top of climb and top of descent points shown including slope. Orange flight plan
lines show procedure legs. Waypoint EV501 has an overfly condition and there are several altitude restrictions shown for the approach
procedure below the tooltip.

19.9. Top of Climb and Top of Descent Paths
The elevation profile will also display the top of climb and top of descent which are calculated based
on the current Aircraft Performance profile and wind situation.
Note that the TOC and TOD calculation is influenced by altitude restrictions in procedures. Little
Navmap will calculate a climb or descent path always adhering to these restrictions. The resulting
path might use a higher or lower climb or descent speed than expected.
The path is also forced to the lowest allowed altitude at the final approach fix (FAF) and the final
approach course fix (FACF) to avoid arriving above the ILS glide slope or too high at the destination
runway.

You can safely follow the descent path as shown by Little Navmap, provided you can manage your
aircraft speed at the same time. For large aircraft you might want to descent around 10 nm earlier
to reduce speed to 250 knots below 10,000 ft.
I recommend to make the descent path manually more shallow (i.e. use a lower sink rate) to take
the deceleration phases into account.
The climb and descent paths are affected by wind and are moved accordingly for strong head- or
tailwinds. The climb path will be steeper in the elevation profile if you climb in a strong headwind,
for example.
See chapter Winds Aloft for more information.
The plan will switch to a flat display showing only a flight plan line at cruise altitude if the TOC
and/or TOD cannot be calculated or if the plan violates altitude restrictions. A red warning message
is displayed if this is the case. Click the message for more information.

An approach procedure which requires the aircraft to descent early due to a restriction between 7,000 and 10,000 ft at ARTIP.

19.10. Elevation Data
Elevation processing is done in the background since data has to be downloaded and computation
is CPU intensive. Therefore, the update of the elevation display can take from a few seconds up to
half a minute. This background update is started after creating or changing the flight plan or when
new elevation data was downloaded. The display will be updated accordingly whenever new data is
available.
Close the Flight Plan Elevation Profile window if you think that it causes performance problems or
stutters. All updates will stop once the window is closed.
19.10.1. Online Elevation Data
Note that the third party online elevation data does not cover all countries and currently ends at 60
degrees north. The data contains several known errors which cannot be fixed.
The calculation of online elevation points is limited to flight plan segments not longer than 2,000
NM to avoid overloading. Add more waypoints or calculate a flight plan to avoid this limitation.
19.10.2. Offline Elevation Data
Using the recommended freely downloadable GLOBE - Global Land One-km Base Elevation Project
[https://ngdc.noaa.gov/mgg/topo/globe.html] elevation data has several advantages:
Faster updates
World wide coverage
No known errors
Display of altitude below the cursor in the status bar
Resolution is a bit lower than the one for the online data, though.
See Install GLOBE elevation data in the options dialog for instructions how to download and install
the GLOBE data.

20.

Search

The search dock window contains several tabs with similar functionality that allows to search for
objects by name, ident or other criteria.
Airport, navaid, userpoint and online search tabs contain multiple rows of search filters. These rows
can be switched on and off with the drop down menu on the menu button

on the top right.

The drop down menu prefixes menu items with a change indicator * to show that the related filter
row has modifications. You can use this to find out why a search does not give the expected
results.
Tip
If you do not get the expected results or no results at all use the Reset Search menu item, button
Reset Search or press Ctrl+R to clear all search criteria.
Filters are defined by various controls which are mostly self explaining. Only text filters and the tristate checkboxes like Lighted, Approach or Closed need a few extra remarks below.
All filters can be used together where all conditions have to be met (and operator). All filters except
the distance search filter are applied immediately. The distance search is applied after a short delay
for each change.
Entering three or four characters in the ICAO Code field of the airport search tab will trigger
a quick search which ignores all other filters.
A tooltip on the blue help button on the top right shows information about searching.
Tip
You can use the cursor key Down to jump from the input fields into the result table.
Using keyboard shortcuts like Ctrl+I for Show Information or Ctrl+M for Show on map are usable directly
from the input fields and will apply to the topmost airport in the result table.
The same applies to other tabs like navaid and logbook search as well.
20.1. Text filters
The standard is to search for entries that start with the entered text.
The placeholder * stands for any text. Once a * is included in the term, the standard search (match
start of text) is no longer used. In that case you might have to add a * at the end of the search
term as well to get the expected result.
The search is negated (i.e. find all entries that do not match) if the first character in a search box
is a -.
Note that all of the above does not apply to numeric fields like Runways: Min or Altitude: Max.
20.2. Tri state checkboxes
These are used to filter airports by presence of certain facilities or properties.
Below are the states as they are shown in Windows 10:
Black Box: Condition is ignored.
Checked: Condition must match.
Empty Box: Condition must not match.

Colors and look of these checkboxes vary with theme and operation system. So instead of gray
another color might be used (red fill on Linux or a - for macOS).
20.3. Distance search
This function is only available in the airport and navaid search.
This function allows you to combine all other search options with a simple spatial search.
The checkbox Distance has to be selected to enable this search. The result will include only airports
or navaids that are within the given minimum and maximum range of NM from the search center.
This allows you to quickly search for a destination that is within the range of your aircraft and
fulfills other criteria like having lighted runways and fuel.
The center for the distance search is highlighted by a

symbol.

To restrict the search further you can select a direction (North, East, South and West).
Check the drop down menu for the change indicator * and the search fields for any remaining text
if the distance search does not give any or unexpected results. Use Reset Search in the context menu
of the result table or press Ctrl+R to clear all search criteria.

A complex distance search: Find all airports within a distance between 200 and 400 NM from Frankfurt (EDDF). Airports should have a
rating greater than 0 and should have at least one lighted runway. Military and closed airports are excluded. The resulting airports are
highlighted on the map by selecting them in the search result table.

A complex search for scenery: This example shows how to find specific add-on scenery by using the Scenery Path search field. This shows
all airports of the Orbx New Zealand South Island add-on scenery that have lighted runways.

20.4. Ident in Airport Search
The input field Ident in the airport search tab searches for all available airport identifiers. These are:
Ident:

Mostly equal to ICAO code but can be differnt especially for small airfields. X-Plane
uses partially an unofficial code in this field like XPA000B. Available for all simulators and
Navigraph navdata.
ICAO: Four letter ICAO code [https://en.wikipedia.org/wiki/ICAO_airport_code]. Only available in X-Plane.
FAA: Airport code used in the United States given by the Federal Aviation Administration
[https://www.faa.gov/]. The FAA code is only available in X-Plane.
IATA: Three letter IATA airport code [https://en.wikipedia.org/wiki/IATA_airport_code]. Available in X-Plane
and Navigraph navdata.
Local Code: Official local airport code mostly used for small airfields. Only available in X-Plane.
The airport codes are also shown in the information windows, tooltips and in the map labels as well
as in Flight Plan Route Description. ICAO, FAA, IATA, and local codes are shown and the internal
ident is avoided if possible.
Example:
Akutan

is shown as Akutan (PAUT) with its official ICAO code PAUT instead of the internal X-Plane code

XPA000B.

Search Example:
Searching for ident KOI gives the airports Oberlin Muni (KOIN), Lt Warren Eaton (KOIC) and Kirkwall (EGPA)
where EGPA has the IATA code KOI.
Tip
Hide the additonal airport codes if you do not use X-Plane or if you are not interested in these
columns. You can do this by moving the columns to the rightmost position or by shrinking them
to minimum size. See Header.
20.5. Override in Airport Search
Entering an airport ident using three letters or more ignores all other search options and shows
only airports matching this ident.
This is indicated by the message Ident overriding other search options. in the search window footer.
20.6. Search Result Table View

All selected elements in the table view will be highlighted on the map using a black/yellow circle.
See Highlights and User Features for more information.
Use Shift+Click or Ctrl+Click to select two or more elements (multi-selection).
20.6.1. Header
The header of all table views allows the following manipulation:
Click on the top left corner of the column header: Select all result rows.
Click on a column header: Sort ascending or descending (only for search result tables not for flight plan table).
Click and drag on the column header: Change column order.
Double-click on column border: Automatically fit column size to content.
Click and drag on column border: Change column width.
Click into the empty space below all rows: Deselect all entries and remove highlights on
the map.
The above applies to all table views in the program and partially also to the tree view of the
procedure search.
The program saves the sort order, column widths and positions until Reset View is selected in the
context menu.

Airport search result table. All additional search options are hidden by using the drop down menu of the menu button on the top right.

Navaid search limited to ICAO region LI (Italy) and VOR, VORTAC and TACAN stations that have a range of 100 or more NM.

20.6.2. Mouse Clicks
A double-click on an entry in the table view shows either an airport diagram or zooms to the navaid
or other feature. Additionally, details are shown in the Information dock window. Single click selects
an object and highlights it on the map using a black/yellow circle.
20.7. Top Buttons
Available buttons and menu items depend on search tab. This chapter explains common buttons
and menu items.

20.7.1.

Reset Search

Clear search filters and show all entries again in the search result table view.

20.7.2.

Clear Selection

Deselect all entries in the table and remove any highlight circles from the map.

20.7.3.

Help

Display a quick help in the tooltip. Click to open this chapter of the manual in the default browser.

20.7.4.

Menu Button

Drop down menu button that allows to hide or show search options.
The drop down menu prefixes menu items with a change indicator * to show that the related filter
row has modifications. You can use this to find out why a search does not give the expected
results.
20.8. Context Menu Search
Available menu items depend on search tab.

20.8.1.

Show Information

Same as Context Menu Map.

20.8.2.

Show Procedures

Open the procedure search tab of the search dock window and display all procedures for the
airport. Only available in the airport search tab.
The exact text of the menu item depends if the airport is already used as destination or departure
in the flight plan.
See Search Procedures for more information.

20.8.3.

Create Approach

Opens a dialog which allows to create a simple user defined final approach. Only available in the
airport search tab.
The exact text of the menu item depends if the airport is already used as destination or departure
in the flight plan.
See User Defined Approach for more information.

20.8.4.

Show on Map

Show either the airport diagram or zooms to the navaid, userpoint or other features on the map.
20.8.5. Follow Selection
The map view will be centered, but not zoomed in, on the selected feature if this function is
enabled.

20.8.6.

Filter by Entries including/excluding

Use the field under the cursor to set a search filter that includes or excludes the text of the field.
This is only enabled for text columns.

20.8.7.

Reset Search

Clear search filters and revert to showing all entries in the search result table view.

20.8.8.

Show All

The table view does not show all entries initially for performance reasons. This menu item allows to
load and show the whole search result. The view switches back to the limited number of entries
after a search filter is modified or the sort order is changed. The number of all, visible and selected
entries is shown at the bottom of the tab.
Be aware that showing all navaids and airports can take some time especially if they are
highlighted on the map when selecting all entries in the search result. The program does not crash
but needs a few seconds to highlight all the objects on the map.

20.8.9.

Add Range Rings

20.8.10.

Add Navaid Range Ring

20.8.11.

Add Airport Traffic Pattern

20.8.12.

Add Holding

Same as Context Menu Map.
Note that the menu item is disabled if the respective user feature is hidden on the map (menu View
-> User Features). The menu item is suffixed with the text hidden on map if this is the case.

20.8.13.

Set as Flight Plan Departure

20.8.14.

Set as Flight Plan Destination

20.8.15.

Add as Flight Plan Alternate

20.8.16.

Add to Flight Plan

20.8.17.

Append to Flight Plan

Same as Context Menu Map.

20.8.18.

Copy

Copy the selected entries in CSV format to the clipboard. This will observe changes to the table
view like column order and sort order. The CSV includes a header line. Columns which are hidden
or shrinked to minimum width are excluded.
Import the CSV-Text into spreadsheed programs using UTF-8 encoding and a semicolon as a
separator.
20.8.19. Select All

Select all visible entries. To select all available entries the function Show All has to be used first.

20.8.20.

Clear Selection

Deselect all entries in the table and remove any highlight circles from the map.

20.8.21.

Reset View

Reset sort order, column order and column widths to default.

20.8.22.

Set Center for Distance Search

Same as Context Menu Map.

21.

Search Procedures

The tab Procedures allows previewing and adding approach and departure procedures to the flight
plan. Procedures of a selected airport are arranged in a tree which indicates the dependencies
between approaches and transitions.
See Procedures for general information about SID, STAR, approaches and transitions.
Note that the SID and STAR names are limited to 5 characters in FSX and P3D due to a limitation in
the BGL file format. Therefore procedure names are slightly modified. However, this does not apply
to procedures from a Navigraph or X-Plane scenery database.
See the Delete Selected Legs or Procedure chapter of this manual for more details.
Procedure legs are shown when a procedure node is expanded in the tree. Procedures can be
filtered by runway and type.
Right-click on a procedure to get more options in the context menu, like centering the map on the
procedure or adding it to your flight plan.
Use the context menu of the flight plan table to remove procedures. See Delete Selected Legs or
Procedure.
Procedure legs are highlighted in red if one or more navaids could not be resolved. A warning
dialog will be displayed if you try to add this procedure to a flight plan.
Note
It is up to the user to combine the correct procedures.
Little Navmap will not keep you from choosing north bound procedures for a route going south,
for example. Also check the resulting route to avoid accidental zig-zag routing which can happen
if you combine the wrong approach/transition with a STAR, for example.

Showing a transition and a RNAV approach. Start and endpoint of a transition leg are highlighted on the map.

21.1. Procedure Tree
Legs are shown in dark blue while missed approach legs are shown in dark red color.
Bold red text indicates an error in the leg. The procedure is incomplete and should not be used in a
flight plan. Little Navmap might refuse to use the procedure depending on the error since
inconsistencies can result in crashes.
Remarks:

Either description of the procedure or flight instruction for procedure legs.
Magnetic course for a leg.

Course °M:

Dist./Time:

Distance of flying time for a leg. Holds can have a leg time in minutes or a leg
distance in NM.
Ident: Ident of the initial fix or name of the procedure. Fix name for legs.
Restriction: Either minimum altitude for en-route airway segment, procedure altitude
restriction or procedure speed limit. A / separates altitude and speed restriction. The
following altitude restrictions exist for procedures:
Number only: Fly at altitude or speed. Example: 5,400 or 210.
Prefix A: Fly at or above altitude or speed. Example: A 1,800.
Prefix B: Fly at or below altitude or speed. Example: B 10,000 or B 220.
Range: Fly at or above altitude one and at or below altitude two. Example: A 8,000, B
10,000.
Altitude and speed limit: Values separated by /. Example: A 8,000, B 10,000/B220.
Speed limit only: A prefixed / indicates no altitude but a speed restriction. Example:
/B250.
Remarks: Shows fly-over, turn direction or related navaid for a procedure leg.
21.2. Top Buttons
21.2.1. Type Filter (All Procedures)
The type filter is not available for an FSX or P3D stock database.
This filter is always available for a X-Plane database which contains SIDs and STARs already in the
stock data.
The type filter allows the selections below:
All Procedures:

SID, STAR and approaches
Only SID
Arrival Procedures: STAR and approaches
Only Approaches and Transitions: No SID and no STAR
Departure Procedures:

The respective transitions are always shown.
21.2.2. Runway Filter (All Runways)
This filter is always available and helps to find procedures for a certain departure or arrival runway.

21.2.3.

Clear Selection

Deselect all entries in the table and remove any highlight circles from the map.

21.2.4.

Help

Open this chapter of the manual in the default browser.
21.3. Context Menu Procedures

21.3.1.

Show on Map

Center the map on the selected procedure.
21.3.2. Follow Selection
The map view will be zoomed on the selected procedure when this function is enabled.

21.3.3.

Insert into Flight Plan, Use as Destination and Use as Departure

Text and functionality of this menu item depends on the selected procedure type and whether the
procedure’s airport is already the departure or destination airport of the current flight plan.

Use the context menu of the flight plan table or the map to remove procedures. See Delete
Selected Legs or Procedure and Delete from Flight Plan.
If a transition is selected, the corresponding procedure (approach, SID or STAR) is added or
replaced as well.
Insert ... into Flight Plan:

This menu item will add the selected procedure to the current flight plan. A procedure of the same
type (SID, STAR or approach with or without transition) will be replaced if already present in the
flight plan.
Use ... as Destination

or Use ... as Departure:

This will add or replace the destination or departure airport and add the selected procedure.
If the flight plan is empty, the departure or destination airport is added to the flight plan as well.
A leg entry will drawn red if a navaid was not resolved during the scenery database loading
process. This happens only when the source data is not valid or incomplete. In this case, the
resulting procedure is not usable and a warning dialog will be shown if essential navaids are
missing.
Little Navmap might refuse to use the procedure depending on error.

21.3.4.

Show Information for Airport

Show detailed information in the Information dock window for the airport.
See the Information for details.

21.3.5.

Show Airport on Map

Show the airport on the map. The zoom distance can be changed in the dialog Options on the tab
Map.

21.3.6.

Show Airport in Search

Shows the airport in the search dialog.
21.3.7. Expand All / Collapse All
Expand all procedures so that their legs and transitions are shown or collapse the tree.

21.3.8.

Reset Search

Clear search filters and revert to showing all procedures in the tree.

21.3.9.

Clear Selection

Deselect the currently selected procedure and remove the preview from the map.

21.3.10.

Reset View

Reset column order and column widths to default.

22. Userpoints
User-defined waypoints (or userpoints) allow for adding, editing, searching, exporting, and
importing bookmarks, points of interest, waypoints and more. You can pick freely which types you
want to see as icons on the map.

An overview of userpoint functionality showing information on the left dock window, highlighted userpoints on the map, userpoints
selected in the search window on the right, and the drop down menu opened by clicking the userpoint icon in the dock window.

22.1. User-defined Waypoint Search
The functionality of the search filters and the result table is similar to the airport and navaid
search. See Search for information about search filters and buttons.
Additional context menu items and buttons allow adding, editing, and deleting of userpoints.
22.1.1. Top Buttons and additional Menu Items
See Context Menu Search for a description of common context menu items across all search
dialogs. All buttons have an equivalent in the result table context menu.

22.1.1.1.

Add Userpoint

Add an user-defined waypoint to the userpoints.
Some fields of the new userpoint dialog are populated automatically depending on a selected
userpoint or, if nothing is selected in the search result table, based on previous additions. This
allows to quickly add similar userpoints to the database without the need to re-enter all the
information.
Note that you have to add the coordinates manually if the dialogs starts empty i.e. nothing was
selected in the result table. Add userpoints with the map context menu ( Add Userpoint) to avoid
this and have the coordinates set automatically.
See below for more information about the add dialog: Add Userpoints.

22.1.1.2.

Edit Userpoint

Open the edit dialog for one or more userpoints.
The edit dialog shows a column of checkboxes on the right side if more than one userpoint is
selected. These allow to choose the fields to edit.

See below for more information about the add dialog.

22.1.1.3.

Delete Userpoint

Remove the selected userpoints after a confirmation dialog. Undo is not possible but database
backups are created on each start. See Userpoints for information about database backup files.

22.1.1.4.

Reset Search

Clear search filters and revert to showing all entries in the search result table view.

22.1.1.5.

Clear Selection

Deselect all selected entries in the table and remove any highlight circles from the map.

22.1.1.6.

Help

Display a quick help in the tooltip. Click to open this chapter of the manual in the default browser.

22.1.1.7.

Menu Button

Drop down menu button that allows to hide or show search options.
The drop down menu prefixes menu items with a change indicator * to show that the related filter
row has modifications.
22.2. Add Userpoints

The dialog is shown when selecting Add Userpoint
in the map context menu, using the top
button in the userpoint search tab, or selecting Add Userpoint from the context menu in the search
result table.
The dialog will be populated automatically depending on the selected map context, the selection in
the search result table or previous additions.
Type

can be selected from a drop down list or entered freely.

The field Description allows multi line text and special characters. Formatting like italic or bold is not
supported. See Remarks for more information about using web links in this field.
The field Visible from allows to define visibility on the map depending on zoom distance. The zoom
distance (viewpoint distance to earth surface) for the current map view is shown in the Statusbar.
The userpoint will be visible for all zoom distances smaller than the value in Visible from. Maximum
value is 3,000 NM and minimum value is 1 NM.
Valid coordinates are required to confirm the dialog. See Coordinate Formats for a detailed
description of the recognized coordinate formats. A label below the coordinates displays the parsed
coordinates or an error message in case the coordinates are invalid.
All other text fields are optional and can be left blank.
The userpoint is removed on next startup of Little Navmap when Temporary userpoint. Delete on next
startup. is checked.
The button Reset clears all fields with exception of the coordinates and sets the type of the
userpoint to Bookmark.

Add dialog that has been populated automatically by context. The user right-clicked on an airport and selected Add Userpoint Airport
Frankfurt am Main (EDDF).

22.3. Edit Userpoints
22.3.1. A single Userpoint
The edit dialog shows the same edit fields as the dialog used to add userpoints above.
Additional metadata shown at the bottom:
Last Change: Date and time of import, creation or change.
Imported from file: File and path of source file from CSV, X-Plane or Garmin import. You
can filter the userpoint search for this name.
Temporary userpoint - will be deleted on next startup. This indicates a temporary
userpoint.
The button Reset undoes all manual changes and reverts all fields to their original state.

Edit dialog for a single userpoint.

22.3.2. Multiple Userpoints
If more than one userpoint was selected for editing, the edit dialog shows a column of checkboxes
on the right side.
If checked, the field to the left is unlocked and any text entered will be assigned to the respective
field in all selected userpoints. Unchecked fields will not be altered for any of the userpoints.
In combination with the search function, this allows for bulk changes like fixing an invalid region
and simultaneously changing the visibility range for the affected userpoints:
1. Search for all userpoints with the invalid region.
2. Select all the resulting userpoints, e.g. by clicking on one of the userpoints among the
search results and pressing Ctrl+A or by clicking on the top left corner of the column header.
3. Right-click one of the highlighted userpoints and select Edit Userpoints from the context
menu.
4. Click the checkbox to the right of the Region: field and change the region.
5. Click the checkbox to the right of the Visible from: field and adjust the value.
6. Click OK.

Edit dialog for more than one userpoint. The fields Region and Visible from will be changed for all selected points. All other fields remain
unchanged.

22.4. Types
The userpoint type can be any text string. If the text matches an entry from the list below, the
appropriate icon is used. Otherwise, the icon for Unknown

is used.

Types and icons can be customized and new types can be added. See Userpoint Category Icons for
information on how to do this.
Some types are used as defaults when adding new userpoints. This depends on the context, i.e.
what was below the cursor when right-clicking on the map.
Note that the userpoint types cannot be translated to other languages for now.
22.4.1. Airports

Airport: Default when creating an userpoint on top of an airport.
Airstrip
Closed airport
Helipad
Seaport
22.4.2. Navaids

DME: Distance measuring equipment.
NDB: Non-directional beacon.
TACAN: Tactical air navigation system.
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VORDME: VHF omnidirectional range and DME.
VORTAC: VOR and TACAN.
VOR: VHF omnidirectional range.
VRP: Visual reporting point.
Waypoint: Default when creating an userpoint on top of a navaid.
22.4.3. Points of Interest

Bookmark: Default type for new userpoints.
Cabin
Error
Flag
Lighthouse
Location
Logbook. Also legacy logbook entry.
Marker
Mountain
Obstacle
POI
Pin

Unknown: Type named Unknown and all types which do not match the default types in this
list.
22.5. CSV Data Format
The CSV data format is aligned to the format already used around the flight simulator community
and other applications.
Each row in the file represents an user-defined waypoint.
The recommended minimum fields for import are Type, Name, Ident, Latitude and Longitude.
Only Latitude and Longitude are required, the rest can be empty.
All twelve fields are saved when exporting userpoints as CSV. Also, the multi line field Remarks is
enclosed in quotes if needed and preserves line breaks.
English number format (dot . as decimal separator) is used in import and export to allow exchange
of files on computers with different language and locale settings.

Little Navmap uses UTF-8 [https://en.wikipedia.org/wiki/UTF-8] encoding when reading and writing files. This
is only relevant if you use special characters like umlauts, accents or others. Otherwise encoding
does not matter.
If an application fails to load a CSV file exported by Little Navmap, use LibreOffice Calc
[https://www.libreoffice.org], Microsoft Excel or any other spreadsheet software capable of reading and
writing CSV files to adapt the exported file to the format expected by that application.
See Comma-separated values [https://en.wikipedia.org/wiki/Comma-separated_values] in the Wikipedia for
detailed information on the format.
22.5.1. Examples
Example for an absolute minimal userpoint consisting of coordinates only:
,,,49.0219993591,7.8840069771
Visible from

will be set to the default of 250 NM and the userpoint will be shown using the Unknown

icon after import.
Example for a minimal userpoint record with type Mountain , ident and name for import:
Mountain,My Point of Interest,MYPOI,49.0219993591,7.8840069771
Visible from

will be set to the default of 250 NM after import.

Example for an exported userpoint with type Mountain and all fields set:
Mountain,My Point of
Interest,MYPOI,49.0219993591,7.8840069771,1200,2.0085027218,"View,Interesting,Point","Interesting point
""Eselsberg"" - nice view",ED,250,2018-05-17T17:44:26.864

Note of the following when parsing the CSV files:
In the field Tags, the list "View,Interesting,Point" is enclosed in double quotes since it contains
commas. The field description "Interesting point ""Eselsberg"" - nice view" is enclosed in double
quotes since the text itself contains a pair of double quotes ("Eselsberg") which are, in turn, escaped
by another double quote each.
22.5.2. CSV Fields
The full header if enabled on export is:
Type,Name,Ident,Latitude,Longitude,Elevation,Magnetic Declination,Tags,Description,Region,Visible From,Last
Edit,Import Filename

Position

Name

Required

Empty
Allowed

Comment

1

Type

Yes

Yes

One of the predefined or user-defined types. The
icon for Unknown is used if the type does not
match one of the known types.

2

Name

Yes

Yes

Free to use field. Used for Garmin export.

3

Ident

Yes

Yes

Required only for Garmin and X-Plane export.
Has to be an unique valid identifier with
maximum of five characters for these exports.

4

Latitude

Yes

No

Range from -90 to 90 degrees using dot . as
decimal separator

5

Longitude

Yes

No

Range from -180 to 180 degrees using dot . as
decimal separator.

Position

Name

Required

Empty
Allowed

Comment

6

Elevation

No

Yes

Must be a valid number if used. Unit is always
feet.

7

Magnetic
declination

No

Yes

Ignored on import and set to a valid calculated
value on export.

8

Tags

No

Yes

Free to use field. GUI has no special tag search.

9

Description

No

Yes

Free to use field which allows line breaks.

10

Region

No

Yes

Two letter ICAO region of an userpoint or
waypoint. Used for X-Plane export. Replaced
with default value ZZ on X-Plane export if empty.

11

Visible
From

No

Yes

Defines from what zoom distance in NM (shown
on Statusbar) the userpoint is visible. Set to 250
NM if empty on import.

12

Last Edit

No

Yes

ISO date and time of last change. Format is
independent of system date format settings.
Format: YYYY-MM-DDTHH:mm:ss. Example:
2018-03-28T22:06:16.763. Not editable in the
user interface.

13

Import
Filename

No

Yes

Full path and file name the userpoint was
imported from. Not editable in the user
interface.

22.6. X-Plane user_fix.dat Data Format
This allows to read and write the X-Plane user_fix.dat file for user-defined waypoints. The file does
not exist by default and has to be saved to XPLANE/Custom Data/user_fix.dat.
The format is described by Laminar Research in a PDF file which can be downloaded here: XPFIX1101-Spec.pdf [https://developer.x-plane.com/wp-content/uploads/2016/10/XP-FIX1101-Spec.pdf].
The file consists of a header and a number of rows for the user fixes. Each row has five columns
which are separated by space or tab characters.
There are five columns of data in the file:
1.
2.
3.
4.
5.

Latitude
Longitude
Ident
Airport ident
Region

Example for user_fix.dat :
I
1101 Version - data cycle 1704, build 20170411, metadata FixXP1101. NoCopyright (c) 2017 useruser
50.88166689 12.58666711 PACEC ENRT ZZ
-36.29987200 174.71089013 N0008 NZNI ZZ
99

Note

Note that, while the user-defined waypoints are not displayed on the X-Plane map, they can be
selected and used to build flight plans in the X-Plane stock GPS and FMS.
Keep in mind that waypoints are loaded from the Navigraph database if the default mode Use
Navigraph for Navaids and Procedures is enabled.
Therefore, user defined waypoints from the file user_fix.dat might not be shown in Little Navmap
after loading the scenery library from X-Plane.
22.6.1. Import
Example line from user_fix.dat above:
50.88166700

The
The
The
The

12.58666700 PACEC ENRT ZZ

coordinates are read into the Little Navmap userpoint coordinates.
fix ident PACEC is read into the Ident field in Little Navmap.
fix airport ENRT (en-route: no airport here) is read into the Tags field in Little Navmap.
region ZZ (invalid or no region) is read into the Region field in Little Navmap.

Type will be set to Waypoint

for all imported fixes.

22.6.2. Export
The mapping is the same as for the import.
Ident to fix ident.
Tags to fix airport.
Region to fix region.
All other fields are ignored.
The ident is adjusted to match an up to five digit and letter combination. A generated ident is used
if that is not possible or the ident is empty.
Fix airport is always ENRT when exporting.
The region is adjusted for a two letter digit and letter combination. ZZ is used if that is not possible
or the region is empty.
Note
The ident has to be unique in the user_fix.dat. Therefore it is recommended to set an unique
ident for each waypoint manually or leave the field empty so Little Navmap can generate an
ident during export.
22.7. Garmin user.wpt Data Format
The Garmin user waypoint file is a CSV file. Each row in the file represents an unique user
waypoint.
There must be four columns of data in the file:
1.
2.
3.
4.

Waypoint ident
Waypoint name or description
Latitude
Longitude

Example of a user.wpt file:
MTHOOD,MT HOOD PEAK,45.3723,-121.69783
CRTRLK,CRATER LAKE,42.94683,-122.11083
2WTER,2NM WEST TERRACINA,41.28140000,13.20110000
1NSAL,1NM NORTH SALERNO TOWN,40.69640000,14.78500000

The waypoint ident can be up to 10 numbers or capital letters but the GTN will shorten the name to
the first 6 characters. No special characters or symbols can be used. Little Navmap adjusts the

ident accordingly.
The waypoint name can be up to 25 numbers, capital letters, spaces, or forward slash / characters.
The name is displayed when selecting waypoints to provide additional context to the pilot. Little
Navmap adjusts the name according to limitations.
22.7.1. Import
Example line from user.wpt above:
MTHOOD,MT HOOD PEAK,45.3723,-121.69783

The ident MTHOOD is read into the Ident field in Little Navmap.
The name MT HOOD PEAK is read into the Name field in Little Navmap.
The coordinates are read into the Little Navmap userpoint coordinates.
Type will be set to Waypoint

for all imported waypoints.

22.7.2. Export
Mapping of fields is same as import but all fields are adjusted to limitations.
Note
If an imported waypoint ends up being within 0.001° latitude and longitude of an existing user
waypoint in the GTN, the existing waypoint and name will be reused.
22.7.3. Export XML for FSX/P3D BGL Compiler
This export option creates an XML file which can be compiled into an BGL file containing waypoints.
The region and ident fields are required for this export option. If region is empty or otherwise
invalid ZZ is used. All waypoints are of type NAMED.
See Prepar3D SDK documentation for information on how to compile and add the BGL to the
simulator.
Example:
<?xml version="1.0" encoding="UTF-8"?>
<FSData version="9.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="bglcomp.xsd">
<!--Created by Little Navmap Version 2.0.1.beta (revision 2b14e14) on 2018 05 17T12:24:36-->
<Waypoint lat="47.40833282" lon="15.21500015" waypointType="NAMED" waypointRegion="ZZ"
magvar="4.02111530" waypointIdent="WHISK"/>
<Waypoint lat="47.39666748" lon="15.29833317" waypointType="NAMED" waypointRegion="ZZ"
magvar="4.01835251" waypointIdent="SIERR"/>
</FSData>

22.8. Database Backup Files
Little Navmap creates a full database backup on every start since undo functionality is not available
for userpoints.
You can also use the CSV export to create backups manually since CSV allows to export the full
dataset.
See Userpoints for information about database backup files.

23. Logbook
Little Navmap creates logbook entries for each flight automatically when detecting a takeoff or
landing. A logbook entry containing only departure is created on takeoff and finalized with
destination and more information on landing.
Create Logbook entries has to be checked to enable this functionality.
Note that all times, fuel consumption and other values are measured between takeoff and landing
since it is not reliably possible to detect the start and end of a flight.
You can speed up the flight or to warp to another position without breaking the logbook record.
Editing functionality in the logbook is similar to the userpoints editing ( Userpoint).
Note
Use Reset all for a new Flight to be sure that the logbook flight detection is set up for a new
flight.
The logbook entries will not be recorded between different sessions. Update the logbook entry
manually if you have to exit the flight simulator or Little Navmap.

23.1. Logbook Files
Each logbook entry has a reference using the full path to the used flight plan and aircraft
performance files. Keep in mind that these references naturally break if the files are moved or
renamed.
Additionally, the flight plan file, the aircraft performance file and the flown track are directly
inserted into logbook entry. These attachments can be saved as LNMPLN, LNMPERF or GPX files.
The GPX attachment is also used to show the trail and flight plan preview when selecting logbook
entries in the search result table.
See Little Navmap LNMPLN Format for information about the LNMPLN format.
The GPX trail contains coordinates, flown altitude and time as well as the flight plan with airport
and navaid idents, coordinates and calculated altitude.
The flight plan file contains all plan information like procedures or remarks.
You can access and modify the referenced and attached files in the context menu of the search
result table and edit dialog.
Note
Unfinished flights will not have trail information and show only the departure airport.

23.2. Logbook Search
The functionality of the search filters and the result table is equal to the airport and navaid search.
See Search for information about search filters and buttons.
A search field Airport ICAO allows to search entries having either a matching destination or
departure airport.
Additional context menu items and buttons allow adding, editing, and deleting of logbook entries as
well as saving or loading the attached flight plan or track.
One or more logbook entries are highlighted on the map with blue lines connecting departure and
destination as well as the two airports once selected in the search result table.
The label at the connecting great circle line shows departure airport ident, destination airport ident
and great circle distance. A tooltip is shown if hovering the mouse over the blue direct connection
or flight plan preview lines.
Note
Logbook details (route preview and trail) on the map are only shown if one single entry is
selected in the logbook search result table. Selecting more than one entry shows only the direct
connection lines if enabled.

Map showing several logbook entries selected and highlighted. Departure and destination of each entry is connected by a great circle line.
A tooltip shows more information.

A selected logbook entry and the flight plan preview showing the waypoints and flying direction.

The dashed line shows the flown track.
Tip
Search for logbook entries with a max distance of zero if you like to remove invalid entries from
interrupted flights or pattern work.
23.2.1. Top Buttons and additional Menu Items
See Context Menu Search for a description of common context menu items across all search
dialogs. All buttons have an equivalent in the result table context menu.
23.2.1.1. Airport

Sub-menu for departure and destination airport.

23.2.1.1.1.

Show Information for Airport

23.2.1.1.2.

Show on Map

23.2.1.1.3.

Set as Flight Plan Departure

23.2.1.1.4.

Set as Flight Plan Destination

23.2.1.1.5.

Set as Flight Plan Alternate

These menu items are only enabled for a right click on a departure or destination airport name or
ICAO.
Same functionality as in Context Menu Map and in Context Menu Flight Plan.

23.2.1.2.

Add Logbook Entry

Add a logbook entry manually.

See Add Logbook Entry and Edit Logbook Entry below for more information about the add/edit
dialog.

23.2.1.3.

Edit Logbook Entry

Open the edit dialog for one or more logbook entries.
The edit dialog shows a column of checkboxes on the right side if more than one logbook entry is
selected. These allow to choose the fields to change for all selected entries.
See Edit Logbook Entry below for more information about the add/edit dialog.

23.2.1.4.

Delete Logbook Entry

Remove the selected logbook entries after a confirmation dialog. Undo is not possible but database
backups are created on each start. See Logbook for information about database backup files.
23.2.1.5. Files

Sub-menu for referenced and attached files.

23.2.1.5.1.

Open Flight Plan

Opens the referenced flight plan file. This menu item is disabled if the referenced file cannot be
found. This can be the case if the file was renamed or moved.
Same as Open Flight Plan.

23.2.1.5.2.

Open Aircraft Performance

Opens the referenced aircraft performance file. This menu item is disabled if the referenced file
cannot be found. This can be the case if the file was renamed or moved.
Same as Open Aircraft Performance.
23.2.1.5.3. Open attached Flight Plan

Opens the attached flight plan file replacing the current plan.
23.2.1.5.4. Save attached Flight Plan as

Saves the attached LNMPLN flight plan to a new file.
23.2.1.5.5. Open attached Aircraft Performance

Opens the attached performance file replacing the current aircraft performance.
23.2.1.5.6. Save attached Aircraft Performance as

Saves the attached LNMPERF flight plan to a file.
23.2.1.5.7. Save attached GPX Trail as

Saves the attached GPX to a file which contains the flown trail as well as the flight plan preview.
23.2.1.6. View Options

These three options activate or deactivate the respective preview functions for selected logbook
entries.
The start and destination airports are always highlighted. This is also the case when all three
options are deactivated.
23.2.1.6.1. Show direct connection

Shows a direct connection line between start and destination.
Displayed for one or more selected logbook entries.
23.2.1.6.2. Show flight plan preview

Shows a simplified preview of the flight plan in use.
This is only shown when a single logbook entry is selected.
23.2.1.6.3. Show aircraft trail

Shows the flight path.
This is only shown if a single logbook entry is selected.

23.2.1.7.

Open Flight Plan

Opens the referenced flight plan file. This menu item is disabled if the flight plan field in the
logbook entry is empty or if the flight plan file was moved or renamed.

23.2.1.8.

Open Aircraft Performance

Loads a LNMPERF aircraft performance profile and shows the fuel report. This menu item is
disabled if the aircraft performance field in the logbook entry is empty or if the file was moved or
renamed.

23.2.1.9.

Reset Search

Clear search filters and reverts to showing all entries in the search result table view.

23.2.1.10.

Clear Selection

Deselect all selected entries in the table and remove any highlighted logbook entries from the map.

23.2.1.11.

Help

Display a quick help in the tooltip. Click to open this chapter of the manual in the default browser.

23.2.1.12.

Menu Button

Drop down menu button that allows to hide or show search options.
The drop down menu prefixes menu items with a change indicator * to show that the related filter
row has modifications.

23.3. Add Logbook Entry
Allows to create a new log entry manually. The dialog layout and functionality is the same as for
editing logbook entries. The button Reset clears all fields.

23.4. Edit Logbook Entry
The dialogs for editing and adding are equal and contain three tabs.
Most fields have a tooltip explaining the meaning, are optional and can be freely edited.
The button Reset undoes all manual changes and reverts all fields back to the original state.
23.4.1. Tab Logbook Entry
Additional notes about some fields on this page:
Departure and Destination: These are automatically resolved to an airport. Coordinates
(not shown and not editable) are assigned to the departure or destination airport if found.
The dialog will show the airport name and elevation if the airport ident can be resolved.
Otherwise an error message is shown.
Date and Time in Simulator UTC: Time set in the simulator on liftoff or touchdown.
Always UTC.
Real local Time: Real world time on liftoff or touchdown. Stored in your local time.
Route Description: Flight Plan Route Description extracted from the flight plan.
Flight plan file and Aircraft performance file: Used flight plan and performance files.
These are only references which will turn invalid if the files are moved or renamed.
23.4.2. Tab Fuel and Weight
Block fuel and trip fuel are extracted from Tab Fuel Report.
Used fuel is the fuel consumption between liftoff and touchdown.
23.4.3. Tab Remarks
Free text input field which is also shown in the tooltip and the information window on tab Logbook.
See Remarks for more information about using web links in this field.
23.4.4. Edit a single Logbook Entry

Editing a logbook entry.

23.4.5. Edit multiple Logbook Entries
If more than one logbook entry was selected for editing, the edit dialog shows a column of
checkboxes on the right side of available fields. Not all fields are available for bulk edit.
If checked, the field to the left is unlocked and any text entered will be assigned to the respective
field in all selected logbook entry. Unchecked fields will not be altered for any of the selected
entries.
In combination with the search function, this allows for bulk changes like fixing an invalid aircraft
type.

Editing more than on logbook entry. Three fields are to be changed for the selected entries.

23.5. Logbook Statistics
This dialog shows two tabs:
1. Overview contains a general report which can be copied as formatted text to the clipboard.
2. Grouped Queries has a button on top which shows different reports in the table below. The
content of the table can be copied as CSV to the clipboard.
Some simulators report a wrong departure and arrival time in rare cases which can result in
negative flying time for some flights.
The logbook statistics ignore these invalid simulator time intervals.
Correct the simulator departure or arrival time manually if you find such cases.

Overview tab of logbook statistics dialog.

23.6. Import and Export

The full logbook or selected logbook entries can be imported and exported to a CSV (comma
separated value) text file which can be loaded in LibreOffice Calc or Microsoft Excel. All data can be
exported and imported which allows to use this function for backup purposes.
Export and import can be done by using the menu items Import CSV and Export CSV.
See chapter CSV Data Format below for more information on the format.
23.7. X-Plane Import
Imports the X-Plane logbook file .../X-Plane 11/Output/logbooks/X-Plane Pilot.txt into the Little Navmap
logbook database. Note that the X-Plane logbook format is limited and does not provide enough
information to fill all Little Navmap logbook fields.
The imported logbook entries get remarks containing Imported from X-Plane logbook X-Plane Pilot.txt
which allows to search for the imported entries. Use a pattern like *Imported from X-Plane logbook XPlane Pilot.txt* in the description search field to look for all imported entries.
Available information in the X-Plane logbook:
1.
2.
3.
4.
5.
6.
7.
8.

Date of flight
Departure airport
Destination airport
Number of landings - added to description.
Duration of flight
Time spent flying cross-country, in IFR conditions and at night - added to description.
Aircraft tail number
Aircraft type

X-Plane logbook example:
I
1
2
2
2

Version
190917
190917
190920

EDDN
ESNZ
LSZR

ESNZ
ESNZ
LSZR

4
0
0

0.8
0.1
0.2

0.0
0.0
0.0

0.0
0.0
0.0

0.0
0.0
0.0

C-STUB
C-STUB
SF34

727-100
727-100

23.8. Conversion
Automatically converts all legacy log entries that were collected as userpoints having type Logbook.
The conversion copies them to the new logbook after showing an information dialog.
The conversion works best if field Remarks in the userpoints was not modified and if no entries were
inserted manually.
The converted logbook entries are appended to the current logbook. The original userpoint of type
Logbook are not deleted or modified.
The converted logbook entries get a description containing Converted from userdata which allows to
search for the imported entries. Use a pattern like *Converted from userdata* in the description search
field to search for all entries.
Not all values can be recovered but the original description from the userpoint is stored in the
description of the new logbook entry.
A warning dialog is displayed after the conversion which shows any issues during conversion.

Warnings shown after converting userpoints to logbook entries.

23.9. Database Backup Files
Little Navmap creates a full database backup on every start since undo functionality is not available
for logbook entries.
You can also use the CSV export to create backups manually since CSV allows to export the full
dataset.
See Logbook for information about database backup files.
23.10. CSV Data Format
English number format (dot . as decimal separator) is used in import and export to allow exchange
of files on computers with different language and locale settings.
Little Navmap uses UTF-8 [https://en.wikipedia.org/wiki/UTF-8] encoding when reading and writing files. This
is only relevant if you use special characters like umlauts, accents or others. Otherwise encoding
does not matter.
If an application fails to load a CSV file exported by Little Navmap, use LibreOffice Calc
[https://www.libreoffice.org], Microsoft Excel or any other spreadsheet software capable of reading and
writing CSV files to adapt the exported file to the format expected by that application.
See Comma-separated values [https://en.wikipedia.org/wiki/Comma-separated_values] in the Wikipedia for
detailed information on the format.
Altitudes are always feet and distances are always nautical miles in the exported CSV.
The first line of the CSV contains the field names if chosen for export.
Field name

Description

Aircraft Name

Free name like Cessna 172

Aircraft Type

ICAO type descriptor like B732

Aircraft Registration

e.g. N12345

Flightplan Number

Flight number if available

Flightplan Cruise Altitude

Flight plan cruise altitude in feet

Flightplan File

Full path to flight plan file

Performance File

Full path to performance file

Field name

Description

Block Fuel

From aircraft performance - lbs

Trip Fuel

As above

Used Fuel

As above

Is Jetfuel

Calculated from aircraft fuel, 1 is jet fuel

Grossweight

Weight at takeoff, lbs

Distance

Flight plan distance in NM

Distance Flown

Actual flown distance in NM

Departure Ident

Airport ICAO code

Departure Name

Airport name

Departure Runway

Runway if available

Departure Lonx

Coordinates if available and airport resolves

Departure Laty

As above

Departure Alt

Elevation in ft

Departure Time

Real world departure time in local time

Departure Time Sim

Simulator departure time in UTC

Destination Ident

Same as above for destination

Destination Name

As departure

Destination Runway

As departure

Destination Lonx

As departure

Destination Laty

As departure

Destination Alt

As departure

Destination Time

As departure

Destination Time Sim

As departure

Route string

ICAO route description

Field name

Description

Simulator

X-Plane 11, Prepar3D v4,

Description

Free text by user

Flightplan

The flight plan in LNMPLN XML format

Aircraft Perf

The aircraft performance in LNMPERF XML
format

Aircraft Trail

The flown trail and flight plan preview in GPX
format

etc.

24. Online Networks
The online network functionality allows to connect to VATSIM [https://www.vatsim.net], IVAO
[https://ivao.aero], PilotEdge [https://www.pilotedge.net/] or other online networks which publish whazzup.txt
files. This covers display of information for centers, clients and servers on the map.
Network specific information like user names, active centers/towers, frequencies, flight plans and
much more are displayed world wide without limits like distance to the user aircraft.
Access to online networks can be enabled and configured on Online Flying. Predefined options for
the well known networks are available as well as freely configurable ones.
Online network related functionality can be found in the following places:
Search dock window, tabs Online Clients, Online Centers and Online Server.
Information dock window, tabs Online Clients and Online Centers.
Options dialog, page Online Flying.
24.1. Simulator and Online Aircraft Duplicates
Little Navmap fetches data from online networks using an interval of three minutes depending on
settings and network.
The program also fetches AI or multiplayer aircraft from the simulator which are updated about
several times a second. These aircraft are injected into the simulator by the various online clients
so they are visible there.
Therefore, the user aircraft and other client aircraft can appear duplicated on the map.
Little Navmap tries to remove these duplicates by matching the aircraft registration (simulator) and
the client callsign (online network). Aircraft can appear duplicated if this information is not available
which is the case for X-Plane. Refer to the configuration of your online network tool how to add this
information.
24.2. Map Display
24.2.1. Clients

Online network clients or their aircraft are displayed on the map using the
includes simulator aircraft that were recognized as online network clients.

symbol. This

The user aircraft is always displayed using the yellow
or a similar symbol depending on
aircraft type and simulator. Use the Show in Search map context menu item to see your own aircraft
in the list of online clients.
Information for online aircraft is shown on the tab Online Clients in Information.
All other functionality like context menu, double-click, tooltips, map highlights and other are the
same as for the other aircraft.
See Aircraft and Ships in the legend for all symbols.

Online network clients/aircraft in search tab, map, tooltip and information window.

24.2.2. Centers
Online centers are displayed as circular airspaces in Little Navmap and provide the same
functionality as the other airspaces (tooltips, information and more). They can be enabled
separately from the other airspaces by selecting Online as airspace source (Airspace Libraries)
Note
The circles do not represent the real airspaces and are only used to indicate the presence of an
active center, tower, ground or other position. See below how to assign airspace boundaries to a
center.
Detailed information for online centers/airspaces is shown on Information.
The following types are available and can be enabled in the drop down menus on the airspace
toolbar or sub-menu Airspaces:
Observer: Circle size is taken from the Visual Range value of the center.
Flight Information (Center): Uses Visual Range.
Delivery (Clearance): Uses Visual Range.
Ground: Shows a circle with a diameter of 10 NM.
Tower: 20 NM circle.
Approach: 40 NM circle.
ACC (Center): Uses Visual Range.
Departure: Uses Visual Range.
The size of the circle shapes can be changed in the options dialog. See Map Display Online.
You can also assign centers to a boundary shape using imported OpenAir airspaces from the user
airspace database. See Online Airspaces for more information about this.

Online network center/ATC in search tab, map, tooltip and information window.

24.3. Online Search
24.3.1. Online Network Client Search
24.3.2. Online Network Center Search
The functionality of the search filters in these two tabs and the result tables are similar to the
airport and navaid search. See Search for information about search filters, buttons and context
menu items.
24.3.3. Online Server Search
Displays all online servers in a table and has no search functionality. You can use the context menu
to copy parts of the result table like the IP address.

25.

Information

25.1. General
This dock window contains text information about airports in several tabs as well as information for
one or more navaids, airways in another tab plus an additional tab showing airspace information.
All information can be copied to the clipboard as formatted text. Use the context menu of the text
fields or use Ctrl+A to select all and Ctrl+C to copy the content to the clipboard.
Note that the formatted clipboard content is removed when Little Navmap is closed.
Bearing and distance to the user aircraft is shown for airports, navaids and userpoints if connected
to a simulator and if the distance is below 500 NM.
The display of additional units for fuel and weight as well as true course can be enabled in the
options dialog on tab Units.
25.2. Dock Window and Tabs
Information for only one airport, navaid or userpoint is shown when selecting one of the Show
Information for ... context menu items in the map, flight planning dock window or the search result
table.
All tabs are filled for airport, all navaids, all userpoints or all airspaces which are close to the cursor
for a left click in the map.
Little Navmap shows tabs based on priorities and selected objects and tries minimize tab changes.
Example: If you click on an airport, a VOR, a NDB and an userpoint at the same position:
1. Little Navmap fills all airport (several tabs), navaid and userpoint tabs with information. The
tab Navaids gets information for the NDB and the VOR.
2. The dock window Information is opened and raised if not visible.
3. The tab Userpoints is opened and raised if not visible. Userpoints are activated since user
features like map highlights, logbook entries or userpoints have priority before airports,
navaids and others.
Use the map context menu for an easier selection of map objects through the sub-menus.
25.3. Links
A blue link Map in the information allows jumping to and/or highlighting the shown object on the
map. A link Remove Airway Highlights or Remove Airspace Highlights can be used to remove the
corresponding highlights on the map.
Other links open web pages with airport information in the web browser or a file manager like
Windows Explorer with directories or files.
25.4. Scenery Information
All information about airports and navaids includes one or more links at the bottom of the object
information in section Scenery. These links point to the matching BGL (FSX, P3D and MSFS) or dat
(X-Plane) files that contain information about the airport or navaid. Click the links to open the
containing directory in your file manager (e.g. Windows Explorer). If possible, the matching file will
be selected automatically.
Multiple links can appear for airports since these can be updated by several files from different addon sceneries or navdata updates.
Note
The links shown as plain text with an additional remark like File not found if the file or folder is
missing. This can happen if you copy databases between computers and has no further
consequences.

25.5. Tabs in Information Dock Window
25.5.1. Airport
A tab that has several sub-tabs for airport information.
The six tabs Overview, Runways, Com, Procedures, Nearest and Weather below the airport tab show
information for one selected airport.
Airports can have several idents/codes depending on simulator. Unofficial internal idents are
avoided in the Little Navmap user interface but can still show up in some cases.
See also Ident in Airport Search for airport search options.
Ident or code shown in brackets after airport name: Either ICAO, FAA, IATA, local code
or internal code depending on simulator and availability.
ICAO: Four letter ICAO code [https://en.wikipedia.org/wiki/ICAO_airport_code]. Only available in X-Plane.
FAA: Airport code used in the United States given by the Federal Aviation Administration
[https://www.faa.gov/]. The FAA code is only available in X-Plane.
IATA: Three letter IATA airport code [https://en.wikipedia.org/wiki/IATA_airport_code]. Available in X-Plane
and Navigraph navdata.
Local Code: Official local airport code mostly used for small airfields. Only available in X-Plane.
X-Plane Ident:: Internal identfier for X-Plane airports.
The airport codes are also shown in the information windows, tooltips and optionally in the map
labels as well as in Flight Plan Route Description. ICAO, FAA, IATA, and local codes are shown and
the internal ident is avoided if possible.
Code display is omitted if a code is not available.
Example:
is shown as Akutan (PAUT) with its official ICAO code PAUT on the map instead of the internal XPlane code XPA000B.
Akutan

25.5.1.1. General

Sunrise and sunset for the airport are calculated based on current real date if no simulator is
connected. Otherwise the simulator date is used. This is indicated by the text (civil twilight, real
date) or (civil twilight, simulator date).
Preferred runways depending on wind are shown after the METAR. More details about preferred
runways are on the tab Airport Weather.
Additional links for helipads are available in the tab Runways.
The tab Nearest shows airports having procedures and closest navaids relative to the selected
airport.
25.5.1.2. Links

Links to several online services like SkyVector [https://skyvector.com/] or the The X-Plane Scenery
Gateway [https://gateway.x-plane.com/] open the browser with information for the airport using the
respective online service.
The links are shown in the tab Overview.

Airport information with linked web-sites in the Links section and links to user files in the Files section.
25.5.1.3. Files

Little Navmap will show extra links to local files if you put these into a special directory with the
name of the airport ICAO ident.
The path to the airport files is shown in the Files section.
You can use any file type. A file will be opened with the default application like a PDF reader if you
click on the link.
Examples for airport Ouessant (LFEC):
/home/USERNAME/Documents/Little Navmap Files/Airports/LFEC:

Linux
Linux with German translation
/Users/USERNAME/Documents/Little Navmap Files/Airports/LFEC: macOS
/Users/USERNAME/Documents/Little Navmap Dateien/Flugplätze/LFEC: macOS with German translation
C:\Users\YOURUSERNAME\Documents\Little Navmap Files/Airports/LFEC: Windows
C:\Users\YOURUSERNAME\Dokumente\Little Navmap Dateien/Flugplätze/LFEC: Windows with German
translation
/home/USERNAME/Dokumente/Little Navmap Dateien/Flugplätze/LFEC:

You can use the translated directory names or the English variant. Translated directory names
depend on the program and system language. Little Navmap will only use the English names if you
set the user interface language to English.
Little Navmap looks for files using both the translated path and the English path like: ...\Little
Navmap Files\Airports\LFEC and ...\Little Navmap Dateien\Flugplätze\LFEC.
The links are shown in the tab Overview.

Airport information overview. Additional tabs show information for runways, COM frequencies, approaches and weather. Weather symbols
user NOAA weather as source. Sunset and sunrise is based on real date since not connected to a simulator. Wind direction prefers runways
09 and 14.

25.5.2. Tab Navaids
More than one navaid or airway can loaded into this tab on left click. VOR, NDB, waypoint, airway
and ILS information is shown in this tab.
An airway is always displayed with all its waypoints. Click any blue waypoint link to center the map
around the waypoint.
Whole airways are highlighted and shown on the map when clicking the Map link in the information
window.
Highlighted airways have their own tooltip which is also shown if all other airways are hidden.

Click the link Remove Airway Highlights from Map in the information window to remove them from the
map.

Navaid information. Two navaids were close to the cursor when clicked.

Navaid information. Display of several airways with altitude restrictions and list of clickable waypoints. Clicking on the link Map highlights a
whole airway.

25.5.3. Tab Airspaces
Airspaces are highlighted on the map with their boundary and a text label when clicking the Map link
in the information window.
Highlighted airspaces have their own tooltip which is also shown if all other airspaces are hidden.

Click the link Remove Highlights from Map in the information window to remove the highlights from the
map.

Two airspaces that are shown in the information after clicking into the map. Two airspaces are highlighted on the map after clicking onto
the Map link in the information text.

25.5.4. Tab Weather
The tab Weather shows decoded weather information for a selected airport. The flight rules icon
(Airport Weather) has a suffix - Map if the shown weather source is the source for airport weather
icons on the map. Also shown is detailed information for best runways for takeoff and landing
based on wind conditions.
25.5.5. Other Tabs
Userpoints:

Shows information about user defined waypoints or points of interest.
Details about logbook entries.
Online Clients: Online network clients/aircraft.
Online Centers: Online network centers/airspaces.
Logbook:

25.6.

Tabs in Simulator Aircraft Dock Window

This dock window shows information about the user aircraft and about AI or multiplayer aircraft in
several tabs. Little Navmap has to be connected to the simulator to enable this feature. See
Connecting to a Flight Simulator for more information on this topic.
25.6.1. Tab Aircraft
Gives an overview about the user aircraft and shows type, weight and fuel information.

Aircraft information when connected to a flight simulator. Alternate units (liter and kg) are enabled.

25.6.2. Tab Progress
Shows information similar to a flight management computer about the user aircraft. This covers
flight plan progress, altitude, speed, ambient and environment parameters.
The text information in the tab has a link More Less on the top left. You can use this to toggle
between more detailed and less information.
The aircraft and progress tabs show warnings and errors by highlighting text in red or orange.
These are:
Fuel and time estimated since flight plan not valid.
Fuel and time estimated since aircraft performance not valid.
Insufficient fuel at destination (only if aircraft performance is valid).
Speed limit of 250 knots exceeded below 10,000 ft.
Icing.
Fuel and time estimates are based on the aircraft performance if valid. ( Aircraft Performance).
Fuel at destination and at top of descent is estimated by the current fuel amount in tanks and the
consumption as predicted by aircraft performance for the remaining distance to fly. Wind as well as
the different fuel flow numbers of the climb cruise and descent phases is considered in this
calculation.
Time of arrival is similarly calculated by current time and aircraft performance prediction
considering wind, climb cruise and descent phases.
Headwind is indicated by arrow down ▼ and tailwind by an up arrow ▲.
Some rows like Ice are hidden if the condition is not met.
Note
Little Navmap might show an orange warning about insufficient fuel at destination in the early
flight phases. This is normal since fuel flow is higher for takeoff and early climb.

Aircraft progress information when connected to a flight simulator and user aircraft airborne. Alternate weight and fuel units (kg and liter)
are enabled as well as true course display.

25.6.3. Tab AI / Multiplayer
Information about an AI or multiplayer aircraft from the simulator (not online networks) or ship is
displayed in this tab if a vehicle is clicked on the map.
This also includes the aircraft’s departure and destination airports that can be shown on the map by
clicking on the blue links (only for FSX or P3D and if a flight plan is filed).
Note that information on AI aircraft is limited on X-Plane. Only position, altitude and heading can
be displayed.

Information about an AI aircraft.

26.

Legend Dock Window

Contains two tabs: One tab Navmap explaining the various airport and navaid symbols and a tab Map
which shows the general legend for the base map like the OpenStreetMap for example.
The contents of the Navmap legend are also available in the online manual: Legend.
Note that the general map legend is not available for all map themes.

27.

Flight Planning

The flight planning Dock Window contains the four tabs: Flight Plan, Flight Plan Remarks, Fuel Report (
Aircraft Performance) and Current Performance (Aircraft Performance Collection).
27.1. Upper Part
The top shows a label that contains departure, departure position (parking, runway or helipad),
destination, flight plan distance, traveling time, used procedures (SID, STAR, approach and
transitions) as well as flight plan type.
The label also displays error messages if, for example, the runway of a STAR differs from the
runway of the following approach procedure.
Traveling time is only shown if a valid aircraft performance profile is loaded that has at least climb,
cruise and descent speeds set.
The ARINC name of the approach procedure which is needed by some FMCs is shown in
parentheses.

Header of a flight plan. VORDME LITSY has D34 as ARINC name.

Besides the label there are two input fields on top of this dock window:
27.1.1. Cruise altitude
This value is saved with the flight plan and is also used to calculate an airway flight plan.
Changing the cruise altitude of a flight plan using airways might result in errors (Error Display).
This can happen if the cruise altitude violates airway altitude restrictions. Calculate the flight plan
again to remove the errors.
See Flight Plan Route Calculation.
Note
Note that Little Navmap does not support step climb or different altitudes for each waypoint.
27.1.2. Flight Plan Type
Either IFR or VFR.
This is saved with the flight plan and is only relevant for FSX, Prepar3D or MSFS.
27.2. Flight Plan Table
The table view allows the same operations as the search table view except sorting. See Header for
more information.
All selected elements in the flight plan table view will be highlighted on the map using a
black/green circle. See Highlights and User Features for more information. Use Shift+Click or
Ctrl+Click to select two or more elements (multi-selection).
The active flight plan leg is highlighted in magenta when Little Navmap is connected to a simulator,
the user aircraft is airborne and user aircraft is closer than 40 NM to the flight plan.
Procedure legs have dark blue color and legs of a missed approach have a dark red color.

Alternate airports are shown at the end of the list using gray text. Note that more than one
alternate can be added to the flight plan. Legs to the alternate airports originate all from the
destination.
27.2.1. Table Columns
Ident:

ICAO ident of the navaid or airport. The ident can be suffixed as shown below:
+ or - and a distance value: Shows waypoints in procedures that are relative to a fix.
(IAF): Initial fix of a procedure or transition.
(FAF): Final approach fix. Depending on procedure either the FAF or FACF are shown
with a Maltese cross on the map and in the elevation profile.
(FACF): Final approach course fix.
(MAP): Missed approach point.
Region: Two letter region code of a navaid.
Name: Name of airport or radio navaid.
Procedure: Either SID, SID Transition, STAR, STAR Transition, Transition, Approach or Missed plus the
name of the procedure. Contains the text Alternate for alternate airports at the end of the list
or Departure or Destination.
Airway or Procedure: Contains the airway name for en-route legs or procedure instructions.
This field also shows track names if NAT, PACOTS or AUSOTS tracks are used. Airways are
suffixed with the airway type like N601 / V:
V Victor or low altitude airway
J Jet or high altitude airway
B Both
Restriction:
For airways:
Example 10,000: Minimum altitude for airway segment.
Example 0-20,000: Maximum airway altitude. Minimum does not apply.
Example 10,000-20,000: Minimum and maximum airway altitude.
For procedures: Altitude restriction or speed limit. A / separates altitude and speed
restriction. The following altitude restrictions exist for procedures:
Number only: Fly at altitude or speed. Example: 5,400 or 210.
Prefix A: Fly at or above altitude or speed. Example: A 1,800.
Prefix B: Fly at or below altitude or speed. Example: B 10,000 or B 220.
Range: Fly at or above altitude one and at or below altitude two. Example: A
8,000, B 10,000.
Altitude and speed limit: Values separated by /. Example: A 8,000, B
10,000/B220.
Speed limit only: A prefixed / indicates no altitude but a speed restriction.
Example: /B250.
Type: Type of a radio navaid. Shows ILS or LOC for ILS or localizer approaches on the last
runway leg.
Freq.: Frequency or channel of a radio navaid. Also shows ILS or localizer frequency for
corresponding approaches on the last runway leg.
Range: Range of a radio navaid if available.
Course °M: This is the start course of the great circle route connecting the two waypoints of
the leg. Use this course at departure if you travel long distances without navaids. Be aware
that you have to change you course constantly when traveling along a great circle line.
Course °T: The same as the two fields above but using true course. Use this in areas with
high magnetic variation.
Distance: Distance of the flight plan leg.
Remaining: Remaining distance to destination airport or procedure end point (usually the
runway).
Leg Time: Flying time for this leg. Calculated based on the selected aircraft performance
profile (see Aircraft Performance). This is a static value and not updated while flying. Empty
if performance calculation failed.
ETA: Estimated time of arrival. This is a static value and not updated while flying. Calculated
based on the selected aircraft performance profile. Empty if performance calculation failed.
Fuel Rem.: Fuel remaining at waypoint, once for volume and once for weight. This is a static
value and not updated while flying. Calculated based on the selected aircraft performance
profile. Empty if aircraft performance profile has no fuel consumption numbers set.
Wind: Magnetic wind direction and speed at the waypoint.

Head- or Tailwind:

Wind at waypoint. Headwind is indicated by arrow down ▼ and tailwind by
an up arrow ▲.
Altitude: Calculated altitude at waypoint. Uses aircraft performance to determine altitude.
Remarks: Turn instructions, flyover or related navaid for procedure legs. Also shows user
remarks that can be edited with Edit Flight Plan Position or Edit Flight Plan Position Remarks.
See Map Flight Plan Editing for more information.

The Flight Planning dock window. The flight plan uses a SID for departure and a STAR, a transition and an approach for arrival.

27.2.2. Column Selection
Choose Select visible Columns from the flight plan table context menu to customize the table. You
can still move and resize columns in the table. All changes are saved.
The changes can be undone by selecting Reset View in the context menu.

The flight plan column selection dialog with tooltip.

27.2.3. Error Display
If a waypoint of a flight plan cannot be found in the database it will be displayed in red. This can
happen if the used AIRAC cycles do no match. The same applies to airways. The position on the
map is still correct.
Airways are also displayed in red if the minimum altitude, maximum altitude or one-way
restrictions are violated.
Hover the mouse over a field in the table to see a tooltip giving more information about the error.
Warning
Note that flight plans are still usable in Little Navmap although saving and exporting to other
formats is limited and can lead to unexpected results.

The Flight Planning with three different tooltips showing errors.

Tooltip on error message showing violations of altitude restrictions.

27.3. Magnetic Declination
Little Navmap uses the magnetic declination [https://en.wikipedia.org/wiki/Magnetic_declination] that is stored
either with VOR stations or the actual environment declination. The latter one is calculated by the
program using the world magnetic model. (WMM [https://en.wikipedia.org/wiki/World_Magnetic_Model]) or loaded
from the simulator scenery database.
Note that the magnetic declination of a VOR (also: calibration for VOR, VORDME and VORTAC) may
differ from the actual declination in a simulator region as it does in reality. The calibration of a VOR

might be very old while the real declination in the environment changed in the meantime due to
the wandering of the magnetic poles. Therefore, magnetic course values might differ. This can
result in strange course readings in flight plans.
Little Navmap uses the declination of a VOR to calculate the inbound and outbound magnetic
course of a flight plan leg to and from this VOR. This allows the pilot to use the VOR radials for
navigation. For all other legs the actual environment declination is used.
You can disable the use of VOR declination in the options dialog on page Flight Plan by checking
Ignore declination of VOR and other radio navaids. This will use the environment declination for all
calculations. You might want to use this if you fly entirely based on GPS and ignore VOR stations.
27.3.1. Examples
A flight plan crossing the VORTAC Battle Ground (BTG) last calibrated 1975 (source
[http://www.pilotnav.com/navaid/faa-2529]) with a declination of 21° East while the environment has an actual
declination of 15.2° East. You can see the actual declination below the mouse cursor in the status
bar of Little Navmap.
Below a flight plan with three legs all having a true course of 90°.
Example with Ignore declination of VOR and other radio navaids not checked:

Note the course difference when flying to and from BTG compared to the magnetic course when flying to YIPYU. Magnetic course in- and
outbound to/from BTG is calculated based on the station declination 21° East while course to YIPYU is based on 15.2° East.

Example with Ignore declination of VOR and other radio navaids checked:

All magnetic course values are equal since the environment declination of 15.2° East is used to calculate the magnetic course for all legs.

See also Magnetic Declination for more information about declination values and scenery
databases.
27.4. Mouse Clicks
A double-click on an entry in the table view shows either an airport diagram or zooms to the
navaid. Additionally, details are shown in the Information dock window. A single click selects an
object and highlights it on the map using a black/green circle.
27.5. Top Buttons

27.5.1.

Clear Selection

Deselect all entries in the table and remove any highlight circles from the map.

27.5.2.

Select visible Columns

See chapter Column Selection below.
27.6. Context Menu Flight Plan

27.6.1.

Show Information

Same as Context Menu Map.

27.6.2.

Show Procedures

Same as Show Procedures. Only enabled for airports having procedures.

27.6.3.

Create Approach to Airport

Same as Create Approach.
See User Defined Approach for more information.

27.6.4.

Show on Map

Show either the airport diagram or zooms to the navaid on the map. The zoom distance can be
changed in the dialog Options on the tab Map.

27.6.5.

Activate Flight Plan Leg

Makes the selected leg the active (magenta) flight plan leg. The active leg might change if Little
Navmap is connected to the simulator and the user aircraft is moving.
You have to activate the leg manually if you would like to fly to an alternate airport.
Legs of a missed approach procedure are activated automatically if the procedure is shown on the
map.
27.6.6. Follow Selection
The map view will be centered - not zoomed in - on the selected airport or navaid when this
function is enabled.

27.6.7.

Move Selected Legs up or down

Move all selected flight plan legs up or down in the list. This works also if multiple legs are selected.
Airway names will be removed when waypoints in the flight plan are moved or deleted because the
new flight plan legs will not follow any airway but rather use direct connections.
Procedures or procedure legs cannot be moved and waypoints cannot be moved into or across
procedures.

27.6.8.

Delete Selected Legs or Procedure

Delete all selected flight plan legs. Use Undo if you delete legs accidentally.
The whole procedure is deleted if the selected flight plan leg is a part of a procedure. Deleting a
procedure deletes its transition too.

27.6.9.

Edit Flight Plan Position or Edit Flight Plan Position Remarks

Allows to change the name or coordinates of an user-defined waypoint in the flight plan. See Edit
Flight Plan Position.
Also allows to add a remark to any flight plan waypoint which is not an alternate and not a part of a
procedure. See Edit Flight Plan Remarks.

27.6.10.

Insert Flight Plan before

Inserts a flight plan before the selected leg into the current plan.

Using Insert Flight Plan before or Append Flight Plan allows to load or merge complete flight plans or
flight plan snippets into a new plan.
Procedures are inserted from the loaded flight plan and dropped from the current one depending on
insert position.
If you insert a flight plan after departure all procedures from the loaded plan are used and current
procedures are kept.
Inserting before departure takes the departure procedures from the loaded flight plan and drops
the current departure procedures.
The inserted legs are selected after loading the flight plan.

27.6.11.

Append Flight Plan

Adds departure, destination and all waypoints of another flight plan to the end of the current plan.
All currently selected arrival procedures will be removed when appending a flight plan. Arrival and
approach procedures from the appended flight plan are added to the current one, if any.
The appended legs are selected after loading the flight plan.

27.6.12.

Save selected range as Flight Plan

Extracts a part of the current flight plan and saves a new flight plan file which contains all legs
between the first and last selected including.
The currently loaded flight plan is not changed.
This menu item is disabled if the selected range contains legs which are alternates or part of a
procedure.

27.6.13.

Calculate Flight Plan for selected Range

Opens the flight plan calculation dock window which allows to automatically generate a flight plan
by various criteria between the first and last selected flight plan leg.
This menu item is disabled if the selected range contains legs which are alternates or part of a
procedure.
See chapter Flight Plan Route Calculation for more information.

27.6.14.

Add Range Rings

Same as Context Menu Map.
Note that the menu item is disabled if range rings are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

27.6.15.

Add Navaid Range Ring

Show the range rings for all selected radio navaids in the flight plan. Simply select all legs of the
flight plan and use this function to display a range circle for each radio navaid in the flight plan.
Otherwise, the same as Context Menu Map.
Note that the menu item is disabled if range rings are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

27.6.16.

Add Airport Traffic Pattern

Same as Add Traffic Pattern.
This menu item is enabled if clicked on an airport. Shows a dialog that allows to customize and
display an airport traffic pattern on the map.
See Traffic Patterns.
Note that the menu item is disabled if traffic patterns are hidden on the map (menu View -> User
Features). The menu item is suffixed with the text hidden on map if this is the case.

27.6.17.

Add Holding

Same as Add Holding.
See also Holdings.
Note that the menu item is disabled if holdings are hidden on the map (menu View -> User Features).
The menu item is suffixed with the text hidden on map if this is the case.

27.6.18.

Copy

Copy the selected entries in CSV format to the clipboard. The CSV will include a header. This will
reflect changes of the table view like column order. Columns which are hidden or shrinked to
minimum width are excluded.
Import the CSV text into spreadsheed programs using UTF-8 encoding and a semicolon as a
separator.
27.6.19. Select All
Select all flight plan legs.

27.6.20.

Clear Selection

Deselect all currently selected flight plan legs and remove any highlight circles from the map.

27.6.21.

Reset View

Reset the column order, visibility and widths back to default.

27.6.22.

Select visible Columns

See chapter Column Selection above.

27.6.23.

Set Center for Distance Search

Same as Context Menu Map.
27.7. Flight Plan Remarks
Adds a free text remark for the flight plan.
Note that this field saved is saved only in the Little Navmap LNMPLN format (Little Navmap LNMPLN
Format).
See also Remarks.

28. Map Flight Plan Editing
The flight plan drag and drop editing mode is enabled by default. It can be toggled using the
toolbar or Flight Plan -> Edit Flight Plan on Map in the main menu.
You can use the keyboard, the mouse wheel or the map overlays to scroll and zoom while editing
the route.
Note
The flight plan drag and drop editing is based on the assumption that a direct connection
between departure and destination already exists.
Always select departure and destination first if you would like to build you flight plan manually. This
will connect both points with a great circle line. Based on this line you can start to add navaids to
your flight plan.
Note that selecting airways is not possible.
The cursor will change into a cross
if a new navaid can be added to a leg. A cursor
will
be shown if a present navaid can be replaced by another one or if an user position can be moved.
The following functionality is available:
Click on a flight plan leg: Starts editing and adds a new waypoint depending on where the
next click is done:
On a single airport and navaid: Object is inserted into the flight plan segment.
On multiple airports or navaids: A menu pops up that allows you to select the
object to be inserted.
No airport and no navaid: An user-defined position is inserted into the flight plan.
Click on waypoint: Starts editing and replaces the selected waypoint with an object
depending on where you click next:
On a single airport and navaid: Object replaces the selected waypoint.
On multiple airports or navaids: A menu pops up that allows to pick the object
that should replace the selected waypoint.
No airport and no navaid: An user-defined position replaces the waypoint.
Click on departure or destination: Replaces the departure or destination with an object
depending on where you click next:
On a single airport: Airport replaces the departure or destination. A default runway
is assigned as start position if the departure is replaced with a new airport.
On a navaid: Object replaces departure or destination which results in an invalid
flight plan. The flight plan can be saved and loaded (a warning will be shown) but is
unusable by the flight simulator.
On multiple airports or navaids: A menu pops up that allows to select the object
that replaces departure or destination.
No airport and no navaid: An user-defined position replaces the waypoint resulting
in an invalid flight plan.
Right-clicking, pressing the escape key or any click outside of the map window:
Cancel current operation.
Limitations if procedures are used: You can not add navaids in or between procedures, nor can
you delete procedure legs. The cursor will not change shape when you hover over a procedure. The
following is not allowed:
Add a waypoint between departure airport and SID.
Add a waypoint between STAR or approach and destination airport.
Add a waypoint between STAR and approach or transition.
Move or remove the first or last waypoint of a procedure.
All departure or destination procedures are removed if the departure or destination airport is
moved or replaced. The same applies if waypoints are prepended before or appended after
departure or destination.

Inserting a navaid into a flight plan leg by clicking and moving the leg line. A tool tip for the navaid is shown.

Replacing VOR TRA in the flight plan with another one by simply clicking and moving the waypoint TRA onto KLO. A selection menu pops up
for disambiguation.

29. Procedures
29.1. General
Departure and arrival procedures will typically be used when flying an airliner, but smaller aircraft,
too, have to use at least an approach procedure at their destination when flying IFR. FSX and
Prepar3D stock data provides only approaches and transitions. SIDs and STARs are not available.
These can be added by navdata updates.
An airline flight containing all variations can use the following procedures or segments:
1.
2.
3.
4.
5.
6.
7.
8.
9.

Departure airport
SID
SID Transition
en-route airway system
STAR transition
STAR
Transition to approach
Approach
Destination

A small aircraft IFR flight can use the following procedures or segments:
1.
2.
3.
4.
5.

Departure airport
en-route airway system
Transition to approach
Approach
Destination

Note that transitions make only sense together with an approach, a SID or a STAR which will guide
you to or from the runway. You can select a transition only together with the respective procedure
(although the SID may be empty and consist only of a transition). If you delete a procedure from
the flight plan, its transition will be deleted too.
Procedure information is saved together with a flight plan as an annotation in the PLN file and will
be restored by Little Navmap when loading the flight plan.
Procedure waypoints are excluded from all flight plan formats by default. You have to use the GPS
or FMS in the simulator to select procedures.
Procedure waypoints are not saved in the flight plan since the PLN format does not support all the
different leg types and the flight simulator would not be able to display them correctly. Select the
procedures manually in your GPS or FMC as needed.
Some flightplan formats like X-Plane FMS allow saving and loading of procedures.
You can enable saving of waypoints by checking Export Waypoints for Approaches and/or Export
Waypoints for SID and STAR.
Note
It is not possible to assign an approach or STAR to an alternate airport. Create a new flight plan
for the alternate trip if you wish to do so.
29.2. Create Approach
An user defined approach can be created and applied to all airports, even small airstrips which do
not provide approach procedures.
This user defined approach consists of a final approach leg and can be customized by changing
altitude and length. This approach allows Little Navmap to give vertical guidance and to show ILS
and/or VASI slopes at the destination.
See more about this type of approach in chapter User Defined Approach.
29.3. Inserting a Procedure into a Flight Plan

Right-click on an airport in the map, the airport search table, or the flight plan table, and select Show
Procedures (or Show Departure Procedures, Show Arrival Procedures) from the context menu. This will show
the tab Procedures in the dock window Search.
Insert a procedure into the flight plan using the context menu in the procedure tree view.
See Search Procedures for more information.
29.4. Deleting a Procedure from a Flight Plan
Deleting a single leg that is part of a procedure will remove the whole procedure and its transition.
Deleting a leg that is part of a transition will remove only the transition.

About to remove the transition MUN of the approach RNAV BEGEN from the flight plan.

29.5. Limitations when editing a flight plan with procedures
Deleting a leg of a procedure will remove the whole procedure from the flight plan.
You cannot move a procedure leg up or down neither can you move or add a flight plan leg
into a procedure.
You cannot add waypoints in between procedures (e.g. between a STAR and an approach).
Waypoints can only be added to the route between departure and arrival procedures.
You cannot add waypoints between departure airport and a SID procedure.
You cannot add waypoints between arrival procedure and destination airport.
If you delete or replace the departure airport all SID procedures are removed too.
If you delete or replace the destination airport all approach and arrival procedures are
removed too.
29.6. Flying Procedures
Procedure legs are pre-calculated, with the exception of holds and procedure turns. This means you
can fly them mostly as they are drawn on the map. If in doubt about how to fly a leg (e.g. if too
many lines are overlapping) look at the procedure table in the Flight Plan Table.

29.6.1. Holds
No entry or exit procedure is shown. You have to find a proper entry procedure yourself. Holds
have a straight leg flying time in minutes or a distance.
If a time is given, fly the hold as usual:
1.
2.
3.
4.
5.
6.

Enter at the fix using a proper entry procedure
Do a standard turn
Fly the straight leg for the given time (typically one minute)
Do standard turn
Fly to fix
Exit hold when done or instructed by ATC

Note
Do not follow the lines exactly, they are just an indicator for what to fly. An exception are holds
where a distance is given for the straight leg. The hold size will match the distance in this case.
Note that procedure holds are part of the flight plan and differ from the user defined holdings (
Holdings) which are simply map display objects.

A hold with 2 NM straight segment length. Enter and exit at ZUNAD and fly at or above 2,600 ft. Course is 61° magnetic degrees.

29.6.2. Exiting a Hold
Little Navmap will detect when a hold is exited and advance the active leg to the next one if one of
the two conditions is met:
1. If the next leg continues after or at the hold fix: When approaching the hold fix after
one circuit continue straight on. The next leg will be activated after half a NM up to one NM.
2. If the next leg starts before the hold fix: Exit the hold at its fix. Exit right turn holds to
the left and vice versa (i.e. turn outside the hold). Proceed to the fix of the next leg which
will be activated.
You can activate the next leg manually if you do not exit the hold at its fix. Right-click in the flight
plan table on the next leg and select Activate Flight Plan Leg.
29.6.3. Procedure turns
The flight simulator data moves the turn point of a procedure turn 10 NM out from the fix which is
usually too far away.
Fly the procedure turn as usual: Minimum one minute from the fix. Use more if you need space to
catch the next fix after the course reversal. Then turn using an teardrop or a standard 45/180
degree turn. Again: Follow the procedures, not the lines.

A procedure turn. Fly at least one minute outbound 61° from ABERN, turn left to 16°, fly one minute, turn 180° and fly to LAMMB, then 242°
to ABERN.

29.6.4. Distances
All procedure legs, with the exception of holds and procedure turns, are included when calculating
flight distance. This means the total flight plan distance as well as the top of descent point will
change when selecting an approach or a transition.
29.7. Special Leg Types
All procedure leg types (Track to Fix, Initial Fix and more) that are shown in Little Navmap are
based on the ARINC 424 path terminator concept. A deeper knowledge of these leg types is not
important for the simulator pilot.
Four additional types are used by Little Navmap:
Start of Procedure:

This leg is added if a procedure does not start with an initial fix but rather
with a course, heading or track to a fix. It indicates the first position of the procedure.
Proceed to Runway in a SID: The first leg of a SID to indicate the start position on the runway.
The program might fall back to the airport center if the runway is not available. The altitude
restriction indicates the elevation of the runway.
Straight In: Added to an approach procedure to show the course from the missed approach
point (MAP) to the runway threshold. It is added when an approach ends with a runway fix.
The leg has an altitude restriction 50 ft above the threshold.
Circle to Land: Added to an approach procedure to show the course from the missed
approach point to the airport. It is added if an approach does not end with a runway fix.
Vectors: Vectors connect legs that are manually terminated by ATC with their successors
which is often an initial fix.

Straight In example: ENSH approach LOC FL01 (L01) to runway 01. White/orange dotted line is the straight-in leg. ML01 is the MAP. If
runway is not visible at ML01 turn left to missed.

Circle to Land in example: LSZC RNAV-A KUSIX (RNVA). White/orange dotted line is the circle-to-land leg. ZC701 is the MAP. No guidance
is given for this leg. You have to navigate around the mountain to get to runways 06 or 24.

29.8. Fix Types in a Procedure
Waypoints: Terminal waypoints or radio navaids. Some are marked as flyover in the
approach table.
Radial and distance: Example: WIK/7nm/291°M. A fix defined by a course or heading and
distance to a navaid.
Distance to DME: Example: WIK/9nm. This fix is defined by a heading or track which is
terminated by reaching a DME distance.
Intercept Course to Fix: Intercept a course to the next fix at an angle of about 45 degrees.
Course/Heading to radial termination: Example: LPD/135°M. Turn left or right to intercept a radio
navaid radial.
Intercept Leg: Intercept the next approach leg at a course of about 45 degrees.
Altitude: A leg or hold that is terminated by reaching a certain altitude and is used mostly on
missed approaches. Since the distance depends on the aircraft, 2 NM length are used for
this leg. You can ignore the line and proceed to the next leg once the altitude criteria is
satisfied.
Manual: Fly a heading, track or a hold until manually terminated by ATC.
Runway fixes are prefixed with RW. They usually have an altitude restriction a few ft above the
runway. Higher altitude restrictions (i.e. > 500 ft) indicate a circling approach.
29.9. Altitude and Speed Restrictions
Restrictions are shown on the map and in the flight plan table.
Number only: Fly at altitude or speed. Map examples: 5400ft or 210kts.
Prefix A: Fly at or above altitude or speed. Map example: A1800ft or A200kts.
Prefix B: Fly at or below altitude or speed. Map example: B10000ft or B240kts.
Range: Fly at or above the first altitude and at or below the second altitude. Map example:
A8000B10000ft. Same for speed.
Prefix GS: Not an altitude restriction but an indicator for the ILS glideslope altitude. Can
mean at or at or above.
29.10. Related Navaids

Many fixes have a related or recommended navaid. This can be a VOR, NDB, ILS or a waypoint. The
related navaid comes with radial and distance values that can be used to locate waypoints when
flying without GPS or simply for cross checking the position.
29.11. Missed Approaches
Missed approach legs are activated once the simulator aircraft passes the last point of an approach
and the missed approach is shown on the map. The display of remaining flight plan distance will
switch to display of remaining distance to last missed approach leg.
29.12. Leg Highlights on the Map
Up to three points will be highlighted when clicking on a procedure leg in the tree in the search
window:
A small blue circle shows the beginning of the leg.
The end of the leg is shown by a large blue circle.
A thin circle shows the location of the recommended or related fix if available.
29.13. Invalid Data
A leg entry will drawn red if a navaid was not resolved during the scenery database loading
process. This happens only when the source data is not valid or incomplete. In this case, the
resulting procedure is not usable and a warning dialog will be shown if essential navaids are
missing.
Little Navmap might refuse to use the procedure depending on error.

30. User Defined Approach
An user defined approach can be created and applied to all airports, even small airstrips which do
not provide approach procedures.
A defined approach consists of a final approach leg which can be customized by changing altitude
and length. This enables vertical guidance in the elevation profile and allows to show ILS and/or
VASI slopes at the destination.
The approach does not create an airport traffic pattern or a pattern like structure. Add user defined
waypoints to the flight plan for lateral guidance around the destination.
User defined approaches are part of a flight plan similar to a procedure unlike Traffic Patterns which
is only a map display feature.
This type of approach can be removed like other procedures by deleting one of the legs in the flight
plan table.
The approach is saved in the LNMPLN flight plan file like other approaches. User defined waypoints
are used for the initial fix and runway threshold when exporting a custom approach to other flight
plan formats than LNMPLN.
30.1. Waypoints
An user defined or custom approach consists of two waypoints which also indicate the runway
name:
IF22:

The initial fix or start of the approach procedure. This point has an altitude restriction
based on the entry altitude above the runway which is runway 22 in this example.
RW22: The runway threshold for runway 22 here.
30.2. Create Approach
Right click into the map, flight plan table or airport search result table on an airport and select
Create Approach for Airport and use as Destination or Create Approach for Airport and insert into Flight
Plan. The available options depend on whether the airport is already part of the flight plan.
Dialog header: Shows airport name and its ICAO ident as well as field elevation.
Runways: List of available runways for the airport. Shows runway name, length, width,
magnetic heading, surface and lighting status.
Entry distance to runway threshold: Distance from the initial fix to the runway. Default is 3 NM.
Entry altitude above runway: Altitude of the initial fix above runway elevation. Default is 1,000
ft.
Approach slope: Shows the slope angle calculated from the given distance and altitude. The
default values for distance and altitude give a 3.1 degree slope.
A click on the OK button or a double click into the list Runways closes the dialog and creates the
approach.

Dialog shown after right clicking on an airport and selecting Create Approach for Airport and use as Destination on airport 3R2.

An user defined approach for airport 3R2 to runway 22. Elevation profile shows approach slope and PAPI for vertical guidance.

31.

Tracks

Tracks are a structured set of flight routes that stretch across the Atlantic, Pacific or Australia.
Little Navmap can download, display and use the following tracks:
NAT [https://en.wikipedia.org/wiki/North_Atlantic_Tracks]: North Atlantic Tracks
PACOTS [https://en.wikipedia.org/wiki/Pacific_Organized_Track_System]: Pacific Organized Track System
AUSOTS [https://www.airservicesaustralia.com/ausots/ausotstoday.asp]: Australian Organised Track Structure

Image showing all track related functions in Little Navmap.

31.1. Download
Tracks are not downloaded periodically since changes in the track system can break flight plans.
You can choose to download tracks on startup or download them manually.
Download on startup and immediate can be enabled in the menu Flight Plan -> Download Tracks on
Startup. Manual download can be started in the menu Flight Plan -> Download Tracks.
You can select the track systems to download in the sub-menu Track Sources in the menu Flight
Plan. You have to start the download again to see the changes.
The track database is cleared on startup if Download Tracks on Startup is not selected.
31.2. Map Display and Information
Tracks are mostly used like airways. They respond to mouse click, tooltip and can be highlighted
from the information window on tab Navaids.

Tracks can be enabled for map display in the toolbar or menu View using

Show Tracks.

PACOTS and NAT tracks are shown in dark red color if eastbound and in dark blue color if
westbound. This does not apply to AUSOTS tracks.

Westbound PACOTS tracks are shown red and eastbound tracks in blue on the map. Track 8 is highlighted and shown in information
window. This track is valid for the current time.

NAT tracks A and Z. Information for track A shows flight levels 350, 370 and 390.

31.3. Flight Plan Calculation and Editing
You have to check Use NAT, PACOTS or AUSOTS tracks in the flight plan calculation window to use
tracks. The track will be used by Little Navmap if the settings allow this and the track is between
departure and destination.
See Flight Plan Route Calculation for more information.
Little Navmap will not keep you from creating invalid routes where you leave a track early or switch
to a track. Valid flight plans can only be ensured by using the flight plan calculation.
Note
You have to use the correct cruise flight altitude in your flight plan. This has to match the track
levels shown in the information window. Otherwise, the track will not be used.
31.4. Export
Track information is saved for flight plans in Little Navmap’s LNMPLN format (Little Navmap
LNMPLN Format).
It can happen that Little Navmap shows errors when a plan is reloaded later with different or
missing tracks. Calculate the flight plan again to use the changed tracks.
All other exported flight plan formats for simulators, aircraft and tools will not receive track
information but only a list of waypoints extracted from the track. This should allow to load the
plans into all without issues.

32. Edit Flight Plan Position
This dialog allows to edit an user-defined flight plan position that was added with
Position to Flight Plan or

Add

Append Position to Flight Plan.

The information entered here is saved with the flight plan.
Keep in mind that all information entered here is lost if the flight plan position is removed or a new
flight plan is calculated (Flight Plan Route Calculation).
Note that all fields are saved without limitations only in the Little Navmap LNMPLN format (Little
Navmap LNMPLN Format). Other flight plan export formats will only save the ident truncated or a
coordinate.
Note
Waypoints using the default format WP plus number (e.g. WP1 or WP99) are automatically
renumbered by Little Navmap to reflect the flying order in the flight plan.
Changing the name will disable the renumbering for a waypoint.
32.1. Ident
Ident which is shown on the map, in the flight plan table and in exported flight plan formats, if
supported.
It is recommended to use a short identifier without special characters. Otherwise free text field.
32.2. Region
Recommended to use the two-letter code for ICAO region, like EN for Norway or LI for Italy, if
known. The region is shown in map tooltip and flight plan table tooltip.
Otherwise free text field.
32.3. Name
Free text field. Shown in map tooltip and flight plan table tooltip.
32.4. Remarks
Free multi line text field. Shown in abbreviated form in the flight plan table Remarks column and the
column’s tooltip as well as in the map tooltip.
See Remarks for more information.
32.5. Latitude and Longitude
You can also edit the coordinates directly in this dialog besides using the drag and drop method
Map Flight Plan Editing. This can be useful if you’d like to add waypoints with well known
coordinates like visual reporting points.
The tooltip of the coordinate input field shows the available formats. Hover the mouse over the
input field to see this.
See Coordinate Formats for more information.

Editing an user-defined flight plan position. Also showing abbreviated tooltip in flight plan table.

33. Edit Flight Plan Remarks
This dialog allows to add a remark to any flight plan waypoint which is not an alternate and not a
part of a procedure.
The information entered here is saved with the flight plan in the Little Navmap LNMPLN format
(Little Navmap LNMPLN Format).
Keep in mind that all information entered here is lost if the flight plan position is removed or a new
flight plan is calculated (Flight Plan Route Calculation).
33.1. Header
The dialog header shows the navaid type, name and region.
33.2. Remarks
Free multi line text field. Shown in abbreviated form in the flight plan table Remarks column and the
column’s tooltip as well as in the map tooltip.
See Remarks for more information.

Editing remarks for a flight plan waypoint. Also showing abbreviated tooltip in flight plan table.

34. Flight Plan Route Calculation
The route calculation is done in a floating window which is opened from menus -> Flight Plan ->
Calculate Flight Plan or Window -> Flight Planning. The floating window does not dock into the main
window when moving around except when double clicking on its title bar.
The window can be used to calculate the following:
Whole flight plans from start to destination.
Routes between selected waypoints in the flight plan table.
You have to build the route again by pressing the button Calculate after changing any parameters.

Flight Plan calculation floating window. Flight plan is valid for calculation.

34.1. Window Header
Shows start and end of calculation or an error message. Click on the tooltip or hover the mouse
cursor above to see more details.

Error message with tooltip showing details.

34.2. Calculate from departure to destination
Calculates a flight plan between start and destination.
The dialog header will show a red error message if the flight plan is not valid for calculation. Hover
the mouse cursor over the message or click it for details.
Procedures are not affected by this calculation method. The route will be built from SID exit to
STAR or approach entry, if present.
34.3. Calculate for selection in flight plan table

This button is only valid when more than one flight plan leg is selected and neither the first nor the
last selected leg is part of a procedure.
The dialog header will show an error message if the selected range is not valid for calculation.
A selection is also valid for the last leg of a departure procedure or for the first leg of an arrival
procedure.
You can either select the first and the last leg (Ctrl+Click) in the Flight Plan Table or you can select a
whole range of legs (Shift+Click and drag) for route calculation.
The route will be calculated in a way that the first and last navaids are not modified.
The new calculated range will be selected in the table once calculation is done.
34.4. Cruise Altitude
Sets the cruise altitude which will be used to select airways based on their lower and upper altitude
limits when calculating the route.
The value will be assigned to the flight plan (Cruise altitude) after calculation.
Note that a change in the Flight Planning window will not be automatically transferred to this
window.
The calculation might fail if using too low or too high values here.
34.5. Adjust
Changes the flight plan altitude according to a simplified East/West rule and the current route type
(IFR or VFR).
Same as Adjust Flight Plan Altitude.
34.6. Airways
Selects the airway calculation method and enables all fields to the right of this button.
This method uses airways and/or direct waypoint connections to build a route. Which connection
type is selected depends on settings in Prefer.
Criteria for airway selection are always direction for one-way airways and altitude restrictions.
34.6.1. All Airways
Calculation will select any appropriate Jet or Victor airway for the route.
34.6.2. Jet airways (high altitude)
Limit calculation to Jet or high altitude airways. Calculation might fail if using a too low cruise
altitude.
34.6.3. Victor airways (low altitude)
Limit calculation to Victor or low altitude airways. Calculation might fail if using a too high cruise
altitude.
34.6.4. Avoid RNAV airways
Check this for non-RNAV equipped aircraft. This will select only airways which can be followed by
using radio navaids like VOR or NDB.
Calculation might fail or give unexpected results if this is selected unintentionally.
34.6.5. Use NAT, PACOTS or AUSOTS tracks
The calculation will also consider tracks like NAT, PACOTS or AUSOTS, if selected. This button is
disabled if no tracks were downloaded.
See Tracks for more information.

Note
You have to use the correct cruise flight altitude in your flight plan. This has to match the track
levels shown in the information window. Otherwise, tracks will not be used.

34.6.6.

Download Tracks

Downloads Oceanic or other tracks which are NAT, PACOTS and AUSOTS. Download tracks first
before using the option above.
Same as Download Tracks.
34.6.7. Prefer
This slider allows to adjust the preference of the calculation method between airways and direct
waypoint connections.
Putting the slider on the leftmost position instructs the route calculation to use only airways.
The calculation might fail or give not optimal routes if the region between departure and
destination has no airways or no appropriate airways for the given cruise altitude.
This is the fastest calculation method which gives instant results.

A flight plan calculated using airways only. The flight plan is longer since the region above Austria is void of airways due to European
airway restructuring.

Putting the slider on the rightmost position instructs the route calculation to use only direct
waypoint connections. The calculation ensures that the selected waypoints are not too close
together and have a distance of around 200 NM where possible. Cruise altitude is not relevant for
calculation since no airways are used.
This calculation method is slower depending on the covered region. A progress dialog might pop up
which allows to cancel the process.

Same plan as above but calculated with the slider on the far right. The plan is shorter and uses direct waypoint connections only.

Putting the slider on an intermediate position uses more or fewer airways or direct waypoint
connections depending on position. Move the slider step by step and calculate again if you’re not
satisfied with the result. Note that not every slider movement will result in a changed route.
This calculation method is slower depending on the covered region. A progress dialog might pop up
which allows to cancel the process.

A flight plan calculated using airways and direct waypoints. The plan uses mostly airways and skips the airway void above Austria with
direct waypoint connections.

34.7. Radio Navaids

Selects the radio navaid calculation method and enables the field to the right of this button.
Creates a flight plan that uses only VORDME, VORTAC, VOR and optionally NDB stations as
waypoints. This method tries to ensure reception of at least one station along the whole flight plan.
Note that VOR stations are preferred before NDB stations. Calculation can fail if not enough radio
navaids can be found between departure and destination. Build the flight plan manually if this is
the case.
34.7.1. Use NDB
Use NDB stations too when selecting navaids for the route when checked. Otherwise, only
VORDME, VORTAC and VOR.
34.8. Direct
Deletes all intermediate waypoints and connects departure and destination using a great circle line.
Does not delete procedures.
Same function as Calculate Direct.
34.9. Reverse
Swaps departure and destination and reverses order of all intermediate waypoints. Deletes airway
references and procedures.
Same as Reverse Flight Plan.
34.10. Calculate
Calculates the route considering all the parameters given above.
Airway restrictions quite often do not allow optimal routes. You might have to change the cruise
altitude to get better results.
You might also have to change the slider Prefer to adjust for airway and direct waypoint connection
usage if not satisfied with the result.
In any case check your flight plan before using it. Remove any wrongly selected waypoints near
departure and destination manually.

35. Flight Plan Route Description
This dialog allows you to create a flight plan from a route description string consisting of airport
and navaid idents as generated or provided by various online services.
The New Flight Plan from Route Description dialog opens with the route description for the current flight
plan which also contains information about speed and cruise altitude if enabled.
The top half of the dialog holds the route description input field, while the bottom half shows any
messages, warnings or errors that occur during reading.

The menu button
route string.

provides a dropdown menu than can be used to customize the generated

Little Navmap will try to use as much of the route as possible even if parts of the flight plan like
waypoints or airways cannot be found or names are ambiguous. You will see warnings in the
bottom half if that is the case.
If a route covers a long distance and contains a waypoint name which is not unique, a wrong
waypoint might be added to the flight plan. Correct or remove this waypoint manually.
Many waypoints and airways will not be found if route descriptions from the latest AIRAC sources
are used together with the old FSX, P3D or MSFS stock data. It is recommended to use a
navigation data update for the stock scenery or Little Navmap when reading route descriptions
from online sources like RouteFinder [http://rfinder.asalink.net/], Online Flight Planner
[http://onlineflightplanner.org/], SimBrief [https://www.simbrief.com] or SkyVector [https://skyvector.com].
If a navdata update is not an option, pick the online service’s AIRAC cycle that is closest to the
cycle the navigation data of your flight simulator is based on.
Note that even flight plans calculated in Little Navmap cannot be converted back exactly in some
cases. This happens due to navaid ambiguities like NDB and VOR stations having the same names
or errors in the source data.
The cruise altitude is used to create the flight plan, if given. Otherwise the cruise altitude is
automatically determined by the flight plan type (IFR or VFR) and the minimum altitude of the used
airway segments.
The cruise speed is ignored and produces a warning if found.

A route description that was read successfully with a few warnings about ignored elements. The waypoint LLL could not be found. Speed,
altitude, SID and STAR were recognized.

35.1. Buttons

To Clipboard:

Copy the current description as plain text to the clipboard.
Insert text from clipboard into the input field. The inserted text is converted to
upper case and all invalid characters are removed from the text before reading.
Update from Flight Plan: Create the route string from the current flight plan again. Use this
after changing settings with drop down menu button.
Read Route Description: Reads the route description and displays any messages, warnings and
errors in the bottom half of the dialog. The current flight plan is not affected by this action.
IFR / VFR: Defines the type of the generated flight plan and the automatically determined
cruise altitude.
From Clipboard:

Menu Button
: Write denotes flight plan to description and Read denotes description to
flight plan. You can tear off the drop down menu from the button by clicking on the dashed
line on top of it.
Write departure and destination airport: Note that disabling this option will result in an
invalid route description which cannot be read back into a flight plan.
Write DCT (direct) instructions: Add DCT for any direct waypoint connections in the flight
plan.
Write cruise speed and altitude instruction: Add cruise altitude from flight plan and
speed as set in the aircraft performance.
Write waypoints instead of Airways: Does not include airway names in the string but
expands it and inserts the waypoints names only.
Write Alternates: Appends all alternate airports to the end of the description.
Write SID and STAR: Add SID and STAR names, if any are used for departure or arrival.
Write generic SID and STAR: Add the generic SID and STAR keywords if no real SID and/or
STAR were selected.
Write no SID and STAR: Do not include any SID and STAR information at all.
Read trailing Airports as Alternates:
Enabled: A list of airports at the end of the description will be read as alternate
airports except the first in the chain of consecutive airports which will be used
as destination. Any airport with a valid STAR in the chain will be treated as
destination too.
Disabled: Reading simply creates a flight plan with the airports as intermediate
waypoints and the last one as destination. See example below.
Read first and last item as navaid: Does not require airports as start and destination
and will resolve the first and last item to navaids. Useful for reading snippets.
Read: Match coordinates to waypoints: Tries to matches coordinates to nearby waypoints.
EICK 5000N00760W EDDF will result in EICK GAPLI EDDF if this is enabled, for example.
Create Flight Plan: Closes the dialog and creates a new flight plan for the parsed route
description and replaces the current plan. You have to click Read Route Description before you
can create a flight plan.
35.2. Airport idents
ICAO, FAA, IATA and local codes are shown and the internal ident is avoided for display if possible.
Note that IATA codes are only read for departure and destination since they can be easily confused
with navaids en-route.
Note that X-Plane internal codes like XPA000B are still recognized despite being avoided for display.
35.3. Format
The route description has to follow the format rules below:
FROM[ETD] [SPEEDALT] [SID][.TRANS] [ENROUTE] [STAR][.TRANS] TO[ETA] [ALTERNATES]

All elements in square brackets are optional.
FROM

and TO: These are the required 3 or 4 letter idents for departure and destination airports.

Examples: KEAT, CYPU, S16.
ALTERNATES:

Alternate airports are optional and are added to the flight plan when reading depending
on the option Read trailing Airports as Alternates as described above.
SPEEDALT:

An optional entry that contains the cruise speed and altitude. See below for a details.
Speed is ignored when reading since it is part of the aircraft performance profile.

ENROUTE:

This is a list of either WAYPOINT or an AIRWAYWAYPOINT forming the actual flight plan. The first
entry has to be an airport, waypoint, VOR or NDB.
WAYPOINT:

A waypoint, VOR, NDB, airport or user-defined coordinates. See below for a details about
coordinates. A waypoint can be prefixed with DCT to indicate a direct connection not using an
airway. Waypoints can be suffixed with an optional /SPEEDALT value although this is ignored.
Examples: TAU, BOMBI, AST, CL, EDDF.
AIRWAYWAYPOINT:

Airway and end waypoint on the airway separated by a space.

Examples: V495 CONDI, V338 YVR, V330 TRENA.
and STAR.TRANS: Either the words SID or STAR or real SID, STAR and transition names where
the optional transition is separated by a .. The generic keywords SID and STAR create a direct
connection to the en-route part.
SID.TRANS

Examples: RDHK2.HOLLE, OHIO3.LFK, RDHK2, OHIO3.
35.3.1. Features not supported
and ETA: Four digit departure and arrival time attached to the airport or waypoint ident are
ignored.
ETD

WAYPOINT.SPEEDALT:

For example BOMBI/N0090A060. Altitude changes at waypoints are not supported and
ignored when reading.
35.3.2. Alternates
Example when reading Read trailing Airports as Alternates enabled:
KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT
KPWA ATOKA J25 FUZ J33 CRIED J50 LFK KHOU KCLL KVCT
KHOU

is read as destination, KCLL and KVCT are alternates for both examples.

Example when reading Read trailing Airports as Alternates disabled:
KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT

Not valid. Error message BAYYY3.SJI not found printed. KVCT is read as destination, KHOU and KCLL are
intermediate waypoints.
KPWA ATOKA J25 FUZ J33 CRIED J50 LFK KHOU KCLL KVCT
KVCT

is read as destination, KHOU and KCLL are intermediate waypoints.

35.3.3. Speed and Altitude
Cruising ground speed and cruising level not separated by a space.
Speed is prefixed with:
K:

Kilometers per hour followed by a four digit value.

N:

Knots followed by a four digit value.

M:

Mach followed by a three digit value. The mach value is converted to knots ground speed
assuming standard atmosphere conditions at the given flight altitude.
Altitude is prefixed with:
F

:Flight level in three digits.

S:

Metric flight level in three digits of tens of meters.

A:

Altitude in hundreds of feet in three digits.

M:

Altitude in tens of meter in four digits.

Examples:
N0410F310
M071F320

410 knots at flight level 310.

Mach 0.71 at flight level 320.

K0790M0710

790 kilometers per hour at 7,100 meters.

35.3.4. Coordinates
Coordinates can be supplied in different formats:
Degrees only (7 characters): Two digits and north/south indicator plus three digits and east/west
indicator.
Example: 51N010E
Degrees and minutes (11 characters): Two digits degrees, two digits for minutes and north/south
indicator. Then three digits for degrees, two digits for minutes and east/west indicator.
Example: 4010N03822W.
Degrees, minutes and seconds (15 characters): Two digits degrees, two digits for minutes, two
digits for seconds and north/south indicator. Then three digits for degrees, two digits for minutes,
two digits for seconds and east/west indicator. This format is used by SkyVector [https://skyvector.com]
for example.
Example: 481200N0112842E.
North Atlantic track points (NAT). Two digits degrees north and two digits degrees west followed
by character N.
Example: 5010N.
Coordinate waypoint pairs with degrees and minutes as above and prefixed with north/south
and east/west indicator.
Examples: N4200 W02000 or N4200/W02000.
Garmin GFP format (13 characters) north/south indicator, two digits degrees, three digits for
minutes by 10. Then east/west indicator, three digits degrees, three digits minutes by 10. This
format is used by the Flight1 GTN 650/750.
Example: N48194W123096
35.4. Flight Plan Description Examples
Frankfurt Main (EDDF) to Fiumicino (LIRF):
Direct connection:
EDDF LIRF

or EDDF DCT LIRF.

VOR to VOR:
EDDF FRD KPT BOA CMP LIRF.

Same as above with departure time ( ETD ) and arrival time ( ETA ) which both will be
ignored:
EDDF1200 FRD KPT BOA CMP LIRF1300.

Same as above on flight level 310 at 410 knots:
EDDF N0410F310 DCT FRD DCT KPT DCT BOA DCT CMP DCT LIRF

Using Jet airways:
EDDF ASKIK T844 KOVAN UL608 TEDGO UL607 UTABA UM738 NATAG Y740 LORLO M738 AMTEL M727 TAQ LIRF

Same as above on flight level 310 at mach 0.71 with an additional speed and altitude at
NATAG which will be ignored:
EDDF M071F310 SID ASKIK T844 KOVAN UL608 TEDGO UL607 UTABA UM738 NATAG/M069F350 Y740 LORLO M738 AMTEL M727
TAQ STAR LIRF

User-defined waypoints with degree/minute notation and an alternate airport LIRE :
EDDF N0174F255 4732N00950E 4627N01019E 4450N01103E LIRF LIRE

Flight plan using SID and STAR procedures with transitions:
KPWA RDHK2.HOLLE ATOKA J25 FUZ J33 CRIED J50 LFK OHIO3.LFK KHOU

Flight plan using the generic SID and STAR keywords:
KPWA SID ATOKA J25 FUZ J33 CRIED J50 LFK STAR KHOU

Flight plan using SID and STAR procedures with transitions and two alternate airports:
KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT

36. Flight Plan Formats
Little Navmap supports several flight plan formats, all of which have different limitations. All of the formats listed
below can be exported and some can be loaded.
36.1. Little Navmap LNMPLN Format
Little Navmap uses its own XML based format since only this allows to save all features provided by the program in a
safe manner as well as proper file validation. This also eliminates many of the confusing warning dialogs when saving
other formats and potential data loss.
While you can still load, for example, FMS and other formats directly into the program, saving is limited to the LNMPLN
format. You have to export the plan as FMS after changing it. You can do that either directly from the menu File ->
Export Flight Plan as X-Plane FMS 11 or using menu File -> Multiexport Flight Plan Options and then File ->
Multiexport Flight Plan.
See also Flight Plan Multiexport for more information on multiexport.
Note
The LNMPLN format is only understood by Little Navmap. Do not try to load it into simulators or add-ons.
Consider exported flight plan files as disposable since almost all the export formats have limitations resulting in data
loss. Remember that you can always restore them by loading the original LNMPLN file and exporting again.
See Little Navmap Flight Plan File Format for a detailed description of the format.
Warning
Always save a copy in the default LNMPLN format before exporting to other formats like FMS. This allows Little
Navmap to restore all flight plan properties like procedures, alternate airports and remarks.
36.2. Flight Plan Export Formats
The table below shows the capabilities of Little Navmap and the supported flight plan formats (X = supported, 0 = not
supported, - = not applicable) as listed in Flight Plan Multiexport.
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For Flight1 Garmin GTN 650/750, Reality XP GNS 530W/430W V2 and Reality XP GTN 750/650 Touch additional export formats exist
which replace waypoints with user defined waypoints. This helps to avoid the locked waypoint issue.
Procedure waypoints are excluded from most file formats by default, except for GPX. You have to use the GPS, FMS or
MCDU in the simulator to select procedures. Exceptions are e.g. X-Plane FMS and FLP which allow to save and load
procedures.
You can enable saving of waypoints by checking the menu items Export Waypoints for Approaches and/or Export
Waypoints for SID and STAR.
The current file name and type will change if you save a plan as LNMPLN. This does not occur when exporting.
36.3. User Waypoint Names
User waypoint names will be adapted to format limitations when exporting.
PLN: Maximum length for FSX or Prepar3D is 10 characters and no special characters are allowed. Unsupported
characters will be removed and the length will be truncated.
FMS: No spaces allowed. These will be replaced with underscores (_).
FLP: All user waypoint names will be replaced by coordinates.
36.4. Formats

36.4.1.

Microsoft Flight Simulator 2020

File format for MSFS. Little Navmap can read and export this format.
You can export this format directly using Export Flight Plan as MSFS 2020 PLN.
While the format supports procedures there may appear problems in MSFS loading these. Procedures might be omitted
or new ones inserted. Furthermore MSFS does not support the selection of transitions and often inserts these
automatically.
You can set a parking spot or fuel pad as starting position but note that runways and helipads as starting positions will
be ignored by MSFS.

36.4.2.

FSX and Prepar3D

File format for FSX and P3D. Little Navmap can read and export this format. Procedures are not saved.
You can export this format directly using Export Flight Plan as P3D or FSX PLN.
36.4.3. FSX and Prepar3D annotated (obsolete)

Annotated PLN format used by Little Navmap versions up to and including 2.4.5.
This is needed only if you like to save a flight plan for older Little Navmap versions.
Little Navmap can read and export this format completely with procedures.
36.4.4. FS9 PLN
File format of the Flight Simulator 2004. Uses the same PLN file extension as the FSX PLN format. Little Navmap can
only read this format.

36.4.5.

X-Plane FMS 11

X-Plane FMS format which can be loaded into the stock GPS, the G1000 and the FMS of X-Plane 11.10 [https://www.xplane.com] or later.
You can export this format directly using Export Flight Plan as X-Plane FMS 11.
Little Navmap can read and export this format.
Store these files into the Output/FMS plans directory inside the X-Plane directory.
Read the X-Plane manuals for the respective devices on how to load plans inside the cockpit: User Manuals for X-Plane
Products [https://www.x-plane.com/support/manuals/].
Note
Little Navmap cannot determine the cruise altitude of a flight plan after loading this format in some cases. You might
see errors about violated altitude restrictions after loading. Adjust the cruise altitude manually if this is the case.
36.4.6. FMS 3 (X-Plane)
X-Plane FMS format which can be loaded into the stock GPS and FMS of X-Plane 10 and 11.05. The format is very
limited and basically stores only a list of waypoints.
Little Navmap can read and export this format.
Store these files into the Output/FMS plans directory inside the X-Plane directory.

36.4.7.

FlightGear

FlightPlan format which can be loaded into the RouteManager of the free flight simulator FlightGear
[http://www.flightgear.org].
You can export this format directly using Export Flight Plan as FlightGear FGFP.
Little Navmap can read and export this format.
You can save the files into any directory and load it within FlightGear.
36.4.8. FSC
File format for FlightSim Commander. Uses the same PLN file extension as the FSX PLN format. Little Navmap can only
read this format.
36.4.9. Aerosoft Airbus and others
36.4.10. Aerosoft CRJ
A format that can be read by the X-Plane FMS (not the X-Plane GPS), Aerosoft Airbus and other add-on aircraft.
Supports airways and procedures.
You can load these files into the X-Plane FMS including airway information. Procedures are saved in the FLP but cannot
loaded yet by the FMS. You have to select these manually after loading the flight plan.
36.4.11. Garmin
Simple XML based flight plan format which stores only a list of waypoints. Little Navmap can read and export this
format.
36.4.12. Reality XP GNS 530W/430W V2
Flight plan format as FPL file usable by the Reality XP GNS 530W/430W V2.
See Notes about the Garmin Formats GFP and FPL for information on known problems when exporting flight plan data
for the GNS.
Little Navmap considers the GNSAPPDATA environment variable if set. See the GNS manual for more information.

The default directory to save the flight plans for the GNS units is C:\ProgramData\Garmin\GNS Trainer Data\GNS\FPL for all
simulators. The directory will be created automatically by Little Navmap on first export if it does not exist.
36.4.13. Reality XP GTN 750/650 Touch
Save flight plan as GFP file usable by the Reality XP GTN 750/650 Touch.
See Notes about the Garmin Formats GFP and FPL for information on known problems when exporting flight plan data
for the GTN.
Little Navmap considers the GTNSIMDATA environment variable if set. See the GTN manual for more information.
36.4.14. Flight1 Garmin GTN 650/750
The default directory to save the flight plans for the GTN units is C:\ProgramData\Garmin\Trainers\Databases\FPLN for all
simulators. The directory will be created automatically by Little Navmap on first export if it does not exist.
36.4.14.1. Garmin GTN Trainer 6.41

The default directory to save the flight plans for the GTN units is C:\ProgramData\Garmin\Trainers\GTN\FPLN for all simulators.
You have to create this directory manually and then navigate to it in the file dialog when saving. Little Navmap will
remember the selected directory.
36.4.14.2. Garmin GTN Trainer 6.21

If you’re using the trainer version 6.21 then the default path is C:\ProgramData\Garmin\GTN Trainer Data\GTN\FPLN. You have
to create this directory manually.
36.4.15. Flight1 Garmin GTN 650/750
This is the flight plan format used by the Flight1 GTN 650/750.
See Notes about the Garmin Formats GFP and FPL for information on problems when exporting flight plan data for the
GTN.
The default directories to save the flight plans for the GTN units are:
Prepar3D v3: C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\F1TGTN\FPL.
Prepar3D v4: C:\Program Files\Lockheed Martin\Prepar3D v4\F1TGTN\FPL.
Flight Simulator X: C:\ProgramFiles(x86)\Microsoft Games\Flight Simulator X\F1GTN\FPL
You might need to change the user privileges on this directory if your saved flight plans do not show up in the GTN.
Give yourself full control and/or ownership of this directory to avoid this.
A typical symptom is that you can save the flight plan in Little Navmap and you can also see the saved plan in Little
Navmap’s open dialogs but it does not show up in the GTN unit. Change the privileges of the export directory as
mentioned above if that is the case.
The file is a simple text format containing only one line of text.
Example for the content of a flight plan file named KEAT-CYPU.gfp
FPN/RI:F:KEAT:F:EAT.V120.SEA.V495.CONDI.V338.YVR.V330.TRENA:F:N50805W124202:F:N51085W124178:F:CAG3:F:N51846W124150:F:CYPU

36.4.16. PMDG Aircraft
A PMDG RTE file. File location depends on the used aircraft but is usually PMDG\FLIGHTPLANS in the simulator base
directory.
This format does not allow saving of procedures.
36.4.17. Rotate MD-80, JARDesign and others
A simple file format usable by JARDesign or Rotate Simulations aircraft. The dexport directory depends on the used
aircraft which is usually in the X-Plane directory Aircraft.
The file is a simple text format containing only one line of text.
Example for the content of a TXT file named CBZ9CYDC.txt
CBZ9 SID AIRIE V324 YKA B8 DURAK STAR CYDC

36.4.18. Majestic Dash MJC8 Q400
Flight plan format for the Majestic Software MJC8 Q400. Note that the export is limited to a list of waypoints.
The flight plan has to be saved to YOURSIMULATOR\SimObjects\Airplanes\mjc8q400\nav\routes.
Note that the FMC in the Dash will show invalid coordinates when you press INFO on a waypoint or airport. The flight
plan, navigation and autopilot are not affected otherwise.
36.4.19. IXEG Boeing 737

Exports the current flight plan as a FPL file usable by the IXEG Boeing 737. The format is the same as TXT but with a
different file extension.
The file should be saved to XPLANE\Aircraft\X-Aviation\IXEG 737 Classic\coroutes. You have to create the directory manually
if it does not exist.
36.4.20. Flight Factor Airbus
A format for the Flight Factor Airbus. The file is not truncated and flight plans are appended when saving.
Flight plans are saved in a slightly extended ATS route notation which also allows to save the cruise altitude and
approach procedures. Edit the file with a simple text editor if you want to remove flight plans.
While this format allows saving of SID and STAR the option for approaches was removed since it is unreliable.
Example

RTE ETOPS002 EINN 06 UNBE2A UNBEG DCT 5420N DCT NICSO N236A ALLEX Q822 ENE DCT CORVT KJFK I22R JFKBOS01 CI30 FL360
RTE EDDFEGLL EDDF 25C BIBT4G BIBTI UZ29 NIK UL610 LAM EGLL I27R LAM CI25 FL330

36.4.21. iFly
Flight plan format for the iFly 737NG for FSX or P3D. The file has to be saved to YOURSIMULATOR/iFly/737NG/navdata/FLTPLAN.
Procedures cannot be saved.
36.4.22. ProSim
A flight plan format for ProSim [https://prosim-ar.com]. The flight plan is appended to the file companyroutes.xml when saving.
Remove flight plans manually in a text editor.
Little Navmap creates up to two backup files when saving the flight plan: companyroutes.xml_lnm_backup and
companyroutes.xml_lnm_backup.1.
Procedures cannot be saved.
Example

<?xml version="1.0" encoding="UTF-8"?>
<companyroutes>
<route name="EFMAESGT">EFMA RUNGA N872 TEB N623 BEDLA N866 NEGIL ESGT</route>
<route name="LGIRLEDA">LGIR SUD UJ65 TRL UM601 RUTOM M601 QUENN Q123 LULIX P167 GINOX UM601 BCN UN975 SELVA LEDA</route>
</companyroutes>

36.4.23. BlackBox Simulations Airbus
This format is for the Blackbox Simulations Airbus for FSX or P3D. Save this to YOURSIMULATOR/Blackbox Simulation/Company
Routes or YOURSIMULATOR/BlackBox Simulation/Airbus A330 depending on aircraft type.
This format cannot save procedures.
36.4.24. Leonardo Maddog X
Flight plan for the Leonardo MaddogX aircraft. This format cannot save procedures.
36.4.25. QualityWings
Flight plan for QualityWings aircraft. This format cannot save procedures. The location depends on the aircraft.
36.4.26. AivlaSoft EFB
Flight plan for the AivlaSoft Electronic Flight Bag [https://aivlasoft.com]. Saving of procedures is not supported.
36.4.27. Level-D
Flight plan for Level-D aircraft. This format cannot save procedures. Save this to YOURSIMULATOR\Level-D
Simulations\navdata\Flightplans.
36.4.28. FeelThere or Wilco
The format above cannot save procedures. The location depends on the aircraft.
36.4.29. TFDi Design 717
Flight plan format for the TDFi Design Boeing 717. The format above cannot save procedures.
36.4.30. IvAp for IVAO
36.4.31. X-IVAP for IVAO
Flight plan format for the IVAO online network clients IvAp or X-IvAp [https://www.ivao.aero/softdev/ivap.asp].
The file format for these two clients differs slightly.
Flight Plan Online Network Export will appear before where you can add all needed information.

36.4.32. VATSIM vPilot or SWIFT
Flight plan format for the VATSIM vPilot [https://www.vatsim.net/pilots/download-required-software] online network client.
Flight Plan Online Network Export will appear before where you can add all needed information.
36.4.33. UFMC
A flight plan format for the UFMC [http://ufmc.eadt.eu]. The format does not allow saving of procedures.
Save the flight plan to XPLANE\Custom Data\UFMC\FlightPlans.
36.4.34. X-FMC
Save flight plan as FPL file for the X-FMC [https://www.x-fmc.com]. The format does not allow saving of procedures.
The file should be saved to Path to XPLANE\Resources\plugins\XFMC\FlightPlans.
36.4.35. Garmin exchange format
GPX is not a flight plan format.
The GPS Exchange Format can be read by Google Earth and most other GIS applications.
The flight plan is embedded as a route and the flown aircraft trail as a track including simulator time and altitude.
The route has departure and destination elevation and cruise altitude set for all waypoints. Waypoints of all procedures
are included in the exported file. Note that the waypoints will not allow to reproduce all parts of a procedure like holds
or procedure turns.
The track contains the aircraft trail with flown altitude and timestamps.
36.4.36. HTML flight plan web page
This is not a flight plan format. This function saves the current flight plan as a single HTML web page with all images
embedded. You can open this page in any web browser.
The exported file will reflect changes of the flight plan table view like column order. Columns which are hidden or
shrinked to minimum width are excluded.
36.5. Notes about the Garmin Formats GFP and FPL
Various problems can appear when reading exported flight plans into the Garmin units. Most of these are a result of
the Garmin navigation database which uses data of an older AIRAC cycle (mostly 1611 at the time of writing). Updated
simulator or add-on databases (like the one in Little Navmap) can use the latest navdata or an old one from FSX or
P3D stock data.
Any waypoints, airways or procedures that are removed, added or renamed over time can cause locked waypoints or
other messages when reading a flight plan into the GNS or GTN.
It is easy to remove locked waypoints within the GNS or GTN to enable the flight plan to be activated. Refer to the
documentation of the Garmin unit.
Little Navmap allows to change the Garmin export to replace all waypoints with user-defined waypoints to avoid
locking. While this is a sufficient approach to avoid the locked waypoints it comes with a few limitations:
Departure and destination airport are not saved as user-defined waypoints. These have to exist in the Garmin
navigation database.
Navaid information like frequencies cannot be displayed since the waypoint cannot be related to the radio
navaid.
Procedures like SID and STAR cannot be saved with the flight plan and have to be selected manually.
The GTN (not the GNS) changes all names to a generic USERWPT... scheme.
The export of user-defined waypoints can be enabled in the options dialog on tab Flight Plan.
[1] Only SID and STAR. Saving or approaches is not supported.
[2] (1,2) User-defined waypoints will be renamed when loading into the GTN.
[3] (1,2,3) Additional information for online flying can be added in a dialog before saving.
[4] Full name is companyroutes.xml
[5] Procedures might not load in MSFS or might be replaced by other procedures.

37. Flight Plan Multiexport
Multiexport simplifies flight plan export and enables saving to several formats at once with a single
click into the toolbar, a click into the menu (File ->
keyboard shortcut Ctrl+Shift+M.

Multiexport Flight Plan) or using the

The dialog makes use of tooltips. Hover the mouse cursor above rows and buttons for more
information.

Overview of the multiexport features with the related menu items highlighted.

37.1. Quick Setup
The export function is disabled initially until at least one format is enabled for export in File ->
Multiexport Flight Plan Options.
Export paths are pre-filled with sensible values where known. This is done when first opening the
dialog and considers the current simulator selection (Scenery Library Menu). A best guess is used if
not applicable.
Adapt the default paths if needed. You can edit a path by double clicking on it or using the button
which will open a file dialog for selection.
Check the box on the left of a row or use the context menu to enable for a format for export. The
row text will be shown bold if enabled.
Adjust the selection in Export Options and choose if you like to overwrite files or if you would like to
see a file dialog for each saved format.
Click Ok when done.
The flight plan will be exported when using menu File -> Multiexport Flight Plan if a correct path is
entered and the box is checked.
Tip

You can also export flight plans manually from the multiexport options dialog by clicking on the
button

Export Flight Plan now.

Note
Note that Little Navmap does not clean up the exported directories. All old flight plans remain
and have to be removed manually from time to time.
Consider exported flight plan files as disposable since almost all the export formats have
limitations resulting in data loss. Remember that you can always restore them by loading the
original LNMPLN file and exporting again.
See also Flight Plan Formats for more information on the supported flight plan formats.
37.2. File Names
Little Navmap always uses file names based on the pattern set in options on page Flight Plan for
the file formats LNMPLN, PLN (only FSX, P3D and MSFS), FGFP (FlightGear), HTML and GPX.
Other formats have restrictions which require short names. The pattern does not apply for these.
37.3. Exporting Little Navmap native flight plan format
Exporting the Little Navmap native flight plan format with file extension LNMPLN is a special case
compared to the other formats. Enabling this for export saves you a few extra clicks for storing the
file.
The following happens if LNMPLN is saved with multiexport:
The file name is automatically assigned by using the selected pattern in the options dialog
on page Flight Plan. If the file was already saved with another name when doing Save Flight
Plan as LNMPLN or Save Flight Plan then this name is used.
Little Navmap saves the file into the path set in the multiexport options dialog.
The current file is marked as clean. This means that the * is cleared from the window title
and Little Navmap will not ask to save the file once exiting or creating a new plan.
Further saves (menu File -> Save Flight Plan) will use the automatically assigned file name
and path.
Note
Always save a copy in the default LNMPLN format before exporting to other formats. This allows
Little Navmap to restore all flight plan properties like procedures, alternate airports and remarks.
Note that the LNMPLN format is only understood by Little Navmap. Do not try to load it into
simulators or add-ons.
See also Little Navmap LNMPLN Format.
37.4. Path Errors
The path is highlighted red once a format is enabled for export with a non existing directory or file.
Hover the mouse above the path to see more detailed error messages.
Directories (for some export formats files) have to exist for the export to work.

Error message in tooltip for X-Plane FMS export. Hover mouse cursor above red text to see this. Also selected is the MSFS flight plan
export without path errors.

37.5. Running Multiexport
A dialog is shown, if any unsupported features are detected in the current flight plan when trying to
save a plan. You can disable this dialog for future saves if you know what you are doing.
Pressing Cancel in this dialog stops the export. No files will be exported.
Depending on the setting in the Export Options button Little Navmap will also show a file dialog for
each exported file.
You can enable saving of waypoints by checking the menu items Export Waypoints for Approaches,
Export Waypoints for SID and STAR or Export Waypoints for Airways. These three options affects all
flight plan export formats except the native LNMPLN format.
37.6. Multiexport Options Dialog
37.6.1. Export Format Table
You can click on the table headers to sort the content. Tooltips give more information on some
formats and path errors.
Columns can be moved and resized by clicking and dragging the table header. The table layout is
saved and can be reset by choosing Reset View in the context menu of the table.
37.6.1.1. Checkbox

The checkbox on the far left enables the respective format for export and highlights the row in bold
text. Path errors are only shown if the format is enabled.

37.6.1.2.

Select Export Path

Opens a file or directory selection dialog to enter the path. Some export formats need a file to
append flight plan information instead of a directory to save a file.

37.6.1.3.

Export Flight Plan now

Opens a file dialog for immediate export of the current flight plan. You can also export formats
which are not enabled.

37.6.1.4.

Reset Export Path

Resets the path back to default. The default path is determined by the current scenery library or
simulator selection. If not applicable, the best estimate from installed simulators is used.
37.6.1.5. Path Column

Double click or press the key F2 to edit the path directly. You can copy and paste paths from the
Windows Explorer into this field, for example.
37.6.2. Export Options

Three options can be selected in the drop down box. These apply to all export formats.
37.6.2.1. Show file dialog for every exported format

Opens a file or directory selection dialog for each enabled export format once Multiexport Flight
Plan is used. The dialog allows to cancel an export or change the file name or path.
Pressing cancel in this dialog does not stop the export process for further formats.
37.6.2.2. Do not show file dialog. Backup existing files in case of conflict

Present files are backed up to a maximum of four files and the new file is saved in place. Little
Navmap does not check for changed files. You might see backups which are equal if you save too
often.
Example: Saving the plan from ENKB to LICR several times in X-Plane FMS format:
Latest plan: ENKB-LICR.fms
Backups: ENKB-LICR_1.fms, ENKB-LICR_2.fms, ENKB-LICR_3.fms, ENKB-LICR_4.fms
37.6.2.3. Do not show file dialog. Overwrite files without warning

Present files with the same name are overwritten. Be careful with this option, especially when using
the Exporting Little Navmap native flight plan format option.
No backup will be created when saving.
This helps to reduce clutter in the output directories but may overwrite flight plan files.
37.6.3. Help
Opens this chapter in the online help.
37.6.4. Ok
Takes over all changes and closes the dialog.
37.6.5. Cancel
Discards all changes and closes the dialog.
37.7. Context Menu
Right click into the flight plan format table to open the context menu.
37.7.1. Enable Export
Selects format for multiexport. Same as the Select Export Path button.

37.7.2.

Select Export Path

37.7.3.

Export Flight Plan now

Save the format now. Same as the Export Flight Plan now button.

37.7.4.

Reset Export Path

Reset path back to default. Same as the Reset Export Path button.
37.7.5. Edit Path
Allows to edit the path directly. This is the same as double clicking into the path field or pressing F2.
37.7.6. Reset Paths and Selection
Resets all paths back to sensible defaults also considering the current simulator selection. This is
the same as clicking Reset Export Path in each row.

Also disables all flight plan formats for export.

37.7.7.

Reset View

Resets column size and column order back to default.
37.7.8. Increase, Decrease and Default Text Size
Changes the text size in the table. The size is saved.

38. Flight Plan Online Network Export
This dialog appears when exporting a flight plan for the online network clients using the export
menu items IvAp for IVAO, X-IVAP for IVAO, VATSIM vPilot or SWIFT or Multiexport Flight Plan.
Some input fields might hidden depending on format.
Note that IvAp and X-IvAp use a slightly different format.
Fields that contain information which cannot be extracted from the current flight plan are saved
between sessions (e.g. Pilot in command or Equipment).
Other input fields in this dialog are extracted from the current flight plan. These fields can be
adjusted manually and are not saved between sessions. These are:
Flight Rules:

From the current flight plan. IFR or VFR for VFP and I or V for FPL. Change
manually if needed.
Aircraft type: From the current aircraft performance ( Aircraft Performance).
Departure: First waypoint in flight plan.
Destination: Last waypoint in flight plan.
Route: Generated from the flight plan waypoints, airways, SID and STAR (Flight Plan Route
Description).
Cruise altitude: Taken from flight plan. Cruise altitude in ft.
True Airspeed: From the current aircraft performance cruise speed.
Departure time: Uses current UTC time as default. Adjust as needed.
Actual: Actual departure time. Uses same default time as above. Adjust as needed.
En-route: Traveling time as calculated by flight plan and current aircraft performance.
Endurance: Uses same default as above. Adjust as needed.
38.1. Buttons
OK:

Saves relevant fields for the next session and opens the Save as dialog.
Discards all changes and closes dialog.
Reset: Undoes all changes that were made since opening the dialog.
Help: Shows this online help page.
Cancel:

Flight Plan Online Export Dialog for VATSIM vPilot.

39.

Aircraft Performance

Aircraft performance and fuel reports are shown in the dock window Flight Planning.
Little Navmap provides functionality for editing, creating and collecting aircraft performance
profiles. This allows to determine needed fuel, flight time as well as climb and descent paths.
Average performance data like speed, vertical speed and fuel flow is used for the flight phases
taxi/takeoff, climb, cruise and descent to calculate fuel requirements.
The program can either consider NOAA real world wind prediction or the X-Plane winds aloft to
calculate the fuel report. Alternatively, a simple setting for wind at cruise altitude can be used to
adjust the plan for weather.
Related chapters:
Winds Aloft: Information on winds aloft.
Aircraft Performance Collection: Automatic and permanent aircraft performance collection
running in the background.
Aircraft Performance Edit: Change performance manually.
Aircraft Performance Merge: Merge performance data collected from a flight or another file
into the currently loaded.
Aircraft performance and the winds aloft situation is used for the functions below:
Calculation of the flight time which is shown in flight plan header.
Calculation of top of climb and top of descent which are shown on the map and in the
elevation profile. Note that wind and altitude restrictions in procedures might affect the top
of descent or top or climb distances.
Fuel planning report in tab Fuel Report of the dock window Flight Planning.
Remaining fuel at each leg in flight plan table.
Remaining fuel at top of descent and destination in the tab Progress in the Information window
as well as traveling times.
Fuel is shown both as weight (lbs or kg) or as volume (gallons, liter) and can be entered in all
available units independent of the program settings.
Additional display of other fuel units can be enabled in the dialog Options on the tab Units.
See Top of Climb and Top of Descent Paths for details about the calculation of TOC and TOD.
Red warning messages are shown if aircraft performance contains wrong values that keep Little
Navmap from calculating fuel consumption, climb or descent. An orange warning message is shown
if the flown aircraft type does not match the type in the aircraft performance.

Aircraft Performance tab showing an error about a missing value. The * in the tab label shows unsaved changes.

A default profile with 3 NM per 1,000 ft for descent and climb rules and no fuel consumption is
default. Red warning messages will be shown if used since the profile is not complete.
Note
The default performance profile is sufficient to calculate top of climb and top of descent and can
be used if you wish to ignore the fuel and travel time reports.
Little Navmap collects performance data for an aircraft permanently while flying. The collected data
can be merged or copied into the currently used profile or a new one which can be fine tuned
manually. The merging can be done at any time. See Aircraft Performance Collection.

Fuel report tab. Average headwind of 10 knots is based on NOAA winds aloft prediction and is also considered in fuel calculation. Fuel
needed for an alternate airport is shown too. The performance file description contains a web link.

39.1. Files
Performance profile files (file extension LNMPERF) can be saved and loaded like flight plan files. The
performance files can be dragged from a file manager like Windows Explorer or macOS Finder and
dropped into the Little Navmap main window to load them.
Warning
Do not save the files into the Little Navmap directory since it might be deleted when doing an
update. Neither save them in C:\Program Files or one of its sub-directories. Save the files into your
Documents directory or a sub-directory in there like Documents\Little Navmap\Performance.
You can use the folder which is suggested by the Directories dialog.

Tip
Aircraft performance files from contributors and my own flights are available in the download
section of littlenavmap.org [https://www.littlenavmap.org/downloads/Aircraft%20Performance/].
39.2. Wind
You can enter the estimated average wind speed and wind direction at cruise altitude or download
NOAA wind predictions or use the X-Plane wind file. This will be considered when calculating flight
time and fuel consumption for each leg and the whole flight plan.
Wind will also affect the top of descent and top of climb. For example, the top of climb will be a
shorter distance for a strong headwind. Time to reach the top of climb is the same.
The fuel report is updated immediately when changing wind speed, wind direction, wind source or
when editing the flight plan.
The wind speed is interpolated from ground to cruise altitude for the climb and descent phases
when using manual wind.
See the chapter Winds Aloft for more information on winds aloft.
39.3. Tab Fuel Report
39.3.1. Buttons
The buttons on top have the same functionality as the items in the main menu Aircraft Menu.
Manual Wind:

This checkbox overrides the wind source and allows to set the average wind
direction and speed manually. Two input fields for speed and direction are shown if this is
checked.
Edit Aircraft Performance: Opens the edit dialog for the currently loaded profile. You can
also use the menu item Aircraft -> Edit Aircraft Performance ... to change the currently
loaded performance data. See Aircraft Performance Edit for a description of the edit dialog.
New Aircraft Performance: Creates a new performance profile with default values and
opens the edit dialog. A profile with 3 NM per 1,000 ft for descent and climb rules and no
fuel consumption is default. Red warning messages will be shown since the profile is not
complete.
Open Aircraft Performance:

Load a LNMPERF file.

Save Aircraft Performance:

Save current profile to a LNMPERF file.

Save Aircraft Performance as:

Save current profile to a new LNMPERF file.

Help: Click to open this chapter of the manual in the default browser.
39.3.2. Report
Note
The tab Fuel Report in the dock window Flight Planning is meant for fuel planning and does not
change during flight.
Although, the fuel planning report updates automatically if the flight plan, cruise altitude or wind
situation change.
A flight plan has to be loaded to see the full fuel planning report. Otherwise it displays only basic
information like estimated range and other information about the aircraft.
See Aircraft Performance Edit for a detailed description of all fuel numbers.
The text size of the report can be changed in dialog Options on User Interface.
39.3.2.1. Aircraft Section

Fuel Type:

As set in the performance profile. Either Avgas or Jetfuel. Used to change values
when switching between volume and weight as fuel unit and to convert between units in the
report.
Usable Fuel: Shown as set in the performance profile. Only displayed if bigger than zero. A
red warning message is shown if block fuel exceeds this value.
Estimated range with reserve: Calculated based on usable fuel, speed and fuel flow for the
cruise phase and reserve fuel. Shows an orange warning if fuel flow values are not set.
Reserve Fuel and Taxi Fuel: Only shown with empty flight plan.
Minimum runway: Shown if set in the performance profile.
39.3.2.2. Flight Plan Section

Only shown with a valid flight plan.
Distance and Time:

Total flight plan distance and traveling time including procedures. Same
values as on top of the tab Flight Plan. Affected by the wind situation.
Average Ground Speed: Ground speed across all the flight phases climb, cruise and descent.
Calculated based on speeds as given and wind as entered on top the tab or selected wind
source.
True Airspeed at Cruise: Cruise speed as given in the edit dialog.
Mach at cruise: Mach number at flight plan cruise altitude calculated based on given true
airspeed and ISA atmospheric standard conditions. Only mach numbers above 0.4 are
shown.
Average wind: Shows the average wind speed and direction for all three flight phases climb,
cruise and descent. Only shown if sufficient wind is present. Also shows average head- or
tailwind if present. The wind source (NOAA, Simulator, Manual or Disabled) is shown in brackets.
39.3.2.3. Fuel Plan Section

Only shown with a valid flight plan.
Trip Fuel:

Fuel that is consumed while flying and covers all phases from takeoff at departure
to touchdown at the destination. Does not include contingency, extra, reserve or alternate
fuel.
Block Fuel: Fuel to be loaded. Block fuel is the total fuel required for the flight. Includes trip,
reserve, extra, taxi, farthest alternate airport and contingency fuel.
Fuel at Destination: Expected fuel at destination. Will be equal to reserve if no contingency
fuel, no extra fuel and no alternate airports are set.
Alternate Fuel: Fuel needed to travel from the destination to the farthest alternate airport.
Reserve Fuel: Reserve fuel as set in the edit dialog.
Taxi Fuel: Taxi fuel as set in the edit dialog.
Extra Fuel: Extra fuel as set in the edit dialog.
Contingency Fuel: Contingency fuel calculated from the percentage given in the edit dialog and
trip fuel.

39.3.2.4. Climb and Descent Section

Only shown with a valid flight plan.
Climb:

Speed and vertical speed as given plus the calculated flight path angle. The flight path
angle is affected by the wind forecast.
Time to Climb: Calculated time to climb for the given cruise altitude.
Descent: Speed and vertical speed in descent phase as given plus the calculated flight path
angle. The flight path angle is affected by wind.
Descent Rule of Thumb: Calculated rule of thumb for descent.
Note
Altitude restrictions in procedures might affect the top of descent or top or climb distances. The
flight path angle is only valid where the aircraft can freely climb or descent unaffected by altitude
limits.
39.3.2.5. Performance File Remarks Section

This is a free plain text field for notes and links.
Links are recognized and can be opened in the report.
See Remarks for more information about using web links in this field.
39.3.2.6. Performance File Section

Contains a link to the aircraft performance file. Opens the file or directory in the default file
manager like Windows Explorer or macOS Finder.

40.

Aircraft Performance Edit

The dialog allows editing of all aircraft performance related parameters on three tabs. The labels
for all values required for fuel calculation are highlighted bold.
The dialog is opened when clicking on the edit button in the tab Fuel Report, when selecting Aircraft
-> New Aircraft Performance ... or Edit Aircraft Performance ... in the main menu.
40.1. Buttons
OK:

Takes all changes made in the dialog but does not save the profile. The fuel report, top of
climb and top of descent in the Elevation Profile are adjusted immediately.
Cancel: Disregards all changes and closes the dialog.
Reset: Resets all changes made since opening the edit dialog.
Restore Defaults: Resets back to the default profile.
Help: Opens the online help in the default web browser.
40.2. Tab Aircraft
Aircraft model:

Can be used freely. Determined from aircraft name when Little Navmap
collects data for a performance profile.
Aircraft type: The ICAO aircraft type designator. Little Navmap will show a warning in the tab
Fuel Report if the flown aircraft does not match the type. Detected automatically when
collecting performance.
Required runway: Only for information. Shown in the fuel report if bigger than zero.
Required runway type: Only for information. Shown in the fuel report if it differs from default
Hard.
40.2.1. Aircraft Type
See ICAO - Aircraft Type Designators [https://www.icao.int/publications/DOC8643/Pages/Search.aspx] or Wikipedia List of ICAO aircraft type designators [https://en.wikipedia.org/wiki/List_of_ICAO_aircraft_type_designators].
40.2.1.1. X-Plane

Its value can be read with X-Plane Plane Maker program, opening the related aircraft file .acf, then
main menu -> Standard -> Author, field ICAO code for ATC. It is stored as e.g. P acf/_ICAO BE58 in the .acf
file.
40.2.1.2. FSX, FSX-SE and Prepar3D

The model can be found with any text editor, opening the related aircraft.cfg file, key ATC_model
under the section [General].

First tab in aircraft performance edit dialog.

40.3. Tab Performance
All speeds are entered in true airspeed. This makes the values independent of wind influence which
would be the case of ground speed. It also makes the values independent of cruise altitude and
deviation from ISA atmospheric conditions which would be the case when using the Mach number
or indicated airspeed.
40.3.1. Fuel
Fuel Units:

Either Volume (gallons or liters) or Weight (lbs or kilograms). The numbers in the
dialog will be converted using the weight of the selected Fuel Type when changing the unit.
Rounding errors might occur when switching forth and back noticeable a small changes.
Fuel Type: Avgas (default) or Jetfuel. Needed to convert fuel numbers between weight and
volume. This is detected automatically when collecting aircraft performance.
See Fuel - Flight Planning Definitions [https://www.skybrary.aero/index.php/Fuel_-_Flight_Planning_Definitions]
(SKYbrary) for more information on the various fuel types.
40.3.2. Usable Fuel
Used to calculate estimated range and to check if block fuel exceeds fuel capacity of aircraft.
A label Estimated range with reserve shows the maximum distance and time to fly with reserves.
40.3.3. Reserve Fuel
Final reserve fuel is the minimum fuel required to fly for 30 minutes at 1,500 ft above the alternate
airport or at the destination airport at holding speed if an alternate is not required. Some
authorities require sufficient fuel for 45 minutes holding time.
Alternate fuel is the amount of fuel required to fly the missed approach at the destination airport
and to the alternate airport.
Reserve fuel

is the sum of alternate fuel and final reserve fuel.

You have to set this value to avoid running out of fuel at the destination when relying on this
profile.
40.3.4. Taxi Fuel
Taxi fuel

is the fuel used prior to takeoff and includes APU consumption, engine start and taxi fuel.

40.3.5. Extra Fuel
Fuel that is added at the discretion of the captain or the dispatcher.
40.3.6. Contingency Fuel
Contingency fuel is carried to account for additional en-route fuel consumption caused by wind,
routing changes or traffic management restrictions.
The value is given in percent of trip fuel.
Tip
ICAO recommends to use 5 percent contingency fuel for all flights.
40.3.7. Climb
Values for climb are detected automatically when collecting performance.
Average climb speed:

Average true airspeed from takeoff to cruise altitude.
Vertical speed in climb phase. Either ft per minute (fpm) or meter

Average vertical climb speed:

per second (m/s).
Average fuel flow in climb:

Fuel flow in climb phase. Either gal, lbs, l or kg.

Climb speed and vertical climb speed are used to calculate the top of climb which also varies with
wind conditions.
40.3.8. Cruise
Values for the cruise phase are detected automatically when collecting performance.
Cruise speed at typical cruise altitude:
Fuel flow in cruise:

True airspeed at cruise.
Fuel flow in cruise phase.

40.3.9. Descent
Descent values are detected automatically when collecting performance.
Average descent speed:

True airspeed in descent phase.
Average vertical speed.
Average fuel flow for descent: Average fuel flow on descent.
Average vertical descent speed:

A label Descent Rule of Thumb shows the calculated rule of thumb for descent. The default is 3 NM per
1,000 ft.
Descent speed and vertical descent speed are used to calculate the top of descent which also varies
with wind conditions.
40.3.10. Alternate
Average speed for alternate:

True airspeed when flying to alternate.
Average fuel flow when flying to alternate.

Average fuel flow for alternate:

Little Navmap uses the values from the cruise phase as a default. The flight to the alternate airport
usually happens at a lower altitude than cruise altitude and therefore results in a higher fuel flow.
Adjust the values accordingly here.

Aircraft performance edit dialog tab Performance.

40.4. Tab Remarks
This tab contains a free plain text field for notes and links which is also shown in the Fuel Report tab
of the window Flight Planning.
See Remarks for more information about using web links in this field.

41. Aircraft Performance Collection
The performance data collection can be used to create a basic performance profile which can be
fine tuned manually. Little Navmap permanently collects fuel flow and speed data and calculates
average values for all flight phases.
Wind does not affect the calculation since all speeds are based on true airspeed.
The collection begins automatically once Little Navmap is started and connected to a simulator. You
can reset the collection manually to get a clean base.
A report of current average fuel and speed numbers is shown on the tab Current Performance in the
window. You can copy or merge intermediate results at any time into your currently loaded
performance profile.
Little Navmap will show 3 NM per 1,000 ft climb and descent slopes when collecting data based on
an default or new elevation profile. You have to estimate the needed top of descent yourself.
Note
The flight plan cruise altitude is used to detect the cruise phase of the aircraft. Set the cruise
altitude in the flight plan tab at least to the intended cruise altitude if you do not plan use a flight
plan.
41.1. Quick How To
Follow the steps below to collect performance for an aircraft.
1.
2.
3.
4.
5.
6.
7.
8.
9.

Connect Little Navmap to the simulator.
Fuel up your aircraft at best guess for the trip.
Use a typical load for the aircraft.
Create and use a flight plan for the trip. Use a typical distance and cruise altitude for this
aircraft. A short hop does not suffice.
Place your aircraft on the parking spot at departure with engines shut down or running.
Start and fly as precise as possible regarding speeds and performance settings of the
aircraft.
The collection is completed once the field Current flight segment: in the report shows Finished..
Select Aircraft -> Merge collected Aircraft Performance in the main menu and copy all values in
the dialog. See Aircraft Performance Merge for more information on merging.
Edit the aircraft performance data ( Aircraft Performance Edit) and adjust the numbers to
your liking or flying habits.

Warning
Do not forget to add at least sufficient reserve fuel. Otherwise you will run out of fuel at
destination if you rely on this plan.
Other recommended fields to edit are Usable Fuel, Required Runway and Required Runway Type.
You can move your airplane at cruise altitude, use warp tools to get quickly near top of descent or
adjust fuel and time manually. This will not affect performance calculation since Little Navmap
reads the actual fuel flow from the simulator instead of using consumed fuel and time.
In any case stay a few minutes at cruise altitude so that Little Navmap can get numbers for this
phase of flight.
Tip
You can create different performance profiles for different cruise altitude ranges to cover fuel
flow variations.

Report shown when collecting aircraft performance. All phases are already finished.

41.2. Tab Current Performance
41.2.1. Buttons

Restart Aircraft Performance Collection: Resets all collected fuel and speed parameters
back to zero. Nevertheless performance collection will continue immediately even while in
cruise, for example.
Merge collected Aircraft Performance: Opens a dialog allowing to merge the collected
performance parameters into the currently loaded performance file. This can be used in all
flight phases. See Aircraft Performance Merge for more information on merging.

Help: Click to open this chapter of the manual in the default browser.
41.2.2. Report
The text size of the report can be changed in dialog Options on User Interface.
41.2.2.1. Aircraft Section

Current flight segment:
Aircraft status:

Shows which flight phases (Climb, Cruise and more) are detected.
More information about aircraft status like fuel flow or on ground status.

41.2.2.2. Fuel Section

Fuel Type:

Fuel type as reported by simulator. This is calculated based on the volume/weight
ratio. Correct this manually if add-on aircraft do not provide a correct fuel type.
Total Fuel Consumed: Fuel consumed so far since the restart of Little Navmap or the last reset
of the collection function.
Taxi Fuel: Fuel used from first detected fuel flow to lift off.
41.2.2.3. Average Performance Section - Climb, Cruise and Descent

Average values for the different flight phases. Sections for not yet started phases are omitted.
Passed sections like e.g. climb will show zero values if you restart the collection mid flight in e.g.
cruise.
True Airspeed:

True airspeed average.
Average climb or descent speed. Not shown for cruise phase.
Fuel Flow: Fuel flow average.
Vertical Speed:

42.

Aircraft Performance Merge

The currently loaded performance profile can be merged with the collected performance or another
performance file using this dialog.
The dialog is opened when clicking on the merge button in the tab Current Performance, when
selecting Aircraft -> Merge collected Aircraft Performance ... or Open Aircraft Performance and Merge ... in
the main menu.
A warning message is shown if the fuel type does not match.
42.1. Operations
The left side of the dialog shows either collected performance values from a flight or the values of a
profile loaded using the Open Aircraft Performance and Merge ... function.
The right side always shows the values of the current performance profile.
Some values are only shown when merging from a file. Values not provided by the performance
collection like alternate fuel are hidden when merging collected data.
An operation can be selected for each value pair:
Copy:

Simply copies the value from the left side to the currently loaded performance profile
on the right.
Ignore: Does not change the right value.
Merge: Calculates the average of the left and right values and assigns the result to the right.
Not applicable for aircraft type and model.
42.2. Buttons
OK:

Applies the selected operations to the current profile.
Disregards all changes and closes the dialog.
Help: Opens the online help in the default web browser.
Set all operations to:: Copy, Ignore and Merge: Changes the operations for all values.
Cancel:

Merge Aircraft Performance dialog for collected performance values.

43.

Load Scenery Library

This dialog allows loading of the scenery library data from all supported flight simulators into the
Little Navmap internal database. The scenery library to load can be selected in the Simulator: drop
down box.
The dialog shows information about the currently selected database including the number of loaded
airports, database version and more.
FSX and Prepar3D: The base path and the scenery.cfg path will be shown in two text edit fields for
the currently selected simulator. These fields are populated automatically, but can be changed to
any other valid location. All values are saved individually for each flight simulator type.
Microsoft Flight Simulator 2020: The base path of the MSFS installation and its directories
Community and Official is detected automatically. You can change the path manually if needed.
X-Plane: The base path of the first X-Plane installation is added. Select the base path manually if
you like to read the scenery library of another X-Plane installation. On Windows that can be a path
like C:\Simulators\X-Plane 11, the executable being C:\Simulators\X-Plane 11\X-Plane.exe.
Loading a scenery library can take from 2 to 10 minutes depending on your setup and amount of
scenery add-ons. You can speed this up by excluding directories containing neither airport nor
navigation data in the Options dialog on the Scenery Library Database tab.
For FSX and Prepar3D, all airports that are not located in the default Scenery directory of FSX/P3D
are considered to be add-on airports.
For X-Plane, all airports located in the Custom Scenery directory of X-Plane are considered to be addon airports. An exception is ...\X-Plane 11\Custom Scenery\Global Airports\Earth nav data\apt.dat
Microsoft Flight Simulator 2020: All airports located in the Community directory and the
Official\OneStore or Official\Steam are considered to be add-on airports. Exceptions are fs-base and
fs-base-nav.
Add-on airports are highlighted on the map with a yellow ring which can be disabled in the options
dialog on page Map Display.
Using emphasized (bold and underlined) text highlights add-on airports in the search result table,
flight plan table, information windows and map tooltips.
If an add-on only corrects airport elevations or navigation data, it might be undesirable to display
the updated airports as add-on airports on the map. You can exclude directories populated by this
add-on from the add-on recognition in the Options dialog on the page Scenery Library Database.
If you cancel the loading process or if the loading process fails, the previous scenery library
database is restored immediately.
The menu Scenery Library -> Flight Simulators is synchronized with the simulator selection in the
dialog. Once a database is successfully loaded, the display, flight plan and search switch
instantaneously to the newly loaded simulator data.
Note
The final number of airports, navaids and other objects shown in the Load Scenery Library dialog
are lower than the counts shown in the progress dialog. After the data has been loaded, a
separate process removes duplicates and deletes stock airports that were replaced by add-ons.
FSX or P3D only: The program tries to find the base paths and Scenery.cfg files automatically. The
typical locations of the Scenery.cfg for Windows 7/8/10 are:
Flight Simulator X: C:\ProgramData\Microsoft\FSX\Scenery.cfg
Flight Simulator - Steam Edition: C:\ProgramData\Microsoft\FSX-SE\Scenery.cfg
Prepar3D v2: C:\Users\YOUR_ACCOUNT_NAME\AppData\Roaming\Lockheed Martin\Prepar3D v2\Scenery.cfg

Prepar3D v3: C:\ProgramData\Lockheed Martin\Prepar3D v3\Scenery.cfg
Prepar3D v4: C:\ProgramData\Lockheed Martin\Prepar3D v4\Scenery.cfg
Prepar3D v5: C:\ProgramData\Lockheed Martin\Prepar3D v5\Scenery.cfg
An error dialog is shown after loading, if any files could not be read or directories were not found.
In this case you should check if the airports of the affected sceneries display correctly and show the
correct information. The error dialog allows copy and paste of formatted text which is useful for
error reporting.
The Load Scenery Library dialog shows the last time of loading (Last Update:), the program and the
database version. Major database version differences indicate incompatible databases. The
program will ask if the incompatible databases can be erased on startup before the scenery
database can be reloaded. Minor database differences indicate compatible changes where a reload
is recommended but not required.
Warning
Close Little Navmap when updating, copying or replacing its databases manually or using other
programs. Little Navmap might crash or show wrong data otherwise.
43.1. Microsoft Flight Simulator 2020 Airports and Navdata
If you use the Navigraph update for MSFS: Update the Little Navmap database with the
FMS Data Manager as well to keep the program in sync with the MSFS scenery library. Use
the scenery mode Use Navigraph for Navaids and Procedures in the menu Scenery Library to get
access to all procedures in Little Navmap. This is the default.
Also check the selection in menu Scenery Library -> Airspace Libraries. Select Navigraph and
uncheck Simulator there.
If you do not use the Navigraph update for MSFS: Use the scenery mode Do not use
Navigraph Database in the menu Scenery Library to avoid issues with missing or changed
navaids.
The selection in menu Scenery Library -> Airspace Libraries should have Simulator checked.
Uncheck Navigraph there.
See Navigation Databases and FSX, Prepar3D and MSFS Airspaces for more background
information on these settings.
See appendix Microsoft Flight Simulator 2020 for information about MSFS limitations and issues.
43.2. X-Plane Airports and Navdata
Little Navmap reads airport and navaid data from X-Plane’s *.dat files. To check a version of a file
you can open it in a text editor that is capable of dealing with large files. The first lines of the file
will look like:
A
1100 Generated by WorldEditor 1.6.0r1
1
1549 0 0 0A4 Johnson City STOLport
...

Little Navmap can read the following X-Plane scenery files:
Airports ( apt.dat ): From version 850. This covers X-Plane 10 airports and older add-on
scenery.
Navdata ( earth_awy.dat , earth_fix.dat and earth_nav.dat ): From version 1100. This excludes
X-Plane 10 navdata files.
Procedures ( ICAO.dat in the CIFP directory): All procedures from X-Plane 11.
Airspaces ( *.txt ): The included usa.txt and all files in OpenAir format. See next chapter
for more information.
Additionally the files user_fix.dat and user_nav.dat in the X-Plane directory Custom Data are read.
43.2.1. FSX, Prepar3D and MSFS Airspaces

Little Navmap reads all airspaces from the scenery library of FSX, P3D and MSFS. These airspaces
are added in the airspace source Simulator.
43.2.2. OpenAir Airspaces
Little Navmap can read OpenAir airspaces (OpenAir airspace format
[http://www.winpilot.com/UsersGuide/UserAirspace.asp]) from X-Plane or an user defined directory.
Note that the publicly available airspace files can contain errors which may prevent the loading of
an airspace file. These hard errors are reported after loading the scenery library. Other errors only
affecting single airspaces or the geometry are reported in the log file only.
Additional airspace files can be downloaded from the OpenAirspace Directory
[http://www.winpilot.com/openair/index.asp], Soaring Services [http://soaringweb.org/], openAIP [https://www.openaip.net/]
or Luftraumdaten Deutschland [https://www.daec.de/fachbereiche/luftraum-flugbetrieb/luftraumdaten], for example.
Airspace files must have a .txt extension and are loaded from the following directories by Little
Navmap:
The files can be encoded in any UTF [https://en.wikipedia.org/wiki/Unicode#UTF] format but must have a BOM
[https://en.wikipedia.org/wiki/Byte_order_mark] to be recognized properly. Otherwise Windows ANSI coding
(Windows-1252) is used. Special characters like umlauts or accents are not displayed correctly in
names if the encoding is not correct. All other functionality is unaffected.
You can convert the files using any advanced editor like Notepad++ [https://notepad-plus-plus.org/] for
example.
Airspaces will appear as duplicates in the map if an airspace file is found in more than one of these
directories or sources.
See Airspace Libraries for more information on airspace sources.
43.2.2.1. X-Plane Airspaces

X-Plane 11 comes with a single airspace file that can be found in
YOUR_XPLANE_DIRECTORY/Resources/default data/airspaces/usa.txt.
Little Navmap reads X-Plane airspaces from the following locations:
YOUR_XPLANE_DIRECTORY/Resources/default data/airspaces
YOUR_XPLANE_DIRECTORY/Custom Data/Airspaces

These airspaces are added to airspace source Simulator.
43.2.2.2. User Airspaces

These airspaces are added in the airspace source User. You can load them by selecting Scenery
Library -> Load User Airspaces ( Load User Airspaces).
A directory selection dialog will show up when running this function the first time. Select a directory
containing OpenAir airspace files with file ending .txt. All files in the directory will be read
recursively.
Airspaces read with this function will be added to the airspace source User and are stored in a
database independent of flight simulator databases.
You can change the directory and file extensions to read in the options dialog: User Airspaces.
43.2.2.3. Online Airspaces

Online centers are displayed as circular airspaces in Little Navmap per default and provide the
same functionality as the other airspaces (tooltips, information and more). They are loaded with
the online data when connected and are only stored in a temporary database which is deleted on
exit.
Little Navmap can use real center boundaries instead of the circular airspaces. First you have to
enable one or both options in Map Display Online under Online Center Boundary Lookup in User
Airspaces. These are enabled per default.
There are two options:

1. Create an OpenAir airspace file which contains a single boundary for a center. Give the file
the same name as the callsign for the center, i.e. name the file EDDB_TWR.txt for the center
with the callsign EDDB_TWR.
2. Create an OpenAir airspace containing the boundaries for all the centers you need. Give the
file any name but name the boundaries according to the callsign of the centers. You need a
line in the file containing AN EDDF_TWR (AN = airspace name) to use the boundary for a center
with the callsign EDDB_TWR.
Now place the file or files into you user airspace directory and reload the user airspaces. See above
User Airspaces how to do this.
Once done the center should show the correct boundary.
43.3. Load Scenery Library Options
Simulator:

Select the simulator to load, show database statistics in the label above.
Reset all paths back to default values.
Flight Simulator Base Path and Select ...: The path to the base directory of the selected flight
simulator. This usually the directory containing the FSX.exe or Prepar3D.exe. This is the base for
all relative paths found in the scenery.cfg file.
Scenery Configuration File and Select ... (only FSX and P3D): The file scenery.cfg of the
simulator. You can also create copies of the original file, modify them by removing or adding
sceneries and select them here for loading.
Read inactive Scenery Entries: This will read all scenery entries, also the inactive/disabled
ones. This is helpful if you use a tool to disable scenery before flying but still want to see all
add-on sceneries in Little Navmap without reloading. This applies to the FSX/P3D scenery.cfg
as well as X-Plane’s scenery_packs.ini which both allow to disable scenery entries.
Read Prepar3D add-on.xml packages (only P3D v3, v4 and v5): If enabled, reads P3D add-on.xml
packages. These are read from sub directories of C:\Users\YOURUSERNAME\Documents\Prepar3D v4
Files\Add-ons and C:\Users\YOURUSERNAME\Documents\Prepar3D v4 Add-ons.
Load: Starts the database loading process. You can stop the loading process at any time and
the previous database is restored. The dialog is closed and the program will switch to show
the loaded database once it is successfully loaded.
Close: Keep all settings and changes in the dialog and close it without loading anything.
Reset Paths:

Note
Note regarding Read inactive Scenery Entries and X-Plane: You either have to enable this option or
start X-Plane after adding an airport. X-Plane will update the scenery_packs.ini when starting.
Otherwise your new scenery will not appear in Little Navmap.

Load Scenery Dialog. Scenery data is already loaded for FSX.

Progress dialog shown while loading the scenery library into Little Navmap’s internal database.

43.4. Magnetic Declination
Little Navmap reads the magnetic declination [https://en.wikipedia.org/wiki/Magnetic_declination] from different
sources or calculates it using the world magnetic model (WMM
[https://en.wikipedia.org/wiki/World_Magnetic_Model]) depending on simulator and navaid.
The data is updated when loading the scenery library and is also stored in the scenery library
database for each simulator.
See chapter Magnetic Declination for information how this impacts flight plans.
43.4.1. FSX, Prepar3D and Microsoft Flight Simulator 2020
The magnetic declination (or variation) used to calculate the magnetic course is taken from the
magdec.bgl file in the scenery database of FSX or Prepar3D.
Updates for this file are available here: FSX/P3D Navaids update [http://www.aero.sors.fr/navaids3.html].
Little Navmap falls back to the world magnetic model if the file magdec.bgl is not available for some
reason.
43.4.2. X-Plane
The magnetic declination values for X-Plane (airports and all navaids except VORs) are calculated
using the world magnetic model based on the real current year and month. This is calculated while
loading the scenery library and saved in X-Plane scenery library database.
VOR stations come with their own declination values which might differ from the calculated
declination values in their environment as mentioned above.

44. Navigation Databases
Little Navmap can use up to two databases in parallel:
1. Simulator database: Created by reading the scenery library of FSX, Prepar3D, Microsoft
Flight Simulator 2020 or X-Plane.
2. Navigation database: Provided by Navigraph. Does not have to be compiled and can be
updated by the Navigraph FMS Data Manager.
Little Navmap is bundled with a navigation database courtesy of Navigraph [https://www.navigraph.com]
which is enabled per default.
Tip
You can update the navdatabase of Little Navmap with the Navigraph FMS Data Manager.
See Install Navigraph Updates [https://albar965.github.io/littlenavmap_navigraph.html] on my home page for
more information if the update fails.

Note
It is recommended to keep all scenery libraries in sync. This means that your simulator, Little
Navmap, aircraft and tools should use the same AIRAC cycle. Having navdata synchronized helps
to avoid issues when loading flight plans.

Warning
Always close Little Navmap before updating its databases.
Three display modes can be selected from the menu Scenery Library as shown below.
44.1. Use Navigraph for all Features
Uses only information from the Navigraph database.
Note
Note that airport information is limited in this mode. This means that aprons, taxiways, parking
positions, runway surface information and fuel information are not available. Additionally, smaller
airports might be missing.
Runway layout might not match the runway layout in the simulator if you use stock or older airport
scenery.
An advantage of this mode is that approach procedures always match the airport runway layout
precisely.

Airport diagram for EDDN from simulator scenery (X-Plane) as shown in the modes Do not use Navigraph Database or Use Navigraph for
Navaids and Procedures.

Airport EDDN from the Navigraph database while Use Navigraph for all Features is enabled. Note missing runway surface information,
aprons, taxiways and parking positions.

44.2. Use Navigraph for Navaids and Procedures
This is the default and strongly recommended mode.
This mode blends navaids and other features from the Navigraph database with the simulator
database. This affects the map display, all information windows and all search windows.
The following features are taken from the simulator database when using this mode:
Airports (also Search dock window, tab Airport)
Aprons
Taxiways
Parking positions
COM frequencies
ILS
The following features are taken from the Navigraph database:
Navaids (waypoints/intersections, VOR, NDB, marker) which affects:
Search dock window, tab Navaid
Flight plan calculation
Route Description
Procedures (approaches, SIDs and STARs). This affects:
Search dock window, tab Procedures
Loading and display of procedures from flight plans.
Airways
Airspaces
44.2.1. Limitations in this mode
Little Navmap ignores any mismatches between procedures and runways due to airport
updates and will not display a warning. Update an airport using payware or freeware scenery
if you find that an approach or departure procedure does not start at a runway end of an
airport.
Procedures cannot be recognized when selecting Show Procedures in the menu if an airport has
changed its ICAO ident (e.g. Kulik Lake: ident changed from LKK to PAKL). If you suspect such
a case use the mode Use Navigraph for all Features to get the procedures for the airport.
The airport search only considers procedures available in the simulator. Switch to Use
Navigraph for all Features to look for airports that have procedures from the Navigraph
database.
ILS placement or presence might not match approach procedures if an airport has a new ILS
which is not present in stock scenery or an old scenery add-on. If you encounter an ILS
approach without ILS station, switch to Use Navigraph for all Features to overcome this
limitation.
Tip

Use the Navigraph navdata update for Microsoft Flight Simulator 2020 to update the scenery
library to the latest and also to keep Little Navmap and MSFS navdata synchronized. This will
reduce issues when loading flight plans into the simulator.
Using the fsAerodata navdata for FSX or P3D update will remove many of the limitations above
since it will synchronize the simulator scenery with the Navigraph database.

An extreme example for runway/procedure mismatch. The approach from the Navigraph database cycle 1707 ends at the not visible
runway 09 while the outdated scenery from FSX shows the airport at the wrong position. EDVK was rebuild north of Calden in 2013. The
OpenStreetMap backgound shows the new airport.

44.3. Do not use Navigraph Database
Completely ignores the Navigraph database and shows only information read from the simulator
scenery.
Note
This mode will read all navdata from the simulator scenery files. Depending on simulator there
are limitations which result in limited features.
This is missing one-way airways, no airway maximum altitude restrictions, some radio navaid
types missing and more for FSX, P3D and MSFS simulators. You might also experience errors in
the airway system and broken procedures.

45.

Connecting to a Flight Simulator

The setup procedure is different for local connections and remote (networked) connections to a
flight simulator (Remote Connection).
Little Navmap can connect directly to a flight simulator running on the same computer. The Little
Navconnect agent is needed if Little Navmap is used on a remote computer.
The Little Xpconnect plugin has to be installed in X-Plane to allow both Little Navmap and Little
Navconnect to connect to X-Plane.
45.1. Local Connection
45.1.1. All Simulators
Open the connection dialog in Little Navmap by selecting Tools -> Flight Simulator Connection in
the main menu and choose the simulator to which the connection should be established.

Little Navmap connect dialog set up for a local connection to FSX, P3D or MSFS on the left and X-Plane on the right. The connection will be
established automatically.

Click on the tab corresponding to the simulator you want to connect to.
Now click the Connect button. The dialog will close and Little Navmap will try to establish a
connection in the background to the simulator noted in the tab header.
Clicking Close keeps all changes and closes the dialog without establishing a connection.
Enable Connect automatically if you do not want to connect manually. The start order of programs
does not matter if this is checked. Little Navmap will find the simulator once it is started or when it
is already running. This is the recommended setting.
Deselect Fetch AI or multiplayer aircraft or Fetch AI or multiplayer ships to disable the transfer of this
information to the program. This can be useful for performance reasons if you use large amounts of
AI but do not want to see it in Little Navmap.
This option also affects the frigate and carrier in X-Plane.
45.1.2. X-Plane
You have to install the included Little Xpconnect plugin to use Little Navmap as a moving map with
X-Plane.
The plugin is bundled with Little Navmap but can also be downloaded separately.

Copy the whole plugin directory Little Xpconnect into the directory plugins in the directory Resources in
the X-Plane installation. The complete path should look like .../X-Plane 11/Resources/plugins/Little
Xpconnect

The plugin is installed and working correctly if you can see it in the X-Plane plugin manager. Note
that the plugin does not add any items to the X-Plane menu.
Select the X-Plane tab to connect.
45.2. Remote Connection
User aircraft and weather information is transferred to Little Navmap on a remote computer by
using the Little Navconnect agent on the flying computer.
Note
Airport weather information and winds aloft cannot be transferred across a remote connection
from X-Plane. You can only see the current weather around the user aircraft.
See Network Setup on information how to set up a remote/networked connection.
45.2.1. Start Little Navconnect on the Flying Computer
Little Navconnect is bundled together with the Little Navmap download archive. Start Little
Navconnect (littlenavconnect.exe in Windows) on the computer running the simulator and take note
of the message that is printed in the logging window. You only need the colored values which tell
you the name and address of the computer running the simulator. You can use the IP address or
the host name.
Little Navconnect can print multiple IP addresses or host names depending on your network
configuration. This can happen if you have Ethernet plugged in and are connected using wireless
LAN too, for example. You have to try if you are unsure which one to use. Also make sure to set up
the Windows firewall properly to allow communication between littlenavmap.exe and
littlenavconnect.exe on both computers.

Little Navconnect is running and waiting for a Flight Simulator. It is running on the computer win10.fritz.box with the IP address
192.168.2.13.

Change the port in Little Navconnect’s Options dialog if you see an error message like shown below:
[2016-07-27 16:45:35] Unable to start the server: The bound address is already in use.

45.2.2. Start Little Navmap on the Client / Remote Computer
Open the connection dialog in Little Navmap by selecting Tools -> Flight Simulator Connection in the
main menu.

Connect dialog with correct values to access the computer running the simulator and Little Navconnect as shown above.

Now do the following after opening the dialog:
1. Click the Remote / Network tab.
2. Add the value for host name. This can be either the host name or the IP address printed by
Little Navconnect.
3. Check the value for the port. 51968 is the default value and usually does not need to be
changed.
4. Click connect. The dialog will close and Little Navmap will try to establish a connection in the
background.
Establishing a connection can take some time, depending on your network. The aircraft will show
up on the map and on the Simulator Aircraft dock window once a flight is set up and loaded on the
simulator. If no flight is loaded yet (i.e. the simulator still shows the opening screen), you will see
the message Connected. Waiting for update. in the Simulator Aircraft dock window.
Note that it can take a while until an error is shown if you used the wrong values for host name or
port.
Selecting Connect automatically is recommended. The start order of all three programs (simulator,
Little Navconnect and Little Navmap) does not matter if this is checked and the programs will find
each other.
Deselect Fetch AI or multiplayer aircraft or Fetch AI or multiplayer ships in Tools -> Options of Little
Navconnect to disable the transfer of this information across the network. This can be useful for
performance reasons if you use large amounts of AI but do not want to see it in Little Navmap.
45.3. Connect Dialog Options
Disconnect:

Disconnect the current session and stop automatic reconnect.
Try to connect. An error dialog will be shown if no connection can be established.
Little Navmap will constantly try again if Connect automatically is enabled.
Close: Close the dialog without any changes to the current connection status.
Connect automatically: Little Navmap will try to connect constantly if this is enabled. This is the
recommended setting.
All connection attempts will stop immediately if you deselect this button.
You have to click Connect once to start the automatic connection attempts after
checking this button.
Update Time Interval: Allowed range is 50 milliseconds up to 1 second. Little Navmap fetches
data from a simulator using this time interval. Increase this value if you experience stutters
or lag in the simulator. A lower value will result in more fluid map updates in Little Navmap.
Connect:

and Fetch AI or multiplayer ships: Disables fetching of AI
vehicles. These settings are applied immediately.
AI Fetch Radius: Limits the number of AI aircraft around the user aircraft. Only for FSX, P3D
and MSFS.
Fetch AI or multiplayer aircraft

46.

Options

This dialog consists of several pages with configuration options which can be selected in the list on
the left side. Each entry in the page list has a tooltip for easier navigation.
Note that scroll bars can show up at the left or the bottom of a options page. Scroll to see hidden
options.
Tip
Most options are self-explaining and tooltips contain more information in most cases. Hover the
mouse over a button or input field for a more detailed description.
The button Restore Defaults restores only the options of this dialog back to default. Other settings
like map display, table views or dock window positions are not affected. You can press Cancel to
close the dialog and undo this action.
To reset all saved settings completely see Reset all Settings and Restart.
The following chapters give a brief description of each page.
Tip
You can immediately check the effect of your changes on the map display by moving the dialog
Options to the side and pressing Apply.

Note
The menu entry which is referenced as Tools -> Options in this manual for Windows and Linux can
be found in the application menu at Little Navmap -> Preferences on macOS.

46.1.

Startup and Update

Allows to customize what should be loaded and shown on startup of Little Navmap.
You can also configure the frequency of the automatic update check and channels. See Checking
for Updates for more information. Change the settings here if you wish to get notifications about
beta releases.
Note
Always use the beta update channel if you use a beta or test version. Otherwise you might miss
important updates.

46.2.

User Interface

Has options for high DPI support, text sizes in information windows and flight plan as well as the
search result table.
This page also contains options to force the program language and locale settings (number, date
and time formats) to English if you do not want to use a translated user interface.
46.2.1. Language
Allows to choose the language freely among the supported translations. Note that some
translations are incomplete which might result in a mix of English and translated phrases in the
user interface.

You have to restart Little Navmap for this change to take effect.
46.2.2. Raise related windows on actions. Show flight plan after opening file, for
example.
This will open related windows and raise tabs on actions like opening files, modifying the flight plan
and other operations.
This can he helpful for new users.
46.2.3. Raise and activate docking windows when moving the mouse over it
Raises dock windows when hovering the mouse over it. This can be helpful if you have multiple
floating dock windows opened.
See also Dock Windows.
46.2.4. Raise and activate the main program window when moving the mouse over it
Raises the main window of Little Navmap when hovering the mouse over it. This will steal the focus
of other programs and activate Little Navmap which might cause unwanted effects. Therefore, try
this out before using it.
See also Dock Windows.

46.3.

Display and Text

Various user interface related settings.
46.3.1. User Interface Font
You can change the font for the whole user interface of Little Navmap.
The setting is applied immediately. Press Cancel or Reset Font to Default to revert back to previous.
The font for map display is not affected by this value and can be set separately on page Map
Display.
Warning
Keep in mind that using a wrong or too large font can result in display issues.

Tip
Try out the B612 Font family [https://b612-font.com/] which is an open source font family designed and
tested to be used on aircraft cockpit screens.
46.3.2. Enable high DPI monitor support
Toggle this is you see issues with scaled fonts on Windows, cannot shrink the main window or other
issues.
46.3.3. Disable tooltips for whole application
Disables tooltips for the whole application except for the map window which has separate settings
on page Map.
Useful for experienced users.
46.3.4. Text Size
Change default text size for various information displays.
Tip

You can temporarily resize the text in information windows by using Ctrl+Wheel. This change is not
saved.

46.4.

Map

Has map related customization options. Allows to set the tooltips, scroll performance and more.
Hover the mouse above buttons and input fields to see more information.
46.4.1. Allow to undock the map window
Allows to undock and put the map window into a floating state.
This can cause several unwanted effects when arranging dock windows. Uncheck this if you do
experience problems when resizing dock windows.
Restart the program after changing this option.
You might also need to reset the window layout in case the map window is missing after a restart.
Use menu Window -> Reset Window Layout in the main menu to clean up the layout after the restart
if needed.
See Window Layout for more information about window layouts which might be affected by this
option.

46.5.

Map Navigation

Contains all options for moving and zooming around in the map as well as click sensitivity and
zoom distances.
Three navigation modes are available. Tooltips give more information about these.

46.6.

Map Display

This page contains options for symbol sizes, text sizes, flight plan, user aircraft trail colors and
more.
Use the scroll bar on the right to see more hidden options at the bottom.
46.6.1. Map and Elevation Profile Font
You can change the font for the map display. The font will also be used in the elevation profile.

46.7.

Map Display 2

More display options for user features like range rings and more.
The right side of the page contains a tree view that allows to select the text labels that should be
shown at airports, user aircraft, AI/multiplayer aircraft and other map features.
Click on the small right pointing arrow (or + depending on operating system and user interface
style) to open a branch with options.
Hover the mouse above the tree for tooltips giving more explanations.
46.8.

Map Display Online

This page allows to change the default center circle sizes for online centers.
Two options below Online Center Boundary Lookup in User Airspaces can be used to assign OpenAir
airspaces from the user airspace database to centers by matching filename or airspace name with

the callsign of the center.
By airspace name vs. callsign:

Use the airspace name within a file to assign the geometry to a

center by callsign.

By airspace &file name vs. callsign:

Use the airspace filename minus the .txt extension to
assign the geometry to a center by callsign.
See Online Airspaces for more information.

46.9.

Units

You can change all units that are used by Little Navmap on this page between nautical, imperial
and metric. Mixed settings like meter for altitude and nautical miles for distance are possible.
Show other fuel units too:

Shows kilogram and liter as small text besides main units if lbs and
gallon are selected and vice versa. This is applied only to the most important fuel values like
block and trip fuel, for example.
Show true course and heading besides magnetic course in information displays: Add true heading as
small text besides magnetic heading displays. This applies to information, progress as well
as map display (traffic patterns and holds).
Note
See Signed Decimal Formats for more information when using Latitude and Longitude with sign or
Longitude and Latitude with sign.

Warning
Note that any numbers used in the program are not converted when changing units. That means
that you will get a minimum altitude buffer of 1,000 meter after changing the setting Altitude and
Elevation from feet to meter. This also applies to flight plan altitude. Therefore, do not forget to
adapt these numbers after changing units.

46.10.

Simulator Aircraft

Allows to change various aspects around the display of the user aircraft while flying. All settings
resulting in a more fluid aircraft display will use more CPU and can potentially induce stutters in the
simulator.
46.10.1. Aircraft Centering Options
This chapter explains the various options to modify the map updates while flying. The idea is to
reduce manual scrolling or zooming as much as possible while piloting the aircraft.
Read the chapters below if you find the behavior confusing (i.e. map jumping unexpectedly).
Otherwise leave the default values.
46.10.1.1. Center map on aircraft and next flight plan waypoint

Enabled per default.
The map is zoomed to show both the aircraft and the next active waypoint on the flight plan if this
is enabled while flying. Little Navmap uses several criteria to minimize map updates in this mode.
The map will fall back to the default mode of simply centering the aircraft if one of the conditions
below is true:
No flight plan loaded.
Aircraft is on ground (no active magenta leg).
Aircraft distance to flight plan is more than 40 NM (active magenta leg disappears).
46.10.1.2. Do not use box mode for following the aircraft. Move the map constantly.

Disabled per default.

Map will follow the aircraft constantly when checked. This is also used for Center map on aircraft and
next flight plan waypoint.
This option will cause Little Navmap to consume more CPU resources while flying.
46.10.1.3. Simulator aircraft scroll box size (percent of map window size)

Smaller values keep the aircraft centered and will move the map more often. Larger values will
update the map only when aircraft reaches map boundary.
This setting is used only if simple aircraft centering is enabled. See above for details.
46.10.1.4. Scroll flight plan table back to active leg after time below

The active (magenta) leg will be moved to the top of the flight plan table when a new leg is
activated or there is no interaction with the table for the given time period.
46.10.1.5. Clear selection in flight plan table after time below

The selection in the flight plan table and highlights on the map will be cleared after there is no
interaction with the table for the given time period.
46.10.1.6. Allow scrolling and zooming in the map

Enabled per default.
This setting allows a user to move around in the map without the need to manually disable the
aircraft centering.
The two points below explain the behavior of the program depending if this option is enabled or
not.
1. Allow scrolling enabled:
The map will stop following the aircraft for the given time if the user does any interaction
with the map like scrolling or zooming. You can quickly check out the destination or your
overall progress, and after you stop moving around, Little Navmap will return to following
your aircraft.
This option is also used in Elevation Profile.
Note
Note that special gestures are recognized if you use the simple aircraft centering mode
(Center map on aircraft and next flight plan waypoint disabled) or if Little Navmap falls back to
this mode (see above):
1. Using the mouse wheel, the + and - key or any other method first to zoom will
change and keep the zoom distance. The aircraft is still centered but the new zoom
distance is used.
2. Starting to look around by first moving the map with mouse drag, cursor keys or
any other movement: This will remember the last position and the zoom distance.
You can do any map movements and Little Navmap will jump back to the last
position and restore the zoom distance where you started the movement.
The same from point two applies if you jump to airports, navaids or other features by
double click, context menu (Show on Map) or map link.

Toggle
position.

Center Aircraft

on and off if you find that the map jumps back to the wrong

2. Allow scrolling disabled:
Map will constantly follow the aircraft and will not allow moving away from it.
The aircraft centering will be switched off only when using one of the following functions:
Double-click into a table view or map display to zoom to an airport or a navaid.

Context menu item Show on map.
Goto Home or Goto Center for Distance Search.
Map link in Information dock window.
Show Flight Plan, when selected manually, or automatically after loading a flight plan.
Centering a Google Earth KML/KMZ file after loading
This allows a quick inspection of an airport or navaid during flight. To display the aircraft
again use Map Position Back ( Map Position Back/Forward) or enable Center Aircraft again.
46.10.1.7. Jump back to aircraft and resume aircraft following after this time

Time until aircraft following is activated again after any map interaction like scrolling or zooming.

46.11.

Flight Plan

Here you can set preferences for flight plan calculation or change the default filename for saving
flight plans.
46.11.1. Avoid overwriting Flight Plan with not matching departure and destination
Check this option to avoid overwriting LNMPLN files with wrong flight plans after changing,
departure, destination or any other parameter used in the flight plan file.
The dialog Save Flight Plan as LNMPLN will show up instead of overwriting the current flight plan
when you reverse the route, for example.
46.11.2. Pattern for default flight plan names
Allows to customize the default file name which is proposed on first save of LNMPLN and export of
some formats.
Error messages and an example is shown below the input field.
This applies to new filenames when saving LNMPLN, FSX, Prepar3D, FlightGear or MSFS flight
plans. The file suffixes like .lnmpln, .pln or .fgfp are appended automatically.
Export formats like X-Plane FMS which need a certain short name do not adhere to this setting.
Note that PLN files for Microsoft Flight Simulator 2020 will have special characters removed since
the simulator cannot load files having these as a part of the name.
The default value is PLANTYPE DEPARTNAME (DEPARTIDENT) to DESTNAME (DESTIDENT).
The input field falls back to the default if it is left empty or has errors.
The following variables are recognized:
PLANTYPE:

Text IFR or VFR depending on Flight Plan Type.
Departure airport ICAO code
DEPARTNAME: Departure airport name
DESTIDENT: Destination airport ICAO code
DESTNAME: Destination airport name
CRUISEALT: Cruise altitude in selected unit (meter or feet).
DEPARTIDENT:

All variables have to be entered in upper case letters.
46.11.2.1. Short

This button sets the flight plan file pattern to the short name DEPARTIDENT DESTIDENT.
Example: EDDF LIRF.lnmpln.
46.11.2.2. Long

This button sets the flight plan file pattern to the long name PLANTYPE DEPARTNAME (DEPARTIDENT) to
DESTNAME (DESTIDENT).
Example: IFR Frankfurt am Main (EDDF) to Fiumicino (LIRF).lnmpln.

46.11.3. Ignore declination of VOR and other radio navaids
This affects the calculation of the magnetic course in flight plans.
Little Navmap will calculate magnetic course based on environment and ignore the VOR declination
value if checked. The station declination is normally used when calculating a course to and from a
VOR.
This can result in wrong course values if the calibration of a VOR is very old and differs to the
declination in the environment. The latter one is derived from simulator files or calculated based on
the the (WMM [https://en.wikipedia.org/wiki/World_Magnetic_Model]).
Check this if you rely on GPS when flying.
See also Magnetic Declination.

46.12.

Weather

Choose which weather services should be used to fetch and show METAR for airports in information
window and map tooltips.
The weather type Flight Simulator will either display weather from the FSX or P3D connection or
from X-Plane’s METAR.rwx weather file.
Note that this is not supported for Microsoft Flight Simulator 2020.
Weather for a service will not be downloaded if you disable the service for tooltips and information
panels.
Online weather is downloaded and updated every ten minutes.

46.13.

Weather Files

Active Sky can only be selected if either Active Sky Next, AS16, Active Sky for Prepar3D v4 or
Active Sky XP are installed or the weather file is selected directly. Selecting the Active Sky weather
file directly can be useful if you run a networked setup. Use Windows shares or a cloud service to
get access to the file on the remote computer.
The URLs of various weather services can be modified if you like to use another source. Usually
there is no need to change these values.
You can change the path to the X-Plane weather file if you’d like to load it on a remote computer
using a network share.
The test buttons for the online weather services can also be used to find out if Little Navmap can
connect to Internet. Check your firewall settings if these fail.
Default values for web addresses:
NOAA Weather Service URL: https://tgftp.nws.noaa.gov/data/observations/metar/cycles/%1Z.TXT
VATSIM Weather Service URL: https://metar.vatsim.net/metar.php?id=ALL
IVAO Weather Download URL: http://wx.ivao.aero/metar.php
NOAA Wind Service Base URL: https://nomads.ncep.noaa.gov/cgi-bin/filter_gfs_1p00.pl
Note
While this happens rarely some services might be interrupted for hours or even a day or two.
Little Navmap will show error messages if this is the case.
You might want to check you internet access but otherwise ignore these if it does not happen for
a longer time.

46.14.

Online Flying

This page allows to change settings for online networks.
See Online Networks for an overview.
46.14.1. Online Service
46.14.1.1. None

Disables all online services and hides all related window tabs, menu items and toolbar buttons. No
downloads will be done.
46.14.1.2. VATSIM

Uses the predefined configuration for the VATSIM [https://www.vatsim.net] network. No other settings are
needed.
The update rate depends on configuration and is typically three minutes.
46.14.1.3. IVAO

Uses the predefined configuration for the IVAO [https://ivao.aero] network. No other settings are
needed.
The update rate depends on configuration and is typically three minutes.
46.14.1.4. PilotEdge

Configuration for the PilotEdge [https://www.pilotedge.net/] network.
46.14.1.5. Custom with Status File

This option allows to connect to a private network and will download a status.txt file on startup
which contains further links to e.g. the whazzup.txt file.
46.14.1.6. Custom

This option allows to connect to a private network and will periodically download a whazzup.txt file
which contains information about online clients/aircraft and online centers/ATC.
46.14.2. Web Addresses
46.14.2.1. Status File URL

Web address of the status.txt file. You can also use a local path like
C:\Users\YOURUSERNAME\Documents\status.txt.
This file is downloaded only on startup of the Little Navmap.
A button Test allows to check if the URL is valid and shows the first few lines from the downloaded
text file. This does not work with local paths.
The status file format is explained in the IVAO documentation library: Status File Format
[https://doc.ivao.aero/apidocumentation:whazzup:statusfileformat].
46.14.2.2. Whazzup File URL

Web address of the whazzup.txt file. You can also use a local path like
C:\Users\YOURUSERNAME\Documents\whazzup.txt.
This file is downloaded according to the set update rate.
A button Test allows to check if the URL is valid. The test does not work with local paths.
The whazzup file format is explained in the IVAO documentation library: Whazzup File Format
[https://doc.ivao.aero/apidocumentation:whazzup:fileformat].
whazzup.txt example
!GENERAL
VERSION = 1
RELOAD = 1
UPDATE = 20181126131051
CONNECTED CLIENTS = 1
CONNECTED SERVERS = 41

!CLIENTS
:N51968:N51968:PILOT::48.2324:-123.1231:119:0:Aircraft::::::::1200::::VFR:::::::::::::::JoinFS:::::::177
:::
!SERVERS
...
46.14.2.3. Update Every

Sets the update rate that defines how often the whazzup.txt file is downloaded.
Allowed values are 5 to 1,800 seconds, 180 seconds being the default.
You can use smaller update rates for private online networks to improve map display updates.
Warning
Do not use update rates smaller than two minutes for official online networks. They might decide
to block the application or block you based on your internet address if downloads are excessive.
46.14.2.4. Format

or VATSIM. Depends on the format used by your private network. Try both options if unsure or
you see strange effects like all aircraft pointing to the north.
IVAO

46.15.

Web Server

Configuration options for the internal web server of Little Navmap.
Document root directory:

The root directory of the web server pages. Change this only if you
would like to run a customized web server using your own style sheets and you own HTML
templates.
Select Directory ...: Select root directory. Little Navmap will show a warning if no index.html
file is found in the root directory.
Port number: Default 8965. That means you have to use the address http://localhost:8965/ in
your browser to access the web page of Little Navmap, for example. Change this value if you
get errors like Unable to start the server. Error: The bound address is already in use..
Use encrypted connection (HTTPS / SSL): Encrypted connections use a pre-computed self-signed
certificate which comes with Little Navmap. A browser will show an error message if using
this certificate and requires to add a security exception. The encrypted address is
https://localhost:8965/, for example. Creating a self signed certificate is quite complex. Look
at the various web articles by searching for How to create a self signed certificate.
Start Server: Start or stop the server to test the changes above. The server status (running
or not running) is reverted to the previous state when pressing Cancel in the options dialog.
Label Web Server is running at http://my-computer:8965 (IP address http://192.168.1.1:8965): Shows
two links to the web server. Clicking on either one opens the page in your default browser.
You can always try the IP address link if the first link using the computer name does not
work.
See Web Server for detailed information.

46.16.

Cache and Files

46.16.1. Map Display
Here you can change the cache size in RAM and on disk. These caches are used to store the
downloaded images tiles from the online maps like the OpenStreetMap or OpenTopoMap.
All image tiles expire after two weeks and will be reloaded from the online services then.
Note that a reduction of size or erasing the disk cache is done in background and can take a while.
The RAM cache has a minimum size of 100 MB and a maximum size of 2 GB.

The disk cache has a minimum size of 500 MB and a maximum size of 8 GB.
46.16.2. Install GLOBE elevation data
The online elevation data which is used per default contains several known errors. Therefore, it is
recommended to use the freely downloadable GLOBE offline elevation data.
The bottom part of the page Cache and Files in the options dialog allows to install the elevation data
from the GLOBE - Global Land One-km Base Elevation Project [https://ngdc.noaa.gov/mgg/topo/globe.html] .
Follow the instructions below to install the GLOBE elevation data:
1. Click the link in the dialog or click here [https://ngdc.noaa.gov/mgg/topo/globe.html] to open the page.
Click Get data on the web page and then Any or all 16 "tiles". Then click All Tiles in One .zip
file to download the file.
The direct download link is all10g.zip [https://ngdc.noaa.gov/mgg/topo/DATATILES/elev/all10g.zip].
2. Extract the downloaded file all10g.zip to an arbitrary place like ...\Documents\Little
Navmap\GLOBE. You can also use the folder which is suggested by the Directories dialog. As a
result you will get a folder all10 containing files a10g to p10g.

3. Open the options dialog in Little Navmap and click on

Cache and Files

on the left side.

4. Select Use Offline GLOBE Elevation Data on the Cache and Files page in the options dialog.
5. Now select the extracted directory all10 using the Select GLOBE Directory ... button on this
options page. The label in the options dialog will show an error if the path is not correct.
6. Click Ok if the path was recognized and the label below shows Directory and Files are valid.
46.16.3. User Airspaces
You can select the path to the user airspaces and file extensions to read. Little Navmap reads all
OpenAir files with the given extension in the selected directory recursively into the user airspace
database.
You can provide more than one file extension using a space separated list.
See also User Airspaces and Load User Airspaces.

46.17.

Scenery Library Database

Allows to configure the loading of the scenery library database.
Note that these paths apply to all Flight Simulators, FSX, P3D, MSFS and X-Plane.
You have to reload the scenery database in order for the changes to take effect.
46.17.1. Select Paths to exclude from loading
All directories including sub-directories as well as files in this list will be omitted when loading the
scenery library into the Little Navmap database. You can also use this list to speed up database
loading if you exclude directories that do not contain airports or navaids (landclass, elevation data
and others).
You can also exclude FSX, P3D, MSFS BGL or X-Plane dat files if needed.
Select one or more entries in the list and click on Remove to delete then from the list.
Tip
Note that you can choose more than one entry in the file or directory dialogs to add several
entries at once.

46.17.2. Select Paths to exclude add-on recognition
FSX/P3D: All scenery data that is found outside of the base flight simulator Scenery directory is
considered an add-on and will be highlighted on the map as well as considered during search for
add-ons.
X-Plane: All airports in the Custom Scenery directory are considered add-on airports and will be
highlighted accordingly.
Microsoft Flight Simulator 2020: All airports located in the ...\Community directory and the
...\Official\OneStore or ...\Official\Steam are considered to be add-on airports.
You can use this list to modify this behavior.
Add-ons, like Orbx FTX Vector or fsAerodata add scenery files that correct certain aspects of
airports like elevation, magnetic declination or others. All these airports will be recognized as addon airports since all their files are not stored in the base flight simulator Scenery directory.
Insert the corresponding directories or files into this list to avoid unwanted highlighting of these
airports as add-ons.

Page Scenery Library Database with three directories and three files excluded from loading and two directories excluded from add-on
recognition.

46.17.3. Examples
Provided your simulator is installed in C:\Games\FSX.
46.17.3.1. ORBX Vector

Exclude the directories below from add-on recognition. Do not exclude them from loading since you
will see wrong airport altitudes.
C:\Games\FSX\ORBX\FTX_VECTOR\FTX_VECTOR_AEC
C:\Games\FSX\ORBX\FTX_VECTOR\FTX_VECTOR_APT
46.17.3.2. Flight1 Ultimate Terrain Europe

Exclude these directories from loading to speed up the process:
C:\Games\FSX\Scenery\UtEurAirports
C:\Games\FSX\Scenery\UtEurGP
C:\Games\FSX\Scenery\UtEurLights
C:\Games\FSX\Scenery\UtEurRail
C:\Games\FSX\Scenery\UtEurStream
C:\Games\FSX\Scenery\UtEurWater
46.17.3.3. ORBX Regions

Exclude these directories from loading:
C:\Games\FSX\ORBX\FTX_NZ\FTX_NZSI_07_MESH
C:\Games\FSX\ORBX\FTX_NA\FTX_NA_CRM07_MESH
C:\Games\FSX\ORBX\FTX_NA\FTX_NA_NRM07_MESH
C:\Games\FSX\ORBX\FTX_NA\FTX_NA_PNW07_MESH
C:\Games\FSX\ORBX\FTX_NA\FTX_NA_PFJ07_MESH

47. Window Layout
The layout of dock windows and the main window can be saved and loaded. This allows to quickly
change or restore the whole look of the application.
Little Navmap restores the window layout on each startup to the last one used.
You can also instruct Little Navmap to load the recently used layout file on top of the Recent
Window Layouts on startup. This can be enabled in options on page Startup and Update by
checking Load window layout from last used file.
Window layouts cover these aspects:
Main window position and size
Size, position, visibility (open or not) and state (floating or docked into main window) of all
dock windows
Toolbar size, position and visibility (open or not)
Status bar visibility
The main menu cannot be hidden to avoid user lock out.
The state of the fullscreen screen mode and the normal display mode are saved together in layout
files.
See also Dock Windows.
Note
Layouts cannot be exchanged with different settings for Allow to undock the map window in the
options dialog.
Little Navmap will show a warning when loading a layout that was saved with Allow to undock
the map window enabled and Allow to undock the map window is currently disabled, for
example.
47.1. Saving and Loading Layouts
The window layout can be loaded from and saved to LNMLAYOUT files.
Instead of using the menu item Open Window Layout you can also drag and drop a LNMLAYOUT file
from a file manager into the Little Navmap main window. This will load and apply the layout
immediately.
You can save a layout file using Save Window Layout as to an arbitrary place. Using the documents
folder is recommended. You can use the folder which is suggested by the Directories dialog.
Recent Window Layouts allows to quickly access the last save window layout files.
47.2. Reset Layout
You can use Reset Window Layout to reset the window layout back to a reasonable default. This will
load and apply the layout immediately.
47.3. Fullscreen
You can toggle fullscreen from the menu Window -> Fullscreen Map or by pressing Shift+F11.
Additionally, you can use the map context menu ( Fullscreen Map) or the button Exit fullscreen mode
to exit fullscreen mode and return to normal mode.
Fullscreen maximizes the map window and hides all other dock windows and toolbars per default.
The main menu cannot be hidden and is always visible.
You can still reopen dock windows and toolbars after switching to fullscreen mode. This can be
done from the Window Menu or by selecting Show Information in the map context menu, for
example. These dock windows will be saved on exit or when saving a window layout. The dock
windows will be restored at the same position when you enable fullscreen mode again. This way

you can have two different views. One for planning with all docks and one for flying with map and
progress, for example.

48. Weather
Little Navmap can display weather as METARs and decoded weather in the information window and
tooltips as well as weather symbols on the map.
Weather can be taken from the following sources:
FSX or P3D if connected. This also applies to network setups.
X-Plane real time weather from the METAR.rwx file. Not available when Little Navmap runs on a
different computer than your flight simulator.
NOAA [https://www.weather.gov] online weather service
VATSIM [https://www.vatsim.net] network online weather service
IVAO [https://www.ivao.aero] network online weather service
HiFi Simulation Technologies [https://www.hifisimtech.com]:
Active Sky Next (ASN)
AS16
Active Sky for Prepar3D v4 (ASP4)
ASX for X-Plane
Weather display and information can be selected in the following locations:
Options dialog on page Weather: There you define what source is shown in the information
window and in the map tooltip. This is based on the airport METAR reports and does not
affect anything else besides information and tooltip.
Main menu Weather -> Airport Weather Source: This is for the airport weather icons on the
map. Based on METAR of the airport and does not affect anything else except the weather
symbols on the map.
Main menu Weather -> Wind source: This source is used for all winds aloft functions: Map
display wind grid symbols, map tooltip, flight plan table, elevation profile (hover tooltip),
TOD and TOC calculation, fuel planning, ETA calculation and trip time calculation. Not that
this download has nothing to do with the METAR functions above and is fetched from
another source (NOAA/NOMAD).
You have to set the base path for X-Plane in the Load Scenery Library dialog to enable reading of the
weather file. Certain features like regions of manually created weather files are not supported.
METARs are shown in the airport tooltips and on the Airport overview tab. Decoded weather
information for all sources is available in the tab Weather.
The date and time information of the decoded weather display is highlighted in red if the METAR
information is older than six hours.
Note
About X-Plane weather: Little Navmap can only read the X-Plane METAR.rwx file which contains
downloaded online weather. The program cannot read custom weather situations from X-Plane. If
you use custom weather, Little Navmap only has access to the local weather around the aircraft.
Be aware that Little Navmap might display information from an obsolete or inactive downloaded
weather file.
Also, weather and nearest weather in X-Plane might be inaccurate. This is due to interpolation
between weather stations. Another problem is X-Plane falling back to default weather if a METAR
cannot be decoded although it is reported correctly in Little Navmap.

Decoded weather information from X-Plane and NOAA. The weather symbols on the map use NOAA as source (suffix - Map after the flight
rules). X-Plane weather is older than six hours and therefore highlighted red.

48.1. Weather Sources
48.1.1. Flight Simulator
Weather information from a flight simulator or the X-Plane METAR.rwx falls in one of three categories,
depending on the selected airport:
Station:

The airport has a weather station. This is the most precise weather indication.
The selected airport has no weather station and the report from the closest existing
weather station was fetched. The ident of the closest station as well as distance and
elevation are shown in the METAR and on the decoded weather tab. Note that the this
weather station is not necessarily an airport.
Interpolated (not for X-Plane): The weather is interpolated by the flight simulator using three
stations closest to the selected airport. FSX and P3D only provide non-interpolated weather
for airports close to the user aircraft. The weather for other airports is always interpolated.
The ident of the selected airport is used in the METAR report for this kind of weather report.
Nearest:

The flight simulator weather is updated every 15 seconds to catch manual changes or changes in
the weather theme.
Little Navmap watches the X-Plane METAR.rwx file for changes and will apply updates immediately.
48.1.2. Online - NOAA, VATSIM and IVAO

Online weather from both sources is updated every 10 minutes.
48.1.3. Active Sky
All Active Sky programs are recognized automatically on startup for each simulator. The
current_wx_snapshot.txt and activeflightplanwx.txt files are loaded and monitored for changes. Weather
will be reloaded and updated in the information display if necessary.
You can also select the current_wx_snapshot.txt file manually. In that case the METARs from this file
are displayed for all installed flight simulators. The activeflightplanwx.txt will be loaded from the
same directory.
Manual file selection can also be useful if a new Active Sky version is not supported by Little
Navmap yet.
Departure and destination weather will be displayed if a flight plan is loaded in one of the Active
Sky programs. A suffix Destination or Departure will indicate the usage of Active Sky flight plan
weather on the tab Weather. This gives Active Sky users the most precise weather indication for
departure and destination.
Note that the indication of Departure or Destination depends entirely on the flight plan loaded in
Active Sky and not the flight plan in Little Navmap.
48.2. Airport Weather
Little Navmap can show weather symbols for airports having a weather station for all available
weather sources. Select sources for display with Airport Weather Source.
Note that airport weather is only displayed for stations and not interpolated. Stations which are not
airports are not supported.
A suffix - Map is added to the flight rules in the METAR and decoded weather display of the
information window and tooltips to indicate which source is shown on the map.
See Airport Weather for an explanation of the symbols.

Weather situation around New York. All airports are VFR and low winds.

48.3. Winds Aloft
Little Navmap can download and display winds aloft based on either X-Plane or the National
Oceanic and Atmospheric Administration [https://www.noaa.gov/] data.
The latter ones are winds aloft forecasts which are updated four times a day and are used by most
simulators and weather programs as data source. The wind speed and direction is arranged in an
one-degree grid.
Little Navmap can display a wind barb grid for a selected wind layer or at flight plan waypoints.
Tooltips at the wind barbs show wind details for several layers at the position.
Hovering the mouse over the elevation profile shows the wind at the flight plan position. See
Tooltip Label.
Winds are used to calculate flight time, trip fuel, top of descent and top of climb.

A manual wind setting for cruise altitude can also be used. See Buttons.
See Winds Aloft for an explanation of the wind symbols and Weather for more configuration
options.
Select wind data source for display with Wind source.

48.3.1.

Wind Levels Button

Same as Wind levels.
The menu button enables or disables wind aloft display by a wind barb grid at different layers as
well as at flight plan waypoints.
The drop down menu has the following items:
At Flight Plan Waypoints:

Toggles wind barbs with a yellow border at flight plan waypoints on
and off. Wind barbs below 4000 ft above mean sea level are omitted. This function is
independent of the selection below.
None: Do not show the wind barb grid. Wind data is still downloaded and processed until the
source is set to Disabled.
Ground (only NOAA): Show the wind barb grid for winds near ground (about 260 ft). Only
available if the NOAA wind source is selected.
At Flight Plan Cruise Altitude: Show the wind barb grid for winds at the current flight plan
cruise altitude.
At 5,000 ft - At 45,000 ft: Show wind barb grid for the selected altitude.
48.4. Tooltips
The wind barbs show an optional tooltip with wind direction, speed and wind source if you hover
the mouse over them.
Direction is magnetic per default but can be changed in the options dialog on page Units. These
tooltips show the wind for all layers where the currently shown layer is highlighted bold. The cruise
altitude is added as an extra layer if selected for display.

Winds aloft display with tooltip at wind barbs in grid and wind drop down menu.

Wind barbs shown at flight plan waypoints and wind data in tooltip.

49. Printing
49.1.

Print Map

Opens the print preview dialog allowing the current map view to be printed.

Print preview dialog for the current map.

49.2.

Print Flight Plan

Print the current flight plan together with departure and destination airport information.
49.2.1. Options
Print Table Header:

Adds a header showing departure, destination and other information like
the label on top of the tab Plan in the dock window Flight Planning.
Print Fuel Report: Print the fuel calculation report from the tab Aircraft in the dock window
Flight Planning.
New page after each chapter: Add a page feed after header, flight plan, fuel report and airport
information.
Text Size: Allows to increase or decrease the size of all texts except the flight plan table.
49.2.2. Flight Plan
Print flight plan table:

Adds the flight plan to the print.
Increase or decrease the size of the flight plan table text.
Select Flight Plan Columns to Print: Click on the names to include or exclude flight plan
columns. Note that the columns are printed in the same order as shown in the Flight Plan
Table.
Text Size:

49.2.3. Options for Departure and Destination Airport

Overview:

Print the airport overview as show in the Information dock window on tab Airport.
Print runway and helipad information.
Include runways with soft surface: Include runways with soft surfaces like grass, gravel and
others.
Detailed runway information: Include detailed information for the runway ends like approach
lighting, VASI types, ILS information and more.
COM frequencies: Include communication frequencies like tower, ATIS, UNICOM and others.
Procedures: Print procedure information as shown on the tab Procedures in the Information dock
window.
Weather: Print the decoded weather for all enabled sources as shown on the tab Weather in the
Information dock window.
Runways / Helipads:

Print flight plan options dialog.

50.

Reset all for a new Flight

Use this to reset functions for a new flight. This is optional but always helpful if you with to record
logbook entries or aircraft performance between flights.
Dialog input and selection fields:
Create a new and empty flight plan:

Clears the current flight plan. Same as New Flight Plan.
Deletes simulator aircraft trail from map and elevation profile. The
same as Delete Aircraft Trail.
Reset active flight plan leg: Removes the active (magenta) flight plan leg.
Restart aircraft performance collection: Restarts the background aircraft performance
collection. Same function as Restart Aircraft Performance Collection.
Reset flight detection in logbook: Resets the logbook to detect takeoff and landing for new
logbook entries.
Remove all Ranges, Measurements, Patterns and Holdings: Removes all user features from the map.
Same as Remove all Ranges, Measurements, Patterns and Holdings.
Delete aircraft trail:

Resetting Little Navmap functions for a new flight.

51.

Checking for Updates

Little Navmap will automatically check its home page [https://albar965.github.io/] for available updates on
startup. Frequency and update channels are configurable. See below for configuration options.
You can always check manually for updates by selecting Help -> Check for Updates in the main menu.
Note that the installation still has to be done manually.
51.1. Notification Dialog
The dialog showing available updates contains a change log, various other messages and one or
more download links.
51.1.1. Buttons
51.1.1.1. Download in Web Browser

Opens your default web browser and start the download or shows a download page. You might not
necessarily see a web page if the download starts in the background.
The update dialog stays to allow reading the release notes.
51.1.1.2. Remind me Later

Dismiss the dialog. You will be notified again on next startup depending on selected frequency. You
can also press the escape key to trigger this action.
This button is not visible when checking manually.
51.1.1.3. Copy to Clipboard

Copy the contents of the window as formatted text into the clipboard for later reading. This allows
to paste the release notes into LibreOffice Writer or MS Word.
51.1.1.4. Ignore this Update

Pressing this button will close the dialog and ignore the shown version in the future. You will not
see any reminders for this version again but only for newer versions.
This button is not visible when checking manually.
Note that a manual check for updates supersedes the ignored versions.

Update notification dialog showing an available beta version including change log and download link.

51.2. Options

Update check settings can be changed in the options dialog on the page Startup and Update.
51.2.1. Check for Updates
You can set the interval for update checks. Default is Daily. Choices Daily, Weekly or Manual where the
latter one will never check automatically.
Select Help -> Check for Updates in the main menu to search manually for new versions.
Note that the daily or weekly check is only done when starting the program.
51.2.2. Update Channels
Stable Versions only:

This will show only notifications for tested and stable versions with a
complete English manual.
Stable and Beta Versions: Will additionally check for beta/test versions. Beta versions are
program releases that already contain all planned features for a stable release but are still
not tested carefully. The manual might be incomplete.
Stable, Beta and Development Versions: Little Navmap will also show notifications for
development releases. These are neither complete nor well tested. Features might change
over time and the manual is not updated for new functionality.
Note
Always use the beta update channel if you use a beta or test version. Otherwise you might miss
important updates.

Warning
A backup of all settings is recommended before running a beta or development version. See Files
for directories to save.
51.2.3. Check for Updates now
Checks for updates immediately. This will use the current settings as shown in the dialog. It will
also show notifications for updates that were ignored by pressing the Ignore this Update on the
notification dialog.

Update notification settings in dialog Options.

52. Running without Flight Simulator Installation
You can use littlenavmap.exe on all computers no matter if SimConnect or a flight simulator are
installed or not.
Follow these steps if you want to install Little Navmap on a computer not containing any flight
simulator installation for a networked setup, for example. No functionality is affected except direct
connect capability which are not needed in this case.
This scenario is typically used when connecting to the flight simulator to watch the progress of a
flight remotely.
Flight plans can be created, loaded and saved on the client computer. You only have to make sure
that these are transferred to the flight simulator computer using Windows shares or by other
means.
These instructions apply to Windows, macOS and Linux computers equally.
1. Install Little Navmap on both your flying computer and the client computer without
simulator.
2. Start it on the flying computer and generate the scenery library databases. See Load
Scenery Library above for more information.
3. Select Tools -> Files and Directories -> Show Database Files in the main menu on the flying
computer. This will open the directory containing the database files in a file manager like
Windows Explorer or Apple Finder. You will find one or more database file like
little_navmap_fsx.sqlite, little_navmap_p3dv3.sqlite or little_navmap_xp11.sqlite.
4. Exit Little Navmap on the flying computer.
5. Start Little Navmap on the client/remote computer and select Tools -> Files and Directories > Show Database Files.
6. Exit Little Navmap on the client computer so you can copy the datbase files.
7. Copy the database files to your client computer using network shares, USB sticks or
whatever you like. Use the file manager windows opened by the procedures above.
8. Start Little Navmap on the client computer. The menu Scenery Library should contain an entry
for each copied database. Airport icons should be visible on the map in either case. There is
no need to reload the scenery library database now since you just copied a fully
populated database file.
See Remote Connection for information about networked setups.

53. Web Server
Little Navmap includes an internal web server showing the map, aircraft progress and airport
information with optional automatic refresh in a web browser. The page can be accessed from any
computer, tablet or smartphone in the local network.
Note that the functionality is limited. You cannot change map display settings or calculate a flight
plan, for example.
The web server is not running per default. You can start it in the Run Webserver and then open its
page by selecting Open Webserver Page in Browser.
Port and other settings can be changed in Web Server.
You need to adjust you router settings to access it from the internet outside your local network.
Check out your router manual how to do this. In general you have to change the firewall settings to
forward the port 8965 from the router to the computer running Little Navmap.
Warning
Never open the firewall completely. This is a security risk.
53.1. Web Page
53.1.1. Page Links on Top of each Page
The top links Map, Flight Plan, Aircraft, Aircraft Progress and Airport switch the display to the
respective pages. Help opens this page.

Top navigation bar as shown in web browser.

53.1.2. Map Page
Shows the map as currently configured, i.e. airports, navaids, theme and more features are shown
as in the running application.
53.1.2.1. Top bar:

or 1 Second to 120 Seconds: Triggers a reload of the map image for the given time.
Note that this might drain the battery on smartphones or tablets.
Reload Map: Reload the map manually.
User Aircraft: Centers the user aircraft on the map.
Flight Plan: Centers the flight plan on the map.
Show Airport: Jumps the airport which ICAO ident is given in the input field to the left of this
button. Press the Return key or this button to jump to the airport.
Manual Reload

53.1.2.2. Map Navigation

The map is divided into a 3x3 field grid. Each field has an icon in the corner denoting its function:

: Zoom in and out
: Move map

: Reload map

Web map display in browser with navigation icons.

53.1.3. Flight Plan Page
Shows the flight plan with columns visible and column order as in the application. See Flight Plan
Table.
Buttons Manual Reload or 1 Second to 120 Seconds and Reload Map: Same as on map page above. Use
reload to see updates for the active flight plan leg.

Flight plan table in browser.

53.1.4. Aircraft
Shows aircraft information as Tab Aircraft.
Buttons Manual Reload or 1 Second to 120 Seconds and Reload Map: Same as on map page above.
53.1.5. Aircraft Progress Page
Shows aircraft progress information as Tab Progress.
Buttons Manual Reload or 1 Second to 120 Seconds and Reload Map: Same as on map page above.
53.1.6. Airport Information Page
Displays the same information as the Airport on one page.
Buttons and input fields:
ICAO:

Four or three letter airport ICAO ident. Press Return key or button Submit to show airport
information.
Submit: Loads airport information for given ICAO ident.
Reload: Reload page manually to catch weather changes, for example.
The links Runways, Com Frequencies, Procedures and Weather jump to the respective sections below. Click
the link ▲ Top to go back.
53.2. Web Developers
Little Navmap can deliver map images, the flight plan table and more for HTTP requests.
See directory .../Little Navmap/web/test.html or http://localhost:8965/test.html when running the
webserver for examples.

54. Tutorials
54.1. General
All functions will be referred by the names in the main menu by using Menu Name -> Menu Item. The
icons are shown as well, so you can find the buttons on one of the toolbars. Screenshots will
provide more help.
Screenshots were made on Linux and Windows. Therefore, look and feel will be different.
Note
Flight plan distances, available procedures and airport names might differ between the
simulators and used navdata cycles.
54.2. Quick Start
To have a clean common base, I recommend the following:
Select Window -> Reset Window Layout to get all the dock windows back into their default place.
Use the map theme OpenStreetMap with hill shading
enabled.
Reset the map display settings in View -> Reset Display Settings to make sure that all needed
features are shown on the map.
Select File -> Reset all for a new Flight
a clean flight plan table.

and check all buttons in the dialog to start with

54.3. Tutorials
1. Tutorial - Building a VFR Flight Plan: This tutorial shows how to create a simple flight plan
based on the map and its context menu.
2. Tutorial - Building an IFR Flight Plan with Approach Procedures This long tutorial will show
you how to create a more complex IFR flight plan including approach procedures. It
introduces the advanced airport search functionality, the spatial search and the automatic
flight plan calculation.
3. Tutorial - Creating an Aircraft Performance Profile This tutorial shows how to automatically
collect aircraft performance while flying and how to merge and fine tune the result.

55. Tutorial - Building a VFR Flight Plan
55.1. General
This tutorial will show how to create a simple flight plan based on the map and its context menus.
The flight plan is included in the Little Navmap installation directory: .../Little Navmap/etc/Tutorial
VFR Meythet (LFLP) to Challes-les-Eaux (LFLE).pln.
The airport names might differ depending on simulator.
The flight will take us through the valleys of the French alps. You can use this flight plan for any
small aircraft like the free Flight1 Cessna 162 SkyCatcher [http://www.flight1.com/view.asp?page=skycatcher] or
the default Cessna 172 of X-Plane or Prepar3D.
The flight will only go through Class E airspace. There is no need to contact ATC.
The flight plan is: Meythet (LFLP) Parking 11, Ramp GA Small to Challes-les-Eaux (LFLE), 41 nm, 0
h 24 m, Direct
55.2. Prepare Flight

I’d recommend to get use Flight -> Reset all for a new Flight
before each flight to get a clean
base for fuel calculation and other functions. Uncheck Create a new and empty flight plan in the dialog
if your plan is already loaded.
55.3. Default Aircraft Performance
This tutorial does not cover creating or collecting aircraft performance files. See Tutorial - Creating
an Aircraft Performance Profile if you like to do this.
Therefore, we will simply use the default which gives a three degree climb and descent angle as
well as 100 knots cruise speed.

Select Aircraft -> New Aircraft Performance
. Accept the default values by pressing OK in the
dialog. You will see several warnings in the fuel report. Ignore these for now since the aircraft
performance is sufficient to calculate the top of descent and top of climb for the elevation profile.
55.4. Departure Airport
Find the departure airport: Click into the map and zoom to the French Alps. You can use the
following functions to navigate:
The map overlay on the right.
The mouse (click and drag) to move and the mouse wheel to zoom.
The cursor keys to move and the keys + and - for zooming in and out (click into the map
window or press F2 to activate it before using the keys).

Use the back

and forward

See also Map Display.

buttons to jump in the position history like in a web browser.

Look for the departure airport Meythet (LFLP) around here:

Closer with tooltip:

Now:
Zoom in until you see the airport diagram showing taxiways, runway details, parking
positions and more.
Zoom in further until you see the white parking numbers.
Right-click on the center of one of the green ramp parking spots (11 is used here).
Choose Select Airport Meythet (LFLP) / Parking 11 as Departure
context menu.

( Set as Departure) in the

The airport layout and parking spot will be different depending on used simulator.

This will select your departure parking position which will be highlighted by a black/yellow circle.
The airport will be added to the flight plan as departure too.
You can also click on the airport icon and select it for departure. A runway will be automatically
assigned as departure position.
55.5. En-Route Waypoints
Add the waypoints now:
Scroll along the valley to the south east across the lake Lac d’Annecy.
Click Append Position to Flight Plan
. The clicked position will be added as an userdefined waypoint to the end of your plan.

Click undo

or redo

in the toolbar if you don’t like what you just added.

Another function is Add Position to Flight Plan
which will insert the clicked position to the
nearest flight plan leg. You can use this to add user-defined positions, airports or navaids in the
middle of a flight plan. The nearest leg will be chosen automatically by Little Navmap for inserting
the new position.
Little Navmap will automatically assign names to the user-defined waypoints. You can leave these
as they are or replace them with a more meaningful name.
Waypoints using the default format WP plus number (e.g. WP1 or WP99) are automatically renumbered
to reflect the flying order in the flight plan.

Right-click on the user waypoint and select Edit Flight Plan Position WP1
( Edit Flight Plan
Position or Edit Flight Plan Position Remarks) to change a waypoint ident, name, remarks or its
coordinates. Use nearby villages, mountains, lakes or other points of interest. Do not change the
coordinates now.

Keep adding points and stay away from the mountains until you’re at Challes-les-Eaux (LFLE).

55.6. Destination Airport
To add the destination:
Right-click on Challes-les-Eaux (LFLE)
Select Set Airport Challes-les-Eaux (LFLE) as Destination

Now there is a flight plan. Yours might look a bit different.

( Set as Destination).

You can also use the drag and drop feature to move points or add new ones. Enable it by checking
-> Edit Flight Plan on Map
and click on a flight plan waypoint to move it. Click on a
flight plan leg to add a new waypoint into this leg.
Flight Plan

55.7. Cruise Altitude
Change the flight plan type to VFR if not already done.

Now check the cruise altitude:
Look at the flight plan elevation profile. There is a red line indicating the minimum safe
altitude.
Adjust the flight plan cruise altitude until you’re above the red line.
Select Flight Plan -> Adjust Flight Plan Altitude
the hemispherical rule.

to get the correct altitude adjusted by

Note that the default hemispherical rule is not correct for France until you change it in the options
dialog, but avoid this for the sake of simplicity now.

You probably noticed that you will get close to ground near the destination. Be prepared to
circumvent some mountains there.
55.8. Airspaces
Now look if your flight plan touches any airspaces.
Click into one of the airspaces nearby start and destination and have a look at the information dock
window. There are several airspaces:
which starts at 9,500 ft above mean sea level (MSL). This is higher than
our cruise altitude and won’t affect us.
Two Class E airspaces. The information window notes for these: Controlled, IFR and VFR, ATC
clearance required for IFR only. No problem because we will fly using VFR.
Geneva TMA Sector 8

The situation is similar at the destination.
Note that you might find different airspaces depending if you use the latest navdata or stock
airspace data.

55.9. Saving

Save the plan in the Little Navmap format LNMPLN using File -> Save Flight Plan
. The
program usually finds the right directory for the flight plans and gives a sensible name by default.
The format LNMPLN is only understood by Little Navmap. You cannot load these files into another
program. Therefore, we have to export the flight plan.
Now open the multiexport options dialog by selecting File -> Multiexport Flight Plan Options.

Right click on the simulator format you’d like to export and select Export Flight Plan now
Save the file to the right place. The default path is based on best guess.

.

See here Quick Setup for information how to quickly configure the multiexport.
55.10. Flying
Follow the steps below to get a moving map and see your aircraft in Little Navmap:

Open the dialog Connect using Tools -> Flight Simulator Connection
and check if Connect
automatically is selected. Enable it if not. Little Navmap will find the simulator no matter if it
is already started or will be started later.
Click on the tab which corresponds to your simulator. Image below shows the tab for FSX,
P3D or MSFS on the left and the tab for X-Plane on the right.

Click Connect which will close the dialog.

Enable Map -> Center Aircraft
. The map will jump to the simulator aircraft and keep it
centered if an active flight is loaded, i.e. the simulator is not in the opening screen.
Start the simulator if not already done, load the flight plan and go flying.
See also Connecting to a Flight Simulator.
55.11. Looking at Places while Flying
Little Navmap will keep your aircraft and the next flight plan waypoint centered on the screen as a
default setting. You can configure this function in the options dialog on page Simulator Aircraft.
The program will stop following your aircraft for 10 seconds if you start any action that zooms in to
an airport or navaid (double-click, toolbar button or link in the information window) or just simply
move or zoom around in the map.

Double-click on the destination airport to zoom to the airport diagram, for example. Leave Little
Navmap alone and the map will jump back to the aircraft and next flight plan waypoint after the
timeout.

56. Tutorial - Building an IFR Flight Plan with
Approach Procedures
This tutorial will show you how to create a more complex IFR flight plan including approach
procedures. It introduces the advanced airport search functionality and the automatic flight plan
calculation.
The flight plan included in the Little Navmap installation directory: .../Little Navmap/etc/Tutorial IFR
Bembridge (EGHJ) to Wick (EGPC).pln.
While this tutorial looks quite lengthy it is normally a matter of half a minute to get a flight plan if
you know where to go. The planning effort shown here is bigger to highlight some of the more
advanced features of the program.
You should at least read through Tutorial - Building a VFR Flight Plan before doing this one.
The flight plan will go across the UK using an IFR capable aircraft. Its maximum range should be
more than 600 NM including reserves and a cruise altitude of 10,000 ft.
Note that Bembridge has a relatively short runway of 2,729 ft. You probably need a small
turboprop or a powerful twin. Do not try to fly this trip with an airliner.
The tutorial assumes the following preconditions:
You left your aircraft at Bembridge (EGHJ) at the end of the last flight or think of it as you home
base.
You don’t know where you want to fly today.
You know the requirements for your aircraft:
Maximum range
Minimum runway length
Hard runways
Needs a parking spot at the destination
Fuel for return trip
56.1. Prepare Flight

Use Flight -> Reset all for a new Flight
before each flight to get a clean base for fuel
calculation and other functions. Uncheck Create a new and empty flight plan in the dialog if the flight
plan is already loaded.
56.2. Default Aircraft Performance
This tutorial does not cover creating or collecting aircraft performance files. See Tutorial - Creating
an Aircraft Performance Profile if you like to do this.
Therefore, we will simply use a slightly modified aircraft performance profile which gives a three
degree climb and descent angle.

Select Aircraft -> New Aircraft Performance
.
Optional: Select Edit Aircraft Performance from the same menu as above and change the
value for Cruise speed at typical cruise altitude to roughly match your chosen aircraft. This
helps to get an accurate estimate for the traveling time. Fill the other fields too if you know
the performance values.
Optional: Adjust descent and/or climb values as needed.
Accept by pressing OK in the dialog.
You will see several warnings in the fuel report. Ignore these for now since the aircraft performance
is sufficient to calculate the top of descent and top of climb for the elevation profile.

56.3. Cleanup Search
Go to the dock window Search and follow the steps below:

Right-click into the result table and select Reset Search
that may affect the query.

to remove of all search criteria

Click the menu button
and make sure that the search groups Facilities, Runway and
Distance from Mark are checked. Deselect all others you do not need.

56.4. Assign Departure
Now look for the departure airport:
Enter EGHJ in the ICAO Code search field on the top left (case does not matter).
Right-click on the airport in the result table.
Choose Set as Flight Plan Departure
position.

. This will assign a default runway as a start

Your flight plan has one entry now. This is already sufficient if you want to fly a pattern and like to
see distance, speed and time information to the airport.
Now select a parking position:

Go to Flight Plan -> Select a Start Position for Departure
Choose one of the GA small ramp positions.
Click OK and the position will be highlighted on the map.

.

You can also select the start position directly on the map’s context menu as described in Tutorial Building a VFR Flight Plan. See also Set as Departure.
56.5. Search for Destination
Now look for a suitable destination airport:
Right-click on EGHJ in the search result again.
Select Set Center for Distance Search
. You can also do this in the map. This is the
center point for the spatial search.
Clear the ICAO Code search field now. It is a common mistake to leave the text fields filled
when doing distance searches which will give you an empty result table.
We will now look for airports that are in range of the aircraft but not too close. Also, certain criteria
have to be fulfilled, like a runway which is long enough and has the right surface.
You can also find airports in aircraft range by using the range rings where you can right-click into
the map on your departure airport and select Add Range Rings

.

We will use the spatial search instead of range rings since we’d like to see only suitable airports for
out aircraft.
Check the following in the airport search tab:
1. Rating: We’d like to get airports that are either add-ons or have basic scenery requirements
as taxiways, parking spots and more. Select the one with at least four stars. You can also
select 3D if you fly X-Plane.
2. Procedures: Show only airports that have procedures.
3. Deselect Military and Closed (click the checkboxes twice): This will return only civilian airports
and avoid airports that have all runways closed.
4. Select Any is Hard in the button Any Surface to avoid airports having only soft surfaced
runways.

5. Select a minimum runway length of 2,500 ft or whatever you chosen aircraft needs in the
field Runways: Min:.
See also Search.
You can also limit the maximum runway length if you are looking for a short landing challenge.
The search result changes on the fly while doing all these adjustments, though we are not there
yet:
Check Distance: to activate the spatial search.
Change the maximum distance to 600 NM and the minimum to 400 NM (to avoid short
hops). The result table will now update with a small delay since the distance search is more
complex.
To find only airports north of your position select North in the button Any Direction. Note that
the search result is sorted by distance with the closest airport first per default.
Choose an airport for your trip. Use Wick (EGPC) for this tutorial.

Right-click on Wick in the result table and select Show Information
tabs in the dock window Information.

. This will fill the

Select the tab Airport and below this one the tab Weather. Look for the section Best runways for
wind to get an idea of the expected landing runway. Start any third party weather programs
before if you use these.

For this tutorial we assume that the winds favor runway 13.
See also Weather.
56.6. Select an Approach Procedure
We’ll select an approach procedure now:
Go back to the search result.
Right-click on the airport Wick again. Select Show Procedures
. This will pop up the
procedure search tab.
Choose Runway 13 in the All Runways combo box to see only approaches for 13.
Select Expand All in the context menu to see also the transitions for each approach.
Choose Approach VORDME 13 FD13 using Transition (Full) CHINN since we expect to land on runway
13. You can also use any other approach for this runway if VORDME 13 is not available.
The top label in the procedure search shows Wick (EGPC) Approach VORDME 13 FD13 Transition (Full) CHINN
for the selected approach and/or transition. You can also see a preview on the map.

Right-click on the transition and select Show on Map (text might be different depending on
selection)
. This will center the procedure on the map. You can click on the legs in the
procedure tree to see the start and end points of a leg.

See also Search Procedures and Procedures.
If you like what you see right-click again on the transition and select Insert into Flight Plan, Use as
Destination and Use as Departure (text might be different depending on selection)

.

This will do two things:
1. Add Wick as the destination airport to the flight plan. Any previous destination in the flight
plan will be replaced.
2. Add the approach and its transition to the flight plan. The procedure legs use a dark blue
color and the missed approach legs use a dark red color in the flight plan table. Flight plan
en-route legs are black. Again, any previous procedure is replaced with this new one.
About adding transition and approaches: Approaches and transitions are closely related which
is already indicated by the tree structure in the procedure search tab. You can add an approach
alone but a transition always belongs to an approach.
You have to select the transition to add or show both, approach and transition.
56.7. Calculate a Flight Plan
Now we have the departure airport, an approach procedure and the destination all connected by a
straight line. Next is the en-route part of the flight plan:
Set IFR as the flight plan type in the dock window Flight Planning on tab Flight Plan. This
allows the automatic flight plan calculation to adjust the cruise altitude.

Click Flight Plan -> Calculate Flight Plan
window.

to open the flight plan calculation floating

The flight plan cruise altitude is automatically adjusted according to the hemispherical rule
(the rule can be changed in Tools -> Options
on the page Flight Plan), the altitude
restrictions of the airways and the flight plan type (VFR or IFR). You can see the minimum
altitude for each airway segment in the flight plan table in the column Restriction (see Table
Columns).
The altitude can be changed according to the hemispherical rule by clicking the Adjust
button.
Change all settings in the floating window as shown in the screenshot above.
Click the button Calculate.
Use this flight plan for now.

Save the plan using File -> Save Flight Plan as LNMPLN
. The program usually finds the right
directory for the flight plans and gives a sensible name by default.
The top label in the flight planning dock window reads now:
Bembridge (EGHJ) Runway 12 to Wick (EGPC)
Via CHINN and VORDME FD13 (D13) to runway 13 .
538 nm, 5 h 23 m, Low Altitude

The plan looks like shown below.

56.8. Airspaces
Now you can check if you pass through any airspaces:

Enable airspaces by selecting View -> Airspaces -> Show Airspaces
Check View -> Airspaces -> At flight plan cruise altitude
menu button.

if not already done.

in the menu or the toolbar

This will display only airspaces on the map that are relevant for your cruise altitude. You can also
select Below 10,000 ft only to see all relevant airspaces in the climb or descent phase. Use the
tooltips on the map to get information about airspaces like type, minimum and maximum altitude.

56.9. Saving

Save the plan in the Little Navmap format LNMPLN using File -> Save Flight Plan
. The
program usually finds the right directory for the flight plans suggests a name based on departure
and destination.
The format LNMPLN is only understood by Little Navmap. You cannot load these files into another
program. Therefore, we have to export the flight plan.
Now open the multiexport options dialog by selecting File -> Multiexport Flight Plan Options.

Right click on the simulator format you’d like to export and select Export Flight Plan now
Save the file to the right place. The default path is based on best guess.

.

See here Quick Setup for information how to quickly configure the multiexport.
56.10. Flying
Follow the steps below to get a moving map and see your aircraft in Little Navmap:

Open the dialog Connect using Tools -> Flight Simulator Connection
and check if Connect
automatically is selected. Enable it if not. Little Navmap will find the simulator no matter if it
is already started or will be started later.
Click on the tab which corresponds to your simulator. Image below shows the tab for FSX,
P3D or MSFS on the left and the tab for X-Plane on the right.

Click Connect which will close the dialog.

Enable Map -> Center Aircraft
. The map will jump to the simulator aircraft and keep it
centered if an active flight is loaded, i.e. the simulator is not in the opening screen.
Start the simulator if not already done, load the flight plan and go flying.
See also Connecting to a Flight Simulator.
56.11. Top of Descent
A top of descent indication is displayed on the map and in the elevation profile which also shows
the distance from top of descent to the destination. This number includes the distance of approach
procedures (excluding holds).
Altitude restrictions in procedures are considered in the top of descent calculation.

The tab Progress in the dock window Simulator Aircraft will show the distance to the top of descent in
the Flight Plan Progress section.
The section Altitude will show the vertical path deviation after passing the top of descent.
56.12. Changing Procedures

Now the weather has changed requiring an approach to runway 31:
Right-click on the destination airport at the bottom of the flight plan table.
Choose Show Procedures
.
Then change the runway filter to Runway 31.
Expand the approach VORDME 31 to see the transition.
Select the transition.
The label on top of the window shows now Approach VORDME 31 FD31 Transition (Full) CHINN.
Right-click on the selected transition.
Choose Use EGPC and Approach and Transition as Destination
from the context menu which
will replace the current procedure in your flight plan with the new one.
The top label in the flight planning dock window reads now:
Bembridge (EGHJ) Parking 1, Ramp GA Small to Wick (EGPC)
Via CHINN and VORDME FD31 to runway 31
526 nm, 5 h 15 m, Low Altitude

To completely delete a procedure:
Select any leg of the procedure in the flight plan table.
Right-click and choose Delete Selected Legs or Procedure
remove the whole procedure.

or press the Del key to

If ATC clears you to the initial fix of the procedure:
1. Delete any intermediate waypoints between your current aircraft position and the initial fix
of the procedure: Right-click in the flight plan table and select Delete Selected Legs or
Procedure
for all waypoints between your current aircraft position and the initial fix or
start of the procedure. Avoid deleting your approach (you can also right-click on a flight plan
waypoint on the map and delete it from the context menu).
2. Then right-click on your aircraft on the map and select Add Position to Flight Plan

.

This will give a direct connection from your current aircraft position to the start of the procedure
which you can use to get course and distance to the initial fix.
Below: After changing the approach procedure and adding an user-defined waypoint at the aircraft
position to the flight plan. Now we get course and altitude indications for a direct leg to the start of
the transition (43 NM and 314 degrees magnetic course).

56.13. Going Missed
I recommend hiding the missed approaches on the map by unchecking View -> Show Missed
Approaches

. This helps uncluttering the map display.

If the missed approach is not shown: The progress window shows distance and time to
destination. Activating the next leg (shown in magenta color) will stop if the destination (i.e.
the runway threshold) is reached, even when passing the threshold.
If the missed is shown and the aircraft passes the runway threshold: The first leg of
the missed approach is activated and simulator aircraft progress will display the remaining
distance to the end of the missed procedure.

57. Tutorial - Creating an Aircraft Performance
Profile
This tutorial shows how to automatically collect aircraft performance while flying and how to create,
merge and fine tune the result.
You should be already familiar with the flight planning features of Little Navmap.
57.1. Flight Plan
You can use the flight plan from the IFR tutorial is included in the Little Navmap directory:
.../Little Navmap/etc/Tutorial IFR Bembridge (EGHJ) to Wick (EGPC).pln.

Use main menu File -> Open Flight Plan

to load the flight plan.

The plan should cover the typical cruise altitude and travel distance for your aircraft. A short hop of
a few miles at low altitude does not suffice.
You can also fly and collect performance without a flight plan. Set the intended cruise altitude in
the window Flight Planning to allow Little Navmap to detect the cruise phase.
57.2. Aircraft Performance
First start by creating a new and empty performance profile by selecting Aircraft -> New Aircraft
Performance

in the main menu.

Leave all as is in the dialog and click OK.

Ignore the various warnings and error messages in the fuel report for now. This performance
profile is good enough to calculate top of climb and top of descent with a three degree flight path

angle.
Also ignore the zero values in the Fuel Plan Section. Fuel flow data has to be entered in the
performance profile to get a valid fuel prediction.
Start and load a flight with aircraft engines running or not. Connect Little Navmap to the simulator.

Select Flight -> Reset all for a new Flight
in the menu. Remove the check mark from Create a
new and empty flight plan since a plan is already loaded. Click OK to get a clean base for fuel
calculation, logbook and other functions.

Fly and use typical climb and cruise performance settings in the aircraft. Time compression is no
issue if you stay a few minutes at cruise to allow Little Navmap collecting cruise fuel data.
You can see the detected aircraft type, detected flight phase (climb, cruise and more) as well as all
current values collected and averaged by Little Navmap in the tab Current Performance.
See chapter Aircraft Performance Collection for details.

New flight phases are added when detected. Note that the cruise phase is only detected when
flying at flight plan cruise altitude. Set the cruise altitude in the flight plan tab at least if you wish
to collect performance without a flight plan.

After landing and shutting off engines you can see the text Current flight segment: Destination Parking,
Finished. in the tab Current Performance.

You have a complete aircraft performance collection once the text Finished. is shown which is right
after touchdown at the destination.

Now select Aircraft -> Merge collected Aircraft Performance
empty performance profile with the collected values.

in the main menu to fill the

Note the header New Value (collected data) and Current Value (currently loaded or created profile
default values) with the values below.

We’d like to use all values for the new profile. Therefore, set all operations to Copy in the dialog and
click OK.
You can also change the operations for each field individually or use the operation Merge which will
use the average of the new and current value. You can do a merge at any flight phase. For

example, if you’d like to fine tune the values during flight. See Aircraft Performance Merge for
more.
Adjust the performance using Merge when doing more flights after the first one.
Warning
Do not forget to add at least sufficient reserve fuel. Otherwise you will run out of fuel at
destination if you rely on this plan.
You should change the usable fuel and values for alternate after merging. Do this by selecting
Aircraft

-> Edit Aircraft Performance

. Note that required values have bold labels in the edit

dialog.
It is also helpful to add notes like engine power settings in the description file of a performance
profile.
Example below for a Beech King Air C-90:

The chapter Aircraft Performance Edit explains details about editing.
Tip
Use performance files for different cruise altitude ranges to get more precise results for large or
complex aircraft. For example, one file for FL300-FL350 and one for FL350-FL400.

Use Aircraft -> Save Aircraft Performance
and save the new performance file to any place
like Documents\Little Navmap\Performance, for example.
Think about sharing this file with others or send it to me so I can add it to the download section of
littlenavmap.org [https://www.littlenavmap.org/downloads/Aircraft%20Performance/].

58. Coordinate Formats
This chapter briefly describes the recognized coordinate formats in flight plan position dialogs and
userpoint dialogs.
The input field shows a message below which indicates if the coordinates were recognized and
shows the translated coordinates in the preset format as chosen in dialog Options on tab Units. A
red message is shown in case of error.
Check the displayed translated coordinates to verify that your input was parsed correctly.

Editing an user-defined flight plan position. Tooltip gives a quick help on coordinate formats.

58.1. General
Latitude has to be first and longitude second.
N/S and E/W designators are required except for the signed formats. Case does not matter.
Degree, minute and second signs can be omitted if numbers are separated by spaces.
A space is only required to separate latitude and longitude or degrees/minutes/seconds if no unit
signs are used.
Decimal separator can be period (English) or the locale dependent separator like e.g. comma
(German).
All dialogs show the read coordinates below the input field in the curretly configured coordinate
format.
See Units for more information.
Tip
You can directly paste coordinates from the Wikipedia like 40°41′21″N 74°2′40″W into the fields.
58.2. Signed Decimal Formats
For the coordinate formats Latitude and Longitude with sign and Longitude and Latitude with sign:
Latitude: Negative is south and positive is north.
Longitude: Negative is west and positive is east values.
Choosing these display formats will also enable input of signed decimal values. The reading order
for coordinates (Latitude and Longitude versus Longitude and Latitude) will also change depending on
the chosen format if entering signed numbers.
The reading order will not change if the input field uses N, S, E and W designators.
58.3. Other Formats
These have to be given exactly as shown in the examples.

Degrees and minutes: N44124W122451, N14544W017479 or S31240E136502
Degrees only 46N078W
Degrees and minutes 4620N07805W
Degrees, minutes and seconds 481200N0112842E (SkyVector)
Degrees and minutes in pair N6500 W08000 or N6500/W08000
NAT type 5020N
58.4. Examples
Degrees, minutes and seconds: N49° 26' 41.57" E9° 12' 5.49" or 49° 26' 41.57" N 9° 12' 5.49" E
Degrees and decimal minutes: N54* 16.82' W008* 35.95', N 52 33.58 E 13 17.26 or 49° 26.69' N 9°
12.09' E

Decimal degrees only: 49.4449° N 9.2015° E or N 49.4449° E 9:2015°

59. Remarks
The edit fields Remarks allow multi line text and special characters for flight plans, flight plan
waypoints, aircraft performance files and userpoints. Formatted text like italic or bold is not
supported.
Links are recognized in the field Remarks and can be opened in the dock window Information on tab
Navaids which is shown after clicking on an userpoint or selecting Show Information in one of the
context menus, for example.
The same applies to userpoints and aircraft performance in the respective information or fuel report
tabs.
Normal web links like http://www.example.com or https://www.example.com are recognized besides directory
or file links like file:///C:/Users/me/Documents/Aircraft%20Notes.txt on Windows or
file:///home/me/Aircraft%20Notes.txt on macOS or Linux.
Note that you have to use the forward slash / instead of the backslash \ on Windows as a path
separator.
Replace spaces in links with %20 since Little Navmap recognizes links only until the next space.

60. Keyboard Shortcuts
60.1. Main Menu
60.1.1. File
Menu

Shortcut

File -> New Flight Plan

Ctrl+N

File -> Open Flight Plan …

Ctrl+O

File -> Save Flight Plan

Ctrl+S

File -> Save Flight Plan as LNMPLN …

Ctrl+Shift+S

File -> Reset all for a new Flight …

Ctrl+Alt+Shift+R

File -> Export Flight Plan as MSFS 2020 PLN …

Ctrl+Shift+F

File -> Export Flight Plan as P3D or FSX PLN …

Ctrl+Shift+P

File -> Export Flight Plan as X-Plane FMS 11 …

Ctrl+Shift+X

File -> Export Flight Plan as FlightGear FGFP …

Ctrl+Shift+G

File -> Multiexport Flight Plan

Ctrl+Shift+M

File -> Multiexport Flight Plan Options …

Ctrl+Alt+Shift+M

File -> Copy Map Image to Clipboard …

Alt+Shift+P

File -> Print Map …

Ctrl+P

File -> Print Flight Plan …

Ctrl+Alt+P

File -> Exit

Ctrl+Q

60.1.2. Flight Plan
Menu

Shortcut

Flight Plan -> Flight Plan

F7

Flight Plan -> Fuel Report

F8

Flight Plan -> Undo Flight Plan

Ctrl+Z

Menu

Shortcut

Flight Plan -> Redo Flight Plan

Ctrl+Y

Flight Plan -> Select a Start Position for Departure …

Ctrl+Shift+D

Flight Plan -> Edit Flight Plan on Map

Ctrl+Shift+E

Flight Plan -> New Flight Plan from Route Description …

Ctrl+Shift+N

Flight Plan -> Calculate Flight Plan …

Alt+Shift+C

Flight Plan -> Adjust Flight Plan Altitude

Ctrl+Shift+J

60.1.3. Map
Menu

Shortcut

Map -> Goto Home

Ctrl+Home

Map -> Goto Center for Distance Search

Ctrl+End

Map -> Center Flight Plan

Alt+Shift+F

Map -> Remove all Highlights and Selections

Ctrl+H

Map -> Remove all Ranges, Measurements, Patterns and Holdings

Alt+Shift+H

Map -> Center Aircraft

Ctrl+Alt+A

Map -> Delete Aircraft Trail

Alt+Shift+T

Map -> Map Position Back

Alt+Left

Map -> Map Position Forward

Alt+Right

60.1.4. View
Menu

Shortcut

View -> Reset Display Settings

Ctrl+Alt+R

View -> Details -> More Detail

Ctrl++

View -> Details -> Default Detail

Ctrl+0

View -> Details -> Less Detail

Ctrl+-

Menu

Shortcut

View -> Airports -> Force Show Add-on Airports

Ctrl+Alt+O

View -> Airports -> Show Airports with hard Runways

Ctrl+Alt+H

View -> Airports -> Show Airports with soft Runways

Ctrl+Alt+S

View -> Airports -> Show empty Airports

Ctrl+Alt+E

View -> Navaids -> Show VOR Stations

Ctrl+Alt+V

View -> Navaids -> Show NDB Stations

Ctrl+Alt+N

View -> Navaids -> Show Waypoints

Ctrl+Alt+W

View -> Navaids -> Show ILS Feathers

Ctrl+Alt+I

View -> Navaids -> Show Victor Airways

Ctrl+V

View -> Navaids -> Show Jet Airways

Ctrl+J

View -> Navaids -> Show Tracks

Ctrl+T

View -> Airspaces -> Show Airspaces

Ctrl+Alt+C

View -> Show Flight Plan

Ctrl+Alt+F

View -> Show Missed Approaches

Ctrl+Alt+M

View -> Show Compass Rose

Ctrl+Alt+D

60.1.5. Userpoints
Menu

Shortcut

Userpoints -> Userpoint Search

F6

60.1.6. Logbook
Menu

Shortcut

Logbook -> Logbook Search

Shift+F6

60.1.7. Aircraft
Menu

Shortcut

Menu

Shortcut

Aircraft -> Save Aircraft Performance

Alt+Shift+S

Aircraft -> Edit Aircraft Performance …

Alt+Shift+E

60.1.8. Scenery Library
Menu

Shortcut

Scenery Library -> Load Scenery Library …

Ctrl+Shift+L

60.1.9. Tools
Menu

Shortcut

Tools -> Flight Simulator Connection …

Ctrl+Shift+C

Tools -> Options …

Ctrl+Shift+,

60.1.10. Window
Menu

Shortcut

Window -> Shortcuts -> Map

F2

Window -> Shortcuts -> Elevation Profile

F3

Window -> Shortcuts -> Airport Search

F4

Window -> Shortcuts -> Navaid Search

F5

Window -> Shortcuts -> Userpoint Search

F6

Window -> Shortcuts -> Logbook Search

Shift+F6

Window -> Shortcuts -> Flight Plan

F7

Window -> Shortcuts -> Flight Plan Calculation

Shift+F7

Window -> Shortcuts -> Fuel Report

F8

Window -> Shortcuts -> Airport Information

F9

Window -> Shortcuts -> Airport Weather Information

F10

Window -> Shortcuts -> Navaid Information

F11

Menu

Shortcut

Window -> Shortcuts -> Simulator Aircraft Progress

F12

Window -> Style -> Fusion

Shift+F2

Window -> Style -> Night

Shift+F3

Window -> Fullscreen Map

Shift+F11

Window -> Show all floating Windows

Alt+0

Window -> Allow Window docking

Alt+9

Window -> Search

Alt+1

Window -> Flight Planning

Alt+2

Window -> Flight Plan Calculation

Alt+3

Window -> Information

Alt+4

Window -> Flight Plan Elevation Profile

Alt+5

Window -> Simulator Aircraft

Alt+6

Window -> Legend

Alt+7

60.1.11. Help
Menu

Shortcut

Help -> Contents (Online)

F1

Help -> Navmap Legend

Shift+F1

60.2. Context Menus
60.2.1. Flight Plan Table
Menu

Shortcut

Show Information

Ctrl+I

Show Procedures

Ctrl+Shift+R

Create Approach

Alt+Shift+R

Menu

Shortcut

Activate Flight Plan Leg

Ctrl+L

Move selected Legs up

Ctrl+Up

Move selected Legs down

Ctrl+Down

Delete selected Legs or Procedure

Del

Edit Flight Plan Position

Return

Copy

Ctrl+C

Select all

Ctrl+A

Clear Selection

Ctrl+Shift+A

60.2.2. Search Result Tables and Search Input Fields
Menu

Shortcut

Show Information

Ctrl+I

Show Procedures

Ctrl+Shift+R

Create Approach

Alt+Shift+R

Show on Map

Ctrl+M

Reset Search

Ctrl+R

Show All

Ctrl+Shift+O

Copy

Ctrl+C

Select all

Ctrl+A

Clear Selection

Ctrl+Shift+A

60.2.2.1. Procedure Search - Additional Shortcuts

Menu

Shortcut

Show Procedure on Map

Return

Insert Procedure into Flight Plan

Ctrl+Shift+I

Menu

Shortcut

Show Information for Airport

Ctrl+I

Show Airport on Map

Ctrl+M

60.2.2.2. Userpoint and Logbook Search - Additional Shortcuts

Menu

Shortcut

Add

Ins

Edit

Return

Delete

Del

61. Network Setup
This chapter explains how to connect with a remote computer across the network to a simulator on
a flying computer.
Note
There is no need to share the scenery library or files of any simulator on the network.
You do not have to copy the simulator scenery library neither do you have to install a second
simulator on the client computer.
61.1. How to Prepare a Network Setup
1. Install/extract the whole Little Navmap archive on the flying and network computer.
2. Copy Little Xpconnect to the X-Plane plugins directory if you use X-Plane. See X-Plane Plugin
for details.
3. Use Little Navmap to generate the scenery database on the flying computer. Main menu ->
Scenery Library -> Load Scenery Library
4. Open the database directory on the flying computer using Tools -> Files and Directories ->
Show Database Files.
5. Copy the database files to the network computer. Always close Little Navmap before
copying. See Databases for information on what is stored in what database file. Nothing else
to do on the remote computer after copying. The copied file is read-to-use and there is no
need to load the scenery library.
Note
Make sure that the major versions of Little Navmap and Little Navconnect match, otherwise you
might get an error message. Use the version of Little Navconnect which is included in the Little
Navmap download archive if unsure.
61.2. Flying in a network setup
1.
2.
3.
4.

Start the simulator
Start Little Navconnect on the flying computer.
Run Little Navmap on the network/remote computer.
Connect Little Navmap on the network/remote computer to Little Navconnect on the flying
computer. Main menu -> Tools -> Flight Simulator Connection.

See the two chapters below for more details:
Running without Flight Simulator Installation Detailed explanation how to copy scenery
library databases to a remote computer without a simulator installation.
Connecting to a Flight Simulator and chapter Remote Connection explains how to connect
from a remote computer in detail.

62. Customizing General
Little Navmap creates multiple configuration files in the directory
C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel when started. These allow extended customization of
the program.
The files use the Windows-INI style that has groups in square brackets and key=value lines. See INI
(Wikipedia) [https://en.wikipedia.org/wiki/INI_file] for more information about this type of configuration files.
Note
You have to restart Little Navmap to see any changes. Also, do not edit the files while Little
Navmap is running since it might overwrite your changes.
To undo all changes simply delete a file. It will be created again containing the default values when
Little Navmap is started.
Single lines can also be deleted and will be restored with the default value when Little Navmap is
started.
Keys and values are case sensitive. Order in the files is not important if the keys remain in their
respective sections. The program might reorder the keys when saving or updating the files.
62.1. Version
Some of the INI files contain a section [Options] with a key Version as shown below.
[Options]
Version=2.0.1

Warning
Do not delete the version since Little Navmap relies on this information when updating the file. It
will reset the file occasionally whenever the default settings change. A backup will be created to
save your user customizations
Add this version section to all new files. Otherwise, Little Navmap might reset the content.
Examples for backup files: little_navmap_mapstyle_backup_2.0.0.ini or little_navmap_mapstyle_backup.ini.
The file will be backed up and reset if you delete or change the version.
62.2. GUI
Only two user interface styles can be customized. These are Fusion and Night and can be found in
User Interface in the options dialog. These two styles are available on all operating systems.
Two files are generated that allow the customization for all window, button and dialog colors. These
are:
C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_fusionstyle.ini
C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_nightstyle.ini

The key names in these files are derived from the Qt palette options. Each key consists of the
group and role name separated by an underscore. See below for more information on the color
formats used.
See here for more information about groups [http://doc.qt.io/qt-5.6/qpalette.html#ColorGroup-enum] and roles
[http://doc.qt.io/qt-5.6/qpalette.html#ColorRole-enum].
62.3. Map Display
The file C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_mapstyle.ini allows to customize
various aspects of the map display and is currently limited to colors and pens. Most key names are
self explaining. See below for more information about color values.

62.3.1. Color Format
Color can be in one of these formats which are commonly used in web design:
each of R, G, B and A is a single hex digit. Each color value ranges from 00 - FF
(decimal 0-255)
#AARRGGBB first two digits contain the alpha/transparency value. 00 equals to fully tranparent
and FF (decimal 255) to opaque.
SVG color name
#RRGGBB

SVG color name is one of the colors defined in the list of CSS Colors
[https://www.w3schools.com/cssref/css_colors.asp]; for example, steelblue or gainsboro. Note that you cannot
enter an alpha channel value if you use a color name.
You can use the w3schools color picker [https://www.w3schools.com/colors/colors_picker.asp] to get the hex
values for a color.
Examples:
Active_Highlight=#308cc6
AlertFillColor=darkred
ApproachFillColor=#3060808a

62.3.2. Pen Format
A pen contains the following values in a comma separated list:
Color as described above
Pen width as a floating point value measured in pixels. You have to use . as decimal
separator no matter what your locale defines.
Pen style. One of the following values: Solid, Dash, Dot, DashDot and DashDotDot.
Examples:
RestrictedPen=#fd8c00, 2, DashDotDot
ModecPen=#509090, 2, Solid
NationalParkPen=#509090, 2.1, Solid

62.4. Icons
To change an icon download it from the GitHub source repository Icon Resources
[https://github.com/albar965/littlenavmap/tree/release/2.4/resources/icons] or extract the included file Little
Navmap/customize/icons.zip.
Modify the icon and save it into the settings directory C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel.
Little Navmap will automatically detect and use the icon on next startup.
The formats are limited to PNG, JPG, GIF and SVG (Scalable Vector Graphics (SVG) Tiny 1.2
Specification [https://www.w3.org/TR/SVGMobile12]) where advanced graphics effects like textures will not
work.
You can use the free vector drawing program Inkscape [https://inkscape.org] to edit SVG icons. Restart
Little Navmap to see the changes.
62.4.1. User, AI and Multiplayer Aircraft Icons
Default icons are included in file aircraft-icons.zip in installation folder customize.
All icons for user, AI/multiplayer aircraft, helicopters and ships are stored in the program but can
be overloaded by the user.
The icons are:
aircraft_boat.svg
aircraft_boat_ground.svg

aircraft_boat_ground_user.svg
aircraft_boat_user.svg
aircraft_helicopter.svg
aircraft_helicopter_ground.svg
aircraft_helicopter_ground_user.svg
aircraft_helicopter_user.svg
aircraft_jet.svg
aircraft_jet_ground.svg
aircraft_jet_ground_user.svg
aircraft_jet_user.svg
aircraft_online.svg
aircraft_online_ground.svg
aircraft_small.svg
aircraft_small_ground.svg
aircraft_small_ground_user.svg
aircraft_small_user.svg

Only used in X-Plane:
aircraft_carrier.svg
aircraft_carrier_ground.svg
aircraft_carrier_ground_user.svg
aircraft_carrier_user.svg
aircraft_frigate.svg
aircraft_frigate_ground.svg
aircraft_frigate_ground_user.svg
aircraft_frigate_user.svg

The suffixes are chosen by vehicle type, status (ground or airborne) and user or AI/multiplayer. The
icon is for airborne vehicles if ground is missing and for AI/multiplayer vehicles if user is missing. For
historical reasons all icons are prefixed with aircraft.
62.4.2. Userpoint Category Icons
Default icons are included in file userpoint-icons.zip in installation folder customize.
Icons for userpoint categories are stored in the program but can be overloaded by the user as well.
Default category icons can be overloaded with another icon by placing a file with one of the default
category names in the settings directory.
New categories can be added by placing a new icon adhering to a certain name pattern in the
default directory.
userpoint_Airport.svg
userpoint_Airstrip.svg
userpoint_Bookmark.svg
userpoint_Cabin.svg
userpoint_Closed.svg
userpoint_DME.svg
userpoint_Error.svg
userpoint_Flag.svg
userpoint_Helipad.svg
userpoint_Lighthouse.svg
userpoint_Location.svg
userpoint_Logbook.svg
userpoint_Marker.svg
userpoint_Mountain.svg
userpoint_NDB.svg
userpoint_Obstacle.svg
userpoint_Pin.svg
userpoint_POI.svg
userpoint_Seaport.svg
userpoint_TACAN.svg

userpoint_Unknown.svg
userpoint_VOR.svg
userpoint_VORDME.svg
userpoint_VORTAC.svg
userpoint_VRP.svg
userpoint_Waypoint.svg

The text between the first underscore _ and the .png ending defines the category. For example
userpoint_My Places.png creates a new category My Places.
Do not use special characters like / for categories. Only letters, digits, space, underscore and
dashes are allowed. Special characters like umlauts or accented characters are no problem.

63. Creating Map Themes
To add an arbitrary online or offline map to Little Navmap simply add the map directory from a
downloaded or self created map theme to the data\maps\earth directory.
Tip
Also check out the Little Navmap Support Forum at AVSIM [https://www.avsim.com/forums/forum/780-littlenavmap-little-navconnect-little-logbook-support-forum/], Little Navmap Downloads - Map Themes
[https://www.littlenavmap.org/downloads/Map%20Themes/] and LittleNavmapOFMTheme
[https://github.com/AmbitiousPilots/LittleNavmapOFMTheme] for more map themes.
The full path to the DGML file (see links below for more details about DGML) describing the map
must be ...\Little Navmap\data\maps\earth\opencyclemap\opencyclemap.dgml if you like to add the
OpenCycleMap [https://www.opencyclemap.org] for example. The DGML file can refer to an online map
service or included offline map data. Usually a map theme contains many more files than only the
DGML.
The menu View -> Theme in the main menu and the toolbar drop down box will receive an entry for
each additional map theme. Custom map themes are prefixed with a * in the drop down box and
with the word Custom in the menu.
The options Show Country and City Names and Show Hillshading are enabled for all additional map themes
but might not work depending on properties defined in the map’s DGML file.
More maps and information about map configuration and DGML files can be found here on the
Marble and KDE pages:
Download more maps for the Marble widget (only Earth maps are supported in Little
Navmap): Additional Maps [https://marble.kde.org/maps.php]
A tutorial that shows how to create a map theme based on tiled images:
Marble/CustomMaps [https://techbase.kde.org/Marble/CustomMaps]
A tutorial showing how to create a map theme based on OSM Slippy Maps
[https://wiki.openstreetmap.org/wiki/Slippy_map_tilenames]: How to create map themes based on OSM
slippy maps [https://techbase.kde.org/Marble/OSMSlippyMaps]
How to create a historical map for Marble: Historical Maps for Marble
[https://techbase.kde.org/Marble/HistoricalMaps]

64. Files
64.1. Logs
Log files of Little Navmap are stored in the directories:
Windows: C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_navmap.log
Linux: /tmp/abarthel-little_navmap.log
macOS: /var/folders/RANDOMIZED_DIRECTORY_NAME/abarthel-little_navmap.log
The program keeps three log files and rotates these if the file size of 10 MB is exceeded. So you
may find up to three logs:
abarthel-little_navmap.log, abarthel-little_navmap.log.1

and abarthel-little_navmap.log.2.

Send the log file abarthel-little_navmap.log if you like to report an error. All three are needed in some
cases but sending the first is often sufficient.
Please compress the log file using ZIP when sending per email.
64.2. Configuration
The files use the Windows-INI style that has groups in square brackets and key=value lines. See here
[https://en.wikipedia.org/wiki/INI_file] for more information about this type of configuration files.
All configuration files for my programs are stored in these directories:
Windows: C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel
Linux and macOS: $HOME/.config/ABarthel
little_navmap.ini: INI style configuration file. Text file.
little_navmap.history: The map position history. Binary file.
little_navmap.track: The user aircraft trail. Binary file.
little_navmap_profile.track: User aircraft trail for the elevation profile. Binary file.
Three more configuration files are created for customization of colors and styles:
little_navmap_fusionstyle.ini:

INI style configuration file for customizing the GUI colors of the

style Fusion.
little_navmap_nightstyle.ini:
little_navmap_mapstyle.ini:

As above but for the style Night.
INI style configuration file. Text file. Used for customization of the

map display.
See Customizing General for more information.
Note
Note that Little Navmap might reset these files when updated, but only after creating backup
files. This is usually mentioned in the change log.
64.3. Disk Cache
The disk cache that is used to store all the downloaded online map tile images can be found here:
Windows: C:\Users\YOURUSERNAME\AppData\Local\.marble\data
Linux and macOS: $HOME/.local/share/marble
You can delete the cache manually to save space if Little Navmap is not running.
64.4. Databases
Databases are stored in the directories:
Windows: C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_db
Linux and macOS: $HOME/.config/ABarthel/little_navmap_db

All these databases are SQLite [http://sqlite.org] files which can be viewed with e.g. DB Browser for
SQLite [https://github.com/sqlitebrowser/sqlitebrowser/releases] if you’re interested in relational databases.
Warning
Do not modify, move, rename or delete databases while Little Navmap is running.
Do not let the Navigraph FMS Database Manager update databases while Little Navmap is
running. Little Navmap might crash, the update might fail or remain incomplete.
64.4.1. Scenery Library
The number of files depends on which simulators you have installed and which scenery libraries
you’ve loaded.
The files are:
little_navmap_.sqlite:

An empty dummy database. Can be ignored.
Flight Simulator X
little_navmap_fsxse.sqlite: Flight Simulator - Steam Edition
little_navmap_p3dv2.sqlite: Prepar3D v2
little_navmap_p3dv3.sqlite: Prepar3D v3
little_navmap_p3dv4.sqlite: Prepar3D v4
little_navmap_p3dv5.sqlite: Prepar3D v5
little_navmap_msfs.sqlite: Microsoft Flight Simulator 2020
little_navmap_xp11.sqlite: X-Plane 11
little_navmap_navigraph.sqlite: Navigraph navdatabase. Can be either the included database or
an update installed by the Navigraph FMS Data Manager.
little_navmap_fsx.sqlite:

64.4.2. Userpoints
The file little_navmap_userdata.sqlite contains the user-defined waypoints.
Little Navmap creates a backup copy on startup and keeps up to four backup files:
little_navmap_userdata_backup.sqlite to little_navmap_userdata_backup.sqlite.3. You can copy these files
back to the original database little_navmap_userdata.sqlite if you did something wrong.
64.4.3. User Airspaces
The file little_navmap_userairspace.sqlite contains the user-defined airspaces read by using Load User
Airspaces.
It is backed up in the same way as the userpoints.
64.4.4. Logbook
The file little_navmap_logbook.sqlite is used to store logbook entries.
Little Navmap creates backup copies on startup and keeps up to four backup files as for the userdefined waypoints as described above.
64.4.5. Other Database Files
Additional files like
little_navmap_compiling.sqlite,
little_navmap_compiling.sqlite-journal,
little_navmap_temp.sqlite,
little_navmap_temp.sqlite-journal,
little_navmap_onlinedata.sqlite

or

little_navmap_onlinedata.sqlite-journal

are used by temporary processes like the database compilation or online network data. These can
be ignored.
64.5. Little Navmap Flight Plan File Format

LNMPLN files are flight plan files using the format specific to Little Navmap. They are in XML text
format and can only be interpreted by Little Navmap.
See XML (Wikipedia) [https://en.wikipedia.org/wiki/XML] for more information about this type of
configuration files.
The XML schema for validation can be found here: lnmpln.xsd
[https://www.littlenavmap.org/schema/lnmpln.xsd].
Order of elements does not matter. Missing elements will be logged as warning except optional
ones.
Flight Plan File Example. Documentation included as XML comments.

<?xml version="1.0" encoding="UTF-8"?>
<LittleNavmap xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="https://www.littlenavmap.org/schema/lnmpln.xsd">
<Flightplan>
<!-- Coordinates are always latitude and longitude in decimal/signed notation -->
<!-- ====== Header with metadata ====== -->
<Header>
<FlightplanType>IFR</FlightplanType>

<!-- IFR or VFR as set in user interface -

->
<CruisingAlt>30000</CruisingAlt>
<CreationDate>2020-09-11T18:05:15+02</CreationDate>
<FileVersion>1.0</FileVersion>
<ProgramName>Little Navmap</ProgramName>
<ProgramVersion>2.6.0.beta</ProgramVersion>

<!-- feet -->
<!-- Local time with timezone offset -->
<!-- File format version -->
<!-- Little Navmap version used for saving

-->
<Documentation>https://www.littlenavmap.org/lnmpln.html</Documentation>
<Description>Flight plan remarks</Description>
<!-- Remarks as entered in user interface
tab Remarks. -->
</Header>
<SimData>MSFS</SimData>
<!-- Use simulator and AIRAC if available -->
<NavData Cycle="2008">NAVIGRAPH</NavData> <!-- Use navdata and AIRAC -->
<!-- ====== Used aircraft performance ====== -->
<AircraftPerformance>
<FilePath>Normal Climb and Descent all Equal.lnmperf</FilePath>
<Type>BE51</Type>
<Name>Normal Climb and Descent</Name>
</AircraftPerformance>
<!-- ====== Departure parking position ====== -->
<Departure>
<Pos Lon="-120.538055" Lat="46.569828" Alt="1069.00"/>
<Start>PARKING 1</Start>
<!-- Name of position -->
<Type>Parking</Type>
<!-- Type of position. None, Airport, Runway, Parking or Helipad. ->
<Heading>5.1</Heading>
</Departure>

<!-- True heading of the position -->

<!-- ====== Departure and arrival procedures ====== -->
<Procedures>
<!-- SID and STAR are resolved by name and runway when loading -->
<SID>
<Name>WENAS7</Name>
<Runway>09</Runway>
<Transition>PERTT</Transition>
</SID>
<STAR>
<Name>PIGLU4</Name>
<Runway>16</Runway>
<Transition>YDC</Transition>
</STAR>
<!-- Approaches are resolved by either ARINC or the combination of Name, Runway, Type and
Suffix -->
<Approach>
<Name>TATVI</Name>
<!-- Optional approach name. Name of approach fix.
Requires ARINC if not given. -->
<ARINC>I16-Z</ARINC>
<!-- ARINC name of the approach -->
<Runway>16</Runway>
<!-- Approach runway. Not given for circle-to-land
approaches. -->
<Type>ILS</Type>
<!-- Optional approach type -->
<Suffix>Z</Suffix>
<!-- Optional approach suffix -->
<Transition>HUMEK</Transition>
<!-- Transition name if used -->
<TransitionType>F</TransitionType>
<!-- Optional Transition type -->
</Approach>
</Procedures>

<!-- ====== Alternate airports ====== -->
<Alternates>
<Alternate>
<Name>Penticton</Name>
<Ident>CYYF</Ident>
<Type>AIRPORT</Type>
<Pos Lon="-119.602287" Lat="49.462452" Alt="1122.00"/>
</Alternate>
<Alternate>
<Name>Grand Forks</Name>
<Ident>CZGF</Ident>
<Type>AIRPORT</Type>
<Pos Lon="-118.430496" Lat="49.015633" Alt="1393.00"/>
</Alternate>
</Alternates>

<!-<!-<!-<!--

Optional
Required
Optional
Optional

name -->
ident -->
type -->
position -->

<!-- ====== En-route waypoints including departure and destination ====== -->
<!-- The elements Ident, Type and Pos are required to resolve the waypoint in the database.
Region is optional and used for resolving if given.
Procedure waypoints are never included. -->
<Waypoints>
<!-- ====== Departure airport. Other waypoint types are allowed for flight plan snippets.
====== -->
<Waypoint>
<Name>Yakima Air Terminal/Mcallister</Name>
<Ident>KYKM</Ident>
<Type>AIRPORT</Type>
<Pos Lon="-120.543999" Lat="46.568199" Alt="1069.00"/>
</Waypoint>
<!-- ====== User defined waypoint ====== -->
<Waypoint>
<Name>User defined point</Name>
<Ident>USERPT</Ident>
<Region>K1</Region>
<Type>USER</Type>
<Pos Lon="-120.848000" Lat="47.676601" Alt="24960.89"/>
<Description>User waypoint remarks</Description>
<!-- Description as entered in user
interface -->
</Waypoint>
<!-- ====== Direct to waypoint ====== -->
<Waypoint>
<Ident>DIABO</Ident>
<Region>K1</Region>
<Type>WAYPOINT</Type>
<Pos Lon="-120.937080" Lat="48.833759" Alt="30000.00"/>
</Waypoint>
<!-- ====== Airway waypoints ====== -->
<Waypoint>
<Ident>IWACK</Ident>
<Region>K1</Region>
<Airway>J503</Airway> <!-- Airway leading towards this waypoint -->
<Type>WAYPOINT</Type>
<Pos Lon="-120.837067" Lat="48.932140" Alt="30000.00"/>
<Description>Waypoint remarks</Description>
</Waypoint>
<Waypoint>
<Ident>CFKNF</Ident>
<Region>K1</Region>
<Airway>J503</Airway>
<Type>WAYPOINT</Type>
<Pos Lon="-120.767761" Lat="49.000000" Alt="30000.00"/>
</Waypoint>
<!-- ====== Destination airport. Other waypoint types are allowed for flight plan snippets.
====== -->
<Waypoint>
<Name>Kelowna</Name>
<Ident>CYLW</Ident>
<Type>AIRPORT</Type>
<Pos Lon="-119.377998" Lat="49.957199" Alt="1461.00"/>
</Waypoint>
</Waypoints>
</Flightplan>
</LittleNavmap>

64.6. Aircraft Performance File Format
LNMPERF files are files containing aircraft performance files using the format specific to Little
Navmap. They are in XML text format and can only be interpreted by Little Navmap.

See XML (Wikipedia) [https://en.wikipedia.org/wiki/XML] for more information about this type of
configuration files.
The XML schema for validation can be found here: lnmperf.xsd
[https://www.littlenavmap.org/schema/lnmperf.xsd].
Order of elements does not matter. Missing elements will be logged as warning except optional
ones.
Aircraft Performance File Example. Documentation included as XML comments.
<?xml version="1.0" encoding="UTF-8"?>
<LittleNavmap xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="https://www.littlenavmap.org/schema/lnmperf.xsd">
<AircraftPerf>
<!-- ====== Header with metadata ====== -->
<Header>
<CreationDate>2020-11-16T22:43:35</CreationDate>
<FileVersion>1.0</FileVersion>
<ProgramName>Little Navmap</ProgramName>
<ProgramVersion>2.6.4.beta</ProgramVersion>
<Documentation>https://www.littlenavmap.org/lnmperf.html</Documentation>
</Header>
<!-- ====== Options ====== -->
<Options>
<Name>Epic E1000 G1000 Edition</Name> <!-- Aircraft name - free text -->
<AircraftType>EPIC</AircraftType>
<!-- Aircraft ICAO type which is matched to simulator
aircraft ICAO type -->
<Description>Climb: 80% torque, 1600 RPM, 160 KIAS, max ITT 760°
Cruise: FL260-FL280, 1400 RPM, adjust torque to 55 GPH fuel flow, max ITT 760°
Descent: Idle, 250 KIAS
https://www.littlenavmap.org</Description>
>
<FuelAsVolume>0</FuelAsVolume>
-->
<JetFuel>1</JetFuel>
between units in user interface.

<!-- Remarks as entered in user interface tab Remarks. -<!-- 0: Used fuel unit is lbs. 1: Used fuel unit is gal.
<!-- Indicator for fuel type needed when switching
Also checked for simulator aircraft. -->

</Options>
<!-- ====== Performance data. All values are either lbs or gallons depending on FuelAsVolume.
Speed is always TAS. Vertical speed is always ft/min. Fuel flow measure in unit per
hour. ====== -->
<Perf>
<ContingencyFuelPercent>5.0</ContingencyFuelPercent>
<ExtraFuelLbsGal>0.000</ExtraFuelLbsGal>
<MinRunwayLengthFt>1600.000</MinRunwayLengthFt>
<ReserveFuelLbsGal>500.000</ReserveFuelLbsGal>
<RunwayType>SOFT</RunwayType>
<!-- Either HARD (hard only), SOFT (hard and
soft),
WATER (water only) or WATERLAND (equals
to either WATER or SOFT) for amphib -->
<TaxiFuelLbsGal>20.000</TaxiFuelLbsGal>
<UsableFuelLbsGal>1900.000</UsableFuelLbsGal>
<Alternate>
<FuelFlowLbsGalPerHour>361.000</FuelFlowLbsGalPerHour>
<SpeedKtsTAS>302.000</SpeedKtsTAS>
</Alternate>
<Climb>
<FuelFlowLbsGalPerHour>464.807</FuelFlowLbsGalPerHour>
<SpeedKtsTAS>185.220</SpeedKtsTAS>
<VertSpeedFtPerMin>2479.589</VertSpeedFtPerMin>
</Climb>
<Cruise>
<FuelFlowLbsGalPerHour>361.000</FuelFlowLbsGalPerHour>
<SpeedKtsTAS>302.000</SpeedKtsTAS>
</Cruise>
<Descent>
<FuelFlowLbsGalPerHour>222.000</FuelFlowLbsGalPerHour>
<SpeedKtsTAS>201.000</SpeedKtsTAS>
<VertSpeedFtPerMin>2000.000</VertSpeedFtPerMin>
</Descent>
</Perf>
</AircraftPerf>
</LittleNavmap>

64.7. Obsolete Formats

These formats are not used anymore by Little Navmap as of versions 2.6 although, they can still be
loaded.
64.7.1. Aircraft Performance File Format (obsolete INI format)
The LNMPERF files are simple text files and use the Windows-INI style that has groups in square
brackets and key=value lines. See INI (Wikipedia) [https://en.wikipedia.org/wiki/INI_file] for more information
about this type of configuration files.
Speed units are always knots and feet per minute. Fuel units are gallons or lbs depending on the
value of FuelAsVolume. ContingencyFuelPercent is percent which will be added to trip fuel.
Description

has to be enclosed in double quotes. \n are interpreted as line feeds.

Note that comments starting with # or ; will be replaced when saving the file in Little Navmap. You
can add a dummy key like Comment1=my remarks to circumvent this. Unknown keys are not replaced
when saving.
Aircraft Performance File Example

[Options]
AircraftType=B732
Description="Engine type JT8D-15A\n\nClimb: 92% N1, 280/0.7\nCruise: 0.74\nDescent:
0.74,300\n\nhttps://example.com/dokuwiki/doku.php?id=boeing_737-200_reference"
FormatVersion=1.0.0
FuelAsVolume=false
JetFuel=true
Metadata=Created by Little Navmap Version 2.2.0.beta (revision 16944ce) on 2018 11 02T20:23:52
Name=Boeing 737-200
ProgramVersion=2.2.0.beta
[Perf]
ClimbFuelFlowLbsGalPerHour=10000
ClimbSpeedKtsTAS=350
ClimbVertSpeedFtPerMin=1500
ContingencyFuelPercent=0
CruiseFuelFlowLbsGalPerHour=4800
CruiseSpeedKtsTAS=430
DescentFuelFlowLbsGalPerHour=400
DescentSpeedKtsTAS=420
DescentVertSpeedFtPerMin=2500
ExtraFuelLbsGal=0
ReserveFuelLbsGal=6000
TaxiFuelLbsGal=500

64.7.2. Annotated Flight Plan File Format (obsolete)
Little Navmap uses the FSX/P3D XML (Wikipedia) [https://en.wikipedia.org/wiki/XML] flight plan format. The
XML standard allows to add comments in a file which are ignored by the simulators and by most
add-on programs.
The added comment is an XML comment starting with <!-- LNMDATA and ending with -->. Inside the
comment is a simple key/value list separated by | symbols.
Little Navmap stores metadata like version and date in the file which helps when reporting errors or
for future extensions.
The most important data is alternate airports and procedure information which allows the program
to restore SIDs, STARs, approaches and transitions in an error tolerant way when loading flight
plans.
Flightplan Example snippet

<?xml version="1.0" encoding="UTF-8"?>
<SimBase.Document Type="AceXML" version="1,0">
<Descr>AceXML Document</Descr>
<!-- LNMDATA
_lnm=Erstellt mit Little Navmap Version 2.2.1.beta (Revision 257538e) am 2018 11
05T20:20:11|
aircraftperffile=C:\Users\alex\Documents\Little Navmap\Boeing 737-200 JT8D-15A.lnmperf|
aircraftperfname=Boeing 737-200|
aircraftperftype=B732|
approach=LITSI|
approacharinc=D34|
approachdistance=11.9|
approachrw=34|

approachsize=9|
approachsuffix=|
approachtype=VORDME|
cycle=1811|
navdata=NAVIGRAPH
-->
<FlightPlan.FlightPlan>
...
</FlightPlan.FlightPlan>
</SimBase.Document>

65. Tips and Tricks
65.1. Show all Navaid Ranges of a Flight Plan

Select all legs in the flight plan table, then right-click on any leg and select Show Navaid Range
This will place a range ring around every radio navaid in the flight plan.

.

See also Add Navaid Range Ring.
Remove the range rings by right clicking onto the center and select Remove Range Ring from the
context menu.

65.2. Use the measurement lines to get a VOR Radial Intersection
Measurement lines can start at airports or navaids where they use the magnetic variation if
available. You can use them to find an airport by radial and distance if you like to navigate the old
fashioned way.
Below is an example that gets radial and distance from two VORs for ETUO. Measurement lines can
also start at NDBs or waypoints. Note the suffix °M which indicates magnetic course.
See also Measure Distance from here.

The same can be used when flying airways without GPS. In the example below fly 323 degrees
magnetic to VOR SFD (radial 143). You are at WAFFU when the DME shows 13.7 NM. Then turn left to
280°M until you intercept 302° to GWC.

65.3. Search for Add-On Airports
You can use the scenery path to look for add-on airports of a certain developer. Click on one of the
add-on airports and copy the relevant part of the path from the information window. Insert this
path fragment into the Scenery Path input field in the airports tab of the search dock window. Add *
at the beginning and at the end since it is only part of a path.
See also Text filters.
Select all in the result table to get all airports highlighted on the map.

65.4. Use the Search Function to plan a Round the World Trip
The spatial search function is useful to plan a round the world tour. Assume you’d like to go east:

1. Go to the dock window Search, right-click into the result table and select Reset Search
to
remove all search criteria that may affect the query.
2. Set your departure airport.
3. Right-click on your departure airport in the search or on the map and select Set Center for
Distance Search
. This is the center point for the spatial search.
4. Add any additional criteria in the search like lighted runways, procedures, fuel, minimum
runway length and more.
5. Click the checkbox before Distance, adjust the minimum and maximum distance and set
direction to East.
6. Select all in the result table to see the airports on the map.
7. Choose your next destination airport.
8. Add as destination.
9. Calculate plan.
10. Fly.
11. Back to 2. until you are done around the world.

Picture below shows a query result for airports in the east. Note that the black/yellow highlight
circles have tooltips too no matter if the airport is visible or not.

66. Appendix
66.1. Tips for old and slow Computers
66.1.1. Save CPU Cycles
Dialog Options -> Map -> Details while scrolling ...: Use Normal ...
Dialog Options -> Simulator Aircraft -> Simulator Aircraft scroll box size ...: Use a higher value
to reduce map updates.
Close the window Flight Plan Elevation Profile. It will stop all background processing when
closed.
Avoid airspaces. Switch them off using the
button on the airspaces toolbar.
Switch off all AI traffic in the dialog Connect. See Options.
Use the map projection Mercator. It consumes less resources since it can use the downloaded
image tiles as is and does not transform them to the spherical format.
66.2. Troubleshoot
See also Little Navmap - Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html].
Program crashes on start up: Use Reset all Settings and Restart to get a clean base in
case some settings cause problems. If that does not help: Delete the settings and the
database files. In Windows 7, 8 or 10 these can be found in
c:\Users\YOURUSERNAME\Appdata\Roaming\ABarthel. Delete (or better: rename or move) the files
little_navmap.ini, little_navmap.track, little_navmap.history and the directory little_navmap_db. Try
to delete the database first if these cause the problem. Then try to delete the settings files if
removing databases did not help.
** Program starts slowly:** This can happen if a distance search is enabled in one of the
search tabs. The search is executed at each start. Simply disable the distance search or
reset the search options to avoid the slow startup.
Online maps do not load or update: Check your firewall settings if Windows blocks any
outgoing connections. Also check if the offline mode was not enabled accidentally in menu
File. Check if Little Navmap can connect to the internet by going to the options dialog on tab
Weather. Use one of the buttons Test for NOAA or VATSIM weather. Little Navmap cannot
reach the internet if these fail.
Search shows no result or unexpected results: Check the drop down menu for the
change indicator * and the search fields for any remaining text if the distance search does
not give any or unexpected results. Use Reset Search in the context menu of the result table
or press Ctrl+R to clear all search criteria.
Search or flight plan tables shows strange column names like airport_id or others:
This can happen if the program is updated. Use Reset View in the context menu of the result
table.
The flight plan elevation profile has errors or invalid elevation data: The online
elevation data contains several known errors. Use the recommended GLOBE offline elevation
data. See Install GLOBE elevation data for information how to install the offline data.
OpenStreetMap shows a dark gray background on some places without hill shading
coverage (for example New Zealand). Use another map theme or switch off hill shading
for the OpenStreetMap.
Loading of the scenery database takes too long: Exclude scenery directories containing
only landclass, elevation data or other for Little Navmap irrelevant data. You can do that in
the Options dialog on the Scenery Library Database tab. See Select Paths to exclude from
loading.
Crash while loading the scenery library database: You can exclude scenery directories
in the Options dialog on the Scenery Library Database tab if loading of an add-on BGL causes the
program to crash. Do not restart the program after it shows the crash dialog and instead
load the log file which is typically C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-

little_navmap.log.

The path may vary depending on your Windows installation. Search for the
last line in the log-file that looks like:
[2016-10-14 22:58:21.903 default INFO ]

unknown: ==== "404 of 521 (77 %)" "APX41080.bgl"

Now search for APX41080.bgl and exclude the file or its directory from loading in the Options
dialog.
66.3. Known Problems
See also Little Navmap - Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html].
66.3.1. General
Some airport add-ons do not modify the stock airports but only add new scenery and
buildings. These add-ons will not be recognized as such and are therefore not highlighted on
the map (italic and underlined text).
Add-on developers have to use all kind of workarounds to avoid FSX or P3D limitations which
means the display and information given for add-on airports is not always correct. A lot of
these changes are also done to make AI behave properly. Typical examples are: Airports
without runways, airports with runway dimensions 0 by 0 ft or 0 ft runway width, taxiways
with 0 ft width, seemingly closed taxiways, duplicate airports, duplicate runways in water,
taxiways in water, military gates at civilian airports and more.
Some KML/KMZ files do not show up on the map. Adding a center point pushpin to the
KML/KMZ file can fix this.
Coverage for online elevation and OpenStreetMap hill shading data is limited and currently
ends at 60 degree north. Use the OpenTopoMap or Stamen Terrain map themes which have
world wide coverage for hill shading.
There are errors in the online elevation source data (like in northern Italy, Po Valley or Lake
Titicaca in Peru and Bolivia) which will show up in the flight plan elevation profile.
Magnetic declination is partially not set (for example VORDME Cambridge Bay YCB) or
inconsistent between airports an adjacent navaids. This is an error in the source data.
Airports are misplaced (for example Cabo San Lucas, MM15 in Mexico for FSX) compared to
the background maps. This is an error in the source data and cannot be fixed.
Procedures are drawn incorrectly in some cases.
The airport search attribute Procedures does not work correctly in the mixed database. It will
show only simulator airports having procedures instead of using the Navigraph airport
status.
Dock window layout in Little Navmap can change when resizing or maximizing window and
back.
Window is restored in normal state when changing from a maximized window to fullscreen
and back.
The window layout might not be restored precisely on startup in some cases.
The flight plan calculation might pop up shortly when starting the program.
The height of the elevation profile window cannot be reduced in some cases. Reset to default
window layout which fixes this. Rearrange or move the elevation profile window to another
position which usually solves this. Save the layout once you have a working one.
Zooming with touchpad or magic mouse does not work properly on macOS. Use the
navigation overlay or one of the other options on page Map Navigation in Options if you think it
is unusable.
66.3.2. Microsoft Flight Simulator 2020
Navdata updates are not read properly from the MSFS scenery library. This is in general no
issue since you can also update the navdata in Little Navmap with the Navigraph FMS Data
Manager to keep the program in sync with MSFS. Stock data is not affected by this.
You can set a parking spot or fuel pad as starting position in a flight plan but note that
runways and helipads as starting positions will be ignored by MSFS.
MSFS multiplayer and real-time AI cannot be displayed yet. These do not appear in the
SimConnect interface.
Simulator weather cannot be shown for MSFS since SimConnect weather functions are
deprecated and do not deliver data. Use NOAA weather which gives you the most up-to-date
weather reports.
MSFS seems to have no clear concept of scenery order (Content.xml seems unreliable) and
there is no information in the SDK about this. Add-ons are loaded by alphabetical order by
Little Navmap. To put an add-on to the end of the loading list add a z_ to the folder name,
for example.

Flight plan loading in MSFS has issues and does not produce any error messages if it fails.
Country names are missing in MSFS translation tables and are not available in Little
Navmap, therefore.
Add-ons using the .fsarchive encrypted format are not supported. Little Navmap will show
only the stock airport instead of the add-on if a package is locked down like this.
Some aircraft mods do not report correct fuel flow to work around simulator limitations. This
cannot be fixed in Little Navmap.
Some airports files like LEMG.bgl cannot be read due to unknown format. Little Navmap
reports Error: readInt for file "...OMITTED.../LEMG.bgl" failed. Reason 1. Exclude the airport file
from reading in options on page Scenery Library Database or simply ignore the message. The
stock LEMG and all other airports are not affected by this.
66.4. How to report a Bug
If something goes wrong send me any involved files like KML, PLN or BGL (if copyright permits),
Little Navmap’s log file and configuration file which both can be located in the about dialog. My email addresses are shown in the about dialog of Little Navmap as well.
Add all necessary information:
Operating system:
Windows: 7, 8 or 10
macOS: High Sierra, Catalina or Big Sur
Linux: which distribution and version
Simulator:
X-Plane: 11.40 or 11.50 version
FSX, FSX SE, P3D or MSFS including version
Navdata updates if scenery is affected
Add any flight plans or other files if involved in the error
Please add all steps that are necessary to reproduce the error.
If possible send me the log file.
Please compress log files using ZIP when sending by email.
When an error occurs during loading of the scenery library send me the offending file if size
permits. The full name and path of the file is shown on top of the error dialog if a specific is the
cause.
If you’re concerned about privacy when sending log files: The log files will contain all system paths
(like your Documents directory) which will also include your username as a part of the path. They
might also contain your computer’s name and IP address in your network.
I would suggest you remove this information if you’re concerned about it.
In no case are file names of anything but the flight simulator or its configuration files included. No
names or contents of personal files are included in the log files.
I strongly recommend sending the log files by private forum message or by email and not attach
them to forum posts where they are publicly visible.

67. Glossary
3D
X-Plane airport which contains at least one 3D object. May be a fully constructed major
airport.
Add-on airport
FSX/P3D: All scenery data that is found outside of the base flight simulator Scenery directory is
considered an add-on.
X-Plane: All airports in the Custom Scenery directory are considered add-on airports and will be
highlighted accordingly.
Approach Procedure
An approach procedure is a series of maneuvers for the transfer of an aircraft in instrument
flight conditions from the initial approach to a landing or to a point from which a landing may
be made visually. If a flight plan includes a standard arrival procedure (STAR), an approach
procedure will normally follow the STAR.
Arrival Procedure
Approach, transition or STAR procedure.
BGL
A binary file with the extension BGL which is part of a flight simulator scenery containing
airport, navaid or airway information. These files can also contain traffic, landclass, elevation
or other information which is not relevant for Little Navmap.
CSV
Comma-separated values text file.
DAT
A text file format used by X-Plane to store airport, navaid and procedure information.
Departure Procedure
SID (standard instrument departure) procedure.
DME
Distance measuring equipment or a radio navaid.
Empty airport
An airport that has no taxiways, no parking positions or gates, no aprons and is not an add-on
airport and is not a water airport.
FACF
Final approach course fix. A point aligned on the final approach course of an instrument
procedure.
FAF
Final approach fix. The point where the final approach segment begins on the instrument
approach.
Fix
This term refers to a waypoint, radio navaid or an calculated point on a procedure.
Flight Plan Position
An user-defined waypoint which is part of the flight plan.
FLP
Flight plan format used by the X-Plane FMS, Aerosoft Airbus and other add-on aircraft.
FMS
X-Plane flight plan format.
FS9
Flight Simulator 2004.

FSX
Flight Simulator X or Flight Simulator - Steam Edition.
ft
Feet. 0.3048 meter.
GIS
A geographical information system like Google Earth for example.
ILS
Instrument landing system.
Initial Fix
This is the first fix of a procedure.
MAP
Missed approach point. The point on the final approach which represents the termination of
the final approach and the start of the missed approach.
MSFS
Microsoft Flight Simulator 2020.
Navaid
VOR, VORTAC, TACAN, NDB or waypoint/intersection.
NDB
Non directional beacon - radio navaid.
NM
Nautical miles. 1.852 km.
P3D
Prepar3D v2 to v5.
Parking
GA ramp, cargo ramp, fuel box or gate at an airport.
PLN
FSX and P3D flight plan format. Can save all information in flight plans using annotations.
POI
Point of interest. An userpoint type.
Procedure
A STAR, SID or approach and the respective transitions.
Radio navaid
VOR, VORTAC, TACAN or NDB.
Rating
Airport zero to five star rating depending on facilities.
Scenery Library Database
This is an internal database (SQLite [http://sqlite.org]) that is created by Little Navmap when
reading all the flight simulator BGL or DAT files. It allows fast complex searches and map
display.
SID
A standard instrument departure is an air traffic control departure procedure that helps to
simplify clearance delivery procedures. A SID will keep aircraft away from terrain but it is
optimized for air traffic control route of flight and does not necessarily provide the best climb
gradient. It provides a balance between terrain and obstacle avoidance, noise abatement and
airspace management.
SimConnect
A programming interface that allows applications to read and write flight simulator
parameters.

STAR
A standard terminal arrival is a flight route that usually covers the phase of a flight between
the last point of the route filled in the flight plan and the first point of the approach to the
airport, normally the initial approach fix (IAF). A STAR connects the en-route phase with the
approach phase of the flight.
Start position
Used for departure in flight plans. Either runway, helipad, GA ramp, cargo ramp, fuel box or
gate.
TACAN
Tactical air navigation system - radio navaid used by military aircraft.
TOC
Top of climb.
TOD
Top of descent.
VOR
VHF omni directional radio range - radio navaid.
VORDME
VHF omni directional radio range with distance measuring equipment- radio navaid.
VORTAC
Co-located VHF omnidirectional range (VOR) beacon and tactical air navigation system
(TACAN) beacon.
Userpoint
An user-defined waypoint like a bookmark, point of interest or visual reporting point (VRP).
UTC
Universal coordinated time. Also: Greenwich time or zulu time.
VRP
Visual reporting point for VFR flights. An userpoint type.
Waypoint
Navaid defined by coordinates.

68. License
This program is free software: you can redistribute it and/or modify it under the terms of the GNU
General Public License as published by the Free Software Foundation, either version 3 of the
License, or (at your option) any later version.
This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
See the GNU General Public License for more details.
You should have received a copy of the GNU General Public License along with this program. If not,
see http://www.gnu.org/licenses [http://www.gnu.org/licenses/].
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