


Little Navmap User Manual

Little Navmap is a free open source flight planner, navigation tool, moving map, airport search
and

airport information system for Flight Simulator X, Flight Simulator - Steam Edition, Prepar3D
v3 to v5,

Microsoft Flight Simulator 2020, X-Plane 11 and X-Plane 12.

More about my projects at www.littlenavmap.org [https://www.littlenavmap.org].
Support forum at AVSIM

[https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/].

You can get the latest version of this manual in different formats from here:
User Manuals

[https://albar965.github.io/manuals.html]

Do not use this program for real world navigation.

This user manual is for Little Navmap versions 2.8.
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3. Installation

Little Navmap for Windows is available as a 64-bit or 32-bit application and was tested with
Windows

10 and Windows 11. You can download either an installer package or a Zip-archive.

Apple macOS is supported from macOS High Sierra 10.13 or later.
You need Rosetta to run Little

Navmap on Apple Silicon / M1 computers with the
exception of Little Xpconnect which is available as a

native X-Plane plugin.

Linux versions built on recent Ubuntu releases are available and should work on other distributions as

well.

Each version of Little Navmap and the other programs come with a plain text file CHANGELOG.txt
which

has important notes and describes the changes between versions.

Warning

Do not install Little Navmap in the MSFS folder Community or in the X-Plane plugins folder.

Important

Apple macOS users: Keep in mind that you have to clear the quarantine flag for Little Xpconnect

on update. See
Clearing the Quarantine Flag on macOS.

3.1. Updating

Delete all installed files of a previous Little Navmap version before
installing a new version or install

into a new folder.
All files from the previous ZIP archive can be deleted since settings are stored in

separate directories.

Warning

In any case do not merge the installation directories since old files can cause problems.

There is no need to delete the old settings directory. The program is
written in a way that it can work

with old setting files and adapts these if needed. In some cases
settings are reset to default if an

updated version is installed.

See Files for more information about settings, database and cache files.

3.2. Windows

3.2.1. Builds

There are two builds of Little Navmap and Little Navconnect for Windows available:

Windows 64-bit: For MSFS and all X-Plane versions. Download file is LittleNavmap-win64-

2.8.2.zip for example.

Windows 32-bit: For FSX and Prepar3D. Download file is LittleNavmap-win32-2.8.2.zip for

example.

You can see the Windows build type in About Little Navmap and in the Window Title (64-bit or 32-bit).

Note that Little Navmap and all related programs are inter-operable across the network (Little Navmap

and Little Navconnect)
as well as the X-Plane plugin (Little Navmap, Little Navconnect and Little

Xpconnect).



Also both versions share the same settings and databases. You can switch from one version to another

without problems.

3.2.2. Installer

You can use the self-installing package based on Inno Setup [https://jrsoftware.org/isinfo.php] to install Little

Navmap on your computer.
The installer packages are named LittleNavmap-...-Install.exe and contain

the same programs and files as the Zip archives.

The installation process always installs the program for all users in a protected directory like C:\Programs.

You can manually select another directory but I recommend to leave the default location.
Both the 32-

bit and the 64-bit versions can be installed in parallel.

There is no need to uninstall the program when updating.
The installation process automatically detects

the last selected directory and overwrites the current installation.

File types can optionally be associated with Little Navmap which allows to load a flight plan by double

clicking on a LNMPLN file in Windows Explorer, for example. Little Navmap is either started or an

already running
instance is used to load the flight plan.

If both the 32-bit and the 64-bit versions are installed, the last installed version is associated to the file

types.
Change the association manually in Windows Explorer if needed.

Start menu entries for all included programs as well as the most important files and links are created.

Note

There is no need to install or modify any files in the installation folder for the
webserver or map

themes.

See Web Server for information how to change the root folder and
Map Themes for information how

to set the map theme folder and how to install additional map
themes.

3.2.2.1. Uninstall

You can uninstall Little Navmap by right clicking on the icon in the Windows start menu and selecting

Uninstall.
Alternatively uninstall Little Navmap from Windows settings or control panel.

The uninstaller asks to optionally delete all settings and databases created by Little Navmap after

removing the main program.
Files in directories like Documents\Little Navmap are not deleted.

Warning

Note that this step also removes the userpoint database as well as the logbook and cannot be

undone.

The two folders which can be deleted are:

Settings and databases: C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel

Online map cache: C:\Users\YOURUSERNAME\AppData\Local\.marble\data\maps\earth

3.2.3. Manual Installation

The manual installation of Little Navmap does not change or create any registry entries
in Windows and

involves a simple Zip extraction of files.

Important

Do not extract the archive into the directory c:\Program Files\ or
c:\Program Files (x86)\ since this

requires administrative
privileges. Windows keeps control of these directories, therefore other

problems might occur like replaced or deleted files.

https://jrsoftware.org/isinfo.php


There is no need to run Little Navmap as administrator.
Adapt folder permissions if you have to

export flight plans to protected places.

Extract the Zip archive into a directory like C:\Users\YOURNAME\Documents\Little Navmap or

C:\Users\YOURNAME\Programs\Little Navmap.
Then start the program by double-clicking littlenavmap.exe. The

extension .exe might be hidden in Windows Explorer depending on
settings. In that case look for a file

littlenavmap having a light
blue globe icon .

File types have to be manually associated to Little Navmap when using this installation method. Use

Windows Explorer or
another file manager used on your operating system to do this.

3.2.3.1. Uninstall

Simply remove the program folder.
See Files for more settings, cache and database folders if you’d like

to completely remove Little Navmap.

3.2.4. SimConnect

Little Navmap comes with a SimConnect library and
does not require a separate installation of

SimConnect.

3.2.5. Unblock Application

Depending on system and anti-virus settings it might be needed to unblock the executable files.
This

applies to Little Navmap (littlenavmap.exe), Little Navconnect (littleconnect.exe) and the Little Xpconnect

plugin (win.xpl).

You can do this in the Windows explorer by selecting properties and checking Unblock file.
Detailed

instruction can be found here, for example:
How to Unblock a File in Windows 10

[https://mywindowshub.com/how-to-unblock-a-file-in-windows-10/].

3.2.6. Improve Start-up Time

Anti-virus programs can significantly slow down the startup and execution
of the program on Windows.

Therefore, it is recommended to exclude the following directories from
scanning:

Disk cache for map tiles:
C:\Users\YOURUSERNAME\AppData\Local\.marble\data

Scenery library and userpoint

databasesC:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_db

These directories do not contain executable files and are accessed
frequently by Little Navmap.

3.3. macOS

Extract the ZIP file and copy the Little Navmap application to the
directory Applications or any other

directory.

Note

The menu entry which is referenced as Tools -> Options in this manual
for Windows and Linux
can be

found in the application menu at Little Navmap -> Preferences on macOS.

3.3.1. First Start on macOS

Note on first start on macOS: When starting the application you will
get a message Little Navmap is from

an unidentified developer. Are you sure you want to open it?.

https://mywindowshub.com/how-to-unblock-a-file-in-windows-10/


The procedure may be slightly different depending on whether you’re using Big Sur or Catalina.

1. Right or Ctrl-Click in the Finder on Little Navmap and select Open.

2. You will see a dialog Little Navmap cannot be opened because it is from an unidentified developer. Click

Ok.

3. Go to System Preferences -> Security and Privacy. You will see a message mentioning
Little Navmap.

Click Open Anyway.

4. Next a dialog Are you sure you want to open it? pops up. Click Open.

3.4. Linux

Extract the archive to any place and run the executable file
littlenavmap to start the program from a

terminal:

./littlenavmap

Most file managers will start the program if double-clicked.

A desktop file Little Navmap.desktop is included.
You have to adjust the paths to use it. You must use

absolute paths in the desktop file.

See the Little Navmap - Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html] for help if the

program does not start.

3.5. Additional Programs

The Little Navmap Zip archive contains two additional
folders:

Little Navconnect: A complete copy of the program allowing remote
flight simulator connections for FSX,

P3D, MSFS and X-Plane.

Little Xpconnect: This is the 64-bit plugin that is needed for
Little Navmap or Little Navconnect to

connect to X-Plane. See Little Xpconnect for installation and usage.

3.6. X-Plane Plugin

Little Navmap can only connect to X-Plane using the Little Xpconnect
X-Plane plugin which has to be

installed as well.

The Little Xpconnect plugin is included in the Little Navmap archive. You can always find the
correct

and matching version in your Little Navmap installation directory.

See Little Xpconnect for installation and usage.

3.7. Portable Execution

Running Little Navmap in portable mode instructs the program to place all settings, databases and

cached files into the installation directory (i.e. the directory containing the executable file).
No folders

or files are created on the computer running the program from a memory stick, for
example.

You can also use the portable mode to test new Little Navmap releases without affecting your
current

settings.

Scripts allow to run Little Navmap in portable mode by passing certain command line options to the

program:

Windows: Little Navmap Portable.cmd

macOS: Little Navmap Portable.command

Linux: Little Navmap Portable.sh

Three folders are created when running these scripts: Little Navmap Cache for the online map image tiles,

Little Navmap Logs for log files and Little Navmap Settings used to store settings and databases.

See Command Line Options for more information.

https://albar965.github.io/littlenavmap-faq.html


3.8. Multiple Installations

Do not run more than one Little Navmap instances using the same settings folder in parallel. This
can

result in crashes when accessing the databases.
Running several instances is prevented by the program

on Windows but not on Linux and macOS.

You can instruct Little Navmap to create and use a different settings folder by passing the
parameter --

settings-directory to the executable when starting up. This is supported for all operating systems.

This parameter instructs the program to use the given directory instead of ABarthel
and allows to have

two instances of Little Navmap running with their own settings
and databases.

Note that this does not override the full path and spaces are replaced with underscores.

Example:

How to use C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel-XP as a settings folder on Windows:

1. Right click on the littlenavmap.exe file (extension might be hidden in Windows explorer) and

select Create Shortcut.

2. Right click on the newly created shortcut and edit the shortcut properties.

3. Append --settings-directory ABarthel-XP to the path in the settings field separated by a space

before --settings-directory.

4. Click Ok.

Contents of the link properties dialog for the example above. Extended target folder input field to have the whole path

visible.



4. Start

This page opens automatically in your browser after updating or first installation of Little

Navmap
and is a part of the Little Navmap online manual.

It gives valuable links and information for first time users and provides a list of first steps.

Other chapters helpful for beginners:

Installation

User Interface

Tutorials

See also User Aircraft Centering for general information about centering the aircraft during flight, as

this feature can be confusing to new users.

The chapter Main Menu and Toolbars explains all main menu items. You can navigate through the

menu structure in the user manual contents
on the left.
Note that most toolbar items have an

equivalent in the main menu.

Context menus are an important element in Little Navmap.
All context menus and items are

explained in the following chapters:

Context Menu Map

Context Menu Flight Plan

Context Menu Search

Context Menu Procedures

Tip

Explore the chapters on the left side of this page or use the search function on the top left.

4.1. First Steps

Little Navmap shows a several dialog windows on first start to give hints for better usage. You can

dismiss these dialogs
for future starts by pressing Do not show again but keep at least the message in

mind. Make all the dismissed dialog windows reappear by selecting Reset all Messages in the menu

Tools if you need them.

Tip

If you’d like to use a dark mode when flying: Enable this in menu Window -> Styles -> Night
The

darkness of the map window can be adjusted in options on page Map Display User -> Map dimming in

night style.
See Style.

4.1.1. Preparing

4.1.1.1. Files and Directories

The program suggests to create a recommended directory structure on startup. You can choose to

ignore this
and save your Little Navmap files in arbitrary places. The program does not require a fixed

directory structure for its files.

See Directories for more information.

You can also create the directories manually later by selecting menu Tools -> Create Directory

Structure.



4.1.1.2.  Load Scenery Library

Little Navmap will copy and prepare the included Navigraph database on the first startup.

The first dialog window pops up automatically. You have to load the scenery library first to see the

airports of your simulator.
Select your simulator and click Load.
Note that the loading process runs in

background and the connection dialog window pops up immediately.

Go to main menu Scenery Library and select Load Scenery Library or click  on the toolbar
to load

the scenery library database manually later.

Also have a look at Scenery Library Menu, Load Scenery Library and Navigation Databases about the

different
scenery library modes which can be selected in the menu.

4.1.1.3.  Connect to Simulator

The connect dialog window pops up next and allows to attach Little Navmap to your flight simulator.

Choose your simulator and click Connect.

Go to main menu Tools -> Flight Simulator Connection or click  on the toolbar to do this manually.

See Connecting to a Flight Simulator for more information.
The included Little Xpconnect plugin has to

be installed for X-Plane.

4.1.2. Building a Flight Plan

This quick introduction shows only one of many ways to build a flight plan and select departure and

destination airports.

1. Right click into the map on an airport and select departure ( Set as Departure),
destination ( Set

as Destination) and intermediate
waypoints ( Add Position to Flight Plan and Append Position to

Flight Plan) from the context menu.

2. Save the flight plan into Little Navmap’s own format LNMPLN by clicking Save Flight Plan.
This

file format is only for Little Navmap and allows to keep all flight plan features like remarks,

departure as well as arrival runways and more. Do not try to load it into simulators or other

tools.

3. Configure the flight plan export in menu File -> Multiexport Flight Plan Options.
Select desired

formats by clicking one or more checkboxes on the left and adapt the paths and filenames
for

export. See Flight Plan Multiexport.

4. Select File -> Multiexport Flight Plan to export the flight plan for your simulator, tools or
aircraft.

5. You probably see a few warning messages in Little Navmap about missing aircraft performance

information. Ignore these for now.

See also in the menu Help -> Tutorials if you’re new to Little Navmap.

See here Tutorial - Creating an Aircraft Performance Profile for an tutorial which shows how to create

your own aircarft
performance files or download one here:
Little Navmap Downloads - Aircraft

Performance [https://www.littlenavmap.org/downloads/Aircraft%20Performance/].

4.2. How to run a Network Setup

You can connect Little Navmap running on another (or remote, networked) computer to Little

Navconnect running on the flying computer. This setup is helpful if you do not have a separate
screen

available on your flying computer but a spare old notebook or computer.

The remote computer does not need a simulator installation and there is no need to share the
scenery

library of the simulator.

https://www.littlenavmap.org/downloads/Aircraft%20Performance/


The programs are inter-operable which means that you can connect Little Navmap from a Linux or

macOS computer to Little Navconnect on a Windows computer. The same applies to 32-bit and 64-bit

versions.

See Network Setup on information how to set up a remote/networked connection.

4.3. Recommended things to do after Installing

The elevation data which is used by default is limited and inaccuracies.
Therefore, I recommend

to download and use the offline
GLOBE elevation data. See Install GLOBE elevation data for

more information.

Have a look at Tutorials if you use the program the first time.

See Install Navigraph
Updates [https://albar965.github.io/littlenavmap_navigraph.html]
on my home page for

information how to update Little Navmap’s
navigation data.

4.4. Useful Links

Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html].

Little Navmap Downloads - Aircraft Performance and more [https://www.littlenavmap.org/downloads/].

New Maps for Little Navmap at Avsim [https://www.avsim.com/forums/topic/627225-new-maps-for-lnm-updated/].

Little Navmap related projects and more at www.littlenavmap.org [https://www.littlenavmap.org].

Support forum at AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/].

The sources of this manual are available on GitHub [https://github.com/albar965/littlenavmap-manual].

https://albar965.github.io/littlenavmap_navigraph.html
https://albar965.github.io/littlenavmap-faq.html
https://www.littlenavmap.org/downloads/
https://www.avsim.com/forums/topic/627225-new-maps-for-lnm-updated/
https://www.littlenavmap.org/
https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/
https://github.com/albar965/littlenavmap-manual


5. Quick Overview

Click images to enlarge.

5.1. Functions

A quick overview of Little Navmap showing the most important functions.



A quick overview of Little Navmap showing configuration options and aircraft progress.

5.2. Context Menus

Little Navmap makes extensive use of context menus, which are used on the map, on the flight plan

table and search result tables.

See also Context Menus.



The most important context menus which are can be used to build a flight plan, navigate the map or show information.

Image based on Little Navmap 2.4.5.

5.3. Help

There are many ways to get help in Little Navmap. The help menu links to the most important
online

pages as well as the included user manual.

Hove the mouse cursor above a button or input field to get help in form of tooltips (small pop up

windows).

See also Tooltip Help, Help Buttons and Help Menu.



Where to get help and more information. Tooltips, status bar and help buttons marked red.
Image based on Little Navmap

2.4.5.



6. User Interface

6.1. Terms

Button is used for buttons or other texts from the Little Navmap user interface.

Menu -> Sub-menu -> Menu Item denotes paths through the main menu or a context menu.

See Glossary for terms.

6.2. File Associations

The Windows Installer optionally creates file associations for Little Navmap’s own file types as well as

often used flight plan types.

This means you can double click a LNMPLN, PLN or FMS file in Windows Explorer and Little Navmap is

either started or an already running
instance is used to load a flight plan or another file.

This works on all supported operating systems. All you have to do is assign Little Navmap to a file

extension or a file type.
The actual process can differ across operating system and Linux desktop.

See Command Line Options for more information.

6.3. Dock Windows

See the chapter Dock Windows for more information about using dock and floating windows.

6.4. Tabs

See Tabs for information about the context menu and how to configure and arrange tabs.

6.5. Toolbars

Toolbars are also movable by clicking on the left handle and can also be
closed or detached from the

main window similar to the dock windows.
Toolbars can also be opened and closed in the main menu

Window.

All toolbars have a right click context menu where different toolbars can be shown or hidden.

A toolbar gets an overflow button >> on the right side if it is too long to show in the main window. Click

>> to see the remaining buttons.

Moving a toolbar into a new position.



Moving a toolbar into a new vertical toolbar at the left side of the main window.

The main window it too small to show the whole toolbar. Clicking the overflow button >>.

Note

Use the Window menu in the in the main menu to save, load or restore
windows, toolbars and tabs

layouts.

The menu item Reset Window Layout in the menu Window can be used to reset the state and position

of all dock
windows and toolbars back to their default.

6.6. Statusbar

The statusbar at the bottom of the window displays various information.
Shown or hide it in the menu

Window -> Statusbar.
See chapter Statusbar for more on the shown information.

6.7. Disabled Buttons and Menu Items

Menu items, buttons, toolbar buttons and other controls are disabled (i.e. grayed out) if their function

is not applicable. The
aircraft center button on the toolbar is disabled when Little Navmap is not

connected to a simulator or the
Remove all Range Rings menu item is grayed out if there are no range

rings to delete, for
example.

6.8. Warning and Error Messages

Little Navmap shows error messages with white text on red background
for problems with the

aircraft performance, top of descent/climb
calculation or other issues.

Tooltips on these error messages give more help in most cases.
Click these messages or hover the

mouse cursor above to see more information.

Orange warning messages show hints about less severe issues.



These message are shown in the Statusbar, Flight Plan Table fields,
Error Messages Footer, Tab

Progress, Connect Dialog and other places.

A red error message in the flight plan footer and a orange warning message in the flight plan fuel report.

6.9. Tables

The header of table views allows the following manipulation:

Click on the top left corner of the column header: Select all result rows.

Click on a column header: Sort ascending or descending (only for search result tables - not

for flight plan table).

Click and drag on the column header: Change column order.

Double-click on column border: Automatically fit column size to content.

Click and drag on column border: Change column width.

Click into the empty space below all rows: Deselect all entries and remove highlights on the

map.

The above applies to most table views in the program and partially also
to the tree view of the

procedure search.

The program saves the sort order, column widths and positions until
Reset View is selected in the related

context menu.

Table header of the flight plan table with tooltip.

6.10. Trees

Some configuration dialogs uses a tree element. You have to click on the small right pointing arrow (►

or +
depending on operating system and user interface style) to open a branch with options.

Select checkboxes on the left to enable or disable features. Explanations are given in the right column.

You can also click on the small checkbox in the branch root to select or unselect all elements of the

branch.



Tree for flight plan table display configuration. Shows tooltip for cut off explanation.
Branch checkbox for Flight Plan

Table Header is selected and indicates all items in branch enabled.

6.11. Context Menus

Context menus (or right-click menus) are an important element in Little Navmap to build flight plans or

get information and
can be found in the following places:

Toolbars: Toolbars

Tab Bars: Tabs

Map display window: Context Menu Map

Flight plan table: Context Menu Flight Plan

Airport, navaid and other search result tables: Context Menu Search

Procedure search tree: Context Menu Procedures

Elevation Profile: Context Menu Elevation Profile

Aircraft Progress: Tab Progress

Multiexport Flight Plan Options: Flight Plan Multiexport.

The context menus provide functionality to get more information about an
object at the clicked position

or to build or edit a flight plan.

6.12. Menu Buttons

Menu buttons  provide dropdown menus on click. These are used in the Search and Flight Plan

Route Description windows, for example.

6.13. Tooltip Help, Help Buttons and Help Menu

The help menu of Little Navmap contains links to the online help, an
included offline help PDF

document, online tutorials and the map legend.

The program uses tooltips to provide help or to display more information on buttons and
other controls.

Tooltips are small labels which pop up if you hover the mouse above a control like
a button or text edit

field.

A more detailed description is also shown on the left side of the Statusbar
if you hover the mouse over

a menu item.

Almost all dialogs and dock windows have buttons which are labeled Help or use the icon .
Clicking

these will open the corresponding sections of the online manual.

6.14. Window Title

The main window title shows the following information:

1. Application name

2. Version

3. Build type (for Windows only): 64-bit (use this with MSFS and all X-Plane versions) or 32-bit (use

this with FSX and P3D).

4. Selected simulator scenery library database (FSX, FSXSE, P3DV3, P3DV4, P3DV5, MSFS, XP11 or XP12) and

AIRAC cycle if available. In parentheses if not used.



5. Selected navigation database (Navigraph: N) and AIRAC cycle. In parentheses if not used.

6. Loaded flight plan file name plus a * if changed. Only * is shown if plan was not saved yet. Flight

plan will be auto-restored on next startup.

7. Loaded aircraft performance file a * if changed.

8. Selected online network connection if used.

The AIRAC cycle is shown as a four digit number after the simulator and Navigraph database
indication

if available and if a database is selected.

The AIRAC cycle is only shown for X-Plane and Navigraph databases. Other simulators do not
provide

cycle information in their scenery libraries.

A N will be appended if the Navigraph database is used. Otherwise (N) is used. Example
below for

Prepar3D:

P3DV5 / (N): All features on the map and all information in dialogs and
windows come from the

flight simulator database. Navdata might be limited depending on simulator.

P3DV5 / N: Airports and ILS are shown and used from the flight
simulator database. Navaids,

airways and procedures are
used from the Navigraph database.

(P3DV5) / N: All data is used from the Navigraph database. No
aprons, no taxiways and no

parking positions are available for
airports.

See Scenery Library Menu, Load Scenery Library and Navigation Databases for more information.

Examples:
Little Navmap 2.6.8 64-bit - XP11 2001 / N 2011 LOAG_LOWW.lnmpln * - PA30 Twin Comanche.lnmperf -

VATSIM

Version 2.6.8, new 64-bit Windows build, X-Plane selected with AIRAC cycle 2001, Navigraph database

in use with AIRAC cycle
2011, flight plan LOAG_LOWW.lnmpln changed and performance profile PA30 Twin

Comanche.lnmperf unchanged. Connected to VATSIM network.

Little Navmap 2.6.4.beta - (XP11) / N 2012 IFR Frankfurt Am Main (EDDF) to Fiumicino (LIRF).lnmpln - PA30 Twin

Comanche.lnmperf *

Version 2.6.4.beta (a test version), X-Plane not selected - using Navigraph only, Navigraph database in

use with AIRAC cycle
2012, flight plan unchanged and performance profile PA30 Twin Comanche.lnmperf

changed.

Little Navmap 2.6.5.rc1 32-bit - FSX 2012 / (N) - *

Version 2.6.5.rc1 (a release candidate), 32-bit version as required for FSX, FSX selected, not using

Navigraph,
no flight plan loaded and new and empty default performance profile loaded.

6.15. Information and Simulator Aircraft Text

You can change the text size permanently in the options dialog for these
windows. See options dialog

on page Display and Text.

This page also allows to change the font for the whole program interface.

Tip

A quick way to change the text size is to use the mouse wheel and
Ctrl key. This setting won’t be

saved across sessions, though.

6.16. Activating and raising Windows and Tabs

Little Navmap opens and raises dock windows and tabs for certain
actions like File -> New Flight Plan

or Aircraft ->
Open Aircraft Performance to avoid confusion for new users. This
behavior can be

disabled in the options dialog on tab User Interface
by disabling the option Raise related windows on

actions. Show flight plan after opening file, for example..



6.17. Tear off Dropdown Menus

Toolbar buttons with a drop down menu and other buttons like Flight Plan Route Description allow to

tear off the menu
by clicking on the dashed line on top of it.

This will move the menu into a separate window and allows to quickly change several options at once.

The state of the tear off menus is not saved.

The drop down menu button for the userpoint categories for map display and
how the menu can be teared off into its own

window.

6.18. Copy and Paste

Almost all dialogs, text labels and all information windows in Little
Navmap allow to copy and paste the

formatted text to the clipboard.

You can select the text using the mouse and then either use Ctrl+C
or the context menu to copy it to

the clipboard.

The table views for the flight plan or airport/navaid search results
allow copying of the results in CSV

format to the clipboard which can be
pasted into a spreadsheet program like LibreOffice
Calc

[https://www.libreoffice.org] or Microsoft Excel.

6.19. Translation and Locale

Little Navmap is currently available in several languages,
although not all translations are complete.

Your system language is used if supported. Otherwise Little Navmap falls back to English.
The language

for the user interface can be change in Options on page User Interface.

I will happily support anybody who would like to translate the user
interface or manual into another

language. Language packages can be
added to a Little Navmap installation later once they are

available.
See
Translating [https://github.com/albar965/littlenavmap/wiki/Translating]
in the GitHub Little Navmap wiki

for more information.

Despite using the English language in the user interface the locale
settings of the operating system will

be used. So, e.g. on a German
version of Windows you will see comma as a decimal separator instead

of
the English dot.

The language and locale settings can be forced to English in the dialog
Options on the page User

Interface.

https://www.libreoffice.org/
https://github.com/albar965/littlenavmap/wiki/Translating


6.20. Map Legend

The legend explains the Map Display and the
Elevation Profile symbols. It is available in Legend.

6.21. Airport Rating

Airports get a zero to five star rating depending on facilities which is shown in airport search, map

tooltips and the information window.

Airports that have no rating will be displayed
using a gray symbol below all other airports on the map

(Empty Airport). This behavior can be switched off in the
Options dialog on the page Map.

This helps to avoid airports with no scenery elements.

The criteria below are used to calculate the rating. Each item gives one
star:

1. Add-on (or 3D for X-Plane)

2. Parking positions (ramp or gate)

3. Taxiways

4. Aprons

5. Tower building (only if at least one of the other conditions is met).

All airports that are not located in the default Scenery directory
of FSX/P3D or are located in the Custom

Scenery directory of X-Plane
are considered add-on airports which raises the rating by one star.

Airports having the 3D label in
X-Plane are 3D airports which raises the rating by one star too.

All additional airports in MSFS Community and Official directories are considered add-on.
Star airports in

Microsoft Flight Simulator 2020 will always get a five star rating.

Add-on airports are highlighted on the map with a yellow ring which can be disabled
in the options

dialog on page Map Display.

Using emphasized (bold and underlined) text highlights add-on airports in the search result table,
flight

plan table, information windows and map tooltips.



7. Dock Windows

The user interface of Little Navmap consists of a main window and
several dock windows which can be

detached from the main window or
arranged within the main window.

The docked windows can be moved around in their docked position and can
be detached from the main

window by simply dragging them outside of the
main window (click the title bar to drag), by double-

clicking their
title bar or by clicking on the window symbol on the top right.

Double click on the docked window’s title bar or click on the window
symbol again to move the windows

back into their docked position
in the main window.

All docked windows, except the map window, can be closed if they are not
needed. You can also drop

docked windows on each other to create a
tabbed view. The tabs will appear at the bottom of the dock

stack in
this case.

Note that related dock windows open automatically when selecting functions like
Show Information or

clicking on the user aircraft, for example.

You can save and load dock window layouts in the Window menu. See also Window Layout for
details.

Dock window related menu items in menu Window :

Keep in Foreground

Show all floating Windows

Allow Window docking

Allow Dock Window moving

Show Dock Window Title Bars

More dock window settings like auto activation on mouse over can be found in the options
on page

User Interface.

Tip

Hold Ctrl while clicking on the window title bar to prevent a window
from going back into the docked

state in the main window and keep it
floating.

You can also deselect Window -> Allow Window docking in the main menu to prevent the dock
windows

from snapping back into the main window.

Note

Use the Window menu in the in the main menu to save, load or restore
closed windows, toolbars and

tabs.

The menu item Reset Window Layout in the menu Window can be used to reset the state and positions

of all dock
windows and toolbars back to their default.

Use Reset Tabs to Default to reset the tab visibility and order back to default.

7.1. Dock Windows

Click images to enlarge.



Title bar of a dock window marked red.

Moving a dock window around. The blue background
opens to indicate a space in the main window where the dock can be

dropped in.

Dock window in floating state detached from main window.

7.2. Dock Window Stacks



Dropping a dock window on another to create a stack.

A stack of two dock windows. The tab bar is marked
red at the bottom of the stacked dock windows.

Note

You must click on the title bar of a dock window to remove it from the stack, not on the tab bar.



8. Tabs

The dock windows Flight Planning, Information,
Simulator Aircraft and Search have tab bars that allow to

close,
open and move tabs.

Tooltips give more information about the function of a tab.

Note that you cannot move a tab to another window.

The Window -> Reset Tabs to Default menu item in the
main menu also resets the tab visibility and order

to default.

8.1. Context Menu Tabbar

The context menu above the tab bar (right click on one of the tabs) and
the tab button  have the

following menu items:

Open All: Opens all tabs. All closed tabs are opened again and
added to the right side of the tab

bar.

Close all Except Current: All tabs are closed except the
currently active.

Reset Tab Layout: Opens all closed tabs again and restores the
default order.

Lock Tab Layout: Hides the close buttons to avoid accidental
closing. Moving by click and drag as

well as closing by double click
are disabled. A locked tab bar also occupies less space. You can

still close and open tabs using the context menu or menu button.

Close Tab: Only visible in the context menu. Closes the tab below
the click spot.

One menu item for each tab: Toggles tab visibility. A tab is always
opened to the right of the

current one.

8.2. Mouse actions

Click and drag a tab to move it.

Double click a tab to close it.

Right click a tab to open the context menu.

Use the mouse wheel above a tab bar to cycle between tabs.



Drop down button menus and context menus on tab bars marked red. Click image to enlarge.

8.3. Stacked Dock Window Tabs

Tabs at the bottom of a window appear when you drop dock windows on each
other. Grab a window

title bar to move a window out of the stacked
display. You can also change the order of these tabs by

dragging them
around.

See Dock Windows for more information about stacked
dock windows.



9. Main Menu and Toolbars

This chapter describes all the menu items of Little Navmap. You will
find some of this functionality on

the toolbars as well which are not be
described separately. Keyboard shortcuts can be seen on the

menu items.
See Keyboard Shortcuts for a complete list.

All toolbar buttons have an equivalent function in the menu.

Drop down menus in the toolbar can be torn off by clicking on the dashed line on top of them. See
Tear

off Dropdown Menus for more information.

Menu and toolbars docked in default positions. Screenshot based on Little Navmap 2.6.

Tip

Look at the left side of this online user manual to see all the menus and menu items in a tree like

structure.

9.1. File Menu

9.1.1.  New Flight Plan

Clears the current flight plan and shows the flight plan table.

You have to use Context Menu Search,
Context Menu Map or
Flight Plan Route Description dialog to

create a new flight plan.

Note

You can exit Little Navmap without saving the current plan. All will be restored on next startup.
See

Load last used flight plan for more information and how to disable this behavior.

9.1.2.  Open Flight Plan

Opens a flight plan with one of the following formats:

LNMPLN. This is the default format of Little Navmap which supports all flight plan features like

remarks.
See Little Navmap LNMPLN Format for information about this format.

PLN: FSX, FS9, FSC or MSFS.

FLP

FMS: X-Plane FMS 11 (used by X-Plane 11 and X-Plane 12) or FMS 3

FlightGear FGFP

Garmin FPL and GFP

The file type is determined by content and not file extension. See Flight Plan Formats for more

information.

An opened flight plan file will be reloaded on start up (reload and centering can be switched off
in the

Options dialog on Startup and Update and User Interface).

You can also drag and drop files from a file manager like Windows
Explorer or macOS Finder into the

Little Navmap main window to load
them. Single flight plan files of all allowed formats as well as



aircraft performance files
are accepted.

Note

Keep in mind that most flight plan formats are limited and not all information is provided or can be

loaded from a file. For example, cruise altitude might not be loaded from X-Plane FMS in some
cases,

airways and departure parking spots cannot restored for several formats, transitions cannot
be

loaded from MSFS PLN and more.

Important

Always save a copy of the flight plan in LNMPLN format to be able to
reload all information. Exporting

to and reading from other formats like
X-Plane FMS might result in information loss.

9.1.3.  Append Flight Plan

Adds departure, destination and all waypoints to the current flight
plan.

Using Append Flight Plan allows to load or merge complete flight
plans or flight plan snippets into a new

plan. All waypoints are added
at the end of the current flight plan. Then you can use the
Delete selected

Legs and Move selected Legs up/down context menu
items to arrange the waypoints and airports as

required. See Context Menu Flight Plan.

All current arrival procedures will be removed when appending a flight plan. The
new flight plan will use

arrival and approach procedures from the loaded
plan, if any are present.

The appended legs are selected after loading the flight plan.

9.1.4. Recent Flight Plans

Shows all recently loaded flight plans for quick access. You can clear
the list by selecting Clear Menu.

Little Navmap will show an error message if you try to load a deleted file.

9.1.5.  Save Flight Plan

Saves the flight plan into the current LNMPLN file. This format allows to store all flight plan attributes of

Little
Navmap. Disabled if no flight plan has been loaded or created.

Little Navmap opens the Save as dialog (see below Save Flight Plan as LNMPLN) if departure,
destination

or any other value used in the flight plan name has changed. This helps to avoid
overwriting LNMPLN

files with wrong plans after reversing direction, for example.

You can disable this behavior in the options dialog on page Flight Plan by unchecking
Avoid overwriting

Flight Plan with not matching departure and destination.

Note

Little Navmap will not ask to save the file on exit but will instead save the changes to a temporary

file.
The changes will be restored on next startup.
See Load last used flight plan for more information

and how to disable this behavior.

9.1.6.  Save Flight Plan as LNMPLN



Saves the flight plan to a LNMPLN file. This format allows to save all flight plan attributes of Little

Navmap. Disabled if no flight plan has been loaded or created.

See Little Navmap LNMPLN Format for information about this format.

Save Flight Plan as PLN changes the current file name in
Little Navmap which means that all further

saves will go into the new
LNMPLN file.

Little Navmap proposes a new file name based on the pattern set in options on page Flight Plan.

Tip

You can save the flight plan files in any place. I recommend a directory in Documents like

Documents\Little Navmap\Flight Plans.

You can also use the folder which is suggested by the dialog window Directories.

Important

Always save a copy of the flight plan in the default LNMPLN format to be
able to reload all

information. Writing to and reading from other
formats like X-Plane FMS might result in information

loss.
See Flight Plan Formats for more information.

9.1.7.  Reset all for a new Flight

Opens a dialog which allows to reset functions in Little Navmap for a
new flight. See Reset all for a new

Flight for more information.

9.1.8.  Export Flight Plan as MSFS 2020 PLN

Saves a flight plan for Microsoft Flight Simulator 2020. Disabled if no flight plan has been loaded or

created.

Little Navmap can read and write this format.

This does not change the current file name and type. Further saves will still use the same LNMPLN file

name and format as before.

The proposed file name can be defined in the Multiexport Options Dialog for format Microsoft Flight

Simulator 2020.

See also Flight Plan Formats.

9.1.9.  Export Flight Plan as P3D or FSX PLN

Saves a flight plan for FSX or Prepar3D. Disabled if no flight plan has been loaded or created.

Little Navmap can read and write this format.

This does not change the current file name and type. Further saves will still use the same LNMPLN file

name and format as before.

The proposed file name can be defined in the Multiexport Options Dialog for format FSX and Prepar3D.

See also Flight Plan Formats.



9.1.10.  Export Flight Plan as FMS for X-Plane 11 and 12

Saves the flight plan using the new X-Plane FMS 11 format which is usable in X-Plane 11 and X-Plane

12. Disabled if no flight plan has been loaded or created.

Little Navmap can read and write this format.

See Flight Plan Formats for more information on limitations.

This does not change the current file name and type. Further saves will still use the same file name and

format as before.

Store FMS files into the Output/FMS plans directory inside the
X-Plane directory if you would like to use

the flight plan in the
X-Plane GPS, the G1000 or the FMS.

The proposed file name can be defined in the Multiexport Options Dialog for formats X-Plane 11.
Note

that the two export format entries for X-Plane 11 and 12 use the same file format but a different folder.

9.1.11.  Export Flight Plan as FlightGear FGFP

Flightplan format which can be loaded into the RouteManager of the free
flight simulator FlightGear

[http://www.flightgear.org]. Disabled if no flight plan has been loaded or created.

Little Navmap can read and write this format.

See Flight Plan Formats for more information on limitations.

This does not change the current file
name and type. Further saves will still use the same file name and

format as before.

You can save the files into any directory and load it within FlightGear.

The proposed file name can be defined in the Multiexport Options Dialog for format FlightGear.

9.1.12. Open Flight Plan from SimBrief

Opens a dialog that allows to import a flight plan from SimBrief [https://www.simbrief.com/].

See Open Flight Plan from SimBrief for more information.

9.1.13. Export Flight Plan to SimBrief

Opens a dialog that allows to export a flight plan to SimBrief [https://www.simbrief.com/]. Disabled if no flight

plan has been loaded or created.

See Export Flight Plan to SimBrief for more information.

9.1.14. Show Flight Plan in SkyVector

Opens the default web browser and shows the current flight plan in
SkyVector [https://skyvector.com].

Procedures are not shown. Disabled if no flight plan has been loaded or created.

Note that the flight plan will not be shown if a small airport is
unknown to SkyVector.

Example: ESMS NEXI2B NILEN L617 ULMUG M609 TUTBI Z101 GUBAV STM7C
ENBO [https://skyvector.com/?

fpl=ESMS%20NILEN%20L617%20ULMUG%20M609%20TUTBI%20Z101%20GUBAV%20ENBO].
Note missing SID and STAR in

SkyVector.

9.1.15. Export Flight Plan to Other Formats

9.1.15.1. Export Flight Plan as HTML Page

http://www.flightgear.org/
https://www.simbrief.com/
https://www.simbrief.com/
https://skyvector.com/
https://skyvector.com/?fpl=ESMS%20NILEN%20L617%20ULMUG%20M609%20TUTBI%20Z101%20GUBAV%20ENBO


Saves the flight plan table as shown to HTML file which can be viewed in
a web browser. Icons are

embedded in the page. Disabled if no flight plan has been loaded or created.

The exported file will reflect changes of the flight plan table view like
column order. Columns which are

hidden or shrinked to minimum width are excluded.

9.1.15.2. Export Flight Plan as GPX

Exports the current flight plan into a GPS Exchange Format file which
can be read by Google Earth and

most other GIS applications. Disabled if no flight plan has been loaded or created.

The flight plan is exported as a route and the flown aircraft trail as a
track including simulator time and

altitude.

The route has departure and destination elevation and cruise altitude
set for all waypoints. Waypoints

of all procedures are included in the
exported file. Note that the waypoints will not allow to reproduce

all
parts of a procedure like holds or procedure turns.

Note

Do not forget to clear the aircraft trail ( Delete User Aircraft Trail or Reset all for a new Flight)
before

a flight to avoid
old trail segments in the exported GPX file. Or, disable the reloading
of the trail in

the options dialog on Startup and Update.

9.1.15.3. Export Flight Plan for vPilot, xPilot or SWIFT

Export the flight plan for the VATSIM
vPilot [https://www.vatsim.net/pilots/download-required-software] online network

client. Disabled if no flight plan has been loaded or created.

Flight Plan Online Network Export will appear before where you can add all needed information.

9.1.15.4. Export Flight Plan as IvAp FPL

9.1.15.5. Export Flight Plan as X-IvAp FPL

Export flight plan format for IVAO online network clients IvAp or
X-IvAp [https://www.ivao.aero/softdev/ivap.asp].

Disabled if no flight plan has been loaded or created.

Flight Plan Online Network Export will appear
before where you can add all needed information.

9.1.16. Export Options

Sub-menu with several actions that affect export to most flight plan formats. This does not affect the

saving
of flight plans into the LNMPLN format.

Warning

Note that saving flight plans with one or more of these methods has limitations:

Several approach leg types like holds, turns and procedure turns
cannot be displayed properly

by using just waypoints or coordinates.

Speed and altitude limitations are not included in the exported legs.

Normally you should not use these export options.

9.1.16.1. Export Waypoints for Approaches

Save procedure waypoints instead of procedure information if checked.
This affects all flight plan

export formats except the native LNMPLN format.

Use this if your simulator, GPS or FMC does not support loading or
display of approach procedures, SID

or STAR.

https://www.vatsim.net/pilots/download-required-software
https://www.ivao.aero/softdev/ivap.asp


Procedure information is replaced with respective waypoints that allow
to display procedures in limited

GPS or FMS units.

9.1.16.2. Export Waypoints for SID and STAR

As above Export Waypoints for Approaches but only for SID and STAR procedures.

9.1.16.3. Export Waypoints for Airways

Enabling this function will omit all airway information in the exported flight plan formats.
A chain of

waypoints will be exported instead of waypoint/airway/waypoint triplets.

9.1.17.  Multiexport Flight Plan

Exports all selected flight plan formats at once. You have to configure paths and select formats
for

exporting before by selecting Multiexport Flight Plan Options below. Also disabled if no flight plan has

been loaded or created.

Disabled if no flight plan format is selected for export.

See Flight Plan Multiexport for details.

9.1.18.  Multiexport Flight Plan Options

Opens a dialog which allows to configure paths and select formats
for flight plan exports with the

Multiexport Flight Plan function above.

See Flight Plan Multiexport for details.

Note

Note that the multiexport dialog window is also used to define default file names for the export

options
Export Flight Plan as MSFS 2020 PLN, Export Flight Plan as P3D or FSX PLN, Export Flight

Plan as FMS for X-Plane 11 and 12 and Export Flight Plan as FlightGear FGFP.

9.1.19.  Add Google Earth KML

Allows addition of one or more Google Earth KML or KMZ files to the map
display. All added KML or

KMZ files will be reloaded on start up. Reload
and centering can be switched off in the Options dialog on

Startup and Update and User Interface.

Due to the variety of KML files it is not guaranteed that all files will
show up properly on the map.

9.1.20.  Clear Google Earth KML from Map

Removes all loaded KML files from the map.

9.1.21.  Save Map as Image

Saves the current map view as an image file. Allowed formats are JPEG,
PNG and BMP. The image does

not include the map overlays.

Map Image Export will show up before saving which allows to select the image size.

9.1.22.  Save Map as Image for AviTab



Saves the current map view as an image file for
AviTab [https://github.com/fpw/avitab]. Allowed formats are

JPEG and
PNG.

Map Image Export will show up before saving which allows to select the image size.

The saved file is accompanied by a calibration file in
JSON-Format [https://en.wikipedia.org/wiki/JSON]. It
has

the same name as the image with an additional .json extension.

The files have to be saved to
.../X-Plane 11/Resources/plugins/AviTab/MapTiles/Mercator.

See here in the AviTab documentation for more information how to load
the map image: Map App -

Mercator [https://github.com/fpw/avitab/wiki/Map-App#mercator].

9.1.23. Copy Map Image to Clipboard

Copies the current map image to the clipboard. The image does not
include the map overlays.

Map Image Export will show up before copying the image which allows to select the image size.

9.1.24.  Print Map

Allows to print the current map view. See Print Map for more information.

9.1.25.  Print Flight Plan

Opens a print dialog that allows you to select flight plan related
information to be printed. See Print

Flight Plan for more information.

9.1.26.  Quit

Exits the application. Will ask for confirmation if there are unsaved files.

9.2. Flight Plan Menu

9.2.1. Flight Plan

Opens and raises the flight planning dock window and flight plan tab.
Also activates the flight plan table

for quick navigation. Same as
Window -> Shortcuts -> Flight Plan or pressing F7.

See Window for
a full list or shortcuts.

9.2.2. Fuel Report

Opens and raises the flight planning dock window and Fuel Report tab.
Same as Window -> Shortcuts ->

Fuel Report or pressing
F8.

See Window for
a full list or shortcuts.

9.2.3.  Select a Start Position

Select a parking spot (airport center, gate, ramp, fuel box), a runway or a helipad as a start position at

the departure airport. A parking
position can also be selected in the map context menu item Set as

Departure
when right-clicking on the center of a parking position. If no position is selected
the airport

center is automatically selected as a start position.

See Select Start Position for more information.

https://github.com/fpw/avitab
https://en.wikipedia.org/wiki/JSON
https://github.com/fpw/avitab/wiki/Map-App#mercator


9.2.4.  Select Departure Runway

Same as Set Departure Runway in the map context menu. Only active if the current flight plan has a

departure airport.
See more about this in chapter Departure and Destination Runway.

9.2.5.  Select Destination Runway

Same as Set Destination Runway in the map context menu. Only active if the current flight plan has a

departure airport.
See more about this in chapter Departure and Destination Runway.

9.2.6.   Undo and Redo

Allows undo and redo of flight plan changes. The last action is shown in the menu item like Add Waypoint,

for example.
The undo information is cleared when restarting Little Navmap.

9.2.7.  Edit Flight Plan on Map

Toggles the flight plan drag and drop edit mode on the map. See Map Flight Plan Editing.

9.2.8.  Flight Plan Calculation

Opens the flight plan calculation dialog window which allows to automatically generate a flight plan by

various criteria.
The window is pulled into foreground if already open.

The altitude from the current flight plan is transferred to the calculation window but not vice versa.

See chapter Flight Plan Calculation for more information.

9.2.9.  Calculate Direct

Deletes all intermediate waypoints and connects departure and
destination using a great circle line.

This function does not delete procedures from the current flight plan but will connect procedure exit

and entry directly, if any.

Tip

You can calculate a flight plan between any kind of waypoints, even
user defined waypoints (right-

click on the map and select
Add Position to Flight Plan to create one). This allows the creation
of

snippets that can be merged into flight plans.

9.2.10.  Reverse Flight Plan

Swaps departure and destination and reverses order of all intermediate
waypoints. The departure

airport will be assigned as start position.

Procedures are removed by this function.

This function also removes all airway references since the result would not be valid
due to one-way

restrictions.



9.2.11.  Adjust Flight Plan Altitude

Changes the flight plan altitude according to a simplified East/West
rule and the current route type (IFR

or VFR). Rounds the altitude up to
the nearest even 1,000 ft (or meter) for westerly flight plans or odd

1,000 ft (or meter) for easterly flight plans. Adds 500 ft for VFR
flight plans.

The rule can be changed in the options on page Flight Plan.

9.2.12.  Flight Plan Route Description

Opens a dialog with the ATS route description of the current flight plan
that also allows to modify the

current flight plan or enter a new one.

Flight Plan Route Description gives more information about this topic.

9.2.13.  Copy Flight Plan Route Description to the Clipboard

Copies the route description of the current flight plan to the clipboard
using the current settings from

Flight Plan Route Description.

9.2.14. Download Tracks on Startup

Downloads tracks immediately and instructs Little Navmap download tracks on startup.

See Tracks for more information.

9.2.15.  Download Tracks

Downloads Oceanic or other tracks which are NAT, PACOTS and AUSOTS.

Tracks are shown on the map and a message is shown in the Statusbar once the download is finished.

Tracks are removed when closing the program. Use the function Download Tracks on Startup
above to

always have tracks available.

See Tracks for more information.

9.2.16. Delete Tracks

Remove downloaded Oceanic and other tracks from the track database.

9.2.17. Track Sources

9.2.17.1. NAT

9.2.17.2. PACOTS

9.2.17.3. AUSOTS

Allows to select the track systems to download. The download is triggered automatically after changing

one of these options.

See Tracks for more information.

9.3. Map Menu

9.3.1.  Goto Home



Shows the home area that was set using Set Home View in the sub-menu More in the map context

menu.
It will show the map using the saved position and zoom distance. The center of the home area

is highlighted by a  symbol.

Note that the symbol is only an indicator for the home view center position and does not have any

context menu or mouse actions attached.

The symbol cannot be hidden. Set it at a remote position if you like to hide it.

9.3.2.  Goto User Aircraft

Moves and zooms the map to the user aircraft. Disabled if not connected to a simulator.

9.3.3.  Center Flight Plan

Centers the whole flight plan on the map.

9.3.4.  Go to Center for Distance Search

Go to the center point used for distance searches. See Set Center for Distance Search.The
center for

the distance search is highlighted by a  symbol.

The center symbol cannot be hidden. Set it at a remote position if you like to hide it.

9.3.5.  Jump to Coordinates

Opens a dialog allowing to place the map at the given coordinates at the given zoom distance.

See Jump to Coordinates about the dialog and Coordinate Formats about the accepted formats.

9.3.6.  Keep User Aircraft Centered

Zooms to the user aircraft if connected to a flight simulator or Little Navconnect and keeps the aircraft

centered on the map.

See User Aircraft Centering for general information about aircraft centering while flying.

9.3.7.  Delete User Aircraft Trail

The global aircraft trail is saved and will be reloaded on program startup.

This menu item and toolbar button removes the user aircraft trail from both the map and the
elevation

profile.

The trail can be exported together with the flight plan into a GPX
file by using Export Flight Plan as

GPX.

While the global trail is independent of flights, an aircraft trail is also attached to logbook entries as a

flown trail and can be stored there.

The logbook trail only covers the flight from takeoff to touchdown. See Logbook.



9.3.8.   Map Position Back/Forward

Jumps forward or backward in the map position history which is a result of all map movements or zoom

actions.
Movements from the user or the program (like aircraft centering) are recorded.

The complete history is saved and restored when starting Little Navmap.

9.3.9.  Remove all Highlights and Selections

Deselect all entries in the flight plan table, all search result tables
and removes all highlight marks from

the map. Also clears the procedure preview enabled with Preview all Procedures
in the window Search

Procedures.

Use this to get a clean view of the map while flying.

9.3.10.  Remove all Range Rings

9.3.11.  Remove all Measurement Lines

9.3.12.  Remove all Traffic Patterns

9.3.13.  Remove all Holdings

9.3.14.  Remove all MSA Diagrams

Removes the respective user features which are range rings, navaid range rings,
measurement lines,

airport traffic patterns, user placed MSA diagrams and user holdings from the map.

This cannot be undone.

A warning dialog is shown before removing the user features.

The options are disabled if the respective features are not present the map.

9.3.15.  More Details

9.3.16.  Default Details

9.3.17.  Less Details

Increases or decreases the detail level for the map. More details means
more airports, more navaids,

more text information and bigger icons.

Map details have an equivalent button  on the toolbar which allows to change the
detail level with

a slider. The drop down menu of the toolbar button can be torn off by clicking on the dashed line in the

menu (Tear off Dropdown Menus).

The detail level is shown in the Statusbar. Range is -2 for least detail to +5 for most detail.



Warning

Map information will be truncated if too much detail is
chosen. A red warning message Too many

objects will be shown in the Statusbar if this is
the case.

Tip

You can also quickly change the detail level with the mouse wheel using Ctrl+Wheel
or with the

keyboard shortcuts Ctrl++, Ctrl+- or Ctrl+0 (default details).

9.4. View Menu

9.4.1.  Reset Display Settings

Resets all map display settings which can be changed in the menu View back to default.

9.4.2. Airports

This sub-menu has an equivalent button  on the toolbar containing the same items as
this sub-

menu. The toolbar buttons additionally allows to limit the display of airports to a minimum runway

length.
The drop down menu of the toolbar button can be torn off by clicking on the dashed line in the

menu (Tear off Dropdown Menus).

Note that airports might be hidden on the map depending on zoom distance and airport type.

9.4.2.1.  Show Airports

Disable or enable the display of all airports. This also covers add-on airports.

9.4.2.2.  Reset airport display options

Reset airport display to default settings, i.e. display all airports.

9.4.2.3.  Hard surface

Show airports that have at least one runway with a paved surface.
Note that this affects the other map

display airport filters as well.

9.4.2.4.  Soft surface

Show airports that have only unpaved runways.
Note that this affects the other map display airport

filters as well.

9.4.2.5.  Seaplane Bases

Show airports that have only water runways.

9.4.2.6.  Heliports



Show airports that have no runways but only helipads or are marked as a heliport.

9.4.2.7.  Empty

Show empty airports. This button or menu item might be disabled
depending on settings in the Options

dialog on Map.
The status of this button is combined with the other airport
buttons. This means, for

example: You have to enable soft surfaced
airport display and empty airports to see empty airports

having only
soft runways.

An empty airport is defined as one which has neither parking nor
taxiways nor aprons and is not an

add-on. These airports are treated
differently in Little Navmap. Empty airports are drawn gray and

behind all other
airports on the map.

This function helps the user to avoid airports that have no scenery elements.

Airports having only water runways are excluded from this definition to
avoid unintentional hiding.

X-Plane and 3D airports

The function can be extended to X-Plane airports which are not marked as
3D. This can be done by

checking
Consider all X-Plane airports not being 3D empty in the Options
dialog on page Map. All airports not

being marked as
3D will be shown in gray on the map and can be hidden like described
above if

enabled.

An airport is considered 3D if its source file contains 3D in the
gui_label.

The definition of 3D is arbitrary, though. A 3D airport may
contain just a single object, such as a light

pole or a traffic cone or
it may be a fully constructed major airport.

9.4.2.8.  Not lighted

Show airports which have no lighted runway.

9.4.2.9.  No procedure

Show airports which have no approach or other procedures.

9.4.2.10.  Closed

Show airports which are marked closed or have only closed runways.

9.4.2.11.  Military

Show military airports. Note that military airports are detected by name patterns like AB and therefore

not all military airports can be detected. This also applies to airports with both military and civil use.

9.4.2.12.  Add-on

Add-on airports are always shown independently of the other airport map
settings and zoom level if

this option is selected.

This means that the display of add-on airports will ignore all filters set in this menu, also the runway

length.

Enabling this function allows to see even small add-on airstrips in continental zoom levels, for example.



Add-on airports are highlighted with a yellow ring which is independent of this function.
You can disable

the yellow ring in the options dialog on page Map Display by unchecking Highlight add-on airports.

Example: Add-on on a higher zoom level:

Off: Only large add-on airports are shown on the map with a yellow highlight.

On: All large add-on airports and additionally small add-on airstrips are shown on the map with a yellow highlight.

9.4.3. Navaids

Show or hide these navaids on the map. Navaids might be hidden on the map depending on zoom

distance.

Note

Navaids related or being part of a flight plan and its procedures are always shown together with the

flight plan.
You can disable the display of all VOR, NDB, waypoints and ILS to get a more clean

display when flying.



9.4.3.1.  Show VOR Stations

Toggle display of VOR, VORDME, VORTAC, DME and TACAN stations.

9.4.3.2.  Show NDB Stations

Toggle display of NDB navaids.

9.4.3.3.  Show Waypoints

Show or hide intersections or waypoints.

9.4.3.4.  Show ILS Feathers

Toggles the display of ILS, localizer, IGS, LDA and SDF feathers.

Note that this setting also affects the ILS glideslope display in the elevation profile and can be used to

force the display of the ILS slope for all approach types.
See Show ILS or GLS/RNP for more

information.

9.4.3.5.  Show GLS/RNP Approach Paths

Toggles the display feathers for GLS, RNP and other approach types.

Note that this setting also affects the GLS/RNP glidepath display in the elevation profile and can be

used to force the display of a glidepath for all approach types.
See Show ILS or GLS/RNP for more

information.

Note

GLS/RNP approach paths are not available when using the setting Do not use Navigraph Database in

the
menu Scenery Library -> Navigraph with FSX, P3D or MSFS. See also Load Scenery Library and

Navigation Databases.

9.4.3.6.  Show Holdings

Show or hide en-route holdings. Note that these are a part of the navdata and do not cover
user placed

holdings which can be added from the map display context menu using Add Holding.

Note

En-route holdings are not available when using the setting Do not use Navigraph Database in the

menu Scenery Library -> Navigraph with FSX, P3D or MSFS. See also Load Scenery Library and

Navigation Databases.

9.4.3.7.  Show MSA Sectors

Toggle display of MSA (minimum sector altitude) icons. This does not cover the user placed MSA sector

diagrams.

See Minimum Sector Altitude for more information.



Note

MSA sectors are not available when using the setting Do not use Navigraph Database in the
menu

Scenery Library -> Navigraph with FSX, P3D or MSFS. See also Load Scenery Library and Navigation

Databases.

9.4.3.8.  Show Victor Airways

9.4.3.9.  Show Jet Airways

Toggle display of airways and the attached waypoints.

9.4.3.10.  Show Tracks

Show or hide Oceanic or other tracks which are NAT, PACOTS and AUSOTS.

This function is disabled if no tracks are downloaded.

See Tracks for more information.

9.4.4. Airspaces

This sub-menu and toolbar button allow the selection of individual airspace categories.

Airspace data sources can be selected in menu Scenery Library -> Airspace Libraries.

The dropdown menu of the toolbar buttons can be torn off (Tear off Dropdown Menus).

Airspace selection toolbar with all drop down menus. Click image to enlarge.

9.4.4.1.  Show Airspaces

Allows to enable or disable the display of all airspaces with one click.
Use the menu items below this

one or the toolbar buttons to display or
hide the various airspace types.

The airspaces toolbar contains buttons each having a drop down menu that
allows to configure the

airspace display like showing or hiding certain
airspace types. Each drop down menu also has All and

None
entries to select or deselect all types in the menu.

The previous selection state is restored by clicking the All or None items a second time in
the toolbar

button dropdown menu.

Additionally a minimum and maximum altitude can be selected in the toolbar button . Only

airspaces
overlapping with these limits are shown.



9.4.4.2.  ICAO Airspaces

Allows selection of Class A to Class E airspaces.

9.4.4.3.  FIR Airspaces

Allows selection of the Class F and Class G airspaces or flight
information regions.

9.4.4.4.  Restricted Airspaces

Show or hide MOA (military operations area), restricted, prohibited and
danger airspaces.

9.4.4.5.  Special Airspaces

Show or hide warning, alert and training airspaces.

9.4.4.6.  Other Airspaces

Show or hide center, tower, mode C and other airspaces.

9.4.4.7. All altitudes

Show airspaces for all altitudes.

9.4.4.8. At flight plan cruise altitude

Show only airspaces touching the flight plan cruise altitude (set in Cruise altitude).

9.4.4.9. For minimum and maximum altitude

Show only airspaces touching the altitude range set in the toolbar button .

9.4.5. User Features

The menu item has an equivalent button  on the map options toolbar.
The dropdown menu of the

toolbar button can be torn off (Tear off Dropdown Menus).

The previous selection state is restored by clicking the All User Features or No User Features items a

second time in
the toolbar button dropdown menu.

9.4.5.1.  Range Rings

9.4.5.2.  Measurement Lines

9.4.5.3.  Traffic Patterns

9.4.5.4.  Holdings



9.4.5.5.  MSA Diagrams

Hides or shows the respective user features.

The respective option is automatically enabled after a user feature is added to the map.

User features can also be toggled with the toolbar button .

The previous selection state is restored by clicking the All or None items a second time in
the toolbar

button dropdown menu.

9.4.6. Userpoints

Allows to hide or show user defined waypoints by type.

The menu item Unknown Types shows or hides all types which do not belong to a known type.

The type Unknown  shows or hides all userpoints which are exactly of type Unknown.

User features can also toggled with the toolbar button .

You can tear off the drop down menu from the toolbar by clicking on the dashed line on top of it.

The previous selection state is restored by clicking the All Userpoints or No Userpoints items a second

time in
the toolbar button dropdown menu.

The respective type is automatically enabled after a userpoint is added to the map.

See Userpoints for more information on user defined waypoints.

9.4.7.  Show Flight Plan

Show or hide the flight plan. The flight plan is shown independently of
the zoom distance.

Note that the flight plan is also hidden in the elevation profile if you switch it off here.

Related navaids for procedures are forced with the flight plan display. All navaids needed for

procedures are still shown if you disable the display of VOR, NDB and waypoints. This helps to keep
an

uncluttered map display.

9.4.8.  Show Top of Climb and Top of Descent

Hides the climb and descent slopes as well as the top of climb and top of descent indicators when

disabled.
This affects the map and elevation profile display but not the altitude calculation in the fuel

report or elevation profile.

9.4.9.  Show Missed Approaches

Show or hide the missed approaches of the current flight plan or the procedure preview (Preview and

Highlights).

Note



This function changes the active flight plan leg
sequencing: Sequencing the active leg will stop if the

destination is
reached and missed approaches are not displayed. Otherwise sequencing
will continue

with the missed approach and the simulator aircraft
progress will show the remaining distance to the

end of the missed
approach instead.

9.4.10.  Show User Aircraft

Shows the user aircraft and keeps it centered on the map if connected to
the simulator. The user

aircraft is always displayed regardless of the zoom distance.

The icon color and shape indicates the aircraft type and whether the
aircraft is on ground (gray border

on ground).

 User aircraft in flight.

A click on the user aircraft shows more information in the
Simulator Aircraft dock window.

More options to change the map behavior while flying can be found here Simulator Aircraft in options.

9.4.11.  Show User Aircraft Trail

Show the user aircraft trail. The trais is always displayed regardless of the zoom distance. It is saved

and will be reloaded on program startup.

The trail can be deleted manually by selecting Map -> Delete User Aircraft Trail in the main menu.

The length of the trail is limited for performance reasons. If it
exceeds the maximum length, the trail is

truncated and the oldest
segments are lost. The maximum number of points can be changed in options

on page Simulator Aircraft.

The trail can be exported together with the flight plan into a GPX file by using Export Flight Plan as

GPX.

Note that an additional trail is saved with logbook entries. See Logbook for more information.

9.4.12.  Show Selected Altitude Range Arc

Shows a distance arc that predicts reaching the selected autopilot altitude.
This is shown for descent

and climb.

The option Show Vertical Track in the elevation profile provides similar functionality.

The selected autopilot altitude value can be seen in Tab Progress when enabling Autopilot Selected in

Aircraft Progress Display Options.

Note that some add-on aircraft do not provide a useful autopilot altitude and use the value for their

own purposes.



A jet aircraft climbing and about to reach the top of climb before waypoint ASKJA.

9.4.13.  Show Turn Flight Path

Enables a turn indicator which shows the predicted path if the given turn rate of the aircraft is kept.

The arc is limited to 5 NM length and a turn maximum of 180°. Tick marks show distance in 1 NM

steps.

An aircraft turning in a procedure about to intecept the ILS after waypoint CI26B

9.4.14.  Show Aircraft Endurance

A dotted circle showing the maximum endurance is shown around the user aircraft if enabled. A label

display endurance in NM and hours/minutes.
The label turns orange if the endurance is below 45

minutes and to red if endurance is below 30 minutes.
The endurance can be seen in Tab Progress when

enabling Endurance in Aircraft Progress Display Options.

The endurance is based on fuel on board, current fuel flow and groundspeed considering reserves and

contingency as set in the Aircraft Performance file.
It is inly shown if the user aircraft is airborne. You

will see limited endurance if climbing to cruise altitude since the range depends on the current fuel flow

and speed.

Running below fuel reserves might also result in zero endurance shown even with fuel on board.



Note that you will see red or orange endurance warnings if the wrong aircraft performance file is used.

Aircraft endurance shown with label. 384 NM and 3 hours and 18 minutes to go.

9.4.15.  Show Compass Rose

Show a compass rose on the map which indicates true north and magnetic
north. Aircraft heading and

aircraft trail are shown if connected to a
simulator.

The rose is centered around the user aircraft if connected to a simulator.
Otherwise it is centered on

the map view.

See Compass Rose for details.

9.4.16.  Attach Compass Rose to Aircraft

The compass rose is centered in the current view if not connected to a simulator.

Once connected, the compass rose will be attached to the user aircraft and follow its position.

This can be disabled with this menu item which detaches the rose from the user aircraft and keeps it

centered on the screen.

9.4.17. AI and Online Aircraft

9.4.17.1.  Show AI and Multiplayer Aircraft

Shows AI and multiplayer aircraft on the map. Multiplayer
vehicles can be displayed from e.g. FSCloud,

VATSIM or Steam sessions.

The icon color and shape indicates the aircraft type and whether the
aircraft is on ground (gray

border).

Two types of traffic are shown:

AI or multiplayer aircraft from the simulator:

 This includes aircraft traffic that is injected by
online network clients. A click on the AI

aircraft or ship shows more
information in the Simulator Aircraft dock window in the tab
Tab AI /

Multiplayer.

Multiplayer aircraft/client from an online network:

 A click on the
online aircraft shows information in the Information dock window in
the

separate tab Online Clients. See also Online Networks.

The displayed vehicles are limited by the used multiplayer system if
Little Navmap is not connected to

an online network like VATSIM or
IVAO. Multiplayer aircraft will disappear depending on distance to

user
aircraft.



Little Navmap limits the display of AI vehicles depending on size and type.
Zoom close to see small

aircraft or boats.

Aircraft labels are forced to show independently of zoom level for the
next five AI/multiplayer aircraft

closest to the user that are within 20
NM distance and 5,000 ft elevation. Other labels appear

depending on zoom distance.

On the lowest zoom distance all aircraft and ships are drawn to scale on
the map.

All aircraft icons can be customized: User, AI and Multiplayer Aircraft Icons.

Note

Currently MSFS multiplayer traffic cannot be shown.
Have a look at the VirtualFlight.Online

Transmitter [https://virtualflight.online/transmitter/] to address this issue.

9.4.17.2.  Show Online Aircraft

As Show AI and Multiplayer Aircraft but shows online network aircraft on the map if enabled. This

setting affects all traffic from online
networks like IVAO, VATSIM or custom networks which can be

enabled in Options on page
Online Flying.

See Online Networks for an overview and Aircraft and Ships for information on aircraft colors and

symbols.

9.4.17.3.  Show AI and Multiplayer Ships

As Show AI and Multiplayer Aircraft but enables or disabless AI or multiplayer ships on the
map. Fetch

AI or multiplayer ships has to be enabled in the Connect Dialog to see AI ships.

This option also affects the frigate and carrier ships from X-Plane.

See also Aircraft and Ships for information on ship colors and symbols.

9.4.18.  Show Map Grid

Show a latitude/longitude grid as well as the
Meridian [https://en.wikipedia.org/wiki/Prime_meridian] and
180th

Meridian or Antimeridian [https://en.wikipedia.org/wiki/180th_meridian] (near
the date line) on the map.

A 30, 5 or 1 degree grid is shown depending on zoom distance.

9.4.19.  Show Map Grid Options

Shows a dialog window which allows to configure the map grid colors and labels.

9.4.20.  Show Country and City Names

Show country, city and other points of interest. Availability of these
options depends on the selected

map theme. See Map Themes and Map Layers for details.

9.4.21.  Show Minimum off-route Altitude Grid

Toggles the display of minimum off-route altitude grid on the map.

https://virtualflight.online/transmitter/
https://en.wikipedia.org/wiki/Prime_meridian
https://en.wikipedia.org/wiki/180th_meridian


The minimum off-route altitude grid provides an obstacle clearance
altitude within an one degree grid.

The altitudes clear all terrain and
obstructions by 1,000 ft in areas where the highest elevations are

5,000
ft MSL or lower. Where the highest elevations are above 5,000 ft MSL
or higher terrain is cleared

by 2,000 ft.

The large number is 1,000 ft and small number 100 ft minimum
altitude.

Note

The MORA grid is not available when using the setting Do not use Navigraph Database in the
menu

Scenery Library -> Navigraph with FSX, P3D or MSFS.

See also Load Scenery Library and Navigation Databases.

MORA grid: 3,300, 4,400, 6,000, 9,900 and 10,500 ft.

9.4.22.  Show Airport Weather

Shows icons for airport weather where a weather station is available.
Select source for display with

Airport Weather Source below.

See Airport Weather for an
explanation of the symbols and Airport Weather for more information.

9.4.23. Wind levels

Enables or disables wind aloft display for different layers as well as
at flight plan waypoints. Select wind

data source for display with Wind source below.

See Winds Aloft for an
explanation of the wind symbols and Winds Aloft for more information.

9.4.24.  Show Sun Shading

Enables the display of sun shading on the globe. This works in both
projections Mercator and Spherical.

You can change the time source with the Sun Shading Time menu below.
The shadow darkness can be

changed in the dialog Options on page
Map Display User.

Note that offline maps cannot display a sun shadow.

See Sun Shading for more information.

9.4.25. Sun Shading Time

You can choose between three time sources for the sun shadow.

9.4.25.1. Simulator

Uses the time of the connected flight simulator and falls back to real
time if not connected. Updates the

shadow if the simulator time changes.

9.4.25.2. Real UTC Time

Use real time.

9.4.25.3. User defined Time



Allows to use the user defined time as set by using
Set User defined Time below.

9.4.25.4. Set User defined Time

Opens a dialog to set an user defined time in UTC as a source for the
sun shading.

See Set User defined Time for more information.

9.4.26. Projection

See Map Projection for details.

9.4.27. Theme

See Map Themes and Map Layers for details.

9.5. Weather Menu

This sub-menu allows to change or enable weather source.

Note that some weather sources depend on the selected scenery library. For example:

X-Plane 11 scenery selected: X-Plane 11 METAR.rwx weather file and global_winds.grib wind file

in the X-Plane 11 base path are loaded.

X-Plane 12 scenery selected: The folder Output/real weather in the X-Plane 12 base bath is

checked for METAR and wind files.

The same applies to ActiveSky weather files for X-Plane where the files are selected automatically.
This

does not apply to FSX, P3D and MSFS where the weather is loaded using the simulator connection.

See also on options page Weather Files for configuration of download addresses and file paths.

9.5.1. Airport Weather Source

Selects the source for the airport weather symbol display on the map.
See also Airport Weather and

Weather.

See Airport Weather for an explanation of the symbols

The following options are available:

9.5.1.1. Disabled

Disables the weather source which also disables all file accesses and online downloads. The menu item

Show Airport Weather and the toolbar button will disabled if this is selected.

9.5.1.2. Flight Simulator

FSX, Prepar3D or X-Plane. Display for FSX/Prepar3D and on remote
connections is slower and might

cause stutters when scrolling.

Display for X-Plane remote connections is not supported except by
sharing the X-Plane 11 METAR.rwx

weather file or the X-Plane 12 folder Output/real weather on the network.

9.5.1.3. Active Sky

Use Active Sky as source for weather display.

9.5.1.4. NOAA

Most up-to-date option for weather (National Oceanic and Atmospheric
Administration

[https://www.noaa.gov/]).

9.5.1.5. VATSIM

Use this for online flying in the VATSIM network.

https://www.noaa.gov/


9.5.1.6. IVAO

Use this for online flying in the IVAO network.

9.5.2. Wind source

Choose the source for winds aloft forecast data here. This affects the
calculation of top of descent, top

of climb and fuel planning as well as display of wind barbs on the map.
See also Winds Aloft and

Weather.

A manual wind setting on Tab Fuel Report for cruise altitude can also be used. See
Buttons on tab Fuel

Report.

The selected wind source is shown in the Tab Fuel Report in the
Average wind line as well as in all tooltips

on wind barbs.

This is the same function as the Manual Wind menu button  in the Tab Fuel Report.

9.5.2.1. Manual Wind

This menu item allows
to set the average wind direction and speed manually. Three input
fields for

direction, speed and level altitude are shown in the Tab Fuel Report if this is checked.

Note that the wind is set for given altitude and is interpolated down to zero for MSL.
Placing a flight

plan cruise level below the wind layer will result in lower winds.
Placing the cruise level above will

result in the same wind.

9.5.2.2. Disabled

No wind will be downloaded and processed and no files are checked for updates.

9.5.2.3. Flight Simulator (X-Plane only)

Uses the global_winds.grib file which is downloaded and used by
X-Plane 11 or checks the X-Plane 12

folder Output/real weather for changes. The files use less
wind layers and are therefore not as accurate

and not as recent as the NOAA option.

Display for X-Plane remote connections is not supported except by
sharing the X-Plane 11

global_winds.grib weather file or the X-Plane 12 folder Output/real weather on the network.

9.5.2.4. NOAA

Downloads weather files from National Oceanic and Atmospheric
Administration [https://www.noaa.gov/]. This

is the most accurate and most recent
option since it downloads data for several wind layers as well as

the ground level.

9.6. Userpoint Menu

See Userpoints for more information on user defined waypoints.

9.6.1. Userpoint Search

Raise the dock window Search and the tab Userpoints where you
can edit, add delete and search user-

defined waypoints.

9.6.2.   Undo and Redo Userpoint

Same as Undo and Redo Userpoint in the context menu of the userpoint table.

9.6.2.1. Cleanup Userpoints

Same as Cleanup Userpoints in the context menu of the userpoint table.

https://www.noaa.gov/


9.6.3. Import CSV

Import a CSV file that is compatible with the widely used format from
Plan-G and adds all the content

to the database.

Note that the CSV format is the only format which allows to write and
read all supported data fields.

See CSV Data Format for a more
detailed description.

9.6.4. Import X-Plane user_fix.dat

Import user defined waypoints from the file user_fix.dat. The file
does not exist by default in X-Plane

and has to be created either
manually or by exporting from Little Navmap.

The default location is Custom Data/user_fix.dat in the X-Plane base folder.

The imported userpoints are of type Waypoint  which can be
changed after import using the bulk

edit functionality.

For additional information see X-Plane user_fix.dat Data Format.

9.6.5. Import Garmin GTN

Reads user defined waypoints from the Garmin user.wpt file. Refer to
the manual of the Garmin unit you

are using for more information about
format and file location.

The imported userpoints are of type Waypoint  which can be
changed after import using the bulk

edit functionality.

See Garmin user.wpt Data Format for
more information.

9.6.6. Export CSV

Create or append user defined waypoints to a CSV file. A dialog asks if
only selected userpoints should

be exported, if the userpoints should
be appended to an already present file or if a header should be

added.

Note that the exported file contains extra columns compared
to the Plan-G format. The description field

supports more than one line
of text and special characters. Therefore, not all programs might be
able

to import this file. If needed, adapt the file in Microsoft Excel or LibreOffice Calc.

Userpoint export dialog with tooltip help on first option.

9.6.7. Export X-Plane user_fix.dat



Only selected userpoints or all can be exported. The exported data can
optionally be appended to an

already present file.

Not all data fields can be exported to this format. The ident field is
required for export.

Also, you have to make sure that the user waypoint ident is unique
within the user_fix.dat.

See X-Plane user_fix.dat Data Format for more information about
limitations.

9.6.8. Export Garmin GTN

Only selected userpoints or all can be exported. The exported data can
optionally be appended to an

already present file.

Not all data fields can be exported to this format. The ident field is
required for export. Some fields like

the name are adapted to
limitations.

See X-Plane user_fix.dat Data Format for more information about
limitations.

9.6.9. Export XML for FSX/P3D BGL Compiler

This export options creates an XML file which can be compiled into an
BGL file containing waypoints.

The region and ident fields are required for this export option.

See the Prepar3D SDK documentation for information on how to compile the
BGL and how to add this

to the simulator.



9.7. Logbook Menu

9.7.1. Logbook Search

Raise the dock window Search and the tab Logbook where you can
edit, add delete and search logbook

entries.

See Logbook for more information.

9.7.2.   Undo and Redo Logbook Entry

Same as Undo and Redo Logbook Entry in the context menu of the logbook table.

9.7.3. Cleanup Logbook Entries

Same as Cleanup Logbook Entries in the context menu of the logbook table..

9.7.4. Show Statistics

Shows the logbook statistics dialog. See Logbook Statistics.

9.7.5. Import CSV

Import logbook entries from a CSV file. The entries are added to the logbook database.

9.7.6. Export CSV

Allows to export the full logbook or the selected entries to a CSV (comma separated
value) text file

which can be loaded in LibreOffice Calc or Microsoft
Excel. See Import and Export.

9.7.7. Import X-Plane Logbook

Import the X-Plane logbook file
.../X-Plane 11/Output/logbooks/X-Plane Pilot.txt into the Little
Navmap

logbook database. Note that the X-Plane logbook format is
limited and does not provide enough

information to fill all Little
Navmap logbook fields.

See X-Plane Import.

9.7.8. Convert Log Entries from Userpoints

Automatically converts all legacy log entries that were collected as
userpoints and copies them to the

new logbook.

9.7.9. Create Logbook entries

Enables automatic logbook entry creation for takeoff and landing.

See also Create Logbook Entries.

9.8. Aircraft Menu

This menu contains functionality for aircraft performance profiles which
allow fuel planning and

traveling time estimation.

See Aircraft Performance and Aircraft Performance Edit for more information.

9.8.1.  New Aircraft Performance

Creates a new performance profile with default values, shows the fuel
report and opens the edit dialog.

A simple default profile for a Cessna C172 is default.



9.8.2.  Open Aircraft Performance

Loads a LNMPERF aircraft performance profile and shows the fuel
report. You can also load a profile by

dragging the file from a file
manager like Windows Explorer into the main window of Little Navmap.

9.8.3.  Save Aircraft Performance

Saves the current profile. Opens a file dialog if not saved before.

9.8.4.  Save Aircraft Performance as

Allows to save the current profile using a new filename.

9.8.5. Recent Performance Files

Shows all recently loaded aircraft performance files for quick access.
You can clear the list by selecting

the sub-menu item Clear Menu.

9.8.6.  Edit Aircraft Performance

Opens Aircraft Performance Edit for
the current performance profile.

9.8.7.  Open Aircraft Performance and Merge

Opens a file loading dialog and subsequently Aircraft Performance Merge which allows to merge or copy

data from the opened file to the current aircraft performance.

9.8.8.  Merge collected Aircraft Performance

Opens Aircraft Performance Merge
which allows to merge or copy data from the collected aircraft

performance to the currently loaded aircraft performance.

See also Aircraft Performance Collection.

9.8.9.  Restart Aircraft Performance Collection

Resets all collected values for aircraft performance to zero and starts
the performance collection over.

See also Aircraft Performance Collection.

9.8.10. Warning for Aircraft Type Mismatch

A warning in the fuel report and the flight plan table footer will be shown if this is enabled and
the

simulator aircraft type does not match the loaded performance file.

See Aircraft Type for more information on changing the type in the aircraft performance edit dialog

window.

Note

Note that MSFS delivers wrong values for the ICAO designator through the SimConnect interface.

Keep this warning disabled if you use MSFS.



9.9. Scenery Library Menu

See Navigation Databases for general information about navigation and simulator data.

9.9.1. Flight Simulators

One menu item is created for each flight simulator installation or
database found. These menu items

allow switching of databases on the
fly.

The menu shows the simulator name as a disabled menu item as an indicator if only one flight

simulator was found.

Note

The selection in the scenery library menus also affects the selection of weather files for ActiveSky

and X-Plane.

The loaded AIRAC cycle is only shown for X-Plane and Navigraph data
since the information is not

available for FSX, P3D and MSFS.

The menu items are suffixed with the following depending on status:

prev. version - reload advised: The found database was created with a previous version of
Little

Navmap and should be reloaded to benefit from bug fixes or improvements.

99 days old - reload advised: The scenery library database was loaded 99 days ago. Scenery

changes in the simulator are very likely
(installed add-on airports, simulator updates and more)

and might not be reflected in the database.

no simulator: A scenery library database was found but no related simulator
installation. This

database cannot be loaded but can be updated by manual copying from another computer, for

example. This will be shown
for a Network Setup where the simulator is not available on the

remote computer.
See Databases for file locations if you wish to remove a database.

This menu is synchronized with simulator selection in Load Scenery Library. Once a
database is

successfully loaded, the display, flight plan and search
will switch over to the newly loaded simulator

data.

Important

Little Navmap does not keep you from using a X-Plane scenery
database while being connected to

FSX/Prepar3D/MSFS or vice versa, for example. You will
get unwanted effects like wrong weather

information if using such a
setup.

An orange warning message is shown in the connect dialog ( Connecting to a Flight Simulator) if a

mismatch is detected.

Some functions like access to weather source files depend on the selected scenery library database.

X-Plane 11 weather files are read if enabled and the X-Plane 11 scenery library is selected, for

example.

Note

The program might change a loaded flight plan if you switch between
different databases. This can

happen if a departure position is set in
the plan which does not exist in the other database. Select

New Flight Plan in the menu File before switching to avoid this.

9.9.2. Navigraph

This sub-menu also shows the AIRAC cycle if a Navigraph
database is found in the database directory.

Use this indication to verify if an database update was successfull.
See Little Navmap - Install

https://albar965.github.io/littlenavmap_navigraph.html


Navigraph Updates [https://albar965.github.io/littlenavmap_navigraph.html] for installation options if you run into

issues..

The right navdata mode is selected automatically per default. See below for more information.

The recommended selection depends on the simulator setup. Little Navmap will show dialog windows

describing the recommended modes after loading a scenery library database or after selecting Validate

Scenery Library Settings
if Select automatically is not enabled.

Note

Note that the Navigraph selection in this menu is remembered separately for each simulator

selection. This means that
the Navigraph selection is automatically changed when switching between

simulators if Select automatically is not enabled.

Use the menu item Scenery Library -> Validate Scenery Library Settings to check your settings.

See the chapter Navigation Databases for more information about scenery databases and the three

different display modes below.

Note that airspaces are not affected by this selection. See Airspace Libraries below.

9.9.2.1. Select automatically

Selects the right mode of the Navigraph navdata library database automatically, if checked.
This

function is enabled per default and it is recommended to keep it enabled.
The selection of the right

mode depends on the following criteria:

1. Selected simulator (X-Plane, MSFS, etc.)

2. Simulator database status (empty or not)

3. Navdata AIRAC cycle

4. Navdata update installed in MSFS or not

5. Simulator data AIRAC cycle (if available)

The navdata mode is applied when switching between simulators or after compiling a database.

The automatically selected mode can be seen in the disabled menu items in menu Navigraph or in the

Window Title.

The mode Use Navigraph for all Features is enabled if the simulator database is empty to have airports

available for planning.
This mode is selected after a fresh installation, for example. It is independent of

the AIRAC cycle.

9.9.2.2. Use Navigraph for all Features

Completely ignores the simulator database and takes all information from
the Navigraph database.

This mode is automatically selected if the simulator navdatabase is empty.

Note

Airport information is limited in this mode.
This means that aprons, taxiways, parking positions,

runway surface
information and other information is not available.
Also, smaller airports will be

missing.
Runway layout might not match the runway layout in the simulator if you use stock or older

airport scenery.

The Little Navmap window shows a (N) in the title bar and white runway surfaces if this is selected.

9.9.2.3. Use Navigraph for Navaids and Procedures

This mode blends navaids from the Navigraph database with airports from the
simulator database. This

affects the map display, all information and
all search windows.

https://albar965.github.io/littlenavmap_navigraph.html


9.9.2.4. Do not use Navigraph Database

Ignores the Navigraph database and shows only information read from the
simulator scenery.

Note

Navdata read from FSX, P3D or MSFS has limitations. The airway network might not be correct
and

procedures can have errors.

9.9.3. Airspace Libraries

Enables or disables various airspace databases for display.

9.9.3.1. Simulator

Toggles display of simulator airspaces. These also change when changing
the simulator database in the

Scenery Library menu.

See also X-Plane Airspaces and
FSX, Prepar3D and MSFS Airspaces.

9.9.3.2. Navigraph

Shows the airspaces from the included or updated Navigraph database.
This is independent of the

selected simulator.

9.9.3.3. User

Selects user airspaces for display. This source is independent of the
selected simulator.

See also Loading Airspaces and Load User Airspaces.

9.9.3.4. Online

Selects the online centers for display.
Only enabled if connected to an online service like VATSIM or

IVAO.

9.9.4.  Load User Airspaces

Shows a dialog window where user airspaces can be loaded.

See Loading Airspaces for information about loading airspaces into the Little Navmap database and

Airspace Libraries for information how to select airspace sources to display.

9.9.5.  Validate Scenery Library Settings

Tests if the currently selected scenery library selection corresponds to the recommended modes.
Shows

a dialog window describing the recommended selection if changes are required.

See the chapter Navigation Databases and Load Scenery Library for more information.

9.9.6.  Load Scenery Library

Open the Load Scenery Library dialog which loads all files from a simulator scenery library like navaids,

airports and more into an internal database. See Load Scenery Library for more information.

9.10. Tools Menu

9.10.1.  Flight Simulator Connection



Opens the Connect dialog allowing Little Navmap to connect directly
to a flight simulator, the Little

Xpconnect X-Plane plugin, or
remotely using the Little Navconnect agent.
See Connecting to a Flight

Simulator for more
information.

9.10.2. Toggle Flight Simulator Connection

Switches the simulator connection on and off without opening the connection dialog.

9.10.3. Run Webserver

Starts the internal web server of Little Navmap. Access the web page
using the menu item Open

Webserver Page in Browser below.

See Web Server for detailed information and Web Server for configuration options.

9.10.4. Open Webserver Page in Browser

Only enabled if the web server is running. Opens the web server page in
your default browser. The

default address is like
http://YOUR_COMPUTER_NAME:8965 or http://localhost:8965.

This function might not work depending on your network setup.
Enter the computer name as above

manually in your browser if this is the case.

9.10.5. Reset all Messages

Re-enable all dialogs that were disabled by selecting
Do not show this dialog again or similar messages.

All warning and note dialogs will show up again after selecting this. Hide them again manually by

selecting the Do not show this dialog again buttons.

9.10.6. Reset all Settings and Restart

This will reset all options, window layout, dialog layout, aircraft
trail, map position history and file

histories back to default values
and restart Little Navmap after showing a warning dialog.

User features like range rings, traffic patterns, holds as well as
scenery, logbook and userpoint

databases are not affected.

A backup copy of the settings file little_navmap.ini is created in
the configuration directory. See

Configuration.

Use this function instead of deleting the settings directory if you see
crashes or other issues with the

program.

9.10.7. Save Options and Application State

Saves all options, dialog settings, tab arrangements and the window
layout. This is normally only done

when exiting Little Navmap.

9.10.8. Create Directory Structure

Little Navmap creates a recommended directory structure when selecting this menu item.

See Directories for more information.

Note that Little Navmap does not require a fixed directory structure for its files.
You can always save

and load all files to and from arbitrary places.

9.10.9. Files and Directories

9.10.9.1. Open Log File

Shows the log file abarthel-little_navmap.log in the default text editor.
This can be used to track down

errors or crashes.



See also Logs for details.

Note

This file combined with Open Configuration File below is the best way to report an issue.

Immediately save this log to another file if you’d like to report problems with Little Navmap.
The log

file might be overwritten if you continue your flight.
See How to report a Bug for more information

about reporting bugs.

9.10.9.2. Open Configuration File

Shows the main little_navmap.ini configuration file in the default text editor.

See also Configuration for details about the used files.

Warning

There is usually no need to edit this file directly.
Editing this file the wrong way might crash Little

Navmap.

9.10.9.3. Show Database Files

Open Little Navmap’s database directory in a file manager. See Running without Flight Simulator

Installation
for more information on copying database files between different computers.

See also Databases for details about the different database files.

9.10.9.4. Show Map Cache

Opens the file manager with the disk cache directory that is used to store all the downloaded online

map tile
images.

See also Disk Cache for details.

9.10.9.5. Show Map Installation Directory

Opens the file manager with the installation directory for additional map themss.

See also Installing Map Themes for more information about additional map themes.

9.10.10.  Flight Plan Table Display Options

See Flight Plan Table Display Options.

9.10.11.  Aircraft Progress Display Options

See Aircraft Progress Display Options.

9.10.12.  Elevation Profile Display Options

See also Elevation Profile Display Options.

9.10.13.  Options

Opens the dialog window Options which allows to change the user interface, map display, weather and

more.



Note

The menu entry which is referenced as Tools -> Options in this manual
for Windows and Linux
can be

found in the application menu at Little Navmap -> Preferences on macOS.

9.11. Window Menu

9.11.1. Shortcuts

A list of menu items that open and raise the respective dock window and
tab. See Window shortcuts for

a full list.

Some shortcuts also activate search fields or tables like the airport
ICAO search when using Airport

Search or pressing F4. This
allows to quickly look for an airport or other feature by just pressing
a

function key and entering the ICAO code.

9.11.2. Map Overlays

Show or hide floating map overlays, like the overview on the top left or
the compass on the top right

corner of the map window.

You can also right click on a map overlay to hide it from the context menu.

9.11.3. Style

Allows to switch the style of the graphical user interface on the fly. A
restart is not needed.

The user interface styles contain a mode Night which can be used for
flights in a dark environment. You

can also dim the map and elevation
profile display for this style in the dialog Options on
Map Display

User (Map Dimming in Night Style at the bottom of the dialog).

The colors for the styles Fusion and Night can be changed by
editing configuration files. See Customizing

General for more
information.

The available styles depend on the operating system except for
Fusion and Night which are always

available.

9.11.4. Open Window Layout

Opens a LNMLAYOUT file and applies the changes like visibility, position and floating status directly to

the
dock windows. Size and position of the main window is also restored.

Full screen and normal layouts are both loaded from this file.

See Window Layout for more information.

9.11.5. Save Window Layout as

Saves visibility, position and floating status of all dock windows as well as the size and position
of the

main window to a LNMLAYOUT file.

Note that the layout for the fullscreen and normal view are save together in this file.

See Window Layout for more information.

9.11.6. Recent Window Layouts

List of recently saved or loaded window layout files. Select one to load and apply the layout.

9.11.7. Reset Window Layout

Reset the main window layout back to default. This involves visibility,
position and state of all dock

windows as well as the Toolbars and the Statusbar. Tabs are not affected by this.



This function can be helpful if a dock window gets lost on multi monitor setups or other issues.

Note that the dock windows Search and Simulator Aircraft are stacked in the default layout.
You can

access both using the tabs at the lower right position of the main window.

See Window Layout for more information on window layouts.

9.11.8. Reset Tabs to Default

Resets all tabs to default. Opens all closed tabs, unlocks the tab layout and restores the default order.

This is the same as clicking Reset Tab Layout in each tab context menu.

See Tabs for more information on tabs.

9.11.9.  Fullscreen Map

Maximizes the map window and hides all dock windows as well as the toolbars.

See Fullscreen for more information on fullscreen mode.

9.11.10. Keep in Foreground

Forces the main window of Little Navmap to remain in foreground of all other applications.

9.11.11. Show all floating Windows

Raises all undocked (i.e. floating) windows before the main window. This
can be helpful if a window got

lost. See Dock Windows for more information about floating dock
windows.

9.11.12. Allow Window docking

This is enabled per default. Disable this if you do not want floating (i.e. undocked) dock windows to

snap back into the main window while moving them around. See also Dock Windows.

9.11.13. Allow Dock Window moving

Enabled per default. Disable this to avoid moving dock windows around when accidentally clicking
and

dragging the title bar which can mess up the window layout. Disabling this function still
allows to move

floating (i.e. undocked) windows around.

You can still resize the docked windows at the border between them and you can still turn a docked

window into a floating window by double clicking on the title bar. See also Dock Windows.

9.11.14. Show Dock Window Title Bars

Hides the title bars of all docked (i.e. not floating) windows to save screen space if not checked.
You

can still resize the docked windows at their borders but you cannot drag them around. Dock
windows

can still be opened from the toolbar or using keyboard shortcuts.

Enable this if you’d like to undock windows or drag them around. See Dock Windows for more

information.

9.11.15.  Search

9.11.16.  Flight Planning

9.11.17.  Information



9.11.18.  Flight Plan Elevation Profile

9.11.19.  Simulator Aircraft

Open or close these dock windows. The map dock window cannot be closed.
The whole dock window

stack is closed if a dock window is part of a
stack. See Dock Windows for more information about

stacked dock windows.

Note that the Flight Plan Calculation window cannot be docked and remains in floating state.
The

altitude from the current flight plan is not copied to the calculation window when using this function.

9.11.20. File Toolbar

9.11.21. Map Toolbar

9.11.22. Map Options Toolbar

9.11.23. Flight Plan Toolbar

9.11.24. Map Airspaces Toolbar

9.11.25. Dock Window Toolbar

9.11.26. Tools Toolbar

Show or hide these Toolbars.

You can also hide toolbars in the context menu that appears when right clicking on them.

9.11.27. Statusbar

Show or hide the statusbar. See Statusbar for more on the shown information.

9.12. Help Menu

9.12.1.  User Manual (Online)

Show the online user manual in the default web browser. The English user manual is shown if it is
not

available in your language.

You can install additional language packs for Little Navmap which can include a translated manual.

9.12.2.  User Manual - Tutorials (Online)

Shows the online tutorials in the default web browser.

9.12.3.  User Manual - NavMap Legend (Online)

Show the navigation related map legend in the defaul web browser.

9.12.4.  User Manual (Offline, PDF)

Show the included PDF user manual in the default PDF viewer.

You can install additional language packs for Little Navmap which can include a translated PDF manual.



9.12.5.  Frequently asked Questions (Online)

Shows the page Little Navmap - Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html] in the

web browser. Look at these first if you have a question or problem.

9.12.6.  Downloads (Online)

Opens the page Little Navmap Downloads [https://www.littlenavmap.org/downloads/] in the default
web browser

where you can get
aircraft performance files, airspace boundaries,
flight plans, map themes or

userpoints provided by the community.

9.12.7.  Changelog

Opens the included file CHANGELOG.txt in a text editor. This file lists all changes made for each release.

Refer to this file if you think that a function is missing or has been moved.

9.12.8.  About Little Navmap

Show version and revision number for Little Navmap, also contains
links to the database directory,

configuration file, log file and the
author’s contact address.

9.12.9.  About Marble

Display information about the Marble widget [https://marble.kde.org]
that is used to download and show the

maps.

9.12.10.  About Qt

Display information about the Qt application
framework [https://www.qt.io] that is used by Little Navmap.

9.12.11.  Donate for this Program

Opens the donation web page in your default browser.

If you would like to show your appreciation you can donate using PayPal.

Donations are purely optional but greatly appreciated.

 [https://albar965.github.io/donate.html]

9.12.12.  Check for Updates

Allows to manually check for updates. This will also show updates that
were recently ignored by

pressing the Ignore this Update on the
notification dialog.

See Updates for more information.

https://albar965.github.io/littlenavmap-faq.html
https://www.littlenavmap.org/downloads/
https://marble.kde.org/
https://www.qt.io/
https://albar965.github.io/donate.html


10. Statusbar

The statusbar at the bottom of the window shows various information.
Shown or hide it in the menu

Window -> Statusbar.

The statusbar at the bottom of the main window shows various indications (from left to

right):

Messages, last action or quick help

explaining a menu item or toolbar button.
When inactive the field shows the number of messages,

if any. Messages cover background tasks
like weather updates or the simulator connection state.

Messages are shown in the tooltip when clicking into the field or hovering the mouse above.
A

maximum of ten messages is shown.

Connection status

for a local or remote connection. The tooltip
provides more detail about the status, like the host

name for remote
connections as well as the connection status for online networks.

Connecting...: The program is trying to establish a connection
which was initiated either

manually or automatically.

Connected: A connection was established.

Disconnected: The simulator or Little Navconnect exited.

Map content indicator

that shows airport types, airspaces, navaids or AI vehicles
currently visible on the map. The

tooltip gives more details.

A red warning message Too many objects is be shown if too
many objects are displayed on

the map due to too high a detail
level. The map display might be incomplete if this

happens.

A red Database empty message will be shown if the currently
selected database has no

content and needs to be loaded. See Load Scenery Library for more
information how to

load the scenery library for a simulator.

Map detail level.

Range is -2 for least detail to +5 for most detail.
See More Details, Less Details and Default

Details in menu View.

Online map download progress indicator.

This shows the state of the
current map download. The text is prefixed with a red Offline.

indication if offline mode is enabled.

Done: All map data loaded successfully.

Loading: Map data is missing in the cache and was
requested. Now waiting for reply.

Updating: Map data is already loaded but expired
after two weeks. Waiting for new data after

requesting an update.

Incomplete: Download failed.

Zoom distance

viewpoint distance to earth surface in NM
or kilometers.

Coordinates

at cursor position on map as latitude and longitude depending on
selected unit in the dialog

Options on page Units.

Ground elevation below the cursor after a short delay if the
GLOBE

[https://ngdc.noaa.gov/mgg/topo/globe.html] offline
elevation data is selected. See Install GLOBE

elevation data.

Magnetic declination at the cursor position in degrees West or
East. See also Magnetic

Declination for more information.

Current date of month and UTC time

hours:minutes:seconds.
This is the real world time and not the simulator time. The tooltip
gives more

date and time information.

https://ngdc.noaa.gov/mgg/topo/globe.html


Status bar with messages in tooltip about the last weather updates,
the connection status Connecting (FSX/P3D/MSFS)
and

a tooltip that indicates what is currently shown on the map. The map
detail level is unchanged and the map coordinates at

the cursor position
are shown on the bottom right. Altitude at cursor is not shown since
offline elevation data is not

installed. The online map download progress
indicator shows Done indicating all map tiles were downloaded. Zoom
distance

is 1.8 NM.



11. Directories

Little Navmap suggests to create a recommended directory structure on startup. This is purely

optional. You can choose to ignore this
and save your Little Navmap files in arbitrary places. The

program does not require a fixed directory structure for its files.

Menu Tools -> Create Directory Structure allows to create the directory structure later or manually.
The

dialog can also be used to create missing folders in the directory structure. No data is deleted while

doing so.

All default directories are adjusted if you create the directory
structure. This means that file dialogs will

initially point to the right place when saving files.

The following folders are suggested to be created:

Flight Plans: For flight plans in Little Navmap’s own format LNMPLN. See Flight Plan Multiexport

for
exporting flight plans to other formats usable by simulators, aircraft or tools. See also
Little

Navmap LNMPLN Format for information about this format.

Aircraft Performance: Directory for aircraft performance files LNMPERF. See Aircraft Performance

for
more information.

Window Layouts: For saved window layouts LNMLAYOUT. See Window Layout or Dock Windows.

Airports: A place to store PDF, text, image or other files that are linked in the airport
information.

Chapter Files gives more information about this feature.

User Airspaces: User defined airspaces in OpenAir format. See Load Scenery Library.

GLOBE Elevation Data: A place for the GLOBE data used by the flight plan elevation profile.
Look at

chapter See Install GLOBE elevation data for installation instructions.

Map Themes: This directory is used to lookup additional map themes for the background map layer.

See Map Themes for installation instructions. The path can also be set manually in options on

page
Cache and Files, section Map Display Themes.

Note

The directory names depend on the chosen user interface language.
See options on page User

Interface for information how to change the program language.



12. Map Display

12.1. Map Layers

Little Navmap uses two layers to display the map.

12.1.1. Background Map Layer

This is defined by offline or online map themes like the OpenStreetMap [https://www.openstreetmap.org].
You

can change the background by selecting another Theme.
The background maps cannot be modified or

configured since they are fetched from third party online services.
Little Navmap downloads pre-

rendered image tiles from these services to draw the background map.

See Map Themes for more information about how to install additional map themes.

The OpenStreetMap background map showing aprons and taxiways of EDDF. These might not reflect what
you see in the

simulator and are not taken from your scenery library including add-on airports. You can see the
same here on the

OpenStreetMap [https://www.openstreetmap.org/#map=16/50.0357/8.5300]
web page which delivers the background

map tiles for Little Navmap.

12.1.2. Foreground Map Layer

The foreground layer which is drawn by Little Navmap and can be customized in the options dialog on

the map pages.
It consists of airports, navaids, airways, airspaces, userpoints, measurement lines,

range rings, holds, traffic patterns, MSA diagrams
and all moving objects like AI and the user aircraft.

This layer reflects airports as stored in
the scenery library of your simulator. This applies to stock and

add-on airports.

Only this layer provides the objects which enable tooltips and the functionality of the context menus to

build a flight plan.

https://www.openstreetmap.org/
https://www.openstreetmap.org/#map=16/50.0357/8.5300


Aprons, taxiways and runways drawn by Little Navmap. These reflect your simulator stock or
add-on scenery. Tooltips are

available.
Airport features can be disabled on options page Map Display Labels.
See Legend for details about the various

symbols shown by the map.

12.2. Moving

See Mouse Clicks and Key Commands in the map legend for information about how to move around the

map using the mouse or keyboard.

Note

Do not forget to activate the map window by clicking into it or pressing
F2 before using keys for

movement.

12.3. Mouse Clicks

A single click shows details about all map objects at the clicked
position in the Information dock window.

Windows and tabs are raised
depending on clicked objects.

The procedure search window can be raised optionally if clicking an airport.
This can be enabled in the

options dialog on page Map. Check Show procedures on airport
click to enable this function.

A single click on an user aircraft, AI aircraft or multiplayer aircraft
shows details in the Simulator Aircraft

dock window.

A double-click zooms in showing either the airport diagram or the navaid
closely and also shows details

in the Information dock window. The
same applies for all AI or multiplayer aircraft or ships.

The double-click and single-click functionality does not work for flight
plan waypoints or airports if the

flight plan edit mode is enabled. The
edit mode can be disabled using the toolbar or Flight Plan ->
Edit

Flight Plan on Map in the main menu. See also Map Flight Plan Editing.

The mouse click sensitivity can be adjusted in the Options dialog on
the page Map Navigation.

Note

The center of the airport symbol is the hotspot for right or left click actions as well as for
tooltip

display. This is also the case if the whole airport diagram is visible.



The same applies to all navaids as well as airport parking spots where the center is the hotspot
for

clicks.

12.4. Mouse Click Hotspots

Map marks like range rings or measurement lines have hotspots to indicate that a modifier-click
like

Ctrl+Click can remove them or an action is available in the context menu. The same applies
to the flight

plan drag and drop editing mode.

The mouse cursor changes into a hand  to indicate a click
spot.

Click spots and hotspots for tooltips are:

Center of all airport, airport parking and navaid symbols.

Navaids for the procedure preview (Preview and Highlights).

Center of range rings (small circle).

Center of MSA diagrams (small circle).

Start and end of a measurement line (circle and cross).

Runway threshold point (small circle) for airport traffic patterns.

Holding fix (small triangle) of a user holding.

12.5. Mouse Clicks and Modifiers

You can use the keyboard and mouse clicks to get quick access to some functions.

See Mouse Clicks in the map legend for more information about this.

Clicking again on a hotspot removes the mark, measurement line or flight plan waypoint, for example.

12.6. Aircraft

The user aircraft and AI or multiplayer aircraft or ships will be shown
on the map if the program is

connected to a flight simulator. Color
indicates user or AI or multiplayer vehicle and the symbol shape

indicates if the aircraft is an piston/turboprop, jet, helicopter or a
ship. The symbol outline changes to

gray if an aircraft is on ground.

Note that not all simulators and online networks provide enough information to show the correct

aircraft shape.

Little Navmap limits the display of AI vehicles depending on size. Zoom
close to see small aircraft or

boats

AI and multiplayer aircraft on ground are shown only on small zoom
distances to avoid cluttered

airports. This means that an AI aircraft
can disappear from the map when landing on an airport.

Labels are shown depending on zoom level and distance to user aircraft as well.
Zooming out drops the

less important aircraft labels, for example. Flight number and registration are always shown.

A yellow wind arrow and labels for the situation around the user
aircraft can be displayed on the top

center of the map. The displayed
labels for aircraft can be configured in the dialog Options on
Map

Display Labels. No labels are shown for ship traffic.

See Aircraft and Ships for details about the aircraft type.

Tip

On the lowest zoom distance all aircraft are drawn to scale as are the
parking spots which means

you can easily check if your aircraft fits on
an apron, parking spot or taxiway.

12.7. Tooltips



Hovering the mouse over the map will show tooltips for all map objects
including airports, VOR, NDB,

airways, parking, fuel box, towers,
aircraft and ships. The tooltip is truncated and shows a message

More ... if it gets too long. In that case reduce details or zoom in
closer. Disable Verbose tooltips in

options on page Map if you do not like the large tips.

The sensitivity for the tooltip display can be adjusted in the
Options dialog on Map Navigation.

You can select which tooltips to show in options on page Map.

Tooltip with information for an airport and a VOR. Click image to enlarge.

Tooltip with information about airspaces. Click image to enlarge.

12.8. Highlights

Airports, navaids or other features that are selected in the flight plan
table or in a search result table

are highlighted on the map with a
green/black or a yellow/black ring respectively (colors at default

settings).

Waypoints that are selected in the procedure preview are highlighted
with a blue/black ring using

default colors.

These highlight circles provide all functionality of visible map
objects, even if the objects are not shown

at the current zoom distance
(ring is empty). This allows double-click for zoom in, single-click for

information dock window and all context menu entries.

You can use Map -> Remove all Highlights and Selections to remove all
highlights from the map.

Colors and appearance can be customized in options on page Map Display User.

12.9. Flight Plan



You can enable or disable the display of the flight plan as well as missed approaches in the menu and

toolbar.

All features which are part of the flight plan are forced to be shown even if they are disabled in
the

menu. This means that destination, departure and alternate airport symbols as well as diagrams
are

shown even if airport display is disabled. The same applies to all navaids and approach ILS.

Colors and appearance of the flight plan can be customized in options on page Map Display Flight Plan.

Labels can be changed on options page Map Display Labels.

Tip

Hide all map features to get a clean view on flight plan related airports and navaids only.
This will

hide all unneeded map objects but keeps all navaids and related navaids for procedures like ILS for

the approach on the map.

12.10. Airport Diagram

The display will change from a single icon to an airport diagram if you
zoom in deep enough to an

airport. The diagram shows all taxiways,
parking positions, gates, runways and more.

The airport diagram provides more information through tooltips at the center of
parking and tower

positions. A right-click on a parking position opens
the context menu and allows to select the start

position for flight plan
departure.

See Airport Diagram for details about the airport diagram.

Airport labels and diagram features can be changed on options page Map Display Labels.
Disable all

airport features except runways if you’d like to rely on the airport diagrams of the OpenStreetMap

background map, for example.

High level view of the airport diagram of EDDH. Click image to enlarge.



Detailed view of the airport diagram. Shows blue
gates on the right and green general aviation ramp parking spots
on the

left. Long displaced threshold of runway 33 is visible. Dashed
yellow lines indicate taxi paths. Click image to enlarge.

12.11.  Map Projection

The map projection can also be changed in the main menu View -> Projection or with the toolbar button

.
Note that the drop down menu of the toolbar button can be torn off by clicking on the dashed

line in the menu (Tear off Dropdown Menus).

Two projections can be selected in Little Navmap:

Mercator

A flat projection that gives the most fluid movement and the sharpest
map when using picture tile

based online maps themes like
OpenStreetMap or OpenTopoMap.

Note that this projection cannot be used near the poles. Use the spherical projection if you fly in

Antarctica, for example.

Spherical

Shows earth as a globe which is the most natural projection. Movement
can stutter slightly when

using the picture tile based online maps
themes like OpenStreetMap or OpenTopoMap. Use the

Simple,
Plain or Atlas map themes to prevent this.

Online maps can appear slightly blurred when using this projection. This
is a result from

converting the flat image tiles to the spherical
display.



Spherical map projection with Simple offline map theme selected.

12.12.  Map Themes

The map theme can be changed in main menu View -> Theme or with the toolbar button  which

can be torn off by
clicking on the dashed line in the menu (Tear off Dropdown Menus).

This allows to change the map theme which defines the look and feel of the background map (Map

Layers).

See Map Display Keys for more information on themes requiring a login or an account.
Map Themes

explains how to create your own themes and how to install additional themes.

Tip

Also check out the Little Navmap Support Forum at
AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-

little-navconnect-little-logbook-support-forum/],
Little Navmap Downloads - Map Themes

[https://www.littlenavmap.org/downloads/Map%20Themes/] and
LittleNavmapOFMTheme

[https://github.com/AmbitiousPilots/LittleNavmapOFMTheme] for more map themes.

Note

Please note that all the online maps are delivered from free services
therefore fast download speeds

and high availability cannot be
guaranteed.

In any case it is easy to deliver and install a new online
map source without creating a new Little

Navmap release.
See Map Themes for more information.

The following map themes are included per default:

CARTO Dark Matter

A dark map.
Map tiles and style by CARTO [https://carto.com/]. Data by
OpenStreetMap

[https://www.openstreetmap.org], under
ODbL [https://www.openstreetmap.org/copyright].

CARTO Positron

https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/
https://www.littlenavmap.org/downloads/Map%20Themes/
https://github.com/AmbitiousPilots/LittleNavmapOFMTheme
https://carto.com/
https://www.openstreetmap.org/
https://www.openstreetmap.org/copyright


A very bright map called Positron which allows to concentrate on the
aviation features on the map

display.
Map tiles and style by CARTO [https://carto.com/]. Data by
OpenStreetMap

[https://www.openstreetmap.org], under
ODbL [https://www.openstreetmap.org/copyright].

open flightmaps

A high quality VFR map provided by open flightmaps [https://www.openflightmaps.org/].
Note that details

are visible at lower zoom distances smaller than 50 NM or 100 km.

OpenStreetMap

This is an online raster (i.e. based on images) map without hill shading.
The tiles for this map are

provided by OpenStreetMap [https://www.openstreetmap.org].
Data by OpenStreetMap

[https://www.openstreetmap.org], under ODbL [https://www.openstreetmap.org/copyright].

OpenTopoMap

An online raster map that mimics a topographic map. Includes integrated hill
shading and

elevation contour lines at lower zoom distances.
The tiles for this map are provided by

OpenTopoMap [https://www.opentopomap.org].

View at the eastern Alps using OpenTopoMap theme. A flight plan is shown north of the Alps.

Stamen Terrain

A terrain map featuring integrated hill shading and natural vegetation colors. The
hill shading is

available worldwide.
Map tiles by Stamen Design [https://stamen.com], under CC BY
3.0

[https://creativecommons.org/licenses/by/3.0]. Data by
OpenStreetMap [https://www.openstreetmap.org], under
ODbL

[https://www.openstreetmap.org/copyright].

https://carto.com/
https://www.openstreetmap.org/
https://www.openstreetmap.org/copyright
https://www.openflightmaps.org/
https://www.openstreetmap.org/
https://www.openstreetmap.org/
https://www.openstreetmap.org/copyright
https://www.opentopomap.org/
https://stamen.com/
https://creativecommons.org/licenses/by/3.0
https://www.openstreetmap.org/
https://www.openstreetmap.org/copyright


View showing Stamen Terrain theme.

Political Map (Offline)

This is an offline political map using colored country polygons. Boundaries and
water bodies are

depicted coarse. The map included in Little Navmap
has an option to display city and country

names.

Plain Map (Offline)

A very simple offline map. The map is included in Little Navmap and has an
option to display city

and country names. Boundaries and water bodies
are depicted coarse.

Atlas (Offline)

A very simple offline map including coarse hill shading and land colors. The map
is included in

Little Navmap and has an option to display city and
country names. Boundaries and water bodies

are depicted coarse.

Mapbox Outdoors, Mapbox Satellite, Mapbox Satellite Streets, Mapbox User, MapTiler Topo,

Thunderforest Atlas and Thunderforest Landscape

These maps require a registration at the respective sites to get access to the map tiles.
You can

enter the keys in Options on page Map Display Keys which also contains direct links to the login

pages.

12.13. Context Menu Map

The map context menu can be activated using right-click or the menu key.
Menu items are enabled or

disabled depending on selected object and some
menu items contain the name of the selected map

object for
clarification.

Mouse click modifiers like Ctrl+Click are shown as a hint on the right side of the
context menu.

Little Navmap automatically inserts a sub-menu replacing the menu item
if more than one appropriate

map object was found below the cursor. This helps to select
the right airport from a dense map which

displays many airports in one spot, for example.

Some menus add an additional item Position to the sub-menu which inserts a plain position
instead of

the navaid or an airport at the clicked position.

Menu items are disabled if their function does not apply to the clicked map object. Hints showing the

reason are
appended to the menu text like (has not procedure) for an airport.



The various sub-menus of the map context menu. Image based on Little Navmap 2.6.19. Click image to enlarge.

Tip

Look at the left side of this online user manual to see all the menu items in a tree like structure.

12.13.1.  Show Information

Show detailed information in the Information dock window for the
nearest airport, airway, airspace,

navaid or aircraft which name is shown in the
menu item.

If you like to see information on all objects nearby a click position do
a single left click into the map.

See Information for details.

12.13.2.  Set as Departure

This is active if the click is at an airport symbol center, an airport parking
position center or a fuel box.

It will either replace the current flight plan
departure or add a new departure if the flight plan is empty.

The airport and parking position will replace both
the current departure and start position if a parking

position is
clicked within an airport diagram.

12.13.3.  Set as Destination

This menu item is active if the click spot is at an airport. It will either
replace the flight plan destination

or add the airport to the plan if the flight
plan is empty.

12.13.4.  Set as Alternate



This menu item is active clicked at an airport. Selecting this item adds
the airport as an alternate to the

current flight plan.

More than one alternate can be added to the flight plan. Legs to the
alternate airports originate all from

the destination.

This menu item is disabled if airport is selected as destination or already an alternate.

The distance to the farthest alternate is considered in the fuel calculation.

Note that you have to activate an alternate leg manually if you would like to fly it
(see Activate Flight

Plan Leg).

12.13.5.  Set Departure Runway

Selecting a departure runway also adds a departure flight plan leg depicting the extended runway

center line. The length of the extended center line can be adjusted in the dialog window.
See Departure

and Destination Runway for more information.

The text of this menu item varies depending if the airport is already the departure in the flight
plan or

not.

12.13.6.  Set Destination Runway

Selecting a destination runway add a final approach leg and which can be
customized by changing

altitude at final, length and offset angle. This allows Little
Navmap to give vertical guidance and to

show ILS and/or VASI slopes at
the destination.
See Departure and Destination Runway for more

information.

The text of this menu item varies depending if the airport is already the destination in the flight
plan or

not.

12.13.7.  Show Procedures

Open the procedure search tab of the search dock window and displays all
procedures for the airport.

The menu item text varies depending if the airport is a part of the flight plan.

See Search Procedures for more information.

12.13.8.  Insert Procedure

Active if clicked on a waypoint of the procedure preview (see Preview all Procedures and Search

Procedures).
Allows to add a SID, STAR or approach procedure with their respective transitions to the

flight plan.

12.13.9.  Add Position to Flight Plan

Insert the clicked object into the nearest flight plan leg. The object
will be added before departure or

after destination if the clicked
position is near the flight plan end points.

The text Position in the menu is replaced with an object name if an airport,
navaid or userpoint is at the

clicked position.

An user defined flight plan position (green square) is added to the plan if no airport
or navaid is near

the clicked point.



An userpoint is converted to an user defined flight plan position if
added to the plan.

Note

You cannot edit flight plan legs that are a part of a procedure or between procedures. Procedures
will

not be deleted or modified by this function.

Tip

All information from a userpoint like remarks, ident, region and name are copied to the
flight plan

position if you right click on a userpoint and select Add Position to Flight Plan
or Append Position to

Flight Plan.

12.13.10.  Append Position to Flight Plan

Same as Add Position to Flight Plan but will always append the
selected object or position after the

destination or last waypoint of
the flight plan. Otherwise the same as Add Position to Flight Plan.

This will remove STAR and approach procedures from the current flight plan, if any.

12.13.11.  Delete from Flight Plan

Delete the selected airport, navaid or user flight plan position from
the plan. This can be departure,

destination, alternate airport, an
intermediate waypoint or a procedure.

Deleting a waypoint of a procedure removes the procedure and its transition. Deleting a waypoint of a

transition
removes only the transiton but not the related procedure.

This also applies to the runway extension legs when selecting a departure or destination runway

(Departure and Destination Runway).

12.13.12.  Edit Flight Plan Position or Edit Flight Plan Position Remarks

Two options exist depending on the waypoint type:

Edit Flight Plan Position Remarks: Add remarks to a flight plan waypoint which is not an alternate

airport and not a part of
a procedure. See Edit Flight Plan Remarks.

Edit Flight Plan Position: Change the ident, name, remarks or position of an user defined
flight

plan waypoint. See Edit Flight Plan Position. You can edit the coordinates directly instead of

dragging the flight plan position (Map Flight Plan Editing). See Coordinate Formats for a list of

formats that are recognized by the edit dialog.

12.13.13.  Measure Distance from here

Starts to draw a measurment line which gets fixed on a second click.

See Measure Distance and User Features for more information.

12.13.14.  Add Range Rings

Opens a dialog which allows to set the parameters for one or more range rings.

See Range Rings and User Features for more information.



The display of range rings is automatically enabled in menu View -> User Features ->
Range Rings after

using this function.

12.13.15.  Add Navaid Range Ring

Show a ring around the clicked radio navaid (VOR or NDB) indicating the
navaid’s range. A label shows

ident and frequency and the ring color
indicates the navaid type.

The display of range rings is automatically enabled in menu View -> User Features ->
Range Rings after

using this function.

See Range Rings and User Features for more information.

Note that the accuracy of radio navaid range varies across different simulators.

12.13.16.  Add Traffic Pattern

This menu item is enabled if clicked on an airport. Shows a dialog that
allows to customize and display

an airport traffic pattern on the map.

See Traffic Patterns and Airport Traffic Pattern in the map legend.

The display of traffic patterns is automatically enabled in menu View -> User Features ->
Traffic Patterns

after using this function.

12.13.17.  Add Holding

Display a holding pattern at any position on the map. The hold
may also be attached to navaids. Opens

a dialog for customization if selected.

See chapter Holdings and Holding in the map legend for more information.

The display of user holdings is automatically enabled in menu View -> User Features ->
Holdings after

using this function.

12.13.18.  Add MSA Diagram

Adds a to-scale MSA diagram when right clicking on the smaller MSA symbol at an airport, navaid or

other feature.

The display of user MSA diagrams is automatically enabled in menu View -> User Features ->
MSA

Diagrams after using this function.

See Minimum Sector Altitude and Navaids in the map legend for more information.

12.13.19.  Remove User Feature

Removes a map feature added by the user.

Removes the selected measurment line. This menu item is active if you right-click on
the end

point of a distance measurement line (small cross).

Removes the selected range rings from the map. This menu item is active if you
right-click on

the center point of a range ring (small circle).

Enabled if clicked on the airport traffic pattern hotspot (white filled
circle at runway threshold)

which is indicated by a hand cursor.

Enabled if clicked on the holding hotspot (holding fix, white filled triangle)
which is indicated by

a hand cursor.



Removes the selected MSA diagram from the map. This menu item is active if you
right-click

on the hotspot of a user added MSA diagram (small circle in center).

12.13.20.  Mark Airport as Add-on

Marks an airport with a yellow circle as add-on.

This function will add a userpoint of type Addon  filled with the airport information at the clicked

airport position.
Note that the userpoint is not attached to the airport and will not be hidden with

airports and is not affected by airport filters.

You can add you own userpoint type names starting with Addon to create more add-on categories. See

Icons for more information.

See chapter Userpoints for more information how to edit or remove the highlight.

12.13.21.  Userpoint

12.13.21.1.  Add Userpoint

Add an user defined point to the userpoints. A dialog shows up where more information can be

entered. Some fields of the
userpoint dialog are populated automatically depending on the clicked
map

object and previously added userpoints.

Coordinates are always filled-in. If the selected object is an airport
or navaid, an userpoint of type

Airport  or Waypoint  respectively
is created and the fields Ident, Region, Name and Altitude are

filled-in. The same applies to NDB , VOR  and other navaids.

If the selected position is empty map space, an userpoint of type
Bookmark  is created at this position.

Altitude is only filled-in if GLOBE
offline elevation data is installed. See Install GLOBE elevation data.

See Add Userpoints for more information.

12.13.21.2.  Edit Userpoint

Open the edit dialog for an userpoint. Only enabled if the selected
object is an userpoint. See Edit

Userpoints.

12.13.21.3.  Move Userpoint

Move the userpoint to a new position on the map. Only enabled if the
selected object is an userpoint.

Left-click to place the userpoint at the new position. Right-click or
press the escape key to cancel the

operation and return the userpoint to
its previous position.

12.13.21.4.  Delete Userpoint

Remove the user defined waypoint from the userdata. The action can be undone in the main menu

Userpoint.
Only enabled if the selected object is an userpoint.

12.13.22.  Edit Log Entry



Active when clicked on the blue great circle line, the blue flight plan preview or an airport of a
logbook

entry highlight.

Allows to edit the respective logbook entry. See Edit Logbook Entry.

12.13.23.  Fullscreen Map

Same as Fullscreen Map. Only visible in fullscreen mode.

12.13.24. More

12.13.24.1.  Jump to Coordinates

Same function as in main menu Map -> Jump to Coordinates.

See Jump to Coordinates for more information.

12.13.24.2.  Show in Search

Show the nearest airport, navaid, userpoint, online client or online
center in the search dialog. The

current search parameters are reset
in the respective tab.

12.13.24.3.  Copy to Clipboard

Copies the coordinates at the clicked position into the clipboard.

The coordinate format depends on the selection in Options on page Units.

12.13.24.4.  Set Center for Distance Search

Set the center point for the distance search function. See Distance search. The center for the distance

search is highlighted by a  symbol.

The symbol cannot be hidden. Set it at a remote position if you like to hide it.

Note that the symbol is only an indicator for the search center position and does not have a context

menu or a mouse action attached.

12.13.24.5.  Set Home View

Set the currently visible map view as your home view. The center of the home area is highlighted by a 

 symbol.

You can jump to the home view by using main menu Map -> Goto Home.

The symbol cannot be hidden. Set it at a remote position if you like to hide it.

Note that the symbol is only an indicator for the home view center position and does not have a

context menu or a mouse action attached.



13. Legend

By default, all speeds are given in knots (kts), distances in nautical miles (NM),
altitudes and elevations

in feet (ft). The units can be set to imperial or
metric in the dialog Options on Units.

Colors, size and text labels of map elements can be changed in the
dialog Options on Map Display, Map

Display Flight Plan, Map Display User and Map Display Labels.
This legend shows the default values.

Heading and course are suffixed with °T for true course or °M for magnetic course. °T/M is shown if both

courses are equal.

See also Map Display.

13.1. Mouse Clicks

The display of a map feature class will be enabled if you use on of
these mouse clicks. A Shift+Click will

enable display of range
rings after adding one, for example. A second Shift+Click into the center (active

point)
will remove the range rings.

You can enable or disable visibility in menu
View -> User Features or the toolbar.

A click in the map on the active spot (Mouse Click Hotspots) of a feature like a range ring
removes it.

The cursor changes to a hand symbol to indicate an active
spot which allows to remove a feature by

click or remove/edit it in the
context menu.

Mouse Description

Single Click Show information about all
features near the cursor
position.

Double Click Zooms to the clicked feature and
shows information.

Shift+Click Add or remove range rings or
navaid range rings.

Ctrl+Click Start great circle line
measurement or delete measurement
line.

Ctrl+Shift+Click Add or edit an userpoint.

Ctrl+Alt+Click Insert airport, navaid, userpoint
or position into the nearest
flight plan leg.

Shift+Alt+Click Append airport, navaid, userpoint
or position to flight plan.

Wheel Zoom in or out.

Shift+Wheel Zoom in or out in small steps.

Ctrl+Wheel Increase or decrease map details.

13.2. Key Commands

You have to activate the map window (i.e. click into it or press the key F2) before you can use the

keyboard shortcuts.



See Keyboard Shortcuts for a complete list of shortcuts.

Key Description

Cursor keys Scroll the map.

+ and - Zoom in and out.

* and / Zoom in and out in small steps.

Alt+Left and Alt+Right Go forward or backward in the map
position history.

Ctrl++ and Ctrl+- Increase or decrease map details.

Ctrl+Home Go to home position.

Ctrl+End Go to center for distance search.

Ctrl+PgUp Jump to user aircraft.

Ctrl+PgDown Center flight plan.

Ctrl+Shift+Home Jump to coordinates.

13.3. Highlights

Selecting a row in the flight plan table or a search result table causes the related feature to be

highlighted on the map.
Hovering the mouse over the elevation profile will hightlight the related flight

plan position on the map.

Highlights can be customized in Options on page Map Display User.
See also Highlights.

Symbol Description

Center of the home position.
The position can be set in context menu -> More -> Set Home

View

Center point that will be used for distance searches.
Can be set in context menu -> More -

> Set Center for Distance Search.

Shows map center. Useful for
Click and Center navigation
mode. Also shows map navigation

click/touch areas if enabled.
Can be enabled in Options on page Map Display Labels.

A highlighted airport or navaid
selected in the search result
table. See also Search.



Symbol Description

A highlighted airport or navaid
selected in the flight plan
table. See also Flight Planning.



Highlighted positions of a
procedure leg in the preview.
Small circle show from and
large

circle to position. See also Search Procedures.

Thin circle shows the recommended
or related navaid of a procedure
leg. This can be a

VORDME for a
DME arc approach leg for example. See also Search Procedures.

This shows the related position
on the flight plan when hovering
the mouse above the

elevation
profile. See also Elevation Profile.



13.4. Logbook Preview

Selecting rows in the logbook table shows a preview of the related logbook entries.
The flight plan

preview and the aircraft trail are only shown for one selected entry.

Direct connection between departure and destination as well as flight plan preview and flown
trail is

shown for selected logbook entries.
Any of the above can be disabled in the logbook search context

menu.

See also Logbook.

Airports and great circle path
between departure and destination
for a logbook

entry selected in
the search result table. Label
shows departure, destination and

great circle distance between
airports.

Flight plan preview as stored
with the logbook entry.
Waypoint names and flying

direction indicated by arrows.
Note that complex procedures are
not visible.

Flown user aircraft trail stored
with the logbook entry.

13.5. User Features

User features are all objects which can be added to the map by the user. This includes
Holding, Airport

Traffic Pattern and more.

User features can be customized in Options on page Map Display User.

Display of user features can be enabled or disabled in menu View -> User Features.

Range rings labeled with
distance.
The number and distance of the
range rings can be

changed in the
Options dialog on page
Map.
This feature can be added from the map context

menu
using Add Range Rings.

VOR or NDB range rings labeled
with ident and frequency. Color
indicates Navaid type.
This

feature can be added from the map context menu
using Add Navaid Range Ring.

Great
circle
distance and course measurement
line indicating length and true
heading at start

and destination.
The two heading values will be
equal for small distances. For
shorter

distances length is also
shown in feet or meter.
The width of distance measurement
lines can

be changed in the
dialog Options on page
Map Display Labels.
The labels
can be changed in the

tree view
on the right side of the
same page.
This feature can be added from the map context

menu
using Measure Distance from here.

Measurement lines starting from
an airport or navaid have the
same color and additional ident

and frequency labels.
Course will consider calibrated magnetic
declination of a navaid.
This

feature can be added from the map context menu
using Measure Distance from here.

MSA diagram to scale. Right click on a MSA
symbol and select Add MSA Diagram to show this.

See Minimum Sector Altitude for more information.

13.6. Compass Rose

Line thickness can be changed in dialog Options on the tabs
Map Display User and Map Display Labels.

https://en.wikipedia.org/wiki/Great-circle_distance


The colors for flight plan leg course and heading indicator depend on
settings for active flight plan leg

which can be changed in the dialog
Options on tab Map.

Symbol Description

True north.

Magnetic north.

Distance circles and marks from
user aircraft if connected.

Solid line shows aircraft track
in degrees magnetic if connected.

Dashed line shows aircraft
heading if connected.

Magenta line segment shows the
course to next waypoint of the
active flight

plan leg. Hidden if
no flight plan loaded.

Heading indicator. Shows the
heading that has to be flown
towards the next

waypoint of the
active flight plan leg
considering cross wind. Hidden if
no flight

plan loaded.

13.7. Aircraft and Ships

Labels for the user and AI aircraft can be configured Options on the tab Map Display Labels.

Display of traffic can be enabled or disabled in menu View Menu.

Symbol Description

 
 Current user vehicle if connected
to the flight simulator. The user
aircraft depends

on selected
aircraft (jet, piston/turboprop
or helicopter).

  




User aircraft on ground or ship.

 
Aircraft carrier and frigate
(X-Plane only)



Symbol Description

Needle showing the current ground
track of the aircraft. Aircraft
nose shows

heading. Can be disabled in Options on page Map Display Labels.

Selected altitude range arc.
Position where the selected autopilot altitude will be

reached.
This display can be disabled in menu View -> Show Selected Altitude Range

Arc.

Aircraft turn flight path line. This predicts the flight path.
This display can be

disabled in menu View -> Show Turn Flight Path.

Aircraft endurance with distance and hours:minutes to go. This uses reserve fuel,

contingency fuel, current fuel flow, fuel on
board and ground speed to calculate the

endurance
This display can be disabled in menu View -> Show Aircraft Endurance.

User aircraft trail.
Display can be toggled in menu View -> Show User Aircraft Trail

Wind around the user aircraft
with direction in degrees
magnetic and speed.

  


  


  

AI or multiplayer aircraft.
Labels vary and can be customized
in Options on the tab

Map Display. The symbol
depends on aircraft type (jet,
piston/turboprop, helicopter

or
ship).

 

Dark red color indicates online network aircraft/client.
Labels vary and can be

customized
as above.

13.8. Airports

Airports having control towers are shown in dark blue others in magenta.
Add-on airport names and

idents are shown italic and underlined throughout the whole program.
Airports that are part of the

flight plan have a light yellow text
background.

The symbol is shown smaller if an airport has no runways. This is the
case for some add-on airports

that use another techniques like photo
scenery to display runways.

Labels and diagram elements for airports can be configured Options on the tab Map Display Labels.

Display of airports can be enabled or disabled in menu View -> Airports.



Symbol DescriptionSymbol Description


 Airports with hard surface
runways longer than 8,000 ft or
2,400 m. All runways

longer
than 4,000 ft or about 1,200
m
are shown. Only for lower zoom
distances.

 
Airports with hard surface
runways. White line shows heading
of longest runway.

 
Airports with soft surface
runways.

 
Empty airports shown in gray. No
taxiways, no parking spots and no
aprons.



Seaplane base having only water
runways.



Military airport.

Heliport having only helipads and
no runways.



Abandoned airport. All runways
are closed.

 
Airports that have fuel
available.

Add-on airports are always
highlighted.
You can disable this in
the options dialog on

page
Map Display by unchecking
Highlight add-on airports.

Weather at airport. See chapter
Airport Weather
below.

Airport label showing name,
ident, ATIS frequency, elevation,
lighted runways (L) and

length of longest runway. The
text labels for airports can be
changed in the dialog

Options
on the tab Map Display Labels.

Airport runway overview shown
before the full airport diagram
when zooming in.

13.9. Airport Diagram

Runway, taxiway, helipad and apron colors indicate surface type. White
is used for an unknown or

invalid surface type given by an add-on
developer.



Diagram elements for can be enabled or disabled in Options on the tab Map Display Labels.

Symbol Description

Runway with length, width, light
indicator (L) and surface
type.

Runway end with ident and
magnetic heading.

Displaced threshold. Do not use
for landing.

Overrun area. Do not use for
taxi, takeoff or landing.

Blast pad. Do not use for taxi,
takeoff or landing.

Taxiway with name and center
line.

Closed taxiway.

Semi transparent dotted aprons
and taxiways indicate that no
surface is drawn. It

might use a
photo texture or simply the
default background.

 
Tower. Red if a tower frequency
is available. Otherwise just view
position.

Fuel



Symbol Description

GA ramp with parking number and
heading tick mark.

 

Gate with number and heading tick
mark. Second ring indicates
availability of

jetway.

Cargo ramp

Military combat parking or cargo
ramp.

 

 

Helipads. Red text indicates
medical helipad. Color indicates
surface.

13.10. Navaids

Navaids that are part of the flight plan have a light yellow text
background.

Display of navaids can be enabled or disabled in menu View -> Navaids.

Symbol Description

 

VOR DME including ident, type and
frequency. Compass rose shows
magnetic declination

on lower zoom
distances.
Small blue rectangle at high
zoom levels.

The type defines the reception range:
H is high, about 200 NM,
L is low, 40 NM to 60 NM

and
T is terminal, about 25 NM.

 

VOR including ident, type and
frequency.
Tiny blue rectangle at high
zoom levels.



Symbol Description

DME including ident, type and
frequency.
Small blue rectangle at high
zoom levels.

 
TACAN including ident, type
(High, Low or Terminal) and
channel. Compass rose shows

magnetic declination on lower zoom
distances.
Small blue rectangle at high
zoom levels.

 VORTAC including ident, type
(High, Low or Terminal) and
frequency. Compass rose

shows
magnetic declination on lower zoom
distances.
Small blue rectangle at high
zoom

levels.

 
NDB including ident, type and frequency.
Small dark red circle at high
zoom levels.
The

type defines the reception range:
HH is very high, about 75 NM,
H is high, about 50 NM,
MH

is middle, about 25 NM and
CL is compass locator, about 12 NM.

Waypoint with name.
Small magenta triangle at high
zoom levels.

User defined flight plan waypoint with name.

Invalid airport, waypoint, VOR or
NDB that is part of the flight
plan but could not be

found in
the Scenery Database.

Marker with type and heading
indicated by lens shape.

Jet airway with label showing
name, type (Jet or Both), minimum
and maximum altitude.

Text
depends on zoom distance. A
preceding arrow will show the
allowed direction if the

airway
is one-way.

Victor airway with label showing
name, type (Victor or Both),
minimum and maximum

altitude.
Text depends on zoom distance. A
preceding arrow will show the
allowed

direction if the airway
is one-way.

Eastbound PACOTS track with
flying direction, name 2
and type.
Tracks having no

east/west
direction are shown in gray color.

Westbound PACOTS track with
flying direction, name H
and type.



Symbol Description

ILS with glideslope and markers.
Label shows ident, frequency,
magnetic heading,

glideslope
pitch and DME indication if
available.

Localizer. Label shows ident,
frequency, magnetic heading and
DME indication if

available.

GLS/RNP approach glidepath indicating a precision approach.
Can be disabled in menu

View -> Navaids ->
Show GLS/RNP Approach Paths.
The label shows type, performance,

runway/approach,
magnetic inbound course and glidepath.

MSA symbol (minimum sector altitude). Can be attached to an
airport, a runway or other

navaids.
Right click on this symbol to add a diagram which is to scale.
Labels shows MSA,

navaid ident and radius in NM.
Sector bearings shown in degree magnetic
and sector

safe altitudes in feet.
Can be disabled in menu View -> Navaids ->
Show MSA Sectors.

En-route holding. Labels are outbound course,
speed and altitude.
Inbound label shows

inbound magnetic course,
leg time and navaid name.

13.11. Flight Plan

Flight plan display labels can be changed in dialog Options on
tab Map Display Labels. Look can be

changed on Options page Map Display Flight Plan.

See also Flight Planning.

Flight plan with distance,
direction and magnetic course at
each leg.
°M and °T indicate

magnetic or true course,
respectively.

Blue fixed course labels show inbound and outbound course for VOR also depending

on the calibrated declination.
Blue indicates VOR inbound and outbound course with

VOR calibrated declination. Otherwise black.
See Magnetic Declination for more

information on flight plan course and magnetic declination.

Flight plan procedure leg with
the same information as above.

Active flight plan leg.

Wind direction and speed at
flight plan waypoint. See chapter
Winds Aloft
below for

details
about wind barbs.

Flight plan departure position on
airport. Either parking, fuel
box, helipad, water or

runway.

Top of climb point with distance
from departure.
Can be disabled in menu View
->

Show Top of Climb and Top of Descent



Top of descent point with
distance to destination.
Can be disabled in menu View
->

Show Top of Climb and Top of Descent

13.12. Procedures

See chapter Procedures and Search Procedures for more detailed information
on all the legs.

The ellipsis … indicates that additional information, such as altitude restrictions
is available, which is not

visible due to the zoom factor. Zoom in closer to see the details.

Symbol Description

SID, STAR, approach or transition
leg for flight plan and in
preview with

distance, direction
and magnetic course at each leg.

Missed approach leg for flight
plan and preview.

Dotted line indicates
circle-to-land or straight-in
part of a procedure

leading to a
runway end. Here part of flight
plan.

Vector leg indicating course to
an initial fix. Here part of
flight plan.

Manual leg. Fly according to ATC
instructions. Here shown as
preview.

Leg to alternate destination.

Gray yellow filled circle
indicates a procedure point which
is not a navaid

but defined by
course and/or distance from a
navaid, an altitude

restriction
or manual termination.

A black circle indicates an
overfly waypoint. Can be a
procedure point or

a navaid.



Symbol Description

The Maltese cross highlights the
final approach fix or the final
approach

course fix.

Prefix GS is not an altitude
restriction but an indicator for
the ILS

glideslope altitude. Can
mean at or at or above.

Fly a heading, track or a hold
until manually terminated by ATC.

Intercept the next approach leg
at a course of about 45 degrees.

Procedure leg that is terminated
when reaching the given altitude.

A fix defined by a course or
heading and distance to a navaid.

Turn to intercept a radio navaid
radial.

This fix is defined by a heading
or track which is terminated by
reaching

a DME distance.

Intercept a course to the next
fix at an angle of about 45
degrees.

13.13. Elevation Profile

The colors and symbols of the elevation profile follow the style of the
main map as set in the options

dialog on tab Map Display. Colors,
patterns and symbols for airports, navaids, procedures, active and

passed flight plan legs are the same. The profile display also follows
other map settings like visibility of

flight plan line, aircraft and
aircraft trail.

See also Elevation Profile Display Options for customization options.

See Elevation Profile for more information.

Symbol Description



Symbol Description

 Ground with departure elevation
on the left and destination
airport elevation on

the right.

Flight plan altitude.

Top of climb with distance from
departure.

Top of descent with distance to
destination.

At altitude restriction of a
procedure with waypoint name.

At or above altitude restriction
of a procedure.

At or below altitude restriction
of a procedure.

At or above and at or below
(between) altitude restriction of
a procedure.

Minimum safe altitude for flight
plan. This is elevation plus 1,000
ft rounded up to

the next 500
ft. The 1,000 ft buffer can be
changed in the dialog Options
on the

tab Flight Plan



Symbol Description

Minimum safe altitude for a
flight plan segment. The same
rules apply as to the

minimum
safe altitude for flight plan.

User aircraft if connected to the
simulator. Labels show actual
altitude and

climb/sink rate.

User aircraft trail if connected
to the flight simulator.

Projected vertical path by current
climb or sink rate

ILS slope. Label shows ident,
frequency, magnetic heading,
glideslope pitch and

DME
indication if available. Only
shown if an approach is selected
and runway end

has an ILS.
Opening angle has no relation to
actual slope precision.

GLS/RNP approach path indicating a
precision approach.
Can be disabled in
menu

View -> Navaids ->
Show GLS/RNP Approach Paths.
The label shows type,

performance,
runway/approach, magnetic inbound
course and glidepath.

Visual Approach Slope Indicator.
Label shows slope pitch and VASI
type. Only

shown if an approach
is selected and runway end has a
VASI. Opening angle has

no
relation to actual slope
precision.

Calculated vertical descent
path angle during the descent phase.

Required vertical descent path
angle in a procedure.
This is a procedure

restriction.

13.14. Airport Traffic Pattern

Color and indicators depend on user choice in Traffic Patterns dialog.

This feature can be added from the map context menu using Add Traffic Pattern.

Symbol Description

Downwind leg of airport traffic
pattern with altitude and
magnetic course.

Final leg of airport traffic
pattern with runway and magnetic
course.

Arrow and dashed line shows path
for pattern entry.



Symbol Description

Dashed line and arrows show path
for pattern exit.

White circle is active point at
the runway threshold of the
pattern. Mouse cursor

changes
above and allows to remove the
pattern in the context menu.

13.15. Holding

Color depends on user choice in Holdings dialog.

This feature can be added from the map context menu using Add Holding.

Symbol Description

Holding fix, magnetic and true
inbound course, time for straight
leg and navaid

ident (LBU).
Ident is only shown if holding is
attached to navaid. True course

display depends on options.

Magnetic and true outbound
course, speed and altitude as
given in the dialog.

True course
display depends on options.

Active point and holding fix.
Mouse cursor changes above and
allows to remove

the holding in
the context menu.

13.16. MORA Grid

The minimum off-route altitude grid provides an obstacle clearance
altitude within an one degree grid.

The altitudes clear all terrain and
obstructions by 1,000 ft in areas where the highest elevations are

5,000
ft MSL or lower. Where the highest elevations are above 5,000 ft MSL
terrain is cleared by 2,000

ft.

Display of the MORA grid can be toggled in menu View -> Show Minimum off-route Altitude Grid.

Symbol Description

MORA grid. Large number is 1,000
ft and small number 100 ft.
Example

here: 3,300, 4,400, 6,000,
9,900 and 10,500 ft.

13.17. Airport Weather

Display of airport weather symbols can be toggled in menu View -> Show Airport Weather.
The weather

source can be selected in menu Weather -> Airport Weather Source.

See also Weather.

13.17.1. Flight Rules

Symbol

Color
Description



Symbol

Color
Description

VFR. Visual flight rules.

MVFR. Marginal VFR. Visibility
equal or below 5 statue miles or
lowest ceiling at or

below 3,000
ft.

IFR. Instrument flight rules.
Visibility below 3 statue miles
or lowest ceiling below

1,000
ft.

LIFR. Limited IFR. Visibility
below 1 statue miles or lowest
ceiling below 500 ft.

13.17.2. Cloud Cover

Symbol Description

No clouds.

Few

Scattered

Broken ceiling

Overcast

13.17.3. Wind

The source for winds aloft forecasts can be selected in menu Weather -> Wind source.

See also Winds Aloft.

Symbol Description

No pointer indicates wind below 2
knots.

Pointer without wind barb shows
wind below 5 knots from
north-west.



Symbol Description

Short barb is 5 knots wind.

Long barb is 10 knots wind.

50 knots wind.

Example: 25 knots.

Example: 65 knots.

Example: 15 knots steady wind
(black) gusting to 30 knots
(red).

13.18. Winds Aloft

Symbol Description

No pointer indicates wind below 2 knots.

Below 5 knots from west.

Example: 25 knots.



14.  Traffic Patterns

Little Navmap can display an airport traffic patterns for guidance on
the map.

Right click at the center of an airport symbol in the map, flight plan table or airport
search result table

and select Add Traffic Pattern.

This will show a dialog where you can select a runway and customize the
pattern.

The display of traffic patterns is automatically enabled in menu View -> User Features ->
Traffic Patterns

after using this function.

Little Navmap shows a tooltip with information about the traffic
pattern when hovering the mouse

above the hotspot (white filled circle)
at runway threshold.

Traffic patterns can be removed by either selecting Map ->
Remove all Traffic Patterns, File -> Reset all

for a new Flight or by right click on
the hotspot (circle) at the runway threshold.

14.1. Create Traffic Pattern

Dialog input and selection fields:

Dialog header: Shows airport name and its ICAO ident as well as field
elevation.

Runways: List of available runways for the airport. Shows runway
name, length, width, magnetic

heading, surface and attributes like lighting status or approach types.

Turn direction: Select to choose between left or right turn
pattern. This is automatically updated

when selecting a runway from
FSX or P3D.

Base 45° after threshold: Calculates the final leg length
automatically when checked.

Base leg to runway threshold: Length of the final leg. Measured
from turn to final to the runway

threshold.

Downwind to runway: Parallel distance from downwind leg to
runway.

Pattern altitude: Pattern altitude above airport elevation. This
is automatically updated when

selecting a runway from FSX or P3D.

Entry and exit indicators: Shows dashed lines and arrows giving
hints for entry and exit points.

Line Color: Color of the pattern lines and labels. Can be different for each traffic pattern.

A click on OK or a double click into the list Runways closes the
dialog and creates the traffic pattern.

See Airport Traffic Pattern in the map legend for details about the
displayed numbers in the pattern.

Traffic pattern dialog for EDFE runway 08 at 1,000 ft above airport elevation. Click image to enlarge.



Traffic Pattern for the settings in the dialog
above. Downwind leg shows pattern altitude above MSL and course and
final leg

shows runway name and course. White filled circle is the
hotspot that can be right clicked to remove the pattern in the

context
menu. Click image to enlarge.



15.  Holdings

Little Navmap can display a holding pattern at any place or navaid on
the map.

User placed holdings can be added at any map position. Attaching a holding to a
navaid will use the

magnetic declination of the navaid and show its
ident in the holding label.

Right click in the map, flight plan table, airport, navaid or userpoint
search result table and select Add

Holding.

This will show a dialog where you can select a runway and customize the
holding.

The display of holdings is automatically enabled in menu View -> User Features ->
Holdings after using

this function.

Little Navmap shows a tooltip with information about the holding when
hovering the mouse above the

hotspot (white filled triangle) at the
holding fix.

Holdings can be removed by right click on
the hotspot (triangle) at the holding fix and selecting Map ->

Remove User Feature, selecting
Remove all Holdings in the menu View or
or by using File -> Reset all

for a new Flight

15.1. Create Holding

Dialog input and selection fields:

Dialog header: Shows navaid name and ICAO ident or coordinates if
holding is not attached to a

navaid.

Turn direction: Select to choose between left or right turn.

Course: Course of the inbound (towards fix) leg of holding
in magnetic degree.

Speed: Intended holding speed. Used together with time to
calculate holding size.

Time: Time of the straight legs in the holding. Used together
with speed to calculate holding size.

Label Straight section length: Calculated length of the straight inbound and
outbound sections.

Label Total time to complete: Total time to complete one holding.

Altitude label: Altitude to display at the holding.

Line Color: Color of the holding lines and labels.

See Holding for details about the
displayed numbers in the pattern.



Holding dialog for VORDME RID.

Holding at VORDME RID. Inbound label shows
inbound magnetic course, holding time and navaid ident. Outbound track
has

outbound magnetic course, speed and altitude as label. While filled
triangle is the hotspot and holding fix. Click image to

enlarge.



16.  Minimum Sector Altitude

Minimum Sector Altitude (MSA) is the lowest altitude which will provide a minimum
clearance of 1,000

feet above all objects located within a sector of a
circle of mostly 25 NM radius. The sector can be

centered on an airport, a runway end or a navaid.

Little Navmap shows the MSA sectors are symbols attached to an airport, a runway end or a navaid.

These MSA symbols are also shown in the Tab Navaids and in tooltips on the map.
Labels shows MSA,

navaid ident and radius in NM.
Sector bearings are shown in degree magnetic and sector safe altitudes

shown in feet.
Disable MSA symbols in menu View -> Navaids -> Show MSA Sectors.

Right click on the MSA symbol and select Add MSA Diagram from the map context menu to show
a to

scale MSA diagram. The display of user MSA diagrams is automatically enabled in menu View -> User

Features ->
MSA Diagrams after using this function.
Remove MSA diagrams by clicking on the center

and selecting Remove User Feature.

See also Navaids in the map legend.

Note

MSA sectors are not available when using the setting Do not use Navigraph Database in the
menu

Scenery Library -> Navigraph with FSX, P3D or MSFS. See also Load Scenery Library and Navigation

Databases.

An 25 NM MSA symbol at NDB LHR having three sectors. Sectors denoted by magnetic bearing to navaid and altitudes in

feet.



To scale MSA diagram after selecting Add MSA Diagram.



17.  Compass Rose

The compass rose indicates true north, magnetic north, aircraft heading
and aircraft track.

User aircraft heading, track, distance rings and markers are shown if
Little Navmap is connected to a

simulator. The rose is centered around
the user aircraft if connected.

The compass rose is kept centered in the current view if not connected
to a simulator. Magnetic

declination is based on the declination in the
center.

Once connected to a simulator, the compass rose will be attached to the user aircraft and follow its

position.
This can be disabled in menu View -> Attach Compass Rose to Aircraft.

The size is adapted to the map view size but not larger than 500 NM and
not smaller than 0.2 NM.

Line thickness and other display options can be changed in dialog
Options on page Map Display Labels

and Map Display User.

The colors for flight plan leg course and heading indicator depend on
settings for active flight plan leg

which can be changed in the dialog
Options on page Map Display Flight Plan.

17.1. Indicators

True north.

Magnetic north.

Distance circles and marks from
user aircraft if connected.

Solid line shows aircraft track
in degrees magnetic if connected.

Dashed line shows aircraft
heading if connected.

Magenta line segment shows the
course to next waypoint of the
active flight

plan leg. Hidden if
no flight plan loaded.

Heading indicator. Shows the
heading that has to be flown
towards the next

waypoint of the
active flight plan leg
considering cross wind. Hidden if
no flight

plan loaded.

17.2. Examples



Compass rose without simulator connection. Distance rings disabled.



Compass rose centered around user aircraft. No flight plan loaded. Therefore,
heading and next waypoint indicators hidden.



18.  Sun Shading

Little Navmap allows to display the sun shadow on the globe. This
works in both projections Mercator

and Spherical.

Enable the shadow in the menu View -> Show Sun Shading.

You can change the time source for the sun shading in View -> Sun Shading Time.

The shadow darkness can be changed in the dialog Options on page
Map Display User, Sun shading

Darkness at the bottom of the dialog.

Sun shading on the northern hemisphere. Click image to enlarge.

18.1. Time Sources

You can choose between three time source for the sun shading. Time is
not fixed and will advance for

all sources or updated from simulator
time.

Simulator: Uses the time of the connected flight simulator. Falls
back to real time if not connected

to a simulator. Automatically
updates the shadow if the simulator time changes.

Real UTC Time: Always use real time.

User defined Time: Allows to use the user defined time as changed
by Set User defined Time below.

18.2. Set User defined Time

The menu View -> Sun Shading Time -> Set User defined Time
opens a dialog to set an user defined time in

UTC as a source for the
sun shading.

Tip

You can move the dialog away from the map window and see the results
immediately by clicking the

button Apply.

Note

Do not forget to click on a date when changing months or years.
Otherwise the old date will be used.

Note that the user defined time is reset to current real time when
restarting Little Navmap.



Date and time for sun shading on November 8 at 10:42 pm UTC Time.



19. Map Image Export

This dialog appears when saving the map view to an image file, for
AviTab or copying it to the

clipboard.

Dialog input and selection fields:

Resolution: Select the desired resolution in pixels here. The following
options are available:

Current Map View: Export the map view as shown. The current
pixel size of this image is

shown in the list entry.

Custom Resolution: Use the pixel size from the input fields
Width and Height.

720p, 1280 x 720, 16:9,

1080p, 1920 x 1080, 16:9,

1440p, 2560 x 1440, 16:9,

2160p, 3840 x 2160, 16:9 and

4320p, 7680 x 4320, 16:9: Pre-defined typical image and
monitor resolutions.

Width and Height: Use this to define the pixel size for the
image if Custom Resolution is selected.

Zoom out to avoid blurred map: Checking this option helps to get
a sharp background image for

online maps (e.g. from OpenStreetMap).
This works best with the map projection Mercator. As a

result the
map might be zoomed out farther than expected in some cases.

Little Navmap will update the map image tiles for online maps if another option than Custom
Resolution is

selected. A progress dialog running for maximal 60 seconds will appear while
updating the map in

background. You can decide to cancel the download and proceed to export the image without
updating

all tiles.

Dialog shown after choosing Save Map as Image ....

Note

All options except Current Map View will change visible
details. Navaids might appear which are not

shown in the map on screen,
for example.

Warning

Choosing a too high resolution might result in missing map features due to cache overflow. You
can

notice this by missing airports on half of the image, for example.



20. Jump to Coordinates

This function is available from the map display context menu -> More ->
Jump to Coordinates and the

main menu Map -> Jump to Coordinates.

Selecting this function opens a dialog where a coordinate using the recognized formats and a zoom

distance can be entered.
The coordinate is validated and shown in the user selected format ( Units). A

red error message is shown if the coordinate is not recognized.

The map moves and zooms to the point using the given information when clicking Ok.

See Coordinate Formats about recognized coordinate formats.

Jump to coordinates dialog open with valid coordinates.



21.  Measure Distance

Draw a measurment line after selecting Measure Distance from here in the map context menu
or doing

a Ctrl+Click in the map.
Click a second time to finish the measurment and fix the line.

See User Features in the map legend for more information.

All measurement lines are saved and will be restored on next start up.
Remove the lines by Ctrl+Click

on the hotspot (small cross at the end) or by right clicking on
the hotspot and selecting Remove User

Feature.

You can use the keyboard, mouse wheel or the map overlays to scroll and
zoom while dragging a line.

Right-click, press the escape key or click outside of the map window to
cancel the measurement line

editing.

Measurement lines use nautical miles, kilometers or statue miles as
unit. Feet or meter will be added

as unit if the lines are short enough.

A great circle gives the shortest distance from point to point on earth
but does not use a constant

course. For that reason the measurement line
will show two course values. One for the start and one

for the end
position if they are different. Short lines have mostly equal start and end course.

The width of distance measurement lines can be changed in the dialog
Options on page Map Display

User. The labels on the options page Map Display Labels.

A measurment line starting at a VOR, VORDME, VORTAC or TACAN takes the calibrated declination of

the navaid to calculate the magnetic course.
See also Magnetic Declination for more information about

magnetic declination.

The display of measurment lines is automatically enabled in menu View -> User Features ->
Measurement

Lines after adding a line.

Little Navmap shows a tooltip with information about the measurement line when hovering the mouse

above the hotspot (cross at line end).

A measurement line with all labels enabled starting at VOR HMM (not shown on the right).
Labels shown are navaid ident

and frequency, magnetic start and end course, true start and end course, distance and VOR radial.
Tooltip with cross mouse

cursor at the hotspot.



22.  Range Rings

Opens a dialog which allows to set the parameters for one or more range rings.

The dialog window contains the following input fields:

Range ring radii: Radii for the ranges. A ring and an attached label is drawn for each number. A

maximum of 10 values from 0.01 to 10,600 NM can be entered.

Aircraft range: Displays one range ring for the aircraft endurance based on the current aircraft

performance profile. The endurance is static and does not change with current user aircraft

parameters. It is calculated from usable fuel, cruise fuel flow, true airspeed at cruise, reserve

fuel and contingency fuel as set in the Aircraft Performance file. See also Show Aircraft

Endurance for another way to display a dynamic range based on actual user aircraft parmeters

like fuel on board.

Label: An additional label which is attached to the rings.

Line Color: Color for range rings and labels.

Latitude and Longitude: Pre-filled with the coordinates at the click spot but can be changed freely.

See Coordinate Formats for supported formats. The label below shows the translated

coordinates as selected in Options on page Units or an error message.

Do not show this dialog when using "Shift+Click" in the map and use range ring radii as above.: Places a

range ring with the given parameters at the click position Shift+Click without showing this dialog

when checked. Use the map context menu item Add Range Rings to force the dialog to show up.

Help: Shows this help page in the online user manual.

Reset: Resets all options like numbers and color back to default.

Ok: Closes dialog and adds one or more range rings. The dialog keeps all settings.

Close: Closes the dialog without adding range rings but keeps all settings.

Little Navmap shows a tooltip with information about the range ring when hovering the mouse above

the hotspot (white filled circle)
in the center.

The width of all range ring lines can be changed in the dialog Options on Map Display User.

The display of range rings is automatically enabled in menu View -> User Features -> Range Rings after

using this function.

Remove a ring by doing a second Shift+Click at the center or right click on the center and select

Remove User Feature.



Range rings dialog.

A label indicates the radius of each ring and tooltip shown at center hotspot.



23.  Elevation Profile

This dock window shows the ground elevation, flight plan with cruise,
climb, descent legs and altitude

restrictions together with all flight
plan waypoints. It is only available when a valid flight plan is loaded.

The
user aircraft will be shown if Little Navmap is connected to the
simulator.

The elevation profile does not cover missed approaches and legs to
alternate airports. Create a new

flight plan from the destination to the
alternate airport if you wish to use the elevation profile.

Movement of the aircraft and the trail in the elevation profile is tied to the active
flight plan leg and will

not be correct if flying away from the active
leg.

Note

The elevation display covers only the flight plan and will not
change the depiction if you get off the

flight plan with your simulator
aircraft. You need a valid flight plan (i.e. a departure and
destination

airport) and a valid aircraft performance file
to see the elevation profile.

23.1. Top Label

Following information is shown in the top label if connected to a flight
simulator with a valid flight plan:

Distance from user aircraft to flight plan destination

Estimated time en-route in hours and minutes

Distance from user aircraft to the top of descent

Estimated time to top of descent in hours and minutes

Example: Destination: 47 NM (0 h 28 m). Top of Descent: 26 NM (0 h 15 m).

The label is hidden if not connected to a simulator.

23.2. Tooltip Label

Additional information is shown in a tooltip label at the right or left side in the window if the
mouse is

hovered over the diagram. The corresponding position is
highlighted on the map with a black/cyan

circle. The label changes the side depending on mouse position.

The label shows the following information for the mouse position:

Distance from departure and to destination plus calculated altitude and next waypoint.

Course for the flight plan leg at the cursor position.

Heading for this flight plan leg at the position. This is calculated based on wind conditions and

omitted if it is the same as course.

The Flight path angle is only shown in the descent phase and shows the vertical angle.
The label

changes to Required flight path angle if a descent path is reqired by a procedure.

Ground altitude and calculated altitude above ground.

Leg safe altitude of the flight plan leg at the cursor position (orange line).

Wind direction and speed as well as head- (▼) or tailwind (▲) component.

Information for position between waypoints GIGIR and OBITI.
Indicating a headwind of 28 kts at this position.
User aircraft

still climbing.
Note the image showing German number format with dot as thousands separator.



23.3. Zoom Sliders

The right side of the elevation profile contains the zoom sliders. The
following controls are available:

 Splitter: You can resize the right part of the
elevation profile window using this splitter

button. The part
containing the sliders will be collapsed if you drag it to the far
right. You can

open the collapsed part again by dragging the splitter
to the left. The look of the splitter might

be different on another operating system.

 Expand to Window: Resets the view back to 100
percent showing the whole flight plan.

 Display Options: See Elevation Profile Display Options.

 Help: Opens this online help page.

 Zoom Vertically: Move the slider up to zoom in
vertically. Maximum zoom results in 500 ft

height for the whole
profile window.

 Zoom Horizontally: Move the slider up to zoom
in horizontally. Maximum zoom results in about

4 NM distance for the
whole profile window.

23.4. Mouse Movement

Hover: The corresponding position within the flight plan is
highlighted on the map with a

black/cyan circle.

Wheel: Zoom in and out horizontally.

Shift+Wheel: Zoom in and out vertically.

Left Click and drag: Move map up, down, left or right.

Left Double Click: Zoom to position on main map.

Right Click: Show context menu.

23.5. Keyboard Movement

Click on the elevation profile window to activate it before using the
keyboard.

Cursor keys: Move map up, down, left or right.

+ and -: Also on numpad. Zoom in and out horizontally.

* and /: Also on numpad. Zoom in and out vertically.

0 or Ins : Reset view to 100 percent and show the whole
flight plan.

Home and End: Jump to departure or destination.

PageUp and PageDown: Move forward or backward one page.

23.6.  Elevation Profile Display Options

Choose Elevation Profile Display Options from the elevation profile context
menu to customize labels and

other display features.

The dialog uses a tree. See Trees for more information about this type of input element.

Same as main menu Tools -> Elevation Profile Display Options.

23.7. Context Menu Elevation Profile

23.7.1.  Show Position on Map



Zooms to the corresponding position on the map. This is the same as
double clicking into the elevation

profile.

23.7.2.  Expand to Window

Resets the view back to 100 percent showing the whole flight plan.

23.7.3.  Keep User Aircraft Centered

If this option is selected, the aircraft remains centered on the left of
the altitude profile during flight.

The aircraft will be kept on the upper part of the window if the
aircraft is descending and on the lower

part if climbing.
You can move around the profile manually.
After a time without manual movements it

will jump back to the aircraft.

The vertical and horizontal zoom distances set by the user are not changed while Little Navmap keeps

the aircraft visible.

See also for more information on jump back in the options dialog on Simulator Aircraft which partially

affects this function.
See the related tooltips for more information.

This function is independent of the related Keep User Aircraft Centered.

23.7.4.  Center on Aircraft and Destination

Same as Keep User Aircraft Centered above but additionally
zooms the elevation profile to keep aircraft

and destination visible when checked. This hides the
unneeded passed flight plan legs.

The vertical and horizontal zoom distances set by the user are not changed while Little Navmap keeps

the aircraft visible
until the destination is visible on the right side of the map.
The elevation profile

starts to zoom in horizontally and vertically as much as possible to keep the destination and the user

aircraft visible then.

The function Keep User Aircraft Centered has to be enabled to use this function.

Note that the elevation profile starts zooming fairly late after at least half of the flown flight distance.

23.7.5.  Delete Aircraft Trail

The aircraft trail is saved and will be reloaded on program startup.

This menu item removes the user aircraft trail from the elevation
profile only. It does not remove the

trail from the map. Use this if the
trail appears in the wrong place or shape after creating of modifying

a
flight plan.

The trail in the elevation profile is of no relevance for the GPX
file export.

23.7.6.  Show VASI

Shows a VASI slope if an approach procedure with a runway (not
circle-to-land) is selected in the flight

plan and if the runway has a
VASI.

The slope is drawn with the correct angle to be usable as an approach
guide. The vertical opening

angle is only meant for depiction and has no
relation to the real VASI accuracy.



Display of VASI slope at destination airport. Slope
is 3 degrees and VASI type is PAPI4. Final approach fix is marked with a

Maltese cross.

23.7.7.  Show ILS or GLS/RNP

Shows an ILS glideslope or GLS/RNP approach paths if an approach with a runway is selected in the

flight plan and if the runway has the related navaid or approach type.

Drawing of approach guidance depends on selected approach procedure type. An ILS approach will

show the ILS
feathers while a localizer approach without vertical guidance will not.
Note that no vertical

navaid guidance is shown for circle-to-land approaches.

The slope is drawn with the correct angle to be usable as an approach
guide. The vertical opening

angle is only meant for depiction and has no
relation to the real ILS accuracy.

A label on top shows name, frequency, heading, glideslope angle and DME
indicator if available

Note

The ILS glideslope and GLS/RNP glidepaths can be forced to display for all approach types:

Disable ILS or GLS/RNP on the toolbar or in the menu View -> Navaids to see only flight
plan

related navaids on the map and approach related navaids in the elevation profile. This means

you won’t see an ILS glideslope for a VOR approach in the elevation profile, for example.

Enable ILS or GLS/RNP to see slopes in the elevation profile independent of the approach

type. A
destination runway ( Select Destination Runway) or an approach ( Search Procedures)

has to be selected to see the slope.

Display of ILS at destination airport. Final approach fix is marked with a Maltese cross.

23.7.8.  Show Top of Climb and Top of Descent

Hides the climb and descent slopes as well as the top of climb and top of descent indicators when

disabled.
This affects the map and elevation profile display but not the altitude calculation in the fuel

report or elevation profile.

This is the same function as Show Top of Climb and Top of Descent in the menu View.



23.7.9.  Show Vertical Track

Shows a vertical track line indicating the flight path based on current descent or climb rate as
well as

ground speed.

Use this to aim at the right altitude at the next flight plan waypoint. This is especially useful at descent.

Related function for the map is Show Selected Altitude Range Arc in the map context menu.

Vertical track line in elevation profile window indicating climb rate.

23.7.10. Follow on Map

The map view will be centered - not zoomed in - on the position below
the cursor if hovering above the

elevation profile when this option is
selected.

23.7.11. Show Zoom Sliders

Show or hide the zoom sliders and buttons at the right side of the
elevation profile. You can still zoom

using the mouse or the keyboard.

23.7.12. Show Scrollbars

Show or hide the scroll bars at the bottom and the right side of the
elevation profile. You can still use

the mouse or keyboard to navigate.

23.7.12.1.  Elevation Profile Display Options

See Elevation Profile Display Options above.

23.8. Profile Display

The colors, symbols and font of the elevation profile follow the style of the
main map as set in the

options dialog. Colors,
patterns and symbols for airports, navaids, procedures, active and
passed flight

plan legs are the same. The profile display also follows
other map settings like visibility of flight plan

line, aircraft and
aircraft trail.

Display options for the flight plan can be changed in Map Display Flight Plan.
Not all of the flight plan

options affect the elevation profile which is noted in the related tooltips.

Aircraft heading will turn if a backward movement relative to the active
flight plan leg is detected.

For more information see the Elevation Profile in the map legend.

The elevation profile uses actual altitude for display of restrictions,
slope and cruise.

The aircraft icon is shown using indicated altitude to ensure matching to cruise altitude line
at the

higher flight levels.

You might see vertical aircraft movement of the aircraft symbol and jumps in the trail when adjusting

barometric pressure in the simulator altimeter.

Note

Keep in mind that actual altitude shown in Little Navmap might differ from indicated altitude even

with a correct baro setting.



This is an effect of the outside air temperature (OAT) on actual altitude where low temperatures

affect the aircraft altimeter.
When temperature is less than ISA conditions an aircraft will be lower

than the altimeter reading.

This effect is currently modeled in X-Plane 12 and MSFS.

Corrections have to be applied when the aerodrome temperature is 0°C or colder:

DH/DA or MDH/MDA and step-down fixes inside the final approach fix (FAF).

All low altitude approach procedure altitudes in mountainous regions (terrain of 3000 ft AMSL

or higher)

See SKYbrary - Altimeter Temperature Error Correction [https://skybrary.aero/articles/altimeter-temperature-error-

correction]
for more information.

Flight plan elevation profile with line indicating
the mouse hovering position. Orange lines show minimum safe altitude for

flight plan segments. Red line shows overall minimum safe altitude. Top
of climb and top of descent points shown including

slope. Orange flight
plan lines show procedure legs. Waypoint EV501 has an overfly
condition and there are several altitude

restrictions shown for the
approach procedure below the tooltip.

23.9. Top of Climb and Top of Descent Paths

The elevation profile also displays the top of climb and top of
descent which are calculated based on

the current Aircraft Performance profile and Winds Aloft situation.

Note that the TOC and TOD calculation is influenced by altitude
restrictions in procedures. Little

Navmap will calculate a climb or
descent path always adhering to these restrictions. The resulting path

might
use a higher or lower climb or descent speed than expected.

The path is also forced to the lowest allowed altitude at the final
approach fix (FAF) and the final

approach course fix (FACF) to avoid arriving above
the ILS glide slope or too high at the destination

runway.

You can safely follow the descent path as shown by Little Navmap,
provided you can manage your

aircraft speed at the same time. For large
aircraft you might want to descent around 10 nm earlier to

reduce speed
to 250 knots below 10,000 ft.

I recommend to make the descent path manually more shallow (i.e. use a lower sink rate) to take the

deceleration phases into account.

The climb and descent paths are affected by wind and are moved
accordingly for strong head- or

tailwinds. The climb path will be
steeper in the elevation profile if you climb in a strong headwind, for

example.

See chapter Winds Aloft for more information.

The plan will switch to a flat display showing only a flight plan line
at cruise altitude if the TOC and/or

TOD cannot be calculated or if the
plan violates altitude restrictions. A red warning message is shown

in the Error Messages Footer on the flight plan tab
if this is the case. Click the message for more

information.

https://skybrary.aero/articles/altimeter-temperature-error-correction


An approach procedure which requires the aircraft to descent early due to a restriction between 7,000 and 10,000 ft at

ARTIP.

23.10. Elevation Data

Elevation processing is done in the background since online data has to be
downloaded and

computation is CPU intensive. Therefore, the update of
the elevation display can take from a few

seconds up to half a minute.
This background update is started after creating or changing the flight

plan or when new elevation data was downloaded. The display will be
updated accordingly whenever

new data is available.

23.10.1. Online Elevation Data

Note that the third party online elevation data does not cover all countries and
currently ends at 60

degrees north. The data contains several known
errors which cannot be fixed.

The calculation of online elevation points is limited to flight plan
segments not longer than 2,000 NM to

avoid overloading. Add
more waypoints or calculate a flight plan to avoid this limitation.

23.10.2. Offline Elevation Data

Using the recommended freely downloadable GLOBE - Global Land One-km
Base Elevation Project

[https://ngdc.noaa.gov/mgg/topo/globe.html]
elevation data has several advantages:

Faster updates

World wide coverage

No known errors

Display of altitude below the cursor in the status bar

Correct altitude if using non-airport departure and destination points

Resolution is a bit lower than the one for the online data, though.

See Install GLOBE elevation data in the
options dialog for instructions how to download and install the

GLOBE elevation
data.

https://ngdc.noaa.gov/mgg/topo/globe.html


24.  Search

The search dock window contains several tabs with similar functionality
that allows to search for

objects by name, ident or other criteria.

Filters are defined by various controls which are mostly self
explaining. Only text filters and the tri-

state checkboxes like
Lighted, Approach or Closed need a few extra remarks below.

All filters can be used together where all conditions have to be met
(and operator). All filters except the

distance search filter are
applied immediately. The distance search is applied after a short delay
for

each change.

Entering three or four characters in the ICAO Code field of the
airport search tab will trigger a

quick search which ignores all other
filters.

A tooltip on the blue help button on the top right shows information
about searching.

See Tables for more information how to rearrange columns in tables.

Tip

You can use the cursor key Down to jump from the input fields into the result table.

Using keyboard shortcuts like Ctrl+I for Show Information or Ctrl+M for Show on map
are usable directly

from the input fields and will apply to the topmost airport in the result table.

The same applies to other tabs like navaid and logbook search as well.

24.1. Text filters

The standard is to search for entries that start with the entered text.

The placeholder * stands for any text. Once a * is included in
the term, the standard search (match

start of text) is no longer used.
In that case you might have to add a * at the end of the search term
as

well to get the expected result.

The search is negated (i.e. find all entries that do not match) if the first
character in a search box is a

-.

Note that all of the above does not apply to numeric fields like
Runways: Min or Altitude: Max.

24.2. Airport and Navaid Ident Text filters

The fields Ident for the airport and navaid search allow more functionality besides the
one described

above:

Put an ident in double quotes " to force an exact search (i.e. avoid partial matches).
Example:

SEA finds two airports one being SEAM while "SEA" finds only KSEA because
of the matchin IATA code.

Separate several idents by space to do a search for each ident. EDDF EDDM find the two airports

Frankfurt and Munich, for example.

24.3. Tri state checkboxes

These are used to filter airports by presence of certain facilities or
properties.

Below are the states as they are shown in Windows 10:

Black Box: Condition is ignored.

Checked: Condition must match.

Empty Box: Condition must not match.



Colors and look of these checkboxes vary with theme and operation
system. So instead of gray another

color might be used (red fill on
Linux or a - for macOS).

24.4.  Menu Button

Airport, navaid, userpoint and online search tabs contain multiple rows
of search filters. These rows can

be switched on and off with the drop
down menu on the menu button  on the top right.

The drop down menu prefixes menu items with a change indicator * to
show that the related filter row

has modifications. You can use this to
find out why a search does not give the expected results.

Tip

If you do not get the expected results or no results at all use the
Reset Search menu item, the

button Reset Search  or press Ctrl+R to
clear all search criteria.

24.5. Distance search

This function is only available in the airport and navaid search.

This function allows you to combine all other search options with a
simple spatial search.

The checkbox Distance has to be selected to enable this search. The
result will include only airports or

navaids that are within the given
minimum and maximum range of NM from the search center. This

allows you to quickly search for a destination that is within the range
of your aircraft and fulfills other

criteria like having lighted runways
and fuel.

The center for the distance search is highlighted by a  symbol.

To restrict the search further you can select a direction (North, East,
South and West).

Check the drop down menu for the change indicator * and the search
fields for any remaining text if

the distance search does not give any
or unexpected results. Use the
Reset Search menu item, the

button Reset Search  or press Ctrl+R to
clear all search criteria.



A complex distance search: Find all airports within
a distance between 200 and 400 NM from Frankfurt (EDDF).
Airports

should have a rating greater than 0 and should have at least
one lighted runway. Military and closed airports are excluded.

The
resulting airports are highlighted on the map by selecting them in the
search result table. Click image to enlarge.

A complex search for scenery: This example shows how
to find specific add-on scenery by using the Scenery Path search

field. This shows all airports of the Orbx New Zealand South Island
add-on scenery that have lighted runways. Click image

to enlarge.

24.6. Random Flight in Airport Search

Selects a random departure and destination based on the current airport search result.
A progress

dialog allowing to cancel the selection is shown if the process takes longer.
Once done the user can

accept the departure/destination pair or start a new calculation.

You might want to refine the flight plan further by running the Flight Plan Calculation to get airways or

intermediate navaids,
selecting procedures ( Search Procedures) and Select Start Position.

Generating a random flight from a search result showing all airports in Germany, having 5,000
feet minimum runway length

and are neither closed nor military. Click image to enlarge.

24.7. Ident in Airport Search

The input field Ident in the airport search tab searches for all available airport identifiers.
These are:

Ident: Mostly equal to ICAO code but can be differnt especially for small airfields. X-Plane
uses

partially an unofficial code in this field like XPA000B. Available for all simulators and
Navigraph

navdata.

ICAO: Four letter ICAO code [https://en.wikipedia.org/wiki/ICAO_airport_code]. Only
available in X-Plane.

FAA: Airport code used in the United States given by the Federal Aviation Administration

[https://www.faa.gov/].
The FAA code is only available in X-Plane.

https://en.wikipedia.org/wiki/ICAO_airport_code
https://www.faa.gov/


IATA: Three letter IATA airport code [https://en.wikipedia.org/wiki/IATA_airport_code].
Available in X-Plane and

Navigraph navdata.

Local Code: Official local airport code mostly used for small airfields. Only available in
X-Plane.

The airport codes are also shown in the information windows, tooltips and in the map
labels as well as

in Flight Plan Route Description. ICAO, FAA, IATA, and local codes are shown and the internal
ident is

avoided if possible.

Example:

Akutan is shown as Akutan (PAUT) with its official ICAO code PAUT instead of the
internal X-Plane code

XPA000B.

Search Example:

Searching for ident KOI gives the airports Oberlin Muni (KOIN), Lt Warren Eaton (KOIC)
and Kirkwall (EGPA)

where EGPA has the IATA code KOI.

Tip

Hide the additonal airport codes if you do not use X-Plane or if you are not interested in
these

columns. You can do this by moving the columns to the rightmost position or by shrinking them
to

minimum size. See Search Result Table View.

24.8. Country, State/Province and City in Airport Search

Note that quality and availability for administrative data depends on the selected simulator.

MSFS provides names in the local language as selected in Options on page User Interface but country

names are not available.

X-Plane airports are community work and therefore administrative names have varying quality if set at

all. Country names are often used in several variants like USA, U.S.A., United States and more.

24.9. Override in Airport Search

Entering an airport ident using three letters or more ignores all other search options and shows only

airports matching this ident.

This is indicated by the message Ident overriding other search options. in the search window footer.

24.10. Search Result Table View

All selected elements in the table view will be highlighted on the map
using a black/yellow circle. See

Highlights in the map legend for more information.

Use Shift+Click or Ctrl+Click to select two or more elements
(multi-selection).

See Tables for more information how to rearrange columns in tables.

Airport search result table. All additional search
options are hidden by using the drop down menu of the menu button on

the
top right.

https://en.wikipedia.org/wiki/IATA_airport_code


Navaid search limited to ICAO region LI (Italy)
and VOR, VORTAC and TACAN stations that have a range of 100 or more

NM.

24.10.1. Footer

The footer shows the number of selected, loaded and visible entries considering search and filter

criteria.

Note that you to select Show All from the table context menu or have to scroll down to see all entries:

24.10.2. Mouse Clicks

A double-click on an entry in the table view shows either an airport
diagram or zooms to the navaid or

other feature. Additionally, details
are shown in the Information dock window. Single click selects an

object and highlights it on the map using a black/yellow circle.

24.11. Top Buttons

Available buttons and menu items depend on search tab. This chapter explains common buttons and

menu items.

24.11.1.  Reset Search

Same as Reset Search in the context menu.

24.11.2.  Clear Selection

Same as Clear Selection in the context menu.

24.11.3.  Help

Display a quick help in the tooltip. Click to open this chapter of the
manual in the default browser.

24.11.4.  Menu Button

Drop down menu button that allows to hide or show search options.

The drop down menu prefixes menu items with a change indicator * to
show that the related filter row

has modifications. You can use this to
find out why a search does not give the expected results.

24.12. Context Menu Search

Available menu items depend on search tab.

Many menu items are mirrored from the Context Menu Map and provide the same functionality
for the

selected item below the cursor or the selected rows in the result tables.
These are omitted here.



24.12.1.  Show on Map

Show either the airport diagram or zooms to the navaid, userpoint or
other features on the map. The

zoom distance can be changed in the dialog Options on the tab
Map Navigation.

24.12.2.  Mark Airport as Add-on

Marks an airport with a yellow circle as add-on.
Same as Mark Airport as Add-on. Enabled for all

airports at the clicked position.

24.12.3.   Filter by Entries including/excluding

Use the field under the cursor to set a search filter that includes or
excludes the text of the field. This is

only enabled for text columns.

24.12.4.  Reset Search

Clear search filters and revert to showing all entries in the search
result table view.

24.12.5.  Show All

The table view does not show all entries initially for performance
reasons. This menu item allows to

load and show the whole search result.
The view switches back to the limited number of entries after a

search
filter is modified or the sort order is changed. The number of all,
visible and selected entries is

shown at the bottom of the tab.

Be aware that showing all navaids and airports can take some time
especially if they are highlighted on

the map when selecting all entries
in the search result. The program does not crash but needs a few

seconds
to highlight all the objects on the map.

24.12.6. Follow Selection

The map view will be centered, but not zoomed in, on the selected feature
if this function is enabled.

24.12.7.  Copy

Copy the selected entries in CSV format to the clipboard. This will
observe changes to the table view

like column order and sort order. The
CSV includes a header line. Columns which are hidden or

shrinked to minimum width are excluded.

Import the CSV-Text into spreadsheed programs using UTF-8 encoding and a semicolon as a separator.

See Tables for more information how to rearrange or hide columns in tables.

24.12.8. Select All

Select all visible entries. To select all available entries the function
Show All has to be used first.

24.12.9.  Clear Selection

Deselect all entries in the table and remove any highlight circles from
the map.

24.12.10.  Reset View



Reset sort order, column order and column widths to default.



25.  Search Procedures

The tab Procedures allows previewing and adding approach, arrival (STAR) and
departure procedures

(SID) to the flight plan. Procedures of a selected
airport are arranged in a tree which indicates the

dependency between
procedure and transition.

The dialog uses a tree element. See Trees for more information about this type of input element.

See Procedures for general information about SID,
STAR, approaches and transitions.

Procedure legs are shown when a procedure node is expanded in the tree.
Procedures can be filtered

by runway, name and type.

Right-click on a procedure or a procedure leg to show a context menu.

Use the context menu item Delete Selected Legs or Procedure of the flight plan table or the map

context menu
item Delete from Flight Plan to remove procedures from a flight plan.

Procedure legs are highlighted in red if one or more navaids could not
be resolved. A warning dialog

will be shown if you try to add this
procedure to a flight plan.

Note that the SID and STAR names are limited to 5 characters in FSX and
P3D due to a limitation in the

BGL file format. Therefore procedure
names are slightly modified. However, this does not apply to

procedures
from a Navigraph or X-Plane scenery database.

Note

Note that the shown runway numbers might differ compared to airport runways.
This happens when

an add-on airport and the navigation data have different runway numbers which is a result of

renumbered
runways due to changes in magnetic declination (magnetic pole drift).

Little Navmap resolves these mismatches internally and still allows to work with procedures.
You

might expect issues when loading flight plans containing such discrepancies into add-on aircraft or

simulators.

Important

It is up to the user to combine the correct procedures with the flight plan.

Little Navmap will not keep you from choosing north bound procedures for a route going south, for

example.
Also check the resulting route to avoid accidental zig-zag routing which can happen if you

combine the wrong
approach/transition with a STAR, for example.



Showing a transition and a RNAV approach. Start and
endpoint of a transition leg are highlighted on the map. Screenshot

based on Little Navmap 2.6.

25.1. Preview and Highlights

Little Navmap displays a preview of the selected procedure or transition.

Click on a procedure in the procedure tree to see the preview of the procedure.

Click on a transition in the procedure tree to see the preview of the transition and its related

procedure.

Click on a procedure or transition leg to see additonal highlighted navaids.

Tooltips give information about navaids in the preview.

The preview of missed approaches can be changed by toggling Show Missed Approaches in the menu

View.

Procedures can be added to the flight plan by either using Insert Procedure on the
preview from the

map context menu (right click on a navaid) or the Context Menu Procedures.



Previewing a SID at LIPO with tooltip information on procedure and related waypoint.
The preview also uses the

Transparent line setting for flight plans in Options on page Flight Plan.

25.2. Procedure Tree

Legs are shown in dark blue while missed approach legs are shown in dark
red color.

Bold red text indicates an error in the leg. The procedure is incomplete
and should not be used in a

flight plan. Little Navmap might refuse to use the procedure
depending on the error since

inconsistencies can result in crashes.

Description: Description and type. A suffix (T) indicates present transitions.
Parallel runways are

indicated by a list of runways like STAR 07L, 07R, 07C.
The suffix All is added if a procedure applies

to all runways of an airport.

Ident: Ident of the initial fix or name of SID or STAR. Ident name of a procedure leg if expanded.

Course °M: Magnetic course for a leg if expanded.

Restriction: Either procedure altitude restriction, procedure speed limit or a required vertical path

angle.
The following altitude restrictions exist for procedures:

Number only: Fly at altitude or speed. Example: 5,400 or
210.

Prefix A: Fly at or above altitude or speed. Example:
A 1,800.

Prefix B: Fly at or below altitude or speed. Example:
B 10,000 or B 220.

Range: Fly at or above altitude one and at or below altitude
two. Example: A 8,000, B

10,000.

Altitude, optional speed limit and optional path angle: List of values. Example:
A

8,000, B 10,000, B220, -3.5°.

Dist./Time: Distance of flying time for a leg. Holds can have a
leg time in minutes or a leg

distance in NM.

Remarks: Shows number of transtions, fly-over, turn direction, related navaid, RNP indicator and

allowed aircraft categories for a
procedure.

25.3. Top Buttons

25.3.1. Type Filter (All Procedures)

The type filter is not available for an FSX or P3D stock database.



This filter is always available for X-Plane or MSFS databases which contain
SIDs and STARs already in

the stock data.

The type filter allows the selections below:

All Procedures: SID, STAR and approaches

Departure (SID): Only SID

Arrival (STAR): Only STAR

Arrival and Approaches: STAR and approaches

Approaches: Approaches prefixed with type like RNAV Approaches.

The respective transitions are always shown.

25.3.2. Runway Filter (All Runways)

This filter is always available and helps to find procedures for a
certain departure or arrival runway.

The selection No Runway allows to find circle-to-land approaches which have no runway assigned.

25.3.3. Ident Filter

Filter result by approach, SID or STAR name beginning with the entered text.

25.3.4.  Preview all Procedures

Same as Preview all Procedures in context menu.

25.3.5.  Clear Selection

Same as Clear Selection in context menu.

25.3.6.  Help

Opens this chapter of the manual in the default browser.

25.4. Context Menu Procedures

25.4.1.  Show on Map

Center the map on the selected procedure.

25.4.2.  Insert into Flight Plan, Use as Destination and Use as Departure

Text and functionality of this menu item depends on the selected
procedure type and whether the

procedure’s airport is already the
departure or destination airport of the current flight plan.

A Runway Selection dialog might pop up for SID or STAR procedures which are applicable for more

than one runway.

Use the context menu of the flight plan table or the map to remove procedures. See
Delete Selected

Legs or Procedure and Delete from Flight Plan.

If a transition is selected, the corresponding procedure (approach, SID
or STAR) is added or replaced

as well.

Insert ... into Flight Plan:



This menu item will add the selected procedure to the current flight
plan. A procedure of the same type

(SID, STAR or approach with or
without transition) will be replaced if already present in the flight
plan.

Use ... as Destination or Use ... as Departure:

This will add or replace the destination or departure airport and add
the selected procedure.

If the flight plan is empty, the departure or destination airport is
added to the flight plan as well.

A leg entry will drawn red if a navaid was not resolved during the
scenery database loading process.

This happens only when the source data
is not valid or incomplete. In this case, the resulting procedure

is not
usable and a warning dialog will be shown if essential navaids are
missing.

Little Navmap might refuse to use the procedure depending on error.

25.4.3.  Show Information for Airport

Show detailed information in the Information dock window for the
airport.

See the Information for details.

Same as Show Information in map context menu.

25.4.4.  Show Airport on Map

Show the airport on the map. The zoom distance can be changed in the
dialog Options on the tab Map

Navigation.

25.4.5.  Show Airport in Search

Shows the airport in the airport search tab. Same as Show in Search in map context menu.

25.4.6.  Preview all Procedures

This highlights all procedures and their transitions currently shown in the procedure tree on the map.

Note that the map display is updated automatically when changing filters.

Tooltips give information about navaids in the preview.

Note that missed approaches are not shown when previewing all procedures.

Procedures can be added to the flight plan by either using Insert Procedure on the
preview from the

map context menu (right click on a navaid) or the Context Menu Procedures.



Previewing all SID at LIPO from runway 14. Context menu open to add SID and airport as departures.
The preview also

uses the Transparent line setting for flight plans in Options on page Flight Plan.

25.4.7. Follow Selection

The map view will be zoomed on the selected procedure or procedure leg if this function
is enabled.

25.4.8. Expand All / Collapse All

Expand all procedures so that their legs and transitions are shown or
collapse the tree.

25.4.9.  Reset Search

Clear search filters and revert to showing all procedures in the tree.

25.4.10.  Clear Selection

Deselect the currently selected procedure and remove the preview from
the map.

Also clears the procedure preview enabled with Preview all Procedures.

25.4.11.  Reset View

Reset column order and column widths to default.



26. Userpoints

User defined waypoints (or userpoints) allow for adding, editing,
searching, exporting, and importing

bookmarks, points of interest,
waypoints and more. You can pick freely which types you want to see as

icons on the map.

An overview of userpoint functionality showing
information on the left dock window, highlighted userpoints on the map,

userpoints selected in the search window on the right, and the drop down
menu opened by clicking the userpoint icon in the

dock window.
Screenshot based on Little Navmap 2.4. Click image to enlarge.

26.1. Userpoint Search

The functionality of the search filters and the result table is similar
to the airport and navaid search.

See Search
for information about search filters and buttons.

Additional context menu items and buttons allow adding, editing, and
deleting of userpoints.

26.1.1. Top Buttons and additional Menu Items

See Context Menu Search for a
description of common context menu items across all search dialogs.

All
buttons have an equivalent in the result table context menu.

26.1.1.1.   Undo and Redo Userpoint

Allows undo and redo of all userpoint changes. The last action is shown in the menu item like
Undo

deleting of tow Userpoints, for example.
The undo information is kept when restarting Little Navmap and

only deleted if a certain amount of
undo steps is exceeded.

Also in main menu Userpoint -> Undo and Redo Userpoint.

26.1.1.2.  Add Userpoint

Add an user-defined waypoint to the userpoint database.

Some fields of the new userpoint dialog are populated automatically
depending on a selected userpoint

or, if nothing is selected in the
search result table, based on previous additions. This allows to quickly

add similar userpoints to the database without the need to re-enter all
the information.



Note that you have to add the coordinates manually if the dialogs starts
empty i.e. nothing was

selected in the result table. Add userpoints with
the map context menu ( Add Userpoint) to
avoid this

and have the coordinates set automatically.

See below for more information about the add dialog: Add Userpoints.

26.1.1.3.  Edit Userpoint

Open the edit dialog for one or more userpoints.

The edit dialog shows a column of checkboxes on the right side if more
than one userpoint is selected.

These allow to choose the fields to
change for a bulk edit.

See below for more information about the add dialog.

26.1.1.4.  Delete Userpoint

Remove the selected userpoints. The action can be undone in the main menu Userpoint.

26.1.1.5. Cleanup Userpoints

Opens a dialog window where the userpoint database can be cleaned up.
The dialog contains the

following options:

Delete userpoints having no information except coordinates and type

Removes empty userpoints without any information.

Remove duplicates using additional fields as criteria.

A userpoint will considered a duplicate to another if all selected fields are equal. The following

fields can be checked:

Ident, Name, and Type

Region

Remarks

Tags

Coordinates



Cleanup up userpoints dialog. Empty userpoints will not be deleted.
Duplicates are removed if ident, region, name, type

and coordinates are the same.

26.1.1.6.  Menu Button

See Menu Button.

26.2. Add Userpoints

The dialog is shown when selecting Add Userpoint  in the map
context menu, using the top button

in the userpoint search tab, or
selecting Add Userpoint from the context menu in the search result
table.

The dialog will be populated automatically depending on the selected map
context, the selection in the

search result table or previous additions.

Type can be selected from a drop down list or entered freely.

Name and Tags can be selected freely. Note that some of these fields have a special meaning for X-Plane

import and export. See below for more information.

The field Description allows multi line text and special characters.
Formatting like italic or bold is not

supported. See Remarks for more information about using web links in this field.

The field Visible from allows to define visibility on the map
depending on zoom distance. The zoom

distance (viewpoint distance to
earth surface) for the current map view is shown in the
Statusbar. The

userpoint will be visible for
all zoom distances smaller than the value in Visible from. Maximum
value is

3,000 NM and minimum value is 1 NM.

Valid coordinates are required to confirm the dialog. See Coordinate Formats for a detailed
description

of the recognized coordinate formats. A label below the
coordinates displays the parsed coordinates or

an error message in case
the coordinates are invalid.



The userpoint is removed on next startup of Little Navmap when
Temporary userpoint. Delete on next

startup. is checked.

The button Reset clears all fields with exception of the coordinates
and sets the type of the userpoint to

Bookmark.

Note that all fields are optional. Only coordinates are required.

Add dialog that has been populated automatically by
context. The user right-clicked on an airport and selected
Add

Userpoint Airport Frankfurt am Main (EDDF).

26.3. Edit Userpoints

26.3.1. A single Userpoint

The edit dialog shows the same edit fields as the dialog used to add
userpoints above.

Additional metadata shown at the bottom:

Last Change: Date and time of import, creation or change.

Imported from file: File and path of source file from CSV,
X-Plane or Garmin import. You can

filter the userpoint search for
this name.

Temporary userpoint - will be deleted on next startup. This
indicates a temporary

userpoint.

The button Reset undoes all manual changes and reverts all fields to
their original state.



Edit dialog for a single userpoint.

26.3.2. Multiple Userpoints

If more than one userpoint was selected for editing, the edit dialog
shows a column of checkboxes on

the right side.

If checked, the field to the left is unlocked and any text entered will
be assigned to the respective field

in all selected userpoints.
Unchecked fields will not be altered for any of the userpoints.

In combination with the search function, this allows for bulk
changes like fixing an invalid region and

simultaneously changing the
visibility range for the affected userpoints:

1. Search for all userpoints with the invalid region.

2. Select all the resulting userpoints, e.g. by clicking on one of the
userpoints among the search

results and pressing Ctrl+A or by
clicking on the top left corner of the column header.

3. Right-click one of the highlighted userpoints and select
Edit Userpoints from the context menu.

4. Click the checkbox to the right of the Region: field and change
the region.

5. Click the checkbox to the right of the Visible from: field and
adjust the value.

6. Click OK.



Edit dialog for more than one userpoint. The fields
Region and Visible from will be changed for all selected points.
All

other fields remain unchanged.

26.4. Types

The userpoint type can be any text string. If the text matches an entry
from the list below, the

appropriate icon is used. Otherwise, the icon
for Unknown  is used.

Types and icons can be customized and new types can be added. See
Userpoint Category Icons
for

information on how to do this.

Some types are used as defaults when adding new userpoints. This depends
on the context, i.e. what

was below the cursor when right-clicking on
the map.

Note that the userpoint types cannot be translated to other languages for now.

Below a list of the most important userpoint types.

26.4.1. Addon

The userpoint type Addon and all other user defined type names starting with Addon are used to highlight

add-on airports.
The built-in type Addon can be added using Mark Airport as Add-on from the map and

other context menus.
You can add you own userpoint type names starting with Addon to create more

add-on categories. See Icons for more information.

26.4.2. Airports

 Addon: Can be used to mark airports manually as addon. Does not show labels to avoid

overlap with marked airport.

 Airport: Default when creating an userpoint on top of an airport.



 Airstrip

 Closed airport

 Helipad

 Seaport

26.4.3. Navaids

 DME: Distance measuring equipment. Default when creating an userpoint on top of a

DME.

 NDB: Non-directional beacon. Default when creating an userpoint on top of a NDB.

 Radio Range: Old radio range navigation aid.

 TACAN: Tactical air navigation system. Default when creating an userpoint on top of a

DME.

 VORDME: VHF omnidirectional range and DME. Default when creating an userpoint on top

of a VORDME.

 VORTAC: VOR and TACAN. Default when creating an userpoint on top of a VORTAC.

 VOR: VHF omnidirectional range. Default when creating an userpoint on top of a VOR.

 VRP: Visual reporting point.

 Waypoint: Default when creating an userpoint on top of a navaid. Default when creating

an userpoint on top of a waypoint.

26.4.4. Points of Interest

 Bookmark: Default type for new userpoints.

 Cabin

 Error

 Flag

 Lighthouse

 Location

 Logbook. Also legacy logbook entry.

 Marker



 Mountain

 Obstacle

 Oil Platform

 POI

 Pin

 Unknown: Type named Unknown and all types which do not
match the default types in this list.

26.5. CSV Data Format

The CSV data format is aligned to the format already used around the
flight simulator community and

other applications.

Each row in the file represents an user defined waypoint.

The recommended minimum fields for import are Type, Name, Ident,
Latitude and Longitude.

Only Latitude and Longitude are required.

All twelve fields are saved when exporting userpoints as CSV. Also, the
multi line field Remarks is

enclosed in quotes if needed and
preserves line breaks.

English number format (dot . as decimal separator) is used in import
and export to allow exchange of

files on computers with different
language and locale settings.

Little Navmap uses UTF-8 [https://en.wikipedia.org/wiki/UTF-8]
encoding when reading and writing files. This is

only relevant if you
use special characters like umlauts, accents or others. Otherwise
encoding does not

matter.

If an application fails to load a CSV file exported by Little Navmap,
use LibreOffice Calc

[https://www.libreoffice.org], Microsoft
Excel or any other spreadsheet software capable of reading and writing

CSV files to adapt the exported file to the format expected by that
application.

See Comma-separated
values [https://en.wikipedia.org/wiki/Comma-separated_values] in the
Wikipedia for detailed

information on the format.

26.5.1. Examples

Example for an absolute minimal userpoint consisting of coordinates only:

,,,49.0219993591,7.8840069771


Visible from will be set to the
default of 250 NM and the userpoint will be shown using the Unknown


icon after import.

Example for a minimal userpoint record with type Mountain , ident and name for import:

Mountain,My Point of Interest,MYPOI,49.0219993591,7.8840069771


Visible from will be set to the default of 250 NM after import.

Example for an exported userpoint with type Mountain and all fields set:

Mountain,My Point of 

Interest,MYPOI,49.0219993591,7.8840069771,1200,2.0085027218,"View,Interesting,Point","Interesting point 

https://en.wikipedia.org/wiki/UTF-8
https://www.libreoffice.org/
https://en.wikipedia.org/wiki/Comma-separated_values


""Eselsberg"" - nice view",ED,250,2018-05-17T17:44:26.864


Note of the following when parsing the CSV files:

In the
field Tags, the list "View,Interesting,Point" is enclosed in
double quotes since it contains commas.

The field description
"Interesting point ""Eselsberg"" - nice view" is enclosed in double
quotes since the

text itself contains a pair of double quotes
("Eselsberg") which are, in turn, escaped by another double

quote
each.

26.5.2. CSV Fields

The full header if enabled on export is:

Type,Name,Ident,Latitude,Longitude,Elevation,Magnetic Declination,Tags,Description,Region,Visible From,Last

Edit,Import Filename

Position Name Required
Empty

Allowed
Comment

1 Type Yes Yes

One of the predefined or user defined types. The

icon for Unknown is used if the type does not match

one of the known types.

2 Name Yes Yes Free to use field. Used for Garmin export.

3 Ident Yes Yes

Required only for Garmin and X-Plane export. Has to

be an unique valid identifier with maximum of five

characters for these exports.

4 Latitude Yes No
Range from -90 to 90 degrees using dot . as decimal

separator

5 Longitude Yes No
Range from -180 to 180 degrees using dot . as

decimal separator.

6 Elevation No Yes

Must be a valid number when used. A suffix f

indicates an elevation unit feet and m indicates

meter. The default unit with no suffix given is feet.

7
Magnetic

declination
No Yes

Ignored on import and set to a valid calculated value

on export.

8 Tags No Yes Free to use field. GUI has no special tag search.

9 Description No Yes Free to use field which allows line breaks.

10 Region No Yes

Two letter ICAO region of an userpoint or waypoint.

Used for X-Plane export. Replaced with default value

ZZ on X-Plane export if empty.



Position Name Required
Empty

Allowed
Comment

11
Visible

From
No Yes

Defines from what zoom distance in NM (shown on

Statusbar) the userpoint is visible. Set to 250 NM if

empty on import.

12 Last Edit No Yes

ISO date and time of last change. Format is

independent of system date format settings. Format:

YYYY-MM-DDTHH:mm:ss. Example: 2018-03-

28T22:06:16.763. Not editable in the user interface.

13
Import

Filename
No Yes

Full path and file name the userpoint was imported

from. Not editable in the user interface.

26.6. X-Plane user_fix.dat Data Format

This allows to read and write the X-Plane user_fix.dat file for
user defined waypoints. The file does not

exist by default and has to be
saved to XPLANE/Custom Data/user_fix.dat.

The format is described by Laminar Research in a PDF file which can be downloaded for X-Plane 11 XP-

FIX1101-Spec.pdf [https://developer.x-plane.com/wp-content/uploads/2019/01/XP-FIX1101-Spec.pdf] and X-Plane 12 XP-

FIX1200-Spec.pdf [https://developer.x-plane.com/wp-content/uploads/2021/09/XP-FIX1200-Spec.pdf].

The file consists of a header and a number of rows for the user fixes.
Each row has five columns which

are separated by space or tab
characters.

There are five columns of data in the file which are mapped to the userpoint data as shown below:

1. Latitude: From and to userpoint field Latitude.

2. Longitude: From and to userpoint field Longitude.

3. Ident: From and to userpoint field Ident.

4. Airport ident: From and to first space separated entry of userpoint field Tags. Optional.

5. Region: From and to userpoint field Region.

6. Waypoint type as defined by the 3 columns of ARINC 424.18 field definition.
From and to

second space separated entry of userpoint field Tags. See remarks below. Optional.

7. Name (only X-Plane 12): From and to userpoint field Name.

Field decoding for X-Plane 11 and 12:

The Little Navmap userpoint tags field is used to load and save the ID of the airport terminal area

as well as the waypoint type.

The waypoint type is based on ARINC 424 field type definition 5.42.
Spaces from this field are

replaced by underscores _ for userpoint tags. Alternatively double quotes and
spaces can be used.

Little Navmap decodes and encodes the field when exporting and importing user_fix.dat.

Example tags in Little Navmap: EDDF V__ is a VFR Waypoint at airport EDDF, ENRT "I  " is an en-

route unnamed
charted intersection and ENRT R__ is an en-route named intersection. These tags

are encoded to the numeric values on export.

The user defined waypoints are shown on the
X-Plane map if the correct type (VFR or other) matches

the X-Plane map type.
Waypoints can be selected and used to build flight plans in the X-Plane stock

GPS and FMS.

Example for user_fix.dat :

I


1101 Version - data cycle 1704, build 20170411, metadata FixXP1101. NoCopyright (c) 2017 useruser


50.88166689    12.58666711   PACEC ENRT ZZ


https://developer.x-plane.com/wp-content/uploads/2019/01/XP-FIX1101-Spec.pdf
https://developer.x-plane.com/wp-content/uploads/2021/09/XP-FIX1200-Spec.pdf


-36.29987200   174.71089013   N0008 NZNI ZZ


 6.000000000  159.000000000  06E59 ENRT ZZ 2115159


 6.000000000  160.000000000  06E60 ENRT ZZ 2115159


51.801667      -8.573889     VP001 ENRT EI 2105430 HALFWAY ROUTE


51.816389      -8.390833     VP002 ENRT EI 2105430 CARRIGALINE


99


Important

Keep in mind that waypoints are loaded from the Navigraph database if the
default mode Use

Navigraph for Navaids and Procedures is enabled in Little Navmap.
Therefore, user defined waypoints

from the file user_fix.dat are not
shown in Little Navmap after loading the scenery library from X-

Plane.

26.6.1. Import

Example line from user_fix.dat above:

50.88166700  12.58666700 PACEC ENRT ZZ

The coordinates are read into the Little Navmap userpoint
coordinates.

The fix ident PACEC is read into the Ident field in Little
Navmap.

The fix airport ENRT (en-route: no airport here) is read into the
Tags field in Little Navmap.

The region ZZ (invalid or no region) is read into the Region
field in Little Navmap.

Type will be set to Waypoint  for all imported
fixes.

26.6.2. Export

The mapping is the same as for the import.

See X-Plane user_fix.dat Data Format above for waypoint type mapping.

All other fields are ignored.

The ident is adjusted to match an up to five digit and letter
combination. A generated ident is used if

that is not possible or the
ident is empty.

Fix airport is always ENRT when exporting.

The region is adjusted for a two letter digit and letter combination.
ZZ is used if that is not possible or

the region is empty.

Note

The ident has to be unique in the user_fix.dat. Therefore
it is recommended to set an unique ident for

each waypoint manually or
leave the field empty so Little Navmap can generate an ident
during

export.

26.7. Garmin user.wpt Data Format

The Garmin user waypoint file is a CSV file. Each row in the file
represents an unique user waypoint.

There must be four columns of data in the file:

1. Waypoint ident

2. Waypoint name or description

3. Latitude

4. Longitude

Example of a user.wpt file:



MTHOOD,MT HOOD PEAK,45.3723,-121.69783


CRTRLK,CRATER LAKE,42.94683,-122.11083


2WTER,2NM WEST TERRACINA,41.28140000,13.20110000


1NSAL,1NM NORTH SALERNO TOWN,40.69640000,14.78500000


The waypoint ident can be up to 10 numbers or capital letters but the
GTN will shorten the name to the

first 6 characters. No special
characters or symbols can be used. Little Navmap adjusts the ident

accordingly.

The waypoint name can be up to 25 numbers, capital letters, spaces, or
forward slash / characters. The

name is displayed when selecting
waypoints to provide additional context to the pilot. Little Navmap

adjusts the name according to limitations.

26.7.1. Import

Example line from user.wpt above:

MTHOOD,MT HOOD PEAK,45.3723,-121.69783

The ident MTHOOD is read into the Ident field in Little
Navmap.

The name MT HOOD PEAK is read into the Name field in Little
Navmap.

The coordinates are read into the Little Navmap userpoint
coordinates.

Type will be set to Waypoint  for all imported
waypoints.

26.7.2. Export

Mapping of fields is same as import but all fields are adjusted to
limitations.

Note

If an imported waypoint ends up being within 0.001° latitude and
longitude of an existing user

waypoint in the GTN, the existing waypoint
and name will be reused.

26.7.3. Export XML for FSX/P3D BGL Compiler

This export option creates an XML file which can be compiled into an BGL
file containing waypoints.

The region and ident fields are required for this export option. If
region is empty or otherwise invalid ZZ

is used. All waypoints are
of type NAMED.

See Prepar3D SDK documentation for information on how to compile and add
the BGL to the simulator.

Example:

<?xml version="1.0" encoding="UTF-8"?>


<FSData version="9.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xsi:noNamespaceSchemaLocation="bglcomp.xsd">


   <!--Created by Little Navmap Version 2.0.1.beta (revision 2b14e14) on 2018 05 17T12:24:36-->


  <Waypoint lat="47.40833282" lon="15.21500015" waypointType="NAMED" waypointRegion="ZZ" magvar="4.02111530" 

waypointIdent="WHISK"/>


  <Waypoint lat="47.39666748" lon="15.29833317" waypointType="NAMED" waypointRegion="ZZ" magvar="4.01835251" 

waypointIdent="SIERR"/>


</FSData>


26.8. Database Backup Files

Little Navmap creates a full database backup on every start since undo
functionality is not available for

userpoints.

You can also use the CSV export to create backups manually since CSV
allows to export the full

dataset.

See Files - Userpoints for information about database
backup files.



27. Logbook

Little Navmap creates logbook entries for each flight automatically
when detecting a takeoff or landing.

A logbook entry containing only
departure is created on takeoff and finalized with destination and more

information on landing.

Create Logbook entries has to be checked to enable this functionality.

Note that fuel consumption and other values are measured between takeoff and landing, as it is not

possible to reliably determine the beginning and end of a flight.

You can speed up the flight or to warp to another position without breaking the logbook record.

Editing functionality in the logbook is similar to the userpoints
editing ( Userpoint).

Note

Use Reset all for a new Flight to be sure
that the logbook flight detection is set up for a new flight.

The takeoff and landing detection is reset if you restart Little Navmap while flying. In this case
you

get two entries where one is for departure and one for arrival. Merge these manually if needed.



27.1. Create Logbook Entries

Little Navmap creates logbook entries for each flight automatically if
this menu item Create Logbook

entries is checked. A logbook entry containing only departure is
created on takeoff and finalized with

destination, track and more information on landing.

Note that the takeoff and landing detection is reset if restarting Little Navmap while flying. In this case

you get two entries where one is for departure and one for arrival. Merge these manually if needed.

Note that the content of the field Simulator in the logbook entries is determined by the
selected scenery

library and not by the connected simulator.

Note

Always use Reset all for a new Flight before doing a flight.



27.2. Logbook Files

Each logbook entry has a reference using the full path to the used flight plan and aircraft
performance

files. Keep in mind that these references break if the files are moved or renamed. Update them

manually if needed.

Additionally, the flight plan file, the aircraft performance file and the flown track are directly inserted

into
logbook entry. These attachments can be saved as LNMPLN, LNMPERF or GPX files.

See Little Navmap LNMPLN Format for information about the LNMPLN format.

The GPX trail contains coordinates, flown altitude and time as well as the simplified flight plan with

airport and navaid idents, coordinates and calculated altitude.

The flight plan file contains all plan information like procedures or remarks just as the loaded LNMPLN

file.

You can access and modify the referenced and attached files in the context menu of the search result

table and edit dialog.

Note

Unfinished flights will not have trail information and show only the departure airport.



27.3. Logbook Search

The functionality of the search filters and the result table is equal to
the airport and navaid search. See

Search for information about search filters and buttons.

A search field Airport Ident allows to search entries having either a matching destination or
departure

airport. The fields Departure Airport Ident and Destination Airport Ident allow to search exactly for

departure and destination airports or combinations.

Additional context menu items and buttons allow adding, editing, and
deleting of logbook entries as

well as saving or loading the attached flight plan or track.

One or more logbook entries are highlighted on the map with blue lines
connecting departure and

destination as well as the two airports once
selected in the search result table.

The label at the connecting great circle line shows departure airport
ident, destination airport ident and

great circle distance. A tooltip is
shown if hovering the mouse over the blue direct connection or flight

plan preview lines.

Note

Logbook details (route preview and trail) on the map are only shown if one single entry is selected
in

the logbook search result table. Selecting more than one entry shows only the direct connection lines

if enabled.

Map showing several logbook entries selected and
highlighted. Departure and destination of each entry is connected by a

great circle line. A tooltip shows more information.



A selected logbook entry and the flight plan preview showing the waypoints and flying direction.
The dashed line shows the

flown track.

27.3.1. Footer

The footer shows the number of selected, loaded and visible logbook entries considering search and

filter criteria.

Note that you to select Show All from the table context menu or have to scroll down to see all entries:

Example : 9 of 3667 Logbook Entries selected, 256 visible.

A second footer line shows up if one or more logbook entries are selected.
This line shows the total real

travel time, the total simulator travel time and the accumulated distance for the selected entries.

Example: Travel Totals: Real time 2 h 13 m. Sim. time 6 h 48 m. Dist. 1.298 NM.

27.3.2. Top Buttons and additional Menu Items

See Context Menu Search for a
description of common context menu items across all search dialogs.

All
buttons have an equivalent in the result table context menu.

27.3.2.1.   Undo and Redo Logbook Entry

Allows undo and redo of all logbook changes. The last action is shown in the menu item like
Undo Adding

of one Logbook Entry, for example.
The undo information is kept when restarting Little Navmap and only

deleted if a certain amount of
undo steps is exceeded.

Also in main menu Logbook -> Undo and Redo Logbook Entry.

27.3.2.2.  Add Logbook Entry

Add a logbook entry manually.

See Add Logbook Entry and Edit Logbook Entry
below for more information about the add/edit dialog.

27.3.2.3.  Edit Logbook Entry



Open the edit dialog for one or more logbook entries.

The edit dialog shows a column of checkboxes on the right side if more
than one logbook entry is

selected. These allow to choose the fields to
change for all selected entries.

See Edit Logbook Entry below for more information about the
add/edit dialog.

27.3.2.4.  Delete Logbook Entry

Removes the selected logbook entries. The action can be undone in the main menu Logbook.

27.3.2.5. Cleanup Logbook Entries

Removes invalid logbook entries.

Shorter than 5 NM: Removes all entries where the distance flown is below 5 NM.

Departure and destination ident equal: Delete all entries where departure ident is the same as the

destination ident (which can happen when doing pattern work). Airport names or other

attributes are not compared.

Either departure or destination ident empty: Remove all entries where departure or destination is

empty. This can happen when running simulator replay, redoing landings or interrupting flights.

You can undo the change using Undo and Redo Logbook Entry in the logbook table context menu.

Logbook cleanup dialog.

27.3.2.6. Airport

Sub-menu for departure and destination airport.

27.3.2.6.1.  Show Information for Airport

27.3.2.6.2.  Show on Map

27.3.2.6.3.  Set as Flight Plan Departure

27.3.2.6.4.  Set as Flight Plan Destination

27.3.2.6.5.  Set as Flight Plan Alternate



These menu items are only enabled for a right click on a departure or destination airport name or

airport ident.
Same functionality as in Context Menu Map and in Context Menu Flight Plan.

27.3.2.7. Files

Sub-menu for referenced and attached files.

27.3.2.7.1.  Open Flight Plan

Opens the referenced flight plan file.
This menu item is disabled if the referenced file cannot be found.

This can be the case if the file was renamed or moved.

Same as Open Flight Plan.

27.3.2.7.2.  Open Aircraft Performance

Opens the referenced aircraft performance file.
This menu item is disabled if the referenced file cannot

be found.
This can be the case if the file was renamed or moved.

Same as Open Aircraft Performance.

27.3.2.7.3. Open attached Flight Plan

Opens the attached flight plan file replacing the currently loaded flight plan.

27.3.2.7.4. Save attached Flight Plan as

Saves the attached LNMPLN flight plan to a new file.

27.3.2.7.5. Open attached Aircraft Performance

Opens the attached performance file replacing the currently loaded aircraft performance file.

27.3.2.7.6. Save attached Aircraft Performance as

Saves the attached LNMPERF flight plan to a file.

27.3.2.7.7. Save attached GPX Trail as

Saves the attached GPX to a file which contains the flown trail as well as the flight plan preview.

27.3.2.8. View Options

These three options activate or deactivate the respective preview functions for selected logbook

entries.

The start and destination airports are always highlighted. This is also the case when all three options

are deactivated.

27.3.2.8.1. Show direct connection

Shows a direct connection line between start and destination.

Displayed for one or more selected logbook entries.

27.3.2.8.2. Show flight plan preview

Shows a simplified preview of the flight plan used.

This is only shown when a single logbook entry is selected.

27.3.2.8.3. Show aircraft trail



Shows the flight path.

This is only shown if a single logbook entry is selected.



27.4. Add Logbook Entry

This dialog window is used to create a new log entry manually. The dialog layout and
functionality is

the same as for editing logbook entries. The button
Reset clears all fields.



27.5. Edit Logbook Entry

The dialogs for editing and adding are equal and contain three tabs.

Most fields have a tooltip explaining the meaning, are optional and can
be freely edited.

The button Reset undoes all manual changes and reverts all fields
back to the original state.

27.5.1. Tab Logbook Entry

Additional notes about some fields on this page:

Departure and Destination: These are automatically resolved
to an airport. Coordinates (not shown

and not editable) are assigned
to the departure or destination airport if found. The dialog will

show the airport name and elevation if the airport ident can be
resolved. Otherwise an error

message is shown.

Date and Time in Simulator UTC: Time set in the simulator on
takeoff or touchdown. Always UTC.

Real local Time: Real world time on takeoff or touchdown. Stored
in your local time.

Route Description: Flight Plan Route Description extracted from the flight plan.

Flight plan file and Aircraft performance file: Used flight
plan and performance files. These are

only references which will turn
invalid if the files are moved or renamed. Update manually if

needed.

27.5.2. Tab Fuel and Weight

Block fuel and trip fuel are extracted from Tab Fuel Report.

Used fuel is the fuel consumption between takeoff and touchdown.

27.5.3. Tab Remarks

Free text input field which is also shown in the tooltip and the information window on tab Logbook.

See Remarks for more information about using web links in this field.

27.5.4. Edit a single Logbook Entry

Editing a logbook entry. Click image to enlarge.

27.5.5. Edit multiple Logbook Entries

If more than one logbook entry was selected for editing, the edit dialog
shows a column of checkboxes

on the right side of available fields. Not
all fields are available for bulk edit.



If checked, the field to the left is unlocked and any text entered will
be assigned to the respective field

in all selected logbook entry.
Unchecked fields will not be altered for any of the selected entries.

In combination with the search function, this allows for bulk changes
like fixing an invalid aircraft type

for more than one entry.

Editing more than one logbook entry. Three fields are to be changed for the selected entries. Click image to enlarge.



27.6. Logbook Statistics

This dialog shows two tabs:

1. Overview contains a general report which can be copied as
formatted text to the clipboard.

2. Grouped Queries has a button on top which shows different reports
in the table below. The content

of the table can be copied as CSV to
the clipboard.

Some simulators report a wrong departure and arrival time in rare cases which can result in negative

flying time for some flights.

The logbook statistics ignore these invalid simulator time intervals.

Correct the simulator departure or arrival time manually if you find such cases.

You can click on the top table header to sort the related column in ascending or descending order.

Scroll down in the table to load more values.

Overview tab of logbook statistics dialog. Click image to enlarge.

27.7. Import and Export

The full logbook or selected logbook entries can be imported and exported to a CSV (comma separated

value) text file which can be loaded in LibreOffice Calc or Microsoft Excel. All data can be
exported and

imported which allows to use this function for backup purposes.

Export and import can be done by using the menu items Import CSV and
Export CSV.

See chapter CSV Data Format below for more information on the format.

27.8. X-Plane Import

Imports the X-Plane logbook file
.../X-Plane 11/Output/logbooks/X-Plane Pilot.txt into the Little
Navmap

logbook database. Note that the X-Plane logbook format is
limited and does not provide enough

information to fill all Little
Navmap logbook fields.



The imported logbook entries get remarks containing
Imported from X-Plane logbook X-Plane Pilot.txt which

allows to
search for the imported entries. Use a pattern like
*Imported from X-Plane logbook X-Plane

Pilot.txt* in the description
search field to look for all imported entries.

Available information in the X-Plane logbook:

1. Date of flight

2. Departure airport

3. Destination airport

4. Number of landings - added to description.

5. Duration of flight

6. Time spent flying cross-country, in IFR conditions and at night -
added to description.

7. Aircraft tail number

8. Aircraft type

X-Plane logbook example:

I


1 Version


2 190917    EDDN    ESNZ   4   0.8   0.0   0.0   0.0  C-STUB  727-100


2 190917    ESNZ    ESNZ   0   0.1   0.0   0.0   0.0  C-STUB  727-100


2 190920    LSZR    LSZR   0   0.2   0.0   0.0   0.0    SF34


27.9. Database Backup Files

Little Navmap creates a full database backup on every start since undo
functionality is not available for

logbook entries.

You can also use the CSV export to create backups manually since CSV
allows to export the full

dataset.

See Files - Logbook for information about database backup
files.

27.10. CSV Data Format

English number format (dot . as decimal separator) is used in import
and export to allow exchange of

files on computers with different
language and locale settings.

Little Navmap uses UTF-8 [https://en.wikipedia.org/wiki/UTF-8]
encoding when reading and writing files. This is

only relevant if you
use special characters like umlauts, accents or others. Otherwise
encoding does not

matter.

If an application fails to load a CSV file exported by Little Navmap,
use LibreOffice Calc

[https://www.libreoffice.org], Microsoft
Excel or any other spreadsheet software capable of reading and writing

CSV files to adapt the exported file to the format expected by that
application.

See Comma-separated
values [https://en.wikipedia.org/wiki/Comma-separated_values] in the
Wikipedia for detailed

information on the format.

Altitudes are always feet and distances are always nautical miles in the
exported CSV.

The first line of the CSV contains the field names if chosen for export.

Field name Description

Aircraft Name Free name like Cessna 172

Aircraft Type ICAO type descriptor like
B732

Aircraft Registration e.g. N12345

https://en.wikipedia.org/wiki/UTF-8
https://www.libreoffice.org/
https://en.wikipedia.org/wiki/Comma-separated_values


Field name Description

Flightplan Number Flight number if available

Flightplan Cruise Altitude Flight plan cruise altitude in
feet

Flightplan File Full path to flight plan file

Performance File Full path to performance file

Block Fuel From aircraft performance - lbs

Trip Fuel As above

Used Fuel As above

Is Jetfuel Calculated from aircraft fuel,
1 is jet fuel

Grossweight Weight at takeoff, lbs

Distance Flight plan distance in NM

Distance Flown Actual flown distance in NM

Departure Ident Airport ident

Departure Name Airport name

Departure Runway Runway if available

Departure Lonx Coordinates if available and
airport resolves

Departure Laty As above

Departure Alt Elevation in ft

Departure Time Real world departure time in
local time

Departure Time Sim Simulator departure time in UTC

Destination Ident Same as above for destination

Destination Name As departure



Field name Description

Destination Runway As departure

Destination Lonx As departure

Destination Laty As departure

Destination Alt As departure

Destination Time As departure

Destination Time Sim As departure

Route string ICAO route description

Simulator X-Plane 11, Prepar3D v4,
etc.

Description Free text by user

Flightplan The flight plan in LNMPLN
XML format

Aircraft Perf The aircraft performance in
LNMPERF XML format

Aircraft Trail The flown trail and flight plan
preview in GPX format



28. Online Networks

The online network functionality allows to connect to
VATSIM [https://www.vatsim.net], IVAO [https://ivao.aero],

PilotEdge [https://www.pilotedge.net/] or other online networks
which publish information using whazzup.txt or

JSON files. This covers display of information
for centers, clients and servers on the map.

Network specific information like user names, active centers/towers,
frequencies, flight plans and much

more are displayed world wide without
limits like distance to the user aircraft.

Access to online networks can be enabled and configured on
Online Flying.
Predefined options for the

well known networks are available as well as
freely configurable ones.

The custom connection options can be used for internal networks or tools like the Transmitter

[https://virtualflight.online/transmitter/]
which can be used for small flying groups and MSFS which does not

provide multiplayer traffic on its interface.

Online network related functionality can be found in the following
places:

Search dock window, tabs Online Clients, Online Centers and
Online Server.

Information dock window, tabs Online Clients and
Online Centers.

Options dialog, page Online Flying.

See Search for general information on the search tabs.

28.1. Simulator and Online Aircraft Duplicates

Little Navmap fetches data from online networks using an interval of 15 seconds up
three minutes

depending on settings and network.

The program also fetches AI or multiplayer aircraft from the simulator
which are updated about several

times a second. These aircraft are injected
into the simulator by the various online clients so they are

visible
in the sim.

Therefore, the user aircraft and other client aircraft can appear
duplicated on the map. Little Navmap

removes these duplicates by matching the position, speed and other parameters against each other.

The de-duplication can be disabled in dialog Options on page Online Flying.

28.2. Map Display

28.2.1. Clients

Online network clients or their aircraft are displayed on the map using
the  symbol. This includes

simulator aircraft that
were recognized as online network clients.

The user aircraft is always displayed using the yellow  or a
similar symbol depending on aircraft

type and simulator. Use the
Show in Search map context menu item to see your own aircraft in the
list

of online clients.

Information for online aircraft is shown on the tab Online Clients
in Information.

All other functionality like context menu, double-click, tooltips, map
highlights and other are the same

as for the other aircraft.

See Aircraft and Ships in the legend for all
symbols.

https://www.vatsim.net/
https://ivao.aero/
https://www.pilotedge.net/
https://virtualflight.online/transmitter/


Online network clients/aircraft in search tab, map, tooltip and information window. Image based on Little Navmap 2.4. Click

image to enlarge.

28.2.2. Centers

Online centers are displayed as circular airspaces in Little Navmap
and provide the same functionality

as the other airspaces (tooltips,
information and more). They can be enabled separately from the other

airspaces by selecting Online as airspace source (Airspace Libraries)

Note

The circles do not represent the real airspaces and are only
used to indicate the presence of an

active center, tower, ground or
other position. See below how to assign airspace boundaries to
a

center.

Detailed information for online centers/airspaces is shown in the Information window.

The following types are available and can be enabled in the drop down
menus on the airspace toolbar

or sub-menu
Airspaces:

Observer: Circle size is taken from the visual range value of the center.

Flight Information (Center): Uses the visual range.

Delivery (Clearance): Uses the visual range.

Ground: Shows a circle with a diameter of 10 NM.

Tower: 20 NM circle.

Approach: 40 NM circle.

ACC (Center): Uses the visual range.

Departure: Uses the visual range.

The size of the circle shapes and the lookup type can be changed in the options dialog.
See Map

Display Online.

You can also assign centers to a boundary shape using imported OpenAir, JSON or GEOJSON
airspaces

from the user airspace database. See Online Airspaces for more
information about this. The airspace

geomentry is assigned to the centers by ident and type.



Online network center/ATC in search tab, map, tooltip and information window.

28.3. Online Search

28.3.1. Online Network Client Search

28.3.2. Online Network Center Search

The functionality of the search filters in these two tabs and the result
tables are similar to the airport

and navaid search. See Search for information about search filters, buttons and
context menu items.

28.3.3. Online Server Search

Displays all online servers in a table and has no search functionality.
You can use the context menu to

copy parts of the result table like the
IP address.



29.  Information

29.1. General

This dock window contains text information about airports in several
tabs as well as information for one

or more navaids, airways in another
tab plus an additional tab showing airspace information.

All information can be copied to the clipboard as formatted text. Use
the context menu of the text

fields or use Ctrl+A to select all and
Ctrl+C to copy the content to the clipboard.

Note that the formatted
clipboard content is removed when Little Navmap is closed.

Bearing and distance to the user aircraft
is shown for airports, navaids and userpoints if connected to a

simulator and if the distance is below 500 NM.

The display of additional units for fuel and weight as well as true
course can be enabled in the options

dialog on tab Units.

29.2. Dock Window and Tabs

Information for only one airport, navaid or userpoint is shown when
selecting one of the Show Information

for ... context menu items in
the map, flight planning dock window or the search result table.

All tabs are filled for airport, all navaids, all userpoints or all
airspaces which are close to the cursor for

a left click in the map.

Little Navmap shows tabs based on priorities and selected objects and
tries to minimize tab changes.

Example: If you click on an airport, a VOR, a NDB and an userpoint at
the same position:

1. Little Navmap fills all airport (several tabs), navaid and
userpoint tabs with information. The tab

Navaids gets information
for the NDB and the VOR.

2. The dock window Information is opened and raised if not visible.

3. The tab Userpoints is opened and raised if not visible.
Userpoints are activated since user features

like map highlights,
logbook entries or userpoints have priority before airports, navaids
and

others.

Use the map context menu for an easier selection of map objects through the sub-menus.

29.3. Links

A blue link Map in the information allows jumping to and/or
highlighting the shown object on the map. A

link
Remove Airway Highlights or Remove Airspace Highlights can be
used to remove the corresponding

highlights on the map.

The links Procedures, Departure Procedures or Arrival Procedures (text depends on airport position in flight

plan)
allow to jump directly to the Search Procedures window.

Other links open web pages with airport information in the web browser
or a file manager like Windows

Explorer with directories or files.

29.4. Scenery Information

All information about airports and navaids includes one or more links at
the bottom of the object

information in section Data Source. These links
point to the matching BGL (FSX, P3D and MSFS) or

apt.dat (X-Plane) files that
contain information about the airport or navaid. Click the links to open
the

containing directory in your file manager (e.g. Windows Explorer).
If possible, the matching file will be

selected automatically.

The data source Navigraph is shown if a navaid or airport originates from the Navigraph database.



Multiple links can appear for airports since these can be updated by
several files from different add-on

sceneries or navdata updates.

Note

The links shown as plain text with an additional remark like File not found if the file or folder is

missing.
This can happen if you copy databases between computers. This is only a remark has no

further consequences.

29.5. Tabs in Information Dock Window

29.5.1. Airport

A tab that has several sub-tabs for airport information.

The six tabs Overview, Runways, Com, Procedures, Nearest and Weather below
the airport tab show information

for one selected airport.

Airports can have several idents/codes depending on simulator. Unofficial internal idents are
avoided in

the Little Navmap user interface but can still show up in some cases.

See also Ident in Airport Search for airport search options.

Ident or code shown in parentheses after airport name: Either ICAO, FAA, IATA, local code

or
internal code depending on simulator and availability.

ICAO: Four letter ICAO code [https://en.wikipedia.org/wiki/ICAO_airport_code]. Only
available in X-Plane.

FAA: Airport code used in the United States given by the Federal Aviation Administration

[https://www.faa.gov/].
The FAA code is only available in X-Plane.

IATA: Three letter IATA airport code [https://en.wikipedia.org/wiki/IATA_airport_code].
Available in X-Plane and

Navigraph navdata.

Local Code: Official local airport code mostly used for small airfields. Only available in
X-Plane.

X-Plane Ident:: Internal identfier for X-Plane airports.

The airport codes are also shown in the information windows, tooltips and optionally in the map
labels

as well as in Flight Plan Route Description. ICAO, FAA, IATA, and local codes are shown and the internal

ident is avoided if possible.

Example:

Akutan is shown as Akutan (PAUT) with its official ICAO code PAUT on the map instead of the
internal X-

Plane code XPA000B.

29.5.1.1. General

Sunrise and sunset for the airport are calculated based on current real
date if no simulator is

connected. Otherwise the simulator date is used.
This is indicated by the text (civil twilight, real date)

or
(civil twilight, simulator date).

Preferred runways depending on wind are shown after the METAR. More
details about preferred

runways are on the tab Airport Weather.

Additional links for helipads are available in the tab Runways.

The tab Nearest shows airports having procedures and closest navaids
relative to the selected airport.

29.5.1.2. Links

Links to several online services like
SkyVector [https://skyvector.com/] or the The X-Plane Scenery
Gateway

[https://gateway.x-plane.com/] open a web browser with
information for the airport using the respective online

service.

The links are shown in the tab Overview.

https://en.wikipedia.org/wiki/ICAO_airport_code
https://www.faa.gov/
https://en.wikipedia.org/wiki/IATA_airport_code
https://skyvector.com/
https://gateway.x-plane.com/


Airport information with linked web-sites in the
Links section and links to user files in the Files section. Click image to

enlarge.

29.5.1.3. Files

Little Navmap will show extra links to local files if you put these
into a special directory with the name

of the airport ICAO ident.

The path to the airport files is shown in the Files section.

You can use any file type. A file will be opened with the default
application like a PDF reader if you click

on the link.

Examples for airport Ouessant (LFEC):

/home/YOURUSERNAME/Documents/Little Navmap Files/Airports/LFEC: Linux

/home/YOURUSERNAME/Dokumente/Little Navmap Dateien/Flugplätze/LFEC:
Linux with German translation

/Users/YOURUSERNAME/Documents/Little Navmap Files/Airports/LFEC:
macOS

/Users/YOURUSERNAME/Documents/Little Navmap Dateien/Flugplätze/LFEC:
macOS with German translation

C:\Users\YOURUSERNAME\Documents\Little Navmap Files/Airports/LFEC:
Windows

C:\Users\YOURUSERNAME\Dokumente\Little Navmap Dateien/Flugplätze/LFEC:
Windows with German

translation

You can use the translated directory names or the English variant.
Translated directory names depend

on the program and system language.
Little Navmap will only use the English names if you set the user

interface language to English.

Little Navmap looks for files using both the translated path and the
English path like: ...\Little Navmap

Files\Airports\LFEC and
...\Little Navmap Dateien\Flugplätze\LFEC.

The links are shown in the tab Overview.



Airport information overview. Additional tabs show
information for runways, COM frequencies, approaches and weather.

Weather symbols user NOAA weather as source. Sunset and sunrise is based
on real date since not connected to a

simulator. Wind direction prefers
runways 09 and 14. Click image to enlarge.

29.5.1.4. Weather

The tab Weather shows decoded weather information for a selected
airport. The flight rules icon (Airport

Weather) has a suffix - Map if the
shown weather source is the source for airport weather icons on the

map.
Detailed information for best runways for takeoff and
landing based on wind conditions is shown

as well.

The time is shown in warning orange color if older than three hours and in red error color if older

than six hours.

29.5.2. Tab Navaids

More than one navaid or airway can loaded into this tab on left click.
VOR, NDB, waypoint, airway and

ILS information is shown in this tab.

An airway or oceanic track is always shown with all its waypoints. Click any blue
waypoint link to center

the map around the waypoint.

Airways and tracks are highlighted and shown on the map when clicking the
Map link in the information

window.



Highlighted airways as well as tracks have their own tooltip which is also shown if all
other airways are

hidden.

Click the link Remove Airway and Track Highlights in the information
window to remove them from the map.

Navaid information. Two navaids were close to the cursor when clicked. Click image to enlarge.

Navaid information. Display of several airways with altitude restrictions and list of
clickable waypoints. Clicking on the link

Map highlights a whole airway. Click image to enlarge.

29.5.3. Tab Airspaces

Airspaces are highlighted on the map with their boundary and a text
label when clicking the Map link in

the information window.

Highlighted airspaces have their own tooltip which is also shown if all
other airspaces are hidden.

Click the link Remove Airspace Highlights in the information window
to remove the highlights from the

map.



Two airspaces that are shown in the information
after clicking into the map. Two airspaces are highlighted on the map
after

clicking onto the Map link in the information text. Click image to enlarge.

29.5.4. Other Tabs

Userpoints: Shows information about user defined waypoints or
points of interest.

Logbook: Details about logbook entries.

Online Clients: Online network clients/aircraft but not AI aircraft.

Online Centers: Online network centers/airspaces.

29.6.  Tabs in Simulator Aircraft Dock Window

This dock window shows information about the user aircraft and about AI
or multiplayer aircraft in

several tabs. This does not cover online aircraft. Little Navmap has to be
connected to the simulator to

enable this feature. See Connecting to a Flight Simulator for
more information on this topic.

Some fields need a valid flight plan to show. Warning and error messages are shown if needed.

29.6.1. Tab Aircraft

Gives an overview about the user aircraft and shows type, weight and
fuel information.



Aircraft information when connected to a flight
simulator. Alternate units (liter and kg) are enabled. Screenshot based on

Little Navmap 2.6. Click image to enlarge.

29.6.2. Tab Progress

Shows information similar to a flight management computer about the user
aircraft. This covers flight

plan progress, altitude, speed, ambient and
environment parameters.

A button  in the top right corner opens the Aircraft Progress Display Options window which allows

to configure the visible fields.

The aircraft and progress tabs show warnings and errors by highlighting
text in red or orange. These

are:

Fuel and time estimated since flight plan not valid.

Fuel and time estimated since aircraft performance not valid.

Insufficient fuel at destination (only if aircraft performance is valid).

Speed limit of 250 knots exceeded below 10,000 ft.

Icing.

Fuel and time estimates are based on the aircraft
performance if valid. ( Aircraft Performance).

Fuel at destination and at top of descent is estimated by the current
fuel amount in tanks and the

consumption as predicted by aircraft
performance for the remaining distance to fly. Wind as well as the

different fuel flow numbers of the climb cruise and descent phases is
considered in this calculation.

Time of arrival is similarly calculated by current time and aircraft
performance prediction considering

wind, climb cruise and descent
phases.

Headwind is indicated by arrow down ▼ and tailwind by an up arrow ▲.

Some rows like Ice are hidden if the condition is not met.

Note

Little Navmap might show an orange warning about insufficient fuel at
destination in the early flight

phases. This is normal since fuel flow
is higher for takeoff and early climb.

Note



Keep in mind that actual altitude shown in Little Navmap might differ from indicated altitude even

with a correct baro setting.

This is an effect of the outside air temperature (OAT) on actual altitude where low temperatures

affect the aircraft altimeter.
When temperature is less than ISA conditions an aircraft will be lower

than the altimeter reading.

This effect is currently modeled in X-Plane 12 and MSFS.

Corrections have to be applied when the aerodrome temperature is 0°C or colder:

DH/DA or MDH/MDA and step-down fixes inside the final approach fix (FAF).

All low altitude approach procedure altitudes in mountainous regions (terrain of 3000 ft AMSL

or higher)

See SKYbrary - Altimeter Temperature Error Correction [https://skybrary.aero/articles/altimeter-temperature-error-

correction]
for more information.

Aircraft progress information when connected to a
flight simulator and user aircraft airborne. Alternate weight and fuel

units (kg and liter) are enabled as well as true course display. Click image to enlarge.

29.6.2.1.  Aircraft Progress Display Options

Choose Aircraft Progress Display Options from the context
menu of the tab Progress in window Simulator

Aircraft to customize the output table.

The dialog uses a tree. See Trees for more information about this type of input element.

Note that not all fields are visible depending on aircraft status, flight plan and flight progress.

Same as main menu Tools -> Aircraft Progress Display Options.

29.6.3. Tab AI / Multiplayer

https://skybrary.aero/articles/altimeter-temperature-error-correction


Information about an AI or multiplayer aircraft from the simulator (not
online networks) or ship is

displayed in this tab if a vehicle is
clicked on the map.

This also includes the aircraft’s departure and destination airports
that can be shown on the map by

clicking on the blue links (only for FSX
or P3D and if a flight plan is filed).

Note that information on AI aircraft is limited on X-Plane.

Information about an AI aircraft. Click image to enlarge.



30.  Flight Planning

The flight planning Dock Window contains the four tabs: Flight Plan, Flight Plan Remarks,
Fuel Report (

Aircraft Performance) and Current Performance (Aircraft Performance Collection).

See chapter Flight Plan Calculation for more information about automatic calculation of flight plans.

30.1. Flight Plans

Little Navmap allows to build flight plans or flight plan snippets using arbitrary start positions by using

Append Position to Flight Plan or Add Position to Flight Plan in the map and other context menus.

Note that not all simulators or add-ons support this kind of flight plans.

You need to have the GLOBE elevation data installed to get the correct altitudes for arbitrary
start or

departure points. See Install GLOBE elevation data for installation instructions.

30.2. Header

The top shows a label that contains departure, departure position
(parking, runway or helipad),

destination, flight plan distance,
traveling time, used procedures (SID, STAR, approach and transitions)

as
well as flight plan type and more.

The label also displays red error messages if, for example, the runway of a
STAR differs from the

runway of the following approach procedure.

Traveling time is only shown if a valid aircraft performance profile is
loaded that has at least climb,

cruise and descent speeds set.

The ARINC name of the approach procedure which is needed by some FMCs is
shown in parentheses.

The header can be customized using Flight Plan Table Display Options.

Header of a flight plan with all labels enabled.

30.3. Flight Plan Table

The table view allows the same operations as the search table view
except sorting. See Tables for more

information.

All selected elements in the flight plan table view will be highlighted
on the map using a black/green

circle. See
Highlights for more information. Use
Shift+Click or Ctrl+Click to select two or more elements

(multi-selection).



The active flight plan leg is highlighted in magenta when Little
Navmap is connected to a simulator, the

user aircraft is airborne and
user aircraft is closer than 40 NM to the flight plan.

Procedure legs have dark blue color and legs of a missed approach have a
dark red color.

Alternate airports are shown at the end of the list using gray text.
Note that more than one alternate

can be added to the flight plan. Legs
to the alternate airports originate all from the destination.

30.3.1.  Flight Plan Table Display Options

Choose Flight Plan Table Display Options from the flight plan table context
menu to customize the table

columns, header and footer line content.

The changes to the table can be undone by selecting Reset View in the context menu.

The dialog uses a tree. See Trees for more information about this type of input element.

Same as main menu Tools -> Flight Plan Table Display Options.

The flight plan display options dialog window.

30.3.2. Table Columns

Hovering the mouse over the table header shows more information about the columns in a tooltip.

Ident: ICAO ident of the navaid or airport. The ident can be
suffixed as shown below:

+ or - and a distance value: Shows fixes in procedures
that are relative to a navaid or

waypoint plus the distance in NM to the waypoint.

(IAF): Initial fix of a procedure or transition.

(FAF): Final approach fix. Depending on procedure either the
FAF or FACF are shown with

a Maltese cross on the map and in the
elevation profile.

(FACF): Final approach course fix.

(MAP): Missed approach point.

Region: Two letter region code of a navaid.

Name: Name of airport or radio navaid if available.



Procedure: Either SID, SID Transition, STAR,
STAR Transition, Transition, Approach or Missed plus
the name

of the procedure. Contains the text Alternate for
alternate airports at the end of the list or

Departure or Destination.

Airway or Procedure: Contains the airway name for en-route legs
or procedure instructions. This

field also shows track names if NAT, PACOTS or AUSOTS tracks are used.
Airways are suffixed

with the airway type like N601 / V:

V Victor or low altitude airway

J Jet or high altitude airway

B Both

Restriction:

For airways:

Example 10,000: Minimum altitude for airway segment.

Example 0-20,000: Maximum airway altitude. Minimum does not apply.

Example 10,000-20,000: Minimum and maximum airway altitude.

For procedures: Altitude restriction or speed limit. A /
separates altitude and speed

restriction. The following altitude
restrictions exist for procedures:

Number only: Fly at altitude or speed. Example: 5,400 or 210.

Prefix A: Fly at or above altitude or speed. Example: A 1,800.

Prefix B: Fly at or below altitude or speed. Example: B 10,000 or B 220.

Range: Fly at or above altitude one and at or below altitude two. Example: A

8,000, B 10,000.

Altitude and speed limit: Values separated by /. Example: A 8,000, B 10,000/B220.

Speed limit only: Speed restriction. Example: B 250.

Required vertical path angle: Example: -3.1°.

Type: Type of a radio navaid. Shows ILS or LOC for ILS or
localizer approaches on the last runway

leg.

Freq.: Frequency or channel of a radio navaid. Also shows ILS or
localizer frequency for

corresponding approaches on the last runway
leg.

Range: Range of a radio navaid if available.

Course °M: This is the start course of the great circle
route connecting the two waypoints of the

leg. Use this course at
departure if you travel long distances without navaids. Be aware that
you

have to change you course constantly when traveling along a great
circle line. See also Magnetic

Declination for more information.

Course °T: The same as the field
above but using true course. Use this in areas with high

magnetic
declination.

Distance: Distance of the flight plan leg.

Remaining: Remaining distance to destination airport or procedure
end point (usually the runway).

Leg Time: Flying time for this leg. Calculated based on the
selected aircraft performance profile

(see Aircraft Performance). This is a static value and not
updated while flying. Empty if

performance calculation failed.

ETA: Estimated time of arrival. This is a static value and not
updated while flying. Calculated

based on the selected aircraft
performance profile. Empty if performance calculation failed.

Fuel Rem.: Fuel remaining at waypoint, once for volume and once
for weight. This is a static value

and not updated while flying.
Calculated based on the selected aircraft performance profile.

Empty
if aircraft performance profile has no fuel consumption numbers set.

Wind: Magnetic wind direction and speed at the waypoint.

Head- or Tailwind: Wind at waypoint. Headwind is indicated by arrow down ▼ and tailwind by an up

arrow ▲.

Altitude: Calculated altitude at waypoint. Uses aircraft performance to determine altitude.

Leg Safe Alt.: Leg safe altitude. Same as in Elevation Profile.

Latitude and Longitude: Coordinates in selected format from options on page Units.

Related Ident/Freq./Dist./Bearing: Related navaid needed for procedures. Shows ident, frequency,

distance and bearing as radial.

Remarks: Turn instructions, flyover or related navaid for procedure legs.
Also shows user remarks

that can be edited with Edit Flight Plan Position or Edit Flight Plan Position Remarks.
See Map

Flight Plan Editing for more information.



The Flight Planning dock window. The flight
plan uses a SID for departure and a STAR, a transition and an approach for

arrival. Click image to enlarge.

Note

The flight plan table is static and does not update except when changing wind or aircraft

performance.
Look at the tab Tab Progress to see current information.

30.4. Selected Flight Plan Legs Footer

This footer line shows information about the selected flight plan legs.

1. Number of selected legs.

2. From and to waypoint.

3. Distance between the two waypoints.

4. Flight time based on currect aircraft performance configuration file.

5. Fuel required in weight and volume units.

Selected legs and information about the selected.

30.5. Error Messages Footer

If a waypoint of a flight plan cannot be found in the database it will
be shown in red color. This can

happen if the used AIRAC cycles do no
match or old flight plan are loaded. The same applies to

airways. The position on the map is still
correct.

Airways are also displayed in red if the minimum altitude, maximum
altitude or one-way restrictions

are violated.

Hover the mouse over a field in the table to see a tooltip giving more
information about the error.



You can also click on the red error message to see all errors found in the flight plan.

See also Warning and Error Messages.

Warning

Note that flight plans with errors are still usable in Little Navmap although
saving and exporting to

other formats is limited and can lead to
unexpected results.

The Flight Planning with three different tooltips showing errors.



Tooltip on error message showing violations of altitude restrictions.

30.6. Mouse Clicks

A double-click on an entry in the table view shows either the airport
diagram or zooms to the navaid.

Additionally, details are shown in the
Information dock window as well. A single click selects an object

and
highlights it on the map using a black/green circle.

30.7. Top Buttons and Input Fields

30.7.1. Cruise altitude

This value is saved with the flight plan.

Changing this field updates the cruise altitude in the window Flight Plan Calculation.

Changing the cruise altitude of a flight plan using airways might result in errors (Error Messages

Footer).
This can happen if the cruise altitude violates airway altitude restrictions.
Calculate the flight

plan again to remove the errors.

Setting a too low cruise altitude might also violate procedure restrictions. See Altitude and Speed

Restrictions.

Note

Note that Little Navmap does not support step climb or different altitudes for each waypoint.

30.7.2. Flight Plan Type

Either IFR or VFR.

This is saved with the flight plan and is only relevant for FSX, Prepar3D or MSFS.

Note

Note that the VFR/IFR selection affects flight plan loading in MSFS. You cannot load a VFR flight plan

in MSFS which uses procedures, for example.

30.7.3.  Clear Selection

Deselect all entries in the table and remove any highlight circles from
the map.

30.7.4.  Flight Plan Table Display Options

See chapter Flight Plan Table Display Options below.

30.8. Context Menu Flight Plan

30.8.1.  Show Information

Same as Show Information in the map context menu.

30.8.2.  Show on Map

Show either the airport diagram or zooms to the navaid on the map. The
zoom distance can be

changed in the dialog Options on the tab
Map Navigation.



30.8.3.  Set Departure Runway

Same as Set Departure Runway in the map context menu.

30.8.4.  Set Destination Runway

Same as Set Destination Runway in the map context menu.

30.8.5.  Show Procedures

Same as Show Procedures in the map context menu. Only
enabled for airports having procedures.

30.8.6.  Activate Flight Plan Leg

Makes the selected leg the active (magenta) flight plan leg. The active
leg might change if Little

Navmap is connected to the simulator and
the user aircraft is moving.

You have to activate the leg manually if you would like to fly to an alternate airport.

Legs of a missed approach procedure are activated automatically if the procedure is shown on the map.

30.8.6.1.   Undo and Redo Flight Plan

Allows undo and redo of all flight plan changes. The last action is shown in the menu item like Add

Waypoint, for example.
Also in main menu Flight Plan -> Undo and Redo.

30.8.7.   Move Selected Legs up or down

Move all selected flight plan legs up or down in the list. This works
also if multiple legs are selected.

Airway names will be removed when waypoints in the flight plan are moved
or deleted because the new

flight plan legs will not follow any airway
but rather use direct connections.

Procedures or procedure legs cannot be moved and waypoints cannot be
moved into or across

procedures.

30.8.8.  Delete Selected Legs or Procedure

Delete all selected flight plan legs. Use Undo if you deleted legs
accidentally.

The whole procedure is deleted if the selected flight plan leg is a part
of a procedure. Deleting a

procedure deletes its transition too.

30.8.9.  Edit Flight Plan Position or Edit Flight Plan Position Remarks

Allows to change the name or coordinates of an user defined waypoint in
the flight plan. See Edit Flight

Plan Position.

Also allows to add a remark to any flight plan waypoint which is not an alternate and not a part of
a

procedure. See Edit Flight Plan Remarks.



30.8.10.  Insert Flight Plan before

Inserts a flight plan before the selected leg into the current plan.

Using Insert Flight Plan before or Append Flight Plan allows to
load or merge complete flight plans or flight

plan snippets into a new
plan.

Procedures are inserted from the loaded flight plan and dropped from the
current one depending on

insert position.

If you insert a flight plan after departure all procedures from the
loaded plan are used and current

procedures are kept.

Inserting before departure takes the departure procedures from the
loaded flight plan and drops the

current departure procedures.

The inserted legs are selected after loading the flight plan.

30.8.11.  Append Flight Plan

Adds departure, destination and all waypoints of another flight plan to
the end of the current plan.

All currently selected arrival procedures will be removed when appending
a flight plan. Arrival and

approach procedures from the appended flight
plan are added to the current one, if any.

The appended legs are selected after loading the flight plan.

30.8.12.  Save selected range as Flight Plan

Extracts a part of the current flight plan and saves a new flight plan file
which contains all legs between

the first and last selected including.

The currently loaded flight plan is not changed.

This menu item is disabled if the selected range contains legs which are alternates or part of a

procedure.

30.8.13.  Calculate Flight Plan for selected Range

Opens the flight plan calculation dock window which allows to automatically generate a flight plan
by

various criteria between the first and last selected flight plan leg.

This menu item is disabled if the selected range contains legs which are alternates or part of a

procedure.
See chapter Flight Plan Calculation for more information.

30.8.14.  Add Range Rings

Same as Context Menu Map.

30.8.15.  Add Navaid Range Ring

Show the range rings for all selected radio navaids in the flight plan.
Simply select all legs of the flight

plan and use this function to
display a range circle for each radio navaid in the flight plan.

Otherwise, the same as Context Menu Map.



30.8.16.  Add Airport Traffic Pattern

Same as Add Traffic Pattern.
This menu item is enabled if clicked on an airport. Shows a dialog that

allows to customize and display an airport traffic pattern on the map.
See Traffic Patterns.

30.8.17.  Add Holding

Same as Add Holding.
See also Holdings.

30.8.18.  Add MSA Diagram

Same as Add MSA Diagram. Only enabled if the navaid or airport have MSA information.
See also

Minimum Sector Altitude.

30.8.19.  Mark Airport as Add-on

Marks an airport with a yellow circle as add-on.
Same as Mark Airport as Add-on. Enabled for all

airports at the clicked position.

30.8.20. Follow Selection

The map view will be centered - not zoomed in - on the selected airport
or navaid when this function is

enabled.

30.8.21.  Copy

Copy the selected entries in CSV format to the clipboard. The CSV will
include a header. This will reflect

changes of the table view like
column order. Columns which are hidden or shrinked to minimum width

are excluded.

Import the CSV text into spreadsheed programs using UTF-8 encoding and a semicolon as a separator.

30.8.22. Select All

Select all flight plan legs.

30.8.23.  Clear Selection

Deselect all currently selected flight plan legs and remove any
highlight circles from the map.

30.8.24.  Reset View

Reset the column order, visibility and widths if the table back to default.

30.8.25.  Set Center for Distance Search

Same as Context Menu Map.

30.8.26.  Flight Plan Table Display Options

See chapter Flight Plan Table Display Options above.



30.9. Flight Plan Remarks

Adds a free text remark for the flight plan.

Shows the loaded performance file and selected scenery data when saving the flight plan file.

Note that this field saved is saved only when using the Little Navmap LNMPLN format (Little Navmap

LNMPLN Format).

See also Remarks.



31.  User Aircraft Centering

Little Navmap keeps the user aircraft visible while flying if the function Keep User Aircraft Centered ( 

 )
is enabled on the toolbar or in the menu.

The behavior of the map might look confusing for new users but the intention is to minimize

interactions with Little Navmap while flying.

The default is to keep the aircraft visible in the center part of the map window.
The map is centered on

the user aircraft once the aircraft leaves the center part of the map
screen. You can configure the size

of the center part in options. See Aircraft Centering Options.

A countdown timer starts (default is 10 seconds) if a user does interactions with the map like
zooming

or scrolling which allows to move the map away from the user aircraft.
The timer is restarted for each

manual map movement, zooming or other interactions.

Aircraft centering restarts once a user leaves the map window alone and the countdown is finished.

This means you can move around the map, look at airports or navaids and continue flying once done.

No need to go back the aircraft manually since Little Navmap automatically jumps back to the aircraft

after a while.

You can change the map behavior while flying on the Simulator Aircraft page in dialog
Options. See

Aircraft Centering Options for more information on the various settings.

Other related functions in the elevation profile context menu: Keep User Aircraft Centered and
Center

on Aircraft and Destination.

Aircraft centered inside the active brighter box. The aircraft is centered again once it leaves the box. This is the default

behavior.



32. Map Flight Plan Editing

The flight plan drag and drop editing mode is enabled by default. It can
be toggled using the toolbar or

Flight Plan ->
Edit Flight Plan on Map in the main menu.

You can use the keyboard, the mouse wheel or the map overlays to scroll
and zoom while editing the

route.

Note

The flight plan drag and drop editing is based on the
assumption that a direct connection between

departure and destination
already exists.

Always select departure and destination first if you would like to build
you flight plan manually. This will

connect both points with a great
circle line. Based on this line you can start to add navaids to your

flight plan.

Note that selecting airways is not possible.

The cursor will change into a cross  if a new navaid can
be added to a leg. A cursor  will be

shown if a present
navaid can be replaced by another one or if an user position can be
moved.

The following functionality is available:

Click on a flight plan leg: Starts editing and adds a new
waypoint depending on where the

next click is done:

On a single airport and navaid: Object is inserted into the
flight plan segment.

On multiple airports or navaids: A menu pops up that allows you
to select the object

to be inserted.

No airport and no navaid: An user defined position is inserted
into the flight plan.

Click on waypoint: Starts editing and replaces the selected
waypoint with an object depending

on where you click next:

On a single airport and navaid: Object replaces the selected
waypoint.

On multiple airports or navaids: A menu pops up that allows to
pick the object that

should replace the selected waypoint.

No airport and no navaid: An user defined position replaces the
waypoint.

Click on departure or destination: Replaces the departure or
destination with an object

depending on where you click next:

On a single airport: Airport replaces the departure or
destination.

On a navaid: Object replaces departure or destination which
results in an invalid flight

plan. The flight plan can be saved and
loaded (a warning will be shown) but is unusable

by the flight
simulator.

On multiple airports or navaids: A menu pops up that allows to
select the object that

replaces departure or destination.

No airport and no navaid: An user defined position replaces the
waypoint resulting in

an invalid flight plan.

Right-clicking, pressing the escape key or any click outside of the
map window: Cancel

current operation.

Limitations if procedures are used: You can not add navaids in or
between procedures, nor can you

delete procedure legs. The cursor will
not change shape when you hover over a procedure. The

following is not
allowed:

Add a waypoint between departure airport and SID.

Add a waypoint between STAR or approach and destination airport.

Add a waypoint between STAR and approach or transition.

Move or remove the first or last waypoint of a procedure.



All departure or destination procedures are removed if the departure or
destination airport is moved or

replaced. The same applies if waypoints
are prepended before or appended after departure or

destination.

Inserting a navaid into a flight plan leg by
clicking and moving the leg line. A tool tip for the navaid is shown.

Replacing VOR TRA in the flight plan with another
one by simply clicking and moving the waypoint TRA onto KLO. A selection

menu pops up for disambiguation.



33. Procedures

33.1. General

Departure and arrival procedures will typically be used when flying an
airliner, but smaller aircraft, too,

have to use at least an approach
procedure at their destination when flying IFR.

An airline flight containing all variations can use the following
procedures or segments:

1. Departure airport

2. SID

3. SID Transition

4. en-route airway system

5. STAR transition

6. STAR

7. Transition to approach

8. Approach

9. Destination

A small aircraft IFR flight can use the following procedures or
segments:

1. Departure airport

2. en-route airway system

3. Transition to approach

4. Approach

5. Destination

Note that transitions make only sense together with an approach, a SID
or a STAR which will guide you

to or from the runway. You can select a
transition only together with the respective procedure

(although the SID
may be empty and consist only of a transition). If you delete a
procedure from the

flight plan, its transition will be deleted too.

Procedure information is saved together with a flight plan as an
annotation in a LNMPLN file and will be

restored by Little Navmap when
loading the flight plan. Note that some export flight plan formats do

not support saving of procedures.

Procedure waypoints are excluded from all flight plan formats by
default. You have to use the GPS or

FMS in the simulator to select
procedures.

Some flightplan formats like X-Plane FMS allow saving and loading of procedures. See X-Plane FMS 11

and X-Plane 12. for more information.
Transitions cannot be saved with the MSFS PLN format (see

Microsoft Flight Simulator 2020).

You can enable saving of waypoints by checking Export Waypoints for Approaches and/or
Export

Waypoints for SID and STAR. Procedure information will be omitted if this is enabled.
Note that these

functions are normally not needed and can have side effects.

Note

It is not possible to assign an approach or STAR to an alternate
airport. Create a new flight plan for

the alternate trip if you wish to
do so.

Note

FSX and Prepar3D stock
data provides only approaches and transitions. SIDs and STARs are not

available. These can be added by navdata updates.



33.2.   Set Departure Runway and Set Destination Runway

A departure and destination runway can be selected instead of an procedure.

Selecting a destination runway adds a final approach leg (runway centerline extension) which can be

customized by changing altitude, length and offset angle. This allows Little
Navmap to give vertical

guidance and to show ILS and/or VASI slopes at
the destination.

Selecting a departure runway adds a departure flight plan leg depicting the extended runway center

line.

See more about this in chapter Departure and Destination Runway.

33.3. Inserting a Procedure into a Flight Plan

Right-click on an airport in the map, the airport search table, or the
flight plan table, and select Show

Procedures (or
Show Departure Procedures or Show Arrival Procedures depending on airport) from the
respective

context menu. This will show the tab Search Procedures in the dock window
Search.

Insert a procedure into the flight plan using the context menu in the
procedure tree view.
Right click on

a procedure, a procedure leg or a transition and select
Use airport and procedure as Departure, Use airport

and procedure as Destiation or
Insert Procedure into Flight Plan (substitute procedure and airport with the

actual names).

You can also add a procedure from the map if using Leg Highlights on the Map or Preview all

Procedures.
Right click on any waypoint of a procedure (not the leg line) and select Use airport and

procedure as Departure,
Use airport and procedure as Destiation or Insert Procedure into Flight Plan.

Important

Little Navmap removes waypoints from the flight plan which overlap with the procedure.

In any case check the flight plan for reversals or zig-zag guidance.
Delete waypoints manually if you

find such cases.

33.4. Deleting a Procedure from a Flight Plan

Deleting a single leg from the flight plan table which is part of a procedure will remove the whole

procedure and its transition. Deleting a leg being part of a
transition will remove only the transition.

You can also delete procedures from the flight plan by right clicking onto a procedure waypoint on the

map.
Select Delete procedure from flight plan. Substitute procedure the actual name.



About to remove the transition MUN of the
approach RNAV BEGEN from the flight plan. Click image to enlarge.

33.5. Limitations when editing a flight plan with procedures

Deleting a leg of a procedure will remove the whole procedure from
the flight plan.

You cannot move a procedure leg up or down neither can you move or
add a flight plan leg into

a procedure.

You cannot add waypoints in between procedures (e.g. between a STAR
and an approach).

Waypoints can only be added to the route between
departure and arrival procedures.

You cannot add waypoints between departure airport and a SID
procedure.

You cannot add waypoints between arrival procedure and destination
airport.

If you delete or replace the departure airport all SID procedures are
removed too.

If you delete or replace the destination airport all approach and
arrival procedures are removed

too.

33.6. Flying Procedures

Procedure legs are pre-calculated, with the exception of holds,
turns and altitude dependent legs. This

means you can fly them mostly as they are drawn on
the map. If in doubt about how to fly a leg (e.g.

if too many lines are
overlapping) look at the procedure table in the Flight Plan Table.

33.6.1. Holds

No entry or exit procedure is shown. You have to find a proper entry
procedure yourself. Holds have a

straight leg flying time in minutes or
a distance.

If a time is given, fly the hold as usual:

1. Enter at the fix using a proper entry procedure

2. Do a standard turn

3. Fly the straight leg for the given time (typically one minute)

4. Do standard turn

5. Fly to fix

6. Exit hold when done or instructed by ATC

Note

Do not follow the lines exactly, they are just an indicator for what to
fly. An exception are holds

where a distance is given for the straight
leg. The hold size will match the distance in this case.



Note that procedure holds are part of the flight plan and differ from
the user defined holdings (

Holdings) which are simply map
display objects.

A hold with 2 NM straight segment
length. Enter and exit at ZUNAD and fly at or above 2,600 ft.
Course is 61° magnetic

degrees.

33.6.2. Exiting a Hold

Little Navmap will detect when a hold is exited and advance the active
leg to the next one if one of the

two conditions is met:

1. If the next leg continues after or at the hold fix: When
approaching the hold fix after one

circuit continue straight on. The
next leg will be activated after half a NM up to one NM.

2. If the next leg starts before the hold fix: Exit the hold at its
fix. Exit right turn holds to the

left and vice versa (i.e. turn
outside the hold). Proceed to the fix of the next leg which will be

activated.

You can activate the next leg manually if you do not exit the hold at
its fix. Right-click in the flight plan

table on the next leg and select
Activate Flight Plan Leg.

33.6.3. Procedure turns

The flight simulator data moves the turn point of a procedure turn 10
NM out from the fix which is

usually too far away.

Fly the procedure turn as usual: Minimum one minute from the fix. Use
more if you need space to

catch the next fix after the course reversal.
Then turn using an teardrop or a standard 45/180 degree

turn. Again:
Follow the procedures, not the lines.

A procedure turn. Fly at least one minute outbound
61° from ABERN, turn left to 16°, fly one minute, turn 180° and fly
to

LAMMB, then 242° to ABERN.

33.6.4. Distances

All procedure legs, with the exception of holds and procedure turns, are
included when calculating flight

distance. This means the total flight
plan distance as well as the top of descent point will change when

selecting an approach or a transition.



33.7. Special Leg Types

All procedure leg types (Track to Fix, Initial Fix and more)
that are shown in Little Navmap are based

on the ARINC 424 path
terminator concept. A deeper knowledge of these leg types is not
important for

the simulator pilot.

Four additional types are used by Little Navmap:

Start of Procedure: This leg is added if a procedure does not
start with an initial fix but rather with

a course, heading or track
to a fix. It indicates the first position of the procedure.

Proceed to Runway in a SID: The first leg of a SID to indicate
the start position on the runway. The

program might fall back to the
airport center if the runway is not available. The altitude

restriction indicates the elevation of the runway.

Straight In: Added to an approach procedure to show the course
from the missed approach point

(MAP) to the runway threshold. It is
added when an approach ends with a runway fix. The leg

has an
altitude restriction 50 ft above the threshold.

Circle to Land: Added to an approach procedure to show the course
from the missed approach

point to the airport. It is added if an
approach does not end with a runway fix.

Vectors: Vectors connect legs that are manually terminated by ATC
with their successors which is

often an initial fix.

Straight In example: ENSH approach LOC FL01 (L01) to runway 01.
White/orange dotted line is the straight-in leg. ML01 is

the MAP. If runway is not visible at
ML01 turn left to missed.



Circle to Land in example: LSZC RNAV-A KUSIX (RNVA). White/orange dotted line is the
circle-to-land leg. ZC701 is the

MAP. No guidance is given for this leg. You have to navigate
around the mountain to get to runways 06 or 24.

33.8. Fix Types in a Procedure

Waypoints: Terminal waypoints or radio navaids. Some are marked
as flyover in the approach

table.

Radial and distance: Example: WIK/7nm/291°M. A fix defined by
a course or heading and distance

to a navaid.

Distance to DME: Example: WIK/9nm. This fix is defined by a
heading or track which is

terminated by reaching a DME distance.

Intercept Course to Fix: Intercept a course to the next fix at an
angle of about 45 degrees.

Course/Heading to radial termination: Example: LPD/135°M.
Turn left or right to intercept a radio

navaid radial.

Intercept Leg: Intercept the next approach leg at a course of
about 45 degrees.

Altitude: A leg or hold that is terminated by reaching a certain
altitude and is used mostly on

missed approaches. Since the distance
depends on the aircraft, 2 NM length are used for this

leg. You can ignore the line and proceed to the next leg once the
altitude criteria is satisfied.

Manual: Fly a heading, track or a hold until manually terminated
by ATC.

Runway fixes are prefixed with RW. They usually have an altitude
restriction a few ft above the runway.

Higher altitude restrictions
(i.e. > 500 ft) indicate a circling approach.

33.9. Altitude and Speed Restrictions

Restrictions are shown on the map and in the flight plan table.

Number only: Fly at altitude or speed. Map examples: 5400ft
or 210kts.

Prefix A: Fly at or above altitude or speed. Map example:
A1800ft or A200kts.

Prefix B: Fly at or below altitude or speed. Map example:
B10000ft or B240kts.

Range: Fly at or above the first altitude and at or below the
second altitude. Map example:

A8000B10000ft. Same for speed.



Prefix GS: Not an altitude restriction but an indicator for
the ILS glideslope altitude. Can mean at

or at or above.

Vertical path -3.2°: A vertial path angle which has to be followed. Calculated paths
are shown

with a white text background and required paths with a yellow backgroud.

33.10. Related Navaids

Many fixes have a related or recommended navaid. This can be a VOR, NDB,
ILS or a waypoint. The

related navaid comes with radial and distance
values that can be used to locate waypoints when flying

without GPS or
simply for cross checking the position.

Related navaids for procedures are forced with the flight plan display. All navaids needed for

procedures are still shown if you disable the display of VOR, NDB and waypoints. This helps to keep
an

uncluttered map display.

33.11. Missed Approaches

Missed approach legs are activated once the simulator aircraft passes
the last point of an approach and

the missed approach is shown on the map.
The display of remaining flight plan distance will switch to

display of remaining distance to last
missed approach leg.

33.12. Leg Highlights on the Map

Up to three points will be highlighted when clicking on a procedure leg
in the tree in the search

window:

A small blue circle shows the beginning of the leg.

The end of the leg is shown by a large blue circle.

A thin circle shows the location of the recommended or related fix if
available.

33.13. Invalid Data

A leg entry will drawn red if a navaid was not resolved during the
scenery database loading process.

This happens only when the source data
is not valid or incomplete. In this case, the resulting procedure

is not
usable and a warning dialog will be shown if essential navaids are
missing.

Little Navmap might refuse to use the procedure depending on error.



34. Departure and Destination Runway

A departure or destination runway can be selected instead of a SID or an approach procedure.
This can

be used on small airstrips as well.

The inserted departure or arrival legs (runway center line extensions) can be used similar to

procedures. Deleting a leg removes the whole departure or arrival, for example.

34.1. Limitations

The departure and arrival runways as well as the related waypoints are exported as
custom waypoints

(or coordinates) in some flight plan formats like MSFS PLN, X-Plane FMS and others.

Note

The custom waypoints are omitted for all formats related to complex aircraft having an FMS or MCDU

to avoid issues on import.
You have to select the departure and approach manually in the aircraft,

therefore.

If you see problems, delete the departure or/and approach, export the flight plan and undo your

change in the flight plan again.

34.2. Departure Runway

Set this by using Select Departure Runway. Set Departure Runway or from the context menu of the

airport search tab.

Selecting a departure runway adds a extended runway center line. The
length of the runway extension

can be changed when adding the departure runway.

The departure guidance is a part of the flight plan similar to a procedure.

The departure runway is saved in the LNMPLN flight plan file. User defined waypoints are used for the

runway threshold and end of extended runway center line when exporting a departure runway to
other

flight plan formats than LNMPLN.

The extended runway center line consists of two waypoints which also
indicate the runway name:

RW01+3: The start of the final leg. Distance after + given in NM.

RW01: The runway threshold for runway 01 here.

Runway selection dialog:

Dialog header: Shows the airport name and its ICAO ident as well as field elevation.

Runways: List of available runways for the airport. Shows runway
name, length, width, magnetic

heading, surface, lighting status and other attributes.

Length of the extended runway center line: Distance from the runway threshold to the end of the

departure leg. Default is 3 NM.

A click on the OK button or a double click into the list Runways
closes the dialog and creates the approach.



Dialog shown after right clicking the departure airport of a flight plan and
selecting Select Departure Runway on airport 01.

Vertical guidance from runway threshold extended center line.

34.3. Destination Runway

Set this by using Select Destination Runway, Set Destination Runway or from the context menu of the

airport search tab.

Selecting a destination runway consists of a final leg for the approach which can be
customized by

changing altitude, length and offset angle. This enables vertical
guidance in the elevation profile and

allows to the VASI slope at the destination.

The approach guidance is a part of the flight plan similar to a procedure
unlike Traffic Patterns which is

only a map display feature.

This type of approach can be removed like other procedures by deleting
one of the legs in the flight

plan table or from the map context menu ( Delete from Flight Plan).

The destination runway is saved in the LNMPLN flight plan file. User defined waypoints are used for the

start of the final leg and the runway threshold when exporting a destination runway to
other flight plan

formats than LNMPLN.

The approach guidance for a selected destination runway consists of two waypoints which also
indicate

the runway name:

RW12+3: The start of the final leg. Distance after + given in NM. The altitude is fixed and

considered when calculating the elevation profile.

RW12: The runway threshold for runway 12 here.

Runway selection dialog:

Dialog header: Shows airport name and its ICAO ident as well as field elevation.

Runways: List of available runways for the airport. Shows runway
name, length, width, magnetic

heading, surface, lighting status and other attributes.
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Start of final to runway threshold: Distance from the initial fix
to the runway. Default is 3 NM.

Offset angle relative to the runway heading: Defines an offset angle to approach the runway.
This

rotates the final leg clockwise for positive values and counter-clockwise for negative angles.

Final course to runway: Shows the magnetic course of the final leg based on the offset angle.

Altitude above runway at start of final: Altitude at the start of the final leg above
runway

elevation. Default is 1,000 ft.

Approach slope: Shows the slope angle calculated from the given
distance and altitude. The default

values for distance and altitude
give a 3.1 degree slope.

Destination runway dialog window and depiction on map and in elevation profile.
Using 4.5° slope to match VASI and offset

approach to avoid mountains.
Vertical guidance to runway threshold. Note that ILS and other approach aids are not shown

for the VFR approach.
Click image to enlarge.



35.  Select Start Position

A parking spot (gate, ramp, fuel box), airport center, runway or helipad can be
selected as a start

position at the departure airport. A parking
position can also be selected in the map context menu item

Set as Departure
when right-clicking on the center of a parking position. If no position is selected
the

airport center is automatically selected as start.

The start position is highlighted on the map and saved with flight plans. Note that only a
few flight plan

formats allow to load the position and place the aircraft at the ramp. For X-Plane
you have to select the

start position manually before loading the situation. See Flight Plan Formats for details.

Note that the start position might be lost when switching between scenery library databases since

positions often do not match between simulators.

The start position selection dialog has a search field which allows to filter the entries by name,
type,

airline codes or facilities.

The start position selection dialog for EDDN.



36. Runway Selection

This dialog shows up after selecting a SID or STAR applicable for parallel runways or all runways.

Parallel runways are indicated in the Procedure Tree by a list of runways like STAR  07L, 07R, 07C.
The

suffix All is added if a procedure applies to all runways of an airport.

The dialog header shows airport name and its ICAO ident as well as field elevation.

The list Runways shows available runways for the SID or the STAR. Columns are runway
name, length,

width, magnetic heading, surface, lighting status and other attributes.

Note

Note that the shown runway numbers might differ compared to procedure runways.
This happens

when an add-on airport and the navigation data have different runway numbers because the

runways have been renumbered due to changes in magnetic declination (magnetic pole drift).
Little

Navmap resolves these mismatches internally and still allows to work with procedures.
You might

expect issues when loading flight plans containing such discrepancies into add-on aircraft or

simulators.

Runway selection dialog after choosing the STAR UNOK3D which applies to the three parallel runways 07R, 07C, and 07L.



37.  Tracks

Tracks are a structured set of flight routes that stretch across the Atlantic, Pacific or Australia.

Little Navmap can download, display and use the following tracks:

NAT [https://en.wikipedia.org/wiki/North_Atlantic_Tracks]: North Atlantic Tracks

PACOTS [https://en.wikipedia.org/wiki/Pacific_Organized_Track_System]: Pacific Organized Track System

AUSOTS [https://www.airservicesaustralia.com/ausots/ausotstoday.asp]: Australian Organised Track Structure

Note that AUSOTS tracks are currently not available. It is unknown if they will reappear.

Image showing all track related functions in Little Navmap. Click image to enlarge.

37.1. Download

Tracks are not downloaded periodically since changes in the track system can break flight plans.
You

can choose to download tracks on startup or download them manually.

Download on startup and immediate can be enabled in the menu Flight Plan -> Download Tracks on

Startup.
Manual download can be started in the menu Flight Plan -> Download Tracks.

You can select the track systems to download in the sub-menu Track Sources in the menu Flight Plan.

The download will start again after changing sources.

The track database is cleared on startup if Download Tracks on Startup is not selected.

37.2. Map Display and Information

Tracks are mostly used like airways. They respond to mouse click, tooltip and can be highlighted
from

the information window on tab Navaids.

Tracks can be enabled for map display in the toolbar or menu View using  Show Tracks.

PACOTS and NAT tracks are shown in dark red color if eastbound and in dark blue color if westbound.

This does not apply to AUSOTS tracks.

https://en.wikipedia.org/wiki/North_Atlantic_Tracks
https://en.wikipedia.org/wiki/Pacific_Organized_Track_System
https://www.airservicesaustralia.com/ausots/ausotstoday.asp


Westbound PACOTS tracks are shown red and eastbound tracks in blue on the map.
Track 8 is highlighted and shown in

information window. This track is valid for the current time.

NAT tracks A and Z. Information for track A shows flight levels 350, 370 and 390.

37.3. Flight Plan Calculation and Editing

You have to check Use NAT, PACOTS or AUSOTS tracks in the flight plan calculation window to use

tracks.
The track will be used by Little Navmap if the settings allow this and the track is between

departure and destination.

See Flight Plan Calculation for more information.

Little Navmap will not keep you from creating invalid routes where you leave a track early or
switch to

a track. Valid flight plans can only be ensured by using the flight plan calculation.

Note

You have to use the correct cruise flight altitude in your flight plan.
This has to match the track levels

shown in the information window. Otherwise, the track will not be used.

37.4. Export

Track information is saved for flight plans in Little Navmap’s LNMPLN format (Little Navmap LNMPLN

Format).

It can happen that Little Navmap shows errors when a plan is reloaded later with different or
missing

tracks. Calculate the flight plan again to use the changed tracks.

All other exported flight plan formats for simulators, aircraft and tools will not receive track
information

but only a list of waypoints extracted from the track. This should allow to load the
flight plans into all



add-ons without issues.



38. Edit Flight Plan Position

This dialog allows to edit an user defined flight plan position that was
added with  Add Position to

Flight Plan or  Append Position to Flight Plan.

The information entered here is saved with the flight plan.

Note that all fields are saved without limitations only when using the Little Navmap LNMPLN format

(Little Navmap LNMPLN Format).
Other flight plan export formats will only save the ident truncated or a

coordinate.

Note

Keep in mind that all information entered here is lost if the flight plan position is removed or a
new

flight plan is calculated ( Flight Plan Calculation).

Note

Waypoints using the default format WP plus number (e.g. WP1 or WP99) are automatically
renumbered

by Little Navmap to reflect the flying order in the flight plan.

Changing the name will disable the renumbering for a waypoint.

38.1. Ident

Ident which is shown on the map, in the flight plan table and in exported flight plan formats, if

supported.

It is recommended to use a short identifier without special characters.
Otherwise free text field.

38.2. Region

Recommended to use the two-letter code for ICAO region, like EN for Norway or LI for Italy, if known.

The region is shown in map tooltip and flight plan table tooltip.

Otherwise free text field.

38.3. Name

Free text field.
Shown in map tooltip and flight plan table tooltip.

38.4. Remarks

Free multi line text field. Shown in abbreviated form in the Flight Plan Table Remarks
column and the

column’s tooltip as well as in the map tooltip.

See Remarks for more information.

38.5. Latitude and Longitude

You can also edit the coordinates directly in this dialog besides using
the drag and drop method Map

Flight Plan Editing. This can
be useful if you’d like to add waypoints with well known coordinates
like

visual reporting points.

The tooltip of the coordinate input field shows the available formats.
Hover the mouse over the input

field to see the tooltip.



See Coordinate Formats for more information.

Editing an user defined flight plan position. Also showing abbreviated tooltip in flight plan table.



39. Edit Flight Plan Remarks

This dialog allows to add a remark to any flight plan waypoint which is not an alternate and not a
part

of a procedure.

The information entered here is saved with the flight plan in the Little Navmap LNMPLN format (Little

Navmap LNMPLN Format).

Note

Keep in mind that all information entered here is lost if the flight plan position is removed or a
new

flight plan is calculated ( Flight Plan Calculation).

39.1. Header

The dialog header shows the navaid type, name and region.

39.2. Remarks

Free multi line text field. Shown in abbreviated form in the Flight Plan Table Remarks
column and the

column’s tooltip as well as in the map tooltip.

See Remarks for more information.

Editing remarks for a flight plan waypoint. Also showing abbreviated tooltip in flight plan table.



40.  Flight Plan Calculation

The route calculation is done in a window which is opened from
menus -> Flight Plan -> Flight Plan

Calculation.

The window can be put behind the Little Navmap main window. Click the toolbar button
  again to

bring it into front.

The window can be used to calculate the following:

Whole flight plans from start to destination.

Routes between selected waypoints in the flight plan table.

You have to build the route again by pressing the button Calculate after changing any parameters.

Important

Although this happens rarely: Always check the flight plan for reversals or zig-zag guidance,

especially when using procedures.
Delete waypoints manually if you find such cases.

Flight Plan calculation floating window. Flight plan is valid for calculation.

40.1. Window Header

Shows departure and destination as well as the direct Great Circle distance and the flight plan distance.

An error message is shown if the plan cannot be calculated.
Click on the tooltip or hover the mouse

cursor above to see more details.



Error message with tooltip showing details.

40.2. Calculate from departure to destination

Calculates a flight plan between departure and destination.

The dialog header will show a red error message if the flight plan is not valid for calculation.
Hover the

mouse cursor over the message or click it for details.

Procedures are not affected by this calculation method. The route will be built from SID exit to
STAR or

approach entry, if present.

The selected cruise altitude will be used to find airways with suitable restrictions.

40.3. Calculate for selection in flight plan table

This button is only valid when more than one flight plan leg is selected
and neither the first nor the last

selected leg is part of a procedure.

A selection is also valid for the last leg of a departure procedure or for the first leg of an arrival

procedure.

The dialog header will show an error message if the selected range is not valid for calculation.

You can either select the first and the last leg (Ctrl+Click) in the Flight Plan Table
or you can select a

whole range of legs (Shift+Click and drag) for route calculation.

The route will be calculated in a way that the first and last selected navaids are not modified.

The new calculated range will be selected in the table once calculation is done.

40.4. Cruise altitude for calculation

Sets the cruise altitude which will be used to select airways based on their lower and
upper altitude

limits when calculating the route.
Changing cruise altitude for calulation can result in shorter or better

airway routes.

The value will be assigned to the flight plan (Cruise altitude) after calculation.

This field is updated from the current flight plan when opening the window or changing the cruise

altitude in the field
Cruise altitude in the flight plan window.

Important

The calculation might fail if using too low or too high values for the cruise altitude. Make sure that

you use a
sufficiently high altitude which matches the selected airway type (Jet or Victor).

40.5. Adjust

Changes the flight plan altitude according to a simplified East/West
rule and the current route type (IFR

or VFR).

Same as Adjust Flight Plan Altitude.



40.6. Airways

Selects the airway calculation method and enables all fields to the right of this button.

This method uses airways and/or direct waypoint connections to build a route.
Which connection type is

selected depends on settings in Prefer.

Criteria for airway selection are always direction for one-way airways and altitude restrictions.

Note

Changing cruise altitude for calulation can result in shorter or better airway routes. Try to adjust this

if the result of the calculation is not satisfying.

You can also put the slider Prefer more to the right to ignore airways or use direct routing between

waypoints for regions void of suitable airways.

40.6.1. All Airways

Calculation will select any appropriate Jet or Victor airways for the route.

40.6.2. Jet airways (high altitude)

Limit calculation to Jet or high altitude airways. Calculation might fail if using a too low cruise altitude.

40.6.3. Victor airways (low altitude)

Limit calculation to Victor or low altitude airways. Calculation might fail if using a too high cruise

altitude.

40.6.4. Avoid RNAV airways

Check this for non-RNAV equipped aircraft. This will select only airways which can be followed by using

radio navaids like VOR or NDB.

Calculation might fail or give unexpected results if this is selected unintentionally.

40.6.5. Use NAT, PACOTS or AUSOTS tracks

The calculation will also consider tracks like NAT, PACOTS or AUSOTS, if selected. This button is

disabled if no tracks were downloaded.

See Tracks for more information.

Important

You have to use the correct cruise flight altitude in your flight plan.
This has to match the track levels

shown in the information window. Otherwise, tracks will not be used.

40.6.6.  Download Tracks

Downloads Oceanic or other tracks which are NAT, PACOTS and AUSOTS. Download tracks first before

using the option above.

Same as Download Tracks.

40.6.7. Prefer

This slider allows to adjust the preference of the calculation method between airways and direct

waypoint connections.



Putting the slider on the leftmost position

instructs the route calculation to use only airways. The
calculation might fail or give not optimal

routes if the region between departure and destination has
no airways or no appropriate airways

for the given cruise altitude.

This is the fastest calculation method which gives instant results.

A flight plan calculated using airways only.
The flight plan is longer since the region above Austria is void of airways

due to European airway restructuring.

Putting the slider on an intermediate position

uses more or fewer airways or direct waypoint connections depending on position.
Move the slider

step by step and calculate again if you’re not satisfied with the result.
Note that not every slider

movement will result in a changed route.

This calculation method is slower depending on the covered region. A progress dialog might pop

up which allows to cancel the process.



A flight plan calculated using airways and direct waypoints. The plan uses mostly airways and
skips the airway void

above Austria with direct waypoint connections.

Putting the slider on the rightmost position

instructs the route calculation to use only direct
waypoint connections. The calculation ensures

that the selected waypoints are not too close
together and have a distance of around 200 NM

where possible.
Cruise altitude is not relevant for calculation since no airways are used.

This calculation method is slower depending on the covered region. A progress dialog might pop

up which allows to cancel the process.

Note that waypoints are added to the flight plan using certain selection criteria.
Waypoints being

part of a SID or STAR and terminal waypoints will be excluded, for example.

Same plan as above but calculated with the slider on the far right.
The plan is shorter and uses direct waypoint

connections only.



40.7. Radio Navaids

Selects the radio navaid calculation method and enables the field to the right of this button.

Creates a flight plan that uses only VORDME, VORTAC, VOR and optionally NDB stations as waypoints.

This method tries to ensure reception of at least one station along the whole
flight plan.

Note that VOR stations are preferred before NDB stations. Calculation can fail if not
enough radio

navaids can be found between departure and destination.
Build the flight plan manually if this is the

case.

40.7.1. Use NDB

Use NDB stations too when selecting navaids for the route when checked. Otherwise, only VORDME,

VORTAC and VOR.

40.8. Direct

Deletes all intermediate waypoints and connects departure and
destination using a great circle line.

Does not delete procedures.

Same function as Calculate Direct.

40.9. Reverse

Swaps departure and destination and reverses order of all intermediate
waypoints. Deletes airway

references and procedures.

Same as Reverse Flight Plan.

40.10. Calculate

Calculates the route considering all the parameters given above.

Airway restrictions quite often do not allow optimal routes. You might have to change the cruise

altitude to get better results.

You might also have to change the slider Prefer to adjust for airway and direct waypoint connection

usage
if not satisfied with the result.

In any case check your flight plan before using it.
Remove wrongly selected waypoints near departure

and destination manually.

40.11. Close

Closes the window.

40.12.  Help

Opens this chapter in the browsers.



41. Flight Plan Route Description

This dialog allows you to create a flight plan from a route description string consisting of airport and

navaid idents
as generated or provided by various online services.

Click Load from Flight Plan to generate the route string from the currently loaded flight plan.
This will

append and read the string on the top of the list.

The top of the dialog holds the route description input field,
while the center half shows any messages,

warnings or errors that occur
during reading. The string is read automatically while entering it into the

input field.
The lower part provides a quick help.

41.1. Input Field

The upper input field is split into two sections. The top most can cover several lines and is is shown

using bold text. This is the active section which is read and the results are shown in the output.

The lower text can be seen as a kind of a notepad, is displayed in gray color and is ignored for reading.

The two sections are separated by an empty line. You can copy and paste lines between the two

sections using the context menu
or the keyboard shortcuts copy Ctrl+C, cut Ctrl+X and paste Ctrl+V.
All

texts are saved on exit.

41.2. Reading

Little Navmap tries to use as much of the route as possible
even if parts of the flight plan like

waypoints or airways cannot be
found or names are ambiguous. You will see warnings in the center

output field
if that is the case.

If a route covers a long distance and contains a waypoint name which is
not unique, a wrong waypoint

might be added to the flight plan. Correct
or remove this waypoint manually in the Flight Plan Table

using the Context Menu Flight Plan.

Many waypoints and airways will not be found if route descriptions from
the latest AIRAC sources are

used together with the old FSX, P3D or MSFS stock data.
It is recommended to use a navigation data

update for the stock
scenery or Little Navmap when reading route descriptions from online sources like

RouteFinder [http://rfinder.asalink.net/], Online Flight Planner [http://onlineflightplanner.org/],
SimBrief

[https://www.simbrief.com] or SkyVector [https://skyvector.com].

If a navdata update is not an option, pick the online service’s AIRAC
cycle that is closest to the cycle

the navigation data of your flight
simulator is based on.

Note that even flight plans calculated in Little Navmap cannot be
converted back exactly in some cases.

This happens due to navaid
ambiguities like NDB and VOR stations having the same names or errors in

the source data.

The cruise altitude is used to create the flight plan, if
given. Otherwise the cruise altitude is

automatically determined by the
flight plan type (IFR or VFR) and the minimum altitude of the used

airway segments.

The cruise speed is ignored when reading and produces a warning if found since it is taken from the

aircraft performance.
Generating a description from a present flight plan uses the cruise speed from

the loaded aircraft
performance file ( Aircraft Performance) and the cruise altitude as set in Cruise

altitude.

Note that you can modify the flight plan in parallel on the map or in the flight plan table. Move
the

Flight Plan Route Description aside to do so.
You have to transfer the plan to the dialog by clicking Load

from Flight Plan after doing changes in the background.
Click Create Flight Plan before doing changes on

the map or in the flight plan table.

http://rfinder.asalink.net/
http://onlineflightplanner.org/
https://www.simbrief.com/
https://skyvector.com/


A route description (1) (bold top section) that was read successfully with
a few warnings about ignored elements. The

waypoint INVALID could not be
found. Altitude, SID and STAR were recognized.
More inactive route descriptions are stored

below (2).

41.3. Buttons

Note that some buttons are now shown when opening this dialog from Open Flight Plan from SimBrief.

Undo  and Redo : Undo changes in the text input field. This does not affect the flight

plan table.

To Clipboard: Copy the current active description from the input field as plain text to the

clipboard.

From Clipboard: Insert text from clipboard into the top of the input field making it the active route

description.
The inserted text is converted to upper case and all invalid characters are removed

from the text before reading.

Load from Flight Plan: Create the route string from the current
flight plan and inserts it into the

top of the input field making it the active route description.
Use this after changing settings with

drop down
menu buttons or after modifying the flight plan on the map or in the flight plan table.

IFR or VFR: The flight plan type used when creating a plan. This setting will be taken over
into the

field Flight Plan Type in the tab Flight Plan when clicking one of the Create Flight Plan ... buttons.

Menu Button : Write denotes flight plan to
description and Read denotes description to flight

plan.
You can tear off the drop down menu from the button by clicking on the dashed line on top

of it.
Note that the menus starting with Write are now shown when opening this dialog from

Open Flight Plan from SimBrief.

Write departure and destination airport: Note that disabling
this option will result in an

invalid route description which cannot be read
back into a flight plan.

Write DCT (direct) instructions: Add DCT for any direct
waypoint connections in the flight

plan.

Write cruise speed and altitude instruction: Add cruise
altitude from flight plan and speed as

set in the aircraft performance.

Write waypoints instead of Airways: Does not include airway names in the string
but expands

it and inserts the waypoints names only.

Write Alternates: Appends all alternate airports to the end of
the description.

Write SID and STAR: Add SID and STAR names, if any are used for
departure or arrival.

Write generic SID and STAR: Add the generic SID and
STAR keywords if no real SID and/or

STAR were selected.

Write no SID and STAR: Do not include any SID and STAR information at all.



Write STAR and transition reversed: Write TRANS.STAR instead of STAR.TRANS if selected.

Write SID/STAR and transition space separated: Write SID TRANS and
STAR TRANS instead of

SID.TRANS and STAR.TRANS if selected.

Read trailing Airports as Alternates:

Enabled: A list of airports at the end of the description will
be read as alternate

airports except the first in the chain of
consecutive airports which will be used as

destination. Any
airport with a valid STAR in the chain will be treated as

destination too.

Disabled: Reading simply creates a flight plan with the
airports as intermediate

waypoints and the last one as
destination. See example below.

Read first and last item as navaid: Does not require airports as start and destination and

will
resolve the first and last item to navaids. Useful for reading snippets.

Read: Match coordinates to waypoints: Tries to matches coordinates to nearby waypoints.
EICK

5000N00760W EDDF will result in EICK GAPLI EDDF if this is enabled, for example.

Create Flight Plan and Close: Closes the dialog and creates a new flight
plan for the read route

description. Replaces the current flight plan. You can undo this change in the
Flight Plan Table.

Create Flight Plan: As above but keeps the dialog window open.

Tip

In any case you can use Undo and Redo to change the input field (right click context menu in the

input field)
as well as the flight plan table ( Undo and Redo).

41.4. Airport idents

ICAO, FAA, IATA and local codes are shown and the internal ident is avoided for display if possible.

Note that IATA codes are only read for departure and destination since they can be easily confused
with

navaids en-route.

X-Plane internal codes like XPA000B are recognized despite being avoided for display.

41.5. Format

The route description has to follow the format rules below:

FROM[ETD] [SPEEDALT] [SIDTRANS] [ENROUTE] [STARTRANS] TO[ETA] [ALTERNATES]

All elements in square brackets are optional.

FROM and TO: These are the required 3 or 4 letter idents for departure and destination airports.

Departure time ETD or arrival time ETA is ignored. Examples: KEAT, CYPU, S16.

ALTERNATES: Alternate airports are optional and are added to the flight plan when reading

depending on the option Read trailing Airports as Alternates as described above.

SPEEDALT: An optional entry that contains the cruise speed and altitude. See below for a details.

Speed is ignored when reading since it is part of the aircraft performance profile.

ENROUTE: This is a list of either WAYPOINT or an AIRWAYWAYPOINT forming the actual flight plan. The first

entry has to be an airport, waypoint, VOR or NDB.

WAYPOINT: A waypoint, VOR, NDB, airport or user defined coordinates. See below for a details

about coordinates. A waypoint can be prefixed with DCT to indicate a direct connection not using

an airway. Waypoints can be suffixed with an optional /SPEEDALT value although this is ignored.

Examples: TAU, BOMBI, AST, CL, EDDF.

AIRWAYWAYPOINT: Airway and end waypoint on the airway separated by a space. Examples: V495

CONDI, V338 YVR, V330 TRENA.

SIDTRANS: Either the word SID or real SID, STAR and transition names where the optional

transition is separated by a dot . or a space `` . The generic keyword ``SID creates a direct

connection to the en-route part. Examples: RDHK2.HOLLE, OHIO3 LFK, RDHK2, OHIO3.

SIDTRANS: Either the word SID or real SID and transition names where the optional transition is

separated by a dot . or a space `` . The generic keyword ``SID creates a direct connection to the

en-route part. Examples: RDHK2.HOLLE, OHIO3 LFK, RDHK2, OHIO3.



STARTRANS is either the word STAR or a read STAR and an optional transition which can be given as

STAR.TRANS, STAR TRANS, TRANS.STAR or TRANS STAR. The generic keyword STAR creates a direct

connection from the en-route part to the airport.

41.5.1. Features not supported

ETD and ETA: Four digit departure and arrival time attached to
the airport or waypoint ident are ignored.

WAYPOINT.SPEEDALT: For example BOMBI/N0090A060. Altitude changes
at waypoints are not supported and

ignored when reading.

Further extensions like runway and approaches are not supported.

41.5.2. Alternates

Example when reading Read trailing Airports as Alternates enabled:

KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT

KPWA ATOKA J25 FUZ J33 CRIED J50 LFK KHOU KCLL KVCT

KHOU is read as destination, KCLL and KVCT are alternates
for both examples.

Example when reading Read trailing Airports as Alternates disabled:

KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT

Not valid. Error message BAYYY3.SJI not found printed. KVCT is
read as destination, KHOU and KCLL are

intermediate waypoints.

KPWA ATOKA J25 FUZ J33 CRIED J50 LFK KHOU KCLL KVCT

KVCT is read as destination, KHOU and KCLL are intermediate
waypoints.

41.5.3. Speed and Altitude

Cruising ground speed and cruising level not separated by a space.

Speed is prefixed with:

K: Kilometers per hour followed by a four digit value.

N: Knots followed by a four digit value.

M: Mach followed by a three digit value. The mach value is converted to knots ground speed

assuming standard atmosphere conditions at the given flight altitude.

Altitude is prefixed with:

F :Flight level in three digits.

S: Metric flight level in three digits of tens of meters.

A: Altitude in hundreds of feet in three digits.

M: Altitude in tens of meter in four digits.

Examples:

N0410F310 410 knots at flight level 310.

M071F320 Mach 0.71 at flight level 320.

K0790M0710 790 kilometers per hour at 7,100 meters.

41.5.4. Coordinates

Coordinates can be supplied in different formats:



Degrees only (7 characters): Two digits and north/south indicator
plus three digits and east/west

indicator.

Example: 51N010E

Degrees and minutes (11 characters): Two digits degrees, two digits
for minutes and north/south

indicator. Then three digits for degrees,
two digits for minutes and east/west indicator.

Example: 4010N03822W.

Degrees, minutes and seconds (15 characters): Two digits degrees,
two digits for minutes, two

digits for seconds and north/south
indicator. Then three digits for degrees, two digits for minutes, two

digits for seconds and east/west indicator. This format is used by
SkyVector [https://skyvector.com] for

example.

Example: 481200N0112842E.

ARINC 424 Code Convention: All full degree waypoints either a part of the navigation database or

not.

Examples: 57N30 (N57 W130) or 5730S (S57 W030).

North Atlantic track points (NAT). Two digits degrees north and two
digits degrees west followed by

character N.

Example: 5010N.

Coordinate waypoint pairs with degrees and minutes as above and
prefixed with north/south and

east/west indicator.

Examples: N4200 W02000 or N4200/W02000.

Garmin GFP format (13 characters) north/south indicator, two digits
degrees, three digits for minutes

by 10. Then east/west indicator, three
digits degrees, three digits minutes by 10. This format is used

by the
Flight1 GTN 650/750.

Example: N48194W123096

41.6. Flight Plan Description Examples

Frankfurt Main (EDDF) to Fiumicino (LIRF):

Direct connection:

EDDF LIRF or EDDF DCT LIRF.

VOR to VOR:

EDDF FRD KPT BOA CMP LIRF.

Same as above with departure time ( ETD ) and arrival time
( ETA ) which both will be ignored:

EDDF1200 FRD KPT BOA CMP LIRF1300.

Same as above on flight level 310 at 410 knots:

EDDF N0410F310 DCT FRD DCT KPT DCT BOA DCT CMP DCT LIRF

Using Jet airways:

EDDF ASKIK T844 KOVAN UL608 TEDGO UL607 UTABA UM738 NATAG Y740 LORLO M738 AMTEL M727 TAQ LIRF

Same as above on flight level 310 at mach 0.71 with an additional
speed and altitude at NATAG

which will be ignored:

https://skyvector.com/


EDDF M071F310 SID ASKIK T844 KOVAN UL608 TEDGO UL607 UTABA UM738 NATAG/M069F350 Y740 LORLO M738 AMTEL M727 TAQ

STAR LIRF

User defined waypoints with degree/minute notation and an alternate
airport LIRE :

EDDF N0174F255 4732N00950E 4627N01019E 4450N01103E LIRF LIRE

Flight plan using SID and STAR procedures with transitions:

KPWA RDHK2.HOLLE ATOKA J25 FUZ J33 CRIED J50 LFK OHIO3.LFK KHOU

Flight plan using the generic SID and STAR keywords:

KPWA SID ATOKA J25 FUZ J33 CRIED J50 LFK STAR KHOU

Flight plan using SID and STAR procedures with transitions and two
alternate airports:

KPWA N0169F190 MUDDE3 ATOKA J25 FUZ J33 CRIED J50 LFK BAYYY3.SJI KHOU KCLL KVCT



42. Flight Plan Formats

Little Navmap supports several flight plan formats, all of which have
different limitations. All of the formats

listed below can be exported and some can be loaded using Open Flight Plan in the menu File.

42.1. Little Navmap LNMPLN Format

Little Navmap uses its own XML based text format since only this allows to save all features provided
by the

program in a safe manner as well as proper file validation. This also eliminates many of
the confusing

warning dialogs when saving other formats and potential data loss.

While you can still load, for example, FMS and other formats directly into the program, saving is
limited to

the LNMPLN format. You have to export the plan as FMS after changing it. You can do
that either directly

from the menu File -> Export Flight Plan as FMS for X-Plane 11 and 12 or using
menu File -> Multiexport

Flight Plan Options and then File -> Multiexport Flight Plan.

See also Flight Plan Multiexport for more information on multiexport.

Note

The LNMPLN format is only understood by Little Navmap.
Do not try to load it into simulators or add-ons.

Consider exported flight plan files as disposable since almost all export formats have limitations
resulting

in data loss. Remember that you can always restore them by loading the original LNMPLN
file and

exporting again.

See Little Navmap Flight Plan File Format for a detailed description of the format.

Warning

Always save a copy in the default LNMPLN format before exporting to other
formats. This allows Little

Navmap to restore all flight plan
properties like procedures, alternate airports and remarks.

Note that the LNMPLN format is only understood by Little Navmap.
Do not try to load it into simulators or

add-ons.

42.2. User Waypoint Names

User waypoint names will be adapted to format limitations when exporting.

PLN: Maximum length for FSX or Prepar3D is 10 characters and no
special characters are allowed.

Unsupported characters will be
removed and the length will be truncated.

FMS: No spaces allowed. These will be replaced with underscores
(_).

FLP: All user waypoint names will be replaced by coordinates.

42.3. Garmin Export Issues

Many Garmin add-on use the Garmin trainer in the background.

A problem when importing a flight plan containing procedures like SIDs, STARs, and approaches is that

procedure names change over time.

A SID WENAS7 becomes WENAS8, waypoints/intersections are removed, the airway structure changes or runways

are renamed, for example.

The Garmin trainer database is updated by Garmin once or twice a year but AIRAC cycles are updated more

often in Little Navmap as well as in simulators.
The result are inconsistencies between Little Navmap, flight

planning websites or other programs and the less frequently updated Garmin trainer database.

Garmin trainers abort if a waypoint or procedure has a name that does not match or is duplicated in its

database.



The Garmin trainer indicates a duplicate and offers the user the possibility to select from a list when

manually entering such a waypoint into the device.

The Garmin trainer import routine does not allow this. The import is either rejected or the flight plan is

locked and the user has to edit it manually.

42.4. Flight Plan Export Formats

The table below shows the capabilities of Little Navmap and the
supported flight plan formats (X = supported,

0 = not supported,
- = not applicable) as listed in Flight Plan Multiexport.

Ext.: File extension or name.

Open: Can load format using Open Flight Plan in menu File.

Exp.: Format can be exported.

Airw: Can export airways. Otherwise only a list of waypoints.

Proc. can export procedures.

Bold: Main format supporting all features like remarks but not usable for other tools or simulators`.

Highlighted format name: The format can be loaded by
Little Navmap using Open Flight Plan in menu

File.

Format

Name
Ext. Open Exp. Airw VFR/IFR

User

Wpt.

Names

Remarks
Dep.

Parking

Cruise

Alt.
Proc.

LNMPLN LNMPLN X X X X X X X X X

Microsoft

Flight

Simulator

2020

PLN X X X X X 0 X X
X

[[5]]

FSX and

Prepar3D
PLN X X X X X 0 X X 0

FSX and

Prepar3D

annotated

(obsolete)

PLN X X X X X 0 X X X

FS9 PLN PLN X 0 X X X 0 X X 0

X-Plane FMS

11
FMS X X X 0 X 0 0 X X

X-Plane FMS

12
FMS X X X 0 X 0 0 X X

X-Plane FMS

3
FMS X X 0 0 X 0 0 X 0

X-Plane

CIVA
FMS X X 0 0 0 0 0 0 0

FlightGear FGFP X X 0 0 0 0 0 0
X

[[2]]



Format

Name
Ext. Open Exp. Airw VFR/IFR

User

Wpt.

Names

Remarks
Dep.

Parking

Cruise

Alt.
Proc.

FSC PLN X 0 X 0 X 0 0 0 0

Aerosoft

Airbus and

others

FLP X X X 0 0 0 0 0 X

Aerosoft CRJ FLP X X X 0 0 0 0 0 X

Reality XP

GNS

530W/430W

V2

FPL X X 0 0 X 0 0 0 0

Reality XP

GTN

750/650

Touch

GFP X X X 0 X [[1]] 0 0 0 X

Flight1

Garmin GTN

650/750

GFP X X X 0 0 0 0 0 0

TDS GTNXi GFP X X X 0 0 0 0 0 X

PMDG

Aircraft
RTE 0 X X 0 0 0 0 0 0

Rotate MD-

80,

JARDesign

and others

TXT 0 X X 0 0 0 0 0 0

Majestic

Dash MJC8

Q400

FPR 0 X 0 0 0 0 0 0 0

IXEG Boeing

737
FPL 0 X X 0 0 0 0 0 0

Flight Factor

Airbus
corte.in 0 X X 0 0 0 0 X

X

[[2]]

iFly FLTPLAN 0 X X 0 0 0 0 0 0

MSFS

IniBuilds

Airbus

FPL 0 X 0 0 0 0 0 0 0



Format

Name
Ext. Open Exp. Airw VFR/IFR

User

Wpt.

Names

Remarks
Dep.

Parking

Cruise

Alt.
Proc.

ProSim
XML

[[4]]
0 X X 0 0 0 0 0 0

BlackBox

Simulations

Airbus

PLN 0 X X 0 0 0 0 0 0

Leonardo

Maddog X
MDX 0 X X 0 0 0 0 0 0

QualityWings RTE 0 X X 0 0 0 0 0 0

AivlaSoft

EFB
EFBR 0 X X 0 0 0 0 0 0

Level-D RTE 0 X X 0 0 0 0 0 0

FeelThere or

Wilco
FPL 0 X X 0 0 0 0 0 0

TFDi Design

717
XML 0 X X 0 0 0 0 0 0

IvAp for

IVAO [[3]]
FPL 0 X X 0 0 0 0 0 0

X-IVAP for

IVAO [[3]]
FPL 0 X X 0 0 0 0 0 0

VATSIM

vPilot or

SWIFT [[3]]

VFP 0 X X 0 0 0 0 0 0

UFMC UFMC 0 X X 0 0 0 0 0 0

X-FMC FPL 0 X X 0 0 0 0 0 0

Garmin

exchange

format

GPX - X - - - - - - -

HTML flight

plan web

page

HTML - X - - - - - - -

For Flight1 Garmin GTN 650/750, Reality XP GNS 530W/430W V2, Reality XP GTN 750/650 Touch and
TDS GTNXi additional

export formats exist which replace waypoints with user defined
waypoints. This helps to avoid the locked

waypoint issue but drops all procedure and waypoint information.



Procedure waypoints are excluded from most file formats by default, except for GPX.
You have to use the

GPS, FMS or MCDU in the simulator to
select procedures. Exceptions are e.g. X-Plane FMS and FLP which

allow to save and load procedures.

You can enable saving of waypoints by checking the menu items
Export Waypoints for Approaches and/or

Export Waypoints for SID and STAR.

The current file name and type will change if you save a plan as LNMPLN. This does not occur when

exporting.

42.5. Export Formats

42.5.1.  Microsoft Flight Simulator 2020

File format for MSFS.
Little Navmap can read and export this format.

You can export this format directly using Export Flight Plan as MSFS 2020 PLN and load the flight plans using

menu File -> Open Flight Plan.

While the format supports procedures there appear problems in MSFS loading these. Procedures might be

omitted or new ones inserted.
Furthermore MSFS does not support the selection of transitions and often

inserts these automatically.

You can set a parking spot or fuel pad as starting position but note that runways and helipads as starting

positions will be ignored by MSFS.

See FAQ - The flight plan does not show up correctly in MSFS [https://albar965.github.io/littlenavmap-faq.html#flightplan-msfs]

for more information on problems.

PLN files for Microsoft Flight Simulator 2020 will have special characters removed since the simulator cannot

load files having these as a part of the name.

42.5.2.  FSX and Prepar3D

File format for FSX and P3D.
Little Navmap can read and export this format. Procedures are not saved.

You can export this format directly using Export Flight Plan as P3D or FSX PLN.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

42.5.3. FSX and Prepar3D annotated (obsolete)

Annotated PLN format used by Little Navmap versions up to and including 2.4.5.

This is needed only if you like to save a flight plan for older Little Navmap versions.

Little Navmap can read and export this format completely with procedures.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

42.5.4. FS9 PLN

File format of the Flight Simulator 2004. Uses the same PLN file extension as
the FSX PLN format. Little

Navmap can only read this format.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

42.5.5.  X-Plane FMS 11 and X-Plane 12

X-Plane FMS format which can be loaded into the stock GPS, the G1000 and
the FMS of X-Plane 11 and 12.

You can export this format directly using Export Flight Plan as FMS for X-Plane 11 and 12.

Little Navmap can read and export this format.

https://albar965.github.io/littlenavmap-faq.html#flightplan-msfs


Store these files into the Output/FMS plans directory inside the
X-Plane directory.

Read the X-Plane manuals for the respective devices on how to load plans inside the cockpit:
User Manuals

for X-Plane Products [https://www.x-plane.com/support/manuals/].

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

Note

Little Navmap cannot determine the cruise altitude of a flight plan
after loading this format in some cases.

You might see errors about violated altitude
restrictions after loading. Adjust the cruise altitude manually if

this is the case.

42.5.5.1. FMS Export Issues

While Little Navmap resolves references from simulator airports to procedures in the navdata by
various

ways, X-Plane might not be able to find the procedures for a given aiport. This is the
case if an airport has

been renamed or has inconsistent idents like ICAO or FAA. You will see a warning message
in X-Plane where

it complains about not being able to load the procedures. You can try to load the flight plan
and select the

procedures manually in the GPS or FMS units but this also does not work in all cases.

Another issue is where X-Plane refuses to read flight plans due to unknown departure or destination airports.

This can happen if the airports are only present in an add-on and not in stock or have been renamed.
You

can open the FMS file in a text editor and fix this manually by replacing the keywords ADEP and ADES with
DEP

and DES respectively. Note that this does not work if procedures are used with an airport.

FMS file which cannot be loaded by X-Plane with keywords ADEP and ADES:

I


1100 Version


CYCLE 2209


ADEP 44T


ADES KSHN


NUMENR 2


1 44T ADEP 211.000000 46.992359 -122.827721


1 KSHN ADES 271.000000 47.233555 -123.147552


Corrected FMS file for both airports where the first occurences of ADEP and ADES were replaced with DEP and DES keywords for both airports:

I


1100 Version


CYCLE 2209


DEP 44T


DES KSHN


NUMENR 2


1 44T ADEP 211.000000 46.992359 -122.827721


1 KSHN ADES 271.000000 47.233555 -123.147552


42.5.6. FMS 3 (X-Plane)

X-Plane FMS format which can be loaded into the stock GPS and FMS of
X-Plane 10 and 11.05. The format is

very limited and basically stores
only a list of waypoints.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

Store these files into the Output/FMS plans directory inside the
X-Plane directory.

42.5.7. X-Plane CIVA Navigation System

This is a flight plan format which exports files for the X-Plane CIVA Navigation System.

The flight plan is divided into files with a maximum of eight waypoints each.
A flight plan with more

waypoints will result in more files.

Example for flight plan files for a plan from EGAE to LGIO containing not more than 24 waypoints:

EGAELGIO.fms


EGAELGIO1.fms


https://www.x-plane.com/support/manuals/


EGAELGIO2.fms


Little Navmap can read and export this format.

Store these files into the Output/FMS plans directory inside the X-Plane directory.

42.5.8.  FlightGear

FlightPlan format which can be loaded into the RouteManager of the free
flight simulator FlightGear

[http://www.flightgear.org].

You can export this format directly using Export Flight Plan as FlightGear FGFP.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

You can save the files into any directory and load it within FlightGear.

42.5.9. FSC

File format for FlightSim Commander. Uses the same PLN file extension as
the FSX PLN format. Little Navmap

can only read this format.

42.5.10. Aerosoft Airbus and others

42.5.11. Aerosoft CRJ

A format that can be read by the X-Plane FMS (not the X-Plane GPS),
Aerosoft Airbus and other add-on

aircraft. Supports airways and
procedures.

You can load these files into the X-Plane FMS including airway
information. Procedures are saved in the FLP

but cannot loaded yet by
the FMS. You have to select these manually after loading the flight
plan.

42.5.12. Garmin

Simple XML based flight plan format which stores only a list of waypoints.
Little Navmap can read and export

this format.

42.5.13. Reality XP GNS 530W/430W V2

Flight plan format as FPL file usable by the Reality XP GNS 530W/430W
V2.

See Notes about the Garmin Formats GFP and FPL for information on known problems when
exporting flight

plan data for the GNS.

Little Navmap considers the GNSAPPDATA environment variable if
set. See the GNS manual for more information.

The default directory to save the flight plans for the GNS units is
C:\ProgramData\Garmin\GNS Trainer Data\GNS\FPL

for all simulators.

You may have to create the directory manually if it does not exist.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

42.5.14. Reality XP GTN 750/650 Touch

Save flight plan as GFP file usable by the Reality XP GTN 750/650
Touch.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

See Notes about the Garmin Formats GFP and FPL for information on known problems when
exporting flight

plan data for the GTN.

Little Navmap considers the GTNSIMDATA environment variable if
set. See the GTN manual for more information.

42.5.15. TDS GTNXi

The default directory to save the flight plans for the GTN units is
C:\ProgramData\TDS\GTNXi\FPS for all simulators.

http://www.flightgear.org/


Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

See Notes about the Garmin Formats GFP and FPL for information on known problems when
exporting flight

plan data for the GTN.

You may have to create the directory manually if it does not exist.

42.5.16. Flight1 Garmin GTN 650/750

The default directory to save the flight plans for the GTN units is
C:\ProgramData\Garmin\Trainers\Databases\FPLN

for all simulators.

You may have to create the directory manually if it does not exist.

42.5.16.1. Garmin GTN Trainer 6.41

The default directory to save the flight plans for the GTN units is
C:\ProgramData\Garmin\Trainers\GTN\FPLN for all

simulators. You have
to create this directory manually and then navigate to it in the file
dialog when saving.

Little Navmap will remember the selected
directory.

42.5.16.2. Garmin GTN Trainer 6.21

If you’re using the trainer version 6.21 then the default path is
C:\ProgramData\Garmin\GTN Trainer Data\GTN\FPLN.

You have to create
this directory manually.

42.5.17. Flight1 Garmin GTN 650/750

This is the flight plan format used by the Flight1 GTN 650/750.

Flight plans of this format can be loaded into Little Navmap using menu File -> Open Flight Plan.

See Notes about the Garmin Formats GFP and FPL for information on problems when exporting
flight plan

data for the GTN.

The default directories to save the flight plans for the GTN units are:

Prepar3D v3:
C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\F1TGTN\FPL.

Prepar3D v4:
C:\Program Files\Lockheed Martin\Prepar3D v4\F1TGTN\FPL.

Flight Simulator X:
C:\ProgramFiles(x86)\Microsoft Games\Flight Simulator X\F1GTN\FPL

You might need to change the user privileges on this directory if your
saved flight plans do not show up in

the GTN. Give yourself full control
and/or ownership of this directory to avoid this.

A typical symptom is that you can save the flight plan in Little
Navmap and you can also see the saved plan

in Little Navmap’s open
dialogs but it does not show up in the GTN unit. Change the privileges
of the export

directory as mentioned above if that is the case.

The file is a simple text format containing only one line of text.

Example for the content of a flight plan file named KEAT-CYPU.gfp:

FPN/RI:F:KEAT:F:EAT.V120.SEA.V495.CONDI.V338.YVR.V330.TRENA:F:N50805W124202:F:N51085W124178:F:CAG3:F:N51846W124150:

F:CYPU


42.5.18. PMDG Aircraft

A PMDG RTE file. File location depends on the used aircraft but is
usually PMDG\FLIGHTPLANS in the simulator

base directory.

This format does not allow saving of procedures.

42.5.19. Rotate MD-80, JARDesign and others

A simple file format usable by JARDesign or Rotate Simulations aircraft.
The dexport directory depends on

the used aircraft which is usually in the X-Plane
directory Aircraft.

The file is a simple text format containing only one line of text.



Example for the content of a TXT file named CBZ9CYDC.txt:

CBZ9 SID AIRIE V324 YKA B8 DURAK STAR CYDC


42.5.20. Majestic Dash MJC8 Q400

Flight plan format for the Majestic Software MJC8 Q400. Note that the
export is limited to a list of waypoints.

The flight plan has to be saved to
YOURSIMULATOR\SimObjects\Airplanes\mjc8q400\nav\routes.

Note that the FMC in the Dash will show invalid coordinates when you
press INFO on a waypoint or airport.

The flight plan, navigation and
autopilot are not affected otherwise.

42.5.21. IXEG Boeing 737

Exports the current flight plan as a FPL file usable by the IXEG Boeing
737. The format is the same as TXT

but with a different file extension.

The file should be saved to
XPLANE\Aircraft\X-Aviation\IXEG 737 Classic\coroutes. You have to
create the directory

manually if it does not exist.

42.5.22. Flight Factor Airbus

A format for the Flight Factor Airbus. The file is not truncated and
flight plans are appended when saving.

Flight plans are saved in a slightly extended ATS route notation which
also allows to save the cruise altitude

and approach procedures. Edit
the file with a simple text editor if you want to remove flight plans.

While this format allows saving of SID and STAR the option for
approaches was removed since it is

unreliable.

Example:

RTE ETOPS002 EINN 06 UNBE2A UNBEG DCT 5420N DCT NICSO N236A ALLEX Q822 ENE DCT CORVT KJFK I22R JFKBOS01 CI30 FL360

RTE EDDFEGLL EDDF 25C BIBT4G BIBTI UZ29 NIK UL610 LAM EGLL I27R LAM CI25 FL330


42.5.23. iFly

Flight plan format for the iFly 737NG for FSX or P3D. The file has to be
saved to

YOURSIMULATOR/iFly/737NG/navdata/FLTPLAN.

Procedures cannot be saved.

42.5.24. MSFS IniBuilds Airbus

Flight plan locations differ by MSFS installation type:

MS Store

C:\Users\YOURUSERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft

-aircraft-a310-300\work\flightplans

Steam

C:\Users\YOURUSERNAME\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-

300\work\flightplans

42.5.25. ProSim

A flight plan format for ProSim [https://prosim-ar.com]. The flight
plan is appended to the file companyroutes.xml when

saving. Remove
flight plans manually in a text editor.

Little Navmap creates up to two backup files when saving the flight
plan: companyroutes.xml_lnm_backup and

companyroutes.xml_lnm_backup.1.

Procedures cannot be saved.

Example:

https://prosim-ar.com/


<?xml version="1.0" encoding="UTF-8"?>


<companyroutes>


  <route name="EFMAESGT">EFMA RUNGA N872 TEB N623 BEDLA N866 NEGIL ESGT</route>


  <route name="LGIRLEDA">LGIR SUD UJ65 TRL UM601 RUTOM M601 QUENN Q123 LULIX P167 GINOX UM601 BCN UN975 SELVA 

LEDA</route>


</companyroutes>


42.5.26. BlackBox Simulations Airbus

This format is for the Blackbox Simulations Airbus for FSX or P3D. Save
this to YOURSIMULATOR/Blackbox

Simulation/Company Routes or
YOURSIMULATOR/BlackBox Simulation/Airbus A330 depending on aircraft
type.

This format cannot save procedures.

42.5.27. Leonardo Maddog X

Flight plan for the Leonardo MaddogX aircraft. This format cannot save
procedures.

42.5.28. QualityWings

Flight plan for QualityWings aircraft. This format cannot save
procedures. The location depends on the

aircraft.

42.5.29. AivlaSoft EFB

Flight plan for the AivlaSoft Electronic Flight
Bag [https://aivlasoft.com]. Saving of procedures is not supported.

42.5.30. Level-D

Flight plan for Level-D aircraft. This format cannot save procedures.
Save this to YOURSIMULATOR\Level-D

Simulations\navdata\Flightplans.

42.5.31. FeelThere or Wilco

The format above cannot save procedures. The location depends on the
aircraft.

42.5.32. TFDi Design 717

Flight plan format for the TDFi Design Boeing 717. The format above
cannot save procedures.

42.5.33. IvAp for IVAO

42.5.34. X-IVAP for IVAO

Flight plan format for the IVAO online network clients IvAp or
X-IvAp [https://www.ivao.aero/softdev/ivap.asp].

The file format for these two clients differs slightly.

Flight Plan Online Network Export will appear
before where you can add all needed information.

42.5.35. VATSIM vPilot or SWIFT

Flight plan format for the VATSIM
vPilot [https://www.vatsim.net/pilots/download-required-software] online network
client.

Flight Plan Online Network Export will appear
before where you can add all needed information.

42.5.36. UFMC

A flight plan format for the UFMC [http://ufmc.eadt.eu]. The format
does not allow saving of procedures.

Save the flight plan to XPLANE\Custom Data\UFMC\FlightPlans.

42.5.37. X-FMC

Save flight plan as FPL file for the X-FMC [https://www.x-fmc.com].
The format does not allow saving of procedures.

The file should be saved to Path to
XPLANE\Resources\plugins\XFMC\FlightPlans.

42.5.38. Garmin exchange format

https://aivlasoft.com/
https://www.ivao.aero/softdev/ivap.asp
https://www.vatsim.net/pilots/download-required-software
http://ufmc.eadt.eu/
https://www.x-fmc.com/


GPX is not a flight plan format.

The GPS Exchange Format can be read by Google Earth and most other GIS
applications.

The flight plan is embedded as a route and the flown aircraft trail as a
track including simulator time and

altitude.

The route has departure and destination elevation and cruise altitude
set for all waypoints. Waypoints of all

procedures are included in the
exported file. Note that the waypoints will not allow to reproduce all
parts of a

procedure like holds or procedure turns.

The track contains the aircraft trail with flown altitude and timestamps.

42.5.39. HTML flight plan web page

This is not a flight plan format. This function saves the current flight
plan as a single HTML web page with all

images embedded. You can open
this page in any web browser.

The exported file will reflect changes of the flight plan table view like
column order. Columns which are

hidden or shrinked to minimum width are excluded.

42.6. Notes about the Garmin Formats GFP and FPL

Various problems can appear when reading exported flight plans into the
Garmin units. Most of these are a

result of the Garmin navigation
database which uses data of an older AIRAC cycle (mostly 1611 at the
time

of writing). Updated simulator or add-on databases (like the one in
Little Navmap) can use the latest navdata

or an old one from FSX or
P3D stock data.

Any waypoints, airways or procedures that are removed, added or renamed
over time can cause locked

waypoints or other messages when reading a
flight plan into the GNS or GTN.

It is easy to remove locked waypoints within the GNS or GTN to enable
the flight plan to be activated. Refer

to the documentation of the
Garmin unit.

Little Navmap allows to change the Garmin export to replace all
waypoints with user defined waypoints to

avoid locking. While this is a
sufficient approach to avoid the locked waypoints it comes with a few

limitations:

Departure and destination airport are not saved as user defined
waypoints. These have to exist in the

Garmin navigation database.

Navaid information like frequencies cannot be displayed since the
waypoint cannot be related to the

radio navaid.

Procedures like SID and STAR cannot be saved with the flight plan and
have to be selected manually.

The GTN (not the GNS) changes all names to a generic USERWPT...
scheme.

The export of user defined waypoints can be enabled in the options
dialog on tab Flight Plan.

[1]

Only SID and STAR. Saving or approaches is not supported.

[2]
(1,2)

User defined waypoints will be renamed when loading into the GTN.

[3]
(1,2,3)

Additional information for online flying can be added in a dialog
before saving.

[4]

Full name is companyroutes.xml

[5]

Procedures might not load in MSFS or might be replaced by other procedures.



43. Flight Plan Multiexport

Multiexport simplifies flight plan export and enables saving to several formats at once with a
single

click into the toolbar, a click into the menu (File -> 
Multiexport Flight Plan) or using the keyboard

shortcut Ctrl+Shift+M.

The dialog makes use of tooltips. Hover the mouse cursor above rows and buttons for more

information.

Overview of the multiexport features with the related menu items highlighted. Screenshot based on Little Navmap 2.6.

Click image to enlarge.

43.1. Quick Setup

The export function is disabled initially until at least one format is enabled for export in File ->


Multiexport Flight Plan Options.

Export paths are pre-filled where known. This is done when first opening the dialog
and considers the

current simulator selection (Scenery Library Menu). A best guess is used if not applicable.

Adapt the default paths if needed. You can edit a path by double clicking on it or using the
button 

which will open a file dialog for selection.

The footer line below the table shows error messages and an example export file name and path.

Check the box on the left of a row or use the context menu to enable for a format for export.
The row

text will be shown bold if enabled.

Adjust the selection in Export Options and choose if you like to overwrite files or if you would like
to

see a file dialog for each saved format.

Click Ok when done.



The flight plan will be exported when using menu File -> Multiexport Flight Plan if a correct path is

entered and the box is checked.

Tip

You can also export flight plans manually from the multiexport options dialog by clicking on the

button  Export Flight Plan now.

Note

Note that Little Navmap does not clean up the exported directories. All old flight plans remain
and

have to be removed manually from time to time.

Consider exported flight plan files as disposable since almost all the export formats have limitations

resulting in data loss. Remember that you can always restore them by loading the original LNMPLN

file and exporting again.

See also Flight Plan Formats for more information on the supported flight plan formats.

43.2. File Names

Saving LNMPLN

The default file name used when saving LNMPLN files using the functions Save Flight Plan or Save

Flight Plan as LNMPLN can be set in the options dialog on page Flight Plan. See Pattern for default

LNMPLN flight plan names.

Export other Formats

Little Navmap always uses file names based on the pattern set in the column File Name Pattern and

Extension when running an multiexport or starting an export from the menu File.

43.3. Exporting Little Navmap native flight plan format

Exporting the Little Navmap native flight plan format with file extension LNMPLN via multiexport is a

special
case compared to the other formats. Enabling this for export saves you a few extra clicks for

storing the file.

The following happens if LNMPLN is saved with multiexport:

The file name is automatically assigned by using the selected pattern in the options dialog on

page Flight Plan (Pattern for default LNMPLN flight plan names).
If the file was already saved

with another name when doing Save Flight Plan as LNMPLN or Save Flight Plan then this name is

used.

Little Navmap saves the file into the path set in the multiexport options dialog.

The current file is marked as clean. This means that the * is cleared from the window title
and

Little Navmap will not ask to save the file once exiting or creating a new plan.

Further saves (menu File -> Save Flight Plan) will use the automatically assigned file name and

path.

See also Little Navmap LNMPLN Format.

Warning

Always save a copy in the default LNMPLN format before exporting to other
formats. This allows

Little Navmap to restore all flight plan
properties like procedures, alternate airports and remarks.

Note that the LNMPLN format is only understood by Little Navmap.
Do not try to load it into

simulators or add-ons.



43.4. Path Errors

The path is highlighted red once a format is enabled for export with a non existing directory or
file.

Hover the mouse above the path to see more detailed error messages.

Directories (files for some export formats) have to exist for the export to work.

Error message in tooltip for X-Plane FMS export. Hover mouse cursor above red text to see this.
Also selected is the MSFS

flight plan export without path errors.

43.5. Running Multiexport

A dialog is shown, if any unsupported features are detected in the
current flight plan when trying to

save a plan. You can disable this
dialog for future saves.

Pressing Cancel in this dialog stops the export. No files will be exported.

Depending on the setting in the Export Options button Little Navmap will also show a file dialog for

each exported file.

You can enable saving of waypoints by checking the menu items
Export Waypoints for Approaches,

Export Waypoints for SID and STAR or
Export Waypoints for Airways.
These three options affects all

flight plan export formats except the native LNMPLN format.

43.6. Multiexport Options Dialog

43.6.1. Export Format Table

You can click on the table headers to sort the content. Tooltips as well as the footer line below the table

give more information on
formats and path errors.

Columns can be moved and resized by clicking and dragging the table header.
The table layout is saved

and can be reset by choosing Reset View in
the context menu of the table.

See Tables for general information on tables.

43.6.1.1. Enable / Change Path / Export Now / Reset Path

The first column contains several buttons which provide the same functions as the context menu.

43.6.1.1.1. Checkbox

The checkbox on the far left enables the respective format for export and highlights the row in
bold

text. Path errors are only shown if the format is enabled.

43.6.1.1.2.  Select Export Path

Opens a file or directory selection dialog to enter the path. Some export formats need a file to
append

flight plan information instead of a directory to save a file.



43.6.1.1.3.  Export Flight Plan now

Opens a file dialog for immediate export of the current flight plan.
You can also export formats which

are not enabled.

43.6.1.1.4.  Reset Export Path

Resets the path back to default.
The default path is determined by the current scenery library or

simulator selection.
If not applicable, the best estimate from installed simulators and Scenery Library

Menu selection is used.

43.6.1.2. Category

Category for the export format.

43.6.1.3. Usage

Short description of the export format and the product for which it is used.

43.6.1.4. Filename Pattern and Extension

The pattern is used to build filenames when exporting flight plans.
The file suffix like .lnmpln, .pln or

.fgfp is a part of the pattern.

The following keywords are recognized:

PLANTYPE: IFR or VFR

DEPARTIDENT: Departure airport ident.

DEPARTNAME: Departure airport name.

DESTIDENT: Destination airport ident.

DESTNAME: Destination airport name.

CRUISEALT: Cruise altitude.

Keywords are case sensitive and have to be entered in upper case. All other characters are are used as

entered.

Double click or press the key F2 to edit the file pattern directly.

An example filename and error messages are shown in the dialog footer below the table.

Examples (Filename Pattern and Extension, Export Path and result):

DEPARTIDENT-DESTIDENT.fms, X-Plane 11/Output/FMS plans:

X-Plane 11/Output/FMS plans/EDDF-LIRF.fms

DEPARTIDENT-DESTIDENT X-Plane 12 Beta at CRUISEALT.fms, X-Plane 12/Output/FMS plans:

X-Plane 12/Output/FMS plans/EDDF-LIRF X-Plane 12 Beta at 10000.fms

43.6.1.5. Export Path

Target directory for the exported files.
Double click or press the key F3 to edit the path directly.
You can

copy and paste paths from the Windows Explorer into this field, for example.

An example and error messages are shown in the dialog footer below the table.

43.6.2. Export Options

Three options can be selected in the drop down box. These apply to all export formats.

43.6.2.1. Show file dialog for every exported format



Opens a file or directory selection dialog for each enabled export format once
Multiexport Flight Plan is

used. The dialog allows to cancel an export or change the file
name or path.

Pressing cancel in this dialog does not stop the export process for further formats.

43.6.2.2. Do not show file dialog. Backup existing files in case of conflict

Present files are backed up to a maximum of four files and the new file is saved in place.
Little Navmap

does not check for changed files. You might see backups which are equal if you save too often.

Example: Saving the plan from ENKB to LICR several times in X-Plane FMS format:

Latest plan: ENKB-LICR.fms

Backups: ENKB-LICR_1.fms, ENKB-LICR_2.fms, ENKB-LICR_3.fms, ENKB-LICR_4.fms

43.6.2.3. Do not show file dialog. Overwrite files without warning

Present files with the same name are overwritten. Be careful with this option, especially when
using the

Exporting Little Navmap native flight plan format option.

This helps to reduce clutter in the output directories but may overwrite flight plan files.

Warning

No backup will be created when saving with this option enabled.

43.6.3. Help

Opens this chapter in the online help.

43.6.4. Ok

Takes over all changes and closes the dialog.

43.6.5. Export Selected Formats

Export all formats without closing the dialog. This is the same as selecting Multiexport Flight Plan in the

main menu File.

43.6.6. Cancel

Discards all changes except table formatting and closes the dialog.

43.7. Context Menu

Right click into the flight plan format table to open the context menu.

43.7.1. Enable Export

Selects format for multiexport. Same as the Select Export Path button.

43.7.2.  Export Flight Plan now

Save the format now. Same as the Export Flight Plan now button.

43.7.3.  Select Export Path

43.7.4. Edit Path

Allows to edit the path directly. This is the same as double clicking into the path field or pressing F3.



43.7.5.  Reset Export Path

Reset path back to default. Same as the Reset Export Path button.

43.7.6. Edit Filename Pattern

Edit the filename pattern directly. This is the same as double clicking into the path field or pressing F2.

43.7.7. Reset Filename Pattern

Reset the filename pattern back to default.

43.7.8. Reset all Paths, Filename Patterns and Selection Stated

Resets all paths and filename patterns back to defaults also considering the current simulator selection.

This is the same as clicking Reset Export Path in each row.

Also disables all flight plan formats for export.

43.7.9.  Reset View

Resets column size and column order back to default.

43.7.10. Increase, Decrease and Default Text Size

Changes the text size in the table. The size is saved.



44. Flight Plan Online Network Export

This dialog appears when exporting a flight plan for the online network
clients using the export menu

items
IvAp for IVAO, X-IVAP for IVAO, VATSIM vPilot or SWIFT or
Multiexport Flight Plan.

Some input fields might hidden depending on format.

Note that IvAp and X-IvAp use a slightly different format.

Fields that contain information which cannot be extracted from the
current flight plan are saved

between sessions (e.g.
Pilot in command or Equipment).

Other input fields in this dialog are extracted from the current flight
plan. These fields can be adjusted

manually and are not saved between
sessions. These are:

Flight Rules: From the current flight plan. IFR or VFR
for VFP and I or V for FPL. Change manually if

needed.

Aircraft type: From the current aircraft performance ( Aircraft Performance).

Departure: First waypoint in flight plan.

Destination: Last waypoint in flight plan.

Route: Generated from the flight plan waypoints, airways, SID and
STAR (Flight Plan Route

Description).

Cruise altitude: Taken from flight plan. Cruise altitude in ft.

True Airspeed: From the current aircraft performance cruise
speed.

Departure time: Uses current UTC time as default. Adjust as
needed.

Actual: Actual departure time. Uses same default time as above.
Adjust as needed.

En-route: Traveling time as calculated by flight plan and current
aircraft performance.

Endurance: Uses same default as above. Adjust as needed.

44.1. Buttons

OK: Saves relevant fields for the next session and opens the
Save as dialog.

Cancel: Discards all changes and closes dialog.

Reset: Undoes all changes that were made since opening the
dialog.

Help: Shows this online help page.



Flight Plan Online Export Dialog for VATSIM vPilot.



45. Open Flight Plan from SimBrief

This function opens a dialog window where SimBrief flight plans can be imported directly into Little

Navmap.
SID, STAR, the respective transitions, runway assigments as well as the cruise altitude are

downloaded.

Note that approach procedures, cruise speed and fuel parameters are ignored by Little Navmap which

relies on aircraft
performance files for fuel and speed. See Aircraft Performance for more information.

See Export Flight Plan to SimBrief for information on how to export a flight plan from Little Navmap to

SimBrief.

45.1. Download a Flight Plan

1. Open a web browser by clicking the blue SimBrief [https://www.simbrief.com] link in the dialog header

and login.

2. Start with either New Flight, Edit Flight or Saved Flights or Load.

3. Once the flight plan is done click Generate Flight in SimBrief.

4. Go back into Little Navmap and select menu File -> Open Flight Plan from SimBrief.

5. Enter your SimBrief Pilot ID or Alias (Username). Select the type of login in the drop down box at

the left of the input field. Little Navmap remembers this value.

6. Click Download Flight Plan.

7. Click Create Flight Plan if if the generated flight plan was successfully downloaded.

Alternatively, click Open in Route Description for manual editing the flight plan in the Flight Plan Route

Description dialog.

Note that the flight plan is kept for a while on SimBrief. You do not have to login and generate the flight

every time.

Generated flight plan successfully downloaded from SimBrief. Details about the plan are shown in the message area.

https://www.simbrief.com/


The download or parsing failed. Details about errors are shown in the message area.

45.2. How to get the Login Information

1. Go to Account Settings in SimBrief.

2. There your can see Alias (Username) and your Pilot ID.

Path to user and login information.



46. Export Flight Plan to SimBrief

This function can export a flight plan generated in Little Navmap into SimBrief.

SID, STAR and the respective transitions, the Aircraft type (ICAO aircraft type designator) from the

loaded aircraft performance file
as well as the cruise altitude are exported. Note that approach

procedures are not exported.

See Open Flight Plan from SimBrief for information on how to load a flight plan from SimBrief into Little

Navmap.

How to export a flight plan:

1. Create or load flight plan in Little Navmap. See Building a Flight Plan for a quick introduction.

2. Open your web browser and log into SimBrief [https://www.simbrief.com] before exporting the flight

plan. Keep the tab in the web browser open.

3. Go back to Little Navmap and select Open Flight Plan from SimBrief in the menu File.

4. Check the information and press Export if everything is ok. Press Cancel to stop the export.

5. Your web browser opens the flight plan in a new tab or window in SimBrief if you click Export.

Alternatively you can click Copy web address to clipboard and open this later in a web browser.

The information dialog will be skipped if you click Do not show this dialog again and open address in the

browser instead.
You can reset this using Reset all Messages in menu Tools.

SimBrief export dialog.

Note

You have to use the same or at least a close AIRAC cycle in SimBrief and Little Navmap to avoid

issues when exchanging flight plans.

https://www.simbrief.com/


47.  Aircraft Performance

Aircraft performance and fuel reports are shown in the dock window
Flight Planning.

Little Navmap provides functionality for editing, creating and
collecting aircraft performance profiles.

This allows to determine
needed fuel, flight time as well as climb and descent paths.

Average performance data like speed, vertical speed and fuel flow is
used for the flight phases

taxi/takeoff, climb, cruise and descent to
calculate fuel requirements.

The program can either consider NOAA real world wind prediction or the
X-Plane winds aloft to

calculate the fuel report. Alternatively, a
simple setting for wind at cruise altitude can be used to adjust

the
plan for weather.

Related chapters:

Winds Aloft: Information on winds
aloft.

Aircraft Performance Collection: Automatic
and permanent aircraft performance collection

running in the
background.

Aircraft Performance Edit: Change
performance manually.

Aircraft Performance Merge: Merge
performance data collected from a flight or another file into

the
currently loaded.

Aircraft performance and the winds aloft situation is used for the
functions below:

Calculation of the flight time which is shown in flight plan header.

Calculation of top of climb and top of descent which are shown on the
map and in the elevation

profile. Note that wind and altitude
restrictions in procedures might affect the top of descent or

top or
climb distances.

Fuel planning report in Tab Fuel Report of the dock window
Flight Planning.

Remaining fuel at each leg in flight plan table.

Remaining fuel at top of descent and destination in the tab
Progress in the Information window as

well as traveling
times.

Fuel is shown both as weight (lbs or kg) or as volume
(gallons, liter) and can be entered in all available

units
independent of the program settings.

Additional display of other fuel units can be enabled in the dialog
Options on the tab Units.

See Top of Climb and Top of Descent Paths for details about the
calculation of TOC and TOD.

Red warning messages are shown in the tab Fuel Report and in the flight plan table footer
(Error

Messages Footer) if aircraft performance contains wrong
values that keep Little Navmap from

calculating fuel consumption,
climb or descent.

An orange warning message is shown if the flown
aircraft type does not match the type in the

aircraft performance. This can be disabled in the menu
Aircraft -> Warning for Aircraft Type Mismatch.



Aircraft Performance tab showing an error about a
missing value. The * in the tab label shows unsaved changes.

A simple default profile for a Cessna C172 is default.

Note

Note that the aircraft performance does take aircraft load, cruise altitude and temperatures aloft into

consideration.
You can use the block fuel as a starting point for complex aircraft, enter this into the

FMS or MCDU and refine it there.
You can also build more than one performance file to depict

different load situations or cruise altitudes.

Note

The default performance profile for a Cessna C172 is sufficient to calculate top of
climb and top of

descent and can be used if you wish to ignore the fuel
and travel time reports.

Adjust the default profile to you aircraft if needed.

Little Navmap collects performance data for an aircraft permanently
while flying. The collected data can

be merged or copied into the
currently used profile or a new one which can be fine tuned manually.
The

merging can be done at any time. See Aircraft Performance Collection.

Tip

See the Aircraft Performance Database [https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?]
to get

numbers for a start.

https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?


Fuel report tab. Average headwind of 10 knots is
based on NOAA winds aloft prediction and is also considered in fuel

calculation. Fuel needed for an alternate airport is shown too. The
performance file description contains a web link. Click

image to enlarge.

47.1. Files

Performance profile files (file extension LNMPERF) can be saved and
loaded like flight plan files. The

performance files can be dragged from
a file manager like Windows Explorer or macOS Finder and

dropped into
the Little Navmap main window to load them.

Warning

Do not save the files into the Little Navmap installation directory since
they might be deleted when

doing an update. Neither save them in
C:\Program Files or one of its sub-directories. Save the files

into your Documents directory or a sub-directory in there like
Documents\Little Navmap\Performance.

You can use the folder which is suggested by the Directories dialog.

Tip

Aircraft performance files from contributors and my own flights are
available in the download section

of
littlenavmap.org [https://www.littlenavmap.org/downloads/Aircraft%20Performance/].

Note that these files are community work and might vary in quality and accuracy.

47.2. Wind

You can enter the estimated average wind speed and wind direction at
a given altitude, download

NOAA wind predictions or use the X-Plane
wind file. This will be considered when calculating flight time

and fuel
consumption for each leg and the whole flight plan.

Wind will also affect the top of descent and top of climb. For example,
the top of climb will be a shorter

distance for a strong headwind. Time
to reach the top of climb is the same.

https://www.littlenavmap.org/downloads/Aircraft%20Performance/


The fuel report is updated immediately when changing wind speed, wind
direction, wind source or

when editing the flight plan.

The wind speed is interpolated from ground to cruise altitude for the
climb and descent phases when

using manual wind.

See the chapter Winds Aloft for more information on winds aloft.

47.3. Tab Fuel Report

47.3.1. Buttons

The buttons on top have the same functionality as the items in the main
menu Aircraft Menu.

 Wind Source: Same options as menu Wind source in main menu Weather.

 Edit Aircraft Performance: Opens the
edit dialog for the currently loaded profile. You can also

use the
menu item Aircraft -> Edit Aircraft Performance to change
the currently loaded

performance data. See Aircraft Performance Edit for a description of the edit
dialog.

 New Aircraft Performance: Creates a
new performance profile with default values and opens

the edit
dialog. A simple default profile for a Cessna C172 is default.

 Open Aircraft Performance: Load a
LNMPERF file.

 Save Aircraft Performance: Save
current profile to a LNMPERF file.

 Save Aircraft Performance as: Save
current profile to a new LNMPERF file.

 Help: Click to open this chapter of the manual in the default
browser.

47.3.2. Fuel Report

The fuel planning report updates automatically if the flight
plan, cruise altitude or wind situation

change.

A flight plan has to be loaded to see the full fuel planning report.
Otherwise it displays only basic

information like estimated range and
other information about the aircraft.

See Aircraft Performance Edit for a
detailed description of all fuel numbers.

The text size of the report can be changed in dialog Options on
page Display and Text.

Some sections and fields are only shown with a valid flight plan.
Fields not set in the performance file

are omitted.

The section Fuel Plan is replaced with a section Fuel showing information about the
aircraft fuel status if

no flight plan is loaded.

Note

The Tab Fuel Report in the dock window Flight Planning
is meant for fuel planning and does not

change during flight.

47.3.2.1. Aircraft Section

Estimated range with reserve: Calculated based on usable fuel,
speed and fuel flow for the cruise

phase and reserve fuel. Shows an
orange warning if fuel flow values are not set.



Minimum runway: Shown if set in the performance profile.

47.3.2.2. Flight Plan Section

Distance and Time: Total flight plan distance and traveling time
including procedures. Same values

as on top of the tab
Flight Plan. Affected by the wind situation.

Average Ground Speed: Ground speed across all the flight phases
climb, cruise and descent.

Calculated based on speeds as given and
wind as entered on top the tab or selected wind

source.

True Airspeed at Cruise: Cruise speed as given in the edit
dialog.

Mach at cruise: Mach number at flight plan cruise altitude
calculated based on given true airspeed

and ISA atmospheric standard
conditions. Only mach numbers above 0.4 are shown.

Average wind total: Shows the average wind speed and direction for all
three flight phases climb,

cruise and descent. Only shown if
sufficient wind is present. Also shows average head- or

tailwind if
present. The wind source (NOAA, Simulator, Manual or
Disabled) is shown in parentheses.

Average wind at cruise: As above but shows the average wind speed and direction for the cruise

phase.

47.3.2.3. Fuel Plan Section

Only shown with a valid flight plan. Otherwise replaced by a secition Fuel.

Fuel Type: As set in the performance profile. Either Avgas or
Jetfuel. Used to change values when

switching between volume and
weight as fuel unit and to convert between units in the report.

Usable Fuel: Shown as set in the performance profile. Only
displayed if bigger than zero. A :error-

style`red error message` is shown if
block fuel exceeds this value.

Trip Fuel: Fuel that is consumed while flying and covers all
phases from takeoff at departure to

touchdown at the destination.
Does not include contingency, extra, reserve or alternate fuel.

Block Fuel: Fuel to be loaded. Block fuel is the total fuel
required for the flight. Includes trip,

reserve, extra, taxi,
farthest alternate airport and contingency fuel.

Fuel at Destination: Expected fuel at destination. Will be equal
to reserve if no contingency fuel,

no extra fuel and no alternate
airports are set.

Alternate Fuel: Fuel needed to travel from the destination to the
farthest alternate airport.

Reserve Fuel: Reserve fuel as set in the edit dialog.

Taxi Fuel: Taxi fuel as set in the edit dialog.

Extra Fuel: Extra fuel as set in the edit dialog.

Contingency Fuel: Contingency fuel calculated from the percentage
given in the edit dialog and trip

fuel.

47.3.2.4. Climb and Descent Section

Only shown with a valid flight plan.

Climb: Speed and vertical speed as given plus the calculated
flight path angle. The flight path

angle is affected by the wind
forecast.

Time to Climb: Calculated time to climb for the given cruise
altitude.

Descent: Speed and vertical speed in descent phase as given plus
the calculated flight path angle.

The flight path angle is affected
by wind.

Descent Rule of Thumb: Calculated rule of thumb for descent.

Note

Altitude restrictions in procedures might affect the top of
descent or top or climb distances. The flight

path angle is only valid
where the aircraft can freely climb or descent unaffected by altitude
limits.

47.3.2.5. Remarks Section

This is a free plain text field for notes and links which are saved with the aircraft performance file.

Links are recognized and can be opened on tab Fuel Report.



See Remarks for more information about using web links in this field.



48.  Aircraft Performance Edit

The dialog allows editing of all aircraft performance related parameters
on three tabs. The labels for all

values required for fuel calculation
are highlighted bold.

The dialog is opened when clicking on the edit button in the Tab Fuel Report, when selecting Aircraft ->

New Aircraft Performance ... or Edit Aircraft Performance ... in
the main menu.

48.1. Buttons

OK: Takes all changes made in the dialog but does not save the
profile. The fuel report, top of

climb and top of descent in the
Elevation Profile are
adjusted immediately.

OK and Save: Takes all changes made in the dialog and saves the
profile. Opens a file dialog if the

file is new.

Cancel: Disregards all changes and closes the dialog.

Reset: Resets all changes made since opening the edit dialog.

Restore Defaults: Resets back to the default profile.

Help: Opens the online help in the default web browser.

48.2. Tab Aircraft

Simulator: This is populated based on the used simulator scenery library database when
creating

the file. Adjust manually if needed.

Aircraft model: Can be used freely. Determined from aircraft name
when Little Navmap collects

data for a performance profile.

Aircraft type: The ICAO aircraft type designator. Little Navmap
will show an orange warning

message in the Tab Fuel Report if the flown aircraft
does not match the type in the aircraft

performance file. Detected automatically when collecting
performance. The warning can be

disabled in the menu Aircraft -> Warning for Aircraft Type Mismatch.

Required runway: Only for information. Shown in the fuel report if bigger than zero.

Required runway type: Only for information. Shown in the fuel
report if it differs from default Hard.

48.2.1. Aircraft Type

See
ICAO - Aircraft Type Designators [https://www.icao.int/publications/DOC8643/Pages/Search.aspx] or
Wikipedia - List

of ICAO aircraft type designators [https://en.wikipedia.org/wiki/List_of_ICAO_aircraft_type_designators].

A warning message in the fuel report and the flight plan table footer will be shown if Warning for

Aircraft Type Mismatch is enabled in the menu Aircraft and
the simulator aircraft type does not match

the loaded performance file. This helps to avoid
accidental usage of the wrong performance file.

The mismatch is identified by comparing the field Aircraft type with the simulator aircraft
type which

can be seen in field Type: in Tab Aircraft.

48.2.1.1. MSFS

The aircraft type is not exposed in the SimConnect interface and will result in wrong warnings.
Disable

the warnings or adjust the Aircraft type in the aircraft performance tile to match your aircraft.

The model can be found with any text editor, opening the related
aircraft.cfg file, key

icao_type_designator int the section [General].

48.2.1.2. X-Plane

Its value can be read with X-Plane Plane Maker program, opening the
related aircraft file .acf, then

main menu -> Standard ->
Author, field ICAO code for ATC. It is stored as e.g.
P acf/_ICAO BE58 in the .acf

file.

48.2.1.3. FSX, FSX-SE and Prepar3D

https://www.icao.int/publications/DOC8643/Pages/Search.aspx
https://en.wikipedia.org/wiki/List_of_ICAO_aircraft_type_designators


The model can be found with any text editor, opening the related
aircraft.cfg file, key ATC_model under

the section [General].

First tab in aircraft performance edit dialog.

48.3. Tab Performance

All speeds are entered in true airspeed. This makes the values
independent of wind influence which

would be the case of ground speed.
It also makes the values independent of cruise altitude and

deviation
from ISA atmospheric conditions which would be the case when using the
Mach number or

indicated airspeed.

48.3.1. Fuel

Fuel Units: Either Volume (gallons or liters) or Weight
(lbs or kilograms). The numbers in the dialog

will be converted using
the weight of the selected Fuel Type when changing the unit.
Rounding

errors might occur when switching forth and back noticeable
a small changes.

Fuel Type: Avgas (default) or Jetfuel. Needed to convert
fuel numbers between weight and volume.

This is detected
automatically when collecting aircraft performance.

See Fuel - Flight Planning
Definitions [https://www.skybrary.aero/index.php/Fuel_-_Flight_Planning_Definitions]
(SKYbrary)

for more information on the various fuel types.

48.3.2. Usable Fuel

Used to calculate estimated range and to check if block fuel exceeds
fuel capacity of aircraft.

A label Estimated range with reserve shows the maximum distance and
time to fly with reserves.

48.3.3. Reserve Fuel

Final reserve fuel is the minimum fuel required to fly for 30 minutes at
1,500 ft above the alternate

airport or at the destination airport at
holding speed if an alternate is not required. Some authorities

require
sufficient fuel for 45 minutes holding time.

Alternate fuel is the amount of fuel required to fly the missed approach
at the destination airport and

to the alternate airport.

Reserve fuel is the sum of alternate fuel and final reserve fuel.

You have to set this value to avoid running out of fuel at the
destination when relying on this profile.

48.3.4. Taxi Fuel

https://www.skybrary.aero/index.php/Fuel_-_Flight_Planning_Definitions


Taxi fuel is the fuel used prior to takeoff and includes APU
consumption, engine start and taxi fuel.

48.3.5. Extra Fuel

Fuel that is added at the discretion of the captain or the dispatcher.

48.3.6. Contingency Fuel

Contingency fuel is carried to account for additional en-route fuel
consumption caused by wind, routing

changes or traffic management
restrictions.

The value is given in percent of trip fuel.

Tip

ICAO recommends to use 5 percent contingency fuel for all flights.

48.3.7. Climb

Values for climb are detected automatically when collecting performance.

Average climb speed: Average true airspeed from takeoff to cruise
altitude.

Average vertical climb speed: Vertical speed in climb phase.
Either ft per minute (fpm) or meter per

second (m/s).

Average fuel flow in climb: Fuel flow in climb phase. Either
gal, lbs, l or kg.

Climb speed and vertical climb speed are used to calculate the top of
climb which also varies with wind

conditions.

48.3.8. Cruise

Values for the cruise phase are detected automatically when collecting
performance.

Cruise speed at typical cruise altitude: True airspeed at cruise.

Fuel flow in cruise: Fuel flow in cruise phase.

48.3.9. Descent

Descent values are detected automatically when collecting performance.

Average descent speed: True airspeed in descent phase.

Average vertical descent speed: Average vertical speed.

Average fuel flow for descent: Average fuel flow on descent.

A label Descent Rule of Thumb shows the calculated rule of thumb for
descent. The default is 3 NM per

1,000 ft.

Descent speed and vertical descent speed are used to calculate the top
of descent which also varies

with wind conditions.

48.3.10. Alternate

Average speed for alternate: True airspeed when flying to
alternate.

Average fuel flow for alternate: Average fuel flow when flying to
alternate.

Little Navmap uses the values from the cruise phase as a default. The
flight to the alternate airport

usually happens at a lower altitude than
cruise altitude and therefore results in a higher fuel flow.

Adjust the
values accordingly here.



Aircraft performance edit dialog tab Performance. Click image to enlarge.

48.4. Tab Remarks

This tab contains a free plain text field for notes and links which is also shown in the
Tab Fuel Report of

the window Flight Planning.

See Remarks for more information about using web links in this field.



49. Aircraft Performance Collection

The performance data collection can be used to create a basic
performance profile which can be fine

tuned manually. Little Navmap
permanently collects fuel flow and speed data and calculates average

values for all flight phases.

Wind does not affect the calculation since all speeds are based on true
airspeed and not ground speed.

The collection begins automatically once Little Navmap is started and
connected to a simulator. You can

reset the collection manually to get a
clean base or use the function Reset all for a new Flight in menu

File.

A report of current average fuel and speed numbers is shown on the tab
Current Performance in the

window. You can copy or merge
intermediate results at any time into your currently loaded

performance
profile.

Little Navmap will show 3 NM per 1,000 ft climb and
descent slopes when collecting data based on an

default or new elevation
profile. You have to estimate the needed top of descent yourself.

Note

The flight plan cruise altitude is used to detect the cruise phase of
the aircraft. Set the cruise altitude

in the flight plan tab at least to
the intended cruise altitude if you do not plan use a flight plan.

Note

Note that the aircraft performance does not take aircraft load, cruise altitude and temperatures aloft

into consideration.
You can use the block fuel as a starting point for complex aircraft, enter this into

the FMS or MCDU and refine it there.
You can also build more than one performance file to depict

different load situations or cruise altitudes.

49.1. Quick How To

Follow the steps below to collect performance for an aircraft.

1. Connect Little Navmap to the simulator.

2. Fuel up your aircraft at best guess for the trip.

3. Use a typical load for the aircraft.

4. Create and use a flight plan for the trip. Use a typical distance and
cruise altitude for this

aircraft. A short hop does not suffice.

5. Place your aircraft on the parking spot at departure with engines
shut down or running.

6. Start and fly as precise as possible regarding speeds and performance
settings of the aircraft.

7. The collection is completed once the field
Current flight segment: in the report shows Finished..

8. Select Aircraft -> Merge collected Aircraft Performance in
the main menu and copy all values in

the dialog. See Aircraft Performance Merge for more information on
merging.

9. Edit the aircraft performance data ( Aircraft Performance Edit) and adjust the numbers to your

liking or flying habits.

Warning

Do not forget to add at least sufficient reserve fuel. Otherwise you
will run out of fuel at destination

if you rely on this plan.

Five percent contingency fuel are recommended.

Other recommended fields to edit are Usable Fuel,
Required Runway and Required Runway Type.



You can move your airplane at cruise altitude, use warp tools to get
quickly near top of descent or

adjust fuel and time manually. This will
not affect performance calculation since Little Navmap reads

the
actual fuel flow from the simulator instead of using consumed fuel and
time.

In any case stay a few minutes at cruise altitude so that Little
Navmap can get numbers for this phase

of flight.

Tip

You can create different performance profiles for different cruise
altitude ranges to cover fuel flow

variations.

Report shown when collecting aircraft performance.
All phases are already finished.

49.2. Tab Current Performance

49.2.1. Buttons




Restart Aircraft Performance Collection: Resets all collected
fuel and speed parameters back

to zero. Nevertheless performance
collection will continue immediately even while in cruise, for

example.


Merge collected Aircraft Performance: Opens a dialog allowing to
merge the collected

performance parameters into the currently loaded
performance file. This can be used in all flight

phases. See
Aircraft Performance Merge for more
information on merging.

 Help: Click to open this chapter of the manual in the default
browser.

49.2.2. Report

The text size of the report can be changed in dialog Options on
User Interface.

49.2.2.1. Aircraft Section

Current flight segment: Shows which flight phases (Climb,
Cruise and more) are detected.

Aircraft status: More information about aircraft status like fuel
flow or on ground status.

49.2.2.2. Fuel Section

Fuel Type: Fuel type as reported by simulator. This is calculated
based on the volume/weight

ratio. Correct this manually if add-on
aircraft do not provide a correct fuel type.

Total Fuel Consumed: Fuel consumed so far since the restart of
Little Navmap or the last reset of

the collection function.

Taxi Fuel: Fuel used from first detected fuel flow to lift off.

49.2.2.3. Average Performance Section - Climb, Cruise and Descent

Average values for the different flight phases. Sections for not yet
started phases are omitted. Passed

sections like e.g. climb will show
zero values if you restart the collection mid flight in e.g. cruise.

True Airspeed: True airspeed average.

Vertical Speed: Average climb or descent speed. Not shown for
cruise phase.

Fuel Flow: Fuel flow average.



50.  Aircraft Performance Merge

The currently loaded performance profile can be merged with the
collected performance or another

performance file using this dialog.

The dialog is opened when clicking on the merge button in the tab
Current Performance, when selecting

Aircraft ->
Merge collected Aircraft Performance or
Open Aircraft Performance and Merge in the main

menu.

A warning message is shown if the fuel type does not match.

50.1. Operations

The left side of the dialog shows either collected performance values
from a flight or the values of a

profile loaded using the
Open Aircraft Performance and Merge function.

The right side always shows the values of the current performance
profile.

Some values are only shown when merging from a file. Values not provided
by the performance

collection like alternate fuel are hidden when
merging collected data.

An operation can be selected for each value pair:

Copy: Simply copies the value from the left side to the currently
loaded performance profile on

the right.

Ignore: Does not change the right value.

Merge: Calculates the average of the left and right values and
assigns the result to the right. Not

applicable for aircraft type and
model.

50.2. Buttons

Set all operations to:: Copy, Ignore and Merge:
Changes the operations for all values.

Merge: Applies the selected operations to the current profile.

Merge and Save: As above but additionally saves the file.

Cancel: Disregards all changes and closes the dialog.

Help: Opens the online help in the default web browser.



Merge Aircraft Performance dialog for collected performance values.



51.  Load Scenery Library

51.1. Quick Start

You can load the scenery library database by going to the menu item
Load Scenery Library in the menu

Scenery Library.

Note that the loading runs in background which means you can put the loading progress window aside

and continue to plan a flight while loading.

From this dialog window you can select all detected Flight Simulators and load their scenery
libraries

into the database of Little Navmap.

An Empty Database indication is shown in the statusbar and a (empty) suffix is added in the related menu

item if you skip this step and Little Navmap automatically selects Use Navigraph for all Features in the

scenery library menu.

One database is kept for each simulator and can be changed on the fly in Scenery Library Menu.
One

disabled menu item is kept as an indicator in the Scenery Library menu if only one simulator is available.

Scenery library databases may need to be updated when you
install a new version of Little Navmap. A

question dialog will pop up
prompting you to erase the now incompatible database. You can reload the

scenery in Load Scenery Library after erasing the databases.

Little Navmap uses two database sources and data is merged if needed. See Navigation Databases for

more information.

See Loading Airspaces for information about loading airspaces into the Little Navmap database.

Important

Selecting the right scenery library for the simulator while flying is crucial since the selection
also

affects other functions of Little Navmap. The selected scenery library
defines which weather files are

read, for example.

Some functions like access to weather source files depend on the selected scenery library database.

X-Plane 11 weather files are read if the X-Plane 11 scenery library is selected, for example.

See Scenery Library Menu for information on the scenery library menu and the following chapters for

more details.

Note

Little Navmap does not keep you from using a X-Plane scenery
database while being connected to

FSX/Prepar3D/MSFS or vice versa, for example. You will
get unwanted effects like wrong weather

information if using such a setup.

An orange warning message is shown in the connect dialog ( Connecting to a Flight Simulator) if a

mismatch is detected.

Note

Parking positions in flight plans might change when switching between scenery library databases.

This can happen if airports have parking positions with different names or missing parking positions.

51.2. Navdata Updates



Little Navmap comes with a ready to use navigation database courtesy of Navigraph

[https://www.navigraph.com] which
includes airspaces, SIDs, STARs and more. The database can be updated

to the latest AIRAC cycle by using Navigraph’s FMS Data Manager.

See the chapter Navigation Databases for more information.

Warning

In any case close Little Navmap when updating, copying or replacing scenery databases.
Little

Navmap might crash or show wrong data otherwise.

51.2.1. FSX, Prepar3D and Microsoft Flight Simulator 2020

Little Navmap is compatible with navdata updates from
fsAerodata [https://www.fsaerodata.com], the FSX/P3D

Navaids
update [http://www.aero.sors.fr/navaids3.html] and
the Navigraph update for Microsoft Flight Simulator

2020.

See Microsoft Flight Simulator 2020 Airports and Navdata for more information on MSFS and navdata

updates.

51.2.2. X-Plane

Little Navmap will use navdata updates that are installed in the
directory Custom Data.

User defined data from the files user_fix.dat and user_nav.dat
is read and merged into the simulator

database if found. Note that you have to disable the Navigraph database to see the user navaids from

the X-Plane files.

Note that neither ARINC nor the FAACIFP files are supported.
Updates installed in the GPS directories

are not used.

51.3. Dialog Load Scenery Library

The dialog window Load Scenery Library has the following controls:

Simulator: Select the simulator to load, show database statistics
in the label above.

Reset Paths: Reset all paths back to default values.

Flight Simulator Base Path and Select ...: The path to the
base directory of the selected flight

simulator. This usually the
directory containing the FSX.exe, Prepar3D.exe or x-plane.exe. For MSFS

this is the
folder Packages containing the folder Community.

Scenery Configuration File and Select ... (only FSX and P3D):
The file scenery.cfg of the simulator.

You can also create copies
of the original file, modify them by removing or adding sceneries and

select them here for loading.

Read inactive Scenery Entries: This will read all scenery
entries, also the inactive/disabled ones.

This applies
to the FSX/P3D scenery.cfg as well as X-Plane’s
scenery_packs.ini which both allow to

disable scenery entries.

Read Prepar3D add-on.xml packages (only P3D v3, v4 and v5): If
enabled, reads P3D add-on.xml

packages.

Load: Starts the database loading process. You can stop the
loading process at any time and the

previous database is restored.
The dialog is closed and the program will switch to show the

loaded
database once it is successfully loaded.
Note that the loading runs in background which

means you can continue to plan a flight while loading.

Close: Keep all settings and changes in the dialog and close it
without loading anything.

This dialog will also show a hint if folders are excluded or included in loading.
This helps to avoid issues

by unintended directory exclusions.

FSX and Prepar3D: The base path and the scenery.cfg path will be
shown in two text edit fields for the

currently selected simulator.
These fields are populated automatically, but can be changed to any
other

valid location.

https://www.navigraph.com/
https://www.fsaerodata.com/
http://www.aero.sors.fr/navaids3.html


Microsoft Flight Simulator 2020: The base path of the MSFS installation and its
directories Community

and Official
is detected automatically. You can change the path manually if needed.

X-Plane: The base path of the first X-Plane installation is
added. Select the base path manually if you

like to read the scenery
library of another X-Plane installation.

Important

Always reset the paths if your simulator installation location has changed.

Loading a scenery library can take from 2 to 10 minutes depending on
your setup and amount of

scenery add-ons. You can speed this up by
excluding directories containing neither airport nor

navigation data in
the Options dialog on the page Scenery Library Database.

You can put the progress dialog window into the background and continue flight planning while loading.

If you cancel the loading process or if the loading process fails, the
previous scenery library database is

restored immediately.

The menu Scenery Library -> Flight Simulators is synchronized
with the simulator selection in the dialog.

Once a database is
successfully loaded, the display, flight plan and search switch
instantaneously to the

newly loaded simulator data.

Note

The final number of airports, navaids and other objects shown
in the Load Scenery Library dialog are

lower than the counts shown
in the progress dialog. After the data has been loaded, a
separate

process removes duplicates and deletes stock airports that were
replaced by add-ons.

An error dialog is shown after loading, if any files could not be read or
directories were not found. In

this case you should check if the
airports of the affected sceneries display correctly and show the

correct information. The error dialog allows copy and paste of formatted
text which is useful for error

reporting.

The Load Scenery Library dialog shows the last time of loading
(Last Update:), the program and the

database version. Major database
version differences indicate incompatible databases. The program

will
ask if the incompatible databases can be erased on startup before the
scenery database can be

reloaded. Minor database differences indicate
compatible changes where a reload is recommended but

not required.

Warning

Close Little Navmap when updating, copying or replacing its databases
manually or using other

programs to replace the databases. Little Navmap might crash or show
wrong data otherwise.



Load Scenery Dialog. Scenery data is already loaded for FSX.

Progress dialog shown while loading the scenery library into Little Navmap’s internal database.

51.4. Linking Scenery

Little Navmap follows all linked scenery which is linked by:

Symbolic links (all operating systems)

Windows shortcuts

Windows junctions

macOS aliases

Note that this functionality is limited to
the MSFS Community and X-Plane Custom Scenery directories.

Any directories added in the Options dialog on the page Scenery Library Database also support linking

51.5. Add-On Airports

For FSX and Prepar3D, all airports that are not located in the default
Scenery directory of FSX/P3D are

considered to be add-on airports.

For X-Plane, all airports located in the Custom Scenery directory of
X-Plane are considered to be add-on

airports. An exception is ...\X-Plane 11\Custom Scenery\Global Airports\Earth nav data\apt.dat

Microsoft Flight Simulator 2020: All airports located in the Community
directory and the

Official\OneStore or Official\Steam are considered to be add-on airports.
Exceptions are fs-base, fs-base-

genericairports and fs-base-nav.

Add-on airports are highlighted on the map with a yellow ring which can be disabled
in the options

dialog on page Map Display.

Using emphasized (bold and underlined) text highlights add-on airports in the search result table,
flight

plan table, information windows and map tooltips.



If an add-on only corrects airport elevations or navigation data, it
might be undesirable to display the

updated airports as add-on airports
on the map. You can exclude directories populated by this add-on

from
the add-on recognition in the Options dialog on the
page Scenery Library Database.

51.6. Microsoft Flight Simulator 2020 Airports and Navdata

If you use the Navigraph update for MSFS: Update the Little Navmap database with the FMS

Data Manager as well to keep the program in sync with the MSFS scenery library. Use the

scenery
mode Use Navigraph for Navaids and Procedures in the menu Scenery Library to get access to

all procedures in Little Navmap. This is the default.

Also check the selection in menu Scenery Library -> Airspace Libraries. Select
Navigraph and

uncheck Simulator there.

If you do not use the Navigraph update for MSFS: Use the scenery mode Do not use

Navigraph
Database in the menu Scenery Library to avoid issues with missing or changed navaids.

The selection in menu Scenery Library -> Airspace Libraries should have Simulator
checked.

Uncheck Navigraph there.

See Navigation Databases and FSX, Prepar3D and MSFS Airspaces for more background
information on

these settings.

See appendix Known Problems and Frequently asked Questions for information about MSFS limitations

and issues.

Use the menu item Scenery Library -> Validate Scenery Library Settings to check your settings.

51.7. X-Plane Airports and Navdata

Little Navmap reads airport and navaid data from X-Plane’s *.dat
files. To check a version of a file you

can open it in a text editor
that is capable of dealing with large files. The first lines of the file
will look

like:

A


1100 Generated by WorldEditor 1.6.0r1


1   1549 0 0 0A4 Johnson City STOLport


...


Little Navmap can read the following X-Plane scenery files:

Airports ( apt.dat ): From version 850. This
covers X-Plane 10 airports and older add-on

scenery.

Navdata ( earth_awy.dat , earth_fix.dat and
earth_nav.dat ): From version 1100. This excludes
X-

Plane 10 navdata files.

Procedures ( ICAO.dat in the
CIFP directory): All procedures from X-Plane 11 and 12.

Airspaces ( *.txt ): The included usa.txt and all
files in OpenAir format. See next chapter for

more information.

Additionally the files user_fix.dat and user_nav.dat in the
X-Plane directory Custom Data are read.

51.8. Magnetic Declination

Little Navmap reads the magnetic
declination [https://en.wikipedia.org/wiki/Magnetic_declination] from
different

sources or calculates it using the world magnetic model
(WMM [https://en.wikipedia.org/wiki/World_Magnetic_Model])

depending
on simulator and navaid.

The data is updated when loading the scenery library and is also stored
in the scenery library database

for each simulator.

See also Magnetic Declination for more information.

51.8.1. FSX, Prepar3D and Microsoft Flight Simulator 2020

https://en.wikipedia.org/wiki/Magnetic_declination
https://en.wikipedia.org/wiki/World_Magnetic_Model


The magnetic declination used to calculate the magnetic
course is taken from the magdec.bgl file in the

scenery database of
FSX, Prepar3D or MSFS.

Little Navmap falls back to the world magnetic model if the file
magdec.bgl is not available for some

reason.

Updates for this file in FSX and P3D are available here: FSX/P3D Navaids
update

[http://www.aero.sors.fr/navaids3.html].

51.8.2. X-Plane

The magnetic declination values for X-Plane (airports and all navaids
except VORs) are calculated using

the world magnetic model based on the
real current year and month. This is calculated while loading

the
scenery library and saved in X-Plane scenery library database.

VOR stations come with their own calibrated declination values which might differ
from the calculated

declination values in their environment as mentioned
above.

http://www.aero.sors.fr/navaids3.html


52. Loading Airspaces

Airspaces are loaded from the Navigraph database, simulator database, a user defined directory or

online flying services.
You can select airspaces to show in the main menu Scenery Library -> Airspace

Libraries.

52.1. FSX, Prepar3D and MSFS Airspaces

Little Navmap reads all airspaces from the scenery library of FSX, P3D and MSFS. These airspaces
are

added in the airspace source Simulator.

52.2. Airspace Formats

Little Navmap can read three airspace formats from a user defined directory.

See Airspace Libraries for more information on airspace sources.

52.2.1. OpenAir

Little Navmap can read OpenAir airspaces (OpenAir airspace
format

[http://www.winpilot.com/UsersGuide/UserAirspace.asp]) from
X-Plane or an user defined directory.

Note that the publicly available airspace files can contain errors which
may prevent the loading of an

airspace file. These hard errors are
reported after loading the scenery library. Other errors only

affecting
single airspaces or the geometry are reported in the log file only.

Additional airspace files can be downloaded from the OpenAirspace
Directory

[http://www.winpilot.com/openair/index.asp], Soaring
Services [http://soaringweb.org/],
openAIP [https://www.openaip.net/] or

Luftraumdaten
Deutschland [https://www.daec.de/fachbereiche/luftraum-flugbetrieb/luftraumdaten],
for example.

Airspace files must have a .txt extension and are loaded from the
following directories by Little

Navmap:

The files can be encoded in any
UTF [https://en.wikipedia.org/wiki/Unicode#UTF] format but must have
a BOM

[https://en.wikipedia.org/wiki/Byte_order_mark] to be
recognized properly. Otherwise Windows ANSI coding

(Windows-1252) is
used. Special characters like umlauts or accents are not displayed
correctly in names if

the encoding is not correct. All other
functionality is unaffected.

You can convert the files using any advanced editor like
Notepad++ [https://notepad-plus-plus.org/] for

example.

Airspaces will appear as duplicates in the map if an airspace file is
found in more than one of these

directories or sources.

Airspace types recognized in OpenAir format:

R: restricted

Q: danger

P: prohibited

A: Class A

B: Class B

C: Class C

D: Class D

E: Class E

F: Class F

G: Class G

GP: Glider prohibited

CTR: CTR

W: Wave Window

RMZ Radio Mandatory Zone / Class G

TMZ: Transponder Mandatory Zone / Mode C

http://www.winpilot.com/UsersGuide/UserAirspace.asp
http://www.winpilot.com/openair/index.asp
http://soaringweb.org/
https://www.openaip.net/
https://www.daec.de/fachbereiche/luftraum-flugbetrieb/luftraumdaten
https://en.wikipedia.org/wiki/Unicode#UTF
https://en.wikipedia.org/wiki/Byte_order_mark
https://notepad-plus-plus.org/


Internal airspace types:

Little Navmap passes an airspace type through to its scenery library database if it is not one of the

recognied types above.
This means you can additionally use these types which are only recognized by

Little Navmap:

C: Center

CA: Class A

CB: Class B

CC: Class C

CD: Class D

CE: Class E

CF: Class F

CG: Class G

FIR: FIR

UIR: UIR

T: Tower

CL: Clearance

G: Ground

D: Departure

A: Approach

M: MOA

R: Restricted

P: Prohibited

CN: Caution

W: Warning

AL: Alert

DA: Danger

NP: National park

MD: MODEC

RD: Radar

GCA: Control area

MCTR: MCTR

TRSA: TRSA

TR: Training

GP: Glider prohibited

WW: Wavewindow

52.2.2. GEOJSON

Further formats for online airspaces are GEOJSON which can be downloaded for VATSIM boundaries at

the VATSpy Data Project [https://github.com/vatsimnetwork/vatspy-data-project].

The extension is .geojson.

52.2.3. IVAO JSON

IVAO boundaries in JSON format can be downloaded at Little Navmap Downloads - Airspace Boundaries

[https://www.littlenavmap.org/downloads/Airspace%20Boundaries/].

The extension is .json.

52.3. X-Plane Airspaces

X-Plane 11 and 12 come with a single airspace file that can be found in

YOUR_XPLANE_DIRECTORY/Resources/default data/airspaces/.

Little Navmap reads X-Plane airspaces from the following locations:

YOUR_XPLANE_DIRECTORY/Resources/default data/airspaces

YOUR_XPLANE_DIRECTORY/Custom Data/Airspaces

https://github.com/vatsimnetwork/vatspy-data-project
https://www.littlenavmap.org/downloads/Airspace%20Boundaries/


These airspaces are added to airspace source Simulator.

52.4. User Airspaces

These airspaces are added in the airspace source User. You can load
them by selecting Scenery Library ->

Load User Airspaces.

Airspaces read with this function will be added to the airspace source
User and are stored in a database

independent of flight simulator
databases.

52.5. Online Airspaces

Online centers are displayed as circular airspaces in Little Navmap
per default and provide the same

functionality as the other airspaces
(tooltips, information and more). They are loaded with the online

data
when connected and are only stored in a temporary database which is
deleted on exit.

Little Navmap can use real center boundaries instead of the circular
airspaces. First you have to enable

one or both options in Map Display Online under
Online Center Boundary Lookup in User Airspaces. These are

enabled
per default.

There are two options:

1. Create an OpenAir airspace file which contains a single boundary for
a center. Give the file the

same name as the callsign for the center,
i.e. name the file EDDB_TWR.txt for the center with the

callsign
EDDB_TWR.

2. Create an OpenAir airspace containing the boundaries for all the
centers you need. Give the file

any name but name the boundaries
according to the callsign of the centers. You need a line in

the file
containing AN EDDF_TWR (AN = airspace name) to use the
boundary for a center with the

callsign EDDB_TWR.

Now place the file or files into you user airspace directory and reload
the user airspaces. See above

User Airspaces how to do
this.

Once done the center should show the correct boundary.



53. Navigation Databases

Little Navmap can use up to two databases in parallel:

1. Simulator database: Created by reading the scenery library of
FSX, Prepar3D, Microsoft Flight

Simulator 2020 or X-Plane.

2. Navigation database: Provided by Navigraph. Does not have to be
compiled and can be

updated by the Navigraph FMS Data Manager to the latest AIRAC cycle.

Little Navmap is bundled with a navigation database courtesy of Navigraph [https://www.navigraph.com] which

is enabled per default.

You can see the data source for each navaid or airport in the section Data Source in the information

window (see Scenery Information).

Tip

You can update the navdatabase of Little Navmap with the Navigraph FMS Data Manager.
See Install

Navigraph
Updates [https://albar965.github.io/littlenavmap_navigraph.html] on
my home page for more information

if the update fails.

Note

Note that runway numbers shown in the procedure search or context menus might differ compared

to the airport runways.
This happens when an add-on airport and the navigation data have different

runway numbers which is a result of renumbered
runways due to changes in magnetic declination

(magnetic pole drift).

Little Navmap resolves these mismatches internally and still allows to work with procedures.
You

might expect issues when loading flight plans containing such discrepancies into add-on aircraft or

simulators.

Important

It is recommended to keep all scenery libraries in sync. This means that your simulator, Little

Navmap,
aircraft and tools should use the same AIRAC cycle. Having navdata synchronized
helps to

avoid issues when loading flight plans.

Warning

Always close Little Navmap before updating its databases.

Three display modes can be selected from the menu Scenery Library as
shown below.

53.1. Use Navigraph for all Features

Uses only information from the Navigraph database.
This mode is automatically selected if the

simulator navdatabase is empty.

Note

Note that airport information is limited in this mode. This means that
aprons, taxiways, parking

positions, runway surface information and fuel
information are not available. Additionally, smaller

airports might be
missing.

https://www.navigraph.com/
https://albar965.github.io/littlenavmap_navigraph.html


Runway layout might not match the runway layout in the simulator if you
use stock or older airport

scenery.

An advantage of this mode is that approach procedures always match the
airport runway layout

precisely.

Airport diagram for EDDN from simulator scenery
(X-Plane) as shown in the modes Do not use Navigraph Database or
Use

Navigraph for Navaids and Procedures.

Airport EDDN from the Navigraph database while
Use Navigraph for all Features is enabled. Note missing runway
surface

information, aprons, taxiways and parking positions.

53.2. Use Navigraph for Navaids and Procedures

This is the default and strongly recommended mode for all simulators (see Microsoft Flight

Simulator 2020 Airports and Navdata for MSFS considerations).

This mode blends navaids and other features from the Navigraph database
with the simulator

database. This affects the map display, all
information windows and all search windows.

The following features are taken from the simulator database when using
this mode:

Airports (also Search dock window, tab Airport)

Aprons

Taxiways

Parking positions

Airport COM frequencies

The following features are taken from the Navigraph database:

Navaids (waypoints/intersections, VOR, NDB, marker, ILS and more) which affects:

Search dock window, tab Navaid

Flight plan calculation

Route Description

MORA grid ( Show Minimum off-route Altitude Grid)



Airport MSA sectors ( Show MSA Sectors)

En-route holdings ( Show Holdings)

GLS/RNV glidepaths ( Show GLS/RNP Approach Paths)

Procedures (approaches, SIDs and STARs). This affects: Search dock window, tab Procedures

and loading and display of procedures from flight plans.

Airways

53.2.1. Limitations in this mode

Little Navmap ignores any mismatches between procedures and runways
due to airport updates

and will not display a warning. Update an
airport using payware or freeware scenery if you find

that an
approach or departure procedure does not start at a runway end of an
airport.

Procedures cannot be recognized when selecting Show Procedures in
the menu if an airport has

changed its ICAO ident (e.g.
Kulik Lake: ident changed from LKK to PAKL). If you
suspect such a

case use the mode Use Navigraph for all Features
to get the procedures for the airport.

The airport search only considers procedures available
in the simulator. Switch to Use Navigraph

for all Features to
look for airports that have procedures from the Navigraph database.

Tip

Use the Navigraph navdata update for Microsoft Flight Simulator 2020
to update the scenery library

to the latest and also to keep Little Navmap
and MSFS navdata synchronized. This will reduce issues

when loading
flight plans into the simulator. See also Microsoft Flight Simulator 2020 Airports and

Navdata.

Using the fsAerodata navdata for FSX or P3D update will remove many
of the limitations above since

it will synchronize the simulator scenery
with the Navigraph database.

An extreme example for runway/procedure mismatch.
The approach from the Navigraph database cycle 1707 ends at the

not
visible runway 09 while the outdated scenery from FSX shows the airport
at the wrong position. EDVK was rebuild north

of Calden in 2013. The
OpenStreetMap backgound shows the new airport. Click image to enlarge.

53.3. Do not use Navigraph Database

Ignores the Navigraph database and shows only information read from the simulator scenery.

Note

This mode will read all navdata from the simulator scenery files.
Depending on simulator there are

limitations.

This means missing one-way airways, no airway maximum altitude restrictions, some radio navaid

types missing and more for FSX, P3D and MSFS simulators. You might also experience errors in the



airway system
and broken procedures.

MORA grid ( Show Minimum off-route Altitude Grid), airport MSA sectors ( Show MSA Sectors), en-

route holdings ( Show Holdings) and
GLS/RNV glidepaths ( Show GLS/RNP Approach Paths) are not

available when using this mode with with FSX, P3D or MSFS.

See also Load Scenery Library.



54.  Connecting to a Flight Simulator

The setup procedure is different for local connections and remote
(networked) connections to a flight

simulator (Remote Connection).

Little Navmap can connect directly to a flight simulator running on the
same computer. The Little

Navconnect agent is needed if Little
Navmap is used on a remote computer.

The Little Xpconnect plugin has to be installed in X-Plane to allow both Little Navmap and
Little

Navconnect to connect to X-Plane.

54.1. Local Connection

54.1.1. All Simulators

Open the connection dialog in Little Navmap by selecting Tools ->
Flight Simulator Connection in the

main menu and choose the
simulator to which the connection should be established.

Little Navmap connect dialog set up for a local
connection to FSX, P3D or MSFS on the left and X-Plane on the right.
The

connection will be established automatically.

Click on the tab corresponding to the simulator you want to connect to.

Now click the Connect button. The dialog will close and Little Navmap will
try to establish a connection in

the background to the simulator
noted in the tab header.

Clicking Close keeps all changes and closes the dialog without
establishing a connection.

Enable Connect automatically if you do not want to connect manually.
The start order of programs does

not matter if this is checked.
Little Navmap will find the simulator once it is started or when it is

already running. This is the recommended setting.

Deselect Fetch AI or multiplayer aircraft or
Fetch AI or multiplayer ships to disable the transfer of this

information to the program. This can be useful for performance reasons
if you use large amounts of AI

but do not want to see it in Little
Navmap.

This option also affects the frigate and carrier in X-Plane.

54.1.2. FSX, P3D and MSFS

No plugin or separate SimConnect installaton is needed since Little Navmap comes with its own

SimConnect library.



You will see an orange warning message if you use a X-Plane scenery library when trying to connect

to FSX, P3D or MSFS.

Important

Note that there are two builds of Little Navmap and Little Navconnect for Windows available:

Windows 64-bit: For MSFS and all X-Plane versions. Download file is LittleNavmap-win64-

2.8.2.zip for example.

Windows 32-bit: For FSX and Prepar3D. Download file is LittleNavmap-win32-2.8.2.zip for

example.

Make sure you use the right build. The 64-bit version shows only MSFS in the connection tab while the

32-bit version shows FSX and P3D.

54.1.3. X-Plane

You have to install the included Little Xpconnect plugin to use
Little Navmap as a moving map with X-

Plane 11 and X-Plane 12.

The plugin is bundled with Little Navmap but can also be downloaded
separately. See Little Xpconnect

for more information and installation instructions.

Select the X-Plane tab to connect.

You will see an orange warning message if you use a FSX, P3D or MSFS scenery library when

connecting to X-Plane.

54.2. Remote Connection

User aircraft and weather information is transferred to Little Navmap
on a remote computer by using

the Little Navconnect agent on the
flying computer.

Note

Airport weather information and winds aloft cannot be transferred across a remote
connection from

X-Plane. You can only see the current weather around the user aircraft in the Simulator Aircraft

window on the Tab Progress.

Share files and directories for X-Plane across computers and adjust loading path in Options on page

Cache and Files for remote setups.
Little Navmap watches the X-Plane 11 METAR.rwx and

global_winds.grib files as well as the X-Plane 12 Output/real weather directory for changes and
applies

updates immediately.

See Network Setup on information how to set up a remote/networked connection.

54.2.1. Start Little Navconnect on the Flying Computer

Little Navconnect is bundled together with the Little Navmap
download archive. Start Little Navconnect

(littlenavconnect.exe in Windows)
on the computer running the simulator and take note of the message

that
is printed in the logging window. You only need the colored values which
tell you the name and

address of the computer running the simulator. You
can use the IP address or the host name.

Little Navconnect can print multiple IP addresses or host names
depending on your network

configuration. This can happen if you have
Ethernet plugged in and are connected using wireless LAN

too, for
example. You have to try if you are unsure which one to use. Also make
sure to set up the

Windows firewall properly to allow communication
between littlenavmap.exe and littlenavconnect.exe on

both
computers.



Little Navconnect is
running and waiting for a Flight Simulator. It is running on the
computer win10.fritz.box with the IP

address 192.168.2.13.

Change the port in Little Navconnect’s Options dialog if you see
an error message like shown below:

[2016-07-27 16:45:35] Unable to start the server: The bound address is already in use.

Note

A common reason for failing connections are firewall settings which block the connection attempts.

54.2.2. Start Little Navmap on the Client / Remote Computer

Open the connection dialog in Little Navmap by selecting Tools ->
Flight Simulator Connection in the main

menu.

Connect dialog with correct values to access the
computer running the simulator and Little Navconnect as shown above.

Now do the following after opening the dialog:

1. Click the Remote / Network tab.

2. Add the value for host name. This can be either the host name or the
IP address printed by

Little Navconnect.

3. Check the value for the port. 51968 is the default value and
usually does not need to be changed.



4. Click connect. The dialog will close and Little Navmap will try to
establish a connection in the

background.

Establishing a connection can take some time, depending on your network.
The aircraft will show up on

the map and on the Simulator Aircraft
dock window once a flight is set up and loaded on the simulator.

If no
flight is loaded yet (i.e. the simulator still shows the opening
screen), you will see the message

Connected. Waiting for update. in
the Simulator Aircraft dock window.

Note that it can take a while until an error is shown if you used the
wrong values for host name or port.

Selecting Connect automatically is recommended. The start order of
all three programs (simulator, Little

Navconnect and Little Navmap)
does not matter if this is checked and the programs will find each

other.

Deselect Fetch AI or multiplayer aircraft or
Fetch AI or multiplayer ships in Tools -> Options of Little

Navconnect to disable the transfer of this information across the
network. This can be useful for

performance reasons if you use large
amounts of AI but do not want to see it in Little Navmap.

54.3. Connect Dialog

Disconnect: Disconnect the current session and stop automatic
reconnect.

Connect: Try to connect. An error dialog will be shown if no
connection can be established. Little

Navmap will constantly try
again if Connect automatically is enabled.

Close: Close the dialog without any changes to the current
connection status.

Connect automatically: Little Navmap will try to connect
constantly if this is enabled. This is the

recommended setting.

All connection attempts will stop immediately if you deselect this
button.

You have to click Connect once to start the automatic
connection attempts after checking

this button.

Update Time Interval: Allowed range is 50 milliseconds up to 1
second. Little Navmap fetches data

from a simulator using this time
interval. Increase this value if you experience stutters or lag in

the simulator. A lower value will result in more fluid map updates in
Little Navmap.

Fetch AI or multiplayer aircraft and
Fetch AI or multiplayer ships: Disables fetching of AI vehicles.

These settings are applied immediately.

AI Fetch Radius: Limits the number of AI aircraft around the user aircraft.
Only for FSX, P3D and

MSFS.



55.  Options

This dialog consists of several pages with configuration options which
can be selected in the list on the

left side. Each entry in the page
list has a tooltip for easier navigation.

Note that scroll bars can show up at the left or the bottom of a options page.
Scroll to see hidden

options.

Tip

Most options are self-explaining and tooltips contain more information in most cases.
Hover the

mouse over a button or input field for a more detailed description.

The button Restore Defaults restores only the options of this dialog
back to default. Other settings like

map display, table views or dock
window positions are not affected. You can press Cancel to close the

dialog and undo this action.

To reset all saved settings completely see Reset all Settings and Restart.

The following chapters give a brief description of each page.

Using the help button in the options dialog window jumps directly to the related chapter for a page.

Tip

You can immediately check the effect of your changes on the map display
by moving the dialog

Options to the side and pressing Apply.

Note

The menu entry which is referenced as Tools -> Options in this manual
for Windows and Linux
can be

found in the application menu at Little Navmap -> Preferences on macOS.

55.1.  Startup and Update

Allows to customize what should be loaded and shown on startup of
Little Navmap.

55.1.1. Load last used flight plan

This function allows to restore the last saved or edited flight plan on startup.

Selected

The last saved flight plan file or the last edited flight plan will be reloaded on startup.

You can exit Little Navmap without saving a new plan. All changes will be restored on next

startup.

Little Navmap will also not ask to save an already saved but changed plan on exit but instead

saves the changes to a temporary file.
The changes and the last saved file will be restored on next

startup.

Not selected

The last saved flight plan will not be reloaded on startup.

Little Navmap will ask to save a plan on exit if it has been changed.



55.1.2. Update Check

You can also configure the frequency of the automatic update check and
channels. See chapter Updates

for more information.

Important

Always update Little Navmap to the latest version which usually contains many improvements and

bug fixes.
Old versions are not supported.

55.2.  User Interface

This page contains options to force the program language and locale
settings (number, date and time

formats) to English if you do not want
to use a translated user interface.

55.2.1. Language

Allows to choose the language freely among the supported translations. Note that some translations

are incomplete which might result in a mix of English and translated phrases in the user interface.

You have to restart Little Navmap for this change to take effect.

55.2.2. Raise related windows on actions. Show flight plan after opening file, for example.

This will open related windows and raise tabs on actions like
opening files, modifying the flight plan and

other operations.

This can he helpful for new users.

55.2.3. Raise and activate docking windows when moving the mouse over it

Raises dock windows when hovering the mouse over it. This can be helpful if you have multiple floating

dock windows opened.

See also Dock Windows.

55.2.4. Raise and activate the main program window when moving the mouse over it

Raises the main window of Little Navmap when hovering the mouse over it.
This will steal the focus of

other programs and activate Little Navmap which might cause unwanted effects.
Therefore, try this out

before using it.

See also Dock Windows.

55.3.  Display and Text

Various user interface related settings.

55.3.1. User Interface Font

You can change the font for the whole user interface of Little Navmap.

The setting is applied immediately. Press Cancel or Reset Font to Default to revert back to previous.

The font for map display is not affected by this value and can be set separately on page Map Display.

Warning

Keep in mind that using a wrong or too large font can result in display issues.



Tip

Try out the B612 Font family [https://b612-font.com/] which is an
open source font family designed and

tested to be used on aircraft cockpit screens.

55.3.2. Enable high DPI monitor support

Toggle this is you have problems with scaled fonts on Windows,
cannot shrink the main window or

other issues.

You have to restart Little Navmap after changing.

55.3.3. Disable tooltips for whole application

Disables tooltips for the whole application except for the map window which has separate settings on

page Map.

Useful for experienced users.

55.3.4. Text Size

Change default text size for various information displays.

Tip

You can temporarily resize the text in information windows by using Ctrl+Wheel.
This change is not

saved.

55.4.  Units

You can change all units that are used by Little Navmap on this page
between nautical, imperial and

metric. Mixed settings like meter for
altitude and nautical miles for distance are possible.

Show other fuel units too: Shows kilogram and liter as small text
besides main units if lbs and

gallon are selected and vice versa.
This is applied only to the most important fuel values like

block and
trip fuel, for example.

Show true course and heading besides magnetic course in information displays:
Add true heading as

small text besides magnetic heading displays.
This applies to information, progress as well as

map display (traffic
patterns and holds).

Note

See Signed Decimal Formats for more information when using Latitude and Longitude with sign
or

Longitude and Latitude with sign since these modes also affect coordinate input.

The format Degree, Decimal Minutes for Google is useful for input into Google Maps or Google Earth.

Warning

Note that any numbers used in the program are not converted when
changing units. That means

that you will get a minimum altitude buffer
of 1,000 meter after changing the setting Altitude and

Elevation from
feet to meter. This also applies to flight plan altitude. Therefore, do
not forget to adapt

these numbers after changing units.

55.5.  Map

https://b612-font.com/


Has map related customization options. Allows to set the tooltips,
scroll performance and more.

Hover the mouse above buttons and input fields to see more information.

55.5.1. Allow to undock the map window

Allows to undock and put the map window into a floating state which also results in more
flexibility

when positioning other dock windows.

This can cause several unwanted effects when arranging dock windows.
Uncheck this if you do

experience problems when resizing dock windows.

You have to restart the program after changing this option.

See Window Layout for more information about window layouts which might be affected by this option.

Important

You need to reset the window layout in case the map window is missing after a restart.
Use menu

Window -> Reset Window Layout in the main menu to clean up the layout.

55.6.  Map Navigation

Contains all options for moving and zooming around in the map as well as
click sensitivity and zoom

distances.

Three navigation modes are available. Tooltips give more information
about these.

55.7.  Map Display

This page contains options for symbol sizes, text sizes, flight plan,
user aircraft trail colors and more.

Use the scroll bar on the right to see more hidden options at the bottom.

Symbol allows to adjust icon size of a feature type, Text can be used to adjust label size
independent of

the symbol, Text Background places the labels in a white rectangle if
selected and Line Width adjusts flight

plan and other line thickness.

Change colors by clicking on the colored buttons.

The option Hide aircraft on ground can be used to avoid hiding aircraft on ground at higher zoom levels.

Disabling this can help
to avoid hidden AI if traffic tools do not update the on-ground status of aircraft

properly.

55.7.1. Map and Elevation Profile Font

You can change the font for the map display. The font will also be used in the elevation profile.

55.8.  Map Display Flight Plan

Change display options affecting map and partly elevation profile display.
In the tooltips you will find

information about whether the corresponding setting affects the altitude profile or not.

Input fields are the same types as on page Map Display.

55.9.  Map Display User



More display options for user features like range rings, measurment lines, highlights, userpoints and

more.

Input fields are the same types as on page Map Display.

55.10.  Map Display Labels

This page contains a tree view that allows to select
the text labels that should be shown at airports,

user aircraft,
AI/multiplayer aircraft and other map features.

Furthermore airport details like aprons or taxiways can be enabled or disabled in the branch Airport

Details.

The dialog uses a tree. See Trees for more information about this type of input element.

55.11.  Map Display Keys

On this page you can enter login information, tokens or API keys for map services which need an user

account.

The required keys shown are extracted from the installed map themes. See Map Themes for more

information about map themes.

The following map themes requiring an account come with Little Navmap:

Mapbox [https://account.mapbox.com] also allows user customized maps in Mapbox Studio. See the

Mapbox page for help.
Click Add Mapbox User Map to add an user styled map to Little Navmap.

Thunderforest [https://www.thunderforest.com/]

Maptiler [https://www.maptiler.com/]

A restart might be needed after changing keys.

Click one of the following links to go directly to the account pages of the respective map services. You

need to sign in.

Warning

Do not show these keys publicly in forums on screenshots.

55.11.1. Map Web Service Configuration

Click the images to enlarge.

55.11.1.1. Mapbox

https://account.mapbox.com/
https://www.thunderforest.com/
https://www.maptiler.com/


Location of the Mapbox access token on the Mapbox Account page [https://account.mapbox.com/].
Use this as Value for

Mapbox Token.

Location of the Mapbox Studio URL on the Mapbox Studio page [https://studio.mapbox.com/]
Insert this URL into the Add

Mapbox User Map dialog window to add an user styled map to Little Navmap.

55.11.1.2. Thunderforest

https://account.mapbox.com/
https://studio.mapbox.com/


Thunderforest Console [https://manage.thunderforest.com/dashboard] with API key.
Use this as Value for Thunderforest

API Key.

55.11.1.3. Maptiler

Maptiler Cloud Account API key page [https://cloud.maptiler.com/account/keys/].
Use this as Value for MapTiler API Key.

55.12.  Map Display Online

This page allows to change the default center circle sizes for online
centers.

Two options below Online Center Boundary Lookup in User Airspaces
can be used to assign OpenAir airspaces

from the user airspace database
to centers by matching filename or airspace name with the callsign of

the center.

By airspace name vs. callsign: Use the airspace name within a
file to assign the geometry to a

center by callsign.

By airspace file name vs. callsign: Use the airspace filename
minus the .txt extension to assign

the geometry to a center by
callsign.

See Online Airspaces for more
information.

55.13.  Simulator Aircraft

https://manage.thunderforest.com/dashboard
https://cloud.maptiler.com/account/keys/


Allows to change various aspects around the display of the user aircraft

55.13.1. Simulator Aircraft Updates

Settings resulting in a more fluid aircraft display
will use more CPU and can potentially induce stutters

in the simulator.

55.13.2. Aircraft Centering Options

This chapter explains the various options to modify the map updates while flying.
The idea is to reduce

manual scrolling or zooming as much as possible while piloting the aircraft.

Read the chapters below if you find the behavior confusing (i.e. map jumping
unexpectedly). Otherwise

leave the default values.

See User Aircraft Centering for general information about aircraft centering while flying.

55.13.2.1. Center map on aircraft and next flight plan waypoint

The map is zoomed to show both the aircraft and the next active waypoint
on the flight plan if this is

enabled while flying. Little Navmap uses
several criteria to minimize map updates in this mode.

The map will fall back to the default mode of simply centering the
aircraft if one of the conditions below

is true:

No flight plan loaded.

Aircraft is on ground (no active magenta leg).

Aircraft distance to flight plan is more than 40 NM (active magenta leg disappears).

You can change the zoom freely if the fall back is active.

55.13.2.2. Do not use box mode for following the aircraft. Move the map constantly.

Map will follow the aircraft constantly when checked. This is also used
for Center map on aircraft and next

flight plan waypoint.

This option will cause Little Navmap to consume more CPU resources
while flying.

55.13.2.3. Simulator aircraft scroll box size (percent of map window size)

Smaller values keep the aircraft centered and will move the map more
often. Larger values will update

the map only when aircraft reaches map
boundary.

This setting is only applicable if Center map on aircraft and next flight plan waypoint above is disabled.

55.13.2.4. Allow scrolling and zooming in the map and jump back to aircraft after

This setting allows a user to move around in the map without the need to manually disable the
aircraft

centering.

Time until aircraft following is activated again after any manual map
interaction like scrolling or

zooming.

You cannot move the user aircraft out of view if this option is disabled. The map will jump back

immediately.

This option is also used in the Elevation Profile.

Allow scrolling enabled:

The map will stop following the aircraft for the given time if the user
does any interaction with the

map like scrolling or zooming. You can
quickly check out the destination or your overall progress,

and after
you stop moving around, Little Navmap will return to following your
aircraft.

This option is also used in Elevation Profile.



Toggle  Center Aircraft on and off if you find that
the map jumps back to the wrong position.

Allow scrolling disabled:

Map will constantly follow the aircraft and will not allow moving away from it.

The aircraft centering will be switched off only when using one of the
following functions:

Double-click into a table view or map display to zoom to an airport or a navaid.

Context menu item Show on map.

Goto Home or Goto Center for Distance Search.

Map link in Information dock window.

Show Flight Plan, when selected manually, or automatically after loading a flight plan.

Centering a Google Earth KML/KMZ file after loading

This allows a quick inspection of an airport or navaid during flight. To
display the aircraft again use

Map Position Back ( Map Position Back/Forward) or enable
Keep User Aircraft Centered again.

55.13.2.5. Zoom out on takeoff

Zooms out to a fixed zoom distance when a takeoff is detected.

This setting is only applicable if Center map on aircraft and next flight plan waypoint above is disabled.

55.13.2.6. Zoom in on touchdown

Zooms in to a fixed zoom distance to show airport details when a takeoff is detected.

55.13.2.7. Scroll flight plan table back to active leg after

The active (magenta) leg will be moved to the top of the flight plan table
when a new leg is activated

or there is no interaction with the table for the given time period.

55.13.2.8. Clear selection in flight plan table after

The selection in the flight plan table and highlights on the map will be cleared
after there is no

interaction with the table for the given time period.

55.13.2.9. Highlight active flight plan legs

Shows active flight plan legs in magenta color (default) on the map and in the flight plan table.

55.13.2.10. Maximum number of aircraft trail points:

Limits the number or aircraft trail to avoid performance issues when showing a too large number of

trail points.

55.14.  Flight Plan

Here you can set preferences for flight plan calculation or change the
default filename for saving flight

plans in LNMPLN format.

Note

Note that the default filenames for exporting flight plans from the menu File are set in in the

Multiexport Options Dialog.

55.14.1. Avoid overwriting Flight Plan with not matching departure and destination

Check this option to avoid overwriting LNMPLN files with wrong flight plans after changing,
departure,

destination or any other parameter used in the flight plan file.



The dialog Save Flight Plan as LNMPLN will show up instead of overwriting
the current flight plan when

you reverse the route, for example.

55.14.2. Pattern for default LNMPLN flight plan names

Allows to customize the default file name which is proposed on first save of LNMPLN files ( Save Flight

Plan and Save Flight Plan as LNMPLN).

See Flight Plan Multiexport for more information about how to customize the default file names for

other flight plan formats which can be exported.

Error messages and an example is shown below the input field.

This applies to new filenames when saving LNMPLN flight plans.
The file suffix .lnmpln is added

automatically.

The default value is PLANTYPE DEPARTNAME (DEPARTIDENT) to DESTNAME (DESTIDENT).

The input field falls back to the default if it is left empty or has errors.

The following variables are recognized:

PLANTYPE: Text IFR or VFR depending on Flight Plan Type.

DEPARTIDENT: Departure airport ident

DEPARTNAME: Departure airport name

DESTIDENT: Destination airport ident

DESTNAME: Destination airport name

CRUISEALT: Cruise altitude in selected unit (meter or feet).

All variables have to be entered in upper case letters. Other characters are used as entered.

55.14.2.1. Short

This button sets the flight plan file pattern to the short name DEPARTIDENT DESTIDENT.

Example: EDDF LIRF.lnmpln.

55.14.2.2. Long

This button sets the flight plan file pattern to the long name PLANTYPE DEPARTNAME (DEPARTIDENT) to DESTNAME

(DESTIDENT).

Example: IFR Frankfurt am Main (EDDF) to Fiumicino (LIRF).lnmpln.

55.15.  Weather

Choose which weather services should be used to fetch and show METAR for airports in information

window and map tooltips.

The weather type Flight Simulator will either display weather from
the FSX or P3D connection or from X-

Plane’s weather files.

The weather for a service is downloaded or read on demand when you enable the corresponding

service for tooltips or information panels.

Online weather is downloaded and updated every ten minutes.

Note

Simulator weather is not supported for Microsoft Flight Simulator 2020.



55.16.  Weather Files

Active Sky can only be selected if either Active Sky Next, AS16,
Active Sky for Prepar3D v4 or Active

Sky XP are installed or the
weather file is selected directly. Selecting the Active Sky weather
file

directly can be useful if you run a networked setup. Use Windows
shares or a cloud service to get

access to the file on the remote
computer.

The URLs of various weather services can be modified if you like to use
another source. Usually there is

no need to change these values.

You can change the path to the X-Plane weather files if you’d like to
load it on a remote computer using

a network share.

The buttons Test for the online weather services can also be used to
find out if Little Navmap can

connect to Internet. Check your firewall
settings if these fail.

Use Reset to set a value back to default if you change something accidentally.

Note

While this happens rarely, some public services like NOAA might be interrupted for hours.
Little

Navmap will show error messages if this is the case.

You might want to check you internet access but otherwise ignore these if
it does not happen for a

longer time.

55.17.  Online Flying

This page allows to change settings for online networks.

VATSIM, IVAO and PilotEdge provide pre-configured options to connect to the services.

Use Custom with status file if you have a status file pointing to whazzup.txt files.
Use Custom if you’d like to

load a whazzup.txt file directly.

See Online Networks for an overview.

Tip

The custom options can be used for internal networks or tools like the Transmitter

[https://virtualflight.online/transmitter/]
which can be used for small flying groups and MSFS which does not

provide multiplayer traffic on its interface.

55.17.1. Online Service

55.17.1.1. None

Disables all online services and hides all related window tabs, menu
items and toolbar buttons. No

downloads will be done.

55.17.1.2. VATSIM

Uses the predefined configuration for the
VATSIM [https://www.vatsim.net] network. No other settings are

needed.

The update rate depends on configuration and is typically three minutes.

55.17.1.3. IVAO

https://virtualflight.online/transmitter/
https://www.vatsim.net/


Uses the predefined configuration for the IVAO [https://ivao.aero]
network. No other settings are needed.

The update rate depends on configuration and is typically three minutes.

55.17.1.4. PilotEdge

Configuration for the PilotEdge [https://www.pilotedge.net/]
network.

55.17.1.5. Custom with Status File

This option allows to connect to a private network and will download a
status.txt file on startup which

contains further links to e.g. the
whazzup.txt file.

55.17.1.6. Custom

This option allows to connect to a private network and will periodically
download a whazzup.txt file which

contains information about online
clients/aircraft and online centers/ATC.

55.17.2. Web Addresses

55.17.2.1. Status File URL

Web address of the status.txt file. You can also use a local path like

C:\Users\YOURUSERNAME\Documents\status.txt.

This file is downloaded only on startup of the Little Navmap.

A button Test allows to check if the URL is valid and shows the
first few lines from the downloaded text

file. This does not work with
local paths.

The status file format is explained in the IVAO documentation library:
Status File
Format

[https://doc.ivao.aero/apidocumentation:whazzup:statusfileformat].

55.17.2.2. Whazzup File URL

Web address of the whazzup.txt file. You can also use a local path like

C:\Users\YOURUSERNAME\Documents\whazzup.txt.

This file is downloaded according to the set update rate.

A button Test allows to check if the URL is valid. The test
does not work with local paths.

The whazzup file format is explained in the IVAO documentation library:
Whazzup File
Format

[https://doc.ivao.aero/apidocumentation:whazzup:fileformat].

whazzup.txt example:

 !GENERAL


 VERSION = 1


 RELOAD = 1


 UPDATE = 20181126131051


 CONNECTED CLIENTS = 1


 CONNECTED SERVERS = 41





 !CLIENTS


 :N51968:N51968:PILOT::48.2324:-123.1231:119:0:Aircraft::::::::1200::::VFR:::::::::::::::JoinFS:::::::177:::





 !SERVERS


 ...


55.17.2.3. Update Every

Sets the update rate that defines how often the whazzup.txt file is
downloaded.

Allowed values are 1 to 1,800 seconds.

You can use smaller update rates for private online networks to improve
map display updates.

https://ivao.aero/
https://www.pilotedge.net/
https://doc.ivao.aero/apidocumentation:whazzup:statusfileformat
https://doc.ivao.aero/apidocumentation:whazzup:fileformat


Warning

Do not use update rates smaller than two minutes for official online
networks. They might decide to

block the application or block you based
on your internet address if downloads are excessive.

55.17.2.4. Format

IVAO or VATSIM. Depends on the format used by your private
network. Try both options if unsure or you

see strange effects like all aircraft pointing to the north.

55.18.  Web Server

Configuration options for the internal web server of Little Navmap.

Document root directory: The root directory of the web server
pages. Change this only if you would

like to run a customized web
server using your own style sheets and you own HTML templates.

Select Directory ...: Select root directory. Little Navmap will
show a warning if no index.html file is

found in the root
directory.

Port number: Default 8965. That means you have to use the address
http://localhost:8965/ in your

browser to access the web page of
Little Navmap, for example. Change this value if you get

errors
like
Unable to start the server. Error: The bound address is already in use..

Use encrypted connection (HTTPS / SSL): Encrypted connections use
a pre-computed self-signed

certificate which comes with Little
Navmap. A browser will show an error message if using this

certificate and requires to add a security exception. The encrypted
address is

https://localhost:8965/, for example. Creating a self
signed certificate is quite complex. Look at

the various web articles
by searching for How to create a self signed certificate.

Start Server: Start or stop the server to test the changes above.
The server status (running or

not running) is reverted to the
previous state when pressing Cancel in the options dialog.

Label Web Server is running at http://my-computer:8965 (IP address http://192.168.1.1:8965):
Shows two

links to the web server. Clicking on either one opens the page in
your default browser. You can

always try the IP address link if the
first link using the computer name does not work.

See Web Server for detailed information.

55.19.  Cache and Files

55.19.1. Map Display

Here you can change the cache size in RAM and on disk. These caches are
used to store the

downloaded images tiles from the online maps like the
OpenStreetMap or OpenTopoMap.

All image tiles expire after two weeks by default and will be reloaded from the
online services then.

You can delete the files manually using your file manager.
You can also open the cache directory from

menu Tools -> Files and Directories -> Show Map Cache or by
clicking on the button Show Disk Cache in

File Manager.

The RAM cache has a minimum size of 100 MB and a maximum size of 2 GB.

The disk cache has a minimum size of 500 MB and a maximum size of 8 GB.

See chapter Disk Cache for information on cache locations.



The map cache directory on Windows showing caches for four map themes. Delete all or any of these to save space.
Click

image to enlarge.

55.19.2. Map Display Themes

You can select a directory to lookup additional map themes for the background map layer.
Each map

theme has to consist of a directory containing the related .dgml and other files.
See Map Themes for

installation instructions.

External map themes are ignored if this field is empty.

55.19.3. Install GLOBE elevation data

The online elevation data which is used per default contains several known errors.
Therefore, it is

recommended to use the freely downloadable GLOBE offline elevation data.

The bottom part of the page Cache and Files in the options dialog allows to install the elevation data

from the
GLOBE - Global Land One-km Base Elevation Project [https://ngdc.noaa.gov/mgg/topo/globe.html] .

Follow the instructions below to install the GLOBE elevation data:

1. Click the link in the dialog or click
here [https://ngdc.noaa.gov/mgg/topo/globe.html] to open the page. Click

Get data on the web page and
then Any or all 16 "tiles". Then click All Tiles in One .zip file to

download the file.

The direct download link is all10g.zip [https://ngdc.noaa.gov/mgg/topo/DATATILES/elev/all10g.zip].

2. Extract the downloaded file all10g.zip to an arbitrary place like ...\Documents\Little Navmap\GLOBE.

You can also use the folder which is suggested by the Directories dialog.
As a result you will get

a folder all10 containing files a10g to p10g.

3. Open the options dialog in Little Navmap and click on  Cache and Files on the left side.

4. Select Use Offline GLOBE Elevation Data on the Cache and Files page in the options dialog.

5. Now select the extracted directory all10 using the Select GLOBE Directory ... button on this options

page.
The label in the options dialog will show an error if the path is not correct.

6. Click Ok if the path was recognized and the label below shows Directory and Files are valid.

55.20.  Scenery Library Database

Allows to configure the loading of the scenery library database.

https://ngdc.noaa.gov/mgg/topo/globe.html
https://ngdc.noaa.gov/mgg/topo/globe.html
https://ngdc.noaa.gov/mgg/topo/DATATILES/elev/all10g.zip


Note that these paths apply to all Flight Simulators, FSX, P3D, MSFS and
X-Plane.

You have to reload the scenery database in order for the changes to take
effect.

Little Navmap supports linked scenery which is linked by Symbolic links (all operating systems),

Windows shortcuts, Windows junctions and macOS aliases. Note that this functionality is limited to
the

MSFS Community and X-Plane Custom Scenery directories. Other combinations are not tested.

55.20.1. Scenery library directories to include when loading

This list shows extra directories which are loaded additionally when reading the simulator scenery

library.
Add-on airports in the extra directories extending MSFS Community, X-Plane Custom Scenery or

FSX/P3D Addon Scenery are
read when loading the simulator scenery library database.

Note that airport files in this list are always read last which can affect the display in MSFS, FSX or P3D.

Note

The add-ons must be at the top level for the selected directory and will not be read recursively.

55.20.2. Scenery library directories or files to exclude from loading

All directories including sub-directories as well as files in this list will be omitted
when loading the

scenery library into the Little Navmap database. You
can also use this list to speed up database loading

if you exclude
directories that do not contain airports or navaids (landclass,
elevation data and others).

You can also exclude FSX, P3D, MSFS BGL or X-Plane apt.dat files if needed.

Select one or more entries in the list and click on Remove to delete
then from the list.

Tip

Note that you can select more than one entry in the file
dialog to add several entries at once.

55.20.3. Scenery library directories to exclude from add-on recognition

FSX/P3D: All scenery data that is found outside of the base flight
simulator Scenery directory is

considered an add-on and will be
highlighted on the map as well as considered during search for add-

ons.

X-Plane: All airports in the Custom Scenery directory are
considered add-on airports and will be

highlighted accordingly.

Microsoft Flight Simulator 2020: All airports located in the Community
directory and the

Official\OneStore or Official\Steam are considered to be add-on airports.
Exceptions are fs-base, fs-base-

genericairports and fs-base-nav.

You can use this list to modify this behavior.

Add-ons, like Orbx FTX Vector or fsAerodata add scenery files that
correct certain aspects of airports

like elevation, magnetic declination
or others. All these airports will be recognized as add-on airports

since all their files are not stored in the base flight simulator
Scenery directory.

Insert the corresponding directories or files into this list to avoid
unwanted highlighting of these

airports as add-ons.



Page Scenery Library Database with three
directories and three files excluded from loading and two directories
excluded

from add-on recognition.

55.20.4. Examples

Provided your simulator is installed in C:\Games\FSX.

55.20.4.1. ORBX Vector

Exclude the directories below from add-on recognition. Do not exclude
them from loading since you will

see wrong airport altitudes.

C:\Games\FSX\ORBX\FTX_VECTOR\FTX_VECTOR_AEC

C:\Games\FSX\ORBX\FTX_VECTOR\FTX_VECTOR_APT

55.20.4.2. Flight1 Ultimate Terrain Europe

Exclude these directories from loading to speed up the process:

C:\Games\FSX\Scenery\UtEurAirports

C:\Games\FSX\Scenery\UtEurGP

C:\Games\FSX\Scenery\UtEurLights

C:\Games\FSX\Scenery\UtEurRail

C:\Games\FSX\Scenery\UtEurStream

C:\Games\FSX\Scenery\UtEurWater

55.20.4.3. ORBX Regions

Exclude these directories from loading:

C:\Games\FSX\ORBX\FTX_NZ\FTX_NZSI_07_MESH

C:\Games\FSX\ORBX\FTX_NA\FTX_NA_CRM07_MESH

C:\Games\FSX\ORBX\FTX_NA\FTX_NA_NRM07_MESH

C:\Games\FSX\ORBX\FTX_NA\FTX_NA_PNW07_MESH

C:\Games\FSX\ORBX\FTX_NA\FTX_NA_PFJ07_MESH



56. Window Layout

The layout of dock windows and the main window can be saved and loaded. This allows to quickly

change or restore the whole look of the application.

Little Navmap restores the window layout on each startup to the last one used.

You can also instruct Little Navmap to load the recently used layout file on top of the
Recent Window

Layouts on startup. This can be enabled in options on page Startup and Update by checking
Load window

layout from last used file.

Window layouts cover these aspects:

Main window position and size

Size, position, visibility (open or not) and state (floating or docked into main window) of all dock

windows

Size, position and visibility (open or not) or Toolbars.

Statusbar visibility

The main menu cannot be hidden to avoid user lock out.

The state of the fullscreen screen mode and the normal display mode are saved together in layout files.

See also Dock Windows.

Note

Layouts cannot be exchanged with different settings for Allow to undock the map window in the

options dialog.

Little Navmap will show a warning when loading a layout that was saved with Allow to undock the

map window enabled
and Allow to undock the map window is currently disabled, for example.

56.1. Saving and Loading Layouts

The window layout can be loaded from and saved to LNMLAYOUT files.

Instead of using the menu item Open Window Layout
you can also drag and drop a LNMLAYOUT file

from a file manager into the Little Navmap main
window. This will load and apply the layout

immediately.

You can save a layout file using Save Window Layout as to an arbitrary place. Using the documents

folder
is recommended. You can use the folder which is suggested by the Directories dialog.

Recent Window Layouts allows to quickly access the last save window layout files.

56.2. Reset Layout

You can use Reset Window Layout to reset the window layout back to a reasonable default.
This will

load and apply the layout immediately.

56.3. Fullscreen

You can toggle fullscreen from the menu Window -> Fullscreen Map or by pressing Shift+F11.

Additionally, you can use the map context menu ( Fullscreen Map) or the button Exit
fullscreen mode to

exit fullscreen mode and return to normal mode.

Fullscreen maximizes the map window and hides all other dock windows and toolbars per default.
The

main menu cannot be hidden and is always visible.



You can still reopen dock windows and toolbars after switching to fullscreen mode. This can be done

from the
Window Menu or by selecting Show Information in the map context menu, for example.
These

dock windows will be saved on exit or when saving a window layout.
The dock windows will be restored

at the same position when you enable fullscreen mode again.
This way you can have two different

views. One for planning with all docks and one for flying with map and progress, for example.



57. Weather

Little Navmap can display weather as METARs and decoded weather in the
information window and

tooltips as well as weather symbols on the map.

Weather can be taken from the following sources:

FSX or P3D if connected. This also applies to network setups.

X-Plane 11 and 12 real time weather from weather files. You have to share files and directories

across computers and adjust loading path in Options on page Cache and Files for remote setups.

NOAA [https://www.weather.gov] online weather service

VATSIM [https://www.vatsim.net] network online weather service

IVAO [https://www.ivao.aero] network online weather service

HiFi Simulation Technologies [https://www.hifisimtech.com]:

Active Sky Next (ASN)

AS16

Active Sky for Prepar3D v4 (ASP4)

ASX for X-Plane

Weather files are accessed or downloaded on demand when an option in menu Show Airport Weather

or Weather Menu is selected.

Important

The base path to the simulator has to be correct for Little Navmap to find the X-Plane weather files.

Click Reset Paths in the Dialog Load Scenery Library to ensure a correct path.

Furthermore you have to select the right simulator in the Scenery Library Menu.
Little Navmap

otherwise reads the wrong weather files.

Features like regions of manually created weather for X-Plane are not supported in Little Navmap.

Weather display and information can be selected in the following locations:

Options dialog on page Weather: There you define what source is shown in the information

window and in the map tooltip. This is based on the airport METAR reports and does not affect

anything else besides the information window and the map tooltip.

Main menu Weather -> Airport Weather Source: This is for the airport weather icons on
the map.

Based on METAR of the airport and only affects the weather symbols on the map.

Main menu Weather -> Wind source: This source is used for all winds aloft functions:
Map display

wind grid symbols, map tooltip, flight plan table, elevation profile (hover tooltip),
top of descent

and top of climb point calculation, fuel planning,
arrival time calculation and trip time

calculation. Note that this
download has nothing to do with the METAR functions above and is

fetched from another source
(NOAA/NOMADS [https://nomads.ncep.noaa.gov]).

METARs are shown in the airport tooltips and on the tab Airport -> Overview
tab. Decoded weather

information for all sources is available in the tab
Airport -> Weather.

The date and time information of the decoded weather display is
highlighted in red if the METAR

information is older than six hours.

Note

About X-Plane weather: The
program cannot read custom weather situations from X-Plane. If you

use
custom weather, Little Navmap only has access to the local weather
around the aircraft in the

Simulator Aircraft window on the
Tab Progress. Be aware that Little Navmap might display
information

from an obsolete or inactive downloaded weather file in this case.

https://www.weather.gov/
https://www.vatsim.net/
https://www.ivao.aero/
https://www.hifisimtech.com/
https://nomads.ncep.noaa.gov/


Also, weather and nearest weather in X-Plane might be inaccurate. This
is due to interpolation

between weather stations.

Decoded weather information from X-Plane and NOAA.
The weather symbols on the map use NOAA as source (suffix - Map

after the flight rules). X-Plane weather is older than six hours and
therefore highlighted red.

57.1. Weather Sources

57.1.1. Flight Simulator

Weather information from a flight simulator or the X-Plane weather files
falls in one of three categories,

depending on the selected airport:

Station: The airport has a weather station. This is the most
precise weather indication.

Nearest: The selected airport has no weather station and the
report from the closest existing

weather station was fetched. The
ident of the closest station as well as distance and elevation

are
shown in the METAR and on the decoded weather tab. Note that the this
weather station is

not necessarily an airport.



Interpolated (not for X-Plane): The weather is interpolated by
the flight simulator using three

stations closest to the selected
airport. FSX and P3D only provide non-interpolated weather for

airports close to the user aircraft. The weather for other airports
is always interpolated. The

ident of the selected airport is used in
the METAR report for this kind of weather report.

The flight simulator weather is updated every 15 seconds to catch manual
changes or changes in the

weather theme.

Little Navmap watches the X-Plane 11 METAR.rwx and global_winds.grib files as well as the X-Plane 12

Output/real weather directory for changes and
applies updates immediately.

57.1.2. Online - NOAA, VATSIM and IVAO

Online weather from both sources is updated every 10 minutes.

57.1.3. Active Sky

All Active Sky programs are recognized automatically on startup for
each simulator. The

current_wx_snapshot.txt and
activeflightplanwx.txt files are loaded and monitored for changes.
Weather will

be reloaded and updated in the information display if
necessary.

You can also select the current_wx_snapshot.txt file manually. In
that case the METARs from this file are

displayed for all installed
flight simulators. The activeflightplanwx.txt will be loaded from
the same

directory.

Manual file selection can also be useful if a new Active Sky version
is not supported by Little Navmap

yet.

Departure and destination weather will be displayed if a flight plan is
loaded in one of the Active Sky

programs. A suffix Destination or
Departure will indicate the usage of Active Sky flight plan weather
on

the tab Weather. This gives Active Sky users the most precise
weather indication for departure and

destination.

Note that the indication of Departure or Destination depends
entirely on the flight plan loaded in Active

Sky and not the flight
plan in Little Navmap.

57.2. Airport Weather

Little Navmap can show weather symbols for airports having a weather
station for all available weather

sources. Select sources for display
with Airport Weather Source.

Note that airport weather is only displayed for stations and not
interpolated. Stations which are not

airports are not supported.

Weather is also shown for hidden airports if these provide a weather report.

A suffix - Map is added to the flight rules in the METAR and decoded
weather display of the information

window as well as in tooltips to indicate which
source is shown on the map.

See Airport Weather in the map legend for an explanation of the symbols.



Weather situation around New York. All airports are VFR and low winds.

57.3. Winds Aloft

Little Navmap can download and display winds aloft based on either
X-Plane or the National Oceanic

and Atmospheric
Administration [https://www.noaa.gov/] data.

The latter ones are winds aloft forecasts which are updated four times a
day and are used by most

simulators and weather programs as data source.
The wind speed and direction is arranged in an one-

degree grid.

Little Navmap can display a wind barb grid for a selected wind layer
or at flight plan waypoints. Tooltips

at the wind barbs show wind
details for several layers at the position.

Hovering the mouse over the elevation profile shows the wind at the
flight plan position. See Tooltip

Label.

Winds are used to calculate flight time, trip fuel, top of
descent and top of climb.

A manual wind setting for cruise altitude can also be used. See
Buttons.

See Winds Aloft for an
explanation of the wind symbols and Weather for more configuration options.

Select wind data source for display with Wind source.

57.3.1.  Wind Levels Button

Same as Wind levels.

The menu button enables or disables wind aloft display by a wind barb
grid at different layers as well

as at flight plan waypoints.

The drop down menu has the following items:

At Flight Plan Waypoints: Toggles wind barbs with a yellow border
at flight plan waypoints on and

off. Wind barbs below 4000 ft above
mean sea level are omitted. This function is independent of

the
selection below.

No Wind Barbs: Do not show the wind barb grid. Wind data is still
downloaded and processed until

the source is set to Disabled.

Wind at Ground (only NOAA): Show the wind barb grid for winds near ground
(about 260 ft). Only

available if the NOAA wind source is selected.

Wind at Flight Plan Cruise Altitude: Show the wind barb grid for winds
at the current flight plan

cruise altitude.

Wind for Selected Altitude: Enables the slider button below and allows to change the wind barb

altitude in 500 feet steps.

57.4. Tooltips

https://www.noaa.gov/


The wind barbs show an optional tooltip with wind direction, speed and
wind source if you hover the

mouse over them. The same applies to wind barbs at flight plan waypoints with
option At Flight Plan

Waypoints enabled.

Direction is magnetic per default but can be changed in the options
dialog on page Units.
These tooltips

show the wind for all layers with flight plan cruise altitude, selected wind barb altitude and manual

layer altitude highlighted.

Winds aloft set manually, display with tooltip at wind barbs in grid and wind drop down menu.
Indicators in tooltip show

flight plan cruise altitude, wind barb altitude and manual layer altitude.
Notice the decreasing wind speed as interpolated

from manual layer altitude to ground.

Wind barbs shown at flight plan waypoints and wind data in tooltip.



58. Printing

58.1.  Print Map

Opens the print preview dialog allowing the current map view to be
printed.

Print preview dialog for the current map.

58.2.  Print Flight Plan

Print the current flight plan together with departure and destination
airport information.

58.2.1. Options

Print Table Header: Adds a header showing departure, destination
and other information like the

label on top of the tab Plan in
the dock window Flight Planning.

Print Fuel Report: Print the fuel calculation report from the tab
Aircraft in the dock window Flight

Planning.

New page after each chapter: Add a page feed after header, flight
plan, fuel report and airport

information.

Text Size: Allows to increase or decrease the size of all texts
except the flight plan table.

58.2.2. Flight Plan

Print flight plan table: Adds the flight plan to the print.

Text Size: Increase or decrease the size of the flight plan table
text.

Select Flight Plan Columns to Print: Click on the names to
include or exclude flight plan columns.

Note that the columns are printed in the same order as shown in the Flight Plan Table.



58.2.3. Options for Departure and Destination Airport

Overview: Print the airport overview as show in the
Information dock window on tab Airport.

Runways / Helipads: Print runway and helipad information.

Include runways with soft surface: Include runways with soft
surfaces like grass, gravel and others.

Detailed runway information: Include detailed information for the
runway ends like approach

lighting, VASI types, ILS information and
more.

COM frequencies: Include communication frequencies like tower,
ATIS, UNICOM and others.

Procedures: Print procedure information as shown on the tab
Procedures in the Information dock

window.

Weather: Print the decoded weather for all enabled sources as
shown on the tab Weather in the

Information dock window.

Print flight plan options dialog.



59.  Reset all for a new Flight

Use this to reset functions for a new flight. This is optional but
helpful if you wish to record logbook

entries or aircraft performance between flights.

Dialog input and selection fields:

Create an empty flight plan: Clears the current flight plan. Same as New Flight Plan.

Delete user aircraft trail: Delete simulator aircraft trail from map and elevation profile.
and

elevation profile. The same as Delete User Aircraft Trail.

Reset active flight plan leg: Removes the active (magenta) flight plan leg.

Restart the aircraft performance collection: Restarts the background
aircraft performance

collection. Same function as Restart Aircraft Performance Collection.

Reset flight detection in logbook: Resets the logbook to detect
takeoff and landing for new logbook

entries.

Range rings, Measurement lines, Holdings, Traffic patterns and MSA diagrams:
Removes the respecive

user features from the map. Same as Remove all Range Rings and following.

The dialog shows a scrollbar on the right side if it is too small.

Resetting Little Navmap functions for a new flight.



60.  Updates

Little Navmap will automatically check its home
page [https://albar965.github.io/] for available updates on

startup and in regular time intervals.
Frequency and update channels are configurable. See below for

configuration options.

You can always check manually for updates by selecting Help -> Check for Updates in the main menu.

Note that the installation still has to be done manually. The update notifications are suppressed
if a

dialog window is open or if Little Navmap is connected to a simulator.

Important

Always update Little Navmap to the latest version which usually contains many improvements and

bug fixes.
Old versions are not supported.

60.1. Notification Dialog

The dialog showing available update contains a message and a link pointing to the announcement. You

can download the new version from the announcement page.

60.1.1. Buttons

Remind me Later: Dismiss the dialog. You will be notified again on next startup depending on

selected frequency. You can also press the escape key to trigger this action. This button is not

visible when checking manually.

Copy to Clipboard: Copy the contents of the window as formatted text into the clipboard for later

reading. This allows to paste the message and the link into LibreOffice Writer or MS Word.

Ignore this Update: Pressing this button will close the dialog and ignore the shown version in the

future. You will not see any reminders for this version again but only for newer versions. This

button is not visible when checking manually. Note that a manual check for updates supersedes

the ignored versions.

https://albar965.github.io/


Update notification dialog showing an available release candidate version rc1 with the link to the announcement.

60.2. Options

Update check settings can be changed in the options dialog on the page Startup and Update.

60.2.1. Check for Updates

You can set the interval for update checks. Default is Daily.
Choices Daily, Weekly or Manual where the last

option will
never check automatically.

Select Help -> Check for Updates in the main menu to search
manually for new versions.

Note that the daily or weekly check is only done when starting the
program.

60.2.2. Update Channels

Stable Versions only: This will show only notifications for tested
and stable versions with a

complete English manual.

Stable and Beta Versions: Will additionally check for beta/test or relase candidate
versions. Beta

versions are program releases that already contain all
planned features for a stable release but

are still not tested
carefully. The manual might be incomplete.

Stable, Beta and Development Versions: Little Navmap will also
show notifications for

development/alpha releases. These are neither complete
nor well tested. Features might change

over time and the manual is not
updated for new functionality.

Important

Note that using a beta or a release candidate release automatically changes the channel to beta and

using a development or alpha release automatically changes the channel to development.

Always use the beta update channel if you use a beta or test version.
Otherwise you might miss

important updates.

Tip

Run beta or development version of Little Navmap in Portable Execution
mode to avoid overwriting

your settings. This allows you to run the new version
with separate settings and databases without

affecting your current settings.

60.2.3. Check for Updates now

Checks for updates immediately. This will use the current settings as
shown in the dialog. It will also

show notifications for updates that
were ignored by pressing the Ignore this Update on the notification

dialog.



Update notification settings in dialog Options.



61. Running without Flight Simulator Installation

You can use Little Navmap on all computers no matter if
SimConnect or a flight simulator are installed

or not.

Follow these steps if want to install Little Navmap on a computer
not containing a flight simulator

installation. This is useful for a networked setup,
for example. No functionality is affected except direct

connect
capability which is not needed in this case.

This scenario is typically used when connecting to a flight simulator
to watch the progress of a flight

remotely from another computer across a local network.

Flight plans can be created, loaded and saved on the client computer.
You only have to make sure that

these are transferred to the flight
simulator computer using Windows shares or by other means.

These instructions apply to Windows, macOS and Linux computers equally.

1. Install Little Navmap on both your flying computer and the client
computer without simulator.

2. Start it on the flying computer and generate the scenery library
databases. See Load Scenery

Library above for
more information.

3. Select Tools -> Files and Directories -> Show Database Files in the main
menu on the flying

computer. This will open the directory containing
the database files in a file manager like

Windows Explorer or Apple
Finder. You will find one or more database file like

little_navmap_fsx.sqlite, little_navmap_p3dv3.sqlite or
little_navmap_xp11.sqlite.

4. Exit Little Navmap on the flying computer.

5. Start Little Navmap on the client/remote computer and select
Tools -> Files and Directories ->

Show Database Files.

6. Exit Little Navmap on the client computer so you can copy the
database files.

7. Copy the database files to your client computer using network shares,
USB sticks or whatever

you like. Use the file manager windows that were opened
by the steps above.

8. Start Little Navmap on the client computer. The Scenery Library Menu
should contain an entry

for each copied database. Airport
icons should be visible on the map in either case. There is no

need
to reload the scenery library database now since you just copied a
fully

populated ready-to-user database file.

X-Plane

Share flight plan and weather directories for X-Plane across computers and adjust the loading

path in Options on page Cache and Files for remote setups.

Little Navmap watches the X-Plane 11 METAR.rwx and global_winds.grib files as well as the X-Plane 12

Output/real weather directory for changes and
applies updates immediately.

See Remote Connection for information about
networked setups.



62. Web Server

Little Navmap includes an internal web server showing the map,
aircraft progress and airport

information with an optional automatic
refresh in a web browser. The page can be accessed from any

computer,
tablet or smartphone in the local network.

Note that the functionality is limited. You cannot change map display
settings or calculate a flight plan,

for example.

The web server is not started per default. You can start it in the menu Tools ->
Run Webserver and

then open its page by selecting Open Webserver Page in Browser.

Port and other settings can be changed in options on page Web Server.

You need to adjust your router settings to access the Little Navmap webserver from the internet

outside your local network. Check out your router manual how to do this.
In general you have to

change the firewall settings to forward the port
8965 from the router to the computer running Little

Navmap.

Warning

Never open the firewall completely. This is a security risk.

62.1. Web Page

This chapter describes the legacy web interface of Little Navmap.

62.1.1. Page Links on Top of each Page

The top links Map, Flight Plan, Aircraft,
Aircraft Progress and Airport switch the display to the
respective

pages. Help opens this page.

Top navigation bar for the legacy web interface as shown in web browser. Click image to enlarge.

62.1.2. Map Page

Shows the map as currently configured, i.e. airports, navaids, theme and
more features are shown as

in the running application.

62.1.2.1. Top bar:

Manual Reload or 1 Second to 120 Seconds: Triggers a
reload of the map image for the given time.

Note that this might
drain the battery on smartphones or tablets.

Reload Map: Reload the map manually.

User Aircraft: Centers the user aircraft on the map.

Flight Plan: Centers the flight plan on the map.

Show Airport: Jumps the airport which ICAO ident is given in the
input field to the left of this

button. Press the Return key or
this button to jump to the airport.

62.1.2.2. Map Navigation

The map is divided into a 3x3 field grid. Each field has an icon in the
corner denoting its function:

 : Zoom in and out



   : Move map

: Reload map

Web map display in browser with navigation icons. Click image to enlarge.

62.1.3. Flight Plan Page

Shows the flight plan with columns visible and column order as in the
application. See Flight Plan Table.

Buttons Manual Reload or 1 Second to 120 Seconds and
Reload Map: Same as on map page above. Use reload

to see updates for
the active flight plan leg.



Flight plan table in browser. Click image to enlarge.

62.1.4. Aircraft

Shows aircraft information as Tab Aircraft.

Buttons Manual Reload or 1 Second to 120 Seconds and
Reload Map: Same as on map page above.

62.1.5. Aircraft Progress Page

Shows aircraft progress information as Tab Progress.

Buttons Manual Reload or 1 Second to 120 Seconds and
Reload Map: Same as on map page above.

62.1.6. Airport Information Page

Displays the same information as the Airport on one page.

Buttons and input fields:

ICAO: Four or three letter airport ICAO ident. Press Return
key or button Submit to show airport

information.

Submit: Loads airport information for given ICAO ident.

Reload: Reload page manually to catch weather changes, for
example.

The links Runways, Com Frequencies, Procedures and
Weather jump to the respective sections below. Click the

link
▲ Top to go back.

62.2. Web Developers

Little Navmap can deliver map images, the flight plan table and more for
HTTP requests.

See directory .../Little Navmap/web/test.html or
http://localhost:8965/test.html when running the webserver

for
examples.



63. Tutorials

63.1. General

All functions will be referred by the names in the main menu by using
Menu Name -> Menu Item. The icons

are shown as well, so you can
find the buttons on one of the toolbars. Screenshots will provide more

help.

Screenshots were made on Linux and Windows. Therefore, look and feel
might be different.

See User Interface for general information about the user interface.

Note

Flight plan distances, available procedures and airport names
might differ between the simulators

and used navdata cycles.

Select the closest procedures or runways if they differ in your setup.

63.2. Quick Start

To have a clean common base, I recommend the following:

Select Window -> Reset Window Layout and Reset Tabs to Default to get all the dock
windows and

tabs back into their default place.

Use the map theme OpenStreetMap in menu View -> Theme.

Reset the map display settings in View ->
Reset Display Settings to make sure that all needed

features are shown on the map.

Select File -> Reset all for a new Flight  and check all buttons in the dialog to start with a

clean
flight plan table.

63.3. Tutorials

1. Tutorial - Building a VFR Flight Plan: This tutorial shows
how to create a simple flight plan based

on the map and its context menu.

2. Tutorial - Building an IFR Flight Plan with Approach Procedures This long tutorial will show you

how
to create a more complex IFR flight plan including approach
procedures. It introduces the

advanced airport search functionality,
the spatial search and the automatic flight plan

calculation.

3. Tutorial - Creating an Aircraft Performance Profile This tutorial shows how to automatically

collect aircraft performance
while flying and how to merge and fine tune the result.



64. Tutorial - Building a VFR Flight Plan

64.1. General

This tutorial shows how to create a simple flight plan based on the
map and its context menus.

The flight plan is included in the Little Navmap installation directory:
.../Little Navmap/etc/Tutorial VFR

Meythet (LFLP) to Challes-les-Eaux (LFLE).lnmpln.

The airport names might differ depending on simulator.

Use the map theme Stamen Terrain in menu View -> Theme to see the mountains.
The flight will only go

through Class E airspace. There is no need to contact ATC.
Disable airspace display in menu View ->

Show Airspaces for now.

The flight takes us through the valleys of the French alps. You can
use this flight plan for any small

aircraft like the default Cessna C172 which is available for all simulators.

The flight plan is: Meythet (LFLP) / Runway 04 to Challes-Les-Eaux (LFLE) Distance 41 NM, time 0 h 24

m.

64.2. Prepare Flight

I’d recommend to get use Flight -> Reset all for a new Flight
  before each flight to get a clean

base for
fuel calculation and other functions. Uncheck
Create an empty flight plan in the dialog if your

plan is
already loaded.

64.3. Default Aircraft Performance

This tutorial does not cover creating or collecting aircraft performance
files. See Tutorial - Creating an

Aircraft Performance Profile
if you like to do this.

Therefore, we will simply use the default example performance profile based on a Cessna C172.

Select Aircraft -> New Aircraft Performance . Accept the default values by pressing OK in the

dialog.

64.4. Departure Airport

Find the departure airport: Click into the map and zoom to the French
Alps. You can use the following

functions to navigate:

The map overlay on the right.

The mouse (click and drag) to move and the mouse wheel to zoom.

The cursor keys to move and the keys + and - for zooming in
and out (click into the map window

or press F2 to activate it before using the keys).

Use the back  and forward  buttons to jump in the
position history like in a web browser.

See also Map Display.

Look for the departure airport Meythet (LFLP) around here:



Closer with tooltip:



Now:

Zoom in until you see the airport diagram showing taxiways, runway
details, parking positions

and more.

Zoom in further until you see the white parking numbers.

Right-click on the center of one of the green ramp parking spots (11
is used here).

Choose
Set Parking 11 at Meythet (LFLP) as Departure
  ( Set as Departure) in the context

menu.

The airport layout and parking spot will be different depending on used simulator.



This will select your departure parking position which will be
highlighted by a black/yellow circle. The

airport will be added to the
flight plan as departure too.

You can also click on the airport icon and select it for departure.
The airport center will be automatically

assigned as departure position.

64.5. En-Route Waypoints

Add the waypoints now:

Scroll along the valley to the south east across the lake Lac
d’Annecy.

Click Append Position to Flight Plan . The clicked position will be added as an user defined

waypoint (green rectangle)
to the end of your plan.

Click undo  or redo  in the toolbar if you don’t like what you just added.



Another function is Add Position to Flight Plan  which will insert the clicked position to the nearest

flight plan leg. You can use this to add user defined positions,
airports or navaids in the middle of a

flight plan. The nearest leg will
be chosen automatically by Little Navmap for inserting the new

position.

Little Navmap will automatically assign names to the user defined
waypoints. You can leave these as

they are or replace them with a more
meaningful name.

Waypoints using the default format WP plus number (e.g. WP1 or WP99) are automatically
renumbered to

reflect the flying order in the flight plan.

Right-click on the user waypoint and select
Edit Flight Plan Position WP1  ( Edit Flight Plan Position

or Edit Flight Plan Position Remarks) to change
a waypoint ident, name, remarks or its coordinates. Use

nearby villages, mountains,
lakes or other points of interest. Do not change the coordinates now.



Keep adding points and stay away from the mountains until you’re at
Challes-les-Eaux (LFLE).

64.6. Destination Airport

To add the destination:

Right-click on Challes-les-Eaux (LFLE)

Select Set Airport Challes-les-Eaux (LFLE) as Destination  ( Set as Destination).



Now there is a flight plan. Yours might look a bit different.

You can also use the drag and drop feature to move points or add new
ones. Enable it by checking

Flight Plan ->
Edit Flight Plan on Map  and click on a
flight plan waypoint to move it. Click on a

flight plan leg to add a new
waypoint into this leg. See Map Flight Plan Editing for information on this

function.

64.7. Cruise Altitude

Change the flight plan type to VFR if not already done.



Now check the cruise altitude:

Look at the flight plan elevation profile. There is a red line
indicating the minimum safe altitude.

Adjust the flight plan cruise altitude until you’re above the red
line.

Select Flight Plan -> Adjust Flight Plan Altitude  to get the correct altitude adjusted by the

hemispherical rule.

Note that the default hemispherical rule is not correct for France until
you change it in the options

dialog, but avoid this for the sake of
simplicity now.

You probably noticed that you will get close to ground near the
destination. Be prepared to circumvent

some mountains there.

64.8. Airspaces

Now look if your flight plan touches any airspaces.

Click into one of the airspaces nearby start and destination and have a
look at the information dock

window. There are several airspaces:

Geneva TMA Sector 8 which starts at 9,500 ft above mean sea
level (MSL). This is higher than our

cruise altitude and won’t affect
us.

Two Class E airspaces. The information window notes for these:
Controlled, IFR and VFR, ATC

clearance required for IFR only. No
problem because we will fly using VFR.

The situation is similar at the destination.

Note that you might find different airspaces depending if you use the
latest navdata or stock airspace

data.



64.9. Saving

Save the plan in the Little Navmap format LNMPLN using File ->
Save Flight Plan .
The program

usually finds the right directory for the flight plans and
gives a meaningful name by default.

The format LNMPLN is only understood by Little Navmap. You cannot load these files
into another

program. Therefore, we have to export the flight plan.

Now open the multiexport options dialog by selecting File -> Multiexport Flight Plan Options.

Right click on the simulator format you’d like to export and select Export Flight Plan now .
Save

the file to the right place. The default path is based on best guess. Adjust it as needed.

See Quick Setup for information how to quickly configure the multiexport.

64.10. Flying

Follow the steps below to get a moving map and see your aircraft in
Little Navmap:

Open the dialog Connect using Tools ->
Flight Simulator Connection  and
check if Connect

automatically is selected. Enable it if not.
Little Navmap will find the simulator no matter if it is

already
started or will be started later.

Click on the tab which corresponds to your simulator.
Image below shows the tab for FSX, P3D

or MSFS on the left
and the tab for X-Plane on the right.



Click Connect which will close the dialog.

Enable Map -> Keep User Aircraft Centered . The map will
jump to the simulator aircraft and

keep it centered if an active flight
is loaded, i.e. the simulator is not in the opening screen.

Start the simulator if not already done, load the flight plan and go flying.

Important

Make sure you use the right build of Little Navmap.
The 64-bit version shows only MSFS in the

connection tab while the 32-bit version shows FSX and P3D.

See also Connecting to a Flight Simulator.

64.11. Looking at Places while Flying

Little Navmap will keep your aircraft centered on the screen as a default setting. You can configure
this

function in the options dialog on page Simulator Aircraft.

The program will stop following your aircraft for 10 seconds if you
start any action that zooms in to an

airport or navaid (double-click,
toolbar button or link in the information window) or just simply move or

zoom around in the map.

See User Aircraft Centering for more information about aircraft centering while flying.

Double-click on the destination airport to zoom to the airport diagram,
for example. Leave Little

Navmap alone and the map will jump back to the aircraft
and next flight plan waypoint after the

timeout.



65. Tutorial - Building an IFR Flight Plan with

Approach Procedures

This tutorial will show you how to create a more complex IFR flight plan
including approach procedures.

It introduces the advanced airport search
functionality and the automatic flight plan calculation.

The flight plan is included in the Little Navmap installation directory:
.../Little Navmap/etc/Tutorial IFR

Bembridge (EGHJ) to Wick (EGPC).lnmpln.

While this tutorial looks quite lengthy it is normally a matter of half
a minute to get a flight plan if you

know where to go. The planning
effort shown here is bigger to highlight some of the more advanced

features of Little Navmap.

You should at least read through Tutorial - Building a VFR Flight Plan before doing this one.

Note

The flight plan will go across the UK using an IFR capable aircraft. Its
maximum range should be

more than 600 NM including reserves
and a cruise altitude of 10,000 ft.

Note that Bembridge has a relatively short runway of 2,729 ft. You probably need
a small turboprop

or a powerful twin.

Do not try to fly this trip with an airliner.

The tutorial assumes the following preconditions:

You left your aircraft at Bembridge (EGHJ) at the end of the last
flight or think of it as you home

base.

You don’t know where you want to fly today.

You know the requirements for your aircraft:

Maximum range

Minimum runway length

Hard runways

Needs a parking spot at the destination

Fuel for return trip

65.1. Prepare Flight

Use Flight -> Reset all for a new Flight
  before each flight to get a clean base for
fuel calculation

and other functions. Uncheck
Create an empty flight plan in the dialog if the flight plan is
already loaded.

65.2. Default Aircraft Performance

This tutorial does not cover creating or collecting aircraft performance
files. See Tutorial - Creating an

Aircraft Performance Profile if you like to do this.

Therefore, we will simply use a slightly modified aircraft performance
profile which allows to calculate

the top of climb and top of descent.

Select Aircraft -> New Aircraft Performance .

Optional: Select Edit Aircraft Performance from the same menu as above and
change the values

fuel flow and speed at climb cruise and descent to roughly match your aircraft.
Add reserve fuel

for about one hour or cruise fuel consumption for now.
This helps to get an estimate for the

traveling time. Fill the other fields too if you know the performance values.

Accept by pressing OK in the dialog.



You might see warnings in the fuel report. Ignore these for now
since the aircraft performance is

sufficient to calculate the top of
descent and top of climb for the elevation profile.

Tip

Lookup numbers at the Aircraft Performance Database

[https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?] or download a community made performance file

from Little Navmap Downloads - Aircraft Performance

[https://www.littlenavmap.org/downloads/Aircraft%20Performance/].

65.3. Cleanup Search

Go to the dock window Search and follow the steps below:

Right-click into the result table and select Reset Search  to remove of all search criteria

that may affect the query.

Click the menu button  and make sure that the search
groups Facilities, Runway and Distance

from Mark are
checked. Deselect all others you do not need.

https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?
https://www.littlenavmap.org/downloads/Aircraft%20Performance/


65.4. Assign Departure

Now look for the departure airport:

Enter EGHJ in the ICAO Code search field on the top left
(case does not matter).

Right-click on the airport in the result table.

Choose Set as Departure . This will assign the airport center point as a start position.



The flight plan has one entry now. This is already sufficient if you
want to fly a pattern and like to see

distance, speed and time
information to the airport.

Now select a parking position:

Go to Flight Plan -> Select a Start Position
 .

Choose one of the GA small ramp positions.

Click OK and the position will be highlighted on the map.



You can also select the start position directly on the
map context menu as described in Tutorial -

Building a VFR Flight Plan.
See also Set as Departure.

65.5. Search for Destination

Right-click into the result table and select Reset Search  to remove of all search criteria from the

recent search.

Now look for a suitable destination airport:

Right-click on EGHJ in the search result again.

Select Set Center for Distance Search . You can also do this in the map. This is the center

point
for the spatial search.

Clear the Ident search field on the top left of the search window now. It is a common mistake to

leave the text fields filled when doing distance searches which will
give you an empty result

table.

We will now look for airports that are in range of the aircraft but not
too close. Also, certain criteria

have to be fulfilled, like a runway
which is long enough and has the right surface.

You can also find airports in aircraft range by using the range rings
where you can right-click into the

map on your departure airport and
select Add Range Rings .

We will use the spatial search instead of range rings since we’d like to
see only suitable airports for out

aircraft.

Check the following in the airport search tab:

1. Rating: We’d like to get airports that are either add-ons or have
basic scenery requirements as

taxiways, parking spots and more.
Select the one with at least four stars.
You can also select 3D

if you fly X-Plane.

2. Procedures: Show only airports that have procedures like SID, STAR or approaches.



3. Deselect Military and Closed (click the checkboxes twice):
This will return only civilian airports

and avoid airports that have
all runways closed.

4. Select Any is Hard in the button Any Surface to avoid
airports having only soft surfaced runways.

5. Select a minimum runway length of 2,500 ft or whatever you chosen
aircraft needs in the field

Runways: Min:.

See also Search for general information about searching for airports, navaids and other features.

You can also limit the maximum runway length if you are looking for a
short landing challenge.

The search result changes on the fly while doing all these adjustments,
though we are not there yet:

Check Dist: to activate the spatial search.

Change the maximum distance to 600 NM and the minimum to 400 NM
(to avoid short hops).

The result table will now update with a
small delay since the distance search is more complex.

To find only airports north of your position select North in the
button Any Dir.. Note that the

search result is sorted by
distance with the closest airport first per default.

Choose an airport for your trip. Use Wick (EGPC) for this
tutorial.



Right-click on Wick in the result table and select
Show Information . This will fill the
tabs in

the dock window Information.

Select the tab Airport and below this one the tab Weather. Look for the section
Best runways for wind

to get an idea of the expected landing
runway. Start any third party weather programs before if

you use these.

For this tutorial we assume that the winds favor runway 13.

See also Weather for general information about weather display in Little Navmap.

65.6. Select an Approach Procedure

We’ll select an approach procedure now:

Go back to the search result.

Right-click on the airport Wick again. Select Show Procedures for
 . This will pop up the

procedure search tab.

Choose Runway 13 in the All Runways box to see only
approaches for 13.

Select Expand All in the context menu to see also the transitions
for each approach.

Choose Approach VORDME 13 FD13 using Transition (Full) CHINN
since we expect to land on runway 13.

You can also use any other approach for this runway
if VORDME 13 is not available.

The top label in the procedure search shows
Wick (EGPC) Approach VORDME 13 FD13 Transition (Full) CHINN for

the
selected approach and/or transition. You can also see a preview on the map.



Right-click on the transition and select
Show on Map (text might be different depending on selection)


. This will center the procedure on the map. You can click on the
legs in the procedure tree to see

the start and end points of a leg highlighted on the map.

See also Search Procedures and Procedures.

If you like what you see right-click again on the transition and select
Insert into Flight Plan, Use as

Destination and Use as Departure (text might be different depending on selection) .

This will do two things:

1. Add Wick as the destination airport to the flight plan. Any previous
destination in the flight plan

will be replaced.

2. Add the approach and its transition to the flight plan. The procedure
legs use a dark blue color

and the missed approach legs use a dark
red color in the flight plan table. Flight plan en-route

legs are
black. Any previous procedure is replaced with this new one.

About adding transition and approaches: Approaches and transitions
are closely related which is

already indicated by the tree structure in
the procedure search tab. You can add an approach without

transition but a transition
always belongs to an approach.



65.7. Calculate a Flight Plan

Now we have the departure airport, an approach procedure and the
destination all connected by a

straight line. Next is the en-route part
of the flight plan:

Set IFR as the flight plan type in the dock window Flight Planning on tab Flight Plan.
This allows

the automatic flight plan calculation to adjust the cruise altitude.

Click Flight Plan -> Flight Plan Calculation 
to open the flight plan calculation floating

window.

The flight plan cruise altitude is automatically adjusted according to
the hemispherical rule (the

rule can be changed in Tools ->
Options  on the page Flight Plan), the altitude
restrictions of

the airways and the flight plan type (VFR or
IFR). You can see the minimum altitude for each

airway segment in
the flight plan table in the column Restriction (see Table Columns).
The

altitude can be changed according to the hemispherical rule by clicking the Adjust button.

Change all settings in the floating window as shown in the screenshot above.

Click the button Calculate.

Use this flight plan for now.



Save the plan using File -> Save Flight Plan as LNMPLN .
The program usually finds the right

directory for the flight plans and
gives a meaningful name by default.

The top label in the flight planning dock window reads now:

Bembridge (EGHJ) / Parking 7 to Wick (EGPC)


Arrive via CHINN and VORDME FD13 (D13).


Land at 13, 129°M, 5.215 ft, 126 ft elevation, PAPI4.


Distance 538 NM, time 4 h 35 m.


Note that no departure runway information is given. Click Select Departure Runway  on the

toolbar to select one and save the plan.

Below the runway selection dialog and the result in the flight plan table after selecting runway 12 for

departure.
You can see the runway start point RW12 and the end of the extended runway center line

RW12+3.

The plan looks like shown below.



65.8. Airspaces

Now you can check if you pass through any airspaces:

Enable airspaces by selecting View -> Airspaces ->
Show Airspaces  if not already done.

Check View -> Airspaces -> At flight plan cruise altitude
  in the menu or the toolbar menu

button.



This will display only airspaces on the map that are relevant for your
cruise altitude. You can also select

Below 10,000 ft only to see all
relevant airspaces in the climb or descent phase. Use the tooltips on
the

map to get information about airspaces like type, minimum and
maximum altitude.

65.9. Saving

Save the plan in the Little Navmap format LNMPLN using File ->
Save Flight Plan .
The program

usually finds the right directory for the flight plans suggests a name
based on departure and

destination.



The format LNMPLN is only understood by Little Navmap. You cannot load these files
into another

program. Therefore, we have to export the flight plan.

Now open the multiexport options dialog by selecting File -> Multiexport Flight Plan Options.

Right click on the simulator format you’d like to export and select Export Flight Plan now .
Save

the file to the right place. The default path is based on best guess.

See here Quick Setup for information how to quickly configure the multiexport.

65.10. Flying

Follow the steps below to get a moving map and see your aircraft in
Little Navmap:

Open the dialog Connect using Tools ->
Flight Simulator Connection  and
check if Connect

automatically is selected. Enable it if not.
Little Navmap will find the simulator no matter if it is

already
started or will be started later.

Click on the tab which corresponds to your simulator.
Image below shows the tab for FSX, P3D

or MSFS on the left
and the tab for X-Plane on the right.

Click Connect which will close the dialog.

Enable Map -> Center Aircraft . The map will
jump to the simulator aircraft and keep it

centered if an active flight
is loaded, i.e. the simulator is not in the opening screen.

Start the simulator if not already done, load the flight plan and go flying.

Important

Make sure you use the right build of Little Navmap.
The 64-bit version shows only MSFS in the

connection tab while the 32-bit version shows FSX and P3D.

See also Connecting to a Flight Simulator.

65.11. Top of Descent



A top of descent indication is displayed on the map and in the elevation
profile which also shows the

distance from top of descent to the
destination. This number includes the distance of approach

procedures
(excluding holds).

Altitude restrictions in procedures are considered in the top of descent
calculation.

The tab Progress in the dock window Simulator Aircraft will show
the distance to the top of descent in the

Flight Plan Progress
section.

The section Altitude will show the vertical path deviation after
passing the top of descent.

65.12. Changing Procedures

Now the weather has changed requiring an approach to runway 31:

Right-click on the destination airport at the bottom of the flight
plan table.

Select Show Procedures for .

Then change the runway filter to Runway 31.

Expand the approach VORDME 31 to see the transition.

Select the transition.

The label on top of the window shows now
Approach VORDME 31 FD31 Transition (Full) CHINN.

Right-click on the selected transition.

Select Use EGPC and Approach and Transition as Destination  from the context
menu which will

replace the current procedure in your flight plan
with the new one.

The top label in the flight planning dock window reads now:

Bembridge (EGHJ) / Parking 7 to Wick (EGPC)


Takeoff from 12, 118°M, 2.729 ft.


Arrive via CHINN and VORDME FD13 (D13).


Land at 31, 309°M, 5.031 ft, 126 ft elevation, PAPI4.


Distance 519 NM, time 4 h 26 m.


To remove a procedure from the flight plan:

Select any leg of the procedure in the flight plan table.

Right-click and select Delete Selected Legs or Procedure  or press the Del key to remove

the
whole procedure.

Alternatively right click on any fix/waypoint of the procedure on the map
and select Delete from Flight

Plan .

If ATC clears you to the initial fix of the procedure:

1. Delete any intermediate waypoints between your current aircraft
position and the initial fix of

the procedure: Right-click in the
flight plan table and select Delete Selected Legs or Procedure


 for all waypoints between your
current aircraft position and the initial fix or start of the

procedure. Avoid deleting your approach (you can also right-click on
a flight plan waypoint on

the map and delete it from the context
menu).



2. Then right-click on your aircraft on the map and select
Add Position to Flight Plan .

This will give a direct connection from your current aircraft position
to the start of the procedure which

you can use to get course and
distance to the initial fix.

Below: After changing the approach procedure and adding an user defined
waypoint at the aircraft

position to the flight plan. Now we get course
and altitude indications for a direct leg to the start of the

transition
(43 NM and 314 degrees magnetic course).

65.13. Going Missed

I recommend hiding the missed approaches on the map by unchecking
View -> Show Missed

Approaches . This
helps uncluttering the map display.

If the missed approach is not shown: The progress window shows
distance and time to

destination. Activating the next leg (shown in
magenta color) will stop if the destination (i.e. the

runway
threshold) is reached, even when passing the threshold.

If the missed is shown and the aircraft passes the runway
threshold: The first leg of the

missed approach is activated and
simulator aircraft progress will display the remaining distance

to
the end of the missed procedure.



66. Tutorial - Creating an Aircraft Performance Profile

This tutorial shows how to automatically collect aircraft performance
while flying and how to create,

merge and fine tune the result.

You should be already familiar with the flight planning features of
Little Navmap.

66.1. Flight Plan

You can use the flight plan from the IFR tutorial is included in the
Little Navmap directory:
.../Little

Navmap/etc/Tutorial IFR Bembridge (EGHJ) to Wick (EGPC).lnmpln.

Use main menu File -> Open Flight Plan  to
load the flight plan.

The plan should cover the typical cruise altitude and travel distance
for your aircraft. A short hop of a

few miles at low altitude does not
suffice.

Tip

You can also fly and collect performance without a flight plan. Set the
intended cruise altitude in the

window Flight Planning to allow Little
Navmap to detect the cruise phase.

66.2. Aircraft Performance

First start by creating a new and empty performance profile by selecting
Aircraft -> New Aircraft

Performance 
in the main menu.

First page shows example aircraft name and type.

Second page shows default aircraft performance values. Click the image to enlarge.



Leave all as is in the dialog and click OK.

Ignore the warning and error messages in the fuel report for now.

Also ignore the zero values in the Fuel Plan Section.
Fuel flow data has to be entered in the

performance profile to get a valid fuel prediction.

Tip

Lookup numbers at the Aircraft Performance Database

[https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?] or download a community made performance file

from Little Navmap Downloads - Aircraft Performance

[https://www.littlenavmap.org/downloads/Aircraft%20Performance/] which can be used as a starting point.

Start and load a flight with aircraft engines running or not. Connect
Little Navmap to the simulator.

Select Flight -> Reset all for a new Flight  in the menu. Remove the check mark from
Create an

empty flight plan since a plan is already loaded.
Click OK to get a clean base for fuel calculation, logbook

and other
functions.

https://contentzone.eurocontrol.int/aircraftperformance/default.aspx?
https://www.littlenavmap.org/downloads/Aircraft%20Performance/


Fly and use typical load, climb and cruise performance settings in the
aircraft. Time compression is no

issue if you stay a few minutes at
cruise to allow Little Navmap collecting cruise fuel data.

You can see the detected aircraft type, detected flight phase (climb,
cruise and more) as well as all

current values collected and averaged by
Little Navmap in the tab Current Performance.

See chapter Aircraft Performance Collection for details.



New flight phases are added when detected. Note that the cruise phase is
only detected when flying at

flight plan cruise altitude. Set the cruise
altitude in the flight plan tab at least if you wish to collect

performance without a flight plan.



After landing and shutting off engines you can see the text
Current flight segment: Destination Parking,

Finished. in the tab
Current Performance.

You have a complete aircraft performance collection once the text
Finished. is shown which is right after

touchdown at the
destination.

Now select Aircraft -> Merge collected Aircraft Performance
  in the main menu to fill the
empty

performance profile with the collected values.

Note the header New Value (collected data) and Current Value
(currently loaded or created profile default

values) with the values
below.



We’d like to use all values for the new profile. Therefore, set all
operations to Copy in the dialog and

click OK.

You can also change the operations for each field individually or use
the operation Merge which will use

the average of the new and
current value. You can do a merge at any flight phase. For example, if

you’d like to fine tune the values during flight.
See Aircraft Performance Merge for more.

Adjust the performance using Merge when doing more flights after the first one.

Warning

Do not forget to add at least sufficient reserve fuel. Otherwise you
will run out of fuel at destination

if you rely on this plan.

You should change the usable fuel and values for alternate after
merging. Do this by selecting Aircraft -

>
Edit Aircraft Performance . Note that
required values have bold labels in the edit dialog.

It is also helpful to add notes like engine power settings in the
description file of a performance profile.

Example below for a Beech King Air C-90:



The chapter Aircraft Performance Edit explains
details about editing.

Tip

Use performance files for different cruise altitude ranges to get more
precise results for large or

complex aircraft. For example, one file for
FL300-FL350 and one for FL350-FL400.

Use Aircraft -> Save Aircraft Performance  and save the new performance file to any place like

Documents\Little Navmap\Performance, for example.

Think about sharing this file with others or send it to me so I can add
it to the community

download section of littlenavmap.org [https://www.littlenavmap.org/downloads/Aircraft%20Performance/] .

https://www.littlenavmap.org/downloads/Aircraft%20Performance/


67. Coordinate Formats

This chapter briefly describes the recognized coordinate formats in
flight plan position dialogs and

userpoint dialogs.

The input field shows a message below which indicates if the coordinates
were recognized and shows

the translated coordinates in the preset
format as selected in dialog Options on page Units. A red

message
is shown in case of error.

Check the displayed translated coordinates to verify that your input was
parsed correctly.

Editing an user defined flight plan position. Tooltip gives a quick help on coordinate formats.

67.1. General

Latitude has to be first and longitude second.

N/S and E/W designators are required except for the signed formats. Case does not matter.

Degree, minute and second signs can be omitted if numbers are separated by spaces.

A space is only required to separate latitude and longitude or degrees/minutes/seconds if no

unit signs are used.

Decimal separator can be period (English) or the locale dependent separator like e.g. comma

(German).

ARINC 424 Code Convention full degree waypoint formats like 57N30, 5730E or 57S30 can be read.

Full degree coordinate conventions, examples and respective quadrants.

All dialogs show the read coordinates below the input field in the curretly configured coordinate format.

See Units for more information.

Tip

You can directly paste coordinates from the Wikipedia like 40°41′21″N 74°2′40″W into the fields.

67.2. Signed Decimal Formats



For the coordinate formats Latitude and Longitude with sign and
Longitude and Latitude with sign:

Latitude: Negative is south and positive is north.

Longitude: Negative is west and positive is east values.

Selecting these display formats will also enable input of signed decimal
values.

Comma separated values like 50,07477,8,54053 (comma as German decimal separator) or 50.07477,8.54053

are valid. Spaces before and after the comma are allowed.

Note

The reading order for coordinates (Latitude and Longitude versus Longitude and Latitude)
will also change

depending on the selected format if entering signed numbers.

The reading order will not change if the input field uses N, S, E and W designators.

67.3. Other Formats

These have to be given exactly as shown in the examples.

Degrees and minutes: N44124W122451, N14544W017479 or S31240E136502

Degrees only 46N078W

Degrees and minutes 4620N07805W

Degrees, minutes and seconds 481200N0112842E (SkyVector)

Degrees and minutes in pair N6500 W08000 or N6500/W08000

NAT type 5020N

67.4. Examples

Degrees, minutes and seconds: N49° 26' 41.57" E9° 12' 5.49" or
49° 26' 41.57" N 9° 12' 5.49" E

Degrees and decimal minutes: N54* 16.82' W008* 35.95',
N 52 33.58 E 13 17.26 or 49° 26.69' N 9°

12.09' E

Decimal degrees only: 49.4449° N 9.2015° E or N 49.4449° E 9:2015°

ARINC 424 Code Convention full degree waypoint format: 57N30, 5730E or 57S30



68. Magnetic Declination

Little Navmap uses the magnetic
declination [https://en.wikipedia.org/wiki/Magnetic_declination] which
is stored

either with VOR stations (calibrated declination) or the actual environment declination. The
latter one is

calculated by the program using the world magnetic model.
(WMM

[https://en.wikipedia.org/wiki/World_Magnetic_Model]) or loaded
from the simulator scenery database.

Note that the magnetic declination of a VOR (also: calibration for VOR,
VORDME and VORTAC) may

differ from the actual declination in a simulator
region as it does in reality. The calibration of a VOR

might be very old
while the real declination in the environment changed in the meantime
due to the

movement of the magnetic poles. Therefore, magnetic course
values might differ when flying inbound

or outbound a VOR.

Little Navmap offers several options to display course labels along the flight plan line using
VOR

calibrated declination or not. This can be changed in Options on page Map Display Labels.

See Flight Plan for more information on the labels and
Magnetic Declination for more information about

declination and scenery databases.

Flight plan leg course label related option on page Map Display Labels.

Two flight plan legs showing the additional labels which are needed when using VOR navigation.
The VOR has a different

calibrated declination (21° East) compared to the actual declination (14.8° East) in this area.
Therefore the approach to

and departure from LTJ has to use the calibrated declination of the VOR station.
The two black and moving labels show the

magnetic departure course for the respective legs based on actual declination while
the two dark blue fixed labels show the

magnetic inbound and outbound course for the VOR based on the calibrated declination for LTJ.
Use the dark blue and fixed

labels when flying VOR to VOR and use the black moving labels when using a GPS.

Futhermore consider the different departure and destination true courses for Great Circle

[https://en.wikipedia.org/wiki/Great-circle_distance] routes. These appear at long flight plan legs.

https://en.wikipedia.org/wiki/Magnetic_declination
https://en.wikipedia.org/wiki/World_Magnetic_Model
https://en.wikipedia.org/wiki/Great-circle_distance


A long great circle course leg shown in Mercator projection to show the exaggerated course
difference in long flight plan

legs.
Note the different departure and arrival true courses which are a result of the
Great Circle

[https://en.wikipedia.org/wiki/Great-circle_distance] route.
Although it looks like a detour in the Mercator projection, the

great circle route is the shortest route between two points.

https://en.wikipedia.org/wiki/Great-circle_distance


69. Remarks

The edit fields Remarks allow multi line text and special characters for flight plans, flight
plan waypoints,

aircraft performance files and userpoints.
Formatted text like bold or markdown is not supported.

Links are recognized in the field Remarks and can be opened in
the dock window Information on tab Navaids

which is shown after
clicking on an userpoint or selecting Show Information in one of the
context menus,

for example.

The same applies to userpoints and aircraft performance remarks in the respective information
or fuel

report tabs.

Normal web links like http://www.example.com or
https://www.example.com are recognized besides directory or

file
links like file:///C:/Users/me/Documents/Aircraft%20Notes.txt on
Windows or

file:///home/me/Aircraft%20Notes.txt on macOS or Linux.

Note that you have to use the forward slash / instead of the
backslash \ on Windows as a path

separator.

Replace spaces in links with %20 since Little Navmap recognizes links only until the next space.



70. Keyboard Shortcuts

70.1. Main Menu

70.1.1. File

Menu Shortcut

File -> New Flight Plan Ctrl+N

File -> Open Flight Plan … Ctrl+O

File -> Save Flight Plan Ctrl+S

File -> Save Flight Plan as LNMPLN … Ctrl+Shift+S

File -> Reset all for a new Flight … Ctrl+Alt+Shift+R

File -> Export Flight Plan as MSFS 2020 PLN … Ctrl+Shift+F

File -> Export Flight Plan as P3D or FSX PLN … Ctrl+Shift+P

File -> Export Flight Plan as X-Plane FMS 11 … Ctrl+Shift+X

File -> Export Flight Plan as FlightGear FGFP … Ctrl+Shift+G

File -> Multiexport Flight Plan Ctrl+Shift+M

File -> Multiexport Flight Plan Options … Ctrl+Alt+Shift+M

File -> Copy Map Image to Clipboard … Alt+Shift+P

File -> Print Map … Ctrl+P

File -> Print Flight Plan … Ctrl+Alt+P

File -> Exit Ctrl+Q

70.1.2. Flight Plan

Menu Shortcut

Flight Plan -> Flight Plan F7



Menu Shortcut

Flight Plan -> Fuel Report F8

Flight Plan -> Undo Flight Plan Ctrl+Z

Flight Plan -> Redo Flight Plan Ctrl+Y

Flight Plan -> Select a Start Position … Ctrl+Shift+D

Flight Plan -> Select Departure Runway … Alt+Shift+R

Flight Plan -> Select Destination Runway … Alt+Shift+U

Flight Plan -> Edit Flight Plan on Map Ctrl+Shift+E

Flight Plan -> Flight Plan Calculation … Alt+Shift+C

Flight Plan -> Adjust Flight Plan Altitude Ctrl+Shift+J

Flight Plan -> Flight Plan Route Description … Ctrl+Shift+N

70.1.3. Map

Menu Shortcut

Map -> Goto Home Ctrl+Home

Map -> Goto Center for Distance Search Ctrl+End

Map -> Center Flight Plan Ctrl+PgDown

Map -> Jump to Coordinates … Ctrl+Shift+Home

Map -> Remove all Highlights and Selections Ctrl+H

Map -> Keep User Aircraft centered Ctrl+Alt+A

Map -> Delete Aircraft Trail Alt+Shift+T

Map -> Map Position Back Alt+Left

Map -> Map Position Forward Alt+Right



Menu Shortcut

Map -> More Map Detail Ctrl++

Map -> Default Map Detail Ctrl+0

Map -> Less Map Detail Ctrl+-

70.1.4. View

Menu Shortcut

View -> Reset Display Settings Ctrl+Alt+R

View -> Airports -> Show Airports Ctrl+Alt+H

View -> Airports -> Hard surface Ctrl+Alt+J

View -> Airports -> Soft surface Ctrl+Alt+S

View -> Airports -> Seaplane Bases Ctrl+Alt+U

View -> Airports -> Heliports Ctrl+Alt+X

View -> Airports -> Empty Ctrl+Alt+E

View -> Airports -> Add-on Ctrl+Alt+O

View -> Navaids -> Show VOR Stations Ctrl+Alt+V

View -> Navaids -> Show NDB Stations Ctrl+Alt+N

View -> Navaids -> Show Waypoints Ctrl+Alt+W

View -> Navaids -> Show ILS Feathers Ctrl+Alt+I

View -> Navaids -> Show Victor Airways Ctrl+V

View -> Navaids -> Show Jet Airways Ctrl+J

View -> Navaids -> Show Tracks Ctrl+T

View -> Airspaces -> Show Airspaces Ctrl+Alt+C



Menu Shortcut

View -> Show Flight Plan Ctrl+Alt+F

View -> Show Missed Approaches Ctrl+Alt+M

View -> Show User Aircraft Ctrl+Alt+B

View -> Show User Aircraft Trail Ctrl+Alt+T

View -> Show Selected Altitude Range Arc Ctrl+Alt+K

View -> Show Turn Flight Path Ctrl+Alt+L

View -> Show Aircraft Endurance Ctrl+Alt+G

View -> Show Compass Rose Ctrl+Alt+D

View -> Projection -> Mercator Map Projection Alt+Shift+M

View -> Projection -> Spherical Map Projection Alt+Shift+G

View -> Theme -> CARTO Dark Matter Ctrl+Alt+0

View -> Theme -> CARTO Positron Ctrl+Alt+1

View -> Theme -> MapTiler Topo * Ctrl+Alt+2

View -> Theme -> Mapbox Outdoors * Ctrl+Alt+3

View -> Theme -> Mapbox Satellite * Ctrl+Alt+4

View -> Theme -> Mapbox Satellite Streets * Ctrl+Alt+5

View -> Theme -> Mapbox User * Ctrl+Alt+6

View -> Theme -> OpenStreetMap Ctrl+Alt+7

View -> Theme -> OpenTopoMap Ctrl+Alt+8

View -> Theme -> StamenTerrain Ctrl+Alt+9

70.1.5. Userpoints



Menu ShortcutMenu Shortcut

Userpoints -> Userpoint Search F6

Userpoints -> Undo Userpoint Ctrl+Shift+Z

Userpoints -> Redo Userpoint Ctrl+Shift+Y

70.1.6. Logbook

Menu Shortcut

Logbook -> Logbook Search Shift+F6

Logbook -> Undo deleting of 3855 Logbook Entries Ctrl+Shift+Z

Logbook -> Redo Logbook Entry Ctrl+Shift+Y

70.1.7. Aircraft

Menu Shortcut

Aircraft -> Save Aircraft Performance Alt+Shift+S

Aircraft -> Edit Aircraft Performance … Alt+Shift+E

70.1.8. Scenery Library

Menu Shortcut

Scenery Library -> Load Scenery Library … Ctrl+Shift+L

70.1.9. Tools

Menu Shortcut

Tools -> Connect to Flight Simulator … Ctrl+Shift+C

Tools -> Toggle Flight Simulator Connection Ctrl+Shift+A

Tools -> Options … Ctrl+Shift+,

70.1.10. Window



Menu ShortcutMenu Shortcut

Window -> Shortcuts -> Map F2

Window -> Shortcuts -> Elevation Profile F3

Window -> Shortcuts -> Airport Search F4

Window -> Shortcuts -> Navaid Search F5

Window -> Shortcuts -> Userpoint Search F6

Window -> Shortcuts -> Logbook Search Shift+F6

Window -> Shortcuts -> Flight Plan F7

Window -> Shortcuts -> Flight Plan Calculation Shift+F7

Window -> Shortcuts -> Fuel Report F8

Window -> Shortcuts -> Airport Information F9

Window -> Shortcuts -> Airport Weather Information F10

Window -> Shortcuts -> Navaid Information Shift+F11

Window -> Shortcuts -> Simulator Aircraft Progress F12

Window -> Style -> Fusion Shift+F2

Window -> Style -> Night Shift+F3

Window -> Recent Window Layouts -> 1 Alex Small.lnmlayout Ctrl+Shift+W

Window -> Fullscreen Map F11

Window -> Show all floating Dock Windows Alt+0

Window -> Allow Window docking Alt+9

Window -> Search Alt+1

Window -> Flight Planning Alt+2



Menu Shortcut

Window -> Information Alt+4

Window -> Flight Plan Elevation Profile Alt+5

Window -> Simulator Aircraft Alt+6

70.1.11. Help

Menu Shortcut

Help -> User Manual (Online) F1

Help -> User Manual - Map Legend (Online) Shift+F1

70.2. Context Menus

70.2.1. Flight Plan Table

Menu Shortcut

Show Information Ctrl+I

Show Procedures Ctrl+Shift+R

Create Approach Alt+Shift+R

Activate Flight Plan Leg Ctrl+L

Move selected Legs up Ctrl+Up

Move selected Legs down Ctrl+Down

Delete selected Legs or Procedure Del

Edit Flight Plan Position Return

Copy Ctrl+C

Select all Ctrl+A

Clear Selection Ctrl+Shift+A



70.2.2. Search Result Tables and Search Input Fields

Using keyboard shortcuts like Ctrl+I for Show Information or Ctrl+M for Show on map
are usable directly from

the input fields and will apply to the topmost airport in the result table.

The same applies to other tabs like navaid and logbook search as well.

Menu Shortcut

Jump from any input field to table Down

Show Information Ctrl+I

Show Procedures Ctrl+Shift+R

Create Approach Alt+Shift+R

Show on Map Ctrl+M

Reset Search Ctrl+R

Show All Ctrl+Shift+O

Copy Ctrl+C

Select all Ctrl+A

Clear Selection Ctrl+Shift+A

70.2.2.1. Procedure Search - Additional Shortcuts

Menu Shortcut

Show Procedure on Map Return

Insert Procedure into Flight Plan Ctrl+Shift+I

Show Information for Airport Ctrl+I

Show Airport on Map Ctrl+M

70.2.2.2. Userpoint and Logbook Search - Additional Shortcuts

Menu Shortcut

Add Ins



Menu Shortcut

Edit Return

Delete Del



71. Network Setup

This chapter explains how to connect with a remote computer across the network to a simulator on a

flying computer.

Note

There is no need to share the scenery library or files of any simulator on the network.

You do not have to copy the simulator scenery library neither
do you have to install a second

simulator on the client computer.

71.1. How to Prepare a Network Setup

1. Install/extract the whole Little Navmap archive on the flying and the network computer.

2. Install Little Xpconnect into the X-Plane plugins directory if you use X-Plane. See Little

Xpconnect for details.

3. Use Little Navmap to generate the scenery database on the flying computer. Main menu ->

Scenery Library -> Load Scenery Library

4. Open the database directory on the flying computer using Tools -> Files and Directories -> Show

Database Files.

5. Copy the database files to the network computer. Always close Little Navmap
before copying.

See Databases for information on what is stored in what database file.
There is nothing else to

do on the remote computer after copying. The copied file is ready-to-use and there is no
need to

load the scenery library.

Note

Make sure that the major versions of Little Navmap and Little
Navconnect match, otherwise you

might get an error message. Use the
version of Little Navconnect which is included in the Little

Navmap
download archive if unsure.

71.2. Weather

71.2.1. FSX, P3D and MSFS

The weather information from P3D and FSX is transferred through the connection via Little Navconnect.

MSFS does not provide weather information at all.

71.2.2. X-Plane

Weather information like winds aloft and airport METARs are read from files in the X-Plane installation

folder.

Do the following to get access to X-Plane weather files:

1. Share the weather folders on the flying computer.
This is either the X-Plane 11 base folder

containing the files global_winds.grib and METAR.rwx or
the folder Output/real weather in the X-Plane

12 installation.

2. Open the Little Navmap options dialog and go to page Weather Files.
Change the path to the

network share containing the two X-Plane 11 files or the folder for the X-Plane 12 weather files.

Weather should update automatically in Little Navmap once done.

71.3. Flying in a network setup

Startup order does not matter.

Start the simulator



Start Little Navconnect on the flying computer.

Run Little Navmap on the network/remote computer.

Connect Little Navmap on the network/remote computer to Little
Navconnect on the flying

computer. Main menu -> Tools -> Flight Simulator Connection.

See the two chapters below for more details:

Running without Flight Simulator Installation: Detailed explanation how to copy scenery library

databases to a remote computer without a simulator installation.

Connecting to a Flight Simulator and chapter Remote Connection explains how to connect from a

remote computer in detail.



72. Little Xpconnect

Little Navmap connects to X-Plane using the Little Xpconnect
X-Plane plugin which has to be installed in

X-Plane.

The Little Xpconnect plugin is included in the Little Navmap archive. You can always find the
latest,

correct and matching version on your Little Navmap installation directory.

The plugin is 64-bit only and is available for Windows, macOS (ARM and Intel) and Linux and can be

used in X-Plane 11 and X-Plane 12.

See Installation below for installation instructions.

72.1. Menu

The plugin adds a sub-menu Little Xpconnect to the X-Plane menu Plugins which
contains the following

menu items:

Fetch AI: Enable or disable the fetching of AI aircraft and
ships (carrier and frigate). Disable AI

fetching if you see
stutters or performance degradation within X-Plane when using the plugin.

Load AI Aircraft Information: Xpconnect tries to load additional information
from related .acf files.

This is done in background and does not cause stutters
or hesitations. You can disable this

function if you see problems. Only limited
information is available for AI and multiplayer if

disabled.

Fetch Rate 50 ms to Fetch Rate 500 ms: Xpconnect will get all aircraft
parameters at this rate. Lower

values result in smoother aircraft movement (see more below) but
may induce stutters or

decrease performance in X-Plane.

The changes are applied immediately and are saved on exit.

Note that the settings are shared between all plugin installations on the same computer.

Note that the fetch rate affects only the rate of which Little Xpconnect gets the data from X-Plane.
This

can affect X-Plane performance, expecially when using large amounts of AI aircraft.

The option Update Time Interval in Connect Dialog in the Little Navmap connect dialog
window defines the

rate Little Navmap fetches the data from the plugin.
This affects Little Navmap performance and fluidity

of the aircraft updates together with the
setting Simulator aircraft updates in Options page Simulator

Aircraft.

It is recommended to keep both update rates equal and not lower than 100 ms.

72.2. Compatibility Error

If a pop up window says that versions are not compatible and and upgrade of Little Xpconnect is

needed:

Remove the Little Xpconnect plugin from X-Plane and reinstall the new one.

If the latest Little Xpconnect plugin is installed:

There is probably an old version of Little Xpconnect installed wrongly somewhere in your X-Plane

plugins path. Maybe it was installed accidentally in the plugins base path without the Little

Xpconnect folder structure.

Check if there is another folder with the Little Xpconnect executable (win.xpl, mac.xpl or lin.xpl

depending on operating system) around or if the file is stored in the plugins folder on the top

level.

You can see the path of the (wrongly) loaded plugin in the X-Plane plugin manager or in the X-

Plane Log.txt file.

72.3. Installation



Delete any old Little Xpconnect installations in the plugins directory before copying
the new version. Do

not merge new and old installations.

Copy the whole plugin directory Little Xpconnect into the directory Resources/plugins
in the X-Plane

installation. The complete path should look like:

.../X-Plane/Resources/plugins/Little Xpconnect

The installation was successful if you can see the menu Little Xpconnect in the X-Plane plugins menu.

When connecting with Little Navmap select the tab X-Plane in the connection dialog.
See also Flight

Simulator Connection.

72.4. macOS Architectures

The X-Plane plugin comes in two separate folders for different architectures.

1. Little Xpconnect arm64: This is for Apple computers having an Apple Silicon or an Intel CPU.
It

supports only newer macOS releases from Mojave 10.14 and later.

2. Little Xpconnect x86: This is only for Apple computers having an Intel CPU. This supports older

macOS releases from Sierra 10.12.

Install Little Xpconnect arm64 if in doubt.

72.5. Clearing the Quarantine Flag on macOS

You have to remove the quarantine flag from the plugin after downloading and extracting it.
Otherwise

X-Plane will silently not load the plugin.

The procedure may be slightly different depending on whether you’re using Big Sur or Catalina.

1. Copy the whole plugin folder Little Xpconnect into the folder plugins
in Resources in the X-Plane

installation. The complete path
should look like .../X-Plane 11/Resources/plugins/Little Xpconnect.

2. Right or Ctrl-Click in the Finder on the included script Prepare Little Xpconnect.command
in the folder

.../plugins/Little Xpconnect and select Open With and Terminal.

3. You will see a dialog Prepare Little Xpconnect.command cannot be opened because it is from
an

unidentified developer. Click Ok.

4. Go to System Preferences -> Security and Privacy. You will see a message mentioning
the script

Prepare Little Xpconnect.command. Click Open Anyway.

5. Next a dialog Are you sure you want to open it? pops up. Click Open.

The script shows a few explantions and asks for your password which allows it to run a
command as an

administrator. You can look at the script which is a text file to see what
commands are executed.

The installation was successful if you can see the menu Little Xpconnect in the X-Plane plugins menu.

You have to repeat this procedure each time you update Little Xpconnect.

Tip

Use the tool Mac OS - CleanUp Quarantine Flags [https://forums.x-plane.org/index.php?/files/file/79828-mac-os-cleanup-

quarantine-flags/] to
clean the flags for all X-Plane plugins. Place the downloaded and extracted

application in your
X-Plane base folder and double click it. A dialog window showing the number of

cleaned flags pops up after running.

72.6. Files

The Plugin creates a log file which can be found in

C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_xpconnect.log for Windows,

/tmp/abarthel-little_xpconnect.log for Linux and

/var/folders/RANDOMIZED_DIRECTORY_NAME/abarthel-little_xpconnect.log for macOS.

https://forums.x-plane.org/index.php?/files/file/79828-mac-os-cleanup-quarantine-flags/


Additionally a settings file is created which can be found in

C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_xpconnect.ini for Windows,

$HOME/.config/ABarthel/little_xpconnect.ini for Linux and macOS.

The settings can also be changed using the configuration file little_xpconnect.ini.

Little Xpconnect configuration file

[Options]


FetchAiAircraft=true     # Same as "Fetch AI" in plugin menu.


FetchAiAircraftInfo=true # Same as "Load AI Aircraft Information" in plugin menu.


FetchRateMs=200          # Data will be fetched from X-Plane every 200


                           milliseconds. Same as "Fetch Rate" in plugin menu.


FetchRate=200            # Old obsolete value. Will be deleted on start.




73. Customizing General

Little Navmap creates multiple configuration files in the directory

C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel when started. These allow extended customization of the

program.

This chapter shows the Windows file locations. See Files for locations on Linux and macOS.

The files use the Windows-INI style that has groups in square brackets and key=value lines. See
INI

(Wikipedia) [https://en.wikipedia.org/wiki/INI_file] for more information
about this type of configuration files.

Note

You have to restart Little Navmap to see any changes. Also,
do not edit the files while Little Navmap

is running since it might
overwrite your changes.

To undo all changes simply delete a file. It will be created again
containing the default values when

Little Navmap is started.

Single lines can also be deleted and will be restored with the default
value when Little Navmap is

started.

Keys and values are case sensitive. Order in the files is not important
if the keys remain in their

respective sections. The program might
reorder the keys when saving or updating the files.

73.1. Version

Some of the INI files contain a section [Options] with a key
Version as shown below.

[Options]


Version=2.0.1


Warning

Do not delete the version since Little Navmap relies on this information when updating
the file. It will

reset the file occasionally whenever the default
settings change. A backup will be created to save

your user
customizations

Keep this version section in all files. Otherwise, Little Navmap might reset the content.

Examples for backup files: little_navmap_mapstyle_backup_2.0.0.ini
or little_navmap_mapstyle_backup.ini.

The file will be backed up and reset if you delete or change the
version.

73.2. GUI

Two user interface styles can be customized. These are Fusion and Night.
These two styles are available

on all operating systems.

Two files are generated that allow the customization for all window,
button and dialog colors. These

are:

Fusion

C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_fusionstyle.ini

Night

C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_nightstyle.ini

The key names in these files are derived from the palette options of the Qt library.
Each key consists of

the group and role name separated by an underscore.
See below for more information on the color

https://en.wikipedia.org/wiki/INI_file


formats used.

See here for more information about
groups [https://doc.qt.io/qt-5/qpalette.html#ColorGroup-enum] and
roles

[https://doc.qt.io/qt-5/qpalette.html#ColorRole-enum].

73.3. Map Display

The file C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_mapstyle.ini
allows to customize various

aspects of the map display and is currently
limited to colors and pens. Most key names are self

explaining. See
below for more information about color values.

73.3.1. Color Format

Color can be in one of these formats which are commonly used in web
design:

#RRGGBB each of R, G, B and A is a single hex digit. Each color
value ranges from 00 - FF (decimal

0-255)

#AARRGGBB first two digits contain the alpha/transparency value.
00 equals to fully tranparent and

FF (decimal 255) to opaque.

SVG color name

SVG color name is one of the colors defined in the list of
CSS Colors

[https://www.w3schools.com/cssref/css_colors.asp];
for example, steelblue or gainsboro. Note that you cannot enter an

alpha channel value if you
use a color name.

You can use the w3schools color picker [https://www.w3schools.com/colors/colors_picker.asp]
or the
fffuel Simple

HEX, RGB & HSL color picker tool for web designers [https://fffuel.co/cccolor/] to get
the hex values for a

color.

Important

Most web color tools give you the color value in format #RRGGBBAA with the transparency at the end of

the string.
Convert this to the required value by putting the last two characters AA to the front to get

the needed #AARRGGBB.

Examples:

Active_Highlight=#308cc6

AlertFillColor=darkred

ApproachFillColor=#3060808a

73.3.2. Pen Format

A pen contains the following values in a comma separated list:

Color as described above

Pen width as a floating point value measured in pixels. You have to
use . as decimal separator

no matter what your locale defines.

Pen style. One of the following values: Solid, Dash, Dot,
DashDot and DashDotDot.

Examples:

RestrictedPen=#fd8c00, 2, DashDotDot

ModecPen=#509090, 2, Solid

NationalParkPen=#509090, 2.1, Solid

73.3.3. Level Configuration

https://doc.qt.io/qt-5/qpalette.html#ColorGroup-enum
https://doc.qt.io/qt-5/qpalette.html#ColorRole-enum
https://www.w3schools.com/cssref/css_colors.asp
https://www.w3schools.com/colors/colors_picker.asp
https://fffuel.co/cccolor/


Labels, symbols and zoom layer settings can be changed in the file maplayers.xml.

You can download the file here: maplayers.xml

[https://raw.githubusercontent.com/albar965/littlenavmap/release/2.8/resources/config/maplayers.xml].

Put a copy of this file into the Little Navmap settings folder
(C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\

on Windows) to override the stock settings.
Little Navmap will watch the file, reload it and redraw the

map when it is changed.

See the comments inside the file for more explanations.

Warning

Using wrong settings in this file can crash or freeze the program.

73.4. Icons

To change an icon download them from the GitHub source repository Icon
Resources

[https://github.com/albar965/littlenavmap/tree/release/2.8/resources/icons]
or extract the included file customize/icons.zip in

the installation folder.

Modify the icon and save it into the settings directory
C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel. Little

Navmap will
automatically detect and use the icon on next startup.

The formats are limited to PNG, JPG, GIF and SVG (Scalable Vector Graphics (SVG) Tiny 1.2

Specification [https://www.w3.org/TR/SVGMobile12]) where advanced
graphics effects like textures will not work.

You can use the free vector drawing program
Inkscape [https://inkscape.org] to edit SVG icons. Restart Little

Navmap to see the changes.

73.4.1. User, AI and Multiplayer Aircraft Icons

Default icons are included in file aircraft-icons.zip in installation folder customize.

All icons for user, AI/multiplayer aircraft, helicopters and ships are
stored in the program but can be

overloaded by the user.

The icons are:

aircraft_boat.svg

aircraft_boat_ground.svg

aircraft_boat_ground_user.svg

aircraft_boat_user.svg

aircraft_helicopter.svg

aircraft_helicopter_ground.svg

aircraft_helicopter_ground_online.svg

aircraft_helicopter_ground_user.svg

aircraft_helicopter_online.svg

aircraft_helicopter_user.svg

aircraft_jet.svg

aircraft_jet_ground.svg

aircraft_jet_ground_online.svg

aircraft_jet_ground_user.svg

aircraft_jet_online.svg

aircraft_jet_user.svg

aircraft_online.svg

aircraft_online_ground.svg

aircraft_small.svg

aircraft_small_ground.svg

aircraft_small_ground_online.svg

https://raw.githubusercontent.com/albar965/littlenavmap/release/2.8/resources/config/maplayers.xml
https://github.com/albar965/littlenavmap/tree/release/2.8/resources/icons
https://www.w3.org/TR/SVGMobile12
https://inkscape.org/


aircraft_small_ground_user.svg

aircraft_small_online.svg

aircraft_small_user.svg

Only used in X-Plane:

aircraft_carrier.svg

aircraft_carrier_ground.svg

aircraft_carrier_ground_user.svg

aircraft_carrier_user.svg

aircraft_frigate.svg

aircraft_frigate_ground.svg

aircraft_frigate_ground_user.svg

aircraft_frigate_user.svg

The suffixes are chosen by vehicle type, status (ground or airborne) and
user or AI/multiplayer. The

icon is for airborne vehicles if ground
is missing and for AI/multiplayer vehicles if user is missing. For

historical reasons all icons are prefixed with aircraft.

73.4.2. Userpoint Category Icons

Default icons are included in file userpoint-icons.zip in installation folder customize.

Icons for userpoint categories are stored in the program but can be
overloaded by the user as well.

Default category icons can be overloaded with another icon by placing a
file with one of the default

category names in the settings directory.

New categories can be added by placing a new icon adhering to a certain
name pattern in the default

directory.

userpoint_Airport.svg

userpoint_Airstrip.svg

userpoint_Bookmark.svg

userpoint_Building.svg

userpoint_Cabin.svg

userpoint_Closed.svg

userpoint_DME.svg

userpoint_Error.svg

userpoint_Flag.svg

userpoint_Helipad.svg

userpoint_History.svg

userpoint_Landform.svg

userpoint_Lighthouse.svg

userpoint_Location.svg

userpoint_Logbook.svg

userpoint_Marker.svg

userpoint_Mountain.svg

userpoint_NDB.svg

userpoint_Obstacle.svg

userpoint_Other.svg

userpoint_POI.svg

userpoint_Park.svg

userpoint_Pin.svg

userpoint_Radio Range.svg

userpoint_Seaport.svg

userpoint_Settlement.svg

userpoint_TACAN.svg

userpoint_Unknown.svg

userpoint_VOR.svg



userpoint_VORDME.svg

userpoint_VORTAC.svg

userpoint_VRP.svg

userpoint_Water.svg

userpoint_Waypoint.svg

The text between the first underscore _ and the .png ending
defines the category. For example

userpoint_My Places.png creates a
new category My Places.

Do not use special characters like / for categories. Only letters,
digits, space, underscore and dashes

are allowed. Special characters like umlauts or accented
characters are no problem.



74. Map Themes

74.1. Installing Map Themes

Additional map themes can be installed in the directory set in options on page Cache and Files,
section

Map Display Themes. You have to enter a valid path there before using map themes.

New maps come as downloads with different directory structures. Some contain the base folder

data\maps\earth in the downloaded archive some do not.
Each map installed theme has to consist of a

directory containing the related .dgml and other files.
The name of the map directory and the .dgml file

have to match. For example .../norway-topo/norway-topo.dgml.

Note that you have to restart Little Navmap to see the new map themes.

Select map theme folder Documents\Little Navmap Files\Map Themes in options. The status line below the path
shows a

valid directoy and one map theme found. Click image to enlarge.



Installing a map theme from a ZIP file OpenStreetMap French.zip. The compressed file contains the subdirectory

data\maps\earth.
You have to copy the directory osm-fr containing the file osm-fr.dgml
into your selected map theme

directory Documents\Little Navmap Files\Map Themes.

You have to restart Little Navmap to see the new map themes. Click image to enlarge.

Tip

Also check out the Little Navmap Support Forum at
AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-

little-navconnect-little-logbook-support-forum/],
Little Navmap Downloads - Map Themes

[https://www.littlenavmap.org/downloads/Map%20Themes/] and
LittleNavmapOFMTheme

[https://github.com/AmbitiousPilots/LittleNavmapOFMTheme] for more map themes.

74.2. Creating Map Themes

To add an arbitrary online or offline map to Little Navmap simply add
the map directory from a

downloaded or self created map theme to the
data\maps\earth directory.

Note that you need to restart Little Navmap to see the new map themes in the menu.

Tip

Also check out the Little Navmap Support Forum at
AVSIM [https://www.avsim.com/forums/forum/780-little-navmap-

little-navconnect-little-logbook-support-forum/],
Little Navmap Downloads - Map Themes

[https://www.littlenavmap.org/downloads/Map%20Themes/] and
LittleNavmapOFMTheme

[https://github.com/AmbitiousPilots/LittleNavmapOFMTheme] for more map themes.

https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/
https://www.littlenavmap.org/downloads/Map%20Themes/
https://github.com/AmbitiousPilots/LittleNavmapOFMTheme
https://www.avsim.com/forums/forum/780-little-navmap-little-navconnect-little-logbook-support-forum/
https://www.littlenavmap.org/downloads/Map%20Themes/
https://github.com/AmbitiousPilots/LittleNavmapOFMTheme


The full path to the DGML file (see links below for more details about DGML) describing the map must

be
...\Little Navmap\data\maps\earth\opencyclemap\opencyclemap.dgml if
you like to add the OpenCycleMap

[https://www.opencyclemap.org] for
example. The DGML file can refer to an online map service or included

offline map data. Usually a map theme contains many more files than only
the DGML.

The menu View -> Theme in the main menu and the toolbar drop
down box will receive an entry for

each additional map theme.

The option Show Country and City Names is
enabled for all additional map themes but might not work

depending on
properties defined in the map’s DGML file.

See the comments in the included file data\maps\earth\example\example.dgml or here online
example.dgml

[https://raw.githubusercontent.com/albar965/littlenavmap/release/2.8/marble/data/maps/earth/example/example.dgml] for more

information.

More maps and information about map configuration and DGML files can be
found here on the Marble

and KDE pages:

Download more maps for the Marble widget (only Earth maps are
supported in Little Navmap):

Additional
Maps [https://marble.kde.org/maps.php]

A tutorial that shows how to create a map theme based on tiled
images:
Marble/CustomMaps

[https://techbase.kde.org/Marble/CustomMaps]

A tutorial showing how to create a map theme based on OSM Slippy
Maps

[https://wiki.openstreetmap.org/wiki/Slippy_map_tilenames]:
How to create map themes based on OSM slippy

maps [https://techbase.kde.org/Marble/OSMSlippyMaps]

How to create a historical map for Marble: Historical Maps for
Marble

[https://techbase.kde.org/Marble/HistoricalMaps]

https://www.opencyclemap.org/
https://raw.githubusercontent.com/albar965/littlenavmap/release/2.8/marble/data/maps/earth/example/example.dgml
https://marble.kde.org/maps.php
https://techbase.kde.org/Marble/CustomMaps
https://wiki.openstreetmap.org/wiki/Slippy_map_tilenames
https://techbase.kde.org/Marble/OSMSlippyMaps
https://techbase.kde.org/Marble/HistoricalMaps


75. Files

Note that file locations can be overridden using command line options. See Command Line Options for

more information.

File paths will differ if using one of the portable scripts (Portable Execution).

Tip

You can open all file locations from the main menu Tools -> Files and Directories.

75.1. Backups

Little Navmap creates a copy of the most important files on startup and keeps up to three additional

backup files: ..._backup.sqlite to ..._backup.sqlite.2, for example. You can copy these files
back to the

original if you did something wrong.

This applies to the files for Userpoints, Logbook and Trails.

Furthermore, Little Navmap creates backups of important files when starting an updated version to

avoid accidental data loss.
These files end with ..._update-backup.1 to ..._update-backup.3.

75.2. Logs

Log files of Little Navmap are stored in the directories:

Windows: C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_navmap.log

Linux: /tmp/abarthel-little_navmap.log

macOS: /var/folders/RANDOMIZED_DIRECTORY_NAME/abarthel-little_navmap.log
Use the command below on

the macOS terminal to find the log file and open it in Text Edit.
Save the file to another place

from where you can attach it to an email.

open -a TextEdit $(find /private/var/folders/ -name abarthel-little_navmap.log 2>/dev/null)


The Little Navmap keeps up to two log files and rotates these if
the file size of 10 MB is exceeded. So

you may find up to two log files abarthel-little_navmap.log and abarthel-little_navmap.log.1.

Send the log file abarthel-little_navmap.log if you like to report
an error. All two are needed in some

cases but sending the first is often sufficient.

Note

Please compress log and other files before sending them by email.

75.3. Trails

Aircraft trails are stored in separate files:

little_navmap.track: The main user aircraft trail shown on the map. Binary file. This trail can be

exported

as a GPX using Export Flight Plan as GPX in the menu File.

little_navmap.logbooktrack and little_navmap_profile.track are temporary files for saving trails.

75.4. Configuration

The files use the Windows-INI style that has groups in square
brackets and key=value lines. See
here

[https://en.wikipedia.org/wiki/INI_file] for more information
about this type of configuration files.

https://en.wikipedia.org/wiki/INI_file


All configuration files for my programs are stored in these directories:

Windows: C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel

macOS: /Users/YOURUSERNAME/.config/ABarthel

Linux: $HOME/.config/ABarthel

little_navmap.ini: INI style configuration file. Text file. Can be opened with Open Configuration

File.

little_navmap.history: The map position history. This is a binary file which cannot be opened in

text editors.

little_navmap.lnmpln: Temporary flight plan file in LNMPLN format. This is used to reload changed

flight plans without manual save.

Three more configuration files are created for customization of colors
and styles:

little_navmap_fusionstyle.ini: INI style configuration file for
customizing the GUI colors of the style

Fusion.

little_navmap_nightstyle.ini: As above but for the style
Night.

little_navmap_mapstyle.ini: INI style configuration file. Text
file. Used for customization of the map

display.

See Customizing General for more information.

Note

Note that Little Navmap might reset these files when being updated,
but only after creating backup

files. This is usually mentioned in the
change log.

75.5. Disk Cache

The disk cache that is used to store all the downloaded online map tile
images can be found here:

Windows: C:\Users\YOURUSERNAME\AppData\Local\.marble\data\maps\earth

macOS: /Users/YOURUSERNAME/.local/share/marble/maps/earth

Linux: $HOME/.local/share/marble/maps/earth

The cache directory earth contains one folder for each installed map theme.

You can delete the cache manually to save space if Little Navmap is not running.

Cache size can be changed on page Map Display in options.

75.6. Databases

Databases are stored in the directories:

Windows: C:\Users\YOURUSERNAME\AppData\Roaming\ABarthel\little_navmap_db

macOS: /Users/YOURUSERNAME/.config/ABarthel/little_navmap_db

Linux: $HOME/.config/ABarthel/little_navmap_db

All these databases are SQLite [http://sqlite.org] files which can
be viewed with e.g. DB Browser for
SQLite

[https://github.com/sqlitebrowser/sqlitebrowser/releases] if
you’re interested in relational databases.

The directory can be opened with Show Database Files.

Warning

Do not modify, move, rename or delete databases while Little
Navmap is running.

Do not let the Navigraph FMS Database Manager update databases
while Little Navmap is running.

Little Navmap might crash,
the update might fail or remain incomplete.

http://sqlite.org/
https://github.com/sqlitebrowser/sqlitebrowser/releases


75.6.1. Scenery Library

The number of files depends on which simulators you have installed and
which scenery libraries you

have loaded.

The files are:

little_navmap_.sqlite: An empty dummy database. Can be ignored.

little_navmap_fsx.sqlite: Flight Simulator X

little_navmap_fsxse.sqlite: Flight Simulator - Steam Edition

little_navmap_p3dv4.sqlite: Prepar3D v4

little_navmap_p3dv5.sqlite: Prepar3D v5

little_navmap_p3dv6.sqlite: Prepar3D v6

little_navmap_msfs.sqlite: Microsoft Flight Simulator 2020

little_navmap_xp11.sqlite: X-Plane 11

little_navmap_xp12.sqlite: X-Plane 12

little_navmap_navigraph.sqlite: Navigraph navdatabase. Can be
either the included database or an

update installed by the Navigraph
FMS Data Manager.

75.6.2. Userpoints

The file little_navmap_userdata.sqlite contains the user defined
waypoints.

Little Navmap creates a copy on startup and keeps up to three additional
backup files:

little_navmap_userdata_backup.sqlite to
little_navmap_userdata_backup.sqlite.2. You can copy these files
back

to the original database little_navmap_userdata.sqlite if you
did something wrong.

Tip

Open this folder in your file manager using Show Database Files select the
userpoint database and

hit Ctrl+C (copy file) and Ctrl+V (paste file).
This will add a copy of the database which will be named

little_navmap_userdata (1).sqlite or similar.

This is the fastest way to create a backup.

You can apply the same to the Logbook files.

75.6.3. User Airspaces

The file little_navmap_userairspace.sqlite contains the user defined
airspaces read by using Load User

Airspaces.

It is backed up in the same way as the userpoints.

75.6.4. Logbook

The file little_navmap_logbook.sqlite is used to store logbook
entries.

Little Navmap creates copies on startup and keeps up to two additional
backup files for the user

defined waypoints as described above.

75.6.5. Other Database Files

Additional files like

little_navmap_compiling.sqlite,

little_navmap_compiling.sqlite-journal,

little_navmap_temp.sqlite,

little_navmap_temp.sqlite-journal,

little_navmap_onlinedata.sqlite or

little_navmap_onlinedata.sqlite-journal



are used by temporary processes like the database compilation or online
network data. These can be

ignored.

75.7. Little Navmap Flight Plan File Format

LNMPLN files are flight plan files using the format specific to Little Navmap. They are in XML
text

format and can only be interpreted by Little Navmap. You can use any text editor to modify or look at

the files.

See XML (Wikipedia) [https://en.wikipedia.org/wiki/XML] for more information
about this file type.

The XML schema for validation can be found here: lnmpln.xsd [https://www.littlenavmap.org/schema/lnmpln.xsd].

Order of elements does not matter. Missing elements will be logged as warning except optional ones.

Flight Plan File Example. Documentation included as XML comments:

<?xml version="1.0" encoding="UTF-8"?>


<LittleNavmap xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"


              xsi:noNamespaceSchemaLocation="https://www.littlenavmap.org/schema/lnmpln.xsd">


  <Flightplan>





    <!-- Coordinates are always latitude and longitude in decimal/signed notation -->


    <!-- Altitude in feet. -->





    <!-- ====== Header with metadata ====== -->


    <Header>


      <FlightplanType>IFR</FlightplanType>                 <!-- IFR or VFR as set in user interface -->


      <CruisingAlt>30000</CruisingAlt>                     <!-- feet -->

      <CruisingAltF>30000.0000</CruisingAltF>              <!-- Feet. Optional floating point altitude 

avoid


                                                                rounding issues when using metric values 

-->


      <CreationDate>2020-09-11T18:05:15+02</CreationDate>  <!-- Local time with timezone offset -->


      <FileVersion>1.0</FileVersion>                       <!-- File format version -->


      <ProgramName>Little Navmap</ProgramName>

      <ProgramVersion>2.6.0.beta</ProgramVersion>          <!-- Little Navmap version used for saving -->


      <Documentation>https://www.littlenavmap.org/lnmpln.html</Documentation>


      <Description>Flight plan remarks</Description>       <!-- Remarks as entered in user interface tab 

Remarks. -->


    </Header>


    <SimData>MSFS</SimData>                    <!-- Use simulator and AIRAC if available -->


    <NavData Cycle="2008">NAVIGRAPH</NavData>  <!-- Use navdata and AIRAC -->





    <!-- ====== Used aircraft performance ====== -->


    <AircraftPerformance>


      <FilePath>Normal Climb and Descent all Equal.lnmperf</FilePath>


      <Type>BE51</Type>


      <Name>Normal Climb and Descent</Name>

    </AircraftPerformance>





    <!-- ====== Departure parking position ====== -->


    <Departure>


      <Pos Lon="-120.538055" Lat="46.569828" Alt="1069.00"/>


      <Start>PARKING 1</Start>    <!-- Name of position -->


      <Type>Parking</Type>        <!-- Type of position.


                                       None, Airport, Runway, Parking or Helipad. -->


      <Heading>5.1</Heading>      <!-- True heading of the position -->


    </Departure>





    <!-- ====== Departure and arrival procedures ====== -->


    <Procedures>


      <!-- SID and STAR are resolved by name and runway when loading -->


      <SID>


        <Name>WENAS7</Name>             <!-- SID name. Only five character SIDs. -->


        <Runway>09</Runway>             <!-- SID departure runway if applicable. -->


        <Transition>PERTT</Transition>  <!-- Transition name if used -->


      </SID>


      <!-- Alternative to SID. Selected runway for departure plus length of runway extension line. -->


      <SID>


      <Name>KYKM9</Name>


https://en.wikipedia.org/wiki/XML
https://www.littlenavmap.org/schema/lnmpln.xsd


        <Runway>9</Runway>


        <Type>CUSTOMDEPART</Type>


        <CustomDistance>3.00</CustomDistance>


      </SID> -->


      <STAR>


        <Name>PIGLU4</Name>             <!-- STAR name. Only five character SIDs. -->


        <Runway>16</Runway>             <!-- STAR arrival runway if applicable. -->


        <Transition>YDC</Transition>    <!-- Transition name if used -->


      </STAR>


      <!-- Approaches are resolved by either ARINC or the combination of Name, Runway, Type and Suffix --

>


      <Approach>


        <Name>TATVI</Name>                   <!-- Optional approach name. Name of approach fix.


                                                  ARINC is required if this is not given. -->


        <ARINC>I16-Z</ARINC>                 <!-- ARINC name of the approach.


                                                  Type, runway and optional suffix. -->


        <Runway>16</Runway>                  <!-- Optional approach runway.


                                                  Not given for circle-to-land approaches. -->


        <Type>ILS</Type>                     <!-- Optional approach type -->


        <Suffix>Z</Suffix>                   <!-- Optional approach suffix -->


        <Transition>HUMEK</Transition>       <!-- Transition name if used -->


        <TransitionType>F</TransitionType>   <!-- Optional Transition type if available. -->


      </Approach>


      <!-- Alternative to approach. Selected runway for approach plus length of runway extension line,


           altitude at start of final and offset angle.


      <Approach>


        <Name>CYLW34</Name>


        <Runway>34</Runway>


        <Type>CUSTOM</Type>


        <CustomDistance>3.00</CustomDistance>


        <CustomAltitude>1000.00</CustomAltitude>

        <CustomOffsetAngle>0.00</CustomOffsetAngle>


      </Approach> -->


      </Procedures>





    <!-- ====== Alternate airports ====== -->


    <Alternates>


      <Alternate>


        <Name>Penticton</Name>                                 <!-- Optional name -->


        <Ident>CYYF</Ident>                                    <!-- Required ident -->


        <Type>AIRPORT</Type>                                   <!-- Optional type -->


        <Pos Lon="-119.602287" Lat="49.462452" Alt="1122.00"/> <!-- Optional position.


                                                                    Helps to resolve the correct 

airport. -->


      </Alternate>


      <Alternate>


        <Name>Grand Forks</Name>


        <Ident>CZGF</Ident>


        <Type>AIRPORT</Type>


        <Pos Lon="-118.430496" Lat="49.015633" Alt="1393.00"/>


      </Alternate>


    </Alternates>





    <!-- ====== En-route waypoints including departure and destination ====== -->


    <!-- The elements Ident, Type and Pos are required to resolve the waypoint in the database.


         Region is optional and used for resolving if given.


         Procedure waypoints are never included. -->


    <Waypoints>





      <!-- ====== Departure airport. Other waypoint types are allowed for flight plan snippets. ====== --

>


      <Waypoint>


        <Name>Yakima Air Terminal/Mcallister</Name>


        <Ident>KYKM</Ident>


        <Type>AIRPORT</Type>


        <Pos Lon="-120.543999" Lat="46.568199" Alt="1069.00"/>


      </Waypoint>





      <!-- ====== User defined waypoint ====== -->

      <Waypoint>


        <Name>User defined point</Name>


        <Ident>USERPT</Ident>


        <Region>K1</Region>


        <Type>USER</Type>




        <Pos Lon="-120.848000" Lat="47.676601" Alt="24960.89"/>


        <Description>User waypoint remarks</Description>       <!-- Remarks as entered in user interface -

->


      </Waypoint>





      <!-- ====== Direct to waypoint ====== -->


      <Waypoint>


        <Ident>DIABO</Ident>


        <Region>K1</Region>


        <Type>WAYPOINT</Type>


        <Pos Lon="-120.937080" Lat="48.833759" Alt="30000.00"/>


      </Waypoint>





      <!-- ====== Airway waypoints ====== -->


      <Waypoint>


        <Ident>IWACK</Ident>


        <Region>K1</Region>


        <Airway>J503</Airway>  <!-- Airway leading towards this waypoint -->


        <Type>WAYPOINT</Type>


        <Pos Lon="-120.837067" Lat="48.932140" Alt="30000.00"/>


        <Description>Waypoint remarks</Description>


      </Waypoint>


      <Waypoint>


        <Ident>CFKNF</Ident>


        <Region>K1</Region>


        <Airway>J503</Airway>


        <Type>WAYPOINT</Type>


        <Pos Lon="-120.767761" Lat="49.000000" Alt="30000.00"/>


      </Waypoint>





      <!-- ====== Destination airport.


                  Other waypoint types are allowed for flight plan snippets. ====== -->


      <Waypoint>


        <Name>Kelowna</Name>


        <Ident>CYLW</Ident>


        <Type>AIRPORT</Type>


        <Pos Lon="-119.377998" Lat="49.957199" Alt="1461.00"/>


      </Waypoint>


    </Waypoints>


  </Flightplan>


</LittleNavmap>


75.8. Aircraft Performance File Format

LNMPERF files are files containing aircraft performance files using the format specific to Little Navmap.

They are in XML
text format and can only be interpreted by Little Navmap.

See XML (Wikipedia) [https://en.wikipedia.org/wiki/XML] for more information
about this type of configuration

files.

The XML schema for validation can be found here: lnmperf.xsd [https://www.littlenavmap.org/schema/lnmperf.xsd].

Order of elements does not matter. Missing elements will be logged as warning except optional ones.

Aircraft Performance File Example. Documentation included as XML comments:

<?xml version="1.0" encoding="UTF-8"?>


<LittleNavmap xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"


              xsi:noNamespaceSchemaLocation="https://www.littlenavmap.org/schema/lnmperf.xsd">


  <AircraftPerf>





     <!-- ====== Header with metadata ====== -->


    <Header>


      <CreationDate>2020-11-16T22:43:35</CreationDate>


      <FileVersion>1.0</FileVersion>


      <ProgramName>Little Navmap</ProgramName>

      <ProgramVersion>2.6.4.beta</ProgramVersion>


      <Documentation>https://www.littlenavmap.org/lnmperf.html</Documentation>


    </Header>





     <!-- ====== Options ====== -->


    <Options>


https://en.wikipedia.org/wiki/XML
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      <Name>Epic E1000 G1000 Edition</Name>  <!-- Aircraft name - free text -->


      <AircraftType>EPIC</AircraftType>      <!-- Aircraft ICAO type which is matched to simulator 

aircraft ICAO type -->


      <Description>Climb: 80% torque, 1600 RPM, 160 KIAS, max ITT 760°


Cruise: FL260-FL280, 1400 RPM, adjust torque to 55 GPH fuel flow, max ITT 760°


Descent: Idle, 250 KIAS





https://www.littlenavmap.org</Description>  <!-- Remarks as entered in user interface tab Remarks. -->


      <FuelAsVolume>0</FuelAsVolume>        <!-- 0: Used fuel unit is lbs. 1: Used fuel unit is gal. -->


      <JetFuel>1</JetFuel>                  <!-- Indicator for fuel type needed when switching between


                                                 units in user interface.


                                                 Also checked for simulator aircraft. -->


    </Options>





    <!-- ====== Performance data. All values are either lbs or gallons depending on FuelAsVolume.


                Speed is always TAS. Vertical speed is always ft/min. Fuel flow measure in unit per 

hour. ====== -->


    <Perf>


      <ContingencyFuelPercent>5.0</ContingencyFuelPercent>


      <ExtraFuelLbsGal>0.000</ExtraFuelLbsGal>


      <MinRunwayLengthFt>1600.000</MinRunwayLengthFt>


      <ReserveFuelLbsGal>500.000</ReserveFuelLbsGal>


      <RunwayType>SOFT</RunwayType>                    <!-- Either HARD (hard only), SOFT (hard and 

soft),


                                                            WATER (water only) or WATERLAND (equals to 

either WATER or SOFT) for amphib -->


      <TaxiFuelLbsGal>20.000</TaxiFuelLbsGal>


      <UsableFuelLbsGal>1900.000</UsableFuelLbsGal>

      <Alternate>


        <FuelFlowLbsGalPerHour>361.000</FuelFlowLbsGalPerHour>


        <SpeedKtsTAS>302.000</SpeedKtsTAS>


      </Alternate>


      <Climb>


        <FuelFlowLbsGalPerHour>464.807</FuelFlowLbsGalPerHour>


        <SpeedKtsTAS>185.220</SpeedKtsTAS>


        <VertSpeedFtPerMin>2479.589</VertSpeedFtPerMin>


      </Climb>


      <Cruise>


        <FuelFlowLbsGalPerHour>361.000</FuelFlowLbsGalPerHour>


        <SpeedKtsTAS>302.000</SpeedKtsTAS>


      </Cruise>


      <Descent>


        <FuelFlowLbsGalPerHour>222.000</FuelFlowLbsGalPerHour>


        <SpeedKtsTAS>201.000</SpeedKtsTAS>


        <VertSpeedFtPerMin>2000.000</VertSpeedFtPerMin>


      </Descent>


    </Perf>


  </AircraftPerf>


</LittleNavmap>




76. Tips and Tricks

76.1. Show all Navaid Ranges of a Flight Plan

Select all legs in the flight plan table, then right-click on any leg
and select Show Navaid Range . This

will place a
range ring around every radio navaid in the flight plan.

See also Add Navaid Range Ring.

Remove the range rings by right clicking onto the center and select
Remove Range Ring from the context

menu.

Radio navaid range rings along a flight plan. Click image to enlarge.

76.2. Use the measurement lines to get a VOR Radial Intersection

Measurement lines can start at airports or navaids where they use the
magnetic declination if available.

You can use them to find an airport by
radial and distance if you like to navigate the old fashioned way.

See also Measure Distance from here.



Example that gets radial and distance from two VORs for
ETUO. Measurement lines can also start at NDBs or waypoints.

Note
the suffix °M which indicates magnetic course. Click image to enlarge.

The same can be used when flying airways without GPS. In the example
below fly 323 degrees magnetic to VOR SFD (radial

143). You are at
WAFFU when the DME shows 13.7 NM. Then turn left to
280°M until you intercept 302° to GWC. Click image

to enlarge.

76.3. Search for Add-On Airports

You can use the scenery path to look for add-on airports of a certain
developer. Click on one of the

add-on airports and copy the relevant
part of the path from the information window. Insert this path

fragment
into the Scenery Path input field in the airports tab of the search
dock window. Add * at the

beginning and at the end since it is only
part of a path.

See also Text filters.



Select all in the result table to get all airports highlighted on the map. Click image to enlarge.

76.4. Use the Search Function to plan a Round the World Trip

The spatial search function is useful to plan a round the world tour.
Assume you’d like to go east:

1. Go to the dock window Search, right-click into the result table
and select Reset Search  to

remove all search
criteria that may affect the query.

2. Set your departure airport.

3. Right-click on your departure airport in the search or on the map and
select Set Center for

Distance Search . This is the center point for the spatial search.

4. Add any additional criteria in the search like lighted runways,
procedures, fuel, minimum runway

length and more.

5. Click the checkbox before Distance, adjust the minimum and maximum
distance and set direction

to East.

6. Select all in the result table to see the airports on the map.

7. Choose your next destination airport.

8. Add as destination.

9. Calculate plan.

10. Fly.

11. Back to 2. until you are done around the world.



The image above shows a query result for airports in the east. Note that
the black/yellow highlight circles have tooltips too

no matter if the
airport is visible or not. Click image to enlarge.



-h, --help

--help-all

-v, --version

-s, --settings-directory <settings-directory>

-p, --settings-path <settings-path>

77. Command Line Options

Several command line options to define paths or files to load are available.

Start Little Navmap with the help option littlenavmap.exe -h (Windows),
"Little

Navmap.app/Contents/MacOS/littlenavmap" -h (macOS) or ./littlenavmap -h (Linux) to get more
information on

the terminal or the command line.

Note that paths or files containing spaces or special characters have to be put in double quotes ".

Example: Load a flight plan file:

littlenavmap.exe --flight-plan "IFR Ireland West Knock (EIKN) to Benbecula (EGPL).lnmpln"

Example: Create a flight plan from the given route description:

littlenavmap.exe -d "KYKM WENAS7 PERTT 4741N12051W DIABO J503 FOLDY YDC PIGLU4 CYLW CYYF CZGF"

All files passed to Little Navmap without one of the - or -- options below are checked for file type
and

loaded into the program.
All supported flight plan formats are loaded (see Open Flight Plan for a list) as

well as .lnmperf aircraft performance
files ( Open Aircraft Performance) and .lnmlayout window layout

files (Open Window Layout).

For all files without an option specifying the type, the file type is detected by the content and not by

the extension.

All files are passed to an already running Little Navmap instance, if detected. This will activate the

other window
and pass all files or parameters on the command line to the other instance. This applies

to the options
--flight-plan, --flight-plan-descr, --aircraft-perf and --layout. This is functional on all

supported
operating systems. A question dialog might appear asking to discard changes, if any.

Note

--flight-plan-descr reads the route string using the current options set in the drop down menu button

in the Flight Plan Route Description dialog window.

Warning

Any unsaved flight plan in progress (visible * in main window title bar but no filename)
will be

overwritten without further notice if using
one of the options to load a flight plan or route

description.

77.1. Options

Both short and long options are available.

Displays help on command line
options.

Displays help including Qt
specific options.

Displays version information.

Use <settings-directory>
instead of ABarthel. This
does not override the full

path. Spaces are replaced with
underscores.

Use <settings-path> to store
options and databases into the
given

directory.
<settings-path> can be relative
or absolute. Missing
directories

are created. Path
can be on any drive.



-l, --log-path <settings-path>

-c, --cache-path <cache-path>

-f, --flight-plan <flight-plan>

-d, --flight-plan-descr <flight-plan-descr>

-a, --aircraft-perf <aircraft-perf>

-y, --layout <layout>

-g, --language <language>

Use <log-path> to store log
files into the given directory.
<log-path> can

be relative or
absolute. Missing directories
are created. Path can be on any

drive.

Use <cache-path> to store
tiles from online maps. Missing
directories are

created. Path
can be on any drive.

Load the given <flight-plan>
file on startup. Can be one of
the supported

formats like
.lnmpln, .pln, .fms,
.fgfp, .fpl, .gfp or
others.

Parse and load the given
<flight-plan-descr> flight plan
route description

on startup.
Example EDDF BOMBI LIRF.

Load the given <aircraft-perf>
aircraft performance file
.lnmperf on startup.

Load the given <layout> window
layout file .lnmlayout on
startup.

Use language code <language>
like de or en_US for the
user interface. The

code is not
checked for existence or
validity and is saved for the
next

startup.



78. Appendix

78.1. Tips for slow Computers

Dialog Options -> Map -> Details while scrolling ...: Use
Normal ...

Dialog Options -> Simulator Aircraft ->
Simulator Aircraft scroll box size ...: Use a higher value to

reduce map updates.

Close the window Flight Plan Elevation Profile. It will stop all
background processing when closed.

Avoid airspaces. Switch them off using the  button on
the airspaces toolbar.

Switch off all AI traffic in the dialog Connect. See
Options.

Use the map projection Mercator. It consumes less resources since
it can use the downloaded

image tiles as is and does not transform
them to the spherical format.

78.2. Troubleshoot

See also Little Navmap - Frequently asked
Questions [https://albar965.github.io/littlenavmap-faq.html] which is

updated regularly.

78.3. Known Problems and Frequently asked Questions

See also Little Navmap - Frequently asked Questions [https://albar965.github.io/littlenavmap-faq.html] which is

updated regularly.

78.4. How to report a Bug

Please use either the forum or email to avoid confusion and additional effort. Please do not

use both.

If something goes wrong send me all available information like flight plans, links to add-on sceneries,

Little Navmap’s log file and configuration files. See chapter Files for file paths.

Contact and Support [https://albar965.github.io/contact.html]

Provide as much information as possible if you’d like to report a problem:

1. A screenshot of the full Little Navmap window including title or a flight plan depending on issue

might be helpful at first.

2. The version of Little Navmap.

3. Information about used add-on airports if applicable.

4. Operating system:

Windows: 10 or 11.

macOS: Catalina or Big Sur

Linux: which distribution and version

5. Simulator:

X-Plane: 11.55 or 12 version

FSX, FSX SE, P3D or MSFS including version

Navdata updates if scenery is affected

6. Add flight plans or other files if involved in the error.

Please add all steps that are necessary to reproduce the error.

When an error occurs during loading of the scenery library send me the
offending file if size permits.

The full name and path of the file is
shown on top of the error dialog if a specific is the cause.

Note

If you’re concerned about privacy when sending log files:

The log files contain system paths (like your Documents directory) which
will also include your

username as a part of the path. They might also
contain your computer’s name and IP address in

https://albar965.github.io/littlenavmap-faq.html
https://albar965.github.io/littlenavmap-faq.html
https://albar965.github.io/contact.html


your network.

I would suggest you remove this information if you’re concerned about it.

In no case are file names of anything but the flight simulator or its
configuration files included. No

names or contents of personal files are
included in the log files.

I strongly recommend sending the log files by private forum message or
by email and not attach them

to forum posts where they are publicly
visible.

Please …

Compress all files using ZIP when sending by email.



79. Glossary

3D

X-Plane airport which contains at least one 3D object. May be a fully
constructed major airport.

Airport

Means all airports, water airports, airstrips or heliports.

Add-on airport

FSX/P3D: All scenery data that is found outside of the base flight
simulator Scenery directory is

considered an add-on.

X-Plane: All airports in the Custom Scenery directory are considered
add-on airports and will be

highlighted accordingly.

Microsoft Flight Simulator 2020: All airports located in the Community
directory and the

Official\OneStore or Official\Steam are considered to be add-on airports.
Exceptions are fs-base, fs-

base-genericairports and fs-base-nav.

Approach Procedure

An approach procedure is a series of maneuvers for the transfer of an
aircraft in instrument flight

conditions from the initial approach to a
landing or to a point from which a landing may be made

visually. If a
flight plan includes a standard arrival procedure (STAR), an approach
procedure will

normally follow the STAR.

Arrival Procedure

Approach, transition or STAR procedure.

BGL

A binary file with the extension BGL which is part of a flight
simulator scenery containing airport,

navaid or airway information.
These files can also contain traffic, landclass, elevation or other

information which is not relevant for Little Navmap.

Checkbox

A user interface element that allows to toggle a setting between two states (on and off)
or three

states (on, off and not applicable).

CSV

Comma-separated values text file.

DAT

A text file format used by X-Plane to store airport, navaid and
procedure information.

Departure Procedure

SID (standard instrument departure) procedure.

Dialog

A dialog window requiring user input. Most dialogs block the whole applicaton until closed.

DME

Distance measuring equipment or a radio navaid.

Empty airport

An airport that has no taxiways, no parking positions or gates, no
aprons and is not an add-on

airport and is not a water airport.

FACF

Final approach course fix. A point aligned on the final approach course
of an instrument

procedure.

FAF



Final approach fix. The point where the final approach segment begins on
the instrument

approach.

Fix

This term refers to a waypoint, radio navaid or an calculated point on a
procedure. A fix might be

defined by VOR radial and distance, for example.

Flight Plan Position

An user defined waypoint which is part of the flight plan.

FLP

Flight plan format used by the X-Plane FMS, Aerosoft Airbus and other
add-on aircraft.

FMS

Flight plan format used by X-Plane 11 and 12. Can be loaded into the stock GPS, FMS or add-ons.

FS9

Flight Simulator 2004.

FSX

Flight Simulator X or Flight Simulator - Steam Edition.

ft

Feet. 0.3048 meter.

GIS

A geographical information system like Google Earth for example.

LDA

Localizer type directional aid. A type of localizer-based instrument approach to an airport.

IGS

Instrument guidance system – a modified ILS to accommodate a non-straight approach.

ILS

Instrument landing system.

Initial Fix

This is the first fix of a procedure.

Intersection

In aviation, an intersection is a virtual navigational fix that helps aircraft maintain their flight plan.

This manual also uses the synonym waypoint.

Logbook Entry

Created by the user or automatically on finishing a flight containing takeoff and landing.

LNMPLN

Own flight plan format of Little Navmap.

MAP

Missed approach point. The point on the final approach which represents
the termination of the

final approach and the start of the missed
approach.

MSFS

Microsoft Flight Simulator 2020.

Navaid

VOR, VORTAC, TACAN, NDB or waypoint/intersection. Also ILS and Localizer.

NDB

Non directional beacon - radio navaid.



NM

Nautical miles. 1.852 km, 1’ (one minute or 1/60°) latitude or 1’ longitude at the Equator.

P3D

Prepar3D v3 to v5.

Parking

GA ramp, cargo ramp, fuel box or gate at an airport.

PLN

FSX and P3D flight plan format.

POI

Point of interest. An userpoint type.

Procedure

A STAR, SID or approach and the respective transitions.

Radio navaid

VOR, VORTAC, TACAN or NDB.

Rating

Airport zero to five star rating depending on facilities.

Scenery Library Database

This is an internal database (SQLite [http://sqlite.org]) that is
created by Little Navmap when reading

all the flight simulator BGL or
DAT files. It allows fast complex searches and map display.

SDF

Simplified directional facility is a localizer-based instrument non-precision approach to an
airport,

which provides a final approach course similar to ILS and LDA approaches, but not as
precise.

SID

A standard instrument departure is an air traffic control departure
procedure that helps to simplify

clearance delivery procedures. A SID
will keep aircraft away from terrain but it is optimized for air

traffic
control route of flight and does not necessarily provide the best climb
gradient. It provides

a balance between terrain and obstacle avoidance,
noise abatement and airspace management.

SimConnect

A programming interface that allows applications to read and write
flight simulator parameters

from FSX, P3D and MSFS.

STAR

A standard terminal arrival is a flight route that usually covers the
phase of a flight between the

last point of the route filled in the
flight plan and the first point of the approach to the airport,

normally
the initial approach fix (IAF). A STAR connects the en-route phase with
the approach

phase of the flight.

Start position

Used for departure in flight plans. Either runway, helipad, GA ramp,
cargo ramp, fuel box or gate.

TACAN

Tactical air navigation system - radio navaid used by military aircraft.

TOC

Top of climb.

TOD

Top of descent.

VOR

VHF omni directional radio range - radio navaid.

http://sqlite.org/


VORDME

VHF omni directional radio range with distance measuring equipment - radio navaid.

VORTAC

Co-located VHF omnidirectional range (VOR) beacon and tactical air
navigation system (TACAN)

beacon.

Userpoint

An user defined waypoint like a bookmark, point of interest or visual reporting point (VRP).

User Feature

Any display object like traffic patterns or measurment lines which can be added or removed by the

user.

UTC

Universal coordinated time. Also Zulu time.

VRP

Visual reporting point for VFR flights. An userpoint type.

Waypoint

It is a navaid defined by coordinates. Synonym for intersection in this manual.



80. License

This program is free software: you can redistribute it and/or modify it
under the terms of the GNU

General Public License as published by the
Free Software Foundation, either version 3 of the License, or

(at your
option) any later version.

This program is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without

even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the

GNU General
Public License for more details.

You should have received a copy of the GNU General Public License along
with this program. If not, see

http://www.gnu.org/licenses [http://www.gnu.org/licenses/].

http://www.gnu.org/licenses/


Index



Note

Keep in mind that actual altitude shown in Little Navmap might differ from indicated altitude even

with a correct baro setting.

This is an effect of the outside air temperature (OAT) on actual altitude where low temperatures

affect the aircraft altimeter.
When temperature is less than ISA conditions an aircraft will be lower

than the altimeter reading.

This effect is currently modeled in X-Plane 12 and MSFS.

Corrections have to be applied when the aerodrome temperature is 0°C or colder:

DH/DA or MDH/MDA and step-down fixes inside the final approach fix (FAF).

All low altitude approach procedure altitudes in mountainous regions (terrain of 3000 ft AMSL

or higher)

See SKYbrary - Altimeter Temperature Error Correction [https://skybrary.aero/articles/altimeter-temperature-error-

correction]
for more information.

https://skybrary.aero/articles/altimeter-temperature-error-correction


Warning

Always save a copy in the default LNMPLN format before exporting to other
formats. This allows

Little Navmap to restore all flight plan
properties like procedures, alternate airports and remarks.

Note that the LNMPLN format is only understood by Little Navmap.
Do not try to load it into

simulators or add-ons.
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