43. Flight Plan Multiexport

Multiexport simplifies flight plan export and enables saving to several formats at once with a single click into the toolbar, a click into the menu (File -> Multiexport Flight Plan Multiexport Flight Plan) or using the keyboard shortcut Ctrl+Shift+M.

The dialog makes use of tooltips. Hover the mouse cursor above rows and buttons for more information.

_images/multiexport.jpg

Overview of the multiexport features with the related menu items highlighted. Screenshot based on Little Navmap 2.6. Click image to enlarge.

43.1. Quick Setup

The export function is disabled initially until at least one format is enabled for export in File -> Multiexport Flight Plan Options Multiexport Flight Plan Options.

Export paths are pre-filled where known. This is done when first opening the dialog and considers the current simulator selection (Scenery Library Menu). A best guess is used if not applicable.

Adapt the default paths if needed. You can edit a path by double clicking on it or using the button Select Export Path which will open a file dialog for selection.

The footer line below the table shows error messages and an example export file name and path.

Check the box on the left of a row or use the context menu to enable for a format for export. The row text will be shown bold if enabled.

Adjust the selection in Export Options and choose if you like to overwrite files or if you would like to see a file dialog for each saved format.

Click Ok when done.

The flight plan will be exported when using menu File -> Multiexport Flight Plan if a correct path is entered and the box is checked.

Tip

You can also export flight plans manually from the multiexport options dialog by clicking on the button Export Flight Plan now Export Flight Plan now.

Note

Note that Little Navmap does not clean up the exported directories. All old flight plans remain and have to be removed manually from time to time.

Consider exported flight plan files as disposable since almost all the export formats have limitations resulting in data loss. Remember that you can always restore them by loading the original LNMPLN file and exporting again.

See also Flight Plan Formats for more information on the supported flight plan formats.

43.2. File Names

Saving LNMPLN

The default file name used when saving LNMPLN files using the functions Save Flight Plan or Save Flight Plan as LNMPLN can be set in the options dialog on page Flight Plan. See Pattern for default LNMPLN flight plan names.

Export other Formats

Little Navmap always uses file names based on the pattern set in the column File Name Pattern and Extension when running an multiexport or starting an export from the menu File.

43.3. Exporting Little Navmap native flight plan format

Exporting the Little Navmap native flight plan format with file extension LNMPLN via multiexport is a special case compared to the other formats. Enabling this for export saves you a few extra clicks for storing the file.

The following happens if LNMPLN is saved with multiexport:

  • The file name is automatically assigned by using the selected pattern in the options dialog on page Flight Plan (Pattern for default LNMPLN flight plan names). If the file was already saved with another name when doing Save Flight Plan as LNMPLN or Save Flight Plan then this name is used.

  • Little Navmap saves the file into the path set in the multiexport options dialog.

  • The current file is marked as clean. This means that the * is cleared from the window title and Little Navmap will not ask to save the file once exiting or creating a new plan.

  • Further saves (menu File -> Save Flight Plan) will use the automatically assigned file name and path.

See also Little Navmap LNMPLN Format.

Note

Always save a copy in the default LNMPLN format before exporting to other formats. This allows Little Navmap to restore all flight plan properties like procedures, alternate airports and remarks.

Note that the LNMPLN format is only understood by Little Navmap. Do not try to load it into simulators or add-ons.

43.4. Path Errors

The path is highlighted red once a format is enabled for export with a non existing directory or file. Hover the mouse above the path to see more detailed error messages.

Directories (files for some export formats) have to exist for the export to work.

_images/multiexporterr.jpg

Error message in tooltip for X-Plane FMS export. Hover mouse cursor above red text to see this. Also selected is the MSFS flight plan export without path errors.

43.5. Running Multiexport

A dialog is shown, if any unsupported features are detected in the current flight plan when trying to save a plan. You can disable this dialog for future saves.

Pressing Cancel in this dialog stops the export. No files will be exported.

Depending on the setting in the Export Options button Little Navmap will also show a file dialog for each exported file.

You can enable saving of waypoints by checking the menu items Export Waypoints for Approaches, Export Waypoints for SID and STAR or Export Waypoints for Airways. These three options affects all flight plan export formats except the native LNMPLN format.

43.6. Multiexport Options Dialog

43.6.1. Export Format Table

You can click on the table headers to sort the content. Tooltips as well as the footer line below the table give more information on formats and path errors.

Columns can be moved and resized by clicking and dragging the table header. The table layout is saved and can be reset by choosing Reset View in the context menu of the table.

See Tables for general information on tables.

43.6.1.1. Enable / Change Path / Export Now / Reset Path

The first column contains several buttons which provide the same functions as the context menu.

43.6.1.1.1. Checkbox

The checkbox on the far left enables the respective format for export and highlights the row in bold text. Path errors are only shown if the format is enabled.

43.6.1.1.2. Select Export Path Select Export Path

Opens a file or directory selection dialog to enter the path. Some export formats need a file to append flight plan information instead of a directory to save a file.

43.6.1.1.3. Export Flight Plan now Export Flight Plan now

Opens a file dialog for immediate export of the current flight plan. You can also export formats which are not enabled.

43.6.1.1.4. Reset Export Path Reset Export Path

Resets the path back to default. The default path is determined by the current scenery library or simulator selection. If not applicable, the best estimate from installed simulators and Scenery Library Menu selection is used.

43.6.1.2. Category

Category for the export format.

43.6.1.3. Usage

Short description of the export format and the product for which it is used.

43.6.1.4. Filename Pattern and Extension

The pattern is used to build filenames when exporting flight plans. The file suffix like .lnmpln, .pln or .fgfp is a part of the pattern.

The following keywords are recognized:

  • PLANTYPE: IFR or VFR

  • DEPARTIDENT: Departure airport ident.

  • DEPARTNAME: Departure airport name.

  • DESTIDENT: Destination airport ident.

  • DESTNAME: Destination airport name.

  • CRUISEALT: Cruise altitude.

Keywords are case sensitive and have to be entered in upper case. All other characters are are used as entered.

Double click or press the key F2 to edit the file pattern directly.

An example filename and error messages are shown in the dialog footer below the table.

Examples (Filename Pattern and Extension, Export Path and result):

DEPARTIDENT-DESTIDENT.fms, X-Plane 11/Output/FMS plans:

X-Plane 11/Output/FMS plans/EDDF-LIRF.fms

DEPARTIDENT-DESTIDENT X-Plane 12 Beta at CRUISEALT.fms, X-Plane 12/Output/FMS plans:

X-Plane 12/Output/FMS plans/EDDF-LIRF X-Plane 12 Beta at 10000.fms

43.6.1.5. Export Path

Target directory for the exported files. Double click or press the key F3 to edit the path directly. You can copy and paste paths from the Windows Explorer into this field, for example.

An example and error messages are shown in the dialog footer below the table.

43.6.2. Export Options

Three options can be selected in the drop down box. These apply to all export formats.

43.6.2.1. Show file dialog for every exported format

Opens a file or directory selection dialog for each enabled export format once Multiexport Flight Plan is used. The dialog allows to cancel an export or change the file name or path.

Pressing cancel in this dialog does not stop the export process for further formats.

43.6.2.2. Do not show file dialog. Backup existing files in case of conflict

Present files are backed up to a maximum of four files and the new file is saved in place. Little Navmap does not check for changed files. You might see backups which are equal if you save too often.

Example: Saving the plan from ENKB to LICR several times in X-Plane FMS format:

  • Latest plan: ENKB-LICR.fms

  • Backups: ENKB-LICR_1.fms, ENKB-LICR_2.fms, ENKB-LICR_3.fms, ENKB-LICR_4.fms

43.6.2.3. Do not show file dialog. Overwrite files without warning

Present files with the same name are overwritten. Be careful with this option, especially when using the Exporting Little Navmap native flight plan format option.

This helps to reduce clutter in the output directories but may overwrite flight plan files.

Warning

No backup will be created when saving with this option enabled.

43.6.3. Help

Opens this chapter in the online help.

43.6.4. Ok

Takes over all changes and closes the dialog.

43.6.5. Export Selected Formats

Export all formats without closing the dialog. This is the same as selecting Multiexport Flight Plan in the main menu File.

43.6.6. Cancel

Discards all changes except table formatting and closes the dialog.

43.7. Context Menu

Right click into the flight plan format table to open the context menu.

43.7.1. Enable Export

Selects format for multiexport. Same as the Select Export Path button.

43.7.2. Export Flight Plan now Export Flight Plan now

Save the format now. Same as the Export Flight Plan now button.

43.7.3. Select Export Path Select Export Path

43.7.4. Edit Path

Allows to edit the path directly. This is the same as double clicking into the path field or pressing F3.

43.7.5. Reset Export Path Reset Export Path

Reset path back to default. Same as the Reset Export Path button.

43.7.6. Edit Filename Pattern

Edit the filename pattern directly. This is the same as double clicking into the path field or pressing F2.

43.7.7. Reset Filename Pattern

Reset the filename pattern back to default.

43.7.8. Reset all Paths, Filename Patterns and Selection Stated

Resets all paths and filename patterns back to defaults also considering the current simulator selection. This is the same as clicking Reset Export Path in each row.

Also disables all flight plan formats for export.

43.7.9. Reset View Reset View

Resets column size and column order back to default.

43.7.10. Increase, Decrease and Default Text Size

Changes the text size in the table. The size is saved.